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Legal notices

Legal notices
For legal notices, see http://help.adobe.com/en_US/legalnotices/index.html.

A note to our customers
Adobe provides this searchable PDF of archived technical support documents as a service to our 
customers who own and continue to enjoy older, unsupported versions of our software products. The 
information in these documents is not updated, and will become increasingly less accurate as 
hardware, browsers, and operating systems continue to evolve. Please be aware that these archived 
documents reflect historical issues and solutions for products that are no longer supported. Adobe 
does not warrant that the information in this document is accurate.
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Using FileMaker in Dreamweaver via Lasso Studio

Issue
FileMaker is not a database supported by Dreamweaver for creating dynamic database-driven web applications 
(ColdFusion, ASP, ASP.NET, JSP and PHP).

Reason
Because of problems concerning FileMaker's ODBC connectivity feature, FileMaker is not one of the natively 
supported databases when it comes to creating dynamic web applications in Dreamweaver. The following databases are 
natively supported by Dreamweaver:

• Microsoft Access

• Microsoft SQL Server

• MySQL (PHP only)

• Oracle

Databases that are not listed above, such as FileMaker, may work with Dreamweaver, but they have not been tested by 
Macromedia's engineers and Macromedia does not provide support for those databases.

Solution
If you would like to use FileMaker as the database for your web application, there is a third-party product available for 
purchase: the Lasso Studio for Dreamweaver by Blue World. The Lasso Studio installs Lasso objects into Dreamweaver, 
which facilitate the visual creation of Lasso Dynamic Markup Language (LDML) pages that run on a Lasso web 
application server. Because Lasso can communicate with FileMaker in the database's native language, FDML 
(FileMaker Dynamic Markup Language), the ODBC connectivity issue is averted.

Currently, Lasso Studio 5 is only compatible with Dreamweaver 4 and Dreamweaver UltraDev 4. The next version of 
Lasso Studio (out later in 2002) is slated to support Dreamweaver MX.

Note: Macromedia does not provide technical support for third-party software or extensions, such as Lasso Studio for 
Dreamweaver. Please contact Blue World if you need assistance.

Additional Information
• FileMaker white paper on FileMaker, Dreamweaver UltraDev and JSP

http://www.filemaker.com/downloads/pdf/FMPU55_UltraDev.pdf
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Uninstall Dreamweaver CS3 | Mac OS
Adobe Dreamweaver CS3 comes with an uninstaller on Mac OS. If you remove Dreamweaver CS3, use the uninstaller 
instead of manually deleting application folders by dragging them to the trash. Manually deleting folders before using 
the uninstaller can cause problems when you try to reinstall Dreamweaver CS3.

Remove Dreamweaver CS3 using the uninstaller
The uninstaller is designed to remove everything installed by Dreamweaver CS3.

Note: When you run the uninstaller, you are reminded to deactivate your software. If you plan to reinstall the 
Dreamweaver CS3 on the same machine, then considering keeping your activation.

Use the uninstaller on Mac OS
Navigate to /Applications/Utilities/Adobe Installers and double-click the Add or Remove Adobe Dreamweaver CS3 
alias. Follow the onscreen instructions to remove Dreamweaver CS3.

Remove Dreamweaver using the Adobe CS5 Cleaner Tool
If you manually removed Dreamweaver CS3 by dragging it to the trash and are having problems reinstalling it, then 
run the Adobe CS5 Cleaner Tool. 

Download the Adobe CS5 Cleaner Tool from http://www.adobe.com/support/contact/cs53clean.html and follow the 
instructions included with the script.

Unable to assign keywords in pages created from a 
template

Issue
 Users are unable to add keywords or other meta tags to a page created from a template, whether they use the menu 
command Insert> Head > Keywords or the Head category, Keyword button of the Object Palette. 

Note: This is not an issue for newer versions of Macromedia Dreamweaver. If you are using a template created in an 
older version of the application, you may need to use the solution listed below. Otherwise, you should have no problems 
adding meta tags to a page based on a template in newer versions of Dreamweaver. 

Reason
 Both the Keyword button of the Object Palette and the menu command are attempting to insert the code for the 
keywords in a line of the noneditable <head> section of the HTML. 

Note: The <head> section of the HTML in a page created from a template is not editable except for the title information 
section. 
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Solution
 The keywords can be added to the page by manually typing the meta tag and the keywords after the <title> tag in the 
source code. 

To add keywords to a page created from a template do the following:

1 Open the HTML source code (Window > HTML).

2 Locate the <title> section that begins with the following comment line:<!--#BeginEditable "doctitle" --> Refer to the 
following example code:
 <html><!--#BeginTemplate "/Templates/myTemplate.dwt" --><head><!--#BeginEditable 
"doctitle" --><title>Untitled Document</title><!-- #EndEditable --><meta http-
equiv="Content-Type" content="text/html; 

 
   charset=iso-8859-1"></head><body > 

3 Type the following code after the <title> line and before the EndEditable comment line typing your keywords 
separated by commas between the empty quotes.<meta name="keywords" content=" "> Refer to the following 
example for correct placement of the line of code.

<html><!--#BeginTemplate "/Templates/myTemplate.dwt" --><head><!--#BeginEditable "doctitle

Troubleshoot synchronization problems in 
Dreamweaver CS4 and CS5

Issue
When you use Adobe Dreamweaver CS4 and CS5 to synchronize files or upload files to a server, you experience one of 
the following issues:

• When you put files, Dreamweaver warns you that the remote file has changed on the server: "my_file.htm has 
changed on the remote server since your last get or put operation. Putting it could overwrite changes to the file. Do 
you wish to put the file anyway?" However, you are sure that the remote files haven't changed.

• The Synchronize preview dialog box does not correctly list the files that require synchronization.

• The Synchronize preview dialog box says that no synchronization is necessary, but you know that some files have 
changed.

Note: Synchronization underwent major enhancements in Adobe Dreamweaver 8. The current version of Adobe 
Dreamweaver CS4 and CS5 uses similar technology.

Solution
Complete one of the following two solutions, depending on how widespread the synchronization problems are.

Solution 1: Delete the specific dwsync.xml files.
Perform these steps if only a few of your files have synchronization problems.

1 Close Dreamweaver.

2 In Windows Explorer or Mac Finder, browse to the folder that contains the files with synchronization problems.
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3 For each folder containing files with synchronization problems, locate the _notes folder and delete the dwsync.xml 
file inside it.Note: The dwsync.xml files only reside locally. Dreamweaver never uploads the dwsync.xml files to the 
server, and there is no reason to upload them to the server.

4 Reopen Dreamweaver and verify that the problem is resolved.

Solution 2: Disable the "Maintain synchronization information" setting.
Perform these steps if you are experiencing widespread synchronization problems.

Note: Dreamweaver re-creates the synchronization information for your site.

1 Choose Site > Manage Sites, select the site you want to edit, and click Edit.

2 Deselect the Maintain Synchronization Information setting to delete the existing dwsync.xml files. The options vary 
between CS4 and CS5.

• CS4

a In the Advanced category of the Site Definition dialog box, choose Remote Info and deselect "Maintain 
synchronization information."

• CS5

b In the Servers category, select the appropriate site and click the Pencil icon.

c Select the Advanced tab and deselect "Maintain synchronization information."

3 Close Dreamweaver.

4 Verify that all of the dwsync.xml files have been deleted from your local root folder and all of its subfolders.Note: 
The dwsync.xml files are located in the _notes folders that are hidden by default in Dreamweaver. So check for the 
_notes folders and dwsync.xml files in the Windows Explorer or Macintosh file browsers. The dwsync.xml files only 
reside locally. Dreamweaver never uploads the dwsync.xml files to the server, and there is no reason to upload them 
to the server.

5 Reopen Dreamweaver, choose Site > Manage Sites, and edit the same site you selected in step 1.

6 Reselect the Maintain Synchronization Information setting. Refer to step 2 above for option differences between 
CS4 and CS5.Note:Dreamweaver re-creates the dwsync.xml files as you transfer files to and from the server.

7 Verify that the problem is resolved.

Additional information
When you put or get a file in Adobe Dreamweaver CS4 and CS5, Dreamweaver locally stores the remote and local 
date/time stamps in files called dwsync.xml. These files are located in hidden _notes folders in the same folder as the 
files being transferred. Occasionally, the dwsync.xml files can become corrupted.

For more information about Dreamweaver synchronize features, select the version below.

• Dreamweaver CS4 

• Dreamweaver CS5 

More Help topics 
How synchronization works in Adobe Dreamweaver 8

http://help.adobe.com/en_US/Dreamweaver/10.0_Using/WSc78c5058ca073340dcda9110b1f693f21-7ea4a.html
http://help.adobe.com/en_US/Dreamweaver/CS5/Using/WSc78c5058ca073340dcda9110b1f693f21-7ea4a.html
http://www.adobe.com/go/kb400972
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Troubleshoot JavaScript errors | Dreamweaver CS4, CS5, 
CS5.5, CS6

Identify JavaScript errors
When you perform tasks within Dreamweaver, you sometimes encounter a JavaScript error message. These design-
time JavaScript errors usually prevent you from implementing a portion of Dreamweaver functionality.

Example: The following JavaScript error message can appear when you save a file:

Another example of a possible JavaScript error: "While executing onLoad in tempURL_afterSave.htm, a JavaScript 
error occurred."

Important: These pop-up JavaScript errors in Dreamweaver are different from JavaScript runtime errors you encounter 
when viewing a page in a web browser. JavaScript errors in a web browser indicate a problem with embedded or linked 
JavaScript in the HTML page. These types of runtime JavaScript errors are beyond the scope of this TechNote. See the 
Dreamweaver Help files for errors resulting from JavaScript that Dreamweaver generates. Or, see a third-party 
JavaScript reference for troubleshooting hand-coded JavaScript.

Sometimes, a translator error message accompanies these internal JavaScript errors:

The following translators were not loaded due to errors: ASP.htm: has configuration information that is invalid. 
ASP.NET.htm: has configuration information that is invalid. ColdFusion.htm: has configuration information that is 
invalid. PHP_MySQL.htm: has configuration information that is invalid. JSP.htm: has configuration information that 
is invalid. XSLT.htm: has configuration information that is invalid.

JavaScript errors in Dreamweaver
Dreamweaver uses JavaScript to perform numerous internal actions. Adobe has implemented much of Dreamweaver 
functionality by using JavaScript files. This heavy use of JavaScript helps to make Dreamweaver easily extensible. 
Developers only have to have a good knowledge of JavaScript and access to the Dreamweaver API to add to or change 
the native functionality of Dreamweaver. However, the errors that Dreamweaver generates if it encounters a problem 
executing some action tend to be JavaScript errors.

JavaScript error troubleshooting tips
JavaScript errors in Dreamweaver usually indicate a conflicting Dreamweaver extension, a conflict with the code on a 
page or a bad installation of Dreamweaver. Here are a few questions that can help you isolate the problem:

• Does the error occur when using a specific feature? For example, do you see the same error message every time 
you attempt to create a web photo album? This error can indicate a conflicting extension or a bad installation of 
Dreamweaver.

• Does the error occur on a specific page or with all pages? If the error doesn't occur with all pages, then you can 
have a conflict with some code on a particular page.

• Does the error occur in all sites or just one? To test this issue properly, make sure that you test a different site that 
does not use the same files. If the error only occurs in a certain site, then the issue can be specific to files and code 
within that site.
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• Does the problem persist if you restart Dreamweaver? If the problem does not recur on relaunching 
Dreamweaver, then it's possible that a JavaScript file loaded incorrectly.

• If using a server behavior, does the problem occur with all databases and tables? If not, then it's possible that you 
have an issue with the database connection files or with the tables of the database itself.

Troubleshooting steps
After answering the questions above, follow the steps below to troubleshoot the errors:

1 Check the list of known JavaScript errors. 

2 Install the latest update for your version of Dreamweaver. 

3 Name objects referenced by JavaScript. 

4 Delete the FileCache.dat file. 

5 Try a new page. 

6 Re-create the site cache. 

7 For site-specific errors, try deleting the .dws site cache file. 

8 Mac OS users: Check for special characters in paths. 

9 Verify that extensions are compatible with your version of Dreamweaver. 

10 Disable extensions. 

11 Uninstall extensions. 

12 Re-create the Dreamweaver user configuration folder. 

13 Run Dreamweaver in Selective Startup Mode or Diagnostic Startup Mode. 

14 See additional TechNotes. 

1. Check the list of known JavaScript errors.
Adobe has documented a number of known errors within Dreamweaver and have provided information to assist you 
in resolving the problem. For a list of known issues, see the Known JavaScript Errors Chart .

2. Install the latest Dreamweaver updates.
Updates provide fixes for a number of issues identified within Adobe applications. Download updates from the Adobe 
Updates page.

3. Verify that any object the JavaScript references is named in the code.
For example, if you have a behavior applied to an image, then that image must have a name. Likewise, if the behavior 
references another image, then that image must also have a name. All object names must be unique and must meet 
other criteria. Object naming is described in Naming strategies for Dreamweaver and various interpreters (tn_14610).

4. Delete FileCache.dat files from the Dreamweaver user configuration folder.
Delete the WinFileCache-7A9586CB.dat, MacFileCache-BFE7CE2E.dat, or FileCache.dat file from the Dreamweaver 
user configuration folder. Adobe recommends that you delete the FileCache.dat file if you are experiencing a JavaScript 
error related to "dwscripts. " Also delete the file if you receive a "translators were not loaded" error. The string of 
characters after "FileCache-" can differ on your machine. The location of the FileCache.dat file depends your operating 
system and your version of Dreamweaver. On Windows, the Application Data and AppData folders are hidden by 
default, so verify that your Windows Explorer folder options are set to View Hidden Folders.

http://helpx.adobe.com/dreamweaver/kb/#main_known_errors
http://helpx.adobe.com/dreamweaver/kb/#main_latest_update
http://helpx.adobe.com/dreamweaver/kb/#main_name_objects
http://helpx.adobe.com/dreamweaver/kb/#main_dat
http://helpx.adobe.com/dreamweaver/kb/#main_new_pg
http://helpx.adobe.com/dreamweaver/kb/#main_site_cache
http://helpx.adobe.com/dreamweaver/kb/#main_dws
http://helpx.adobe.com/dreamweaver/kb/#main_special_char
http://helpx.adobe.com/dreamweaver/kb/#main_ext_compat
http://helpx.adobe.com/dreamweaver/kb/#main_disable_ext
http://helpx.adobe.com/dreamweaver/kb/#main_uninstall_ext
http://helpx.adobe.com/dreamweaver/kb/#main_user_config
http://helpx.adobe.com/dreamweaver/kb/#main_safe_mode
http://helpx.adobe.com/dreamweaver/kb/#main_additional
http://helpx.adobe.com/dreamweaver/kb/#main_KnownJS
http://www.adobe.com/support/dreamweaver/downloads_updaters.html
http://www.adobe.com/support/dreamweaver/downloads_updaters.html
http://kb2.adobe.com/cps/146/tn_14610.html
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Note: The [language] folder below is an abbreviation of the language you are currently using. Typically there is only one 
folder in this location.

• Mac OS: Dreamweaver CS6: /Users/Your User Name/Library/Application Support/Adobe/Dreamweaver 
CS6/[language]/Configuration Dreamweaver CS5.5: /Users/Your User Name/Library/Application 
Support/Adobe/Dreamweaver CS5.5/[language]/Configuration Dreamweaver CS5: /Users/Your User 
Name/Library/Application Support/Adobe/Dreamweaver CS5/[language]/Configuration Dreamweaver CS4: 
C/Users/Your User Name/Library/Application Support/Adobe/Dreamweaver CS4/[language]/Configuration 

• Windows 7 or Windows Vista: Dreamweaver CS6: C:\Users\Your User 
Name\AppData\Roaming\Adobe\Dreamweaver CS6\[language]\Configuration Dreamweaver CS5.5: 
C:\Users\Your User Name\AppData\Roaming\Adobe\Dreamweaver CS5.5\[language]\Configuration 
Dreamweaver CS5: C:\Users\Your User Name\AppData\Roaming\Adobe\Dreamweaver 
CS5\[language]\Configuration Dreamweaver CS4: C:\Users\Your User 
Name\AppData\Roaming\Adobe\Dreamweaver CS4\[language]\Configuration 

• Windows XP: Dreamweaver CS6: C:\Documents and Settings\Your User Name\Application 
Data\Adobe\Dreamweaver CS6\[language]\Configuration Dreamweaver CS5.5: C:\Documents and Settings\Your 
User Name\Application Data\Adobe\Dreamweaver CS5.5\[language]\Configuration Dreamweaver CS5: 
C:\Documents and Settings\Your User Name\Application Data\Adobe\Dreamweaver 
CS5\[language]\Configuration Dreamweaver CS4: C:\Documents and Settings\Your User Name\Application 
Data\Adobe\Dreamweaver CS4\[language]\Configuration 

For older versions of Dreamweaver, the configuration paths are as follows:

Dreamweaver CS3 on Windows Vista: C:\Users\[user name]\AppData\Roaming\Adobe\Dreamweaver 
9\Configuration

Dreamweaver CS3 on Windows XP: C:\Documents and Settings\[user name]\Application Data\Adobe\Dreamweaver 
9\Configuration

Dreamweaver 8 on Windows XP: C:\Documents and Settings\[user name]\Application 
Data\Macromedia\Dreamweaver 8\Configuration

Dreamweaver 8 on Windows Vista: C:\Users\[user name]\AppData\Roaming\Macromedia\Dreamweaver 
8\Configuration

Dreamweaver CS3 on Macintosh: Mac HD/Users/[user]/Library/Application Support/Adobe/Dreamweaver 9/

Dreamweaver 8 on Macintosh: Mac HD/Users/[user]/Library/Application Support/Macromedia/Dreamweaver 8/

5. Try a new page.
There can be conflicting code or Dreamweaver behaviors on the page. Try to build a page from scratch with minimal 
behaviors and other design elements and see if you can reproduce the error. Custom code or modified Dreamweaver 
code can occasionally cause problems.

6. Re-create the site cache and see if the problem persists.
In particular, this step is useful for JavaScript errors related to templates, library items, and uploading files. This step is 
only available if the site is defined to use a site cache:

1 Within Dreamweaver, open the Site panel by choosing Window > Files.

2 From the Files panel group, click the Options menu in the upper-right corner, and choose Site > Recreate Site Cache.
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7. For site-specific errors, try deleting the .dws site cache file.
If the JavaScript only occurs in one site definition, then delete the site cache file for that site. To delete the cache, choose 
Site > Advanced > Recreate Site Cache.

8. Mac OS users: Check for special characters in paths.
Check for any special characters in the hard drive name, in the path to the Dreamweaver configuration folder, or in the 
path to your site files. Examples of special characters that can cause conflicts include the following:

~ @ # $ % ^ & * ( ) + | / \ ';

9. Verify that extensions are compatible with your version of Dreamweaver.
There can be a conflicting extension installed in Dreamweaver. For example, an extension could have been designed to 
work with an older version of Dreamweaver. Check the extension developer's website to see if the extension is 
compatible with your version of Dreamweaver.

There are several JavaScript errors associated with third-party extensions. Adobe recommends searching the 
Dreamweaver forum. Search using some of the keywords in your JavaScript error message (for example, search using 
the text of the JS filename).

10. Disable extensions.
To manually test for an extension conflict, open the Extension Manager and disable the extensions that you installed in 
Dreamweaver. If turning off the extensions solves the problems, then turn them back on one-by-one, until you isolate 
the problematic extension. If you identify a problematic extension, then notify the extension developer.

1 Choose Commands > Manage Extensions.

2 In the Extension Manager, select your version of Dreamweaver from the product list

3 Within the list of installed extensions, set the On/Off checkbox to Off for all Dreamweaver extensions.

11. Uninstall extensions.
If the JavaScript error persists after you disable all of the extensions, then uninstall the extensions in the Extension 
Manager. If you identify a problematic extension, then notify the extension's author.

1 Within the Extension Manager, select each extension.

2 Choose File > Remove Extension.

12. Re-create the Dreamweaver user configuration folder.
For Dreamweaver CS4, CS5, CS5.5 or CS6, see Restore preferences | Dreamweaver CS4, CS5, CS5.5, CS6.

For Dreamweaver CS3 on Windows, see "How to re-create the Dreamweaver user configuration folder (CS3 on 
Windows XP, Vista)" (TechNote kb401118).

On Mac OS

1 Quit Dreamweaver

2 In the Mac Finder, browse to the following folder: /Users/[username]/Library/Application 
Support/Adobe/Dreamweaver CS4 [or CS5]/[language]/ConfigurationNote: For older versions of Dreamweaver, 
the paths are as follows:Dreamweaver CS3: Mac HD/Users/[user]/Library/Application 
Support/Adobe/Dreamweaver 9/ConfigurationDreamweaver 8: Mac HD/Users/[user]/Library/Application 
Support/Macromedia/Dreamweaver 8/Configuration

3 Rename the folder to "Configuration Old."

http://forums.adobe.com/community/dreamweaver
http://helpx.adobe.com/dreamweaver/kb/restore-preferences-dreamweaver-cs4-cs5.html
http://kb2.adobe.com/cps/401/kb401118.html
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4 Restart Dreamweaver and see if the problem persists.

13. Run Dreamweaver in Selective Startup Mode.
• To start Windows XP in diagnostic mode, see Start Windows in Diagnostic mode (Windows XP) (kb404860) for 

details.

• To start Windows Vista/7 in modified mode, see Restart Windows in a modified mode (Windows Vista/7) 
(kb404913) for details.

14. See additional TechNotes.
If the JavaScript errors persist after you follow the suggestions above, then see the following TechNotes for additional 
troubleshooting suggestions. Uninstalling and reinstalling Dreamweaver, with anti-virus software disabled, is an 
important test to perform:

• Troubleshooting Dreamweaver for Windows (tn_15481)

Known JavaScript errors and solutions

Troubleshooting synchronization problems in 
Dreamweaver (Mac OS and Windows)

Issue
 When using Dreamweaver's synchronize feature or uploading files to a server, the following problems may occur: 

• You are putting files and Dreamweaver is warning you that the remote file has changed on the server: "my_file.htm 
has changed on the remote server since your last get or put operation. Putting it may overwrite changes to the file. 
Do you wish to put the file anyway?" However, you are sure that the remote files haven't changed. 

• The Synchronize preview dialog box is not correctly listing the files that should be synchronized. 

• The Synchronize preview dialog box says no synchronization is necessary, but you know some files have changed. 

Note: This TechNote only applies to Dreamweaver 8 and later. The synchronize feature was redesigned in Dreamweaver 
8, so the troubleshooting steps mentioned here do not apply to Dreamweaver MX 2004 and earlier. (Ref. 202195) 

JavaScript Error Solution

"The following JavaScript errors occurred: At line 56 of file "C:\ Program 
Files\Adobe\Dreamweaver CS4\Configuration\Shared\Common\ 
Scripts\dwscriptsExtData.js": ReferenceError: dwscripts is not defined."

Remove the WinFileCache-7A9586CB.dat file from the Dreamweaver 
user configuration folder. If that doesn't solve it, then recreate the 
Dreamweaver user configuration folder . These suggestions also apply 
if you are receiving the error message: "The following translators were 
not loaded due to errors."

While executing DWMenu_File_SaveDocumentToRemoteServer 
command in menus.xml, the following JavaScript errors occurred: 
Exception thrown in native function.

See the following TechNote for more information: JavaScript error and 
hang when performing Save To Remote Server (kb401216)

"While executing applyBehavior in Show Pop-Up Menu.htm, the 
following JavaScript errors occurred: At line 27 of file "D:\Program 
Files\Macromedia\DreamweaverMX\Configuration\ 
Behaviors\Actions\Show Pop-up Menu.js":

The image to which you are applying the behavior is not named, or 
there is a problem with the object name. For more information, see 
"Error 'While executing applyBehavior in Show Pop-Up Menu...'" 
(TechNote tn_16462).

http://kb2.adobe.com/cps/404/kb404860.html
http://kb2.adobe.com/cps/404/kb404913.html
http://kb2.adobe.com/cps/154/tn_15481.html
http://helpx.adobe.com/dreamweaver/kb/#main_dat
http://helpx.adobe.com/dreamweaver/kb/#main_user_config
http://helpx.adobe.com/dreamweaver/kb/#main_user_config
http://kb2.adobe.com/cps/401/kb401216.html
http://kb2.adobe.com/cps/401/kb401216.html
http://kb2.adobe.com/cps/164/tn_16462.html
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Reason
 In Dreamweaver 8 and later, whenever a user puts or gets a file, Dreamweaver locally stores the remote and local 
date/time stamps in files called dwsync.xml which are located in hidden _notes folders in the same folder as the files 
being transferred. Occasionally, the dwsync.xml files can become corrupted. 

Solution
 There are two recommended solutions, depending on how widespread the synchronize problems are. 

Only a few files have synchronization problems

 If only a few of your files are having synchronize problems, try deleting the specifc dwsync.xml files, instead of 
recreating all of the synchronization information for your site. 

1. Close Dreamweaver. 

2. In Windows or Mac Finder, browse to your site's local root folder and browse to the folder that contains the files that 
are having synchronization problems. For each folder(s) having synchronization problems, locate the _notes folder and 
delete the dwsync.xml file inside of it. The dwsync.xml files only reside locally. Dreamweaver will never upload the 
dwsync.xml files to the server, and there is no reason to upload them to the server. 

3. Re-open Dreamweaver and see if the problem is resolved. 

Several or all files have synchronization problems

 If you are experiencing widespread synchronization problems, then it is recommended to temporarily disable the 
"Maintain synchronization information" setting so that Dreamweaver recreates all of the synchronization information 
for your site. 

1. Temporarily disable the "Maintain synchronization information" option from the Remote Info category of the 
advanced view of the Site Definition dialog box. This will delete all of the existing dwsync.xml files. 

2. Close Dreamweaver. 

3. Verify that all of the dwsync.xml files have been deleted from your local root folder and all of its subfolders. The 
dwsync.xml files are located in the _notes folder which are hidden by default in Dreamweaver, so check for the _notes 
folders and dwsync.xml files in the Windows or Macintosh file browsers. The dwsync.xml files only reside locally. 
Dreamweaver will never upload the dwsync.xml files to the server, and there is no reason to upload them to the server. 

4. Re-open Dreamweaver and go into the site definition dialog box. Turn "Maintain synchronization information" back 
on. Dreamweaver will now recreate the dwsync.xml files as you transfer files back-and-forth to and from the server. See 
if the problem is resolved. 

Additional Information
For more information on Dreamweaver's synchronize feature, please refer to this section of the Dreamweaver 
documentation: Synchronizing the files on your local and remote sites.

Also, refer to How synchronization works in Dreamweaver 8 (TechNote kb400972).

http://livedocs.macromedia.com/dreamweaver/8/using/05_sit45.htm
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb400972
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Troubleshoot FTP issues
Before troubleshooting FTP access failures, verify that Dreamweaver and your operating system are updated. Access 
Dreamweaver updates by choosing Help > Updates and following the onscreen instructions.

Note: For information on improvements to FTP in Dreamweaver CS6, see 
http://blogs.adobe.com/dreamweaver/2012/06/ftp-improvement-in-dreamweaver-cs6.html

Set up an FTP Remote Server
Dreamweaver can use an FTP server to upload and download website information. You can set up an FTP server on 
the Servers category of the Site Setup dialog box. For additional information about setting up an FTP site, see the Help 
topic Set Options For FTP Connections. Click Test to verify connection information after setting up an FTP server. If 
you can't connect to your FTP server after entering the information, proceed to Verify FTP access .

Verify FTP access
Firewalls, routers, and other networking components can prevent you from accessing FTP servers. Use the information 
below to verify that you can access an FTP server before verifying your connection information. 

• Log in to a known FTP server 

• Temporarily disable software firewalls 

• Verify that a router is not preventing the connection 

• Configure firewall or proxy settings 

Log in to a known FTP server
Adobe has provided an FTP server to verify that Dreamweaver can access an external FTP server. The login 
information provided below is for testing purposes only. Do not use the connection information below for your final 
site as Adobe has restricted the login for testing purposes. 

Important: Adobe provides this test FTP server to verify your connection information. The account has extreme 
limitations applied and cannot be used to upload or host your website.

1 Launch Dreamweaver.

2 Choose Site > Manage Sites.

3 Select the website and click Edit.

4 Select the Servers category and click +.

5 Enter the following information on the Basic tab of the Site Setup dialog box.Server Name: Adobe Test FTP 
ServerConnect Using: FTPFTP Address: sjftp.adobe.com Port: 21User name: cust-dl Password: 
&Zxv2468abRoot Directory: /techsuppWeb URL: http://sjftp.adobe.com 

6 Expand More Options.

7 Select Use Passive FTP. 

http://blogs.adobe.com/dreamweaver/2012/06/ftp-improvement-in-dreamweaver-cs6.html
http://helpx.adobe.com/content/help/en/dreamweaver/using/connect-remote-server.html#specify_a_connection_method
http://helpx.adobe.com/en/dreamweaver/kb/troubleshoot-ftp-issues-dreamweaver-cs5.html#main-pars_heading_1
http://helpx.adobe.com/dreamweaver/kb/#main_LoginKnownServer
http://helpx.adobe.com/dreamweaver/kb/#main_DisableFirewall
http://helpx.adobe.com/dreamweaver/kb/#main_VerifyRouter
http://helpx.adobe.com/dreamweaver/kb/#main_ConfigureHardwareFirewallProxy
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8 Click Test.

• The message “Dreamweaver connected to your Web server successfully” indicates that you successfully connected 
to the FTP server. To continue troubleshooting, proceed to Verify login credentials .

• If you were unable to log in to Adobe’s FTP server, proceed to Temporarily disable software firewalls .

Temporarily disable software firewalls
Software firewalls restrict access to your computer and can prevent software from accessing the Internet. Numerous 
software firewalls prompt you when a program attempts to access the Internet.

1 If prompted, select the allow option for Dreamweaver to access the FTP server. The following is an example dialog 
box:

2 If you are not prompted, disabling software firewalls can help you determine whether they are preventing access to 
FTP servers. See the firewall software documentation to temporarily disable software firewalls. 

• If disabling the software firewall resolves the issue, configure the software to allow Dreamweaver access to FTP. For 
steps on adding a program to the allowed list, see the firewall software documentation.

• If you can't locate the documentation to temporarily disable the software firewall, disable startup items and services. 
Most software firewalls are disabled using this process. For instructions on how to disable startup items and services, 
select your operating system from the list below.

• Windows XP

• Windows Vista/7

• Mac OS X 

Verify that a router is not preventing the connection
Routers can have built-in hardware firewall or proxy servers. To determine if a router is preventing Dreamweaver from 
accessing the FTP server, temporarily remove the router from the network. Connecting the computer directly to a DSL 
or cable modem eliminates the router. 

? If the router is preventing access, see the router documentation to set up port forwarding from the computer.

Configure hardware firewall or proxy settings
Many companies use a hardware firewall and proxy server that can prevent Dreamweaver from accessing an FTP server. 
A hardware solution applies to all computers within the corporate network. Most home networks do not use hardware 
firewall or proxy technology. 

Determine if your company uses a hardware firewall or proxy:

1 Contact your company's IT department to obtain firewall or proxy information.Important: Dreamweaver cannot 
connect through an authentication proxy. If your proxy server requires a user name and password, you can't connect 
to a remote FTP site. The IT department has to set up exceptions for the site and Dreamweaver. Dreamweaver can 
only store firewall/proxy information for a single authentication server. 

2 Choose Site > Manage Sites. 

3 Select your site. 

4 Click Edit. 

5 Select the Servers category.

http://helpx.adobe.com/dreamweaver/kb/#main_verify_credentials
http://helpx.adobe.com/dreamweaver/kb/#main_DisableFirewall
http://kb2.adobe.com/cps/404/kb404984.html
http://go.adobe.com/kb/ts_kb404913_en-us
http://go.adobe.com/kb/ts_kb404936_en-us
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6 Select the server to modify and click the Pencil icon.

7 Expand More Options.

8 Select use Proxy, As Defined In Preferences.

9 Click the Preferences link.

10 On the Site category, enter the provided firewall or proxy information in the Proxy Host and Proxy Port text boxes.

11 Click OK, then click Save.

12 Click Save to exit the Site Setup.

Verify login credentials and other options
Login information is essential to connecting to an FTP site. Use the information below to verify your login information 
and make any necessary changes.

• Verify your FTP information 

• Log in with another FTP client 

• Verify whether your SFTP server is supported 

• Modify connection options 

• Troubleshoot FTP log 

Verify your FTP information 
Connecting to an FTP server requires an FTP address, port, login, and password. A root directory is required for some 
server configurations. This information is typically supplied by your web hosting service provider; verify all of this 
information with them. Below are tips to assist you in resolving problems with this information.

FTP address
Use a standard web address or IP address for the FTP address. A web address is similar to eftp.adobe.com. An IP address 
appears as a set of four numbers separated with periods similar to 192.150.11.87. Web hosting service providers 
typically provide a domain name for your website such as www.adobe.com and a similar address for your ftp server 
such as ftp.adobe.com. 

Additional information that can assist you in connecting:

• Do not enter the ftp:// in front of the web address.

• If you were provided with a web address, enter the IP address rather than the web address. Contact your web hosting 
service provider or use the ping command to discover the IP address.

Port
Web hosting service providers can provide a different port to access the FTP server. The port is a number that creates 
a channel between your machine and the FTP server. The default port (21 for FTP and 22 for SFTP) is most likely being 
used if no port number is specified. The web address can appear in the following format eftp.adobe.com:445, where 
eftp.adobe.com is the web address and the port is 445. 

User name
The login name is the user name used to log in to your FTP server. This information is supplied by your web hosting 
service provider and cannot be the same login information as you use to access website information. 

http://helpx.adobe.com/dreamweaver/kb/#main_VerifyFTPInformation
http://helpx.adobe.com/dreamweaver/kb/#main_LoginAnotherClient
http://helpx.adobe.com/dreamweaver/kb/#main_VerifySFTPServerSupported
http://helpx.adobe.com/dreamweaver/kb/#main_ModifyConnectionOptions
http://helpx.adobe.com/dreamweaver/kb/#main_Troubleshoot_FTP_log
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The user name must meet the following requirements:

• No spaces

• Can only contain alphanumeric characters

Password
The password is associated with your login name and can be any combination of characters without spaces. The 
password is case sensitive.

Root directory
The root directory is the primary location within which your website is stored. Specifying the root directory redirects 
Dreamweaver to view this subfolder as the root of your website files. Your web hosting service providers supplies the 
root directory information, if necessary. Remove root directory information before proceeding if this step does not 
resolve the issue.

This list shows root directory entries that web hosting service providers typically use:

• /

• /[domain_name] (for example, /www.mywebsite.org) 

• /html 

• /docs 

• /www 

• /public_html 

Log in with another FTP client
Logging in with another FTP client allows you to determine if the FTP server information is correct. Use any installed 
FTP client or an online solution. An example FTP client you can use is FileZilla. For installation and configuration 
information for FileZilla, see the product's documentation.

• If you are able to log in to the FTP server, proceed to the section, “Select/deselect Passive Mode.”

• If you can't log in to the FTP server, then the connection information is most likely incorrect. Contact your web 
hosting service provider to verify the information and the status of the service. 

Verify whether your SFTP server is supported
Dreamweaver is unable to connect with certain SFTP servers. For additional information on what SFTP servers work 
with Dreamweaver, see Limitations with website hosting servers using Adobe Contribute and Dreamweaver 
(kb406569).

Modify connection options
Dreamweaver includes some additional configuration options that are sometimes required to connect to your FTP 
server. If the option is required, your web hosting service provider provides this information. Try the following 
configuration options to see if they resolve your connection issues.

Select/deselect Passive Mode
Passive mode can help resolve FTP issues that firewalls cause, preventing the FTP server from opening a connection to 
your computer. When you use Passive mode, the connection is made from your computer to the server instead. 

1 Choose Site > Manage Sites.

http://filezilla-project.org/
http://kb2.adobe.com/cps/406/kb406569.html
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2 Select your site and click Edit. 

3 Select the Servers category and select your remote server.

4 Click the Pencil icon.

5 Expand More Options.

6 Select (or deselect) Use Passive FTP.

7 Click Save, then click Save again.

Select/deselect Use FTP Performance Optimization 
1 Choose Site > Manage Sites.

2 Select your site and click Edit. 

3 Select the Servers category and select your remote server.

4 Click the Pencil icon.

5 Expand More Options.

6 Select (or deselect) Use FTP Performance Optimization.

7 Click Save, then click Save again.

Enable IPv6 transfer mode
IPv6 is a network protocol that extends the number of addresses available for networking. If it is required, this protocol 
requires that information is transferred differently across a network. 

1 Choose Site > Manage Sites.

2 Select your site and click Edit. 

3 Select the Servers category and select your remote server.

4 Click the Pencil icon.

5 Expand More Options.

6 Select (or deselect) Use IPV6 Transfer Mode.

7 Click Save, then click Save again.

Select SFTP
1 Choose Site > Manage Sites 

2 Select your site and click Edit. 

3 Select the Servers category and select your remote server.

4 Click the Pencil icon.

5 Select SFTP from the Connect Using pop-up menu.

6 Click Save, then click Save again.

Troubleshoot FTP log
Dreamweaver keeps a log of the commands it sends to the FTP server and its responses. Responses from the server can 
assist in diagnosing FTP issues. To view the FTP log, choose Window > Results > FTP Log. 

For more information on interpreting FTP log files, see Checking the FTP log (tn_14536). 

http://kb2.adobe.com/cps/145/tn_14536.html
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Additional information
File Transport Protocol (FTP) is the most commonly used method for transferring files over the Internet. FTP has 
numerous security vulnerabilities despite its popularity. Secure FTP (SFTP) enables you to fully encrypt all file transfers 
and prevent unauthorized access to your data, files, user names, and passwords. While secure FTP is a different protocol 
than FTP, they share similar commands and settings. 

If you are not sure whether your server is running SFTP, check with your web hosting service provider. 

Troubleshoot Dreamweaver on Macintosh OS X
Introduction

 This TechNote suggests some general troubleshooting techniques for issues or unexpected behavior with Macromedia 
Dreamweaver MX, Dreamweaver MX 2004 and Dreamweaver 8 running on Apple Macintosh OS X. Answers to 
common questions and additional information are at the end of the TechNote. 

Note: This TechNote includes information specific to Dreamweaver. Users should use this TechNote in conjunction 
with General Macintosh troubleshooting (TechNote tn_3500), which describes basic troubleshooting steps appropriate 
for all Macromedia products on Macintosh OS X. 

The information is divided into three main sections: 

• Collecting information 

• Isolating the problem 

• Searching for a workaround 

Collecting Information

 Troubleshooting problems with Dreamweaver is generally easier when complete information and conditions to 
reproduce the issue are available. Information to help narrow down the problem can be found by answering the 
questions below. 

• Does the computer meet the minimum system requirements for Dreamweaver? 

• Are Background Maintenance Tasks run on a regular basis? 

• Which applications are executing when the computer starts? (this is covered in the General TechNote ) 

• Which applications are running before Dreamweaver starts? (this is covered in the General TechNote ) 

• Is there any way to get detailed reports about crashes? (this is covered in the General TechNote ) 

Does the computer meet the minimum system requirements for Dreamweaver?

Verify that your system meets the minimum requirements. Running below or without the advertised minimum 
requirements may cause the software to malfunction.

• Dreamweaver 8: 600 MHz PowerPC G3 and later Macintosh OS X 10.3 and later 256 MB RAM 300 MB available 
disk space You must have at least 1024 x 768, thousands of colors monitor, although millions of colors is 
recommended.Note: This product must be activated over the Internet prior to use. Visit the Product Activation 
Center to learn more about activation.

http://helpx.adobe.com/dreamweaver/kb/#main_common
http://helpx.adobe.com/dreamweaver/kb/#main_additional_info
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500
http://helpx.adobe.com/dreamweaver/kb/#main_collecting
http://helpx.adobe.com/dreamweaver/kb/#main_isolating
http://helpx.adobe.com/dreamweaver/kb/#main_workaround
http://helpx.adobe.com/dreamweaver/kb/#main_systemrequirements
http://helpx.adobe.com/dreamweaver/kb/#main_bgmaint
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#running
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#running
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#log
http://helpx.adobe.com/x-productkb/policy-pricing/activation-deactivation-products.html
http://helpx.adobe.com/x-productkb/policy-pricing/activation-deactivation-products.html
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• Dreamweaver MX 2004: 500 MHz Power PC G3 processor Macintosh OS X 10.2.6 and later, 10.3 128 MB computer 
RAM (256 MB recommended) 275 MB available disk space You must have at least 800 x 600, thousands of colors 
monitor, although 1024 x 768, millions of colors is recommended.Note: This product must be activated over the 
Internet or phone prior to use. Visit the Product Activation Center to learn more about activation.

• Dreamweaver MX: A Power Macintosh G3 or better Macintosh OS 9.1 and higher or Macintosh OS X 10.1 and 
higher 96MB RAM (128 MB recommended) 275 MB of available disk space You must have at least 800 x 600, 
thousands of colors monitor, although 1024 x 768, millions of colors is recommended.

Note: Unix File System (UFS) is not a supported File system format to use with Dreamweaver on Macintosh OS X 10.x. 
Use Macintosh OS Extended (Journaled) HFS formatting in your hard disks.

Are Background Maintenance Tasks run on a regular basis?

 Some developers report that aberrant behavior is corrected, and application performance improved, when Background 
Maintenance Tasks have been run. It is recommended these tasks be run on a regular basis. Please refer to the Apple 
Support Article ID 107388 for more information. 

Isolating the problem

 After confirming system requirements are met, and information is collected about applications running at the same 
time as Dreamweaver, isolation of the problem can begin. 

• Does the problem happen when Classic mode is not running? (this is covered in the General TechNote ) 

• Is there a conflict with another application? 

• Could the problem be the preferences file? 

• Is there a problem with permissions? (this is covered in the General TechNote ) 

• Corrupt fonts or possible problem with Extensis Suitcase or DiamondSoft Font Reserve (this is covered in the 
General TechNote ) 

• New window disappearing on a second monitor? 

• Dreamweaver help is not working (this is covered in the General TechNote ) 

• Where did the sites, or extensions, go when I logged in as a different user? (this is covered in the General TechNote ) 

• Has the hard drive been checked for corruption? 

• Other Macintosh OS X 10.x troubleshooting 

• Can you reproduce the problem in Macintosh OS 9? (For Dreamweaver MX only) 

Is there a conflict with another application?

 Close all other applications and verify that the problem persists when Dreamweaver is the only application running. A 
list of running applications can be viewed in the Force Quit Applications window by pressing Option-Apple-Escape. 
For advanced users the ProcessViewer utility (found in /Applications/Utilities) provides some information about 
currently running applications. 

Additional information can be found by running the Unix top utility in the terminal window, which shows the name 
of the application. For additional information about processes and daemons please see the articles, Mac OS X Server: 
Processes and Mac OS X: What are all those processes?. 

Could the problem be the preferences file?

 Because the preferences file for Dreamweaver is generally updated more frequently than other Dreamweaver files, the 
chances of that file becoming corrupt is greater. To test the Dreamweaver preference file, move or rename the file while 
Dreamweaver is not running, restart Dreamweaver and try reproducing the issue. Dreamweaver will create a new 
preferences file that should eliminate issues associated with a corrupt file. 

http://helpx.adobe.com/x-productkb/policy-pricing/activation-deactivation-products.html
http://docs.info.apple.com/article.html?artnum=107388
http://docs.info.apple.com/article.html?artnum=107388
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#no_classic
http://helpx.adobe.com/dreamweaver/kb/#main_application_conflict
http://helpx.adobe.com/dreamweaver/kb/#main_preferences
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#permissions
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#fonts
http://helpx.adobe.com/dreamweaver/kb/#main_dual_displays
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#help
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#multiuser
http://helpx.adobe.com/dreamweaver/kb/#main_disk
http://helpx.adobe.com/dreamweaver/kb/#main_other
http://helpx.adobe.com/dreamweaver/kb/#main_os9
http://docs.info.apple.com/article.html?artnum=106415
http://docs.info.apple.com/article2.html?artnum=60053
http://docs.info.apple.com/article2.html?artnum=60053
http://www.westwind.com/reference/OS-X/background-processes.html
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Note: Dreamweaver site definitions are stored in the preferences file, so use the export/import functionality built into 
the Sites dialog box before performing this test. The Dreamweaver Preference file is located in the 
HD:Users:[username]:Library:Preferences folder, named as follows: 

• Dreamweaver 8 Prefs 

• Dreamweaver MX 2004 Prefs 

• Dreamweaver MX Prefs 

New window disappearing on a second monitor?

 Several customers have reported issues when opening new files on a second monitor. The new window appears as a 
small rectangle about five to ten pixels down the side of the second display screen. The workaround is to move the title 
bar to the first display screen and resize the window by dragging the bottom right corner. 

Has the hard drive been checked for corruption?

 There are several utilities that examine and repair disk corruption. Knowledge Base document, Mac OS X: About Using 
Disk Utility and fsck for File System Maintenance describes the use of these utilities. In addition, there are third-party 
utilities to fix certain types of disk corruption. 

Can you reproduce the problem in Macintosh OS 9?

Note: This is a useful step for Dreamweaver MX users, but Dreamweaver 8 and Dreamweaver MX 2004 do not run 
under classic mode. Dreamweaver 8 and MX 2004 require Macintosh OS X. 

Another useful piece of information is whether or not the problem can be reproduced in Macintosh OS 9.x. Please note, 
this is not the same as running in classic mode. To run the applications in Macintosh OS 9.x you will need to restart the 
computer. The Apple Knowledge Base document, How to Switch Between Mac OS 9 and Mac OS X, describes switching 
between Macintosh OS 9.x and Macintosh OS X. 

If the problem cannot be reproduced in Macintosh OS 9.x, further investigation should determine if the problem is with 
the Dreamweaver MX installation by using a new account with admin privileges to see if the problem is reproduced. 

Searching for a workaround

 Most issues with Dreamweaver can be fixed once the problem has been defined, but some issues may require 
reinstalling Dreamweaver or disabling a corrupt font. 

• How do I uninstall Dreamweaver? 

• How do I reinstall Dreamweaver? 

• How to disable a font? 

How do I uninstall Dreamweaver?

 Please refer to Uninstalling Studio 8 applications on Macintosh OS X (TechNote 8f101099) for instructions on 
Dreamweaver uninstallation. Before uninstalling, make sure to back up important sites and customized settings; see 
Backing up and restoring Dreamweaver settings (TechNote tn_18736) for details. 

How do I reinstall Dreamweaver?

1 Copy the Dreamweaver installer from the CD to the Desktop. (Browse the CD and look for FSCOMMAND > 
DW_client_installer.

2 Shut down 10.x ( Apple Menu > Shut Down)

3 Turn on the machine and hold down the Shift key to start in Safe Boot (also called Safe Mode).

4 Run the Dreamweaver installer in Safe Mode.

http://docs.info.apple.com/article.html?artnum=106214
http://docs.info.apple.com/article.html?artnum=106214
http://www.info.apple.com/kbnum/n106667
http://helpx.adobe.com/dreamweaver/kb/#main_uninstall
http://helpx.adobe.com/dreamweaver/kb/#main_reinstall
http://helpx.adobe.com/dreamweaver/kb/#main_disable_font
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=8f101099
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_18736
http://docs.info.apple.com/article.html?artnum=107393
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5 Restart the machine to log out of Safe Mode.

How to disable a font?

Mac OS X error when launching Fireworks (TechNote tn_16404) describes how to disable fonts. To add or remove 
Classic Fonts from the Font folder, please see Apple knowledge base document, How to Add or Remove Classic Fonts. 
Another font resource is the knowledge base document, Font Locations and Their Purposes.

Other Macintosh OS X 10.x Troubleshooting

• Run the Hotfix for Macromedia Installers Please refer to Some applications do not run after upgrading Macintosh 
OS X versions (ServiceNote tn_18933). Note: This step does not apply to Dreamweaver 8.

• Run Macromedia License Cleaner Please refer to Macromedia License Cleaner. Note: This step does not apply to 
Dreamweaver 8.

• Disable Start Page Some users have encountered issues where the start page of Dreamweaver causes the application 
to hog memory or causes launching issues. This issue was first reported on Macintosh OS X 10.3.9. In most cases, 
turning off the start page would resolve the issue.

1 Go to HD:Users:[username]:Library:Preferences:Dreamweaver 8 Prefs.

2 Open the preference file in Text Edit (Control + Select the preference file and choose Open with > Text Edit).

3 In Text Edit, Choose Edit > Find >Find (Apple Command + F) and look for GENERAL PREFERENCES.

4 Change the line show start page=True to show start page=False.

5 Save the file (File > Save).

6 Test Dreamweaver 8.Note: Deleting or uninstalling/reinstalling Dreamweaver 8 will revert the preference file to 
its default settings.

• Create a New user account on Macintosh OS X 10.x with Administrator privileges (this is covered in the General 
TechNote ) 1. Go to Apple menu > System Preferences. 2. Launch Accounts dialogue in the System category. 3. Click 
the plus (+) button for New User 4. Supply all the fields in the New user dialogue window and make sure you check 
(select) "Allow user to administer this computer" in the Security tab.Note: If this option is unavailable, you might 
not be the Administrator of your machine and you may need to ask the Administrator to do this step for you. 5. Log 
on as the New User account (Apple Menu > Log out as [username]). 6. Test Dreamweaver. Note: If the problem goes 
away there may be some problem with the original account. You may consider Repairing Disk Permission.

• Repair Mac OS X permissions Permission repair in Mac OS X 10.2 or later means increasing the startup speed, 
performance and stability of the operating system. It is a good practice to repair permissions periodically. 
Permissions are privileges given to files, folders, and directory structures in Mac OS X. When files come from 
another operating system, or are installed without having correct permissions, problems may occur. For additional 
information about the Repair Disk Utility of Macintosh OS X, visit the Apple knowledge base document 
Troubleshooting permissions issues in Mac OS X.Note: You may need to verify if you have the latest update for the 
Operating System. Visit the Apple website to check for the latest update for your Operating System.

Answers to common questions

• If Dreamweaver MX is installed on Macintosh OS 9, will it run on Macintosh OS X?Yes

• If Dreamweaver MX is installed on Macintosh OS X, will it run on Macintosh OS 9?Yes

• How do I enable the root account on Macintosh OS X?Apple describes how to enable root access in the knowledge 
base document, Enabling and using the "root" user in Mac OS X.

• Where are Dreamweaver Extensions installed?Extensions installed by users are stored in 
/Users/USERNAME/Library/Application Support/Macromedia Dreamweaver 8/Configuration.

Additional information

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_16404
http://docs.info.apple.com/article.html?artnum=106737
http://docs.info.apple.com/article.html?artnum=106417
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_18933
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_18933
https://www.adobe.com/support/service/activation/license_cleaner.html
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#other_accounts
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#other_accounts
http://docs.info.apple.com/article.html?artnum=106712
http://www.apple.com
http://docs.info.apple.com/article.html?artnum=106290
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 Below you will find additional troubleshooting TechNotes and links to more resources: 

TechNotes on specific Macintosh issues

• General Macintosh Troubleshooting (TechNote tn_3500) 

• Known Macintosh conflicts (TechNote tn_15014) 

• Memory issues on the Macintosh (TechNote tn_14263) 

• FreeHand troubleshooting for the Macintosh (TechNote tn_15821) 

• Fireworks MX 2004 is not supported in a UFS formatted hard drive in Macintosh OS X 10.x (TechNote tn_19425) 

• Some applications won't run after upgrading to Macintosh OS X version 10.2.8 or to Panther (version 10.3) 
(ServiceNote tn_18933) - only applies to Dreamweaver MX 2004 users. 

• Macromedia License Cleaner - only applies to Dreamweaver MX 2004 users. 

• Macintosh OS 9.1 issues (TechNote tn_15072) - only applies to Dreamweaver 4 and Dreamweaver UltraDev 4 users. 

TechNotes on Font issues

• How to detect a corrupt font on the Macintosh (TechNote tn_15830) 

• Mac OS X error when launching Fireworks MX (TechNote tn_16404) 

• Font installation in Macintosh OS X (TechNote tn_15818) 

• Font Locations and Their Purposes (Apple Knowledge Base document 106417) 

• To Add or Remove Classic Fonts (Apple Knowledge Base document 106417) 

Third-party resources

• Mac OS X: Troubleshooting a Startup Issue (Apple Support Article ID 106464) 

• Mac OS X: How to Force Background Maintenance Tasks (Logs and Temporary Items) (Apple Support Article ID 
107388) 

• Common system error messages: what they mean and what might help resolve the problem (Apple Support Article 
ID 55743) 

• Mac OS X 10.2, 10.3: Starting up in Safe Mode (Apple Support Article ID 107393) 

• Choosing UFS or Mac OS Extended (HFS Plus) Formatting (Apple Support Article ID 25316) 

• Enabling and using the "root" user in Mac OS X (Apple Support Article ID 106290) 

• Troubleshooting permissions issues in Mac OS X (Apple Support Article ID 106712) 

• Troubleshooting solutions for the Macintosh can be found at the following web site: http://www.macfixit.com

Third party links

Although links to external web sites are provided as a resource, the web sites are not part of Macromedia. Please see the 
Macromedia policy regarding links to third party web sites in the Legal Notices and Information section. Pages to 
external web sites will open in a new browser window.

Understanding the Template Updating option in 
Dreamweaver 8.0.1-8.0.2
Description

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15014
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_14263
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15821
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_19425
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_18933
http://helpx.adobe.com/dreamweaver/kb//support/service/activation/license_cleaner.html
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15072
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15830
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_16404
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15818
http://docs.info.apple.com/article.html?artnum=106417
http://docs.info.apple.com/article.html?artnum=106737
http://docs.info.apple.com/article.html?artnum=106464
http://docs.info.apple.com/article.html?artnum=107388
http://docs.info.apple.com/article.html?artnum=55743
http://docs.info.apple.com/article.html?artnum=107393
http://docs.info.apple.com/article.html?artnum=25316
http://docs.info.apple.com/article.html?artnum=106290
http://docs.info.apple.com/article.html?artnum=106712
http://www.macfixit.com/
http://helpx.adobe.com/en/dreamweaver/dreamweaver-copyright-trademarks-third-party-notices.html
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 After updating from Dreamweaver 8.0 to either Dreamweaver 8.0.1 or 8.0.2, you will see a new Templates category 
added to the Site Definition dialog box. This category consists of just one checkbox: "Template Updating: Don't rewrite 
document relative paths" (shown below): 

Why would you want to uncheck the Template Updating checkbox?

By default, the Template Updating checkbox is checked. If your template workflow matches the three-step workflow 
listed below, you might want to consider unchecking the Template Updating checkbox, otherwise, you should leave it 
checked. You should consider unchecking the checkbox if your workflow includes all of the following items:

1 You are using a Dreamweaver template (DWT file).

2 The DWT file contains relative paths pointing to server-side include (SSI) files, CSS files, links or images.

3 The SSI files, CSS files, links, or images being pointed to are also located in the Templates folder along with the DWT 
file. In other words, your Templates folder contains non-template items.

 If you are not using Dreamweaver templates, or you only have DWT files in your Templates folder, you can most likely 
leave this checkbox checked (the default setting). 

What changed in Dreamweaver 8.0?

 Dreamweaver MX 2004 and Dreamweaver MX would not touch any path that pointed into the Templates folder, 
inconsistent from how Dreamweaver would deal with any other types of paths in a template. Due to complaints from 
some Dreamweaver MX 2004 and Dreamweaver MX users regarding this inconsistency, Dreamweaver 8.0 was changed 
so that it treated paths into the Templates folder just like it treated any other path. This change caused problems for 
some Dreamweaver users though, who were used to the Dreamweaver MX 2004 behavior. 

In Dreamweaver 8.0, new pages created from templates with paths that pointed into the Templates folder, always had 
the Templates folder added to the path. For example, in Dreamweaver 8.0, the following code in the parent template 
DWT file in either a non-editable or editable region: 

<!--#include -->

 would be rewritten to something similar to one of the following paths when a new child page was created from the 
template: 

<!--#include --><!--#include -->

 The Dreamweaver 8.0 way of writing paths is problematic if you want the item being linked to, to be relative to the child 
pages and not to the parent template. For example, each of your template child pages may have its own CSS, SSI or image 
file. In the sample site below, each department has its own unique SSI file that consists of department-specific content, 
but the SSI files are all named include.inc. 

Since the include files' names are the same for all departments, you may have manually entered the path <!--#include -
-> in the parent template file. 

Note: When entering paths in Dreamweaver templates, it is recommended to browse to the file through the 
Dreamweaver user interface, so Dreamweaver writes the path for you. Manually entering a path in a Dreamweaver 
template is not a recommended workflow. However, you may find your setup similar to the one above, and there may 
not be a better alternative for your project. 
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In the example site above, my_template.dwt has the following path: 

<!--#include -->

 When you create the child page hr_child_pg.htm from my_template.dwt, the include file path turns into this: 

<!--#include -->

 Since there isn't an include.inc file in the Templates folder, the page breaks. You can't workaround this problem by 
placing the include.inc file in the Templates folder, because each include.inc file in the different departments' subfolders 
actually has different content, even though they all share the same file name. A site root relative path also can't be used 
because each department's include file has different content -- a site root relative path would just point to one of the 
include.inc files. 

How Dreamweaver MX 2004 and Dreamweaver MX wrote paths

 In Dreamweaver MX 2004 (version 7) and Dreamweaver MX (version 6), the following code in the parent template 
DWT file in either a non-editable or editable region: 

<!--#include -->

would remain untouched when a new child page was created from the template: 

<!--#include -->

How to get Dreamweaver 8 to leave these paths alone

With the Dreamweaver 8.0.2 or 8.0.1 Updaters, the Template Updating checkbox is checked by default, which means 
the default behavior is now to leave relative paths alone that point to items located inside the Templates folder, which 
is the same behavior as Dreamweaver MX 2004 and Dreamweaver MX. If you would prefer to have Dreamweaver 8.0.2 
or 8.0.1 treat relative paths that point to items located inside the Templates folder as it would any other path and re-
write them, then go into the Site Definition dialog box and uncheck the Template Updating checkbox. That way, 
Dreamweaver will add the Templates folder to the path, which was the default behavior and only option in 
Dreamweaver 8.0.

How synchronize works in Dreamweaver 8
For the Dreamweaver 8 release, Adobe did a major redesign of Dreamweaver's synchronize feature. While the 
synchronize feature worked great for most users, some users were encountering accuracy problems. The new algorithm 
implemented in Dreamweaver 8 gets used when synchronizing files. But it's also used to determine whether remote files 
have changed on the server when putting. That way, Dreamweaver can warn you that you could be overwriting changes 
on the server.

Note: This TechNote only applies to Dreamweaver 8 and later. The synchronize feature was redesigned in Dreamweaver 
8, so the information mentioned here does not apply to Dreamweaver MX 2004 and earlier.

https://www.adobe.com/support/dreamweaver/downloads_updaters.html
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How Dreamweaver MX 2004 determines whether a file has changed locally, 
remotely or both
Dreamweaver MX 2004 determined whether a local file is newer than the remote file by figuring out the difference 
between the time stamp of the local file and of the remote file. Then, it adjusted for the difference in remote server time 
versus local machine time. This method worked, but there were a few flaws in the system. FTP servers don't return 
seconds, and when files are from a previous year, don't even return an hour and minute. Also, machine times can drift 
over time at different rates. So that Dreamweaver MX 2004 knew for certain that the remote and local files were 
identical, it set the local time stamp to match the remote time stamp after every put or get. This method led to a usability 
issue, since you now don't really know when a file was last updated locally. Dreamweaver 8 no longer alters the 
date/time stamp of the local file to match the remote date/time stamp. So, it reflects the local time when the file was last 
saved.

The dwsync.xml file
Whenever you put or get a file, Dreamweaver 8 now locally stores the remote and local date/time stamps in files called 
dwsync.xml. These files are in the hidden _notes folder in the same folder as the files being transferred. All files in a 
folder store their date/time stamp in that folder's dwsync.xml file. Therefore, there is only one dwsync.xml file per 
folder. If your site has multiple subfolders, then you also have multiple dwsync.xml files and _notes folders one 
dwsync.xml file and one _notes folder for each subfolder. While the _notes folder is primarily used to hold Design 
Notes, the dwsync.xml file is not considered a Design Note. The dwsync.xml files only reside locally. Dreamweaver 
never uploads the dwsync.xml file to the server, and there is no reason to upload it to the server.

New algorithm for determining whether a file has changed locally, remotely, 
or both
When Dreamweaver 8 needs to determine which files to upload to the server or download from the server, it uses the 
following algorithm:

If the dwsync.xml file exists, and there is an entry for the file in the dwsync.xml file:

Dreamweaver 8 checks to see if there is an entry in the dwsync.xml file for the local file. If so, Dreamweaver sees if the 
time stamp in dwsync.xml for the local file is different from the current time stamp of the local file. If so, the local file 
has been altered since the last get or put. Dreamweaver does the same check for the remote file. If the remote file time 
stamps do not match, the remote file has been changed since the last get or put you did.

If the dwsync.xml file does not exist, or if there is no entry for the file in the dwsync.xml file:

If no dwsync.xml file exists and the time stamps are the same, Dreamweaver still assumes that the files are identical. If 
no dwsync.xml file exists or no entry for that file is in the dwsync.xml file, Dreamweaver falls back to figuring out the 
newer file using the time stamps and machine time stamp difference. The exception is when the difference in file time 
stamps is smaller than the difference in machine times. For that scenario, Dreamweaver can't determine with 
confidence whether the local file or the remote file or both files have changed. This issue was the primary source of 
problems where Dreamweaver MX 2004 said that the remote file was newer. Therefore, Dreamweaver 8 now leaves it 
up to you to tell Dreamweaver which file is the correct one or to do a merge of the files.

Dreamweaver 8 synchronize statuses
In Dreamweaver 8, each file evaluated now has a status of "Local Newer," "Remote Newer," "Same," or "Don't know." 
During synchronize, "Local Newer" files are uploaded, "Remote Newer" files are downloaded and "Same" files are not 
uploaded or downloaded. Finally, "Don't know" files are reported to you to allow you to merge the files or figure out 
which file is newer.
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Local Newer If the local file has changed and the remote file hasn't changed.

Remote Newer If the remote file has changed and the local file hasn't changed.

Don't Know If both files have changed or if no entry exists for that file.

Same If neither file has changed or no entry exists and the time stamps are the same.

Changes to the Synchronize dialog box
The Synchronize functionality in Dreamweaver 8 uses the new algorithm for comparing files. Therefore, there is a new 
category of files to list those in which Dreamweaver cannot determine whether the local or remote file is the newer file. 
Dreamweaver MX 2004 only listed files it was going to Get, Put, or Delete. Dreamweaver 8 lists all of the files so you 
get a clear picture of what Dreamweaver is doing. The choices in the Action column are: Put, Get, Resolve, Delete, 
Ignore, or Synchronized. If the Action is Ignore, the Status column indicates why either "The local and remote version 
of the file changed since the last synchronization. Please decide whether to put or get this file." or "Not enough 
information to synchronize".

You have the option of seeing files Dreamweaver thinks are already synchronized or that Dreamweaver would ignore 
by clicking the "Show all files" checkbox. By default, this is deselected so that Dreamweaver doesn't clutter the dialog 
box with all of the already synchronized files.

You can make a selection of files and change what Dreamweaver does when you click OK. All of these buttons change 
the action to be performed but don't perform the action until you click OK. Here's what clicking each of the buttons in 
the above dialog does:

Mark selected files to get the testing version If you are doing a two-way synchronize, you can choose whether to 
Get the file by clicking this button. Changes the action to Get.

Mark selected files to put the local version If you are doing a two-way synchronize, you can choose whether to 
Put the file by clicking this button. Changes the action to Put.

Mark selected files for deletion If you want to delete any file in the list, you can choose to delete files by clicking 
the Delete button. Deletes the file from both the local and remote side, if necessary. Changes the action to Delete.

Ignore selected files during this synchronization Changes the action to Ignore and the status to "User is ignoring."

Mark selected files as already synchronized You can inform Dreamweaver that the selected files are already 
synchronized. Changes the action to Synchronized and status to "Files are synchronized." Creates entries for the 
selected files in the dwsync.xml files for those files upon you clicking OK. If you cancel, no changes are made to the xml 
file. Also note the current local and remote time stamps in the dwsync.xml file.

Compare the testing and local versions of the selected files One new option in Dreamweaver 8 is it allows you to 
compare the local and remote files. To do this, you select those files to compare and click Compare to launch the 
integrated file diff tool and passes in the selected files.

There is also a right-click context menu which has options to match the buttons mentioned above:

 If you select Synchronize and no synchronization is necessary, Dreamweaver puts up a message stating that. 
Dreamweaver 8 also allows you to click the Yes button and see the list of files anyway and override whether the 
synchronization happens: 
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Maintain Synchronization Information site definition preference
Dreamweaver 8 has a new preference to determine if Dreamweaver should track file time stamps in the dwsync.xml 
files mentioned above. This preference is enabled by default. But, if you are not interested in using the synchronize 
feature, consider turning it off to speed up performance. Also turn it off if you don't want to be warned about potentially 
overwriting changes on the server. If you are experiencing problems with the synchronize feature, temporarily disabling 
and reenabling this preference clears out Dreamweaver's synchronize information. For more information, see 
"Troubleshooting synchronization problems in Dreamweaver" (TechNote kb400975 ). The preference is a site-specific 
preference and is located in the Remote Info category of the site definition dialog box.

A warning appears if you deselect the preference indicating that synchronization is disabled for that site. You aren't 
warned of potentially overwriting changes on the server.

If the preference is on, Dreamweaver gets the remote file's current time stamp and compare it to the one in the 
dwsync.xml file. If no dwsync.xml file exists or the remote time stamp isn't in the dwsync.xml file, Dreamweaver 
doesn't warn you. Dreamweaver only warns if it knows with certainty the remote file has changed since the last 
synchronization. You are presented with the following dialog and given the choice of comparing the remote file to the 
local file, putting the local file, or canceling the put operation. Clicking "Compare" downloads the remote file to a 
temporary file and launches the file diff tool comparing the downloaded temp file to the local file.

Additional information
For more information on Dreamweaver's synchronize feature, see the following section of the Dreamweaver 
documentation: Synchronizing the files on your local and remote sites.

Synchronize and Select Newer options are not working 
correctly

Issue
 Dreamweaver takes a long time to connect and/or timestamp related functions do not work correctly. When you check 
the site FTP log, you can see that Dreamweaver is failing to create and remove the temporary XYIZNWSK folder (MKD 
XYIZNWSK and RMD XYIZNWSK). The functions you may be seeing problems with include Select Newer, 
Synchronize, and the warning when Getting and Putting older versions of files. 

Note: This TechNote applies to Dreamweaver MX 2004 and earlier. The Synchronize and Select Newer features were 
redesigned in Dreamweaver 8 and the XYIZNWSK folder is no longer created by Dreamweaver. For more information, 
see "How synchronization works in Dreamweaver 8" (TechNote kb400972 ). 

Reason
 You don't have permission to create a directory in the default login directory of the remote server. Dreamweaver MX 
2004 and earlier create a temporary directory (XYIZNWSK) and read the server's timestamp to establish the time 
difference. This allows Dreamweaver to complete functions that involve comparing files' timestamps. 

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb400975
http://livedocs.macromedia.com/dreamweaver/8/using/05_sit45.htm
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb400972
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Solution
 In order for the timestamp-related functions to work correctly in Dreamweaver MX 2004 and earlier, users must have 
permission (set by the server administrator) to create directories in the default login directory. 

Subversion resources | Dreamweaver CS4, CS5, CS5.5, 
CS6

About Subversion
Subversion (SVN) is a revision control system initiated in 2000 by CollabNet, Inc.

Developers use Subversion to maintain current and historical versions of files such as source code, web pages, and 
documentation. Its goal is to be a mostly compatible successor to the widely used Concurrent Versions System (CVS). 
For information on using Subversion within Dreamweaver, see the Dreamweaver documentation:

• Use Subversion (SVN) to get and check in files in Dreamweaver CS4

• Use Subversion (SVN) to get and check in files in Dreamweaver CS5

Subversion versions and Dreamweaver
Dreamweaver CS6 and Dreamweaver CS5.5 use the Subversion 1.6.9 client library.

Dreamweaver CS5 uses the Subversion 1.6.6 client library. Later versions of the Subversion client library are not 
backward-compatible. If you update a third-party client application (for example, TortoiseSVN) to work with a later 
version of Subversion, the updated Subversion application updates local Subversion metadata. Dreamweaver can no 
longer communicate with Subversion.

You can, however, generally use multiple clients/servers of Subversion successfully as long as they're all the same 
major.minor version. For example, 1.4.x works with 1.4.x (and 1.4.5 works with 1.4.6), 1.6.x works with 1.6.x (and 1.6.6 
works with 1.6.9), and so on. Errors can arise when you update files with a third-party tool that automatically updates 
your local Subversion meta data to a later version. Then, Dreamweaver becomes incompatible with Subversion.

Dreamweaver CS4 users can use a downgrader extension that restores meta data to the previous version of Subversion. 
For more information, see Error: "SVN: #155021. You cannot update this file using Dreamweaver's Subversion 
integration... " | Dreamweaver CS4 (kb406661).

Resources for working with Dreamweaver and Subversion
For basic information on setting up a Dreamweaver site to work with Subversion, see the Dreamweaver documentation 
referenced above.

The following additional information below can also be useful:

• Connecting to an SVN server (video)

• Configure Subversion with SSH | Dreamweaver CS4, CS5, CS5.5, CS6

• Using Subversion with Dreamweaver CS5 – Part 1: Introducing Subversion

• Using Subversion with Dreamweaver CS5 – Part 2: Configuring Dreamweaver to use Subversion 

http://help.adobe.com/en_US/Dreamweaver/10.0_Using/WS80FE60AC-15F8-45a2-842E-52D29F540FED.html
http://help.adobe.com/en_US/dreamweaver/cs/using/WS80FE60AC-15F8-45a2-842E-52D29F540FED.html
http://kb2.adobe.com/cps/406/kb406661.html
http://kb2.adobe.com/cps/406/kb406661.html
http://www.adobe.com/go/lrvid4049_dw
http://kb2.adobe.com/cps/406/kb406167.html
http://www.adobe.com/devnet/dreamweaver/articles/using_subversion_pt1.html
http://www.adobe.com/devnet/dreamweaver/articles/using_subversion_pt2.html
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• Using Subversion with Dreamweaver CS5 – Part 3: Configuring Apache with Subversion support 

Errors connecting to Subversion servers
The following errors can occur when attempting to connect to a Subversion server from Dreamweaver. Use the 
information below to resolve these issues.

• Error: "SVN: #155021. You cannot update this file using Dreamweaver's Subversion integration... " | Dreamweaver 
CS4 (kb406661)

Restore preferences | Dreamweaver CS4, CS5, CS5.5
For information on resetting preferences in Dreamweaver CS6 and Dreamweaver CC versions, click here .

Damaged preferences files can cause crashes, errors, and other unexpected behavior in Dreamweaver. Follow the 
instructions below to restore preferences to the default settings.

Disclaimer: Some of these procedures involve editing the Windows registry. Adobe doesn't provide support for editing 
the registry, which contains critical system and application information. Make sure to back up the registry before 
editing it. For more information about the registry, see the Windows documentation or contact Microsoft.

Windows users: Some of the procedure below require you to access hidden folders. By default, Windows does not 
display hidden folders or files. For instructions on showing these hidden folders, see Show hidden files, folders, and 
filename extensions | Windows XP, Vista, Windows 7 .

Mac OS 10.7 "Lion" users: Some of the procedure below require you to access your user Library folder. In Mac OS 10.7, 
Apple has made this folder hidden. For instructions to access your user Library, see Access hidden user library files | 
Mac OS 10.7 Lion .

Remove existing preferences
To remove existing preferences, follow the instructions below that are appropriate for your operating system and 
version of Dreamweaver.

• Mac OS 

• Windows 7, Windows Vista 

• Windows XP 

Remove preferences on Mac OS
1 Quit Dreamweaver.

2 In the Finder, navigate to /Users/Your User Name/Library/Application Support/Adobe.

3 Rename the Dreamweaver preferences folder:

• Dreamweaver CS5.5: Rename the Dreamweaver CS5.5 folder to, for example, Old Dreamweaver CS5.5.

• Dreamweaver CS5: Rename the Dreamweaver CS5 folder to, for example, Old Dreamweaver CS5.

• Dreamweaver CS4: Rename the Dreamweaver CS4 folder to, for example, Old Dreamweaver CS4.

4 Navigate to /Users/Your User Name/Library/Preferences.

http://www.adobe.com/devnet/dreamweaver/articles/using_subversion_pt3.html
http://kb2.adobe.com/cps/406/kb406661.html
http://kb2.adobe.com/cps/406/kb406661.html
http://helpx.adobe.com/en/dreamweaver/kb/restore-preferences-dreamweaver-cs6-cc.html
http://helpx.adobe.com/en/x-productkb/global/show-hidden-files-folders-extensions.html
http://helpx.adobe.com/en/x-productkb/global/show-hidden-files-folders-extensions.html
http://helpx.adobe.com/en/x-productkb/global/access-hidden-user-library-files.html
http://helpx.adobe.com/en/x-productkb/global/access-hidden-user-library-files.html
http://helpx.adobe.com/dreamweaver/kb/#main_RestoreMac
http://helpx.adobe.com/dreamweaver/kb/#main_Restore7V
http://helpx.adobe.com/dreamweaver/kb/#main_RestoreXP
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5 Rename the Dreamweaver preferences file:

• Dreamweaver CS5.5: Rename the Adobe Dreamweaver CS5.5 Prefs file to, for example, Old Adobe 
Dreamweaver CS5.5 Prefs.

• Dreamweaver CS5: Rename the Adobe Dreamweaver CS5 Prefs file to, for example, Old Adobe Dreamweaver 
CS5 Prefs.

• Dreamweaver CS4: Rename the Adobe Dreamweaver CS4 Prefs file to, for example, Old Adobe Dreamweaver 
CS4 Prefs.

Remove preferences on Windows 7 or Windows Vista
1 Exit Dreamweaver.

2 In Windows Explorer, navigate to C:\Users\Your User Name\AppData\Roaming\Adobe.

3 Rename the Dreamweaver preferences folder:

• Dreamweaver CS5.5: Rename the Dreamweaver CS5.5 folder to, for example, Old Dreamweaver CS5.5.

• Dreamweaver CS5: Rename the Dreamweaver CS5 folder to, for example, Old Dreamweaver CS5.

• Dreamweaver CS4: Rename the Dreamweaver CS4 folder to, for example, Old Dreamweaver CS4.

4 Choose Start, type regedit in the Start Search, and then press Enter.

5 In the left pane of the Registry Editor, navigate to the following key: HKEY_CURRENT_USER\Software\Adobe

6 Remove the Dreamweaver preferences registry entries.

Dreamweaver CS5.5

a Select the Dreamweaver CS5.5 key, then choose File > Export. In the Export Registry File dialog, enter a filename 
and location, and then click Save.

b Ensure the Dreamweaver CS5.5 key is still selected, and then choose Edit > Delete. In the Confirm Key Delete 
dialog, click Yes.

Dreamweaver CS5

c Select the Dreamweaver CS5 key, then choose File > Export. In the Export Registry File dialog, enter a filename 
and location, and then click Save.

d Ensure that the Dreamweaver CS5 key is still selected, and then choose Edit > Delete. In the Confirm Key Delete 
dialog, click Yes.

Dreamweaver CS4

e Select the Dreamweaver CS4 key, then choose File > Export. In the Export Registry File dialog, enter a filename 
and location, and then click Save.

f Ensure that the Dreamweaver CS4 key is still selected, and then choose Edit > Delete. In the Confirm Key Delete 
dialog, click Yes.

7 Exit the Registry Editor.

Remove preferences on Windows XP
1 Exit Dreamweaver.

2 In Windows Explorer, navigate to C:\Documents and Settings\Your User Name\Application Data\Adobe.

3 Rename the Dreamweaver preferences folder:

• Dreamweaver CS5.5: Rename the Dreamweaver CS5.5 folder to, for example, Old Dreamweaver CS5.5.
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• Dreamweaver CS5: Rename the Dreamweaver CS5 folder to, for example, Old Dreamweaver CS5.

• Dreamweaver CS4: Rename the Dreamweaver CS4 folder to, for example, Old Dreamweaver CS4.

4 Choose Start > Run. Type regedit in the Open text box, and then press Enter or click OK.

5 In the left pane of the Registry Editor, navigate to the following key: HKEY_CURRENT_USER\Software\Adobe

6 Remove the Dreamweaver preferences registry entries:

Dreamweaver CS5.5

a Select the Dreamweaver CS5.5 key, then choose File > Export. In the Export Registry File dialog, enter a filename 
and location, and then click Save.

b Ensure the Dreamweaver CS5.5 key is still selected, and then choose Edit > Delete. In the Confirm Key Delete 
dialog, click Yes.

Dreamweaver CS5

c Select the Dreamweaver CS5 key, then choose File > Export. In the Export Registry File dialog, enter a filename 
and location, and then click Save.

d Ensure that the Dreamweaver CS5 key is still selected, and then choose Edit > Delete. In the Confirm Key Delete 
dialog, click Yes.

Dreamweaver CS4

e Select the Dreamweaver CS4 key, then choose File > Export. In the Export Registry File dialog, enter a filename 
and location, and then click Save.

f Ensure that the Dreamweaver CS4 key is still selected, and then select Edit > Delete. In the Confirm Key Delete 
dialog, click Yes.

7 Exit the Registry Editor.

Try to re-create the problem
After you have removed your existing preferences, restart Dreamweaver. The application creates new preferences files, 
folders, and registry entries, as applicable, using the default settings. 

Then try to re-create the problem that you had before.

If the problem was resolved, then damaged preferences was the cause.

If the problem persists, then the preferences are not the cause and you can replace the original preferences.

To replace the original preferences:

1 Quit Dreamweaver.

2 Delete the new preferences folder and restore the original name of the previous folder.

3 Do one of the following:

• Mac OS: Delete the new preferences file and restore the original name of the previous preferences file.

• Windows: Double-click the registry backup file you created.
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More Help topics 
Troubleshoot system errors and freezes | Adobe software on Mac OS 10.x

Troubleshoot system errors and freezes | Adobe software on Windows

Troubleshoot unexpected behavior that occurs only in a particular user account | Adobe software on Mac OS

Troubleshoot unexpected behavior that occurs only in a particular user account | Adobe software on Windows 7 and 
Vista

Troubleshoot unexpected behavior that occurs only in a particular user account | Adobe software on Windows XP

The registration message box continues to appear on 
launch after registration
IssueIn Dreamweaver 3 on Windows 2000 or Windows NT, a message box appears on every launch prompting the user 
to register. This prompt repeatedly appears on launch although Dreamweaver 3 has been registered or the user has 
clicked "Don't Remind Me." 

Note:This situation does not occur in Dreamweaver 4. 

ReasonOn Windows 2000 and Windows NT, only the Administrator or users with certain permissions can install 
applications. If an administrator installs the application and then another non-administrative user launches the 
application, the prompt to register can appear on every launch. 

Solutions One of the following two solutions may solve the problem: 

http://kb2.adobe.com/cps/824/cpsid_82414.html
http://kb2.adobe.com/cps/822/cpsid_82252.html
http://kb2.adobe.com/cps/408/kb408993.html
http://kb2.adobe.com/cps/408/kb408995.html
http://kb2.adobe.com/cps/408/kb408995.html
http://kb2.adobe.com/cps/408/kb408994.html


31

Last updated 11/5/2015

Re-creating the Dreamweaver user configuration folder 
on Windows
 If Dreamweaver starts behaving unpredictably, this can be an indication that the Dreamweaver user configuration 
folder has become corrupt. Dreamweaver (version MX and later) allows multiple users to log in to a machine and 
customize Dreamweaver to their liking. For example, each user can have different snippets, menu options, extensions, 
spelling dictionaries, etc. These customizations are saved in each user's configuration folder in Windows. To test for a 
corrupt user configuration folder, try the following: 

1 Exit from Dreamweaver if necessary.

2 Open Windows Explorer by right-clicking the main Start button and selecting Explore.

Installer disables the registration message box Whoever installed 
the application must log in, launch Dreamweaver and click "Don't 
Remind Me" on the registration message box. The user may then be 
able to log in and run the application without the appearance of the 
prompt. 

User reinstalls Dreamweaver3

1

 Uninstall Dreamweaver 3 using Add/Remove programs. 
(Start this process by choosing Start > Settings > Control 
Panel> Add/Remove programs. Select Dreamweaver 3 
and then click Change/Remove.) 

Note: Uninstalling Dreamweaver 3 will clear all your Site 
Definition information. After reinstalling the program, 
you will have to reenter the Site Definition information to 
redefine all your sites. Write down all Site Definition 
information;including all FTP information for each 
site;before uninstalling Dreamweaver 3. 

2

 Reinstall Dreamweaver 3 under an Administrative login 
or as a user with permissions. The login must be the same 
login that will be used to run the application after 
installation. 

3

 Launch Dreamweaver 3 (using the same login that was 
used to reinstall the application). 

4

 Click an option on the registration message box. Clicking 
"Don't Remind Me" will prevent the appearance of the 
registration message box the next time that Dreamweaver 
launches. 
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3 In Windows Explorer, browse to the following folder (this example assumes Dreamweaver 8): C:\Documents and 
Settings\[username]\Application Data\Macromedia\Dreamweaver 8Note: To see this folder, you may need to make 
the following change in Windows Explorer: Tools > Folder Options > View > Advanced Settings section> Files and 
Folders section > Hidden Files and Folders > turn on "Show hidden files and folders".

4 Re-name this folder to an arbitrary name, such as "OLD Dreamweaver 8." Once the user configuration folder has 
been renamed, Dreamweaver will no longer be able to find it and Dreamweaver will automatically create a new user 
configuration folder with the default settings.

5 Launch Dreamweaver and see if the problem still occurs.

6 If the problem is resolved after re-creating the user configuration folder, you can delete your old user configuration 
folder, but save any files you may have customized and try to transfer them over to the newly created user 
configuration folder. See Backing up and restoring Dreamweaver settings (TechNote 18736). Note that these 
customized files may be the source of the problem. If the problem is reintroduced after copying old files back in, go 
through steps 1-5 again to get a clean user configuration folder, then transfer customized files one at a time, testing 
for the problem after each file is transferred, to identify the problem file.Note: If you have Dreamweaver extensions 
installed, it is not recommended to move existing user configuration subfolders back into the new user 
configuration folder since extensions can write files to various subfolders in the Dreamweaver user configuration 
folder. Instead, extension users should start from the new user configuration folder and reinstall extensions using 
the Extension Manager installer one at a time. Test each extension individually after installing it, so that you can 
identify any problematic extensions.

Optional step

 If the steps above don't solve the problem, then go back through the steps above again, but insert the following step 
after step4: 

WARNING: If you edit the Windows Registry incorrectly, you can cause serious problems that may require you to 
reinstall your operating system. Adobe does not guarantee that problems that you cause by editing the registry 
incorrectly can be resolved. Edit the registry at your own risk. 

? Backup the Dreamweaver user configuration registry key, delete it, and then restart Dreamweaver to see if it fixes 
the problem. To do this choose Start button > Run > type in "regedit". In the Registry Editor, find the following key 
(this example uses Dreamweaver 8):HKEY_CURRENT_USER\Software\Macromedia\Dreamweaver 8 Select the 
Dreamweaver 8 folder and choose File > Export (so that it is backed up), and then delete it (Edit > Delete).

Additional Information
 If this TechNote doesn't resolve the problem, then here are some additional TechNotes that may help: 

• Troubleshooting Dreamweaver for Windows (TechNote 15481) 

• Troubleshooting JavaScript errors in Dreamweaver (TechNote 19105) 

• Uninstalling Studio 8 applications on Windows (TechNote 4e7826b7) 

• Uninstalling Dreamweaver MX & MX 2004 on Windows (TechNote 362d7b81) 

• Installing Studio 8 products in Selective Startup mode on Windows XP (TechNote d2b5934d) 

• Installing Dreamweaver MX & MX 2004 in Safe Mode on Windows (TechNote 362eefb2) 

• Dreamweaver crashes when performing a task related to site definitions (TechNote 5989f7f4) 

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_18736
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15481
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_19105
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=4e7826b7
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=362d7b81
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=d2b5934d
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=362eefb2
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=5989f7f4
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Protecting PHP server behaviors from SQL injection 
vulnerability

Issue
Some databases let you send multiple SQL statements in a single query. Therefore, there are potential security risks 
when you pass parameters in a query string to a dynamically generated database query. Hackers could try to modify 
URL or form variables in a dynamic query by appending malicious SQL statements to existing parameters. This is often 
referred to as a SQL injection attack. Some of the server behavior code created by Dreamweaver should be modified to 
reduce the risk of SQL injection attacks. For more background information on SQL injection, see this Wikipedia article. 
(Ref. 201713)

Note: The issue described in this TechNote has been fixed in the Dreamweaver 8.0.2 Updater.

This TechNote covers Dreamweaver's PHP server behaviors. There are separate TechNotes for the ColdFusion , ASP 
VBScript , ASP JavaScript , and JSP server behaviors. The ASP.NET server behaviors are not affected.

Solution
When you let a query string pass a parameter, ensure that only the expected information is passed. Adobe has created 
a Dreamweaver 8.0.2 Updater that reduces the risk of SQL injection attacks. These fixes will be incorporated into all 
future releases of Dreamweaver. After updating Dreamweaver 8, you will need to reapply the server behaviors to the 
pages that use them, and redeploy those pages to your server.

The remainder of this TechNote documents how to manually edit Dreamweaver MX 2004 code to prevent SQL 
injection attacks with the PHP server model. Server behaviors that are vulnerable to these attacks are listed below, along 
with fixes:

• Recordset with a filter 

• Insert, Update, and Delete Record server behaviors and Record Insertion Form wizard 

• Log In User 

• Check New User 

• Master Detail Page Set 

• Record Update Form wizard 

Recordset with a filter
 Unfiltered recordsets do not need to be modified, but filtered recordsets do. In the example below, a Dreamweaver MX 
2004 recordset named "rs_byDate" is filtered by a date value passed in from a URL parameter. The highlighted code 
below is what needs to be changed: 

<?php $colname_rs_byDate = "1"; if (isset($_GET['relDate'])) {   $colname_rs_byDate = 
(get_magic_quotes_gpc()) ? $_GET['relDate'] : addslashes($_GET['relDate']); } 
mysql_select_db($database_dreamqa2, $dreamqa2); $query_rs_byDate = sprintf("SELECT * FROM 
albums WHERE relDate = '%s'", $colname_rs_byDate); $rs_byDate = mysql_query($query_rs_byDate, 
$dreamqa2) or die(mysql_error()); $row_rs_byDate = mysql_fetch_assoc($rs_byDate); 
$totalRows_rs_byDate = mysql_num_rows($rs_byDate); ?>

http://en.wikipedia.org/wiki/Sql_injection
https://www.adobe.com/support/dreamweaver/downloads_updaters.html
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=300b670e
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http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=57ae79b2
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=581a553c
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=585ac720
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 To protect the recordset from SQL injection attacks, a custom GetSQLValueString() function should be created near 
the top of the page. This function verifies the data type of the query parameter. Once the function has been created, 
then update the recordset code to use the GetSQLValueString() function. 

1 Go to the second line in code view, right after the include file for the connection, and add the GetSQLValueString() 
function to the beginning of the code as follows:

<?php if (!function_exists("GetSQLValueString")) { function GetSQLValueString($theValue, 
$theType, $theDefinedValue = "", $theNotDefinedValue = "")  {   $theValue = 
get_magic_quotes_gpc() ? stripslashes($theValue) : $theValue;   $theValue = 
function_exists("mysql_real_escape_string") ? mysql_real_escape_string($theValue) : 
mysql_escape_string($theValue);   switch ($theType) {     case "text":       $theValue = 
($theValue != "") ? "'" . $theValue . "'" : "NULL";       break;      case "long":     case 
"int":       $theValue = ($theValue != "") ? intval($theValue) : "NULL";       break;     case 
"double":       $theValue = ($theValue != "") ? "'" . doubleval($theValue) . "'" : "NULL";       
break;     case "date":        $theValue = ($theValue != "") ? "'" . $theValue . "'" : "NULL";        
break;     case "defined":       $theValue = ($theValue != "") ? $theDefinedValue : 
$theNotDefinedValue;       break;   }   return $theValue; } } ?>

2  Remove the magic quotes code so that backslashes are not incorrectly added to GET and POST data when magic 
quotes are turned off on the PHP server. Original code:

$colname_rs_byDate = (get_magic_quotes_gpc()) ? $_GET['relDate'] : 
addslashes($_GET['relDate']);

Modified code:

$colname_rs_byDate = $_GET['relDate'];

3 Update the recordset code to create a SQL string using the GetSQLValueString() function created above. Update the 
value of the variable $query_rs_byDate: Original code:

$query_rs_byDate = sprintf("SELECT * FROM albums WHERE relDate = '%s'", $colname_rs_byDate);

 Modified secured code:

$query_rs_byDate = sprintf("SELECT * FROM albums WHERE relDate = %s", 
GetSQLValueString($colname_rs_byDate, "date"));

Insert, Update, and Delete Record server behaviors and Record Insertion Form wizard
 The Insert, Update, and Delete Record server behaviors and Record Insertion Form wizard already use the 
GetSQLValueString() function, so they need to be refined to prevent SQL injections. The only changes needed are in 
the GetSQLValueString() function. 

Here is the original code. The line to change is highlighted in yellow: 

if (!function_exists("GetSQLValueString")) { function GetSQLValueString($theValue, $theType, 
$theDefinedValue = "", $theNotDefinedValue = "")    {$theValue = (!get_magic_quotes_gpc()) ? 
addslashes($theValue) : $theValue;   switch ($theType) {     case "text":       $theValue = 
($theValue != "") ? "'" . $theValue . "'" : "NULL";       break;      case "long":     case 
"int":       $theValue = ($theValue != "") ? intval($theValue) : "NULL";       break;     case 
"double":       $theValue = ($theValue != "") ? "'" . doubleval($theValue) . "'" : "NULL";       
break;     case "date":       $theValue = ($theValue != "") ? "'" . $theValue . "'" : "NULL";       
break;     case "defined":       $theValue = ($theValue != "") ? $theDefinedValue : 
$theNotDefinedValue;       break;   }   return $theValue; } }

Update the definition of the variable $theValue:
 Original code: 

http://helpx.adobe.com/dreamweaver/kb/
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$theValue = (!get_magic_quotes_gpc()) ? addslashes($theValue) : $theValue;

 Modified secured code: 

$theValue = get_magic_quotes_gpc() ? stripslashes($theValue) : $theValue; $theValue = 
function_exists("mysql_real_escape_string") ? mysql_real_escape_string($theValue) : 
mysql_escape_string($theValue);

Log In User server behavior
 Here are the steps to fix the Log In User server behavior: 

1 Create a GetSQLValueString() function as described in Recordset with a filter above.

2 Modify the code that constructs the login SQL query. Original code:
$LoginRS__query=sprintf("SELECT username, password FROM login WHERE username='%s' AND 
password='%s'",    get_magic_quotes_gpc() ? $loginUsername : addslashes($loginUsername), 
get_magic_quotes_gpc() ? $password : addslashes($password));

 Modified secured code:

$LoginRS__query=sprintf("SELECT username, password FROM login WHERE username=%s AND 
password=%s",    GetSQLValueString($loginUsername, "text"), GetSQLValueString($password, 
"text"));

Check New User server behavior
 The Check New User server behavior requires that an Insert Record server behavior be added to the page first. The 
GetSQLValuesString() function is included with the Insert Record server behavior. All that needs to be done is to 
update the GetSQLValuesString() to better handle SQL Injection and update the Check New User server behavior to 
use this function when a parameter is passed in.

1 Change the first line in the function to update the GetSQLValuesString() function as described in Update the 
definition of the variable $theValue .

2 Modify the code to construct the login SQL query to use the GetSQLValuesString() to pass in parameters. Toward 
the top of the page, locate the code in the section starting with // *** Redirect if username exists. Original code:

$LoginRS__query = "SELECT username FROM login WHERE username='" . $loginUsername . "'"

 Modified secured code:

$LoginRS__query = sprintf("SELECT username FROM login WHERE username=%s", 
GetSQLValueString($loginUsername, "text"));

Master Detail Page Set
For the Master Detail Page Set application object, the changes are mainly in the recordset that Dreamweaver creates for 
the Detail Page. If you don't have a filtered recordset in the Master Page, then no changes need to be made to the Master 
Page. If you have a filtered recordset, then see recordset with a filter to update the recordset code.

Dreamweaver creates a filtered recordset in the Detail Page, so that recordset code needs to be updated to use a 
GetSQLValueString() function to pass in parameters and sprintf() to construct the SQL string.

1 Create the GetSQLValueString() function as described in Recordset with a filter above.

2 Update the variable declaration code and construct the SQL query using the GetSQLValuesString() function. 
Original code:
$recordID = $_GET['recordID']; $query_DetailRS1 = "SELECT * FROM albums WHERE ID = 
$recordID";

http://helpx.adobe.com/dreamweaver/kb/#main_recordset
http://helpx.adobe.com/dreamweaver/kb/#main_theValue
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 Modified secured code:

$colname_DetailRS1 = "-1"; if (isset($_GET['recordID'])) { $colname_DetailRS1 = 
(get_magic_quotes_gpc()) ? $_GET['recordID'] : addslashes($_GET['recordID']); } 
$query_DetailRS1 = sprintf("SELECT * FROM albums WHERE ID = %s", 
GetSQLValueString($colname_DetailRS1, "int"));

Record Update Form wizard
1 Update the definition of the variable $theValue as described in Insert, Update, and Delete Record server behaviors 

and Record Insertion Form wizard .

2 Update the code for the Recordset which is required for the Record Update Form as described in step 2 of Recordset 
with a filter .

Additional Information
Please refer to the following article for more information about SQL injection: Wikipedia article on SQL injection.

Adobe Security Bulletin: APSB 06-07 Dreamweaver Server Behavior SQL Injection vulnerability.

Protecting ColdFusion server behaviors from SQL 
injection vulnerability

Issue
Some databases let you send multiple SQL statements in a single query. Because of this, there are potential security risks 
when you pass parameters in a query string to a dynamically generated database query. Hackers might try to modify 
URL or form variables in a dynamic query by appending malicious SQL statements to existing parameters. This is often 
referred to as a SQL injection attack. Some of the server behavior code created by Dreamweaver should be modified to 
reduce the risk of SQL injection attacks. For more background information on SQL injection, see this Wikipedia article. 
(Ref. 201713)

Note: The issue described in this TechNote has been fixed in the Dreamweaver 8.0.2 Updater.

This TechNote covers Dreamweaver's ColdFusion server behaviors. There are separate TechNotes for the PHP , ASP 
VBScript , ASP JavaScript , and JSP server behaviors. The ASP.NET server behaviors are not affected.

Solution
When you let a query string pass a parameter, ensure that only the expected information is passed. Adobe has created 
a Dreamweaver 8.0.2 Updater that reduces the risk of SQL injection attacks. These fixes will be incorporated into all 
future releases of Dreamweaver. After updating Dreamweaver 8, you will need to reapply the server behaviors to the 
pages that use them, and redeploy those pages to your server.

The remainder of this TechNote documents how to manually editDreamweaver MX 2004 code to prevent SQL injection 
attacks with the ColdFusion server model. Server behaviors that are vulnerable to these attacks are listed below, along 
with the fixes:

• Recordset with a filter 

http://helpx.adobe.com/dreamweaver/kb/#main_insert
http://helpx.adobe.com/dreamweaver/kb/#main_insert
http://helpx.adobe.com/dreamweaver/kb/#main_recordset_step2
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http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=30037473
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• Insert Record server behavior and Record Insertion Form Wizard 

• Update Record and Record Update Form Wizard 

• Delete Record server behavior 

• Log In User server behavior 

• Check New User server behavior 

• Master Detail Page Set 

Recordset with a filter
 Unfiltered recordsets do not need to be modified, but filtered recordsets do. In the example below, a Dreamweaver MX 
2004 recordset named "Recordset1" is filtered by an ID value passed in from a URL parameter. The highlighted code 
below is what will need to be changed: 

<cfquery name="Recordset1" datasource="cafetownsend"> SELECT * FROM COMMENTS WHERE COMMENT_ID 
=#URL.COMMENT_ID#</cfquery>

 To protect the recordset from SQL injection attacks, use thecfqueryparam tag within the cfquery tag that contains the 
SQL SELECT statement. Thecfqueryparam tag will verify the data type of the query parameter and help secure your 
databases from unauthorized users. The line in yellow is the modified secure code: 

<cfquery name="Recordset1" datasource="cafetownsend"> SELECT * FROM COMMENTS WHERE COMMENT_ID 
=<cfqueryparam value="#URL.COMMENT_ID#" cfsqltype="cf_sql_numeric"></cfquery>

Insert Record server behaviors and Record Insertion Form Wizard
 To protect the recordset from SQL injection attacks, use thecfqueryparam tag within the cfquery tag that contains the 
SQL INSERT statement. Thecfqueryparam tag will verify the data type of the query parameter and help secure your 
databases from unauthorized users. 

Original code. The highlighted code below is what will need to be changed: 

<cfquery datasource="cafetownsend">   INSERT INTO COMMENTS (FIRST_NAME, LAST_NAME, TELEPHONE)   
VALUES (<cfif IsDefined("FORM.textfield1") AND #FORM.textfield1# NEQ 
"">'#FORM.textfield1#'<cfelse>NULL</cfif>   ,<cfif IsDefined("FORM.textfield2") AND 
#FORM.textfield2# NEQ "">'#FORM.textfield2#'<cfelse>NULL</cfif>   ,<cfif 
IsDefined("FORM.textfield3") AND #FORM.textfield3# NEQ 
"">'#FORM.textfield3#'<cfelse>NULL</cfif>   )</cfquery>

 Modified secured code: 

<cfquery datasource="cafetownsend">   INSERT INTO COMMENTS (FIRST_NAME, LAST_NAME, TELEPHONE)   
VALUES<cfif IsDefined("FORM.textfield1") AND #FORM.textfield1# NEQ ""><cfqueryparam 
value="#FORM.textfield1#" cfsqltype="cf_sql_clob" maxlength="50"><cfelse>''</cfif>   ,<cfif 
IsDefined("FORM.textfield2") AND #FORM.textfield2# NEQ ""><cfqueryparam 
value="#FORM.textfield2#" cfsqltype="cf_sql_clob" maxlength="50"><cfelse>''</cfif>   ,<cfif 
IsDefined("FORM.textfield3") AND #FORM.textfield3# NEQ ""><cfqueryparam 
value="#FORM.textfield3#" cfsqltype="cf_sql_clob" maxlength="20"><cfelse>''</cfif>   
)</cfquery>

Note: Choose the appropriatecfslqtype and maxlength values for your data. 

http://helpx.adobe.com/dreamweaver/kb/#main_insert
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Update Record and Record Update Form Wizard
 The Update Record server behavior and Record Update Form Wizard require a combination of the fixes above. First, 
look for thecfquery that contains the SQL SELECT statement and modify it as described in Recordset with a filter . 
Then, look for the cfquery that contains the SQL UPDATE statement and modify it as described in Insert Record server 
behaviors and Record Insertion Form Wizard . 

Delete Record server behavior
 The Delete Record server behavior modification is similar to the one for Recordset with a filter . 

Original code: 

<cfquery datasource="cafetownsend">    DELETE FROM COMMENTS    WHERE 
COMMENT_ID=#URL.COMMENT_ID#</cfquery>

 Modified secure code: 

<cfquery datasource="cafetownsend">   DELETE FROM COMMENTS   WHERE COMMENT_ID=<cfqueryparam 
value="#URL.COMMENT_ID#" cfsqltype="cf_sql_numeric"></cfquery>

Note: Choose the appropriatecfslqtype and maxlength values for your data. 

Log In User server behavior
 To fix the Log In User server behavior code, look for thecfquery tags and add cfqueryparam tags. 

Original code: 

<cfquery name="MM_rsUser" datasource="cafetownsend">   SELECT FIRST_NAME,LAST_NAME FROM 
COMMENTS WHERE FIRST_NAME='#FORM.textfield1#'   AND LAST_NAME='#FORM.textfield2#'</cfquery>

 Modified secured code: 

<cfquery name="MM_rsUser" datasource="cafetownsend">   SELECT FIRST_NAME,LAST_NAME FROM 
COMMENTS WHERE FIRST_NAME=<cfqueryparam value="#FORM.textfield1#" cfsqltype="cf_sql_clob" 
maxlength="50">   AND LAST_NAME=<cfqueryparam value="#FORM.textfield2#" 
cfsqltype="cf_sql_clob" maxlength="50"></cfquery>

Note: Choose the appropriatecfslqtype and maxlength values for your data. 

Check New User server behavior
 The Check New User server behavior requires that an Insert Record server behavior be added to the page first. First, 
look for the cfquery that contains the SQL SELECT statement and modify it as described in Recordset with a filter . 
Then, look for the cfquery that contains the SQL INSERT statement and modify it as described in Insert Record server 
behaviors and Record Insertion Form Wizard . 

Master Detail Page Set
 For the Master Detail Page Set application object, the changes are mainly in the recordset that Dreamweaver creates 
for the Detail Page. If you don't have a filtered recordset in the Master Page, then no changes need to be made to the 
Master Page. If you do have a filtered recordset on the Master Page, then see Recordset with a filter to update the 
recordset code. 

For the Detail Page, look for the cfquery that contains the SQL SELECT statement and modify it as described in 
Recordset with a filter . 
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Additional Information
Adobe recommends that you use the cfqueryparam tag within every cfquery tag, to help secure your databases from 
unauthorized users. For more information, see Security Bulletin ASB99-04, "Multiple SQL Statements in Dynamic 
Queries" and Accessing and Retrieving Data in ColdFusion MX Developers Guide.

• ColdFusion MX 7 LiveDocs: Enhancing security with cfqueryparam and cfqueryparam tag description.

• Securing Database Access Using the cfqueryparam Tag (ColdFusion Developer Center Article by Dave Watts)

• Adobe Security Bulletin: APSB 06-07 Dreamweaver Server Behavior SQL Injection vulnerability

What can prevent JavaScript control over audio?
SummaryNot all browsers will let JavaScript control audio. You might consider interactive audio to be a nice addition 
for those visitors whose browsers support it, but be sure to provide visual feedback too. If you need interactive audio 
across a range of browsers, then putting the interactivity and audio in Flash or Shockwave is the standard solution. 

(This TechNote adds to previous interactive audio information in documents such as Dreamweaver 2.0's 
Troubleshooting the Control Sound Behavior Functionality . It includes information on the differences in default audio 
behaviors introduced in Dreamweaver 3.0) How do various browsers trigger audio files? The simplest method is to 
just EMBED an audio file. It will start when the page loads, and will use whatever audio player the browser prefers. You 
won't be able to trigger the audio by a mouseover or other JavaScript event, and will need to use an audio format which 
most browsers support, but a simple EMBED is the standard method of including audio when the page loads. 

Some browsers let JavaScript trigger audio, while others do not: 

http://livedocs.macromedia.com/coldfusion/7/htmldocs/00001252.htm
http://livedocs.macromedia.com/coldfusion/7/htmldocs/00001257.htm
http://livedocs.macromedia.com/coldfusion/7/htmldocs/00000317.htm
http://help.adobe.com/en_US/ColdFusion/9.0/Developing/WSc3ff6d0ea77859461172e0811cbec22c24-7c36.html
http://www.adobe.com/support/security/bulletins/apsb06-07.html
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_14049
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How do Dreamweaver's various sound behaviors work? The Control Sound Behavior in Dreamweaver 1 and 2 
attempted to play audio in browsers which supported it. If a browser did not support script control over audio, then no 
sound would be heard. 

The Play Sound Behavior in Dreamweaver 3.0 takes a different tack. If the script cannot determine that the browser has 
a controllable audio player, it will open the sound as a new page in the window. This means that you will always get the 
sound, but may lose the content. 

(Note that this behavior was current in the default behavior set of Dreamweaver 3.0, at the time of this writing in 
February 2000. It's quite possible that a newer Play Sound Behavior may replace this original one. The upcoming 
Dreamweaver Behavior Exchange would be the place to find updated behaviors and other extensions for 
Dreamweaver.) 

Netscape browsers The Netscape 3.0 browsers on PowerMac and 
Windows 95 introduced LiveConnect, which uses Java to have 
JavaScript and Netscape Plugins talk together. Not all plugins are 
LiveConnect-aware. 

Netscape's default LiveAudio plugin can be controlled by JavaScript. 
Shockwave and Flash can be controlled by JavaScript. Beatnik and 
RealPlayer can be controlled by JavaScript. QuickTime 4.1 can be 
controlled by JavaScript, while earlier versions cannot. These various 
players may have slightly different JavaScript commands exposed. 

Because of the way EMBED tags work -- you specify the MIME type, and 
the browser chooses an appropriate player -- you cannot predict what 
type of player will render your audio file. This means that JavaScript 
may or may not be able to control an audio file in any particular 
Netscape browser. 

Generally, a stock Netscape 3+ browser on a Java-enabled PowerMac 
or Win32 will let JavaScript control audio through the default 
LiveAudio Player. If someone installed an older QuickTime plugin then 
they may not be able to hear audio under JavaScript control. With 
other customizations they may or may not be able to hear audio under 
JavaScript control. 

Microsoft browsers The Microsoft 3.0 browsers on Win95 introduced 
ActiveX Scripting, where JScript could address certain ActiveX 
Controls, and VBScript could catch events from ActiveX Controls. 

The OBJECT tag for ActiveX Controls lets you specify a particular media 
player. If you're just using an EMBED tag then this does not specify a 
particular media player. In the latter case, it's possible that a particular 
browser may be set up to use an unusual media player which does not 
have script control over audio. 

The Microsoft browsers for Macintosh do not offer any means for 
scripts and plugins to communicate. (At time of writing, February 
2000, IE5/Mac is in beta and does not seem to reverse this trend.) 

Generally, IE/Win32 browsers let JavaScript control audio. IE/Mac 
browsers do not let JavaScript control audio. 

Other browsers or platforms Other browsers (such as iCab or Opera) 
and other computer platforms (such as Windows 3.1), and other 
delivery devices (such as PDAs or web phones) tend not to support 
advanced abilities such as page scripts controlling media players. 

If you're designing for a particular device in the future you might wish 
to investigate its abilities, but generally JavaScript control over audio 
is available to Java-enabled Netscape 3+ browsers on PowerMac or 
Win32, and to ActiveX-enabled Microsoft 3+ browsers on Win95 or 
better. 
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If you'd like to have the DW3 Play Sound Behavior act more like the DW2 Control Sound Behavior, and to just fail 
silently on browsers without a controllable audio player, then you might consider removing the final line in that 
behavior: "else window.location=sndFile;". This is the line that triggers the redirect to a new window with just the 
sound. 

Another approach would be to rewrite the JavaScript to open a new window that plays the sound, rather than to play 
the sound in the current window. 

If making such manual edits to behaviors, then it is good to check that your edits are still there before delivering the 
files, because Dreamweaver can automatically fix damaged behaviors. Alternately, you could make the changes in the 
master "PlaySound.js" file itself in your Configuration / Behaviors / Actions folder. 

Summary The audio control behaviors changed between Dreamweaver 2 and 3, and may change after Dreamweaver 
3.0 as well. If you'd rather not have the page play an audio file full-screen, then a small edit to the behavior could attain 
the goal today, without needing to wait for a new behavior. 

Pop-up blocker conflicts (Dreamweaver Developer 
Toolbox)

Issue
 When trying to work with Query Builder, only a browser window opens with this message: "To help protect your 
security, Internet Explorer has restricted this file from showing active content that could access your computer. Click 
here for options ...", but none of the user interface is displayed.

Reason
 You have a pop-up blocker, either the browser default, or a third-party application (e.g. the Microsoft Internet Explorer 
Pop-up Blocker available in SP2, the Mozilla Firefox one or the pop-up blocker in the Google Toolbar). 

Solution
 Disable the pop-up blocker or simply configure it to allow pop-ups for the page containing Query Builder, on a 
temporary or permanent basis. 

To disable the Internet Explorer default pop-up blocker, simply open the Tools menu>Pop-up Blocker >Turn Off Pop-
up Blocker. 

How to pass a user name from a login page
 When using Dreamweaver's Log In User server behavior, you may want to use the user name on the very next page 
(the "redirect page") or on other pages in your web application. Some reasons you may want to pass the user name onto 
other pages include: 

• You want to greet the user after logging in. For example: "Hello John!"

• You want to filter a recordset based on the user name in order to personalize the page.
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• You want to insert the user name into a form field to be used for inserting, updating or deleting a record.

The Log In User server behavior automatically generates a session variable consisting of the user name for the user 
when they log in successfully. The session variable for the user name is labeled "MM_Username". 

Note: A second session variable is also automatically generated containing the user's authorization level, should you 
need to use this information on other pages. This session variable is named "MM_UserAuthorization". 

Defining the MM_Username session variable as a data source for your pages

 To utilize the MM_Username session variable on the pages in your site, open the login page in Dreamweaver. Open 
the Bindings panel. Click the plus (+) button and choose Session Variable from the pop-up menu. In the dialog box that 
pops up, enter "MM_Username" (without the quotes) in the name field. Click OK. Expand the Session icon that appears 
in the Bindings panel. The newly defined data source should appear, with a yellow lightning bolt icon next to it. 

Using the MM_Username session variable in your pages:
• Displaying the user name on successive pages: To display the user name on any of the successive pages, open the

page where you want to display the user name. Open the Bindings panel and drag the MM_Username session
variable on the page in Design view. This will cause the session variable contents to be written to this page.

• Filtering a recordset based on the user name: Open the page where you want to create the filtered recordset. To
filter a recordset based on the session variable, go into the simple view of the Recordset dialog box, and set the filter 
to:"[myUsernameField] = Session Variable MM_Username", where"[myUsernameField]" is the name of the
database field holding the user names. The advanced view of the Recordset dialog box should be used if you are
filtering on multiple variables or if you need to use a more complex SQL statement.

• Setting a form field's value equal to the user name: Open the page that contains the form. To set a form field's value 
equal to the session variable, select the text field form element on the page. Go to the Property inspector > click the
Attributes tab in the upper left corner > click the plus (+) button > choose "value" from the drop-down menu > click 
the yellow lightning bolt icon > choose the MM_Username session
variable.

Additional information

 If you would like to pass form data other than the user name from your login page, please refer to How do I create a 
session variable? (TechNote 14791) for detailed information on creating session variables. 

For an explanation of why session variables should be used to pass form data from a login page to successive pages, 
please refer to: How to pass form data from an insert, update or delete page (TechNote 15239). Though the TechNote 
discusses the insert, update and delete server behaviors, the mechanics are similar for the Log In User server behavior. 

New template features in Dreamweaver MX
 Macromedia Dreamweaver MX introduced many new features for templates. With these new features, you can create 
templates that allow a great deal of control over page editing. With the advent of optional regions, repeat regions and 
nested templates, you can create complex, almost dynamic pages. 

This TechNote will review the template features introduced in Dreamweaver MX. 

Nested Templates

 Nested templates are essentially templates within templates. This feature allows different levels of control on pages 
created from these templates. 

The benefits of nested templates

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_14791
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_14791
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15239
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 Nested templates can help developers in a number of ways, but the common thread among all uses is to provide two 
differing levels of control and editability. A common scenario in which nested templates is useful is for a website that 
has a single overall appearance (the company logo and contact information, for example). But the website also has 
sections that use a distinct appearance. For the separate sections of your web site, you can make nested templates that 
will have common elements and layout features for that section. 

This helps you as a developer because if you need to change your address or logo, you need to merely change it in the 
parent template file and it will automatically update all the pages. If your Products section develops a new look, 
however, you simply have to update the nested template (otherwise known as the child template), and those changes 
will only propagate through the Products pages. 

How to create nested templates

Note: This topic is described in greater detail in Creating a nested template in Dreamweaver MX (TechNote 16282). 
This section just provides an overview of the method used for creating nested templates. 

1 Create a normal template, the same as in previous versions of Dreamweaver. This template will act as the parent 
template. There must be at least one editable region in the template.

2 Make a page from this template. As usual, you will only be able to add new content to the editable area(s). The rest 
of the page will be locked. This template will now act as the nested;or child;template. Add content to the editable 
area(s). You can add images, text or any other web element.

3 In this second template, add a new editable area within the existing editable area. This will convert the page from an 
instance of a template into a nested template.

4 Save this file as a template.

 To see the differences between the two templates, make a page based on this nested template. As expected, you will 
only be able to edit the content defined as editable regions in the nested template. When you make a change to the 
nested template, only pages based on the nested template will update. When you make a change to the original template, 
any pages based on the parent template;including the nested template itself;will update. Since the nested template is 
updated by changes in the parent template, all pages based on the nested template will update, too. 

Note: An example of the template attributes discussed below can be found in the example code provided at the bottom 
of this page. All code examples in this TechNote are taken from this sample file. 

Repeat Regions

 The template repeat regions feature allows developers to create a template without knowing how many instances of a 
certain element will be needed. This allows developers to control the appearance of a specific element, yet the template 
users can freely repeat that specific element, changing the content in the element as appropriate. 

The benefits of repeat regions

 Developers are most likely to use repeating regions in conjunction with tables. If your template contains a table, you 
can set a row or group of rows to be a repeating region. You might then define an editable region within the repeating 
region (so in the example of a table, at least one table cell will contain an editable region). When a user makes a page 
based on that template, the user will be able to add a new row or group of rows, adding distinct content into the editable 
table cells. The template itself will have only one row (or group of rows), yet pages based on the template can have as 
many rows as is needed to display the information. The template user can add and subtract rows and move the rows up 
and down within the repeating rows. This is a good way to give developers flexibility for expanding pages as the site 
grows without disturbing the underlying templates. 

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_16282
http://helpx.adobe.com/dreamweaver/kb/#main_example
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This is such a popular way of using a repeat region that Dreamweaver has a template object called Repeating Table. 
This object allows you to set up the table and repeat region within the same dialog box. 

How to create repeating regions

Note: This topic is described in greater detail in the help documentation. This section just provides an overview of the 
method used for creating repeating regions. 

1 Open or create a new template.

2 Choose the content that you want to repeat. This can be a bunch of text, an image, etc.

3 Choose Insert > Template Objects > Repeating Region.

4 Name the repeat region with a name that does not include spaces or unusual characters, and click OK.

5 Optional: Select content within the newly defined repeat region and make it editable by choosing Insert > Template 
Objects > Editable Objects.

6 Save the template file.

7 Create a new file from this template, and note that the content is available. As shown in the image above, there will 
be a plus and minus icon to allow you to add and remove an instance of the repeat region, and the up and down 
arrow icons allow you to resort the regions.

 Remember that depending on how you define the repeating regions, you may not really need the repeating region. An 
example of a situation in which a repeating region is uniquely suited is if you insert an image, and make it a repeat 
region but not editable. In a document based on this template, the image object can be repeated as necessary simply 
with a click of the plus icon. 

How to create repeating tables

Note: This topic is described in greater detail in the help documentation. This section just provides an overview of the 
method used for creating repeating tables. It is also important to note that the repeating table is merely a specialized 
use of a repeating region. 

1 Open or create a new template.

2 Choose Insert > Template Objects > Repeating Table.

3 Within the Repeating Table dialog box, enter the settings you want for your table, then specify which row should be 
repeated. The Ending Row setting will help determine how many rows will be repeated, and must also be filled. If 
you want only the first row to be repeated, you would enter 1 in both the Starting and Ending Row text boxes.

4 Click OK. Each of the cells in the row will automatically be defined as editable, which means template users will be 
able to add content into each of those cells.

Optional Regions/Template Parameters

 Optional regions are just that: optional. Optional regions define content or editable regions that can be turned on or 
off (be visible or not). 

The benefits of optional regions

 The usage of optional regions can range from simple to complex, and more complex usages will require forethought 
and scripting capabilities. 
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A simple use of an optional region is to allow content to either be visible or not in a page based on the template. The 
content defined as an optional region is added in the template. A template user who makes a template with an optional 
region can then decide whether or not to retain the optional region. If the user turns the optional region off, the content 
defined as the optional region will no longer appear on the page. This may be useful in a situation where the template 
developer wants to control the placement and appearance of a bit of content, yet the developer also wants template users 
to choose whether or not to use that bit of content. 

More complex usages of optional regions allow parameters to determine whether or not the optional region will appear. 
So, instead of the template user choosing to toggle the optional region, the optional region will toggle on or off in 
reaction to a parameter. 

Creating alternate table row colors is an example of a more complex usage of optional regions. If you have a repeating 
table (such as the one discussed and displayed above), the developer is unable to change the appearance of the table 
rows since they are locked down by the template. Dreamweaver can keep track of the number of rows in a table, 
however. You can therefore set up an parameter within the template that tracks the number of rows. The optional region 
can be defined to toggle on or off in response to the row number. 

How to create and implement optional regions

Note: This topic is described in greater detail in the help documentation. This section just provides an overview of the 
method used for creating and implementing optional regions. This section will also give some general information 
about creating and using template parameters, but it is beyond the scope of this TechNote to give precise instructions 
for creating template parameters. 

Create the optional region in the template file: 

1 Open or create a new template file.

2 Add some content (text or a graphic, for example) to the template page and select it.

3 Choose Insert > Template Objects > Optional Region.Note: If you want the template users to be able to add or edit 
the content contained within the optional region, choose Editable Optional Region. Doing so will add a region next 
to the content you have added (not surrounding the content).

4 The New Optional Region dialog box contains two tabs: Basic and Advanced. To create a simple optional region;an 
optional region that template users can toggle themselves;enter a name for the region in the Basic tab and click OK.

5 Save the template.

Toggle the optional region in a file based on the template file: 

1 Create a new file from the template.

2 Choose Modify > Template Properties.

3 The optional region you defined above is listed in the Template Properties dialog box. Select the name of the 
optional region. By default, the optional region will be set to show, so the value for the optional region is True.

4 Turn off the optional region by clicking the Show<OptionalRegionName> option. Choose OK.

 You can create template parameters manually in the code of the template file, but template parameters are also created 
automatically when you create an optional region as described above. In any case, all template parameters must be 
written in the head of the document and must follow the syntax shown below (replace <custom> with customized 
values). 

<!-- TemplateParam name="<custom>" type="<custom>" value="<custom>" -->

 When you create an optional region using the method described above, the template parameter is written specifically 
as follows: 

<!-- TemplateParam name="<custom>" type="boolean" value="true" -->
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 While in the template file, you can create an optional region that uses a template parameter by using the Advanced 
tab of the New Optional Region dialog box: 

• Use Parameter: You can create an optional region that uses a pre-existing template parameter IF the template 
parameter is a boolean type with a value of either true or false. Any parameters that meet that specification will be 
available in this pop-up menu. 

• Enter Expression: Essentially, once you have created a template parameter, the parameter can be used as would any 
other parameter in JavaScript. In fact, template expressions are based on JavaScript coding rules, so the syntax is 
identical to JavaScript coding. You can use mathematical functions to add, subtract, multiply or divide parameters 
to added complexity. 

You can also create an optional region that uses a template parameter directly within the code. How you code these 
regions depends on where in the code you are using them. 

• A region that uses a template parameter can be expressed as a variable. This is the more flexible choice since it can 
be used to replace a value of a tag's attribute, and it can also be used as a placeholder for the content. You use the 
syntax below if expressing the parameter as a variable (replace <parameter> with the name of a defined template 
parameter): 

@@("<parameter>")@@

• A region that uses a template parameter can be expressed as a tag. The Template Expression tag is set off as an HTML 
comment, but it otherwise acts as a tag in that it has a single attribute and a value. This method can not be used to 
replace a value of a tag's attribute, since it is a tag itself. The Template Expression tag is coded as below (replace 
<parameter> with the name of a defined template parameter): 

<!-- TemplateExpr expr="<parameter>" -->

 In both cases, Dreamweaver recognizes the code and will replace the code with the value of the parameter in any page 
based on this template. To get a sense of how they differ, though, the following examples highlight how to use them. 

Example 1: In this example, either method of hand coding an optional region (highlighted in red) will work, because 
the code is not used to replace the value of a tag's attribute. In both cases, Dreamweaver will see this code in any page 
based on this template, and will replace the code with the actual defined value (the value will be editable for template 
users by modifying template properties): 

• Works:<title>@@("title")@@</title>

• Works:<title><!-- TemplateExpr expr="title" --></title>

Example 2: In this example, the method of hand coding that uses a Template Expression tag is incorrect, because the 
code IS used to replace the value of tag's attribute. For the first method, though, Dreamweaver will see this code in any 
page based on this template, and will replace the code with the actual defined value (the value will be editable for 
template users by modifying template properties). For both methods, the code that attempts to describe the parameter 
is highlighted in red: 

• Works:<table border=@@("border")@@ cellpadding=3 cellspacing=0>

• Does not work:<table border=<!-- TemplateExpr expr="border" --> cellpadding=3 cellspacing=0>

Editable Attributes

 Sometimes you want to allow your template users to adjust some specific aspects of the page, but not have access to all 
of the code for the element. Editable attributes can be the answer for this. Editable attributes allow the template users 
to change specific attributes of a tag, without having access to the tag itself. 
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Note: Editable attributes are a specialized use of an optional region. Essentially, adding an editable attribute is the same 
as defining that tag's attribute as an optional region. This feature creates a template parameter, for which the template 
creator can define a default value, and the template users can modify the parameter value as they would modify any 
other optional region's parameter value. 

The benefits of editable attributes

 In HTML, attributes are details assigned to tags. For example, a table tag may have a bgcolor attribute, which defines 
the background color of the table. Typically, if a template developer wanted template users to be able to modify things 
like the background color of a table, the developer would have to allow the entire table to be editable (so in the case of 
a table, the table would actually have to be added into an editable region). By using an editable attribute, however, the 
developer can add the table, set only table cells to be editable regions, and define the background color;the bgcolor 
attribute;to be an editable attribute. In a page based on such a template, the user will not be able to modify the table 
itself, but can change the bgcolor attribute and add or edit any content in editable regions within the cells of the table. 

How to create editable attributes

 Editable attributes are defined by the template developer. 

1 Open or create a new template file.

2 Add content to the page. For example, for the table example, insert a table on the page. Whatever you add to your 
page, it has to be contained in a tag (so text itself wouldn't work, but text contained in a paragraph tag would).

3 Select the tag whose attribute you want to enable. In the case of the table, select the table and define a background 
color for it. You can also skip this step and type the name of the attribute in step 5, but that requires knowing the 
name of the attribute.

4 With the object still selected, choose Modify > Templates> Make Attribute Editable. The Editable Tag Attributes 
dialog box appears:

5 Choose the attribute you wish to make editable from the Attributes pop-up menu. If you did not already set the 
attribute in step 2, click the Add button and type the name of a valid attribute. Important: The attribute must be a 
valid attribute for the tag.

6 Check the Make Attribute Editable option.

7 Type a name for this editable attribute. Dreamweaver will provide one automatically, but it is wise to type a name 
that you know will be unique. Remember, the template users will have to recognize this name from a list when 
choosing to define this attribute.

8 If you choose to make editable an attribute that was already defined, then Dreamweaver should choose the Type 
setting for you. If you added an attribute name in step 5, then you will have to choose the appropriate type from the 
pop-up menu. Verify this setting is correct for the data, since template users will have different methods of choosing 
their value depending on this setting. The choices are:

• Text: This is appropriate for a value that requires text. An example is the align attribute for a table tag. The 
template user will get a text box in which to enter the replacement text. 

• URL: This is appropriate for describing the path to a file. An example is the source (src) attribute for an image 
(img) tag. The template user will get a text box as well as a folder icon to allow them to browse to the file. 

• Color: This is appropriate for setting a color. An example is the background color (bgcolor) for a table tag. The 
template user will get a text box as well as a color picker to choose the color. 
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• True/False: This is appropriate for an attribute that toggles on or off. An example is the nowrap attribute for a 
table cell tag. The template user will get a pop-up menu from which to choose either true or false. 

• Number: This is appropriate for an attribute that requires a number. An example is the width value for a table 
tag. The template user will get a text box in which to enter the replacement number. 

9 Define a default value for the attribute.

10 Click OK.

11 Create a new page from this template, and choose Modify > Template Properties. A list of editable attributes will be 
listed in the dialog box. Optional regions are also in this dialog box. Select the attribute you want to edit and set the 
value in the dialog. Click OK and the new value will be set on the page.

Additional template features

Removing Template Regions

 To remove an editable area or other template region, highlight the region in question and choose Modify > Templates 
> Remove Template Markup. 

Check Template Syntax

 Another feature in Dreamweaver is the ability to verify that your template code is correct. With the added complexity 
and hand coding needed for some template expressions and parameters, there is a bigger opportunity for coding errors. 
Using the Check Template Syntax Command will help you debug your code. 

This feature can only be used in the actual template file. Choose Modify > Templates > Check Template Syntax. 

Example code

 This example code contains editable regions within a repeat region. To use the example code, follow these instructions: 

1 In Dreamweaver, create a new HTML Template (File > New > Template Page > HTML Template).

2 Save this file as a template within a defined site by choosing File > Save as Template, choosing the site from the Site 
list, and naming the file.

3 Within the browser window, select the example code from below and choose Edit > Copy.

4 Switch back to the template file in Dreamweaver.

5 Select all code in the template file (switch to Code View, and choose Edit > Select All) and paste the copied code by 
choosing Edit > Paste.

6 Save the template by choosing File > Save.

7 Make a page based on this template by choosing File > New> Templates, and selecting the template from the 
appropriate site. To use the repeating region feature, choose Modify > Templates > Repeating Entries, and add a new 
entry. These colors can be modified within the instance of the template by choosing Modify > Template Properties.

The template contains:

• an editable attribute.

• expressions

• editable regions

• repeat region

• Template parameters
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<html> <head> <title><!-- TemplateExpr expr="title" --></title> <meta http-equiv="Content-Type" 
content="text/html; charset=iso-8859-1"> <meta name="" content="This example is based an a template created by 
Wanda Huang.">

<!-- TemplateParam name="title" type="text" value="Using Repeat Region Variables in Expressions" --> <!-- 
TemplateParam name="border" type="number" value="1" --> <!-- TemplateParam name="evenColor" type="color" 
value="FFFFFF" --> <!-- TemplateParam name="oddColor" type="color" value="#CCCCCC" --> </head> <body 
text="#000000"> <table border=@@("border")@@ cellpadding=3 cellspacing=0> <tr> <th >Name</th> <th>email 
address</th> <th>phone</th> </tr> <!-- TemplateBeginRepeat name="Parent" --> <tr > <TD><!-- TemplateExpr 
expr="_index+1" --></TD> <TD><!-- TemplateBeginEditable name="email" -->email<!-- TemplateEndEditable --
><br> </TD> <TD><!-- TemplateBeginEditable name="phone" -->phone<!-- TemplateEndEditable --></TD> </tr> 
<!-- TemplateEndRepeat --> </table> </body> </html>

Additional information For more information about the new Dreamweaver MX template features, check the Using 
Templates section of the Dreamweaver Support Center.

For more information about creating nested templates, seeCreating a nested template in Dreamweaver MX (TechNote 
16282).

How to use a MouseOver Event to create an Image Swap 
Action in a different frame
Note: This TechNote only applies to Dreamweaver 1.x. Cross frame communication is a feature built into Dreamweaver 
2. Refer to the Dreamweaver 2 documentation for assistance. 

Dreamweaver Events and Actions are easily assigned to objects within one frame. When an Event in an Active Frame 
is used to control an Action in a different frame (independent separate file), the code "parent.frameName" is added 
manually to accomplish the cross frame communication. The following example uses the Swap Image Action with the 
onMouseOver and onMouseOut Events. This technique can be adapted for other Events and Actions. 

Swap Image Example

 The Web page in this example is divided into two frames (left and right). This division is commonly used for 
navigation, where an index on the left frame loads the page selected from the index on the right frame. In the following 
example the logo.gif image will be inserted in the left frame and the greentea.gif image inserted in the right frame. 
When the mouse is moved over the logo image, it only changes the green tea image in the right frame to another image 
with no change to the logo in the left frame. When the mouse moves away from the logo in the left frame, it changes 
the image on the right frame back to its original. 

To use an event to create an action in another frame do the following:

1 Choose File>New and choose View>Frame Borders. Choose Window > Frames. This shows the Frame inspector 
Window.

2 Move the mouse to the left frame border and hold down Alt (Windows) or Option (Macintosh) and drag the border 
to the right to create two frames equal in size. (In this example the width of the frames can be any size.)

3 Click the mouse in the left frame in the Frame Inspector window. Choose Window>Properties and name the 
frame"pNav."

https://www.adobe.com/support/dreamweaver/templates.html
https://www.adobe.com/support/dreamweaver/templates.html
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_16282
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4 Click the mouse in the right frame in the Frame inspector window. In the Frame Properties window name the 
frame"pBody."

5 Choose File>Save Frameset and enter a filename. Use the file name "example.htm". Click Save.

6 Choose File>Save All. This opens the save dialog prompting to save the new documents created by the two 
frames.Note: Dreamweaver always defaults to the right frame first.

7 Name the right frame file "rightbody.htm" and name the left frame file "leftnav.htm".

8 Click the left frame in the main window and insert logo.gif image. This image is located in the 
Dreamweaver>Configuration>Template folder.

9 Choose Window>Properties and name the image"myLogo".

10 Click the right frame in the main window and insert the greentea.gif image. This image is located in the 
Dreamweaver>Configuration>Templates>Frames folder.

11 Choose Window>Properties and name the image"myTea".

12 Choose File>Save All. This saves the frameset file and the separate files for the left and right frames.

13 Select the green tea image. Choose Window>Behaviors to open the Behaviors dialog box. Leave the Browser version 
set to 4.0 Browsers.

14 Access the Events pop-up menu by clicking the plus button. Select onMouseOver from the pop-up menu. Click OK 
on the dialog reminder about the anchor.

15 In the Actions pop-up menu select Swap Image. Select the logo.gif for the source image. Leave Preload images 
checked.Note: The anchor tags for the Preload Image Behavior appear in the window.

16 Select onMouseOut from the Events pop-up menu. Select Swap Image from the Action menu. Select the greentea.gif 
for the source image.

17 Open the HTML source window for the right frame. Cut the code for the anchor tag but DO NOT include the 
reference for the green tea image (img href="../greentea.tif).Note: This leaves an </a> tag in the main window of the 
right frame. Delete the extra </a> in the right frame.Code Example
<a href="#" onMouseOver="MM_swapImage 

 
 ('document.myTea','document.myTea',' 

 
 ../logo.gif','MM_swapImage1')"   onMouseOut="MM_swapImage 

 
  ('document.myTea','document.myTea',' 

 
 ../greentea.gif','MM_swapImage2')">

18 Open the HTML source window for the left frame. Paste the code for the anchor tag in front of the <img src> tag 
for the logo.gif. Make sure the </a> tag is at the end of the code for the logo image.Note: An </a> anchor (to close 
the <a href> tag) needs to be added manually for the left frame and the </a> deleted from the right frame code.
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19 If the left frame does not contain the JavaScript code between the <head> and </head> tags for preloading and 
swapping images, open the right frame and copy the code. Paste the code between the <head> and </head> tags of 
the left frame.Note: Only the required JavaScript functions need to be copied. In this example with a new created 
document, copy all the JavaScript functions.

Start copying the following section: 
 

 
 

<script > 
 

<!--function MM_preloadImages()> Including the section:<function MM_swapImage()> 
 

 end with the section:</script> 

20 When using the Preload Image behavior also cut the JavaScript code between the <body> and </body> tags from 
the right frame and paste between the <body> and </body> tags in the left frame. Code Example
<<!-- #BeginBehavior MM_swapImage2 --> 

 
<script language='JavaScript'> 

 
<!--MM_preloadImages('../greentea.gif');//--> 

 
</script> 

 
<!-- #EndBehavior MM_swapImage2 --> 

 
<!-- #BeginBehavior MM_swapImage1 --> 

 
<script language='JavaScript'> 

 
<!--MM_preloadImages('../logo.gif');//--> 

 
</script> 

 
<!-- #EndBehavior MM_swapImage1 -->> 

21 Open the HTML source window of the left frame and type in"parent.pBody." in front of each"document.myTea" in 
the code of the anchor tag for the image. The reference to "document.myTea" occurs four times. The mouse event 
can then correctly reference the targeted frame window within a frameset.Code Example
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<a href="#" 
 

 onMouseOver="MM_swapImage 
 

 ('parent.pBody.document.myTea', 
 

 'parent.pBody.document.myTea',' 
 

 ../logo.gif','MM_swapImage1')" 
 

 onMouseOut="MM_swapImage 
 

 ('parent.pBody.document.myTea', 
 

 'parent.pBody.document.myTea',' 
 

 ../greentea.gif','MM_swapImage2')"> 
 

<img href="../logo.gif" 
 

   name="mLogo"></img></a> 

22 Choose File>Save All and Press F12 to view results in browser.

Modified date of local file changes after put

Issue
 After uploading a file to the remote server, the modified date for the local file changes in the Files panel to match the 
modified date of the file uploaded to the server. 

Note: This TechNote applies to Dreamweaver MX 2004 and earlier. The timestamp-related features were redesigned in 
Dreamweaver 8. The local file's timestamp is no longer changed when putting files. For more information, see "How 
synchronization works in Dreamweaver 8" (TechNote kb400972 ). 

Reason
 This change in the modified date for the local file is necessary for the Synchronize command in Dreamweaver MX 2004 
and earlier. Making this change to the local file's modified date is necessary so thatduring the synchronization process, 
Dreamweaver MX 2004 and earlier can determine whether a local file has been updated since it was last transferred to 
the server. 

Additional Information
 For more information about Dreamweaver MX 2004 and earlier synchronization issues, see "Synchronize and Select 
Newer options are not working correctly" (TechNote tn_14413 ). The Site Management and Collaboration chapter in 
the manual, Using Dreamweaver, has additional information about synchronizing local and remote files. 

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb400972
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_14413
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Missing user name, password for site | Update 
Dreamweaver CS5 | Mac OS

Issue
After you install an update for Dreamweaver CS5 on Mac OS, the user name and password for your site are missing in 
the Site Definition.

Solutions

Solution 1: Restart your computer.
Restart your computer after installing the update Restarting forces your keychain to reload, which should restore your 
saved user name and password. If restarting does not restore this information, then see Solution 2.

Solution 2: Reenter your user name and password.
If restarting your computer does not restore this information, then your keychain no longer contains this information. 
To save your user name and password, reenter these pieces of information into your Site Definition and click Save.

Additional information
This issue can occur after you install the 11.0.1, 11.0.2, 11.0.3, or 11.0.4 update for Dreamweaver CS5 if you do not 
restart your computer before using Dreamweaver.

More Help topics 
Dreamweaver Help: Set options for FTP connections

Migrate your Business Catalyst site from Dreamweaver 
CS5.5 to CS6
 Dreamweaver CS6 has better integration with Business Catalyst than was possible with the Business Catalyst extension 
in previous versions of Dreamweaver.

If you previously managed your Business Catalyst site using the extension in Dreamweaver CS5.5, then Adobe 
recommends that you migrate this data into Dreamweaver CS6. That way, you can get the most out of the integration 
in Dreamweaver CS6. You can preview and configure Business Catalyst site modules, and insert these modules into web 
pages in Dreamweaver.

Important: If you have already installed and launched Dreamweaver CS6, then complete the steps in next two sections 
using Dreamweaver CS6. Otherwise, complete these steps in Dreamweaver CS5.5.

http://helpx.adobe.com/dreamweaver/using/connect-remote-server.html
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Synchronize and backup your site
Note: The steps in this section are optional, but recommended.

1 Ensure that you have saved all files for your site.

2 Connect to your Business Catalyst site in Dreamweaver.

3 Choose Site > Synchronize Sitewide. In the dialog that appears, select to synchronize the entire site, and to put newer 
files to remote. Click Preview. If any files require updating, select them and click OK.

Wait for the process to complete.

 

4 Choose Site > Manage Sites. Double-click your Business Catalyst site.

Note: If you are performing this step in Dreamweaver CS6, your Business Catalyst site is identified as a 
Dreamweaver site in the Type column of the Site Manager.

5 In the Site Setup dialog box, note the path to the local site folder. Close the Site Setup dialog box.

6 In the Finder (Mac OS) or Windows Explorer (Windows), navigate to your local site folder as noted in the previous 
step.

7 Create a backup copy of this folder in a separate location.

8 In Dreamweaver, ensure that your Business Catalyst site is still selected in the Site Manager dialog. Click Export.

Follow the prompts to save the site definition to a safe location.

Remove your Business Catalyst site from Dreamweaver
1 Select Site > Manage Sites. Click to select your Business Catalyst site.

2 Click Remove (CS5.5) or the Delete icon (CS6). Select Yes to confirm.

Import your Business Catalyst site in Dreamweaver CS6
1 In Dreamweaver CS6, select Site > Manage Sites.

2 Click Import Business Catalyst Site.

3 If you are not already logged in, sign in to your site when prompted.

4 Select the site that you want to import, and then click Import Site.

5 Do one of the following:

• If you have synced your files with the server previously, deselect Automatically Download The Entire Business 
Catalyst Site Locally.

• If you choose to download files from the server, choose a different local root folder for the site to avoid 
overwriting existing files.

The imported site appears in the Site Manager dialog box. The Type column now reads Business Catalyst.

You can now use the Business Catalyst panel to insert Business Catalyst modules into a web page in Dreamweaver.
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"Low on memory" errors when running Dreamweaver

Issue
 When running Adobe Dreamweaver on Windows, the following error occurs: "Your system is low on memory, Please 
save your documents, then free up memory by closing some document or other applications." One thing that some 
users reporting this problem have in common is that they are running Windows systems with 2GB of RAM. (Ref. 
223385) 

Reason
 There are two reasons that Adobe is aware of that can cause this problem: 

• This problem usually occurs when the currently allocated amount of virtual memory is manually set at a value lower 
than the recommended amount of virtual memory. This can occur when you add real memory to your system and 
you don't manually increase the currently allocated amount of virtual memory. 

• One user has reported that this problem was fixed when there was a file path that exceeded 255 characters and 
shortening the file path fixed the problem. 

Solution
 Make sure that the currently allocated amount of virtual memory on your system is set to a value at least the same as 
the recommended amount of virtual memory. The recommended amount of virtual memory is based on the amount 
of real memory of your system. Virtual memory is a system to extend the amount of real memory, so it will always be 
larger than the real amount of memory you have. 

Setting the amount of virtual memory allocated on Windows XP:

1 Go to the Start Menu > Settings > Control Panel > System.

2 In the System Properties dialog box, select the Advanced Tab. In the Advanced tab, go to the Performance section 
and click the Settings button.

3 In the Performance Options dialog box, click the Advanced tab, go down to the Virtual Memory Section and click 
the Change button.

4 In the Virtual Memory dialog box, if you have the Custom Size option chosen, verify that the Initial Size matches 
the Recommended Size at the bottom. In other words, the Currently Allocated Size should match the 
Recommended Size. You will need to restart your system after changing the Initial Size.

Setting the amount of virtual memory allocated on Windows Vista:

1 Choose Start > Control Panel.
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2 Choose Classic View in the left pane.

3 Double click System.

4 Click the Advanced System Settings link to open the System Properties dialog box.

5 Click the Advanced tab, then click the Settings button in the Performance section.

6 In the Performance Options dialog box, click the Advanced tab, go down to the Virtual Memory Section and click 
the Change button.

7 In the Virtual Memory dialog box, if you have the Custom Size option chosen, verify that the Initial Size matches 
the Recommended Size at the bottom. In other words, the Currently Allocated Size should match the 
Recommended Size. You will need to restart your system after changing the Initial Size. You can also instead try 
using the option: "Automatically manage paging file size for all drives".

Check for file paths longer than 255 characters

 Check your files for any file paths that exceed 255 characters and shorten the file paths if you see any. 

Keychain contains multiple instances of Dreamweaver 
CS4 | Mac OS 10.7 Lion

Issue
After you use Adobe Dreamweaver CS4 on Mac OS 10.7 Lion, there are multiple entries for the application in Keychain 
Access.

Solution
This issue is a known issue with Mac OS 10.7. There is no negative impact to having multiple keychain entries for 
Dreamweaver, so you can safely ignore this unexpected behavior.

Additional information
This issue does not occur with Dreamweaver CS5 or CS5.5. Your Mac OS keychain is used to securely store the user 
name and password for each of your Dreamweaver sites.
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JavaScript error and hang when performing Save To 
Remote Server

Issue
 When selecting File > Save To Remote Server, the following JavaScript error occurs in Dreamweaver: 

While executing DWMenu_File_SaveDocumentToRemoteServer command in menus.xml, the following JavaScript 
error(s) occurred:

Exception thrown in native function.

 After clicking the OK button, Dreamweaver hangs. The only way to exit from Dreamweaver is to force quit. This issue 
only occurs with Windows XP, and does not occur on Windows Vista. (Ref. 225886) 

Reason
 This error occurs when you have Internet Explorer 7 installed on Windows XP. 

Solution
 There are two recommended solutions: 

• Use an alternative method of saving files to the server. For example, use the Put button or Check-In button in the 
Files panel to upload files to the server. 

• Uninstall Internet Explorer 7 which will rollback your system to Internet Explorer 6. 

Additional Information
 For more information on other JavaScript errors, see Troubleshooting JavaScript errors in Dreamweaver (TechNote 
tn_19105 ) 

Issue when creating a database connection: HTTP Error 
Code 404 File Not Found (Dreamweaver Developer 
Toolbox)

Issue
 When I try to create a new Dreamweaver database connection, I get an error message saying : HTTP Error Code 404 
File Not Found

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_19105
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Reason
 There are several possible causes for which this can happen: 

1 The testing server is not setup right in the Dreamweaver site definition. Dreamweaver attempts to upload some files 
on the testing server into the folder you pointed into the site definition and then it tries to call them with an HTTP 
call using the URL base you provided. If the paths are not configured correctly, you will receive this error.

2 The web server is not up and running on the testing server machine.

3 The proxy server as it is configured in thebrowser,is used even for local addresses like localhost, the testing server 
where you want to connect.

4 Your browser is set to "Work Offline".

Solution
 There are several solutions you can attempt: 

1 Go into your site definition from Dreamweaver and recheck all the choosen paths (both folders and URLs).

2 Check the web server status, you may even restart it to be sure.

3 You should change your proxy server configurations in thebrowser to bypass local addresses like localhost.

Installing Dreamweaver MX / MX 2004 in Safe Mode on 
Windows
 If you are experiencing crashes, errors or other unexpected behavior with Dreamweaver MX 2004 or Dreamweaver 
MX, reinstall it with all other applications and background processes turned off to ensure nothing is conflicting with 
the Dreamweaver installer, like anti-virus software. Before installing Dreamweaver in Safe Mode, perform a complete 
uninstall as described in Uninstalling Dreamweaver MX / MX 2004 on Windows (TechNote 362d7b81). 

Note: Dreamweaver 8 uses Windows Installer packages (MSI). Therefore, you cannot install Dreamweaver 8 in Safe 
Mode, because Safe Mode disables the Windows Installer service. For more details on diagnostic installations of 
Dreamweaver 8, see Installing Studio 8 products in Selective Startup mode on Windows XP (TechNote d2b5934d). 

Installing Dreamweaver MX & MX 2004 in Safe Mode

1 Copy the Dreamweaver installer from the installation CD onto the Windows desktop. This is necessary because the 
CD-ROM drive will be disabled in Safe Mode. If you downloaded the application, make sure the installer is fully 
downloaded and available on your hard drive.

a In Windows, browse the MX or MX 2004 CD and go to the FSCOMMAND folder.

b Copy DW_Client_Installer.exe from the FSCOMMAND folder to the Windows desktop.

2 Reboot the computer system in Safe Mode. Here are the instructions for Windows XP, 2000, 98, ME, 95:

a Restart the computer.

b When the computer begins to boot back up, start tapping the F8 key. For Windows 98 and ME, the Ctrl key also 
works.

c When the Windows startup menu appears, select Safe Mode.

3 Log in using the Windows administrator account or a user account with administrator privileges.

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=362d7b81
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=d2b5934d
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4 Exit from all applications that may be open. Disable any virus protection software if Safe Mode did not already 
disable it.

5 Run the installer you copied to the desktop in step 1.

6 When installation is complete, delete the installation files copied from the installation CD.

7 Restart the computer in normal mode.

8 Launch Dreamweaver.

Additional Information
 Here are some related TechNotes: 

• Uninstalling Dreamweaver MX & MX 2004 on Windows (TechNote 362d7b81) 

• Troubleshooting Dreamweaver for Windows (TechNote 15481) 

• Installing Studio 8 products in Selective Startup mode on Windows XP (TechNote d2b5934d) 

• Dreamweaver crashes when performing a task related to site definitions (TechNote 5989f7f4) 

• Uninstalling Studio 8 applications on Windows (TechNote 4e7826b7) 

How to include the current date in an insert page
 There are different ways to include the current date in a newly inserted record. This TechNote describes two options: 

1 Using hidden fields with ColdFusion, PHP, ASP, ASP.NET or JSP code.

2 Setting the default value for the database field equal to the current date.

Hidden form fields

 One approach to this task is to setup a hidden field (Insert> Form > Hidden Field). Once the hidden field has been 
added, select the yellow icon that represents the hidden field and go to the Property inspector. In the Value field, enter 
the appropriate code for the date function: 

• ASP: <%= Date() %>

• JSP: <%= new java.util.Date() %>

• ColdFusion: #Now()#

 If you want to give the end user the option to change the date to something other than today's date, then use a regular 
text field instead of a hidden field. 

When filling out the Insert Record server behavior dialog box, map the hidden form field to the date field in the 
database and set the data type to either "Date" or "MS Access Date".

Note: The date being inserted will be the date on the application server. Keep this in mind if users are in different time 
zones. 

Setting the default value in the database

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=362d7b81
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15481
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=d2b5934d
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=5989f7f4
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=4e7826b7
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 Another approach to this task is to set the default value of the database's date field to the current system date. Most, if 
not all, databases will have a "default value" option for database fields. One advantage to using this approach is that you 
do not have to worry about the date format being sent from the web page. Here is how to set the default value to today's 
date in Microsoft Access 2000: 

1 Open the database in Microsoft Access.

2 Open the database table in Design view, and select the date field.

3 Go to the General tab in the bottom section of the window and type "Date()" (no quotes) in the Default Value field.

4 Save and close the database, and go back to Dreamweaver to finish the insert page.

5 When filling out the Insert Record server behavior dialog box in Dreamweaver, you will not map a form field to the 
date field in the database. The database will automatically fill in the current date when a new record is created.

 Please refer to the Microsoft Access documentation for further detail on setting default values. If you are not using 
Access, please refer to your database documentation for instructions on how to set the default date value. 

Note: The date being inserted will be the date on the database server. Keep this in mind if users are in different time 
zones. 

Additional information

For more information on how to use the Insert Record server behavior, please see Building an insert record page block 
by block.

HTML colors are different from SWF colors
If you set a SWF file's background color to the same background color as an HTML page, the colors don't always match 
on all machines. In particular, you're more likely to see a slight difference on 16-bit monitors, set to display at 
"thousands of colors." That's because a 16-bit monitor can't display as many colors as other monitors, and different 
renderers can round colors in different ways.

Monitors set to "hundreds of colors" have a wider range than those set to "thousands." Although a 16-bit display can 
show more simultaneous colors, the palletized image can choose from a wider range of colors.

The math shows why: 32-bit monitors and 8-bit palettes both use a full byte of information for the red, green, and blue 
channels. That's 256 possible values for each of three colors. But a 16-bit monitor has only 2 bytes of info per pixel, and 
it gives about 5 bits to each channel. Therefore, it can only display 32 different red values, 32 different green values, and 
32 different blue values. Each channel can display only one-eighth of the colors seen on other displays.

When a color is shown on a 16-bit display, most of the time it is rounded to the nearest permitted color. Different 
renderers in a browser can round colors in different ways. That's why a SWF file's color and HTML color can have the 
same definition, but look different from each other on different machines.

Possible solutions

• Try making designs that don't require absolute color fidelity across all machines.

• Use "herringbone" and other patterns to hide edges.

• Consider putting more of the page's content inside the SWF file.

https://helpx.adobe.com/dreamweaver/using/building-record-insert-page-cs6.html
https://helpx.adobe.com/dreamweaver/using/building-record-insert-page-cs6.html
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• On Windows versions of Internet Explorer, you can set thewmode attribute to hide an unused SWF file's 
background.

None of thesesolutions are entirely satisfactory, but it can be difficult to expect all devices to render all colors identically.

Do "Web-safe colors" matter?

Not really, not in this case. Web-safe colors describe how a browser sets the computer's palette at a depth of "hundreds 
of colors." but these color-cube values can still shift on a monitor set to "thousands of colors." The Web-safe color 
discussions are a bit different from these 16-bit rounding discussions.

To summarize, a monitor set to display "thousands of colors" can only show a fraction of the colors seen on other 
monitors. Different renderers inside a browser round colors in different ways.

Hang when opening document | Dreamweaver CS5

Issue
When you try to open a document in Dreamweaver CS5 or CS5.5, it takes anywhere from 30 seconds to several minutes 
for Dreamweaver to open it. Dreamweaver stops responding until the document opens.

Solution
Disable Dreamweaver's Resolve To IP Address feature using the instructions for your operating system.

Mac OS
1 Quit Dreamweaver.

2 In the Finder, navigate to the following location: /Users/Your User Name/Library/Preferences 

3 Open the Adobe Dreamweaver CS5 Prefs file (CS5) or the Adobe Dreamweaver CS5.5 Prefs file (CS5.5) in 
TextEdit.

4 Locate the [REMOTE DOWNLOAD] section in the file. It looks similar to the following:[REMOTE 
DOWNLOAD]remotedownloadcachesize=50remotedownloadallow=TRUE 

5 At the bottom of this section, add a line that says: resolveremoteurltoipaddress=FALSE The [REMOTE 
DOWNLOAD] section now looks like the following:[REMOTE 
DOWNLOAD]remotedownloadcachesize=50remotedownloadallow=TRUEresolveremoteurltoipaddress=FALSE 

6 Save the file, and then quit TextEdit.

Windows
Disclaimer: These steps require you to modify the Windows registry, which contains critical information about your 
system and applications. Before modifying the registry, always make a backup copy of it. Adobe doesn't provide support 
for problems that arise from improperly modifying the registry. For information about the Windows registry, see the 
documentation in Windows or contact Microsoft Technical Support or your computer's manufacturer.

1 Exit Dreamweaver.

2 Choose Start > Run (Windows XP) or click Start (Windows 7/Vista).

3 Type regedit and then press Enter.
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4 In the left pane of the Registry Editor, navigate to one of the following registry keys:CS5.5: 
HKEY_CURRENT_USER\Software\Adobe\Dreamweaver CS5.5\Remote DownloadCS5: 
HKEY_CURRENT_USER\Software\Adobe\Dreamweaver CS5\Remote Download 

5 Click to select the Remote Download key on the left.

6 Choose Edit > New > String Value.

7 Name the new string value: ResolveRemoteURLToIPAddress

8 Double-click the new ResolveRemoteURLToIPAddress string value.

9 Enter FALSE for the value data, and then click OK.

10 Exit the Registry Editor.

Additional information
When you open documents that contain remote URI references in Dreamweaver, it contacts a DNS server to qualify 
each remote URI to its IP address. With some network configurations, it can take several seconds or longer, causing 
Dreamweaver to become unresponsive until it receives the response from the DNS server. If the document contains one 
or more invalid URIs, it can take longer to receive the response from the DNS server.

Flash movies won''t play in the document window
IssueAfter clicking the play button (on the Properties inspector) for a selected Flash movie object, the movie won't play 
in the Dreamweaver 3 document window. 

ReasonDreamweaver 3 cannot find the Macromedia Flash Player (referred to as the Flash plugin in Dreamweaver 3) 
to display the movie (an SWF file) in the document window. You may not have installed the Flash Player in the Netscape 
Communicator Plugins folder. 

SolutionYour computer system must have the Flash Player for the Netscape browser installed in order to play a Flash 
movie in Dreamweaver 3. You do not have to have the Netscape browser itself on your system; however, you do need 
to install the Flash Player for the Netscape browser. 

Installing the Flash Player for the Netscape browser

Note:These instructions are intended for Dreamweaver 3 users only. Dreamweaver 4 installs the Flash 5 plugin into its 
own Plugins folder by default, thus avoiding this Dreamweaver 3 issue. 

Download the Flash Player from 
http://www.macromedia.com/downloads/.

The Flash Player can also be installed from the Dreamweaver 3 
installation CD, as follows:

1

Navigate to Other Macromedia Software > Flash Player > Netscape > 
flash32.EXE.

2

Double-click on the flash32.EXE file to launch the installer.

3

Follow the instructions to install the Flash Player.

http://www.adobe.com/downloads/
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Error uploading or downloading files | Dreamweaver

Issue
When you try to upload (put) to or download (get) from your web server using Adobe Dreamweaver, the process fails 
with an error. The Background File Activity window may say "File activity incomplete" or you may encounter a different 
error indicating that the attempted action failed to complete successfully.

Solutions
You should try the following solutions in order:

Solution 1: Verify that you can connect to your web server Solution 2: Verify the root directory setting in Dreamweaver 
Solution 3: Move or delete any symbolic links from corresponding directories on your server (Dreamweaver CS5.5 
only) Solution 4: Use Passive FTP (FTP and FTPS/FTPeS only) Solution 5: Use an alternate client Solution 6: Try 
additional Site settings options (FTP and FTPS/FTPeS only) 

Solution 1: Verify that you can connect to your web server
If you are unable to successfully connect to your web server, then you will not be able to upload files to or download 
files from your server.

For most connection types, you can use Dreamweaver to test your connection. To do so, open your server's settings in 
the Dreamweaver Site Setup dialog box, and then click Test.

If Dreamweaver cannot successfully connect to your server, then it's likely that your server settings are missing or 
incorrect. See the Dreamweaver documentation to step through the site setup process and verify your settings. (If you 
are using Dreamweaver CS4 or earlier, consult the Dreamweaver CS4 site setup documentation.)

Solution 2: Verify the root directory setting in Dreamweaver
For FTP, SFTP, and FTPS/FTPeS connections, you are able to specify a root directory for each server in the Site Setup 
dialog box. Most web servers require that you specify the root directory in order to upload or download files

The root directory is the folder path on the web server where your index (e.g. index.html, index.php, etc.) and other 
publicly available files and folders are stored. Generally, this path should be relative to the root of the web server (i.e. it 
should start with a forward slash). For example:

• /wwwroot

• /inetpub/wwwroot

• /www/users/USERNAME/wwwroot

• /public_html

• /usr/home/USERNAME/public_html

• /www/users/USERNAME/public_html

Sometimes, however, the root directory can be the actual domain name of the website. This is often the case for users 
who own their own domain names. For example, a site called www.mywebsite.com might have a root directory of 
mywebsite.com/ (with no forward slash at the start).

The exact name and location of the root directory varies from web hosting company to web hosting company. If you're 
having trouble determining what your root directory is, contact your web hosting company for help.

http://helpx.adobe.com/dreamweaver/kb/#main_anchor1
http://helpx.adobe.com/dreamweaver/kb/#main_anchor2
http://helpx.adobe.com/dreamweaver/kb/#main_anchor3
http://helpx.adobe.com/dreamweaver/kb/#main_anchor3
http://helpx.adobe.com/dreamweaver/kb/#main_anchor4
http://helpx.adobe.com/dreamweaver/kb/#main_anchor5
http://helpx.adobe.com/dreamweaver/kb/#main_anchor6
http://helpx.adobe.com/dreamweaver/kb/#main_anchor6
http://helpx.adobe.com/dreamweaver/using/sites-dialog-box-options.html
http://help.adobe.com/en_US/Dreamweaver/10.0_Using/WSBE25912D-A9DE-4ba1-9F85-4C692F5C14ADa.html
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Solution 3: Move or delete any symbolic links from corresponding directories on your server 
(Dreamweaver CS5.5 only) 
If you are using Dreamweaver CS5.5, then the reason for upload/download failure may be caused by the existence of a 
symbolic link (sometimes called a symlink or soft link) in the same folder to which you are trying to upload. Symbolic 
links are effectively shortcuts or aliases that point to a file existing in another location, but can be used as though the 
file exists in that location. Dreamweaver CS5.5 misinterprets these symbolic links as though they were directories, and 
because they cannot be properly enumerated, any attempt to upload or download files in the same directory as the 
symbolic link will fail.

You may be encountering this issue if the FTP Log in Dreamweaver shows an error similar to the following:"An FTP 
error occurred – cannot put ‘/index.html’. Access Denied."

To identify a symbolic link, look in the Dreamweaver FTP Log (Window > Results > FTP Log) for a line that appears 
similar to the following: < lrwxr-xr-x 1 username users 66 Jun 30 18:20 webformmailer.php -> 
/usr/www/stats/mailer.php

There are two things here that tell us that this is a symobilc link. The first letter is an l (as in lrwxr-xr-x), which indicates 
that it is a symbolic link. The second is that the file name that would appear in the local or remote Files panel within 
Dreamweaver (in this case, webformmailer.php), is pointing to (->) a file in a different location (in this case, 
/usr/www/stats/mailer.php).

In the case of the above example, to resolve the issue, you would locate the symbolic link called webformmailer.php in 
the Dreamweaver Files panel, and then delete it. If you needed to use this file for some component of your website, you 
would then also copy the mailer.php file from its location in /usr/www/stats/ to the desired directory.

Solution 4: Use Passive FTP (FTP and FTPS/FTPeS only)
Some firewall or other security software on your computer may be preventing Dreamweaver from uploading or 
downloading files.

In most situations, you can configure your security software to allow network communication between Dreamweaver 
and your web server (both "in" and "out') and this will resolve the issue. This is a better and more recommended method 
for solving this issue.

If you're not familiar with configuring your security software, or as a quicker method for resolving the issue, enable 
Passive FTP in Dreamweaver. To do so, select Use Passive FTP in the Site Setup dialog box options. For Dreamweaver 
CS5 and later, this option appears under the Basic tab's More Options section (at the bottom of the window that appears 
after you select a server for editing).

See the Dreamweaver documentation to step through the site setup process and locate the Passive FTP option. (If you 
are using Dreamweaver CS4 or earlier, consult the Dreamweaver CS4 site setup documentation.)

Solution 5: Use an alternate client
If you are able to connect to your server in Dreamweaver, but are unable to upload or download, then connect to your 
server using an alternate client and then try to upload or download the same file(s).

For example, if you connect to your server via FTP or FTPS/FTPeS, then use an FTP client like FileZilla or CyberDuck. 
If you are using SFTP, then use a client such as PSFTP (PuTTY). For WebDAV connections, try a client like DAV 
Explorer, Goliath, or CyberDuck.

If you are not successful when using an alternate client, contact your web hosting company, network administrator, or 
IT department for additional assistance. Your server may be experiencing temporary problems, your account may not 
be configured correctly, the access permission settings on your server may need to be changed, or there may be another 
problem that needs to be addressed with your server or your computer/network configuration.

http://helpx.adobe.com/dreamweaver/using/sites-dialog-box-options.html
http://help.adobe.com/en_US/Dreamweaver/10.0_Using/WSBE25912D-A9DE-4ba1-9F85-4C692F5C14ADa.html
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Solution 6: Try additional Site settings options (FTP and FTPS/FTPeS only)
Some web servers are not compatible with the default settings in Dreamweaver. The best way to determine which 
settings to use is to check the documentation provided by your web hosting company, or contact them to inquire about 
these settings.

Alternatively, you can use a process of elimination to determine which settings are most compatible with your server. 
To do so, try the following:

1 Open your server settings in the Site Setup dialog box. (See the Dreamweaver documentation to step through the 
user interface. If you are using Dreamweaver CS4 or earlier, consult the Dreamweaver CS4 site setup 
documentation.)

2 On the Basics tab of the server's editing mode, expand the More Options section at the bottom.

3 Check or uncheck one option listed. For example, uncheck Use FTP Performance Optimization.NOTE: Use Proxy 
is a setting that is specific to your computer's network connection, and is not related to your web server. Only check 
Use Proxy if you normally need to use a proxy server to connect to the Internet, or to connect to certain types of 
network resources. Check with your network administrator or IT department if you are not sure if you need to use 
a proxy.

4 Try to upload or download the same files again.

5 Repeat these steps until you have resolved your issue, or until you have tried each combination of options.

Additional information
SFTP is also called FTP over SSH. FTPS is also called FTP over SSL/TLS with Implicit Encryption. FTPeS is also called 
FTP over SSL/TLS with Explicit Encryption.

Error message using Put or Check-in files: Cannot create 
directory...it already exists

Issue
 It is not possible to transfer files that reside more than two directories deep from the Root folder. When attempting to 
do so, the following error message appears: "Cannot create directory example/subexample/subsubexample because it 
already exists." 

Reason
 The Web host is using WU-FTPD v2.6. Many users may have been using Dreamweaver without these errors, but may 
start getting these errors due to an incompatibility when Web hosts and ISPs upgrade to WU-FTPD v2.6. There may 
be other FTP server software packages that yield the same or similar error messages. 

Solution
 Open the Site FTP log and read the login information. In Windows, this is done by choosing FTP log from the Site 
menu in the site files window. On Macintosh, choose FTP log from the Site menu to access the login information. On 
many servers, including WU-FTPD, this log will identify which FTP server software is being used by the Web host or 
ISP. If it is WU-FTPD v2.6, Dreamweaver 1 and 2 cannot be used to transfer files more than two directories deep. 
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Workarounds:
• Use a directory structure that doesn't have files more than two directories deep. For example, use: ROOT: 

Images/Subimages/phoo.gif In place of this structure: ROOT: Images/Subimages/Subsubimages/phoo.gif 

• Use an external program to transfer files which are more than two directories deep. 

Note: Upgrading to Dreamweaver 3.0 will alleviate this problem. 

Error "Local root folder does not exist" | Dreamweaver 
CS5

Issue
When you start Dreamweaver CS5, you receive the following message:

"The local root folder, Site_Root_Folder, does not exist. Please select a new local root folder by clicking the Manage Sites 
button."

Solution
Locate and select the original local site root folder, or select a new local root folder.

1 Click the Manage Sites button in the dialog box. (If you have already closed this dialog, then choose Site > Manage 
Sites.)

2 Select your site in the list, and then click Edit.

3 Click the Browse For Folder icon to the right of the Local Site Folder setting.

4 Browse to the location of the original local site root folder, or browse to a new local root folder, and then click 
Choose or Select.

5 Click Save in the Site Setup dialog.

6 If you have additional sites, then repeat Steps 2 through 5 for each one that needs its local root folder path fixed.

7 Click Done in the Manage Sites dialog.

Additional informationThis error occurs when Dreamweaver can't locate your site root folder. There are several 
possible reasons this error can happen. For example, you moved the local root folder to a different location on your 
hard disk, or renamed the folder or one of its parent folders. On Mac OS, this error can also occur if you renamed your 
hard disk, or if you toggled FileVault on or off.

More Help topics 
Manage and edit sites

Dreamweaver site settings

Simplified site setup in Dreamweaver CS5 (Video on Adobe TV)

http://helpx.adobe.com/dreamweaver/using/sites-dialog-box-options.html#id_86948
http://helpx.adobe.com/dreamweaver/using/sites-dialog-box-options.html#id_86948
http://www.adobe.com/go/learn_dw_comm08_en
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Error "Help folder is missing" | Opening Help | 
Dreamweaver CS5.5

Issue
When you try to access Help from within Adobe Dreamweaver CS5.5, the Help doesn't open and you receive the 
following error message:

"The help system cannot be launched because the help folder is missing. Please install the help folder or reinstall 
Dreamweaver."

Solution

Solution 1: Access the Help content online.
Visit the following URL to access the Dreamweaver CS5.5 Help: 
http://help.adobe.com/en_US/dreamweaver/cs/using/index.html

Solution 2: Download a PDF of the Help content to view offline.
1 Right-click (or Control-click on Mac OS) on the following link: 

http://help.adobe.com/en_US/dreamweaver/cs/using/dreamweaver_cs5_help.pdf

2 Choose the option to save a linked file. (Depending on which web browser you use, this option is called Save Link 
As, Download Linked File As, Save Target As, or something similar.)

3 Follow your web browser's instructions to download the PDF file to a location of your choice on your hard drive.

Additional information
This issue is known to occur on Ukranian and Hungarian localized versions of Dreamweaver.

More Help topics 
Dreamweaver Help and Support

Error "Dynamically-related files could not be resolved" | 
Drupal 7 sites | Dreamweaver CS5

Issue
When you try to discover dynamically related files for a page that is part of a Drupal 7 site, no related files are found. 
The information bar displays the following error:

"Dynamically-related files could not be resolved because the site definition is not correct for this server."

http://help.adobe.com/en_US/dreamweaver/cs/using/index.html
http://help.adobe.com/en_US/dreamweaver/cs/using/dreamweaver_cs5_help.pdf
http://www.adobe.com/support/dreamweaver/
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Solution
Update to Drupal 7.2 or later.

Visit the Drupal website to obtain the latest version: http://drupal.org/project/drupal

Additional information
An issue existed in Drupal 7.0 and 7.1 that prevented Dreamweaver from accessing the root-level index.php file. 
Dreamweaver requires that file to discover dynamically related files.

For more information, see this page on the Drupal site http://drupal.org/node/711650

More Help topics 
Discover Dynamically-Related Files

Setting up a local testing server in Dreamweaver CS5

Error calling getTables: an unidentified error has 
occurred

Issue
When expanding the Tables tree in the Database Items section of UltraDev's advanced recordset dialog box, the error 
"Error calling getTables: an unidentified error has occurred." is generated.

Or, an "Unable to retrieve table from this connection, click on the 'Define...' button to test this connection." error is 
generated when using the simple recordset dialog when selecting a connection from the Connections pop up menu.

Reason
These errors occur even when the connection test within UltraDev's Modify Connection dialog box is successful. This 
is an OLEDB provider issue which is specific to OLEDB connections using Microsoft SQL Server version 6.5. This is 
not an issue when using other versions of Microsoft SQL Server, or when using ODBC connections with Microsoft SQL 
Server 6.5.

Solution
The work around is to use ODBC connections instead of OLEDB connections when connecting to a Microsoft SQL 
Server 6.5 database. See Using ADO Connections in UltraDev (TechNote 14577) for more information on connection 
strings within UltraDev.

http://drupal.org/project/drupal
http://drupal.org/node/711650
http://help.adobe.com/en_US/dreamweaver/cs/using/WSb16ef6880e13ce361172e08122a970c26b-8000.html
http://www.adobe.com/devnet/dreamweaver/articles/setup_testing_server.html
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_14577


69

Last updated 11/5/2015

Error "Android SDK failed to install" with Easy Install | 
Dreamweaver CS5.5

Issue
When you click Easy Install for the Android SDK in the Configuration Application Framework dialog box in 
Dreamweaver CS5.5, you receive the following error:

"The Android SDK failed to install. Please select another folder and try again."

Solutions

Solution 1: Install the 11.5.1 update for Dreamweaver CS5.5
Important: After installing this update, restart your computer.

To install the update automatically:
1 Open Dreamweaver CS5.5.

2 Choose Help > Updates.

3 Follow the on-screen instructions to check for, download, and install the 11.5.1 update.

4 After the update is installed, restart your computer.

To install the update manually:
Mac OS

1 Download the Dreamweaver 11.5.1 
update:http://download.macromedia.com/pub/dreamweaver/updates/cs5/11_5_1/mac/AdobeDreamweaver-11.5-
All-Update.dmg 

2 If the AdobeDreamweaver-11.5-All-Update disk image automatically opens when you have finished downloading 
the file, then go to Step 3. Otherwise, double-click the file you downloaded to open the disk image.

3 Double-click the AdobeDreamweaver-11.5-All-Update folder to open it.

4 Double-click the AdobePatchInstaller application, and then follow the onscreen instructions.

5 After the update is installed, restart your computer.

Windows

1 Download the Dreamweaver 11.5.1 
update:http://download.macromedia.com/pub/dreamweaver/updates/cs5/11_5_1/win/AdobeDreamweaver-11.5-
All-Update.zip 

2 Extract the contents of the ZIP file you downloaded. Note: ZIP files are compressed files which contain other files. 
On Windows 7 or Vista, extract the contents of the ZIP file by right-clicking it, choosing Extract All, clicking Extract, 
and then opening the new Camera_Raw_5_6_updater folder. On Windows XP, extract the contents of the ZIP file 
by right-clicking it, choosing Open With > Compressed (Zipped) Folders, and then dragging all files and folders to 
your Desktop. 

http://download.macromedia.com/pub/dreamweaver/updates/cs5/11_5_1/mac/AdobeDreamweaver-11.5-All-Update.dmg
http://download.macromedia.com/pub/dreamweaver/updates/cs5/11_5_1/mac/AdobeDreamweaver-11.5-All-Update.dmg
http://download.macromedia.com/pub/dreamweaver/updates/cs5/11_5_1/win/AdobeDreamweaver-11.5-All-Update.zip
http://download.macromedia.com/pub/dreamweaver/updates/cs5/11_5_1/win/AdobeDreamweaver-11.5-All-Update.zip


70

Last updated 11/5/2015

3 Double-click the AdobePatchInstaller executable, and then follow the onscreen instructions.

4 After the update is installed, it is recommended to restart your computer.

After you update Dreamweaver, use Easy Install to install the Android SDK:

1 Open Dreamweaver.

2 Choose Site > Mobile Applications > Configure Application Framework.

3 Click Easy Install. Follow any remaining on-screen instructions to complete the installation of the Android SDK.

Solution 2: Install the Android SDK manually
Note: These instructions are meant to provide an overview of the minimum steps required to install and configure the 
Android SDK for use by PhoneGap in Dreamweaver. Consult the Android Developers documentation for the latest and 
most complete information: http://developer.android.com/sdk/installing.html

To install the Android SDK:

1 Download the latest version of the Android SDK starter package for your operating 
system:http://developer.android.com/sdk/index.html 

2 Do one of the following:Mac OS users: Extract the contents of the ZIP to the desired location (e.g. to /android-
sdk).Windows users: If you downloaded the installer (.exe file), then double-click on it and follow the on-screen 
instructions to complete the installation. If you downloaded the ZIP file, then extract its contents to the desired 
location (e.g. to C:\android-sdk).

3 Open the Android SDK Manager. To do so, double-click on the android file -- or, on Windows, android.bat file -- 
in the ./tools folder of the Android SDK. (E.g. /android-sdk/tools/android or C:\android-sdk\tools\android.bat) A 
command line window will open, and then the Android SDK Manager application will open.

4 Update the Android SDK Tools to the latest revision.

5 Install the Android SDK Platform-tools.

6 Install one or more AVDs. (Android 2.2/API 8 recommended.)

After you install the Android SDK, enter the folder path to it in Dreamweaver:

1 Open Dreamweaver.

2 Choose Site > Mobile Applications > Configure Application Framework.

3 Enter the folder path, or browse to and select the folder, to which you installed the Android SDK.

4 Click Save.

More Help topics 
Dreamweaver Mobile Center

Deploy web applications as native mobile applications

Dreamweaver CS5 known issues and bugs

http://developer.android.com/sdk/installing.html
http://developer.android.com/sdk/index.html
http://www.adobe.com/devnet/dreamweaver/dreamweaver-mobile.html
http://help.adobe.com/en_US/dreamweaver/cs/using/WSeffff8bffc80208478c8d43312e240fe0ad-8000.html
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Adobe Dreamweaver known issues and bugs
Welcome to Adobe Dreamweaver CS5. This document contains known issues and troubleshooting tips not covered in 
the Dreamweaver documentation.

See Adobe Support for late-breaking information and known issues for all Creative Suite 5 applications.

Subversion compatibility 
Dreamweaver CS5 uses the Subversion 1.6.6 client library. Later major versions (for example, 1.7.x) of the Subversion 
client library are not backward-compatible after a working copy upgrade. Dreamweaver can't communicate with 
Subversion if you do the following:

You update a third-party client application (for example, TortoiseSVN) to work with a later version of Subversion.

You then upgrade the working copy or try to use a Dreamweaver site with a working copy created by the third-party 
client.

Updates to the Subversion server don't affect this issue, as those updates are backward-compatible.

After upgrading to a third-party client application that uses a Subversion 1.7 or later working copy, check with Adobe 
for updates before using Subversion with Dreamweaver. For more information on this issue, see 
http://www.adobe.com/go/dw_svn_en.

GB18030 support for Windows XP
To support the display of all characters of the Chinese standard GB18030 on Windows XP systems, Adobe recommends 
the installation of theMicrosoft GB18030 Support Package. This support package updates an XP system with, among 
other things, fonts, and input-method-editors (IMEs) to correctly support GB18030. The support package is available 
as a download from the Microsoft website. (#BG061690) 

© 2010 Adobe Systems Incorporated. All rights reserved. 

Crash on Mac OS 10.9

Issue
Dreamweaver CS5 crashes when you try to start it on Mac OS X 10.9 (Mavericks).

Solution
1 Clear your Dreamweaver CS5 preferences by performing the following steps:

Important: By deleting preferences, you lose all the custom (user-specified) settings in Preferences, such as custom 
snippets, extensions, and changes to keyboard shortcuts.

a Open Finder and press Command + shift + G to open the Go To The Folder dialog box.

b Type ~/Library and click Go.

Note: If the Library folder is hidden, perform the steps outlined in this article to unhide the files.

c Navigate to the Application Support/Adobe/ folder, and perform the following steps:

• Locate the folder Dreamweaver CS5 and delete the folder.

http://www.adobe.com/go/support/
http://www.adobe.com/go/dw_svn_en
http://www.microsoft.com/downloads/en/confirmation.aspx?familyId=fc02e2e3-14bb-46c1-afee-3732d6249647&displayLang=en
https://developer.apple.com/library/mac/documentation/Porting/Conceptual/PortingUnix/additionalfeatures/additionalfeatures.html
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• Locate the Preferences folder and delete the Adobe Dreamweaver CS5 Prefs file.

2 Launch Dreamweaver.

3 Do not expand the Adobe BrowserLab panel. Close the panel and then begin to use Dreamweaver. To close the 
panel, click the pop-out menu at the upper-right corner and click Close Tab Group.

Note: Even to customize the workspace, ensure that you first close the Adobe BrowserLab panel and then begin to 
move and dock panels.

Additional information
Adobe BrowserLab on Dreamweaver CS5 is not supported on Mac OS 10.9.

Dreamweaver 8 for Windows loses FTP login settings
Issue

 Some Windows users are reporting that their FTP usernames and passwords in their Dreamweaver site definitions are 
deleted when they close and re-open Dreamweaver 8 or when they reboot their machine. This issue does not occur in 
earlier versions of Dreamweaver. (Ref. 205051, 210466) 

Reason

 There are two known causes for this issue: 

• The most common cause is that Internet Explorer 7 (IE 7) is installed on the same machine as Dreamweaver 8.

• A less likely cause is that the following registry key is missing or is 
empty:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Explorer\User Shell 
Folders\AppData

Solution

If you have Internet Explorer 7 installed

If you have Internet Explorer 7 installed, then installing theDreamweaver 8.0.2 Updater should resolve this issue. Before 
installing the Dreamweaver 8.0.2 Updater, it is recommended to check the Dreamweaver 8 Emerging Issues TechNote 
for changes that may affect your workflow, particularly if you create server-side pages (ASP, PHP, ColdFusion, etc.) or 
insert Flash content.

Note: After you install the Dreamweaver 8.0.2 Updater, verify that the updater successfully installed. Some users think 
they have installed 8.0.2, when in fact the updater installation didn't take. In Dreamweaver, go to Help > About 
Dreamweaver > and click the scrolling text to reveal the version number. It should say Dreamweaver 8.0.2. If it still says 
Dreamweaver 8.0 or 8.0.1, please see Can't install Dreamweaver 8 updaters for Windows after canceling updater 
installer (TechNote 785362aa).

Note: Internet Explorer 7 was released after Dreamweaver 8 and therefore was not tested with Dreamweaver 8 and 
earlier.

If you do not have Internet Explorer 7 installed or if the Dreamweaver 8.0.2 Updater doesn't solve the problem

If you didn't have Internet Explorer 7 at the time this problem occurred, then install the Dreamweaver 8.0.2 Updater as 
described above, and then perform the following steps if you are comfortable editing the Windows Registry.

https://www.adobe.com/support/dreamweaver/downloads_updaters.html
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=a3f38dcf
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=785362aa
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=785362aa
https://www.adobe.com/support/dreamweaver/downloads_updaters.html
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Warning: Editing the Windows Registry incorrectly can cause serious problems that may require reinstalling your 
operating system. Adobe does not guarantee that problems caused by editing the registry incorrectly can be resolved. 
Edit the registry at your own risk.

1 Launch the Registry Editor by clicking the Start button, choose Run, then type "regedit". In the Registry Editor, 
navigate to this folder:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Explorer\User 
Shell Folders\

2 See if there is a key called AppData, as shown in the screen shot below:

3 Backup the Users Shell Folders registry branch as follows:

a Right-click the Users Shell Folders folder and select "Export".

b In the "Export range" section, choose "Selected branch".

c Save the .reg file to the desktop.

d If problems occur after editing the registry, double-clicking the .reg file will re-install that registry branch.

4 If the AppData key is missing, then perform the following steps. If the AppData key exists, then skip to Step 5.

a On the right side of the Registry Editor explorer pane, right-click in a blank area anywhere under the last key in 
the list. You should get a context menu that says "New" with a flyout menu.

b In the flyout menu, select "Expandable String Value" and name the new key AppData.

5 Right-click the new AppData key (or the existing one if it was already there), select Modify, and enter the following 
in the Value Data field: %USERPROFILE%\Application Data. If the values for the other keys in your User Shell 
Folders directory don't start with %USERPROFILE%, then use the value that your other keys use. For example, if 
your Local Settings key has a value of u:\Local Settings, then try usingu:\Application Data.

6 Open Dreamweaver, re-enter the FTP login information for one of your sites, and see if the FTP login is now saved 
when you close and re-open Dreamweaver.

If the solutions above don't solve the problem, then please contact Adobe Technical Support or submit a bug report and 
specify that you are experiencing the issue described in TechNote 3491671c.

Different redirect pages for each user level 
(Dreamweaver Developer Toolbox)

Issue
 When trying to access a page that is protected by the Restrict Access To Page server behavior for a particular level, I 
get redirected to the default login successful page, instead of the page I was trying to access. I thought that the page the 
user tried to access will be passed to the login page as an URL parameter. 

https://www.adobe.com/support/contact/
https://www.adobe.com/go/wish
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Reason
 In Adobe Dreamweaver Developer Toolbox, each user level has its own redirect pages defined in the Developer 
ToolboxControl Panel: a redirect page when the login is successful and one for failure. When a page that has the 
Restrict Access to Page server behavior applied for a certain user level is accessed by a user with a different access level, 
it will be taken to the login page, and if he logs in correctly, he will be redirected to its default login successful page. If 
the user has the correct access level, he will be redirected to the desired page. 

Solution
 Define the desired pages in the Developer Toolbox Control Panel for each user level used in the database. Also, when 
applying the Restrict Access to Page server behavior, specify the exact level that is allowed access. All other users that 
do not have the correct level, will not be able to access it, even if they log in correctly. Also, concerning the matter of 
the page on which access was attempted at first, it is not passed as an URL parameter, but as a session variable. After 
login, the redirect is done automatically to the desired page, if all data match (username, password and access level). 

Deprecated features in Dreamweaver

Dreamweaver - Deprecated Features
There are many features in Dreamweaver that require significant resources to maintain release to release, but aren't 
being used with significant frequency. Correspondingly, we've recently made some difficult decisions as a tradeoff 
between continuing to support infrequently used features vs. developing new features to both streamline key web 
design and development workflows and support newer technologies and development models.

This document serves as an archive of links to a list of deprecated features in Dreamweaver. The deprecated features are 
listed at the bottom of the Help system's "What's New" section.

Dreamweaver CS4 deprecated features

Dreamweaver CS5 deprecated features

Although we understand that deprecating features impacts those of you who rely on them, we want to be as clear as 
possible as to their status so that you can plan for alternate workflows and development approaches within 
Dreamweaver.

- The Adobe Dreamweaver Team

The Date Picker calendar window does not show up 
(Dreamweaver Developer Toolbox)

Issue
 After enhancing a standard text field with the Date Picker widget, when I press the button in the browser the calendar 
window does not show up. On a simple page containing only the enhanced text field it works. 

http://help.adobe.com/en_US/Dreamweaver/10.0_Using/WS2C41F19D-502B-4fb5-8A54-4442E2127C84a.html
http://help.adobe.com/en_US/Dreamweaver/CS5/Using/WSc78c5058ca073340dcda9110b1f693f21-7ffba.html
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Reason
 This happens because elements on the page containing the Date Picker enhanced text field use z-index as method of 
establishing element depth. The calendar window which is displayed when the button is pressed does not use z-index 
and therefore is not visible (it is positioned below the other page elements). 

Solution
 In order to display the Date Picker interface, you have two options: 

1 Remove the z-index options in the page.

2 Set the z-index value for the layer containing the Date Picker to 0.

Customizing HTML code in Dreamweaver
 The SourceFormat.txt file in Dreamweavers Configuration folder can be used to customize some of the HTML 
formatting created by Dreamweaver. This changes how the HTML appears in the HTML Source window. 

Customizing the HTML code is done by one of two methods: 1) entering new information in the HTML Format dialog 
box in Dreamweaver, which updates the SourceFormat.txt file or 2) editing the SourceFormat.txt file itself. 

Method one: entering new information in the HTML Format dialog box To enter new information in the HTML 
Format dialog box, open Dreamweaver and choose Edit > Preferences > HTML Format. The HTML formatting items 
listed in the HTML Format dialog box are those items that can be changed inDreamweaver. 

The settings in the above HTML Format dialog box apply to the following section of the SourceFormat.txt file:

<!-- options     INDENTION      : indention options 
 

      ENABLE    - allows indention 
 

      INDENT    - columns per indention 
 

      TABS      - columns per tab character 
 

      USE       - TABS or SPACES for indention 
 

      ACTIVE    - active indention groups (IGROUP) 
 

 LINES          : end-of-line options 
 

      AUTOWRAP  - enable automatic line wrapping 
 

      BREAK     - CRLF, CR, LF 
 

      COLUMN    - auto wrap lines after column 
 

 OMIT           : element omission options 



76

Last updated 11/5/2015

 
      OPTIONS   - options 

 
 ELEMENT        : element options 

 
      CASE      - "UPPER" or "lower" case 

 
      ALWAYS    - always use preferred element case (instead of 

 
                  original case) 

 
 ATTRIBUTE      : attribute options 

 
      CASE      - "UPPER" or "lower" case 

 
      ALWAYS    - always use preferred element case (instead of 

 
                  original case) 

 
 --><? options><indention enable indent="2" tabs="4" use="spaces" active="1,2,3"><

The SourceFormat.txt settings define the following HTML :

Method two: editing the SourceFormat.txt fileThe SourceFormat.txt file is found in the Configuration folder inside 
the Dreamweaver 3 program folder.

The following are some important considerations before editing the SourceFormat.txt file:

Understanding the Elements section of theSourceFormat.txt fileWhen editing the SourceFormat.txt file, it is 
important to understand that the Elements section is where the heart of formatting takes place. 

 Indentation defines the setting for indent and tab sizes and whether 
to use spaces or tabs or these parameters. 

Lines defines the autowrap, column length and break style. 

Omit has been reserved for future use. 

Element defines upper or lower case for the Element and "always" 
refers to when to use the custom case setting. 

Attribute defines upper or lower case for the Attribute and "always" 
refers to when to use the custom case setting. 

 Dreamweaver reads this document as it opens and updates it upon 
closing. Therefore, it is vital that you have the program closed before 
you do any editing of the SourceFormat.txt. 

If you do not see the changes reflected in the code, click Commands> 
Apply Source Formatting. 

It is a good idea to save a copy of the file before you edit it. 
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<!-- element information line breaks        : BREAK     = "before, inside start, inside                                  
end, after" 

 
 indent contents    : INDENT 

 
 indent group       : IGROUP    = "indention group number 

 
                                  (1 through 8) 

 
 specific name case : NAMECASE  = "CustomName" 

 
 prevent formatting : NOFORMAT        

Do Not Use--><?elements><address break="1,0,0,1"><applet break="0,1,1,0" indent><base break="1,0,0,

The key to understanding the formatting is in the line breaks line:

 : BREAK = " before, inside start, inside end, after" 

The line breaks defines where a break will be placed in relationship to a tag. 

When the Address line is edited to read <address break="1,0,0,1">, there will be one break before the opening address 
tag, no break inside of the address tag before the value, no break inside of the address tag after the value, and one break 
after the closing address tag. 

In the HTML Source window, it will look like this: 

<P>Previous sentence.</P><ADDRESS>Joe Macromedia</ADDRESS><P>Next sentence.</P>

 In the Document window, it will look like this: 

Previous sentence. 

Joe Macromedia 

Next sentence. 

When the Address line is edited to read <Address break="1,1,1,1">, there will be one break between the opening 
address tag and the value and one break between the the value and the ending address tag. 

In the HTML Source window, it will look like this: 

<P>Previous sentence.</P><ADDRESS>Joe Macromedia</ADDRESS><P>Next sentence.</P>

 Since altering the HTML source formatting only affects the HTML source code, the text in the Document window will 
appear the same as it did in the previous example. 

Note:Remember to select Commands > Apply Source Formatting when you reopen Dreamweaver! 

If we want to put a space between the surrounding tags and indent the value, the line will read:<Address break="2,1,1,2" 
indent> 

In the HTML Source window, it will look like this: 

<P>Previous sentence.<P><ADDRESS> 
 

Joe Macromedia 
 

</ADDRESS> 
 

<P>Next sentence.<P> 

Note:The value of this indent is set in the Option indentation line and can be modified from the Preferences menu. 
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Understanding the IGROUPSsection of theSourceFormat.txt file The IGROUP parameter is for enabling groups of 
tags to be defined by the Options settings.By default, IGROUP 1 groups Table rows and columns and IGROUP 2 groups 
Frames and Frameset tags. 

To enable an IGROUP, you would simply put its number in the "active=" parameter of the Indentation Option. (Notice 
that checking 'Table Rows and Columns' and 'Frames and Framesets' in the Preferences will add '1' and '2' respectively 
to the "active=" parameter.) 

You can easily create your own IGROUP. At the end of any tag definition, enter "indent" (this is necessary to enable the 
IGROUP settings) and then "IGROUP= #" (1-8). Then put that number in the "active=" parameter in the Options 
settings. 

To put the Address tag into its own IGROUP, the line would look like this: 

<Address break="2,1,1,2 indent igroup="3">

 In the Options indentation line, it would read 'active="1,2,3" ' 

Note:In order for the IGROUP to be active, the second break number, the "inside start" number, must be greater than 
'0'. IGROUPs will only indent if the value has its own line. 

Additional informationFor more information, read Editing the HTML source formatting profile in the Dreamweaver 
Help Pages. 

Create client-side dynamic dependent list boxes

Introduction

Client-side dynamic dependent list boxes allow a "child" list box to refresh when a selection is made in a "parent" list 
box, without having to return to the server. Most dynamic dependent list box models return to the server to requery 
the dependent list box's recordset. The model described in this TechNote passes dependent list box data to the browser 
in an array. It uses JavaScript to extract the appropriate values from the array and refresh the "child" list box in the 
client's browser.

The advantage to this approach is immediate page response; the user does not have to wait for the new page to be 
delivered from the remote server. The disadvantage is all the data for the dynamic dependent list box is sent to the client 
as text, thus increasing the size of the requested page. An evaluation must be made whether the increased page size 
warrants saving return trips to the server. If the amount of data required for the dynamic dependent list box is not 
significant, page size remains relatively small.

Multiple dynamic dependent list boxes can be added to a page. The extra steps to do this are documented at the end of 
this TechNote.

The model described here has a "parent" list box created normally in UltraDev. It can be either dynamic or static. The 
model also has a "child" dynamic dependent list box created in UltraDev as a normal List/Menu object. The "child" 
dynamic dependent list box is made dynamic on the client side with the addition of the code presented here.

Building the page

1 Add the "parent" list box to the page. Add either hard coded or dynamic Item Labels and Values to it.

Dreamweaver UltraDev is no longer supported, and the Dreamweaver UltraDev support center will no longer be actively updated. The 
functionality available in Dreamweaver UltraDev is available in Dreamweaver, beginning with Dreamweaver MX. Accordingly, we are moving 
pertinent content to the Dreamweaver support center. Please refer to the Dreamweaver version of this technote: Creating client-side dynamic 
dependent list boxes in ASP (TechNote 19117).

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_19117
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_19117
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2 Add the "child" list box to the page. Do not add any Item Labels or Values to it.

3 Create a recordset for the child list box, which must include fields for its Item Labels, Values, and the relationship to 
the parent list box as explained in Relating the list boxes .

4 Copy the appropriate VBScript or JavaScript code and paste into the page's HTML code window just above the 
closing head tag.

5 Change the object names in the pasted code as explained in Object names .

6 Add the Call JavaScript behavior(s) as explained in Final changes .

7 Apply the code to view dynamic listboxes in Netscape 4 as explained in Netscape 4 Modification .

8 If errors occur when viewing the page, or the dependent list box does not function correctly, check Troubleshooting .

9 To add more than one dynamic dependent list box to a page, follow the instructions in Multiple dynamic dependent 
list boxes on one page .

Relating the list boxes

When defining the relationship between the parent and child list boxes, two rules apply.

• The Value of the parent list box is used to filter the data used to populate the child list box.

• A field in the child list box's recordset must correspond to the Value in the parent list box (the "relation").

The following example shows a parent list box populated with two Item Labels;Colors and Shapes;with their 
corresponding values. The child list box is populated in the client browser from a recordset with three fields. The 
Relation field identifies the relationship with the Value of the parent list box. The Item Label field will be displayed in 
the child list box. The Value field is returned to the server corresponding to the item label selected by the user.

Parent list box Child list box

Item Label

Relation

Item Label

Value

Value

Colors

ColorCode

Blue

1

ColorCode

 

ColorCode

Red

2

 

ColorCode

Green

3

http://helpx.adobe.com/dreamweaver/kb/#main_relating
http://helpx.adobe.com/dreamweaver/kb/#main_vbsource
http://helpx.adobe.com/dreamweaver/kb/#main_jssource
http://helpx.adobe.com/dreamweaver/kb/#main_objectnames
http://helpx.adobe.com/dreamweaver/kb/#main_finalchanges
http://helpx.adobe.com/dreamweaver/kb/#main_netscapefix
http://helpx.adobe.com/dreamweaver/kb/#main_troubleshooting
http://helpx.adobe.com/dreamweaver/kb/#main_multiple
http://helpx.adobe.com/dreamweaver/kb/#main_multiple
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BACK TO Building the Page 

Object names

The code provided in this TechNote uses the following object names which must be renamed to the corresponding 
object names from your page.

Note: By naming your objects with the above names, only "Relation", "Label", and "Value" (and possibly form2) need 
to be changed in the provided code.

BACK TO Building the Page 

Client-side dynamic dependent list box code - VBScript

 

ColorCode

Yellow

4

Shapes

ShapeCode

Square

A

ShapeCode

 

ShapeCode

Circle

B

 

ShapeCode

Triangle

C

Parent list box Child list box

Colors Shapes Blue Red Green Yellow

selList1 Name of the parent list box, defined in UltraDev.

form1 Form name containing the selList1 object.

selList2 Name of the child list box populated by this code on the client side 
after making a selection in selList1.

form2 Form name containing the selList2 object (usually the same form 
selList1 uses).

rsList2 Recordset used to populate the child list box, selList2, from an array on 
the client side.

"Relation" Field name from rsList2 used to define the relationship with selList1.

"Label" Field name from rsList2 used to fill the Item Label column of selList2.

"Value" Field name from rsList2 used to fill the Value column of selList2.

http://helpx.adobe.com/dreamweaver/kb/#main_building
http://helpx.adobe.com/dreamweaver/kb/#main_building
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Client-side dynamic dependent list box code This code creates the array for the client side from the recordset rsList2. 
It also includes the functions called when the first list box is changed. setDynaList() controls the functions. 
clearDynaList() clears existing elements from selList2. populateDynaList() adds elements to selList2 based on the value 
selected in selList1.

The client-side dynamic dependent list box code is available for VBScript (this code) or JavaScript server-side scripting 
languages in ASP pages.

Code insertion location

Insert the code provided in the head section of the page, right above the closing head tag. Make sure the first two lines 
and last two lines are not contained within any other open and closed script tags, or a nesting error will occur.

Replace the eight object names in red with your object names. Make sure to leave the quotation marks in the code.

<!-- Dynamic Dependent List box Code for *** VBScript *** Server Model //--><script ><!-- var 
arrDynaList = new Array(); var arrDL1 = new Array(); arrDL1[1] = "selList1";               // 
Name of parent list box arrDL1[2] = "form1";                  // Name of form containing parent 
list box arrDL1[3] = "selList2";               // Name of child list box arrDL1[4] = "form2";                  
// Name of form containing child list box arrDL1[5] = arrDynaList;<% Dim txtDynaListRelation, 
txtDynaListLabel, txtDynaListValue, oDynaListRS txtDynaListRelation = "Relation"      ' Name 
of recordset field relating to parent txtDynaListLabel = "Label"            ' Name of recordset 
field for child Item Label txtDynaListValue = "Value"            ' Name of recordset field for 
child Value Set oDynaListRS = rsList2             ' Name of child list box recordset Dim 
varDynaList varDynaList = -1 Dim varMaxWidth varMaxWidth = "1" Dim varCheckGroup varCheckGroup 
= oDynaListRS.Fields.Item(txtDynaListRelation).Value Dim varCheckLength varCheckLength = 0 Dim 
varMaxLength varMaxLength = 0 While (NOT oDynaListRS.EOF) If (varCheckGroup <> 
oDynaListRS.Fields.Item(txtDynaListRelation).Value) Then If (varCheckLength > varMaxLength) 
Then varMaxLength = varCheckLength End If varCheckLength = 0 End If %> 
arrDynaList[<%=(varDynaList+1)%>] = 
"<%=(oDynaListRS.Fields.Item(txtDynaListRelation).Value)%>" 
arrDynaList[<%=(varDynaList+2)%>] = "<%=(oDynaListRS.Fields.Item(txtDynaListLabel).Value)%>" 
arrDynaList[<%=(varDynaList+3)%>] = 
"<%=(oDynaListRS.Fields.Item(txtDynaListValue).Value)%>"<% If 
(len(oDynaListRS.Fields.Item(txtDynaListLabel).Value) > len(varMaxWidth)) Then varMaxWidth = 
oDynaListRS.Fields.Item(txtDynaListLabel).Value End If varCheckLength = varCheckLength + 1 
varDynaList = varDynaList + 3 oDynaListRS.MoveNext() Wend If (varCheckLength > varMaxLength) 
Then varMaxLength = varCheckLength End If %> //--></script><!-- End of object/array 
definitions, beginning of generic functions --><script ><!-- function setDynaList(arrDL){ var 
oList1 = document.forms[arrDL[2]].elements[arrDL[1]]; var oList2 = 
document.forms[arrDL[4]].elements[arrDL[3]]; var arrList = arrDL[5]; clearDynaList(oList2); if 
(oList1.selectedIndex == -1){ oList1.selectedIndex = 0; } populateDynaList(oList2, 
oList1[oList1.selectedIndex].value, arrList); return true; } function clearDynaList(oList){ 
for (var i = oList.options.length; i >= 0; i--){ oList.options[i] = null; } oList.selectedIndex 
= -1; } function populateDynaList(oList, nIndex, aArray){ for (var i = 0; i < aArray.length; 
i= i + 3){ if (aArray[i] == nIndex){ oList.options[oList.options.length] = new Option(aArray[i 
+ 1], aArray[i + 2]); } } if (oList.options.length == 0){ oList.options[oList.options.length] 
= new Option("[none available]",0); } oList.selectedIndex = 0; } //--></script>

BACK TO Building the Page 

Client-side dynamic dependent list box code - JavaScript

http://helpx.adobe.com/dreamweaver/kb/#main_jssource
http://helpx.adobe.com/dreamweaver/kb/#main_building
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Client-side dynamic dependent list box code This code creates the array for the client side from the recordset rsList2. 
It also includes the functions called when the first list box is changed. setDynaList() controls the functions. 
clearDynaList() clears existing elements from selList2. populateDynaList() adds elements to selList2 based on the value 
selected in selList1.

The client-side dynamic dependent list box code is available forVBScript or JavaScript (this code) server-side scripting 
languages in ASP pages.

Code insertion location

Insert the code provided in the head section of the page, right above the closing head tag. Make sure the first two lines 
and last two lines are not contained within any other open and closed script tags, or a nesting error will occur.

Replace the eight object names in red with your object names. Make sure to leave the quotation marks in the code.

<!-- Dynamic Dependent List box Code for *** JavaScript *** Server Model //--><script ><!-- 
var arrDynaList = new Array(); var arrDL1 = new Array(); arrDL1[1] = "selList1";               // 
Name of parent list box arrDL1[2] = "form1";                  // Name of form containing parent 
list box arrDL1[3] = "selList2";               // Name of child list box arrDL1[4] = "form2";                  
// Name of form containing child list box arrDL1[5] = arrDynaList;<% var txtDynaListRelation, 
txtDynaListLabel, txtDynaListValue, oDynaListRS; txtDynaListRelation = "Relation"      // Name 
of recordset field relating to parent txtDynaListLabel = "Label"            // Name of recordset 
field for child Item Label txtDynaListValue = "Value"            // Name of recordset field 
for child Value oDynaListRS = rsList2                 // Name of child list box recordset var 
varDynaList = -1; var varMaxWidth = "1"; var varCheckGroup = 
oDynaListRS.Fields.Item(txtDynaListRelation).Value; var varCheckLength = 0; var varMaxLength 
= 0; while (!oDynaListRS.EOF){ if (varCheckGroup != 
oDynaListRS.Fields.Item(txtDynaListRelation).Value) { varMaxLength = Math.max(varCheckLength, 
varMaxLength) varCheckLength = 0; } %> arrDynaList[<%=(varDynaList+1)%>] = 
"<%=(oDynaListRS.Fields.Item(txtDynaListRelation).Value)%>"; 
arrDynaList[<%=(varDynaList+2)%>] = "<%=(oDynaListRS.Fields.Item(txtDynaListLabel).Value)%>"; 
arrDynaList[<%=(varDynaList+3)%>] = 
"<%=(oDynaListRS.Fields.Item(txtDynaListValue).Value)%>";<% if 
(oDynaListRS.Fields.Item(txtDynaListLabel).Value.length > varMaxWidth.length) { varMaxWidth = 
oDynaListRS.Fields.Item(txtDynaListLabel).Value; } varCheckLength = varCheckLength + 1; 
varDynaList = varDynaList + 3; oDynaListRS.MoveNext(); } varMaxLength = 
Math.max(varCheckLength, varMaxLength) %> //--></script><!-- End of object/array definitions, 
beginning of generic functions --><script ><!-- function setDynaList(arrDL){ var oList1 = 
document.forms[arrDL[2]].elements[arrDL[1]] var oList2 = 
document.forms[arrDL[4]].elements[arrDL[3]] var arrList = arrDL[5] clearDynaList(oList2); if 
(oList1.selectedIndex == -1){ oList1.selectedIndex = 0; } populateDynaList(oList2, 
oList1[oList1.selectedIndex].value, arrList); return true; } function clearDynaList(oList){ 
for (var i = oList.options.length; i >= 0; i--){ oList.options[i] = null; } oList.selectedIndex 
= -1; } function populateDynaList(oList, nIndex, aArray){ for (var i = 0; i < aArray.length; 
i= i + 3){ if (aArray[i] == nIndex){ oList.options[oList.options.length] = new Option(aArray[i 
+ 1], aArray[i + 2]); } } if (oList.options.length == 0){ oList.options[oList.options.length] 
= new Option("[none available]",0); } oList.selectedIndex = 0; } //--></script>

BACK TO Building the Page 

Final changes

http://helpx.adobe.com/dreamweaver/kb/#main_vbsource
http://helpx.adobe.com/dreamweaver/kb/#main_building
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After inserting the code into your page and renaming the objects to your object names, only one or two more changes 
are needed.

1 Select the selList1 list box object. From the Behaviors panel, add the Call JavaScript behavior. Enter 
setDynaList(arrDL1) (capitalization counts!) in the Call JavaScript dialog box. Make sure the action is added to the 
onChange event for the list box. This causes the child list box contents to update when a change is made in the parent 
list box.

2 Select the body tag in the lower left border of the page. From the Behavior inspector, add the Call JavaScript 
behavior. EntersetDynaList(arrDL1) (capitalization counts!) in the Call JavaScript dialog box. Make sure the action 
is added to the onLoad event. This step is optional. It will initialize selList2 when the page loads on the basis of the 
default value for selList1.

BACK TO Building the Page 

Netscape 4 Modification

An extra modification is needed for Netscape 4 browsers to properly view the dynamic listbox. If the dynamically 
populated listbox does not have any initial values, Netscape 4 will not resize the listbox to accommodate the 
dynamically populated contents. The listbox is essentially unusable. To remedy the situation, this modification will 
initially populate the listbox with the widest item label and the largest number of item labels from your child listbox 
recordset groups. As long as you call thesetDynaList function from the onLoad event, these initial values will not be 
displayed.

Note: The "largest number of item labels" means the number of items in the largest Relation group. In the above 
color/shape example, this value is 4, because there are four ColorCodes. To insure the correct maximum is calculated, 
the recordset must be sorted by Relation (you can add secondary sorts as well, for example by Label).

In the source code, the HTML for the child listbox will appear as follows (with your name if you used a different name):

<select name="selList2"></select>

Replace the code for the child listbox with the following if you are using the VBScript server model:

<select name="selList2"><% Dim varLoopCounter For varLoopCounter = 1 TO varMaxLength %><option 
value = "<%=varMaxWidth%>"><%=varMaxWidth%></option><% Next %></select>

Replace the code for the child listbox with the following if you are using the JavaScript server model:

<select name="selList2"><% for (varLoopCounter = 1; varLoopCounter <= varMaxLength; 
varLoopCounter++){ %><option value = "<%=varMaxWidth%>"><%=varMaxWidth%></option><% } 
%></select>

BACK TO Building the Page 

Troubleshooting

• Verify the object names have been changed correctly as explained in Object names . This is the most common 
problem encountered.

• Verify the "relation" field in the child list box recordset corresponds to the parent list box's Value as explained in 
Relating the list boxes .

• Verify the correct code has been inserted for your server-side scripting language, VBScript or JavaScript.

• Try rebuilding the page from scratch, or building a simple test page.

BACK TO Building the Page 

Multiple dynamic dependent list boxes on one page

http://helpx.adobe.com/dreamweaver/kb/#main_building
http://helpx.adobe.com/dreamweaver/kb/#main_building
http://helpx.adobe.com/dreamweaver/kb/#main_objectnames
http://helpx.adobe.com/dreamweaver/kb/#main_relating
http://helpx.adobe.com/dreamweaver/kb/#main_building
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The provided code can easily be enhanced to accommodate more than one dynamic dependent list box on a page. The 
functions are generic, so no modifications are needed for the functions section of code. Follow these steps to add 
another dynamic dependent list box.

1 Copy the top half of the code down to the following line:<!-- End of object/array definitions, beginning of generic 
functions -->

2 Paste the code segment into a text editor to perform the following modifications.

3 In the same manner as explained above for the first set of list boxes, rename the objects in the code to correspond 
to your object names.

4 Rename the following objects. As long as they do not conflict with other object names in the page, and changes are 
made consistently to all references in the code, the new names are not so important. Use a Find/Replace function to 
ensure all instances are changed correctly.

Note: For a third pair of dynamic dependent list boxes, use names such as "arrDynaList3", and so forth and so on.

5 Add new Call JavaScript behaviors to the new parent list box's onChange event and to the body's onLoad event. This 
time, use the new array name as the parameter in the function call. For example,setDynaList(arrDL2) . 

You may also want to add setDynaList(arrDL2) to the onChange event of another list box, if you now have a 
grandparent/parent/child relationship.

6 Check the source code of any multiple onLoad and onChange JavaScript calls. Starting with the top level list box and 
working down, make sure the functions execute in the proper order.<select 
onChange="setDynaList(arrDL1);setDynaList(arrDL2)" name="selList1">

Crash | Play SWF file in Design View | Dreamweaver CS5.5 
| Mac OS

Issue
When you play a SWF file in the Design View of Adobe Dreamweaver CS5.5 on Mac OS, the application hangs and 
then crashes.

Original Name New Name

arrDynaList arrDynaList2

arrDL1 arrDL2

txtDynaListRelation txtDynaListRelation2

txtDynaListLabel txtDynaListLabel2

txtDynaListValue txtDynaListValue2

oDynaListRS oDynaListRS2

varDynaList varDynaList2



85

Last updated 11/5/2015

Solution
Play the SWF file in Live View or in a web browser.

Additional information
For more information about previewing content, see Previewing pages in Dreamweaver or Previewing pages in 
browsers in Dreamweaver Help.

Crash in Live View | Dreamweaver CS5.5, CS5 | Mac OS

Issue
When you enable Live View in Dreamweaver CS5 or CS5.5, the application hangs for a short period and then 
unexpectedly quits.

Solutions

Solution 1: Disable the RocketEngine plug-in.
The RocketEngine plug-in is included with HP Photo Creations. To disable this plug-in:

1 In the Finder, navigate to /Users/Your User Name/Library/Internet Plug-Ins

2 Move or delete the RocketEngine.plugin alias file.

3 Restart Dreamweaver for the change to take effect.

Solution 2: Troubleshoot other Internet plug-ins
Other plug-ins that have been installed for your web browser may be causing the issue. To determine which plug-in is 
causing the issue, use a method similar to the following:

1 Quit Dreamweaver, as well as any web browsers you may have open.

2 Create a new folder on your Desktop called Disabled Plug-ins.

3 Move all files from both of the following folders to the new folder you created on your Desktop:/Users/Your User 
Name/Library/Internet Plug-Ins/Library/Internet Plug-Ins 

4 Launch Dreamweaver and then attempt to preview your content in Live View.

5 Do one of the following:

• If the problem recurs, then Internet plug-ins are not the cause of your issue. Quit Dreamweaver and move the 
files back to their original locations.

• If the problem does not recur, then one or more of the plug-ins you removed is causing the issue. Proceed to Step 
6.

6 Quit Dreamweaver.

7 Move one plug-in file from Disabled Plug-ins back to its original location.

http://help.adobe.com/en_US/dreamweaver/cs/using/WS0459F349-E2DC-4d31-ADCF-F954B79D9A77.html
http://help.adobe.com/en_US/dreamweaver/cs/using/WScbb6b82af5544594822510a94ae8d65-7bfaa.html
http://help.adobe.com/en_US/dreamweaver/cs/using/WScbb6b82af5544594822510a94ae8d65-7bfaa.html
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8 Restart Dreamweaver and try to preview your content in Live View.

9 Do one of the following:

• If the problem recurs, then repeat Steps 6 through 9.

• If the problem does not recur, then the plug-in file you most recently moved is causing the issue. Remove this 
plug-in file and then contact its manufacturer to check for updates and other assistance. Move any remaining 
plug-ins in Disabled Plug-ins back to their original locations.

Additional information
The HP Photo Creations program installs browser plug-ins and enables them by creating an alias to them in your User 
Library. A problem with the alias for the RocketEngine.plugin file causes Dreamweaver to crash.

Contact HP for additional information about HP Photo Creations.

Configuring WebDAV in IIS for use with Dreamweaver
 Original doc (PDF) 

There are different ways to set up Web-based Distributed Authoring and Versioning (WebDAV) for sharing files over 
the Internet. This TechNote describes one method that allows a website authoring team to modify live files on an IIS-
hosted website using WebDAV in Dreamweaver. To achieve this functionality, this method uses duplicate websites 
running on different ports in Microsoft's Internet Information Services (IIS) server, both pointing to the same set of 
files on the web server.

Prerequisites:

In order to get the most out of this TechNote, developers must have an understanding of IIS, and must know how to 
define a folder as a website in IIS. We recommend the IIS help files. This setup applies to IIS version 5 or higher, which 
includes support for WebDAV.Why configure duplicate websites running on different ports?

If you follow the steps in the IIS help documentation for "Creating a Publishing Directory" using WebDAV, you will 
create a physical directory on the server, link that physical directory to an IIS virtual directory, and grant limited access 
permissions (Read, Write, and Browsing) for the virtual directory. The IIS help documents also state that the WebDAV 
directories should have anonymous access turned off. The problem here is that only the authoring team (assuming they 
have the necessary Windows permissions) will be able to view the website. In other words, the Internet public will not 
be able to view the website, since anonymous access is turned off. A server administrator could transfer the files from 
the "locked down" WebDAV directory to an "open" public website directory, but that would introduce an additional 
administrative step into the website publishing process. Creating duplicate IIS websites running on different ports 
makes web publishing a one-step process in Dreamweaver.Defining and configuring two IIS website instances

For the configuration method explained in this TechNote, it is necessary to define two separate websites in IIS pointing 
to the same folder on the server (in this example,c:\inetpub\wwwroot). One website will handle normal Internet traffic 
(read-only), and the other website will be dedicated to handling WebDAV requests (read, write, file management, file 
locking, etc.).

Note: The instructions for configuring the websites in IIS are provided as a courtesy to customers, but Macromedia 
does not accept responsibility for ensuring such configurations function as expected. This is one of many possible 
configurations, and customers are encouraged to use any other configuration that works for them.Website 1: Setting up 
a website for normal browser (HTTP) requests.

1. Define a new website in IIS which uses port 80.

http://helpx.adobe.com/dreamweaver/kb//content/dam/kb/en/190/tn_19095/attachments/Configuring_WebDAV_in_IIS_for_use_with_Dreamweaver.pdf
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2. Use restricted permissions for the Home Directory. For example, allow "Read" access and set "Execute Permissions" 
to "Scripts Only".

3. Allow Anonymous access. Allowing Integrated Windows authentication is optional. See the IIS help files for more 
information on Integrated Windows authentication.

Website 2: Setting up a second IIS website devoted to handling WebDAV requests.

1. Define a second site in IIS, pointing to the same folder but using a port number other than 80. In this example, port 
81 is used.

2. Allow most or all permissions for the Home Directory and set "Execute Permissions" to "Scripts only".

3. Disable the ASP script server, the ColdFusion script server or other script server you may be using. You do this by 
clicking the "Configuration..." button in the screen shot above and removing the appropriate DLL. This will prevent IIS 
from sending the server-side script to the application server for processing. Someone editing a ColdFusion page would 
want to see the pre-processed ColdFusion code, not the resultant post-processed HTML code.

4. Because the WebDAV site is much more permissive, do not allow Anonymous access. Use Basic authentication.

Note: Basic authentication sends passwords over the network in an unencrypted form, however the Basic 
authentication checkbox must be checked in order for WebDAV to work in Dreamweaver. Microsoft Internet Explorer 
(version 2.0 and later) is the only WebDAV client that supports Integrated Windows authentication (user names and 
passwords are hashed before being sent across the network). WebDAV in Dreamweaver will continue to work if you 
check the "Integrated Windows authentication" checkbox in addition to Basic authentication. This setup would allow 
Dreamweaver connections to use Basic authentication and Internet Explorer connections to use Integrated Windows 
authentication. Microsoft recommends turning on Basic authentication only if you encrypt passwords through Secure 
Sockets Layer (SSL). Dreamweaver 8 now supports WebDAV over SSL.

Define the site in Dreamweaver

1. In Dreamweaver, open the Site Definition dialog box and select the Remote Info category. Set the Access drop-down 
menu to WebDAV. In the WebDAV Connection dialog box, append port 81 to the server name in the URL. Enter the 
username and password that allows you to log into the WebDAV site using IIS Basic authentication.

2.

If you are using a testing server for this Dreamweaver site, set the Access for the testing server to WebDAV and fill out 
the WebDAV Connection dialog box the same as above.Important: Note that the last field of the Testing Server dialog 
box, URL Prefix, should be set to the regular URL (do not add port 81).

Note: WebDAV is only available as a Testing Server Access choice if the Remote Info category uses WebDAV as the 
access choice.

Note: Configuring an Apache web server site to handle both browser traffic and WebDAV requests also requires a setup 
procedure which is a bit more painstaking. For more information about this Apache-specific process, please review 
mod_dav Installation and Configuration at www.webdav.org.

Watch the demonstration below of the steps to configure WebDAV in IIS for use with Dreamweaver.

Additional Information

For more information on IIS and WebDAV, please refer to:

* IIS help documentation. If IIS is installed on your machine, you can access the help files at: http://localhost/iisHelp. * 
WWW authentication methods with Microsoft Internet Information Server (TechNote 19078) * www.webdav.org * 
Troubleshooting WebDAV Connections (TechNote 15167) * Check In/Check Out may not work properly on WebDAV 
(TechNote 15537)
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Third party links

Although links to external websites are provided as a resource, the websites are not part of Macromedia. Please see 
Macromedia's policy regarding links to third party websites in the Legal Notices and Information section. Pages to 
external websites will open in a new browser window.

Configure Subversion with SSH | Dreamweaver CS4, CS5, 
CS5.5, CS6

Configure password-less SSH access
Before you configure Subversion or Dreamweaver for SVN+SSH, create an RSA key pair and configure the public key 
on the server. This public/private key pair is used to authenticate with the server, instead of storing and passing your 
password in plain text. (It is possible to configure SSH without using key pairs; however, Adobe doesn't recommend 
doing so because of the lack of security.)

To configure the RSA keys, create the private/public RSA key pair on the client computer,. Put the public key on the 
server, and then authorize the key on the server. Adobe also recommends testing the SSH connection afterward to 
verify that it is configured correctly.

Note: Access to the client computer (that is, the one from which you connect) is required to complete these steps. These 
steps also require access to the server (for example, directly or via SSH/FTP). On Windows, you need access to an SSH 
client (for example, TortoiseSVN) and an RSA key generator application (for example PuTTYgen). Mac OS comes with 
an SSH client and a key generator.

Create RSA keys on Mac OS
Complete these steps on the client computer:

1 Open a Terminal window.

2 Input the following command and then press Enter:ssh-keygen -t rsa 

3 When prompted to save the key, press Enter to select the default location.

4 (Optional) Type a passphrase for the key, then press Return/Enter. If you typed a passphrase, then type it again to 
confirm and press Return/Enter.

5 A confirmation message appears showing that the private and public keys were saved, including their save location 
and names.

6 To copy the public key to the server, input a command like the following, substituting the appropriate AccountName 
and ServerName:scp .ssh/id_rsa.pub AccountName@ServerName:~/temp_rsa.pub 

7 Connect to the server via SSH. Input a command like the following, substituting the appropriate AccountName and 
ServerName:ssh -l AccountName@ServerName 

8 Type your password when prompted to log in.Note: If you can log in without being prompted for your password, 
then your computer/login has already been authorized on the server. Skip the next section and go directly to Test 
the SSH connection , below.

9 Proceed to Configure the key on the server .

http://tortoisesvn.tigris.org/
http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html
http://helpx.adobe.com/dreamweaver/kb/#main_TestSSH
http://helpx.adobe.com/dreamweaver/kb/#main_TestSSH
http://helpx.adobe.com/dreamweaver/kb/#main_ConfigKey
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Create RSA keys on Windows
Complete these steps on the client computer:

1 Open your RSA key generator application (for example, PuTTYgen).

2 Generate an RSA key pair.

3 Save the private key and the public key. The remaining steps assume that you used the names private_key and 
public_key, respectively.

4 Put your public_key in ~/ using the name temp_rsa.pub on your server (for example, directly or via SSH/FTP).

5 Connect to the server via SSH. Assuming that you're using TortoiseSVN, input a command like the following, 
substituting the appropriate AccountName and ServerName:tortoiseplink AccountName@ServerName 

6 Type your password when prompted to log in.Note: If you can log in without being prompted for your password, 
then your computer/login has already been authorized on the server. Skip the next section and go directly to Test 
the SSH connection , below. 

7 Proceed to Configure the key on the server .

Configure the key on the server
On the server (for example, directly or via SSH/FTP), complete the following steps:

1 Verify that the .ssh folder exists on the server. Input the following command and then press Enter:ls -al ~/.ssh 

2 Do one of the following:

• If the results of the ls command indicate that the folder does not exist, then create it and then authorize the key 
on the server. Input the following commands, and press Enter after each one:mkdir ~/.ssh mv ~/temp_rsa.pub 
~/.ssh/authorized_keys 

• If the folder exists, then add the key to the server's authorization list. Input the following commands, and press 
Enter after each one:cat ~/.ssh/authorized_keys ~/temp_rsa.pub > temp_keys mv temp_keys 
~/.ssh/authorized_keys 

Test the SSH connection
Once you have completed the steps above, test to make sure you can connect to your server via SSH without being 
prompted for a password.

If you can connect but are still being prompted for a password, repeat the applicable server-side steps above. Consider 
starting over by creating a key pair on the client, and then repeating the remaining steps.

Note: When generating keys, be sure to specify the correct number of bits for your server. 2048 bits is fairly common. 
However, check with your web host if you are not certain.

If you still can't connect without being prompted for a password, see the OpenSSH FAQ or your web host for additional 
assistance.

Configure Subversion to use SSH
To configure Subversion to use SSH, add the path to your SSH client and your login information to the Subversion 
config file.

Note: This information assumes that Windows users are using TortoiseSVN, and that Mac users are using the Mac OS 
SSH client.

http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html
http://tortoisesvn.tigris.org/
http://helpx.adobe.com/dreamweaver/kb/#main_TestSSH
http://helpx.adobe.com/dreamweaver/kb/#main_TestSSH
http://helpx.adobe.com/dreamweaver/kb/#main_ConfigKey
http://www.openssh.com/faq.html
http://tortoisesvn.tigris.org/
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Locations of Subversion config file
To complete these steps, first open the Subversion configuration file for editing. The config file is in one of the following 
folders:

• Windows 7 and Vista C:\Users\Your User Name\AppData\Roaming\Subversion\config

• Windows XP C:\Documents and Settings\Your User Name\Application Data\Subversion\config

• Mac OS X /Users/Your User Name/.subversion/config

Configure Subversion for Mac OS
1 In the Terminal, locate the .subversion folder in your user folder as mentioned above. (Choose Go > Go To Folder 

in Finder, or use a command like ls -al ~/.subversion in Terminal.)

2 The path to SSH is usually "/usr/bin/ssh". If you are not sure, enter which ssh into Terminal.

3 Open the Subversion config file for editing with a text editor (for example, nano, pico, and so on). For example, enter 
nano ~/.subversion/config into Terminal.

4 Enter the following within the tunnels section (underneath [tunnels]):ssh = $SVN_SSH /usr/bin/sshNote: To use 
key-based authentication, add -i PathToKey. E.g. ssh = $SVN_SSH /usr/bin/ssh -i PathToKey Alternatively, you can 
enter the user name and password into this path by adding -l UserName -pw Password. This method is insecure and, 
therefore, Adobe doesn't recommend it.

5 Save and close the config file.

Configure Subversion for Windows
1 In Windows Explorer, locate the Subversion folder in your user folder as mentioned above.

2 Open the file into a plain-text editor, like Notepad.

3 In the [tunnels] section, specify where ssh client exists. This location depends on where you installed it. Open the 
file and enter the following within the tunnels section (underneath [tunnels]):ssh = $SVN_SSH 
C:/PathToSSHClient/tortoiseplink.exeNote: To use key-based authentication, add -i PathToKey. E.g. ssh = 
$SVN_SSH C:/PathToSSHClient/tortoiseplink.exe -i PathToKey Alternatively, you can enter the user name and 
password into this path by adding -l UserName -pw Password. This mthod is insecure and, therefore, Adobe doesn't 
recommend it.

4 Save and close the config file.

Set your site to use Subversion with SSH
1 Open your Dreamweaver site definition, and then choose Version Control from the category list.

2 Select Subversion from the Access menu.

3 Select SVN+SSH for the Protocol.

4 Enter your server address in the Server Address field.

5 Unless included with in your server address, enter your repository path in the Repository Path field.

6 Dreamweaver CS4 only:

a If your server does not use the default SSH port (22), then select Non Default and then enter the Server Port.

b Enter the Username and Password. Leave these fields empty for anonymous login.Note: The user name and 
password are NOT taken from Dreamweaver. The only way to send user is to enter AccountName@ServerName 
in the server name field.
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7 Press the Test button to test the connection.

8 Close the Site Definition dialog box.

9 In the Files panel, choose Local view or Repository view.

10 Right-click (Windows) or CTRL+click (Mac OS) on the root folder to display the menu.

11 Select Version Control > Get Latest Versions to update the file list.

More Help topics 
Subversion resources | Dreamweaver CS4, CS5

How to configure Dreamweaver to access a different FTP 
port
Port 21: the default setting Because most Web servers set aside Port 21 to receive connections from FTP clients, 
Dreamweaver is also configured to access Port 21 to upload files. 

Choosing another port for FTP access Sometimes, however, server administrators change the port setting of 21 to 
another port to prevent unauthorized FTP access. In those situations, Dreamweaver can be set to access a different port 
by adding the port number to the end of the FTP host name, as outlined below: 

Configuring Dreamweaver to access an FTP port other than Port 21

Additional informationFor more information about setting up a remote site, see the Site Management and 
Collaboration chapter in the manual, Using Dreamweaver. For Dreamweaver 3, see the Site Management chapter. 

For more information about FTP issues, consult Setting up Dreamweaver's FTP connection (TechNote 14787). 

1 Dreamweaver 2, 3 or 4: In the Site or Document window, choose Site 
> Define Sites. 

Dreamweaver 1: In the Site window, click the Remote Site pop-up 
menu and select Edit Sites. Then go to step 4. 

2  Click Edit (or New for a new site). 

3  Select the Remote Info (Dreamweaver 4) or Web Server Info 
(Dreamweaver 3) from the Category list. 

4  Add a colon and the port number to the end of the FTP host name in 
the FTP Host text box. The FTP host name will appear similarly to the 
following examples: 

www.myhost.com:80 

123.456.789.012:80 

http://kb2.adobe.com/cps/838/cpsid_83857.html
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_14787
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Computer restarts | Launch Dreamweaver CS5.5 | 
Windows XP

Issue
When you try to open Adobe Dreamweaver CS5.5 on Windows XP with Service Pack 2, your computer unexpectedly 
restarts. You sometimes see a STOP error screen, also known as a blue screen or BSOD, displaying a fatal system error.

Solution
Install Service Pack 3 for Windows XP. Visit the Microsoft Update website, or download the installer from the Microsoft 
Download Center, to install this update.

 

Compressed Flash MX SWF file properties are not 
recognized by Dreamweaver

Issue
Dreamweaver cannot determine URLs and movie properties such as size in SWF files published from Flash MX with 
"SWF Compression" turned on. As a result, movies default to a size of 32 x 32, and link management for URLs 
referenced in the movie is not available.

Note: This is no longer an issue in Dreamweaver MX. To download the trial of Dreamweaver MX, please see the 
Macromedia Dreamweaver MX product website.

Reason
 A new feature of Flash MX is the ability to compress SWF files. This option is turned on by default. However, when 
compressed SWF files are inserted into Dreamweaver, movie properties are not properly discovered and are 
inaccurately inserted into the HTML and reported in the Property Inspector. 

Solution
 Export SWF files from Flash MX without compression enabled. This option is available on the Flash tab of the Flash 
Publish settings dialog (File > Publish Settings) or in the Export Flash Player dialog box that appears when a movie is 
exported (File > Export Movie). 

Note: In Dreamweaver 4, users can see URLs referenced with a GoToURL action in a Flash movie by viewing the page 
containing the Flash movie in Site Map view. To see the URLs, do the following: 

1 Launch the Site Map view. 

• On Windows, choose Site > Site Map while in the Document Window, or Window > Site Map while in the Site 
Window. 

http://update.microsoft.com/
http://microsoft.com/download
http://microsoft.com/download
http://www.adobe.com/products/dreamweaver.html


93

Last updated 11/5/2015

• On Macintosh, choose Window > Site Map while in either the Document Window or the Site Window. 

1 The Site Map can only be shown if there is a home page defined for the site. You will only see the file containing the 
Flash movie if it is linked to from the defined home page.

2 Make sure that you can view both dependent and hidden files. 

• On Windows, choose View > Show Files Marked as Hidden and View > Show Dependent Files while in the Site 
Window. A checkmark indicates these options have been set. 

• On Macintosh, choose Site > Site Map View > Show Files Marked as Hidden, and Site > Site Map View > Show 
Dependent Files while in the Site Window. A checkmark indicates these options have been set. 

Color Picker returns incorrect sample color | 
Dreamweaver CS4 | Mac OS 10.7 Lion

Issue
When you use the Color Picker in Adobe Dreamweaver CS4 to sample a color, the color returned is different than the 
color you tried to sample. You are using Mac OS 10.7 Lion.

Solution
Use another method to choose a color, such as by entering the hexadecimal or RGB value directly.

Additional information
This issue is a known issue with Mac OS 10.7. This issue does not occur in Dreamweaver CS5 or CS5.5.

Code view blank | Documents open in BBEdit, 
Dreamweaver CS5 | Mac OS

Issue
When you have two or more documents open in Dreamweaver CS5 and BBEdit simultaneously, the Code view in 
Dreamweaver is blank.

Solutions

Solution 1: Upgrade to Dreamweaver CS5.5.
This issue does not occur in Dreamweaver CS5.5.
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Solution 2: Reload the document.
1 Choose Modify > Page Properties (or press CMD+J).

2 Select the Title/Encoding section on the left.

3 Click the Reload button, which appears to the right of the Encoding option.

Solution 3: Close and then reopen the document.
Close the document. Then reopen it using File > Open, or using another method such as dragging the document to the 
Dreamweaver icon in the Dock.

Changes to ASP Command Variables in Dreamweaver 
8.0.2
In the Dreamweaver 8.0.2 Updater, changes were made to the ASP code Dreamweaver generates, in order to prevent 
SQL injection attacks. One specific change that might be confusing are the changes to the ASP Command server 
behaviors. When you fill out the Command dialog box, Dreamweaver 8.0.2 now asks you to provide the Type and Size 
for the variables without any hinting or drop-down menus, so you have to know what to type in these text fields. Screen 
shots below show the difference between the dialog boxes in Dreamweaver 8.0.2 and Dreamweaver MX 2004 7.0.1. 
Notice the extra columns for Type and Size in the 8.0.2 Variables section.

Dreamweaver 8.0.2 ASP VBScript Insert Command

Dreamweaver MX 2004 7.0.1 ASP VBScript Insert Command

Why do you need to specify Type and Size now?

 To prevent SQL injection attacks, Dreamweaver changed from using a simple Insert SQL statement to using prepared 
statements. Prepared statements are more secure but they require more information, like Type and Size parameters. 

What do you enter in the Size field?

 To get the Size value, you can use the Databases panel in Dreamweaver. Find your database in the Databases panel and 
expand it. Then find the table you are working with and expand it. You should see the sizes listed for your fields. For 
example, it might say: ADDRESS (WChar 50). In this example, 50 is the size. You can also find the size in your database 
application. 

Note: Numeric, boolean and date/time data types always use -1 as the size, as shown in the table below. 

What do you enter in the Type field?

The table below shows the different Types that can be used. In the table, Access is Microsoft Access, and MS SQL stands 
for Microsoft SQL Server. 

Commands (Insert, Update, Delete)
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In the Dreamweaver Command dialog box, you need to enter the word in the "Value in Dreamweaver" column above. 
Alternatively, you can type the numeric value in Code view. If you have a data type that is not covered in the table above, 
you can create a sample page using the Record Insertion Form Wizard or Record Update Form Wizard, and 
Dreamweaver will write the code for the Type and Size values for you, and you can then plug those values into the 
Command. Or, if you are inserting/updating a field that is not covered by the TechNote (e.g. from a different database 
like Oracle) you can look for the corresponding ADO datatype for that field (in the database reference manuals) and 
use that (ADO constant) in the Type column of the Variables grid of the Command.

Example using MS Access and an Insert Command

 The 8.0.2 screen shot above shows how to fill out the Command dialog box for an Insert command using Microsoft 
Access. This example uses the Comments table from the Cafe Townsend sample database that's included with 
Dreamweaver 8. This table has the following MS Access data types: 

• Comment_ID ; Data Type: AutoNumber; field size: Long Integer 

• Last Name ; Data Type: Text; Field Size: 50 

• Submit Date ; Data Type: Date/Time 

• Comments ; Data Type: Memo 

• Answered ; Data Type: Yes/No 

Here is the resulting code: 

 Value Constant Value in Dreamweaver Size Database data type 

5 adDouble Double -1 Numeric (Access, MS SQL, 
MySQL) 

5 adBoolean Double -1 Boolean, Yes/No (Access, 
MS SQL, MySQL) 

135 adDBTimeStamp DBTimeStamp -1 Date/Time (Access, SQL 
Server, MySQL) 

201 adLongVarChar LongVarChar check Databases panel all other types of text 
fields, including the 
MySQL text data types 
char, varchar and longtext 

202 adVarWChar VarWChar check Databases panel Text (Access) or nvarchar, 
nchar (MS SQL) 

203 adLongVarWChar LongVarWChar 1073741823 Memo (Access) or ntext 
(MS SQL) or: these fields 
supports large amounts of 
text. 
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<% Set Command1 = Server.CreateObject ("ADODB.Command") Command1.ActiveConnection = 
MM_cafetownsend_STRING Command1.CommandText = "INSERT INTO COMMENTS (COMMENT_ID, LAST_NAME, 
SUBMIT_DATE, COMMENTS, ANSWERED)   

 
VALUES (?, ?, ?, ?, ?) " Command1.Parameters.Append Command1.CreateParameter("varCommentID", 
5, 1, -1, MM_IIF 

 
(Request.QueryString("txtCommentID"), Request.QueryString("txtCommentID"), 
Command1__varCommentID &amp; "")) Command1.Parameters.Append 
Command1.CreateParameter("varLastName", 202, 1, 50, MM_IIF 

 
(Request.QueryString("txtLastName"), Request.QueryString("txtLastName"), 
Command1__varLastName &amp; "")) Command1.Parameters.Append 
Command1.CreateParameter("varSubmitDate", 135, 1, -1, MM_IIF 

 
(Request.QueryString("txtSubmitDate"), Request.QueryString("txtSubmitDate"), 
Command1__varSubmitDate &amp; "")) Command1.Parameters.Append 
Command1.CreateParameter("varComments", 203, 1, 1073741823, MM_IIF 

 
(Request.QueryString("txtComments"), Request.QueryString("txtComments"), 
Command1__varComments &amp; "")) Command1.Parameters.Append 
Command1.CreateParameter("varAnswered", 5, 1, -1, MM_IIF 

 
(Request.QueryString("cbxAnswered"), Request.QueryString("cbxAnswered"), Command1

Example using Microsoft SQL Server and an Insert Command

 The 8.0.2 screen shot below shows how to fill out the Command dialog box for an Insert command using Microsoft 
SQL Server. This example uses the Employees table from the Northwind sample database that's included with SQL 
Server. This table has the following SQL Server data types: 

• LastName ; Data Type: nvarchar; size: 20 

• FirstName ; Data Type: nvarchar; size: 10 

• BirthDate ; Data Type: datetime 

• Notes ; Data Type: ntext; size: 16 

• ReportsTo ; Data Type: int; size: 4 

Here is the resulting code: 
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<% Set Command1 = Server.CreateObject ("ADODB.Command") Command1.ActiveConnection = 
MM_sqlServ_ts2000adv_northwind_STRING Command1.CommandText = "INSERT INTO dbo.Employees 
(LastName, FirstName, BirthDate, Notes, ReportsTo)   

 
VALUES (?, ?, ?, ?, ?) " Command1.Parameters.Append Command1.CreateParameter("varLastName", 
202, 1, 20, MM_IIF 

 
(Request.QueryString("txtLastName"), Request.QueryString("txtLastName"), 
Command1__varLastName &amp; "")) Command1.Parameters.Append 
Command1.CreateParameter("varFirstName", 202, 1, 10, MM_IIF 

 
(Request.QueryString("txtFirstName"), Request.QueryString("txtFirstName"), 
Command1__varFirstName &amp; "")) Command1.Parameters.Append 
Command1.CreateParameter("varBirthDate", 135, 1, -1, MM_IIF 

 
(Request.QueryString("txtBirthDate"), Request.QueryString("txtBirthDate"), 
Command1__varBirthDate &amp; "")) Command1.Parameters.Append 
Command1.CreateParameter("varNotes", 203, 1, 1073741823, MM_IIF 

 
(Request.QueryString("txtNotes"), Request.QueryString("txtNotes"), Command1__varNotes &amp; 
"")) Command1.Parameters.Append Command1.CreateParameter("varReportsTo", 5, 1, -1, MM_IIF 

 
(Request.QueryString("txtReportsTo"), Request.QueryString("txtReportsTo"), Command1

Additional Information

For more informationabout the changes in Dreamweaver 8.0.2, see Protecting ASP VBScript server behaviors from 
SQL injection vulnerability (TechNote 57ae79b2).

For more information on Types, see MSDN ADO 2.8 API Reference ADO Enumerated Constants - DataTypeEnum 
and http://www.carlprothman.net/Default.aspx?tabid=97.

The captcha image is not generated on the page 
(Dreamweaver Developer Toolbox)

Issue
 When previewing a page with the Capthca wizard applied, instead of the image I get an error message: 

Cannot write in captcha folder 

Reason
 This happens because the temporary folder where the captcha images are stored until display does not allow the user 
running the web server to write files to 

Solution
 To solve this problem you mustgrantwritepermissionstothe user as which the web server is running for the 
<site_root>\common\lib\captcha\temp folder. This will allow the creation and storage of the temporary captcha 
images. 

http://www.carlprothman.net/Default.aspx?tabid=97
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Can't specify versionCode | Android mobile app | 
Dreamweaver CS5.5

Issue
When you try to update an Android app using Adobe Dreamweaver CS5.5, you can specify the android:versionName 
property, but not the android:versionCode property. The android:versionCode property in an Android app created by 
Dreamweaver CS5.5 is always set to 1.

Solution
1 After changing your application in Dreamweaver, build it by choosing Site > Mobile Applications > Build > Android.

2 After the build process completes, quit Dreamweaver.

3 In the Finder (Mac OS) or Windows Explorer (Windows), navigate to and open the build folder (for example, 
com.company.appname_Android).

4 Delete or rename the bin folder.

5 Open the AndroidManifest.xml file in a text editor, such as TextEdit or Notepad.

6 Locate the android:versionCode property in the <manifest> tag (usually on line 3).

7 Replace the "1" with the appropriate whole number. (For example, if it is the first update to the app, then replace with 
"2." If it is the second update, then replace with "3," and so on.)

8 Save the change made to the AndroidManifest.xml file.

9 Open Dreamweaver.

10 Build the application again by choosing Site > Mobile Applications > Build > Android. The updated manifest is used 
to create the .apk.

Note: The mobile application you build with Dreamweaver is an application for debugging purposes only. To upload 
the app to the Android Market, take the additional step of signing it as a release app outside Dreamweaver. For more 
information about signing Android applications and uploading them to the Market, see the Android documentation.

Additional information
To submit updates to Android apps already on the Market, increment the android:VersionCode property. For more 
information, see Versioning Your Applications in the Android Developers documentation.

More Help topics 
Packaging web applications as mobile apps using Dreamweaver CS5.5

Package web applications as native mobile applications (CS5.5)

http://developer.android.com/guide/publishing/app-signing.html
http://developer.android.com/guide/publishing/versioning.html#appversioning
http://www.adobe.com/devnet/dreamweaver/articles/packaging-web-applications-as-mobile-apps.html
http://help.adobe.com/en_US/dreamweaver/cs/using/WSeffff8bffc80208478c8d43312e240fe0ad-8000.html
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Can't select some items in Site Setup | Dreamweaver CS5 
| Windows 7

Issue
When you open the Site Setup dialog in Adobe Dreamweaver CS5 on Windows 7, you can't select the Site, Servers, 
Version Control, and Advanced Settings categories. Or, you can't type anything into the Site Name or Local Site Folder 
text fields.

Solution
Do one of the following:

Solution 1: Disable DPI scaling for Dreamweaver.
1 Close Dreamweaver.

2 In Windows Explorer, navigate to C:\Program Files (x86)\Adobe\Adobe Dreamweaver CS5

3 Right-click the Dreamweaver.exe file and select Properties.

4 Select the Compatibility tab at the top of the Properties dialog box.

5 Click to enable the Disable Display Scaling On High DPI Settings checkbox.

6 Click OK.

Solution 2: Change the Windows DPI scaling setting to the default.
Change the DPI setting to the default of Smaller - 100%. For instructions, see Make the text on your screen larger or 
smaller in the Windows 7 Help: http://windows.microsoft.com/en-US/windows7/Make-the-text-on-your-screen-
larger-or-smaller.

Additional Information
This issue can occur when you create a site or edit an existing site after using the Windows DPI scaling setting to 
increase font sizes onscreen.

Can't launch Dreamweaver CS5 | Mac OS

Issue
When you try to launch Adobe Dreamweaver CS5 on Mac OS, the application doesn't start. One of the following 
occurs:

• The Dreamweaver menu appears in the menu bar, but other menus, such as File, Edit, and View, do not appear.

• The application does not appear on the screen at all.

http://windows.microsoft.com/en-US/windows7/Make-the-text-on-your-screen-larger-or-smaller
http://windows.microsoft.com/en-US/windows7/Make-the-text-on-your-screen-larger-or-smaller
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Solution
Install the Dreamweaver 11.0.4 update:

1 Download the Dreamweaver 11.0.4 
update:http://download.macromedia.com/pub/dreamweaver/updates/cs5/11_0_4/mac/AdobeDreamweaver-11-0-
All-Update.dmg 

2 If the AdobeDreamweaver-11.0-All-Update disk image automatically opens when you have finished downloading 
the file, then go to Step 3. Otherwise, double-click the file you downloaded to open the disk image.

3 Double-click the AdobeDreamweaver-11.0-All-Update folder to open it.

4 Double-click the AdobePatchInstaller application, and then follow the onscreen instructions.

Important: After installing this update, restart your computer.

Additional information
For additional launch troubleshooting steps, see Troubleshoot launch issues or problems -- Adobe Creative Suite 5 
products (cpsid_83223).

Can''t install Dreamweaver 8.0.2 Updater | InstallShield 
wizard interrupted

Issue
Installing the Dreamweaver 8.0.2 Updater fails on certain Windows systems. The 8.0.2 Updater installer starts, but then 
stops with the following InstallShield wizard error message:

"The wizard was interrupted before Macromedia Dreamweaver 8.0.2 Updater could be completely installed. Your 
system has not been modified. To complete installation at another time, please run setup again."

Then a second error message sometimes appears:

"The exception unknown software exception (0xc0000005) occurred in the application at location 0x009441902. Click 
on OK to terminate the program Click on CANCEL to debug the program."

Note: It's possible that you don't get the error messages above when installing the Dreamweaver 8.0.2 Updater. 
However, if after updating, the Dreamweaver version still says 8.0 or 8.0.1, you could have previously canceled an 
updater installer. To resolve this issue, uninstall and then reinstall Dreamweaver 8 or Studio 8. (Ref. 211853)

Solution
There is an InstallShield .exe wrapper around the actual Dreamweaver 8.0.2 Updater installer which is an MSP file. If 
you have trouble with the standard Dreamweaver 8.0.2 Updater installer and its InstallShield wrapper, download the 
unwrapped MSP file for Dreamweaver 8.0.2 and run that. Once you download the MSP file to your hard drive, double-
click it and see if Dreamweaver 8.0.2 installs successfully.

Note: After you install the Dreamweaver 8.0.2 Updater, verify that the updater successfully installed. Some users think 
they have installed 8.0.2, when in fact the updater installation didn't take. In Dreamweaver, go to Help > About 
Dreamweaver > and click the scrolling text to reveal the version number. It should say Dreamweaver 8.0.2. If it still says 
Dreamweaver 8.0 or 8.0.1, uninstall and then reinstall Dreamweaver 8 or Studio 8 to resolve the issue.

http://download.macromedia.com/pub/dreamweaver/updates/cs5/11_0_4/mac/AdobeDreamweaver-11-0-All-Update.dmg
http://download.macromedia.com/pub/dreamweaver/updates/cs5/11_0_4/mac/AdobeDreamweaver-11-0-All-Update.dmg
http://kb2.adobe.com/cps/832/cpsid_83223.html
http://kb2.adobe.com/cps/832/cpsid_83223.html
http://www.adobe.com/support/dreamweaver/ts/documents/kb400150/DW802_unwrapped.zip
http://www.adobe.com/support/dreamweaver/ts/documents/kb400150/DW802_unwrapped.zip
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Additional information
Some Windows systems have a conflict with the InstallShield install wizard in Dreamweaver 8.0.2.

 

Can't change keyboard shortcuts for zoom | 
Dreamweaver CS5.5

Issue
When you change the keyboard shortcut for one or more items in the View > Magnification menu, the change isn't 
reflected in the menu. You can't use the custom keyboard shortcuts.

Solution
Download and install the Fix CS5.5 Magnification Shortcuts extension.

1 Right-click (or Control-click on Mac OS) the following link: FixCS55MagShortcuts2.mxp 

2 Choose the option to save a linked file. (Depending on which web browser you use, this option can be called Save 
Link As, Download Linked File As, Save Target As, or something similar.)

3 Follow your web browser's instructions to download the file to a location of your choice.

4 After the download completes, double-click FixCS55MagShortcuts2.mxp. Adobe Extension Manager CS5.5 opens 
and installs the extension.

5 Restart Dreamweaver. You can now customize these keyboard shortcuts.

Additional information
If you disable or uninstall the Fix CS5.5 Magnification Shortcuts extension in the future, follow these instructions 
before reinstalling it:

1 Open Extension Manager CS5.5.

2 Disable (deselect) any extensions that are installed for Dreamweaver CS5.5.

3 Delete the Menus folder from your Dreamweaver user Configuration folder:

• Mac OS: /Users/Your User Name/Library/Application Support/Adobe/Dreamweaver 
CS5.5/en_US/Configuration/Menus

• Windows 7, Vista: C:\Users\Your User Name\AppData\Roaming\Adobe\Dreamweaver 
CS5.5\en_US\Configuration\Menus

• Windows XP: C:\Documents and Settings\Your User Name\Application Data\Adobe\Adobe\Dreamweaver 
CS5.5\en_US\Configuration\Menus 

? Open Extension Manager CS5.5 and reenable (select) the extensions listed for Dreamweaver CS5.5.

http://helpx.adobe.com/dreamweaver/kb//content/dam/kb/en/914/cpsid_91401/attachments/FixCS55MagShortcuts2.mxp
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More Help topics 
Customize keyboard shortcuts

Add and manage extensions in Dreamwweaver

Cannot create queries using Query Builder 
(Dreamweaver Developer Toolbox)

Issue
 When I try to create my first query with Query Builder I get an error message: There have been some problems 
connection to your database. [...] Please see the manual for possible reasons and solutions.

Reason
 This error occurs because one of the following: 

1 The database connection does not exist, or an error occurred connecting to the database.

2 The user which connects to the database does not have permissions to create new tables.

3 The user which connects to the database does not have permissions to insert data into a table.

4 You have a ColdFusion data source configured to use a MySQL database through a JDBC connector. The connector 
version is 3.0.6 or higher. Starting with the 3.0.6 version the connector no longer allows creating tables or altering 
their contents.

Solution
 To solve this problem, try one of the following: 

• First make sure that the database connection exists and the web server can actually connect to the database. 

• Check that the user name used in the database connection has permissions to create tables and insert data into them. 
If it does not have them, consult your database server documentation to find out how to grant these permissions. 

• If in case four, you must use a different type of connection, or a JDBC prior to version 3.0.6. 

Assigning behaviors to an image map
 In Dreamweaver 3, assigning a behavior to an image map is straightforward: select the appropriate hotspot and assign 
a new behavior with the plus key of the Behaviors inspector. 

However, in Dreamweaver 2, the procedure requires using a dummy image to generate the JavaScript and editing the 
HTML source to reassign the code. The instructions below outline this procedure step by step. Once again, this only 
applies to Dreamweaver 2. 

http://help.adobe.com/en_US/dreamweaver/cs/using/WScbb6b82af5544594822510a94ae8d65-7763a.html
http://help.adobe.com/en_US/dreamweaver/cs/using/WScbb6b82af5544594822510a94ae8d65-7761a.html
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To edit the HTML source code in Dreamweaver 2, do the following:

1 Insert an image in the Document window. This image will serve as a dummy in the document and will be deleted 
after completion of the task.

2 Assign a null link to the image by selecting it and entering a pound (#) sign into the Link field of the Property 
inspector.

3 Select the anchor tag of this dummy image and assign the desired behavior to it. (A quick way to select the anchor 
tag of an image is to select the image then click the <a> tag displayed in the bottom left corner of the Document 
window.)

4 With the anchor tag of the dummy image selected, open the HTML inspector (F10).

5 Find the behavorial JavaScript within the highlighted HTML. The code below is an example of the JavaScript section 
in a sample document.

<a href="#" > 
 

<img href="/support/dreamweaver/ts/documents/assets/Creation.JPG"     name="creation

6 Copy the JavaScript that represents the mouse events. In this example, copy the red color code. This Javascript 
activates the Swap Image behavior using the onMouseOver event.

7 Locate the map tag in the HTML source code that is referenced by the "usemap" attribute of the final destination 
image. You can find the "usemap" attribute within the destination image tag.

<img href="/support/dreamweaver/ts/documents/assets/myImage.JPG"   
 

   ></img> 

8 Paste the code inside the area tag for this image map.

<map name="myName"><area shape="rect" coords="5,4,153,43" href="#"        tar ></map> 

9 Delete the dummy image created in step 1.

Android app doesn't open in emulator | Build And 
Emulate | Dreamweaver CS5.5

Issue
When you try to Build and Emulate an Android app in Adobe Dreamweaver CS5.5, the app is successfully built and the 
emulator opens. However, the app is never installed or opened in the emulator.

Solution
Do the following for each app, as needed:

1 If you have not already built the project, then choose Site > Mobile Applications > Build > Android.

2 After the build process completes, quit Dreamweaver.

3 In the Finder (Mac OS) or Windows Explorer (Windows), navigate to and open the build folder (for example, 
com.company.appname_Android).
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4 Delete or rename the bin folder.

5 Open the build.xml file in a text editor, such as TextEdit or Notepad.

6 Locate the import tag (usually at the end of the file). It looks like the following:<import 
file="${sdk.dir}/tools/ant/build.xml" /> 

7 Add an as attribute with a value of imported to the import tag. The import tag now looks like the following:<import 
file="${sdk.dir}/tools/ant/build.xml" as="imported" /> 

8 On the next line after the modified import tag, add the following new tag:<target name="install" depends="-set-
debug-files,imported.install" /> 

9 Save the changes made to the build.xml file.

The next time you choose Site > Mobile Applications > Build And Emulate > Android, the app should successfully run 
in the emulator.

Additional information
Apache Ant, included with the Android SDK, was changed in recent builds of the SDK and now requires additional 
parameters.

More Help topics 
Packaging web applications as mobile apps using Dreamweaver CS5.5

Package web applications as native mobile applications (CS5.5)

Active content not displayed in browser after converting 
page in Dreamweaver 8.0.2

Issue
In Dreamweaver 8.0.2, after creating a new page with active content (for example, Flash Player content) or after 
converting an existing page with active content, the active content does not display when the page is uploaded to the 
server and viewed in a web browser. This problem is page-specific (browse to the sample "fixed" page on the Developer 
Center and verify that it works as expected, with no gray border around the Flash movie).

(Ref. 20777)

Reason
The most likely reason the active content isn't being displayed is because the Scripts folder (and the JavaScript files 
inside) automatically created at the root level of your site by Dreamweaver 8.0.2 hasn't been uploaded to the server. For 
more information on the Scripts folder and the accompanying JavaScript files, see Converting Active Content with the 
Dreamweaver 8.0.2 Updater (TechNote 2f98fbe7).

http://www.adobe.com/devnet/dreamweaver/articles/packaging-web-applications-as-mobile-apps.html
http://help.adobe.com/en_US/dreamweaver/cs/using/WSeffff8bffc80208478c8d43312e240fe0ad-8000.html
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Solution
Upload the Scripts folder to the server, as described in both the Dreamweaver help system and in Converting Active 
Content with the Dreamweaver 8.0.2 Updater (TechNote 2f98fbe7):

"Dreamweaver creates this external file (AC_RunActiveContent.js), and places it in a new folder (called Scripts, placed 
at the root of your site) when you save the updated file. It is extremely important that you upload the 
AC_RunActiveContent.js file when you upload the updated page, either manually or by clicking Yes in the Dependent 
Files dialog box."

Additional Information
Other causes have similar symptoms. If this TechNote does not resolve your issue, check the following TechNotes:

• Active content JavaScript file not created for existing files that already have active content reference (TechNote 
35ae3721)

• Adobe active content JavaScript fix fails in some installations of Internet Explorer (TechNote 4f91f9b8)
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