Acrobat DC: Plug-in compatibility issue

When Adobe Acrobat DC is installed using the Adobe Creative Cloud Desktop application, it removes Acrobat XI along with all plug-ins. When the 32-bit third-party plug-ins need to be reinstalled to the Acrobat DC folder, the install location is unknown, and the 32-bit plug-ins stop working on Mac OS.

Solution: Acquire 64-bit plug-in versions and copy them to the appropriate folder

Acrobat DC is now a 64-bit application on Mac OS. Therefore, for its plug-ins, it also uses 64-bit architecture. All the plug-ins that ship along with Acrobat DC are built for 64-bit architecture. However, third-party plug-ins built using the 32-bit architecture may not be compatible with Acrobat DC. Contact the respective plug-in developer and obtain a 64-bit version of the plug-in.

Note: This issue is specific to Mac OS only, and does not occur on Windows. On Windows, the existing third-party plug-ins can continue to be installed to the Adobe\Acrobat DC\Acrobat\plug_ins subfolder of the installation location for the subscription license and Adobe\Acrobat 2015\Acrobat\plug_ins for the Classic (Perpetual) license.

Also, on Mac OS, due to certain changes to Mac OS Gatekeeper (OS 10.9.5 and higher), Adobe plug-ins are now “V2 signed,” and therefore, no plug-ins can be installed in Acrobat’s installation location (/Applications/Adobe Acrobat DC).

Once you have the 64-bit third-party plug-ins, follow the steps below to copy them into the appropriate folder.

  1. If you have an Acrobat DC subscription, open Finder and go to the following location:

    • To install plug-ins for the current user: ~/Library/Application Support/Adobe/Acrobat/DC/
    • To install plug-ins for all users: /Library/Application Support/Adobe/Acrobat/DC/

    If you have Acrobat DC Classic/Perpetual license, open Finder and go to the following location:

    • To install plug-ins for the current user: ~/Library/Application Support/Adobe/Acrobat/2015/
    • To install plug-ins for all users: /Library/Application Support/Adobe/Acrobat/2015/
  2. Open the Plug-ins folder if present at the location. If it's not present, create one with the name Plug-ins.

  3. Copy your 64-bit plug-ins into the Plug-ins folder.

  4. Quit Acrobat if it's running, and relaunch Acrobat.

Note:

If a plug-in is installed both for "current user" and "all users", the plug-in installed for "all users"  takes precedence.

If your plug-ins still don't work as expected, you can always go back to Acrobat XI.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy