System requirements

Acrobat X and Adobe Reader X support viewing PDF files inside the Safari browser on Mac OS X. Acrobat X and Reader X do not support any other browser, such as Firefox or Opera. For more information about system requirements, click these links for your product: Acrobat X Pro, Acrobat X Standard, Adobe Reader X.

Adobe PDFViewer for Mac OS X requires the following system requirements:

  • Safari 4 for Mac OS X 10.5.8 and Mac OS X 10.6.4
  • Safari 5 for Mac OS 10.6.4
  • Acrobat and Reader via AdobePDFViewer Safari plug-in are 32/64-bit (64-bit available in Safari 10.6)

Note: If you don't have Acrobat or Reader, or haven't installed the PDFViewer plug-in, then Safari shows PDF files using the Mac OS X native PDF support. Support for many Adobe PDF workflows (such as the Collaboration feature or many Forms and Security features) is unavailable.

Configuring Acrobat to display PDF files in Safari

The AdobePDFViewer plug-in is used to display PDF files in Safari using Acrobat and Reader. This plug-in is installed as part of the Acrobat X or Reader X installation. The location of this plug-in is:

 /Library/Internet Plug-ins/AdobePDFViewer.plugin

Known issues

Reader's Preferences > Internet > Display PDF in Browser is always dimmed

  • To disable Safari integration, delete the AdobePDFViewer.plugin from  /Library/Internet Plug-ins 
  • To reenable Safari integration, rerun the installer over the current installation. Start the Acrobat/Reader X installer from the original media, and then follow the onscreen prompts to complete the installation.

Uninstalling an older version of Acrobat or Reader after Acrobat X or Reader X has been installed removes the AdobePDFViewer plug-in

If Acrobat X or Reader X is installed alongside an older version of Acrobat or Reader, removing the older version removes the AdobePDFViewer plug-in.

To reenable Safari integration, rerun the installer over the current installation. Start the Acrobat/Reader X installer from the original media, and then follow the onscreen prompts to complete the installation.

Older versions of the AdobePDFViewer plugin can overwrite newer versions of the plug-in

Having multiple versions of Acrobat or Reader installed on the same system can cause plug-in conflicts. For example, suppose you have both Acrobat 9 and Acrobat X on your system and Acrobat 9 gets updated. In this case, the Acrobat 9 version of the AdobePDFViewer plug-in can overwrite the Acrobat X version of the plug-in. To correct the issue, follow these steps:

  1. Remove the previous version of Acrobat or Reader.
  2. Reinstall Acrobat X or Reader X from the original media.  

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy