Quickly pinpoint changes by comparing two versions of a PDF file. Acrobat DC analyzes the files and presents a report detailing differences between the documents.

Note:

If you have Acrobat DC Continuous (subscription), see Compare files below. If you have Acrobat DC Classic (desktop only), see Compare files in Acrobat DC Classic below.

Compare files

Available in: Acrobat DC Continuous (subscription)

With the all-new Compare Files tool, you can now quickly and accurately detect differences between two versions of a PDF file.

  1. Choose Tools > Compare Files.

    Select files to compare
  2. Click Select File at left to choose the older file version you want to compare. Click Select File at right to choose the newer file version you want to compare.

  3. Click Change File and then choose an already opened file or browse to select your desired file. Click the Swap arrows icon between the thumbnails to swap the position of the old and new files.

    Select files to compare
  4. To ignore differences between the graphic elements, select the Compare Text Only checkbox.

  5. You can modify settings by clicking the Settings gear icon, which opens the following dialog box.

    Settings for Compare Files
    1. You can limit the comparison to a portion of the documents by entering the page numbers in the Old File and New File fields.
    2. Under Document Description, select the type of documents that you are comparing, or select Autodetect to let Acrobat decide.
      Tip: If your document content can reflow across pages, select Reports, spreadsheets, magazines layouts; otherwise select Presentation Decks. For comparing scanned files, select Scanned documents, drawings or illustrations.
    3. To apply your changes, click OK.
  6. Click Compare.

    Acrobat DC displays the results in a new document. The first page provides an easy-to-scan summary of all file differences.

    Compare results
    a – Comparison timestamp, b – Compared files information, c – Total changes, d – Distribution of changes, e – Formatting changes, f – The hyperlink to take you to the first change

  7. Click the Go to First Change button to begin reviewing each difference in detail.

  8. Select how you want to review the differences.

    • Side-by-side view: Use the Side-by-Side (Ctrl+\) view to see a parallel view of results where the differences are shared in highlighted bands. The old file is displayed on the left and the new file is displayed on the right, with the changes highlighted in each band connecting across the files for easier review. Click a band to display a pop-up note detailing all of the changes within the band. You can also click the highlighted content to open the pop-up.
    Side-by-Side view

    Right-click a change or its pop-up and set an appropriate status for the change.

    Set status for the change
    • Single page view: Use the Old File or New File button (Ctrl+/) on the toolbar to see the individual file with all changes highlighted.
    Single page view
  9. To review all the changes:

    • Use the Filter and Show options.

    By default, annotations, formatting, and background differences are turned off. To see these changes in the report, select these options from the Filter menu in the toolbar. You can also filter comparison results by selecting specific types of changes in the Filter menu. From the Show menu, you can select an option to show or hide legends, row highlights, or results.

    Filter options
    Show options

    • Use the Previous Change (Ctrl+.) or Next Change (Ctrl+,) button to go through the changes one-by-one.
    Navigation buttons

    The Previous Change and the Next Change button are also available in the pop-up notes detailing the changes.

    Navigation buttons in the pop-up
    • Use the right pane. Click the triangle at the center of the right Acrobat window to open the right pane. This pane lists all the changes visible in the Compare Results report. Use the search text box to search for any specific change.
    List of changes highlighted in the Right Hand Pane
  10. Save the Compare Results file (File > Save). Click the cross button at the top right of the toolbar to close the Compare Files tools.

You can print a comparison report along with the summary of changes.

  • Click the Print  icon in the toolbar, and then click Print in the Print dialog box.

Compare files in Acrobat DC Classic

Available in: Acrobat DC Classic (desktop only)

You can use the Compare Documents tool to find differences between two versions of PDF files. After comparing two files, Acrobat DC provides a detailed report of every change, including text, fonts, images, and even the order of the pages.

  1. Choose Tools > Compare Documents.

  2. Choose the documents to compare. You can limit the comparison to a portion of the documents by entering the page numbers in the First and Last page fields under each filename.

  3. Under Document Description, select the type of documents that you are comparing. To ignore
    differences between the graphic elements, select Compare Text Only. Click OK.

    Acrobat DC displays the results in a new document. The first page summarizes the file comparison results.

    Document compare summary
    a - Differences between the files, b - Files compared, c - Get Started hyperlink to take you to the first difference, d - Moved or deleted pages, e - Key to the symbols used within the report

  4. Select how to review the differences.

    1. Use the Compare panel on the left side (default).
      • Page through the thumbnails in the Compare panel. An icon below a thumbnail indicates a difference. A green arrow signifies moved or deleted pages. A purple arrow designates a change on the page.
      • Return to the first page and click Get Started to go to the first difference.
      • Changes are highlighted on the main screen. Hover your mouse over the highlight to see the details. The color legend in the upper right provides a guide.
    2. Use side-by-side view.
      • In the Compare panel on the left, click the options icon, and select Show Documents Side
        By Side
        .
      • Changes are highlighted on the main screen. Hover your mouse over the highlight to see
        the details. The color legend in the upper right provides a guide.
    Compare options in Acrobat
    The Compare options provide you tools to customize the document comparison.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy