AEM forms provides the complete source code of the AEM forms app app. The source contains all components to build a custom AEM forms app. The source code archive, adobe-lc-mobileworkspace-src.zip, is installed along with AEM forms JEE. The default location of the adobe-lc-mobileworkspace-src.zip is [AEM_forms_root]\sdk\LC Mobile Workspace.  

The following image displays the extracted contents of the adobe-lc-mobileworkspace-src.zip.

The following image displays the directory structure of the android folder in the src folder.

Build standard AEM forms app

  1. Perform the following steps to set up a project in Eclipse and provide a signing identity:

    Log in to a machine that has Eclipse and ADT installed and configured.

  2. Copy the adobe-lc-mobileworkspace-src.zip archive from [AEM_forms_root]/sdk/LC Mobile Workspace to:

    For MAC users: [User_Home]/Projects

    For Windows users: %HOMEPATH%\Projects

  3. Extract the archive in the following directory:

    For MAC users: [User_Home]/Projects/[your-project]

    For Windows users: %HOMEPATH%\Projects\[your-project]

  4. Launch Eclipse that comes with ADT bundle.

    Default location:

    For MAC users: Default location is Applications/ADT/eclipse/Eclipse. If the ADT is installed in any other location, update the local.properties file present in the [User_Home]/Projects/[your-project]/src/android folder and point the sdk.dir variable to ADT SDK location on your desktop.

    For Windows users: Update the local.properties file present in the %HOMEPATH%\Projects\[your-project]\src\android folder and point the sdk.dir variable to ADT SDK location on your desktop.

  5. On the File menu, choose the Import option.

    The Import dialog is displayed.

  6. In the Import dialog, choose Existing Android Code into Workspace in the Android folder and click Next.

    The Import Project dialog is displayed.

  7. Enter or select the root directory of the project that you want to build in the Root Directory text box:

    For Mac users: [User_Home]/Projects/[your-project]/src/android

    For Windows users: %HOMEPATH%\Projects\[your-project]\src\android

  8. Click Finish to build the MWSAndroid project.

    The MWSAndroid project is available in the ADT Project Explorer.

  9. In the ADT Project Explorer, select the project (MWSAndroid) and click the Project menu.

  10. In the Project menu, choose Build Project.

    The MWSAndriod.apk installer file is created in the bin directory.

After you have built the project, you can choose to install the app:

  • Using Android Debug Bridge
  • Using Eclipse

Using Android Debug Bridge

You can install the application on an Android device via the Android Debug Bridge with the following command:

For MAC users: adb install [User_Home]/Projects/[your-project]/src/android/bin/MWSAndriod.apk

For Windows users: adb install %HOMEPATH%\Projects\[your-project]\src\android\bin\MWSAndriod.apk

Using Eclipse

Alternatively, you can install the application on an Android device using Eclipse.

  1. Connect the Android device to the computer on which you have built the project.

  2. In the ADT Project Explorer, right-click on the project (MWSAndroid).

  3. From the context menu, choose Run As -> Android Application.

    The Android Device Chooser dialog is displayed.

  4. In the Android Device Chooser dialog, select the Android device on which you need to install the app and click OK.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy