Note:

This article is applicable if you are upgrading AEM forms on OSGi. For information, about upgrading AEM forms on JEE, see the documentation in the Installing, Upgrading, and Clustering AEM forms on JEE section in AEM 6.1 forms help and tutorials.

Before you upgrade

Before upgrading from AEM 6.0 forms to AEM 6.1 forms feature pack 1:

  • Install the latest service pack and patches for AEM 6.0 forms. To download and install latest service packs, see AEM 6.0 documentation.
  • Prepare the source instance for upgrade. For detailed steps, see the Upgrading to AEM 6.1 article.

Perform the upgrade

Perform the following steps to upgrade from AEM 6.0 forms to AEM 6.1 forms feature pack 1:

  1. Download the AEM 6.1 QuickStart.

  2. (Unix/Linux-based installations only) If you are using UNIX or Linux as the underlying operating system, open the terminal window, navigate to the folder containing crx-quickstart, and run the following command:

    chmod -R 755 ../crx-quickstart

  3. Replace the AEM 6.0 QuickStart with AEM 6.1 QuickStart and start the author instance.

    Starting the AEM 6.1 QuickStart, upgrades the existing crx-repository to AEM 6.1, automatically migrates the content from older version to newer version, and creates a folder named archived-versions.  

  4. After the server is up and running, restart the AEM instance. Before restarting the AEM instance, ensure that all the bundles are in active state. The bundles are listed at http://[server]:[port]/system/console/. If all the bundles are not active, wait, and check the status of the bundles after for a few minutes. After all the bundles are in active state, restart the AEM server.   

  5. Open the archived-versions folder and copy all the folders inside archived-versions folder to the [AEM_root]\crx-repository folder. Restart the AEM 6.1 instance. Before restarting the AEM instance, ensure that all the bundles are in active state. The bundles are listed at http://[server]:[port]/system/console/. If all the bundles are not active, wait, and check the status of the bundles after for a few minutes. After all the bundles are in active state, restart the AEM server.  

  6. Log in to AEM as an administrator and open the package share. Log in to the package share with an Adobe ID. A list of folders and packages appears.   

    Note:

    The default URL of package share is http:[server]/host/crx/packageshare/login.html.

    Note:

    Before installing the AEM forms add-on package, ensure that the installation path of the AEM Quickstart does not contain any spaces.

  7. In package share, search AEM forms add-on packages, click the package applicable to your operating system, and click Download. Read and accept the license agreement and click OK. Once downloaded, the word Downloaded appears next to the package.

    You can also use the direct download links listed in the AEM forms add-on package section to manually download a package.

    Note:

    AEM 6.1 forms feature pack 1 is latest AEM form add-on package. It is a cumulative package. Along with enhancements and bug fixes for various components of AEM 6.1 forms, the package contains complete functionality of AEM 6.1 forms. For detailed list of enhancements and fixes, see What's new in AEM 6.1 forms feature pack 1.

  8. Open the package manager, locate the downloaded package, and click Install. The default URL is http://[server]:[port]/crx/packmgr/index.jsp. After the package is installed on your environment, the word Share appears next to the package in the Package Manager. 

    Note:

    If you have hot fix 6717 installed and you are installing AEM forms feature pack 1 add-on package, you can encounter an error "Could not Install Package" on the Package Manager window. It is safe to ignore the error message.   

  9. (Optional) Apart from the AEM 6.1 forms feature pack 1 package, the package share contains packages for Central Migration Bridge and Send to printer services and add-on packages for Geometrixx Finance and Geometrixx.gov reference sites. You can also install these packages as required.

    You can use AEM package share to download and install these packages. The AEM forms add-on package section also lists direct download links to manually download the packages.

  10. (Optional) Configure the Doc Assurance Service

    The DocAssurance service is not available out of the box. It requires RSA and BouncyCastle libraries installed with AEM forms package. Perform the following steps to bootdelegate these libraries:   

    1. Stop the AEM server.

    2. Open the sling.properties at [AEM installation]\crx-quickstart\conf\ for editing.

      Note:

      If you use [AEM_root]\crx-quickstart\bin\start.bat to start AEM, then edit the sling.properties at [AEM_root]\crx-quickstart\

    3. Add the following properties to the sling.properties file:

      sling.bootdelegation.class.com.rsa.jsafe.provider.JsafeJCE=com.rsa.*
      sling.bootdelegation.class.org.bouncycastle.jce.provider.BouncyCastleProvider=org.bouncycastle.* 
    4. Save and close the file. Restart the AEM server.

  11. After the package is installed, do not immediately restart the server. Before restarting the AEM server, ensure that all the bundles, but the Signatures bundle, are in active state. The bundles are listed at http://[server]:[port]/system/console/. If all the bundles are not active, wait, and check the status of the bundles after for a few minutes.

    After all the bundles are in active state, restart the AEM server.  

AEM forms add-on package

AEM forms add-on package for AEM 6.1

After you install AEM 6.1 QuickStart, download and install the required add-on packages.

AEM 6.1 forms add-on package
Download link
AEM forms add-on package for AIX adobe-aemfd-aix-pkg
AEM forms add-on package for Linux adobe-aemfd-linux-pkg
AEM forms add-on package for Solaris
adobe-aemfd-solaris-pkg
AEM forms add-on package for Windows adobe-aemfd-win-pkg
Central Migration Bridge and Send to printer adobe-aemfd-cmb-pkg
Geometrixx Gov sample site add-on package cq-geometrixx-gov-all-pkg
Geometrixx finance sample site add-on package cq-geometrixx-finance-pkg

AEM forms add-on package for hot fix 6717

After you install AEM 6.1 QuickStart, download and install the required add-on packages.

AEM 6.1 forms add-on package
Download link
AEM forms add-on package for AIX adobe-aemfd-aix-pkg
AEM forms add-on package for Linux adobe-aemfd-linux-pkg
AEM forms add-on package for Solaris
adobe-aemfd-solaris-pkg
AEM forms add-on package for Windows adobe-aemfd-win-pkg
AEM forms add-on package for Mac OS X adobe-aemfd-osx-pkg

Note:

AEM 6.1 forms hot fix 6717 is a cumulative package. Along with enhancements and bug fixes for various components of AEM 6.1 forms, the package contains complete functionality of AEM 6.1 forms. For detailed list of enhancements and fixes, see release notes.

Note:

AEM 6.1 forms hot fix 6717 package for Mac OS X is not supported in production environment and mbe used only for demonstration purposes.

AEM forms add-on package for AEM 6.1 feature pack 1 (Latest)

After you install AEM 6.1 QuickStart, download and install the required add-on packages.

AEM 6.1 forms add-on package
Download link
AEM forms add-on package for AIX AEM-Forms-6.1-FP1-AIX
AEM forms add-on package for Linux AEM-Forms-6.1-FP1-LX
AEM forms add-on package for Solaris
AEM-Forms-6.1-FP1-SOL
AEM forms add-on package for Windows AEM-Forms-6.1-FP1-WIN
AEM forms add-on package for Mac OS X AEM-Forms-6.1-FP1-OSX
Central Migration Bridge AEM-Forms-6.1-FP1-CMB
Correspondence Management migration utility AEM-Forms-6.1-FP1-CM-MIGRATION-PKG
Geometrixx Gov sample site add-on package AEM-Forms-6.1-FP1-GOV-REF-SITE
Geometrixx finance sample site add-on package AEM-Forms-6.1-FP1-FSI-REF-SITE

Note:

AEM 6.1 forms feature pack 1 is latest AEM form add-on package. It is a cumulative package. Along with enhancements and bug fixes for various components of AEM 6.1 forms, the package contains complete functionality of AEM 6.1 forms. For detailed list of enhancements and fixes, see What's new in AEM 6.1 forms release notes.

Note:

On installing the AEM forms feature pack 1 add-on package, you can encounter an error message "Could not Install Package". It is safe to ignore the error message.    

Note:

AEM forms add-on package for Mac OS X is not supported in production environment and should be used only for demonstration purposes.

Verify the upgraded instance

  1. Open Web Bundles console and ensure that all the bundles at /system/console/bundle are active. The default address of the Web Bundles is http://localhost:4502/system/console/bundles.

  2. Search the afml (afml) bundle. If you encounter multiple versions of the afml bundle, delete the bundle with version 1.460868.0 and restart the AEM server.  

  3. Open the package manager and ensure that a cq-content package with version 6.1 exists.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy