OpenGL functionality in After Effects CS6 is different from OpenGL functionality in previous versions. This document is only for After Effects CS4 through CS5.5. For more information about After Effects CS6 GPU functionality, see this video.

This document can help you to resolve problems related to OpenGL that occur while you use After Effects. OpenGL problems can manifest in many different ways, including (but not limited to) the following:

  • Adobe After Effects crashes or closes without an error while it starts.
  • A crash or freeze when you scrub the timeline or preview or render a composition.
  • A crash when you change the settings of an effect while OpenGL previews are enabled.
  • A crash or freeze when you enable or disable OpenGL previews.
  • The composition window takes a long time to redraw.
  • Artifacts or blocks of "garbage" pixels are drawn in the composition window.
  • The composition window is drawn differently between when OpenGL previews are on and off.
  • An error message such as one of the following:

    " After Effects warning: A problem occurred when processing OpenGL commands."

    "The instruction at '0x00fe1940' referenced memory at '0x000000000' The memory could not be 'read'."

    "AE_OpenGL: failed to generate shadow map (5065::0)"

    "This composition is too complex for the OpenGL hardware."

    "After Effects error: AE_OpenGL: Create texture error. (5065 :: 0)"

For information about how to configure the preview preferences in After Effects for OpenGL and a list of features in After Effects that can be rendered with OpenGL, see Render with OpenGL in After Effects Help.

To benefit most from this document, perform the tasks in order. Record the tasks that you perform and the results of each, including errors and other problems. Adobe Technical Support can use this information to better assist you if you call.

It's necessary to log on as an administrator to perform some of the procedures in this document.

For Windows, some of these procedures require you to locate hidden files and hidden folders. Some procedures require you to locate files by their full filenames, which include extensions (for example, example_filename.ini). By default, Windows Explorer doesn't show hidden files, hidden folders, and filename extensions that it recognizes. See Show hidden files and folders in Windows for details.

For Windows Vista, the steps in this document that mention the Control Panel are in reference to the Classic view. For information on switching the Control Panel to the Classic view and many other common OS procedures, see Common OS procedures.

These tasks can help you resolve the most common problems with OpenGL. Before performing any of these tasks, back up all personal files (for example, After Effects files you created). Always restart the computer after a system error occurs to refresh its memory. Continuing to work without restarting the computer can compound the problem.

1. Update to the most recent version of After Effects

To check for updates, choose Help > Updates in After Effects. 

To download updates, see After Effects for Mac OS or After Effects for Windows.

2. Make sure that the computer system meets the minimum requirements for After Effects.

See this page for a list of system requirements for After Effects: Adobe After Effects system requirements

3. Make sure that the video card and drivers meet the OpenGL requirements.

Using OpenGL in After Effects requires an OpenGL card that supports OpenGL 2.0.

To determine what version of OpenGL your card supports, click the OpenGL Info button in the Preview preferences. On Mac OS, choose After Effects > Preferences > Previews. On Windows, choose Edit > Preferences > Previews.

For information regarding supported OpenGL hardware, see GPU (CUDA, OpenGL) features.

Newer video card drivers can improve the OpenGL capabilities of your card. See Update the video card driver below.

4. Disable OpenGL to determine whether it is causing the problem.

To disable OpenGL previews:

  1. Choose After Effects > Preferences > Previews (Mac OS) or Edit > Preferences > Previews (Windows).
  2. Deselect the Enable OpenGL option.

Note: OpenGL does not support some features in After Effects, and the appearance of your composition can change between using OpenGL previews and software-rendered previews. For the list features that OpenGL supports, see Render with OpenGL in the Rendering and Exporting section of After Effects Help.

5. Remove the OpenGL plug-in from the After Effects plug-ins folder.

To determine if OpenGL caused the problem, remove the OpenGL plug-in and restart After Effects.

To remove the OpenGL plug-in:

  1. Quit After Effects.
  2. Mac OS: Drag the AE_OpenGL.plugin file from the Applications/Adobe After Effects CS4/Plug-ins/Extensions folder to the desktop.

    Windows: Drag the AE_OpenGL.AEX file from the C:\Program Files\Adobe\Adobe After Effects CS4\Support Files\Plug-ins\Extensions folder to the desktop.
  3. Restart After Effects.

If the problem recurs, OpenGL didn't cause it. Drag the OpenGL plug-in back to the original location. If the problem doesn't recur, the cause of the problem is OpenGL. See Update the video card driver below.

6. Update the video card driver.

Many OpenGL problems or conflicts are solved by updating the video card driver. Many video card manufacturers frequently update their software drivers. If you haven't recently updated the video card driver, contact the video card manufacturer for an updated driver, or download one from the manufacturer's website.

7. Restart After Effects and test the behavior that caused the crash. (Windows only)

Following a crash that an OpenGL problem on Windows causes, After Effects CS4 can automatically disable the Prevent DLL Address Space Fragmentation preference. This preference allows After Effects to access a larger amount of contiguous RAM, but can be incompatible with some OpenGL drivers.

You can enable or disable the Prevent DLL Address Space Fragmentation preference by going to Edit > Preferences > Memory & Cache.

Leave this preference enabled unless you are experiencing OpenGL or memory-related crashes. If you disable the preference because of an OpenGL problem, and you later update the video card drivers, reenable the preference. Then, test the problem again.

8. Optimize the Texture Memory preference.

Crashes or OpenGL errors can occur if After Effects attempts to use too much video texture memory. Texture memory is the amount of RAM on the video card (VRAM).

Set the Texture Memory preference in After Effects:

  1. Multiply the total installed VRAM by 80% to calculate the optimal Texture Memory setting.
  2. In After Effects, choose After Effects > Preferences >Previews (Mac OS) or Edit > Preferences > Previews (Windows).
  3. Click OpenGL Info.
  4. Enter the value you calculated in Step 1, then click OK.

The ideal value for texture memory is 80% of the VRAM on your video card. (If you use multiple video cards, calculate 80% of the VRAM on the video card that is identified in the OpenGL Information dialog box.) If the Texture Memory preference in After Effects is set to more than 80% of the VRAM, it's possible that not enough VRAM is left for the video card to handle the user interface or other tasks. (For example, the entire screen can turn white.) If the value is set to less than 80%, OpenGL previews in After Effects can take longer to process frames.

See Mac OS Help or Windows Help for information about determining the amount of VRAM on a video card.

9. Purge the image caches and video memory.

If After Effects displays artifacts or "garbage" (blocks of incorrect pixels) in the composition window, the video memory (VRAM) could be full, fragmented, or corrupted. Purge the image caches and video memory to empty the VRAM and let After Effects rebuild the composition preview.

To purge the image caches, choose Edit > Purge > Image Caches.

To purge the video memory, choose Edit > Purge > Video Memory.

Note: Some screen savers that use OpenGL (or Direct3D on Windows) can corrupt the video memory if they activate while After Effects is running. Change or disable the screen saver if you frequently have problems with corrupted images in the composition window after turning off the screen saver.

10. Change the color setting for the video card to Highest (32 bit) (Windows) or Millions (Mac OS).

See Mac OS Help or Windows Help for information about changing the video card or display settings.

11. Disable advanced functions of the video card. (Windows only)

Most display card drivers include utilities that allow you to access advanced functions of the card. In particular, anti-aliasing, and 16-bit mode functions can conflict with OpenGL and cause After Effects to crash. Set the advanced functions of the card to their defaults, then disable the anti-aliasing and 16-bit mode options.

If you are using multiple monitors with an Nvidia card, set the Multimonitor setting to "Compatible".

See the documentation for the video card or to the manufacturer's website for instructions on how to access its advanced functions.

12. Use a single monitor.

If you are using multiple monitors and experience problems with OpenGL in After Effects, try the following:

  • If you have placed the After Effects application window or the Composition panel on a secondary monitor, move the window to the primary monitor.
  • Disconnect all but one monitor.
  • If you are using multiple display cards, remove all but one display card. For best results with OpenGL, use a single dual-head display card.

13. Place the Reduce OpenGL Texture Size script in the Startup scripts folder.

The Reduce OpenGL Texture Size script reduces the amount of texture memory After Effects uses and can provide better compatibility with older video cards.

To place the Reduce OpenGL Texture Size script in the Startup scripts folder:

  1. Navigate to the After Effects scripts folder.

    On Mac OS: Applications/Adobe After Effects CS4/Scripts.

    On Windows: C:\Program Files\Adobe\Adobe After Effects CS4\Support Files\Scripts.
  2. Move the Reduce OpenGL Texture Size.jsx file from the (support) folder to the Startup folder.

A newer video card can improve the OpenGL capabilities of your computer and make the script unnecessary. After you install a new card and its drivers, move the Reduce OpenGL Texture Size script back to the (support) folder. Then reset the After Effects preferences.

14. Reset After Effects preferences.

Re-create the After Effects preferences file to eliminate problems that damaged OpenGL preferences can cause.

To re-create the After Effects preferences file, restart After Effects. Hold Ctrl+Alt+Shift (Windows) or Command+Option+Shift (Mac OS) while the application is starting.

15. Contact Adobe Technical Support.

If none of the above steps has resolved the error or freeze that you are experiencing with After Effects, then contact Adobe Technical Support. You can find the support options at Adobe Support.


This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy