Creative_Cloud_mnemonic_RGB_48px

Update to After Effects CC available.

For more information, see the New features summary.


This document describes the new and updated features in the October and December 2014 releases of After Effects CC. The latest features and updates include high-DPI support for Mac OS and Windows, CINEMA 4D R16 compatibility, Anywhere collaboration, and a refreshed interface design.

Updates and enhancements | December 2014

The December 2014 release of After Effects provides important bug fixes and scripting improvements.

  • There are new keyframe icons in After Effects that are a little brighter than the icons in the earlier versions of After Effects. They have bright edges instead of dark edges so that they stand out better against the background.
  • Through scriptiong, you can now read additional information about the properties of a text layer, including the layer coordinates and additional character properties.
  • The sampleImage expression method is another way to sample color values. Use this method to use color values of specific pixels as input into an expression. In the latest release of After Effects, using sampleImage in an expression no longer disables multiprocessing.
    See the Layer General attributes and methods section in the Expression language reference for detailed information about using the sampleImage method.

See the After Effects blog for further information about the enhancements and bug fixes for the December 2014 release of After Effects CC.

Updates and enhancements | October 2014

Refined high-resolution (high-DPI) user interface

Refined high-resolution (high DPI) user interface

The latest release of After Effects CC includes high-DPI content viewers and user interface scaling. This inclusion makes After Effects easier to use on high pixel density monitors.

User interface elements such as icons, text labels, pointers, and buttons now scale according to the display settings of the operating system. Mac OS computers with a Retina display scale to 200%. Windows computers with a HiDPI display scale to 150% or 200%.

Note:

If you want content to appear the same on HiDPI displays and non-HiDPI displays, set the zoom value of the HiDPI display to be twice that of the non-HiDPI display.

Refreshed interface design

After Effects has a new darker design. You can change the brightness of the interface in Edit > Preferences > Appearance, though the slider range is more limited in that you can no longer change the appearance of the user interface to a completely light mode.

There is some simplification to the panel functionality. The following changes have been made to the icons, panels, and buttons:

  • The icon for the panel menu has been moved from the upper-right corner of the panel to the panel tab.
  • The panel grabber and frame grabber icons have been removed; you can drag panels using the panel tab.
  • The close button (x) has been removed from all panels except the Timeline, Composition, Layer, Footage, Effect Controls, and Flowchart, and Render panels. In these panels, the close button has moved to the left side of the panel tab. To close a panel without the close button, open the panel menu or right-click on the panel tab and choose Close Panel, or use the keyboard shortcut, Command+W  (Mac OS) or Ctrl+W (Windows).
  • The panel tabs for the Composition, Layer, Footage, Effect Controls, and Flowchart panels have been updated. Clicking the blue text of the composition, layer, or footage name in the tab will display the viewer menu.
  • The application's title bar now shows the full path to the project file.

Enhanced 3D pipeline with Maxon Cineware 2.0 plug-in and CINEMA 4D Lite R16

After Effects CC now includes Cineware 2.0, which adds CINEMA 4D R16 compatibility. Cineware 2.0 includes the new Reflectance Channel, enables you to work with 3D elements faster, and provides improved layer support.

Automatic settings synchronization - The Synchronize Layer setting enables you to automatically synchronize your Cineware settings with all the layers in a composition. When you add multiple instances of a CINEMA 4D scene layer in a composition, including adding Multi-Pass layers, a new checkbox, Synchronize Layer, is displayed at the top of the Effect Controls panel.

When the box is checked (default), the Cineware effect settings on all instances of the layer synchronize automatically. If the checkbox is disabled for a specific CINEMA 4D scene layer, then that layer's settings will not synchronize with the rest of the layers in the composition.

Default Layer support - The CINEMA 4D layers dialog displays a Default Layer option if the renderer supports it. Layers that have not been assigned to an explicit layer in the .c4d project files are displayed with the Default Layer enabled.

Content Browser support - When using a full retail version of CINEMA 4D R16 as the renderer, textures applied through installed content libraries (.lib4d files) are rendered in After Effects using Cineware.

Region of Interest - You can now render substitute composition regions using the Region Of Interest control in the composition panel. When a Region of Interest has been defined in the composition panel, and the Renderer control is set to Standard (Final), Cineware renders only what is inside the bounds of the region.

Collect Files: Collect Files now collects assets associated with .c4d footage items, such as textures.

Purge Memory -  For complex scenes, the render server may use memory for internal caches. To free up the internal memory, click Purge Memory to extend the length of previews in After Effects.

The Purge Memory option works only when the CINEMA 4D render path is set to one of the following:

  • The default render server Cineware R16.
  • A full retail version of CINEMA 4D R16 or later.

Note:

Cineware 2.0 for After Effects adds CINEMA 4D R16 compatibility and the version of CINEMA 4D Lite included with After Effects CC (October 2014) is R16.

The following sections provide detailed information about Cinema 4D and Collect files:

Online resources

  • For information about Cinema 4D, go to the Maxon website.
  • See this video by John Dickinson which outlines the Cinema 4D changes in the latest After Effects CC release.

Copy with Relative Property Links

There is a new command Copy With Relative Property Links that maintains a relative link between the layer with the expression and the composition containing that layer. This command is similar to the existing Copy With Property Links command except that it creates expressions that do not reference the source composition by name.

For example, use this command when you want to move expression-rigged layers from one composition to another but let the layers reference a control layer only in the same composition.

Note:

The expressions created using the Copy With Relative Property Links command are identical to those created using the expression pickwhip.

To copy a layer’s Position property - thisComp.layer("control_layer").transform.position

The existing Copy With Property Links command specifically references the layer’s source composition in the expression - comp("source_comp").layer("control_layer").transform.position

See the Expression basics section for detailed information about adding, editing, and managing expressions in After Effects.

Dynamic Link color management (Rec. 709 only)

Color settings section in the Project Settings dialog box
Color settings

When color management is enabled for an After Effects project, compositions viewed over Dynamic Link will be transformed using the Rec. 709 color profile. This prevents color or gamma shifts in the appearance of these compositions in Premiere Pro and Adobe Media Encoder.

Dynamic Link always assumes that all incoming frames are in Rec. 709. In previous releases of After Effects, compositions in a color managed project were sent to Dynamic Link in the project's working color space; the compositions were not adjusted for Dynamic Link's assumption of Rec. 709. This mismatch resulted in a noticeable color or gamma shift when the project's working color space was significantly different from Rec. 709 or when Linearize Working Space (under File > Project Settings) was enabled.

In the latest release of After Effects CC, a color transformation is applied to the composition as a last step before the images are passed to Dynamic Link for use in Premiere Pro or Adobe Media Encoder. This transformation corrects the composition image to the color space used by Dynamic Link. This is similar to the View > Enable Display Color Management option in After Effects which corrects the image for your monitor.

See the color management section for detailed information.

Automatic encoding of After Effects projects using watch folders in Adobe Media Encoder

If you copy an After Effects project (.aep) file into one of Adobe Media Encoder's watch folders, the compositions at the top level of the project (compositions that are not in folders in the Project panel) are automatically added to the Adobe Media Encoder encoding queue.

See the Encode files automatically using Watch folder section in Adobe Media Encoder for detailed information.

Support for native encoding and decoding of movies using GoPro CineForm codecs

After Effects, Premiere Pro, and Adobe Media Encoder can natively decode and encode QuickTime (.mov) files using the GoPro Cineform codecs on Mac OS and Windows. This means that you do not need to install additional codecs to use and create such files.

Use this codec with the higher-quality settings, to send intermediate files from one application to the next application in a post-production pipeline. Movie files encoded with the GoPro Cineform codec at the higher-quality settings include an alpha channel.

To use the GoPro CineForm codec for output:

  1. Choose Output Module Settings > QuickTime.
  2. Click the Format Options button.
  3. Choose GoPro CineForm as the video codec.

Note:

  • To control the quality and channels exported with this codec, use the Output Module Settings > Video Output > Depth and Channels controls.
  • To use the highest-quality 4:4:4:4 option with an alpha channel, do the following:
    • Choose RGB+Alpha from the Channels menu
    • Choose Trillions Of Colors+ from the Depth menu; this creates a movie with a precision of 12 bits per channel.

Go to the following links for additional details about the GoPro CineForm codec.

Updates to mocha AE

mocha AE has been updated to mocha AE CC 2014 (version 4.0.1) that includes compatibility with mocha Pro 4 project files. For details about what's new in mocha 4.0, see the Imagineer website.

Miscellaneous updates

  • The Anchor Point icon on selected layers has been enhanced for better contrast and visibility. The icon's hit area changes with the Path Point & Handle Size preference.
  • Use the new Browse Add-ons... command in the File menu to open the Adobe Add-ons page (formerly Adobe Exchange) in your web browser.
  • The new Adobe Color Themes replaces the previously named Adobe Kuler panel. Choose Window > Extensions > Adobe Color Themes to open this panel. See the Select a color with Adobe Color section in the Color basics article to learn more about the Adobe Color panel.
  • You can speed up After Effects compositions using the new Render and Replace feature in Premiere Pro. This feature enables you to flatten After Effects compositions into video clips thus speeding up the performance of sequences. See the Render and Replace After Effects compositions section in Premiere Pro for detailed information.

This document describes the new and updated features in the June 2014 release of After Effects CC. Read on for a complete list of updates and the latest features including the Key Cleaner and Advanced Spill Suppressor effect, the new Compositing Options, and the live text templates workflow with Premiere Pro.  

Updates and enhancements | June 2014

Key Cleaner effect and Advanced Spill Suppressor effect

One minute overview: Keying effects and Advanced Spill Suppressor

One minute overview: Keying effects and Advanced Spill Suppressor
Maxim Jago

The Key Cleaner effect recovers alpha-channel detail from a scene keyed by a typical keying effect, including recovering detail lost due to compression artifacts.

The Advanced Spill Suppressor effect removes color spill on a foreground subject from a colored background used for color keying. It has two methods for spill suppression:

  1. Standard - The Standard method is simpler, automatically detects the dominant key color, and requires less user input.
  2. Ultra - The Ultra method is based on the spill suppression in the Ultra Key effect in Premiere Pro. See the Ultra Key section in Premiere Pro for details about the Ultra Key.

Starting with the 2014 version of After Effects, the Spill Suppressor effect has been moved to the Obsolete effects category. Users are recommended to use the Advanced Spill Suppressor effect instead.

An easy way of applying these effects is by using the Keylight + Key Cleaner + Advanced Spill Suppressor animation preset.

For more information, see the Keying Effects section.

Note:

Use the new Key Cleaner and Advanced Spill Suppressor effects with any keying effect that can provide the original RGB data as input. The new effects are found under the Effects > Keying menu.

Compositing Options (including effect masks)

The Compositing Options property group for each effect includes a new Effect Opacity property, which provides similar functionality as the Blend With Original compositing to every effect. The Effect Opacity allows you to blend between the effect results and the image without applying the effect. You can precisely apply any effect to a particular area of an image by masking and matting the desired area.

You can also restrict the area of effects applied to a layer using a new mask. The Mask Reference option is found under the Compositing Options under each effect in the Timeline panel. Click the plus sign next to the Compositing Options heading and choose a mask listed under the Mask Reference menu.

For more information, see the Compositing Options and Mask Reference article.

Importing masks from Premiere Pro

When you import a clip from Premiere Pro that includes masks, the masks from Premiere Pro are preserved and converted to After Effects masks. This works for all methods of importing clips from Premiere Pro including:

  • Using the Replace With After Effects Composition command in Premiere Pro
  • Copying and pasting the sequence from Premiere Pro to After Effects
  • Importing a Premiere Pro project into After Effects.

The mask shape, feather, opacity, expansion, and inversion properties are all preserved and the keyframes on those properties are also included.

However some After Effects mask attributes, such as variable-width mask feathering, will not get imported into Premiere Pro.

Note:

Masks are either effect masks or layer masks and the mask mode is always set to Add when the mask is imported from Premiere Pro into After Effects.

Live text templates - Edit After Effects text templates in Premiere Pro

One minute overview: Edit text templates

One minute overview: Edit text templates
Maxim Jago

You can create text template compositions in After Effects wherein the source text can be edited in Premiere Pro. Any composition with text layers can be used as a text template, and any unlocked text layers in that composition can be edited in Premiere Pro.

For more information, see the Editing text templates article.

Video preview on external monitor using Mercury Transmit

The video preview system for external monitors has been replaced with the Mercury Transmit-based system.

Video preview preferences

The Mercury Transmit system for video previews sends the contents of the Composition, Layer, or Footage panel to an external monitor. The external monitor can be one of the following:

  • A video monitor connected through third-party video hardware such as AJA, Blackmagic, and Matrox I/O devices
  • A DV device connected over FireWire
  • A computer monitor connected to your video display card via such as HDMI, DVI, VGA, or DisplayPort.

For more information, see the Video preview using Mercury Transmit article.

Add fonts from Typekit in After Effects

You can download and install hundreds of fonts from within After Effects CC through the integration of Typekit in the June 2014 release of After Effects CC. Click File > Add Fonts from Typekit.. to launch the Typekit website.

For more information about using Typekit with Creative Cloud, see the Typekit Help Center.

Integration of Kuler panel into After Effects

The Kuler panel that is integrated into After Effects CC (Window > Extensions > Adobe Kuler) is one of the first instances of an HTML5 CEP panel built for After Effects. Using the Kuler panel, you can :

  • Browse color themes that other users have shared through Creative Cloud
  • Load color themes from your own library on Creative Cloud
  • Create color themes on your iPhone or in your browser using various color models. You can use the color swatches within each color theme as a source from which to sample colors for any purpose within After Effects. (This replaces the old workflow of creating a document in Illustrator that held your color swatches and then importing that file into After Effects as a a source from which to sample when matching colors in a logo or other other branded item.)

For more information, see the Adobe Kuler site at https://kuler.adobe.com and www.adobe.com/in/products/kuler.html.

HTML5 panels using CEP infrastructure

After Effects now includes the CEP (Common Extensibility Platform) infrastructure for loading and using HTML5 panels. These panels have access to the entire After Effects scripting object model in addition to being able to use HTML, CSS, and JavaScript. Hence a very wide variety of extensions can be created using this system.  

Improvements to Curves effect user interface

Curves effect user interface

The primary user interface element in the Curves effect (the curves themselves) is now resizable using buttons immediately above the curves. The icon-based buttons for Open, Save, Smooth, and Reset have been replaced with word-based buttons that make their functionality more discoverable and the interface has been changed to increase the size of the default window.

The new improvements have the following advantages:

  • Click one of the three sizing icons at the top of the effect to adjust screen sizes.
  • Channels will show separately and concurrently in White, Red Green Blue, and Gray(alpha).
  • Channel selection is automatic when a curve or vertex is clicked to add or move a point.
  • The curves are drawn more smoothly.

Auto Adjustment in Curves effect

To adjust the curves in the Curves effect automatically, click the Auto button beneath the curves in the Effect Controls panel. This automatic adjustment is based on a database of curve adjustments performed by color and photography experts on a broad range of input images. This will enable users to get a good starting point for their color adjustments.

The adjustment made to an image is based on the adjustments made to reference input images with similar color distributions.

Supported file formats

The following files are supported for import in the 2014 release of After Effects CC.  

  •  Sony RAW files (raw footage files from F5, F55, and F65 cameras)
  •  MPEG-4 SStP (Simple Studio Profile) Sony SR MXF files
  •  indexed-color PNG files and grayscale PNG files with transparency
  •  Photoshop Large Document (.psb) files
  •  CMYK JPEG files
  •  RED EPIC Dragon 6K files
  •  Cinema 4D (.c4d) 3D scene files
  •  DNxHD MXF OP1a and Op-Atom files
  •  QuickTime (.mov) files using DNxHD codecs (without installing additional codecs)
  •  QuickTime (.mov) files using ProRes codecs (without installing additional codecs) on Mac OS
  •  XAVC (Sony 4K)
  •  AVC-Intra 200

Miscellaneous updates

  • Use File > Save As > Save A Copy As CC (12) to save a project as a copy for the previous version. To open a project created in the latest version of After Effects in After Effects CS6, you have to save back from After Effects CC (12). See Save and backup projects for detailed information.
  • You can now import raw files from Sony F5, F55, and F65 cameras into After Effects. As with ARRIRAW files, the source settings are not carried over when transferring a clip from Premiere Pro to After Effects.
  • After Effects CC now installs mocha-AE version 3.2.1. Previous versions of After Effects CC installed mocha-AE v3.1.0. See the release notes (pdf) on the Imagineer Systems website for details of what's new in mocha-AE v3.2.
  • You cannot export to the following formats in the 2014 version of After Effects CC. See this blog for additional information. However, you can still import these file formats into After Effects.
    • FLV/F4V
    • MPEG-2
    • H.264
    • WMV
    • SWF

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy