after-effects

Create dynamic, visually stunning motion graphics and visual effects wherever inspiration strikes. After Effects connects with Creative Cloud mobile and desktop apps seamlessly, allowing your creativity to inspire you — wherever you are.


Adobe Stock integrated to the CC Libraries panel

New in After Effects CC 2015 | November 2015

This release of After Effects gives you the capability to search from over 40 million high-quality, curated, royalty-free images, illustrations, vector graphics, and videos in Adobe Stock, add them to your libraries, and purchase licenses for the assets directly in the Libraries panel.

You can drag graphics and video assets from the Libraries panel directly to the Composition and Timeline panels to import them into your project. You no longer have to import and add to the composition as separate steps.

When you add an Adobe Stock video to your After Effects project, the video initially appears as a placeholder (color bars) while the video file is downloaded. Once the download completes, the placeholder is replaced with the video file. You can monitor download progress in the new Progress Panel (Window > Progress Panel). When you license a preview video that was used in your project, the licensed video must be downloaded before the preview video is replaced.

Note: In After Effects CC November 2015 release, licensed images do not automatically replace preview images. To replace a preview image in your composition with a licensed image, add the licensed image to your project, then hold the Option (Mac OS) or Alt (Windows) key, and drag the licensed image from the Project panel onto the preview image in the composition.

AE-1Stock-video-library

For more information, see Creative Cloud Libraries and Using Adobe Stock.

Import clips with Lumetri color effects

New in After Effects CC 2015 | November 2015

Now you can bring your Premiere Pro clips in to After Effects along with the color grading changes that you have made to them using Lumetri color effects. After Effects helps you preserve the Lumetri color adjustments in your Premiere Pro clip when you:

  • create an After Effects composition from the clip.
  • copy and paste the clip from Premiere Pro to After Effects.
  • import the Premiere Pro sequence into your After Effects project.

You can apply the Lumetri Color effect to any layer in After Effects.

To learn more about Lumetri color controls, see Premiere Pro color workflows.  

Character Animator Preview 3

New in After Effects CC 2015 | November 2015

The November 2015 release of Adobe After Effects CC includes the Preview 3 of Character Animator, the character animation application that allows you to bring expressive characters to life using your own artwork.

Adobe Character Animator allows you to import artwork from Adobe Photoshop or Adobe Illustrator, and breathe life into them. You can do so by first capturing your performance using a camera and microphone. While you're performing, Character Animator mimics your facial expressions, synchronizes mouth movements to your speech, and provides complete control over all aspects of a character’s movement.

The Preview 3 part of this release includes Stick Tool, take blending, multi-touch display support in the Dragger (formerly Mouse Tracker) behavior, import project, split lip sync into visemes, and many more new features and enhancements.

For an overview of the features in Adobe Character Animator Preview 3, see the New features in Preview 3.

To learn more about Character Animator Preview 3, see Getting Started with Adobe Character Animator.  

New Start experience

New in After Effects CC 2015 | November 2015

Starting with this release, a new Start screen welcomes you when you launch After Effects or while you open a new project. 

You can configure the Start screen to appear at startup or when you open a project using the following options in General Preferences (choose Edit > Preferences > General):

  • Show Start Screen at Startup
  • Show Start Screen when Opening a Project.

Note: The new Start screen is currently available only in English, French, German, and Japanese.

AE-Welcome

New workspace bar for custom and default workspaces

New in After Effects CC 2015 | November 2015

Now you can access custom or default workspaces from the new workspace bar located on the right-hand side of the Tools panel with a single click. By default, the workspace bar displays three workspaces:

  • Standard is the same workspace as in previous versions of After Effects.
  • Essentials is now the default workspace. The layout is similar to Standard, except that the panels on the right side of the workspace are in a stacked panel group.
  • Small Screen is optimized for low-resolution displays such as projectors, and for devices like tablets (which are high-resolution but small-screen devices).

The remaining workspaces are available in the workspace bar's overflow menu.

You can customize the width of the bar by dragging the vertical divider between the tool and the workspace bars.

For more information, see Customizing workspaces.

New caching behavior in Preview

New in After Effects CC 2015 | November 2015

This release of After Effects introduces an improved caching behavior, which replaces the earlier Preview Favors controls.

After Effects renders and caches frames until the cache is full, after which the caching stops. After Effects no longer has an option to cache where preview continues indefinitely by discarding the oldest cached frames.

The new caching behavior stores the screen display cache only for a short duration ahead of the Preview Time Indicator, compared to the earlier mode of keeping the screen display cache for all cached frames. The screen display cache is a secondary cache that transforms the frames for display on the screen.

After Effects provides you a new Cache Before Playback option in this release. If you enable the option, After Effects caches frames before starting playback. This behavior is similar to how RAM Preview behaved in the earlier versions of After Effects. However, frames are not displayed to the Composition, Layer, or Footage panel as they are cached. 

For more information, see Previewing.

Preview-AE - Copy (2)

New ICC color profiles

New in After Effects CC 2015 | November 2015

This release of After Effects introduces new ICC profiles to correctly interpret colors from a variety of sources, including ARRIRAW footage. In addition, there are new profiles to simulate color output and to choose a working color space for a project.

The following is a list of new ICC profiles in After Effects:

  • ARRI Log and Look wide color gamut profiles
  • HDTV and UHDTV Display profiles, recommended for use in place of the older Rec. 709 camera profile
  • SDTV Display profiles, recommended for use in place of the older Rec. 601 profiles
  • DCDM and DCI P3 profiles, with more white points, replacing older inaccurate profiles
  • ACES and ACEScg working space profiles

For more information, see Color management.

Multi-touch zoom and pan gestures

New in After Effects CC 2015 | November 2015

You can use multi-touch gestures (for example, zoom and pan) in the following panels:

  • Composition
  • Layer
  • Footage
  • Timeline

Use the gestures in any touch-enabled device (for example, Microsoft Surface or Wacom Cintiq Touch) or multi-touch trackpad.

For more information, see Using gestures.

Stacked panel groups

New in After Effects CC 2015 | November 2015

Stacked panel groups enable a single-click access to panels while keeping your workspace clean and uncluttered. The feature is similar to the panels in Adobe Lightroom. 

In a stacked panel group, panels are minimized to their tabs and are stacked vertically. If you click a panel tab, the panel expands.

Stacked panel groups come in handy when you want to quickly show and hide panels that typically appear along the right side of the workspace, such as Character, Paragraph, Paint, Brushes, Tracker, and other panels you do not frequently use. You can open the All Panels workspace, and then move all the panels along the right side to a single stacked panel group.

For more information, see Create stacked panel groups.

AE-Stacked-Panelpng

Importers for additional formats and codecs

New in After Effects CC 2015 | November 2015

After Effects CC 2015 can natively import the following:

  • HEVC (H.265) footage
  • QuickTime (.mov) files with Avid DNxHR codec

For more information, see Importing and interpreting footage items.

Scripting access to text baselines

New in After Effects CC 2015 | November 2015

You can read the baseline X,Y locations for a text layer using scripts. The newsourceText.value.baselineLocs attribute for TextDocument objects returns an array of floats. The attribute  indicates the origin of each line of the text's baseline X and Y values.

Line wraps in a paragraph text box are treated as multiple lines.

The array returns float values in the form of: line0.start_x, line0.start_y, line0.end_x, line0.end_y, line1.start_x, line1.start_y, line1.end_x, line1.end_y ... lineN-1.start_x, lineN-1.start_y, lineN-1.end_x, lineN-1.end_y.

For more information, see Scripts.

Function to generate random numbers

New in After Effects CC 2015 | November 2015

The function, generateRandomNumber(), generates random numbers. Use this function instead ofMath.random() when you want to generate random numbers.

generateRandomNumber() avoids a problem where Math.random() does not return random values due to a concurrency issue with multiple CPU threads.

For more information, see Scripts.

Preview panel enhancements

New preview controls

In previous versions of After Effects, the behaviors that occur when you stopped a preview were dependent on the type of caching used by the preview and the keyboard shortcut to stop the preview.

You can now configure the stop behaviors for a shortcut using the new controls at the bottom of the Preview panel.

In the On (Keyboard Shortcut Name) Stop section (for example, On (Spacebar) Stop), you can enable the following options:

  • If caching, play cached frames:  When you enable this option and use this shortcut to stop a preview before caching completes, only caching is stopped. Playback of cached frames will restart from the beginning of the range. When you disable this option, stopping a preview with this shortcut will stop both caching and playback.
  • Move time to preview time: When you enable this option and use this shortcut to stop a preview, the Current Time will move to the position of the Preview Time. When this option is disabled, the Current Time stays at its previous position.

For more information, see Previewing.

Preview-AE - Copy

Mute Audio button behavior changes

The Mute Audio button at the top of the Preview panel now does not control whether audio is played when you start a preview with the current shortcut. This button mutes or unmutes an audio during playback.

Note: If you change the state of the Mute Audio button during a preview, it will also enable or disable theInclude Audio button for the shortcut you used to start that preview.

Preview-AE-1 - Copy

Shortcut for New Comp From Selection command

The New Comp From Selection command now has a keyboard shortcut: Option + \ (Mac OS) or Alt + \ (Windows)

New shortcut for Trim Comp to Work Area command

The Trim Comp to Work Area command now has a keyboard shortcut: Shift + Command + X (Mac OS) or Shift + Ctrl + X (Windows)

New include buttons

There are three new buttons that control if any keyboard shortcut starts an audio or video preview, or shows overlays and layer controls.

Callout-AE1
  • Include Video: Enable to preview video.
  • Include Audio: Enable to preview audio.
  • Include Overlays & Layer Controls: Enable to show overlays (for example, grids and guides) and layer controls for selected layers.

New configurable shortcuts

This release includes the following audio-only preview shortcuts:

  • The keyboard shortcuts for audio-only previews: Numpad-.(period) and Option + Numpad-.(period) (Mac OS) or Alt + Numpad-.(period) (Windows), are now configurable in the Preview panel.
  • Shift + Spacebar: Shift + Spacebar Preview shortcuts is configured similarly to Numpad-0 by default, except that Play From is set to Current Time.

New range option

The Range control includes a new option, Play Around Current Time. This option behaves similarly to the Play Around command in Premiere Pro. When you start a preview with Play Around Current Time enabled, the preroll value is subtracted from the current time, the postroll value is added to the current time, and the frames in-between are previewed.

Playaround-AE2

To set the preroll and postroll values, choose Play Around Current Time from the Range menu to open thePlay Around Current Time settings dialog box. Set your desired preroll and postroll values in seconds, then clickOK to close the dialog box.

Playaround-AE1

CycoreFX HD 1.8.1 plug-ins

Enhanced in After Effects CC 2015 | November 2015

CycoreFX HD 1.8.1 plug-in package includes the following enhancements:

CC Vignette: You can now add or remove a vignette. CC Vignette includes an option to preserve (pin) highlights for more realistic behavior.

CC HexTile: CC Hextile generates honeycomb patterns. It repeats a hexagonal pattern, with several options that include a "smear" control. It can be considered as an extension to the CC Kaleida effect to generate dynamic effects in backgrounds.

For more information, see Plug-ins.

Synthetic Aperture Color Finesse 3.0.14 plug-in

Enhanced in After Effects CC 2015 | November 2015

The Color Finesse 3.0.14 plug-in for After Effects CC includes some bug fixes.

  • The User Interface now launches from a second adjustment layer.
  • Changes to parameters via expressions are no longer ignored.
  • In Mac OS, context menus for the simplified UI's curve and wheel controls display in the correct location.
  • In Windows, pixels scale correctly for HiDPI displays.

For more information, see Plug-ins.

Miscellaneous updates

  • The Composition panel previews compositions being rendered via the Render Queue
  • The Hardware Accelerate Composition, Layer, and Footage Panels option inPreferences Display is now enabled
  • You can drag graphics and video assets from the Libraries panel directly to the Composition and Timeline panels. The asset will automatically be imported into your project; you no longer have to import and add to the composition as separate steps
  • You can drag footage from Finder (Mac OS) or Explorer (Windows) directly to the Composition and Timeline panels. The footage will automatically be imported into your project; you no longer have to import and add to the composition as separate steps
  • You can set Panel tabs to a larger size for easier selection on a touch display device. To enable this for all tabs in a panel group, click the panel menu for any tab in the group, choose Panel Group Settings, then disable Small Tabs
  • Current Time Indicator (CTI) now draws as blue through its entire length at all times, including when preview is stopped
  • The External Video link was removed from the Preview panel.
  • Roving keyframes use a new, easier-to-distinguish icon.
  • The hit area for twirly triangles (ex., to expand folders in the Project panel or show layer properties in the Timeline panel) has been enlarged to the rectangle around the triangle to make them easier to use on touch devices.
  • Auto-save now does not attempt to save when exporting via the Render Queue. Auto-save also now saves a version when the Render button in the Render Queue is pressed.
  • Improved color management on import for video file formats: linear color pixel formats are now recognized automatically, and half-res HD footage is no longer tagged with SD color profiles.
  • The OptiX library from Nvidia has been updated, which adds the ability for Maxwell-architecture GPUs (e.g., GTX 970, GTX 980) to be used for the ray-traced 3D renderer (Windows only).
  • The MXF OP1a format has been removed from the render queue. To export to MXF OP1a, use Adobe Media Encoder.

Creative Cloud Libraries

New in After Effects CC 2015 | June 2015

The inclusion of Creative Cloud Libraries in After Effects CC 2015 puts all your creative assets right at your finger tips. All your favorite assets can now be accessed from within the Libraries panel in After Effects.

You can save, access, and reuse assets stored in Creative Cloud Libraries across Adobe's desktop (such as Photoshop, Illustrator, and more) and mobile apps (such as Adobe Hue CC).

Library sharing makes it easy to collaborate with teams and maintain consistency across projects with common assets like graphics, colors, Looks, or type styles. 

Select Window > Libraries to open the Libraries panel in After Effects.

You can also choose assets from the Creative Cloud Market.

For more information about using Creative Cloud Libraries, see Downloading and reusing assets using Creative Cloud Libraries.

Integration with Adobe Stock

Adobe Stock is a new service that sells millions of high-quality, royalty-free photos, illustrations, and graphics.

You can search for Adobe Stock content directly from within After Effects, using the Libraries panel (Window > Libraries) by clicking the Search Adobe Stock button in the panel. You can then purchase a license for an asset you want to use and include it in your After Effects Library. Or, you can add an unlicensed preview (watermarked) copy to your Library and purchase a license for it later.

For more information, see Add photos using Adobe Stock.

Changes to Preview workflow

Uninterrupted Preview

Enhanced in After Effects CC 2015 | June 2015

You can now make changes to a project while previewing within After Effects. View design iterations, adjust properties, and even resize panels without stopping playback of your compositions.

In previous versions of After Effects, after you started a preview in a composition, layer, or footage viewer, clicking anywhere in the user interface would stop preview. Previews will now continue, until you stop the preview manually.

For more information, see Previewing in After Effects.

Unified and Configurable Preview

Enhanced in After Effects CC 2015 | June 2015

You can now customize Preview behaviors using the updated Preview panel. If you're new to After Effects, you will find the default Preview, started by pressing Spacebar, intuitive with real-time playback of audio and cached frames. For you, the experienced After Effects user, Preview options are configurable to suit your working style.

Note that the these new changes have dissolved the differences between the old RAM preview and Standard preview (spacebar) behaviors, and After Effects no longer uses those terms. Preview is now considered to be unified, with user-configurable behaviors.

New controls in the Preview panel allow you to configure preview behaviors for each keyboard shortcut: audio, looping, caching, range, and layer controls.

For more information, see Previewing in After Effects.

Face Tracker

New in After Effects CC 2015 | June 2015

After Effects CC 2015 now includes face tracking capabilities. You can detect and track human faces with exceptional accuracy by managing the level of detail you track.

Simple mask tracking lets you quickly apply effects only to a face, such as selective color correction or blurring a person’s face, and more. However, with Face Tracking, you can also track specific points on the face such as pupils, mouth, and nose, allowing you to isolate and work on these facial features with greater detail. For example, change colors of the eyes or exaggerate mouth movements without frame-by-frame adjustments.

Face Tracking also lets you extract and copy facial measurements. Tracking of facial measurements tells you details such as how open the mouth is and how open each eye is. You can also export detailed tracking data to Adobe Character Animator for performance-based character animation.

For more information, see Face Tracking in After Effects.

Integration with Adobe Character Animator (Preview)

 New in After Effects CC 2015 | June 2015

Adobe Character Animator (Preview), a companion application, tracks your facial movements, records a voice over, and even triggers bodily movement with simple keyboard actions and automated features that give life to characters you create in Illustrator or Photoshop. When you talk, your character talks. When you feign surprise, so does your character. When you’re grumpy, your character is too.

Adobe Character Animator is for two different types of artists: those who want to rig complex characters without creating a confusing tangle of expressions, and those who just want to create simple characters easily. Either way, once the character is set up in Photoshop or Illustrator, Adobe Character Animator brings it to life. It does this by users acting out a performance in front of their webcam and talking into their microphone.

For more information, see Adobe Character Animator.

Interactive performance improvements

Enhanced in After Effects CC 2015 | June 2015

There are significant architectural code changes in After Effects CC 2015 release that allow the user interface and image rendering to be processed separately by the CPU. The following improvements are a direct result of these changes:

  • The user interface is now much more responsive as it no longer needs to wait for frames to finish rendering. Conversely, frames can continue to render while you work with the user interface. This responsiveness makes for a smoother interaction with the user interface at all times.
  • Far fewer instances of delays or beach ball during a Preview.
  • You can now interrupt or cancel frame renders by making a change to the composition.
  • Fast scrubbing, even when the frames take a long time to render.
  • Faster image caching.
  • More efficient evaluation of expressions.
  • Previews continue to play back while After Effects is in the background.

Changes to expression evaluation

Enhanced in After Effects 2015 | June 2015

Evaluation of expressions in After Effects has been significantly enhanced. Overall, you may find that expressions are evaluated faster; the improvement will vary depending on the expression.

When an expression fails to evaluate, there are two major changes:

  1. Expression errors appear in a warning banner at the bottom of the Composition panel instead of in a dialog box. The expression is not disabled. 
  2. The expression will continue to evaluate and will display the warning banner until the problem with the expression is fixed.

On the right side of the expression error warning banner are Left, Down, and Right arrow buttons:

  1. Click the Left or Right arrow buttons to display the previous or next expression error when multiple expressions fail to evaluate.
  2. Click the Down arrow to display the property with the failing expression in the Timeline panel. The expression error text is clipped to the width of the Composition panel. To see the full expression error in a dialog box, click on the yellow error triangle icon for the expression in the Timeline panel.

User interface enhancements

Color icons for compositions and image sequences

Icons for compositions and image sequences in the Project and Timeline panels are now multicolored instead of monochrome.

Preference for user interface highlight brightness

 

In Preferences > Appearance there is a new Highlight Colors section wherein you can in which you can adjust the brightness of interactive controls and focus indicators.

You can see the changes to the slider values reflected live in the user interface behind the Preferences dialog.

 

Panel group enhancements

 

Several changes have been made to how panel groups work

  • No tab well for single panels - When there is only one panel in a panel group, the tab well does not appear. You can still drag other panels into the tab row to dock them in that panel group.
  • Menu instead of scroll bar - When there are more panel tabs than that will fit in the width of a panel group, a menu ( >>) appears on the right side of the tab well instead of a scroll bar. You can choose a tab from the tab well.
  • Panel Group Settings submenu - In panel menus, panel group commands have been moved to the Panel Group Settings submenu:
    • Close Panel Group
    • Undock Panel Group
    • Maximize Panel Group
  • Close Other Panels In Group: In panel menus, there is a new command to close other panels in the same group.

 


Maxon Cineware 2.0.16 plug-in

Enhanced in After Effects CC 2015 | June 2015

Cineware 2.0.16 for After Effects includes the following enhancements:

  • CINEMA 4D Layers are no longer automatically synchronized - When adding multiple instances of a CINEMA 4D scene layer in a composition, including adding Multi-Pass layers, Cineware no longer automatically synchronizes CINEMA 4D Layers. You will see an on/offcheckbox at the top of the Effect Controls panel that has been relabeled to Synchronize AE Layer. When this preference is enabled, the Render Settings and Camera options on all instances of the layer will automatically synchronize as before, but CINEMA 4D layers can be set independently. If this checkbox is disabled for a specific CINEMA 4D scene layer, then none of that layer's settings will synchronize with the rest of the layers in the composition.
  • Updated CINEMA 4D Layers dialog window - "Non-Layer Items" has been renamed "Items not on Layers". By unchecking this setting, all objects that are not associated with any CINEMA 4D Layers will be turned off.
  • Resizable dialog windows - The CINEMA 4D Layers and Cineware Settings dialogs have been updated so they can be resized as needed.

Miscellaneous updates

Removal of Memory and Multiprocessing preference

The Multiprocessing preference has been removed due to the inclusion of new threading architecture in After Effects CC 2015. The preference that was earlier named Memory and Multiprocessing is now named only Memory.

The Composition > Cache Work Area In Background command was dependent on the Multiprocessing feature. This functionality has been removed.

 

  • Brainstorm has been removed in After Effects CC 2015. You can still use Brainstorm in After Effects CC 2014 and earlier versions/releases.
    You can read about using Brainstorm in AFter Effects in the Use Brainstorm to experiment and explore settings article.
  • RED camera raw (.r3d) file decoding has been updated with the newest RED SDK. New functionality includes Dragon Enhanced Blacks, REDcolor4, and DRAGONcolor 2.

 


This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy