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Legal notices
For legal notices, see http://help.adobe.com/en_US/legalnotices/index.html.

A note to our customers
Adobe provides this searchable PDF of archived technical support documents as a service to our 
customers who own and continue to enjoy older, unsupported versions of our software products. The 
information in these documents is not updated, and will become increasingly less accurate as 
hardware, browsers, and operating systems continue to evolve. Please be aware that these archived 
documents reflect historical issues and solutions for products that are no longer supported. Adobe 
does not warrant that the information in this document is accurate.
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Supported file formats | After Effects CS4
What's covered

• Supported import and export file formats 

• Supported CMYK file formats 

• Supported 16-bpc and 32-bpc file formats 

• Obtain support for additional formats and codecs 

This document lists the file formats which Adobe After Effects CS4 can import and export. Third-party plug-ins are 
available to extend these capabilities, see the "Obtain support for additional formats and codecs" section of this 
document for more information. 

Note: In order for After Effects to import a QuickTime or AVI file, the codec that a particular file uses must be installed 
on the computer. (Common codecs are installed by both QuickTime and Video For Windows.) If you receive an error 
message or the video does not display correctly, you may need to install the codec used by the file. For more information 
about the codec in use, contact the manufacturer of the software or hardware used to create the file. You can read more 
about codecs and digital video file formats in the Adobe Video and Audio Primers. 

Important: QuickTime is required to import and export some file formats on Windows. You can download the latest 
version of QuickTime from the Apple web site at http://www.apple.com/quicktime. 

Most file formats are rendered from After Effects by adding the composition to the render queue; see Render and 
export a movie using the render queue. Some formats are only available through the File > Export menu; see Render 
and export a movie using QuickTime components. 

Supported import and export file formats

Supported audio file formats

Supported still image file formats

Note: You can import files of any still image format as a sequence. See Preparing and Importing still images in After 
Effects help. 

 Format Import/Export support Format Details 

Advanced Audio Coding (AAC, M4A) Import and Export 

Adobe Sound Document (ASND) Import only 

AU audio file (AU) Export only Requires QuickTime on Windows 

Audio Interchange File Format (AIF, AIFF) Import and Export 

MP3 (MP3, MPEG, MPG, MPA, MPE) Import and Export 

Waveform (WAV) Import and Export 

http://helpx.adobe.com/after-effects/kb/#main_head1
http://helpx.adobe.com/after-effects/kb/#main_head2
http://helpx.adobe.com/after-effects/kb/#main_head3
http://helpx.adobe.com/after-effects/kb/#main_head4
http://www.adobe.com/motion/primers.html
http://www.apple.com/quicktime
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79f0a.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79f0a.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79b5a.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79b5a.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103906c6dea-7f7ca.html
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Supported video and animation file formats

Format Import/Export support Format Details 

Adobe Illustrator (AI, EPS, PS) Import only Continuously rasterized 

Adobe PDF (PDF) Import only First page only, continuously rasterized. 

Adobe Photoshop (PSD) Import and Export 8-, 16-, and 32-bpc 

Bitmap (BMP, RLE, DIB) Import only 

Camera raw (TIF, CRW, NEF, RAF, ORF, MRW, 
DCR, MOS, RAW, PEF, SRF, DNG, X3F, CR2, ERF) 

Import only 

Cineon (CIN, DPX) Import and Export Converts to projectâs color bit depth: 8-, 16-, 
or 32-bpc 

CompuServe GIF (GIF) Import and Export 

Discreet RLA/RPF (RLA, RPF) Import only 16-bpc, imports camera data 

ElectricImage IMAGE (IMG, EI) Import and Export 

Encapsulated PostScript (EPS) Import only 

IFF (IFF, TDI) Import and Export 

JPEG (JPG, JPE) Import and Export 

Maya IFF (IFF, TDI) Import and Export 16-bpc 

Maya camera data (MA) Import only 

OpenEXR (EXR) Import and Export 32-bpc3D Channel effect plug-ins from fnord 
software are included with After Effects to 
provide access to multiple layers and channels 
of OpenEXR files. (See Using channels in 
OpenEXR files in After Effects help. 

PCX (PCX) Import only Windows only 

PICT (PCT) Import and Export 

Pixar (PXR) Import only 

Portable Network Graphics (PNG) Import and Export 16-bpc 

Radiance (HDR, RGBE, XYZE) Import and Export 32-bpc 

SGI (SGI, BW, RGB) Import and Export 16-bpc 

Softimage (PIC) Import only 

Targa (TGA, VDA, ICB, VST) Import and Export 

TIFF (TIF) Import and Export 8- and 16-bpc 

 Format Import/Export support Format Details 

3GPP (3GP, 3G2, AMC) Import and Export Requires QuickTime on Windows 

Adobe Flash Player (SWF) Import and Export Note: SWF files are imported with an alpha 
channel. Interactive content is not retained. 

Adobe Flash Professional (XFL) Import and Export 

Adobe Flash Video (FLV, F4V) Import and Export 

http://help.adobe.com/en_US/AfterEffects/9.0/WS3E78212A-C902-4d74-9FE6-C0E98E602AAA.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3E78212A-C902-4d74-9FE6-C0E98E602AAA.html
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Supported project file formats

Adobe Photoshop with video layers (PSD) Import and Export Requires QuickTime on Windows 

Animated GIF (GIF) Import and Export 

AVCHD (M2TS) Import only 

DV Import and Export In MOV or AVI container, or as container-less 
DV stream; requires QuickTime on Windows 

ElectricImage (IMG, EI) Import and Export 

Filmstrip (FLM) Import and Export 

Flic Animation (FLC) Export only 

H.264 (M4V) Import and Export 

Media eXchange Format (MXF) Import only MXF is a container format. After Effects can 
only import some kinds of data contained 
within MXF files. After Effects can import the 
Op-Atom variety used by Panasonic DV, 
DVCPRO, DVCPRO50, and DVCPRO HD video 
cameras to record to Panasonic P2 media. 
After Effects can also import XDCAM HD files 
in MXF format. 

MPEG-1 (MPG, MPE, MPA, MPV, MOD) Import only 

MPEG-2 (MPG, M2P, M2V, M2P, M2A, M2T) Import and Export Windows and Mac OS on Intel-based Mac 
only. Some MPEG data formats are stored in 
container formats with filename extensions 
that are not recognized by After Effects; 
examples include .vob and .mod. In some 
cases, you can import these files into After 
Effects after changing the filename extension 
to one of the recognized filename extensions. 
Because of variations in implementation in 
these container formats, compatibility is not 
guaranteed. 

MPEG-4 (MP4, M4V) Import and Export 

Open Media Framework (OMF) Import and Export Raw media [or essence] only; Windows only) 

QuickTime (MOV) Import and Export QuickTime required on Windows 

Video for Windows (AVI) Import and Export Implemented via QuickTime on Mac OS 

Windows Media (WMV, WMA) Import and Export Windows only 

XDCAM HD and XDCAM EX (MXF, MP4) Import only After Effects can import Sony XDCAM HD 
assets if they were recorded to MXF files. After 
Effects cannot import XDCAM HD assets in 
IMX format. After Effects can import Sony 
XDCAM EX assets stored as essence files with 
the .mp4 filename extension in a BPAV 
directory. For information about the XDCAM 
format, see the XDCAM White paper pdf on 
the Sony website. 

http://pro.sony.com/bbsccms/assets/files/micro/xdcam/articles/XDCAM_WhitePaper_F.pdf


4

Last updated 10/30/2015

Supported other file formats

Supported CMYK file formats

 After Effects CS4 can import Adobe Photoshop (.PSD), Adobe Illustrator (.AI), and Encapsulated PostScript (.EPS) 
files that use the CMYK color space. After Effects will convert the CMYK color values to RGB. 

Note: After Effects cannot assign an input color profile to files that use non-RGB color spaces, such as CMYK. Color 
management on CMYK files is therefore limited. To effectively color manage CMYK files you should convert them to 
RGB before you import them into After Effects. For more information, see Interpret a footage item by assigning an 
input color profile. 

Supported 16-bpc and 32-bpc file formats

 While After Effects can operate in 16 and 32 bits per channel, most video and animation file formats and codecs 
support only 8-bpc. Typical cross-application workflows for higher bit-depth color involve rendering to a still image 
sequence rather than a video or animation file. Still image formats that support 16-bpc that After Effects can render to 
include PSD, PNG, TIFF, IFF, and SGI. Formats that support 32-bpc include PSD, EXR, HDR, and TIFF. 

Video codecs that support 10-bpc are provided with hardware such as a capture card or software such as Adobe 
Premiere Pro. You can import 10-bpc uncompressed YUV AVI files created in Adobe Premiere Pro into 16-bpc RGB 
After Effects projects. You can also render from After Effects with 10-bpc YUV compression. (See Specify Video for 
Windows compression options.) 

Obtain support for additional formats and codecs

 You can add support for additional file formats to After Effects by installing a third-party plug-in. For example, the Pro 
Import AE plug-in from Automatic Duck, Inc. allows you to import project files from popular non-linear editing 
applications into After Effects. You can find a list of software developers that make plug-ins for After Effects on the 
Adobe web site at http://www.adobe.com/products/plugins/aftereffects/. 

Similarly, you can add support to After Effects for additional video codecs by installing the codec on your system. Most 
codecs must be installed into the operating system (Windows or Mac OS) and work as a component inside the 
QuickTime or Video For Windows formats. Codecs are available for a variety of hardware (capture card, camera, etc.) 
and software workflows. Contact the manufacturer of your hardware or software for more information about codecs 
that work with the files that your specific device or application creates. 

 Format Import/Export support Format Details 

Advanced Authoring Format (AAF) Import only Windows only 

Adobe After Effects 5 and later binary projects 
(AEP, AET) 

Import and Export 

Adobe After Effects CS4 XML Project (AEPX) Import and Export 

Adobe Premiere 6.0 and 6.5 (PPJ) Import only 

Adobe Premiere Pro 1.0, 1.5, 2.0, CS3, CS4 
(PRPROJ) 

Import and Export 1.0, 1.5, and 2.0 Windows only 

 Format Import/Export support Format Details 

Adobe Clip Notes (PDF) Export only 

XML Forms Data Format (XFDF) Import only For importing Adobe Clip Notes comments. 

Maya Scene camera data (MA) Import only 

http://help.adobe.com/en_US/AfterEffects/9.0/WSF97D54F0-EBD5-4db1-BD4C-D5AD36A2AABBa.html
http://help.adobe.com/en_US/AfterEffects/9.0/WSF97D54F0-EBD5-4db1-BD4C-D5AD36A2AABBa.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79b0a.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79b0a.html
http://automaticduck.com/
http://www.adobe.com/products/plugins/aftereffects/
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Note: After Effects may not be compatible with all codecs. Test codecs that you intend to use before implementing them 
in your workflow. 

If you intend to render your composition using multiple computers over a network, then any third-party plug-ins or 
codecs used by your project must be installed on each computer in the render farm. See Network rendering with watch 
folders and render engines for more information about network rendering. 

QuickTime movies too dark, light | After Effects CS3

Issue
When you render or export a QuickTime movie from Adobe After Effects CS3, the image is darker or lighter than your 
composition in After Effects.

Solution
 Do one of the following solutions: 

Solution: Install the After Effects CS 8.0.2 update.
 Download the update from the Adobe website at www.adobe.com/support/downloads. 

Solution 2: Enable the Match Legacy After Effects QuickTime Gamma Adjustments option in 
the Project Settings.
 If your workflow uses the QuickTime movie exported from After Effects in Apple QuickTime Player, Apple Final Cut 
Pro, or other Apple products, then the Match Legacy After Effects QuickTime Gamma Adjustments option in the 
Project Settings will produce a better match between the exported QuickTime movie and your composition in After 
Effects. This solution can also produce a better match if you intend to directly distribute the exported QuickTime 
movie, such as via a web page. 

Note: This option changes the QuickTime import and export behavior of After Effects to be the same as in After Effects 
7.0 and earlier. Some advanced features of After Effects CS3 will become disabled when this option is enabled. Read the 
Additional Information section below for further details. 

To enable the Match Legacy After Effects QuickTime Gamma Adjustments option: 

1 Choose File > Project Settings.

2 In the Color Settings box, enable the Match Legacy After Effects QuickTime Gamma Adjustments option.

3  Click OK. 

Solution 3: Enable color management in After Effects and use a color managed workflow.
 Color management ensures that color and tones in your movies remains consistent and predictable between 
applications and devices. Color management will benefit any video workflow, and it can specifically improve the color 
and tone of your video if you use a YUV codec (such as a DV or v210 codec) and you use the QuickTime movie 
exported from After Effects in other video editing applications (such as Apple Final Cut Pro). 

http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79a2a.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79a2a.html
http://www.adobe.com/support/downloads
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For information on how to enable color management in After Effects and on color management workflows, see the 
Color Management section of After Effects Help and the Color Management Workfow in Adobe After Effects CS3 
guide at the Adobe Design Center. 

Additional Information
 Most video codecs require some gamma adjustment to look correct on a computer monitor. This is a form of color 
management. The specific amount of gamma adjustment required to make a video file look correct depends on the 
given codec, the operating system (Mac OS and Windows assume different default gamma values), and any adjustments 
made to the system's color management settings (for example, Apple ColorSync on Mac OS). 

When QuickTime Player displays a movie file, it adjusts the gamma in order to make the image look correct. QuickTime 
Player bases the amount of gamma adjustment on the codec in use (if the file is not tagged with a specific gamma value). 
However, the gamma adjustments that QuickTime Player makes are not consistent between Mac OS and Windows, 
meaning that the same file may not look the same in QuickTime Player on Mac OS and Windows. 

Note: On Windows, the result may be dependent on whether QuickTime Player is set to display through DirectX or 
Safe Mode (GDI). Refer to the documentation for QuickTime for more information about QuickTime settings. 

In order to provide consistency between platforms, After Effects CS3 adds a metadata tag to exported QuickTime movie 
files that specifies what gamma adjustment to use. When this tag is present, QuickTime Player uses that value instead 
of what it normally would use for that codec, and the resulting adjustment is consistent between Mac OS and Windows. 

The value that After Effects CS3 uses for this tag is always 2.2. This value is correct for most YUV codecs such as DV 
and v210. However, for RGB codecs, 2.2 is not often the correct value. This means that files that use RGB codecs (such 
as Animation or None) are over-corrected and look washed out or too light. 

The After Effects CS3 8.0.2 update changes the behavior so that After Effects only reads and writes the gamma tag with 
specific YUV codecs. In most cases, the update will resolve the gamma problems discussed in this document. The 
codecs that After Effects will use the gamma tag with are defined in a file, MediaCoreQTGammaRules.xml. If you use 
a codec that is not in the MediaCoreQTGammaRules.xml file and you want After Effects to read and write the gamma 
tag to files that use this codec, you can edit the file to include your codec. The file is located in the following folder: 

• Mac OS: Users/<username>/Library/Application Support/Adobe/Common 

• Windows XP: Documents and Settings\<username>\Application Data\Adobe\Common 

• Windows Vista: Users\<username>\AppData\Roaming\Adobe\Common 

If you enable the Match Legacy After Effects QuickTime Gamma Adjustments option in the Project Settings in After 
Effects CS3, then it will not tag QuickTime files with the metadata tag when it renders them.That optionalso disables 
other QuickTime handling behaviors that are new to After Effects CS3, such as the ability to preserve overbright pixel 
values in QuickTime files in a 32-bpc project. For detailed information, read About Gamma and Tone Response in 
After Effects Help 

How QuickTime Player displays a movie file may not be relevant to your workflow. Other video editing and motion 
graphics applications typically use their own methods to determine the gamma value of a file or they can adjust the 
value. Adobe Premiere Pro CS3, for example, interprets QuickTime files in the same way that After Effects CS3 does; 
the appearance of QuickTime files is consistent between the applications. Other applications may require that you 
change the preferences or choose an interpretation option when the QuickTime file is imported. Consult the 
documentation for your specific application for more information. 

http://livedocs.adobe.com/en_US/AfterEffects/8.0/help.html?content=WS44E9CED2-117D-4c19-879E-D553BB88B886.html
http://www.adobe.com/designcenter/aftereffects/articles/aftcs3ip_colrmanage/aecolor_management.pdf
http://livedocs.adobe.com/en_US/AfterEffects/8.0/help.html?content=WS44E9CED2-117D-4c19-879E-D553BB88B886.html


7

Last updated 10/30/2015

Regardless of which video editing or motion graphics applications you use, the best way to ensure consistent tone 
response (gamma) and color results is to use a color-managed workflow. A color-managed workflow ensures that the 
colors you see on your computer screen will be consistent between applications, and consistent with your output and 
different devices. For more information on the benefits of color management and how to set up a color-managed 
workflow, read the Color Management Workfow in Adobe After Effects CS3 guide at the Adobe Design Center. 

Known issues with After Effects CS4 on Mac OS X 10.6 
(Snow Leopard)
Apple has released version 10.6 (Snow Leopard) of their Mac OS X operating system. This document tracks the known 
issues that Adobe After Effects users are most likely to encounter while running After Effects CS4 in Snow Leopard. 

Note: It is important to install the latest update for After Effects CS4 (version 9.0.2). You can update After Effects from 
another Adobe CS4 application (Bridge, Premiere Pro, and so on) or download an update from the Adobe support 
website.

Known issues

Plugin Compatibility
• Some third-party plug-ins are not compatible with Adobe After Effects CS4 running on Snow Leopard. Currently, 

this issue only applies to plug-ins that use Quartz Composer. Customers are encouraged to check plug-in 
compatibility before upgrading. Also, on Snow Leopard, QuickTime files with a Quartz Composer track are not 
compatible with After Effects CS4. 

• A table listing plug-ins and their compatibility with Snow Leopard is being maintained at Toolfarm 
(www.toolfarm.com). Note: This link is provided as a courtesy only. Adobe does not monitor the site or verify the 
information provided.

Application Compatibility
• Render Multiple Frames Simultaneously (under Preferences > Memory & Multiprocessing) does not work properly 

in After Effects CS4 (9.0.0) on Mac OS X v10.6.

• After Effects CS4 (9.0.0) may freeze or hang on startup after you upgrade to Mac OS X v10.6. 

Solution
Update After Effects to version 9.0.2. 

Rosetta required
After Effects bounces in the Dock, but does not start.

Note: This issue can occur after a clean installation of Snow Leopard.

Solution: After Effects requires Rosetta to be installed. Rosetta is an optional install on the Snow Leopard disk. After 
Rosetta is installed, users typically have to restart their computers a few times to remove the missing component flag 
that prevents After Effects from starting successfully.

http://www.adobe.com/designcenter/aftereffects/articles/aftcs3ip_colrmanage/aecolor_management.pdf
http://www.adobe.com/downloads/updates/
http://www.toolfarm.com/plugins/index.php/Mac_OSX_Snow_Leopard_Compatibility
http://www.toolfarm.com
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Language Support
It is no longer possible to run After Effects in another language by using the Finder Get Info dialog to deselect 
languages. The Language section has been removed from the Get Info dialog box.

Gamma change
Apple changed the default gamma from 1.8 to 2.2 in Snow Leopard. Although this is not an After Effects issue, it 
sometimes affects the appearance of After Effects projects. For more information on this change in gamma values, see 
this article on the Apple support site.

Additional information
After Effects CS3 has also been tested with Snow Leopard and has the same issues as CS4.

Note: CS3 preceded Snow Leopard by a few years and Adobe no longer issues updates for After Effects CS3.

 

Error "Could not convert Unicode characters" | After 
Effects

Issue
The following error occurs when you start or use After Effects CS3, CS4, or CS5:

"After Effects error: Could not convert Unicode characters. (23::46)"

Solutions

Solution 1: Use single-byte characters for filenames, paths, and hard disks.
Change instances of multibyte characters (such as Chinese, Hebrew, or Japanese characters) to single-byte characters 
(such as English characters). 

Solution 2: Replace the AMT.zdct file for the target language.

Mac OS
1 Open the Applications/Adobe After Effects CS5 (or CS3 or CS4) folder.

Right-click the Adobe After Effects CS4 application icon and choose Show Package Contents.

Open the Content/Resources/AMT Languages folder.

Note the name of the .txt file in this folder, which is the code for the language that After Effects was installed in. This 
language is the target language. For example, US English is en_US, Turkish is tr_TR, Russian is ru_RU, and so on. A list 
of commonly used language codes is available here.

Go back to the Resources folder and open the AMT folder.

http://support.apple.com/kb/HT3712
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Open the folder named with the target language code you identified in step 4.

Place a tilde character (~) at the beginning the AMT.zdct filename. This step causes After Effects to ignore the file, but 
preserves this file as a backup.

Go back to the AMT folder and open the folder for en_US. (You can also choose other languages that are unaffected by 
this problem, such as fr_FR for French or es_ES for Spanish.)

Copy the AMT.zdct file from this folder to the target language folder, from step 6. To copy the file, hold down the 
Option key while dragging it from one folder to the other. Or, select the file and choose File > Duplicate, then move the 
file to the other folder and remove "Copy" from the end of the filename.

Launch After Effects.

Windows
1 Open the Program Files\Adobe\Adobe After Effects CS4 (or CS3)\Support Files\AMT Languages folder.

Note the name of the .txt file in this folder, which is the code for the language that After Effects was installed in. This 
language is the target language. For example, US English is en_US, Turkish is tr_TR, Russian is ru_RU, and so on. A list 
of commonly used language codes is available here. 

Go back to the Support Files folder and then open the AMT folder.

Open the folder named with the target language code you identified in step 2.

Place a tilde character (~) at the beginning the AMT.zdct filename. This step causes After Effects to ignore the file, but 
preserves this file as a backup.

Go back to the AMT folder and open the folder for en_US. (You can also choose other languages that are unaffected by 
this problem, such as fr_FR for French or es_ES for Spanish.)

Copy the AMT.zdct file from this folder to the target language folder, from step 4. Select the file, choose Edit > Copy, 
navigate back to the target language folder, and choose Edit > Paste.

Launch After Effects. 

Additional information
The AMT.zdct files contain text phrases for menu items that are translated for specific languages. A problem in After 
Effects prevents it from translating special characters used in some languages correctly if the OS language does not 
support those characters.

After Effects was installed in a language that uses a non-Roman Unicode or Cyrillic character set on an OS that doesn't 
match the language. For example, you installed After Effects in Turkish on an English OS.

Affected languages include:

• Arabic

• Chinese, Simplified

• Chinese, Traditional

• Greek

• Hebrew

• Japanese

• Korean
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• Romanian

• Russian

• Turkish

• Ukrainian
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