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Troubleshoot OpenGL problems | After Effects CS4-
CS5.5
Note: OpenGL functionality in After Effects CS6 is different from OpenGL functionality in previous versions. This 
document is only for After Effects CS4 through CS5.5. For more information about After Effects CS6 GPU functionality, 
see this video.

This document can help you to resolve problems related to OpenGL that occur while you use After Effects. OpenGL 
problems can manifest in many different ways, including (but not limited to) the following:

• Adobe After Effects crashes or closes without an error while it starts.

• A crash or freeze when you scrub the timeline or preview or render a composition.

• A crash when you change the settings of an effect while OpenGL previews are enabled.

• A crash or freeze when you enable or disable OpenGL previews.

• The composition window takes a long time to redraw.

• Artifacts or blocks of "garbage" pixels are drawn in the composition window.

• The composition window is drawn differently between when OpenGL previews are on and off.

• An error message such as one of the following: " After Effects warning: A problem occurred when processing 
OpenGL commands." "The instruction at '0x00fe1940' referenced memory at '0x000000000' The memory could not 
be 'read'." "AE_OpenGL: failed to generate shadow map (5065::0)" "This composition is too complex for the 
OpenGL hardware." "After Effects error: AE_OpenGL: Create texture error. (5065 :: 0)"

For information about how to configure the preview preferences in After Effects for OpenGL and a list of features in 
After Effects that can be rendered with OpenGL, see Render With OpenGL in After Effects Help.

To benefit most from this document, perform the tasks in order. Record the tasks that you perform and the results of 
each, including errors and other problems. Adobe Technical Support can use this information to better assist you if you 
call.

It's necessary to log on as an administrator to perform some of the procedures in this document.

For Windows, some of these procedures require you to locate hidden files and hidden folders. Some procedures require 
you to locate files by their full filenames, which include extensions (for example, example_filename.ini). By default, 
Windows Explorer doesn't show hidden files, hidden folders, and filename extensions that it recognizes. See the 
following document for details:

• Show hidden files, hidden folders, filename extensions | Windows XP, Vista, Windows 7 (kb402324).

For Windows Vista, the steps in this document that mention the Control Panel are in reference to the Classic view. For 
information on switching the Control Panel to the Classic view and many other common OS procedures, see Common 
Microsoft Windows Vista procedures (kb401275).

http://www.video2brain.com/en/lessons/system-requirements-for-gpu-acceleration-opengl-cuda
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79e8a.html
http://www.adobe.com/go/kb404856
http://www.adobe.com/go/kb401275
http://www.adobe.com/go/kb401275


2

Last updated 10/30/2015

These tasks can help you resolve the most common problems with OpenGL. Before performing any of these tasks, back 
up all personal files (for example, After Effects files you created). Always restart the computer after a system error 
occurs to refresh its memory. Continuing to work without restarting the computer can compound the problem.

1. Update to the most recent version of After Effects

To check for updates, choose Help > Updates in After Effects. 

To download updates, see After Effects for Mac OS or After Effects for Windows.

2. Make sure that the computer system meets the minimum requirements for After Effects.

See this page for a list of system requirements for After Effects: Adobe After Effects system requirements

3. Make sure that the video card and drivers meet the OpenGL requirements.

Using OpenGL in After Effects requires an OpenGL card that supports OpenGL 2.0.

To determine what version of OpenGL your card supports, click the OpenGL Info button in the Preview preferences. 
On Mac OS, choose After Effects > Preferences > Previews. On Windows, choose Edit > Preferences > Previews.

For information regarding supported OpenGL hardware, visit the After Effects OpenGL support page on the Adobe 
website.

Newer video card drivers can improve the OpenGL capabilities of your card. See solution 6: Update the video card 
driver.

4. Disable OpenGL to determine whether it is causing the problem.

To disable OpenGL previews:

1 Choose After Effects > Preferences > Previews (Mac OS) or Edit > Preferences > Previews (Windows).

2 Deselect the Enable OpenGL option.

Note: OpenGL does not support some features in After Effects, and the appearance of your composition can change 
between using OpenGL previews and software-rendered previews. For the list features that OpenGL supports, see 
Render With OpenGL in the Rendering and Exporting section of After Effects Help.

5. Remove the OpenGL plug-in from the After Effects plug-ins folder.

To determine if OpenGL caused the problem, remove the OpenGL plug-in and restart After Effects.

To remove the OpenGL plug-in:

1 Quit After Effects.

2 Mac OS: Drag the AE_OpenGL.plugin file from the Applications/Adobe After Effects CS4/Plug-ins/Extensions 
folder to the desktop. Windows: Drag the AE_OpenGL.AEX file from the C:\Program Files\Adobe\Adobe After 
Effects CS4\Support Files\Plug-ins\Extensions folder to the desktop.

3 Restart After Effects.

If the problem recurs, OpenGL didn't cause it. Drag the OpenGL plug-in back to the original location. If the problem 
doesn't recur, the cause of the problem is OpenGL. See solution 6: Update the video card driver.

6. Update the video card driver.

Many OpenGL problems or conflicts are solved by updating the video card driver. Many video card manufacturers 
frequently update their software drivers. If you haven't recently updated the video card driver, contact the video card 
manufacturer for an updated driver, or download one from the manufacturer's website.

7. Restart After Effects and test the behavior that caused the crash. (Windows only)

http://www.adobe.com/support/downloads/product.jsp?product=13&platform=Macintosh
http://www.adobe.com/support/downloads/product.jsp?product=13&platform=Windows
http://www.adobe.com/products/aftereffects/systemreqs/
http://www.adobe.com/go/learn_ae_openglsupport
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79e8a.html
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Following a crash that an OpenGL problem on Windows causes, After Effects CS4 can automatically disable the Prevent 
DLL Address Space Fragmentation preference. This preference allows After Effects to access a larger amount of 
contiguous RAM, but can be incompatible with some OpenGL drivers.

You can enable or disable the Prevent DLL Address Space Fragmentation preference by going to Edit > Preferences > 
Memory & Cache.

Leave this preference enabled unless you are experiencing OpenGL or memory-related crashes. If you disable the 
preference because of an OpenGL problem, and you later update the video card drivers, reenable the preference. Then, 
test the problem again.

8. Optimize the Texture Memory preference.

Crashes or OpenGL errors can occur if After Effects attempts to use too much video texture memory. Texture memory 
is the amount of RAM on the video card (VRAM).

Set the Texture Memory preference in After Effects:

1 Multiply the total installed VRAM by 80% to calculate the optimal Texture Memory setting.

2 In After Effects, choose After Effects > Preferences >Previews (Mac OS) or Edit > Preferences > Previews 
(Windows).

3 Click OpenGL Info.

4 Enter the value you calculated in Step 1, then click OK.

The ideal value for texture memory is 80% of the VRAM on your video card. (If you use multiple video cards, calculate 
80% of the VRAM on the video card that is identified in the OpenGL Information dialog box.) If the Texture Memory 
preference in After Effects is set to more than 80% of the VRAM, it's possible that not enough VRAM is left for the 
video card to handle the user interface or other tasks. (For example, the entire screen can turn white.) If the value is set 
to less than 80%, OpenGL previews in After Effects can take longer to process frames.

See Mac OS Help or Windows Help for information about determining the amount of VRAM on a video card.

9. Purge the image caches and video memory.

If After Effects displays artifacts or "garbage" (blocks of incorrect pixels) in the composition window, the video memory 
(VRAM) could be full, fragmented, or corrupted. Purge the image caches and video memory to empty the VRAM and 
let After Effects rebuild the composition preview.

To purge the image caches, choose Edit > Purge > Image Caches.

To purge the video memory, choose Edit > Purge > Video Memory.

Note: Some screen savers that use OpenGL (or Direct3D on Windows) can corrupt the video memory if they activate 
while After Effects is running. Change or disable the screen saver if you frequently have problems with corrupted 
images in the composition window after turning off the screen saver.

10. Change the color setting for the video card to Highest (32 bit) (Windows) or Millions (Mac OS).

See Mac OS Help or Windows Help for information about changing the video card or display settings.

11. Disable advanced functions of the video card. (Windows only)

Most display card drivers include utilities that allow you to access advanced functions of the card. In particular, anti-
aliasing, and 16-bit mode functions can conflict with OpenGL and cause After Effects to crash. Set the advanced 
functions of the card to their defaults, then disable the anti-aliasing and 16-bit mode options.

If you are using multiple monitors with an Nvidia card, set the Multimonitor setting to "Compatible".
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See the documentation for the video card or to the manufacturer's website for instructions on how to access its 
advanced functions.

12. Use a single monitor.

If you are using multiple monitors and experience problems with OpenGL in After Effects, try the following:

• If you have placed the After Effects application window or the Composition panel on a secondary monitor, move 
the window to the primary monitor.

• Disconnect all but one monitor.

• If you are using multiple display cards, remove all but one display card. For best results with OpenGL, use a single 
dual-head display card.

13. Place the Reduce OpenGL Texture Size script in the Startup scripts folder.

The Reduce OpenGL Texture Size script reduces the amount of texture memory After Effects uses and can provide 
better compatibility with older video cards.

To place the Reduce OpenGL Texture Size script in the Startup scripts folder:

1 Navigate to the After Effects scripts folder. On Mac OS: Applications/Adobe After Effects CS4/Scripts. On Windows: 
C:\Program Files\Adobe\Adobe After Effects CS4\Support Files\Scripts.

2 Move the Reduce OpenGL Texture Size.jsx file from the (support) folder to the Startup folder.

A newer video card can improve the OpenGL capabilities of your computer and make the script unnecessary. After you 
install a new card and its drivers, move the Reduce OpenGL Texture Size script back to the (support) folder. Then reset 
the After Effects preferences.

14. Reset After Effects preferences.

Re-create the After Effects preferences file to eliminate problems that damaged OpenGL preferences can cause.

To re-create the After Effects preferences file, restart After Effects. Hold Ctrl+Alt+Shift (Windows) or 
Command+Option+Shift (Mac OS) while the application is starting.

15. Contact Adobe Technical Support.

If none of the above steps has resolved the error or freeze that you are experiencing with After Effects, then contact 
Adobe Technical Support. You can find the support options at the Support Center.

 

Supported file formats | After Effects CS4
What's covered

• Supported import and export file formats 

• Supported CMYK file formats 

• Supported 16-bpc and 32-bpc file formats 

• Obtain support for additional formats and codecs 

This document lists the file formats which Adobe After Effects CS4 can import and export. Third-party plug-ins are 
available to extend these capabilities, see the "Obtain support for additional formats and codecs" section of this 
document for more information. 

http://www.adobe.com/support/
http://helpx.adobe.com/after-effects/kb/#main_head1
http://helpx.adobe.com/after-effects/kb/#main_head2
http://helpx.adobe.com/after-effects/kb/#main_head3
http://helpx.adobe.com/after-effects/kb/#main_head4
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Note: In order for After Effects to import a QuickTime or AVI file, the codec that a particular file uses must be installed 
on the computer. (Common codecs are installed by both QuickTime and Video For Windows.) If you receive an error 
message or the video does not display correctly, you may need to install the codec used by the file. For more information 
about the codec in use, contact the manufacturer of the software or hardware used to create the file. You can read more 
about codecs and digital video file formats in the Adobe Video and Audio Primers. 

Important: QuickTime is required to import and export some file formats on Windows. You can download the latest 
version of QuickTime from the Apple web site at http://www.apple.com/quicktime. 

Most file formats are rendered from After Effects by adding the composition to the render queue; see Render and 
export a movie using the render queue. Some formats are only available through the File > Export menu; see Render 
and export a movie using QuickTime components. 

Supported import and export file formats

Supported audio file formats

Supported still image file formats

Note: You can import files of any still image format as a sequence. See Preparing and Importing still images in After 
Effects help. 

 Format Import/Export support Format Details 

Advanced Audio Coding (AAC, M4A) Import and Export 

Adobe Sound Document (ASND) Import only 

AU audio file (AU) Export only Requires QuickTime on Windows 

Audio Interchange File Format (AIF, AIFF) Import and Export 

MP3 (MP3, MPEG, MPG, MPA, MPE) Import and Export 

Waveform (WAV) Import and Export 

Format Import/Export support Format Details 

Adobe Illustrator (AI, EPS, PS) Import only Continuously rasterized 

Adobe PDF (PDF) Import only First page only, continuously rasterized. 

Adobe Photoshop (PSD) Import and Export 8-, 16-, and 32-bpc 

Bitmap (BMP, RLE, DIB) Import only 

Camera raw (TIF, CRW, NEF, RAF, ORF, MRW, 
DCR, MOS, RAW, PEF, SRF, DNG, X3F, CR2, ERF) 

Import only 

Cineon (CIN, DPX) Import and Export Converts to projectâs color bit depth: 8-, 16-, 
or 32-bpc 

CompuServe GIF (GIF) Import and Export 

Discreet RLA/RPF (RLA, RPF) Import only 16-bpc, imports camera data 

ElectricImage IMAGE (IMG, EI) Import and Export 

Encapsulated PostScript (EPS) Import only 

IFF (IFF, TDI) Import and Export 

JPEG (JPG, JPE) Import and Export 

http://www.adobe.com/motion/primers.html
http://www.apple.com/quicktime
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79f0a.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79f0a.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79b5a.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79b5a.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103906c6dea-7f7ca.html
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Supported video and animation file formats

Maya IFF (IFF, TDI) Import and Export 16-bpc 

Maya camera data (MA) Import only 

OpenEXR (EXR) Import and Export 32-bpc3D Channel effect plug-ins from fnord 
software are included with After Effects to 
provide access to multiple layers and channels 
of OpenEXR files. (See Using channels in 
OpenEXR files in After Effects help. 

PCX (PCX) Import only Windows only 

PICT (PCT) Import and Export 

Pixar (PXR) Import only 

Portable Network Graphics (PNG) Import and Export 16-bpc 

Radiance (HDR, RGBE, XYZE) Import and Export 32-bpc 

SGI (SGI, BW, RGB) Import and Export 16-bpc 

Softimage (PIC) Import only 

Targa (TGA, VDA, ICB, VST) Import and Export 

TIFF (TIF) Import and Export 8- and 16-bpc 

 Format Import/Export support Format Details 

3GPP (3GP, 3G2, AMC) Import and Export Requires QuickTime on Windows 

Adobe Flash Player (SWF) Import and Export Note: SWF files are imported with an alpha 
channel. Interactive content is not retained. 

Adobe Flash Professional (XFL) Import and Export 

Adobe Flash Video (FLV, F4V) Import and Export 

Adobe Photoshop with video layers (PSD) Import and Export Requires QuickTime on Windows 

Animated GIF (GIF) Import and Export 

AVCHD (M2TS) Import only 

DV Import and Export In MOV or AVI container, or as container-less 
DV stream; requires QuickTime on Windows 

ElectricImage (IMG, EI) Import and Export 

Filmstrip (FLM) Import and Export 

Flic Animation (FLC) Export only 

H.264 (M4V) Import and Export 

Media eXchange Format (MXF) Import only MXF is a container format. After Effects can 
only import some kinds of data contained 
within MXF files. After Effects can import the 
Op-Atom variety used by Panasonic DV, 
DVCPRO, DVCPRO50, and DVCPRO HD video 
cameras to record to Panasonic P2 media. 
After Effects can also import XDCAM HD files 
in MXF format. 

http://help.adobe.com/en_US/AfterEffects/9.0/WS3E78212A-C902-4d74-9FE6-C0E98E602AAA.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3E78212A-C902-4d74-9FE6-C0E98E602AAA.html
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Supported project file formats

Supported other file formats

Supported CMYK file formats

 After Effects CS4 can import Adobe Photoshop (.PSD), Adobe Illustrator (.AI), and Encapsulated PostScript (.EPS) 
files that use the CMYK color space. After Effects will convert the CMYK color values to RGB. 

MPEG-1 (MPG, MPE, MPA, MPV, MOD) Import only 

MPEG-2 (MPG, M2P, M2V, M2P, M2A, M2T) Import and Export Windows and Mac OS on Intel-based Mac 
only. Some MPEG data formats are stored in 
container formats with filename extensions 
that are not recognized by After Effects; 
examples include .vob and .mod. In some 
cases, you can import these files into After 
Effects after changing the filename extension 
to one of the recognized filename extensions. 
Because of variations in implementation in 
these container formats, compatibility is not 
guaranteed. 

MPEG-4 (MP4, M4V) Import and Export 

Open Media Framework (OMF) Import and Export Raw media [or essence] only; Windows only) 

QuickTime (MOV) Import and Export QuickTime required on Windows 

Video for Windows (AVI) Import and Export Implemented via QuickTime on Mac OS 

Windows Media (WMV, WMA) Import and Export Windows only 

XDCAM HD and XDCAM EX (MXF, MP4) Import only After Effects can import Sony XDCAM HD 
assets if they were recorded to MXF files. After 
Effects cannot import XDCAM HD assets in 
IMX format. After Effects can import Sony 
XDCAM EX assets stored as essence files with 
the .mp4 filename extension in a BPAV 
directory. For information about the XDCAM 
format, see the XDCAM White paper pdf on 
the Sony website. 

 Format Import/Export support Format Details 

Advanced Authoring Format (AAF) Import only Windows only 

Adobe After Effects 5 and later binary projects 
(AEP, AET) 

Import and Export 

Adobe After Effects CS4 XML Project (AEPX) Import and Export 

Adobe Premiere 6.0 and 6.5 (PPJ) Import only 

Adobe Premiere Pro 1.0, 1.5, 2.0, CS3, CS4 
(PRPROJ) 

Import and Export 1.0, 1.5, and 2.0 Windows only 

 Format Import/Export support Format Details 

Adobe Clip Notes (PDF) Export only 

XML Forms Data Format (XFDF) Import only For importing Adobe Clip Notes comments. 

Maya Scene camera data (MA) Import only 

http://pro.sony.com/bbsccms/assets/files/micro/xdcam/articles/XDCAM_WhitePaper_F.pdf
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Note: After Effects cannot assign an input color profile to files that use non-RGB color spaces, such as CMYK. Color 
management on CMYK files is therefore limited. To effectively color manage CMYK files you should convert them to 
RGB before you import them into After Effects. For more information, see Interpret a footage item by assigning an 
input color profile. 

Supported 16-bpc and 32-bpc file formats

 While After Effects can operate in 16 and 32 bits per channel, most video and animation file formats and codecs 
support only 8-bpc. Typical cross-application workflows for higher bit-depth color involve rendering to a still image 
sequence rather than a video or animation file. Still image formats that support 16-bpc that After Effects can render to 
include PSD, PNG, TIFF, IFF, and SGI. Formats that support 32-bpc include PSD, EXR, HDR, and TIFF. 

Video codecs that support 10-bpc are provided with hardware such as a capture card or software such as Adobe 
Premiere Pro. You can import 10-bpc uncompressed YUV AVI files created in Adobe Premiere Pro into 16-bpc RGB 
After Effects projects. You can also render from After Effects with 10-bpc YUV compression. (See Specify Video for 
Windows compression options.) 

Obtain support for additional formats and codecs

 You can add support for additional file formats to After Effects by installing a third-party plug-in. For example, the Pro 
Import AE plug-in from Automatic Duck, Inc. allows you to import project files from popular non-linear editing 
applications into After Effects. You can find a list of software developers that make plug-ins for After Effects on the 
Adobe web site at http://www.adobe.com/products/plugins/aftereffects/. 

Similarly, you can add support to After Effects for additional video codecs by installing the codec on your system. Most 
codecs must be installed into the operating system (Windows or Mac OS) and work as a component inside the 
QuickTime or Video For Windows formats. Codecs are available for a variety of hardware (capture card, camera, etc.) 
and software workflows. Contact the manufacturer of your hardware or software for more information about codecs 
that work with the files that your specific device or application creates. 

Note: After Effects may not be compatible with all codecs. Test codecs that you intend to use before implementing them 
in your workflow. 

If you intend to render your composition using multiple computers over a network, then any third-party plug-ins or 
codecs used by your project must be installed on each computer in the render farm. See Network rendering with watch 
folders and render engines for more information about network rendering. 

Known issues with After Effects CS4 on Mac OS X 10.6 
(Snow Leopard)
Apple has released version 10.6 (Snow Leopard) of their Mac OS X operating system. This document tracks the known 
issues that Adobe After Effects users are most likely to encounter while running After Effects CS4 in Snow Leopard. 

Note: It is important to install the latest update for After Effects CS4 (version 9.0.2). You can update After Effects from 
another Adobe CS4 application (Bridge, Premiere Pro, and so on) or download an update from the Adobe support 
website.

Known issues

http://help.adobe.com/en_US/AfterEffects/9.0/WSF97D54F0-EBD5-4db1-BD4C-D5AD36A2AABBa.html
http://help.adobe.com/en_US/AfterEffects/9.0/WSF97D54F0-EBD5-4db1-BD4C-D5AD36A2AABBa.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79b0a.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79b0a.html
http://automaticduck.com/
http://www.adobe.com/products/plugins/aftereffects/
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79a2a.html
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79a2a.html
http://www.adobe.com/downloads/updates/
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Plugin Compatibility
• Some third-party plug-ins are not compatible with Adobe After Effects CS4 running on Snow Leopard. Currently, 

this issue only applies to plug-ins that use Quartz Composer. Customers are encouraged to check plug-in 
compatibility before upgrading. Also, on Snow Leopard, QuickTime files with a Quartz Composer track are not 
compatible with After Effects CS4. 

• A table listing plug-ins and their compatibility with Snow Leopard is being maintained at Toolfarm 
(www.toolfarm.com). Note: This link is provided as a courtesy only. Adobe does not monitor the site or verify the 
information provided.

Application Compatibility
• Render Multiple Frames Simultaneously (under Preferences > Memory & Multiprocessing) does not work properly 

in After Effects CS4 (9.0.0) on Mac OS X v10.6.

• After Effects CS4 (9.0.0) may freeze or hang on startup after you upgrade to Mac OS X v10.6. 

Solution
Update After Effects to version 9.0.2. 

Rosetta required
After Effects bounces in the Dock, but does not start.

Note: This issue can occur after a clean installation of Snow Leopard.

Solution: After Effects requires Rosetta to be installed. Rosetta is an optional install on the Snow Leopard disk. After 
Rosetta is installed, users typically have to restart their computers a few times to remove the missing component flag 
that prevents After Effects from starting successfully.

Language Support
It is no longer possible to run After Effects in another language by using the Finder Get Info dialog to deselect 
languages. The Language section has been removed from the Get Info dialog box.

Gamma change
Apple changed the default gamma from 1.8 to 2.2 in Snow Leopard. Although this is not an After Effects issue, it 
sometimes affects the appearance of After Effects projects. For more information on this change in gamma values, see 
this article on the Apple support site.

Additional information
After Effects CS3 has also been tested with Snow Leopard and has the same issues as CS4.

Note: CS3 preceded Snow Leopard by a few years and Adobe no longer issues updates for After Effects CS3.

 

Error "Invalid User Credentials" when you install After 
Effects CS4 on Windows Vista 64

http://www.toolfarm.com/plugins/index.php/Mac_OSX_Snow_Leopard_Compatibility
http://www.toolfarm.com
http://support.apple.com/kb/HT3712
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Issue
 When you attempt to install Adobe After Effects CS4 on Windows Vista 64, the installation fails and displays the 
following dialog box: 

"Invalid User Credentials. You do not have sufficient security credentials to install Adobe After Effects CS4." 

you are not prompted to authenticate with an administrator account, and using Run as Administrator gives the same 
results. 

Reason
 This error can occur when a standard (non-administrator) user attempts to install Adobe After Effects CS4 in 
Windows Vista 64 when User Account Control (UAC) is disabled. 

Solution
 Temporarily enable UAC and run the installer again. 

To temporarily enable UAC, see the To enable User Access Control (UAC) section of "Disable User Account Control 
(Windows Vista)" (TechNote kb404888) 

Error "Could not convert Unicode characters" | After 
Effects

Issue
The following error occurs when you start or use After Effects CS3, CS4, or CS5:

"After Effects error: Could not convert Unicode characters. (23::46)"

Solutions

Solution 1: Use single-byte characters for filenames, paths, and hard disks.
Change instances of multibyte characters (such as Chinese, Hebrew, or Japanese characters) to single-byte characters 
(such as English characters). 

Solution 2: Replace the AMT.zdct file for the target language.

Mac OS
1 Open the Applications/Adobe After Effects CS5 (or CS3 or CS4) folder.

Right-click the Adobe After Effects CS4 application icon and choose Show Package Contents.

Open the Content/Resources/AMT Languages folder.

http://www.adobe.com/go/kb404888
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Note the name of the .txt file in this folder, which is the code for the language that After Effects was installed in. This 
language is the target language. For example, US English is en_US, Turkish is tr_TR, Russian is ru_RU, and so on. A list 
of commonly used language codes is available here.

Go back to the Resources folder and open the AMT folder.

Open the folder named with the target language code you identified in step 4.

Place a tilde character (~) at the beginning the AMT.zdct filename. This step causes After Effects to ignore the file, but 
preserves this file as a backup.

Go back to the AMT folder and open the folder for en_US. (You can also choose other languages that are unaffected by 
this problem, such as fr_FR for French or es_ES for Spanish.)

Copy the AMT.zdct file from this folder to the target language folder, from step 6. To copy the file, hold down the 
Option key while dragging it from one folder to the other. Or, select the file and choose File > Duplicate, then move the 
file to the other folder and remove "Copy" from the end of the filename.

Launch After Effects.

Windows
1 Open the Program Files\Adobe\Adobe After Effects CS4 (or CS3)\Support Files\AMT Languages folder.

Note the name of the .txt file in this folder, which is the code for the language that After Effects was installed in. This 
language is the target language. For example, US English is en_US, Turkish is tr_TR, Russian is ru_RU, and so on. A list 
of commonly used language codes is available here. 

Go back to the Support Files folder and then open the AMT folder.

Open the folder named with the target language code you identified in step 2.

Place a tilde character (~) at the beginning the AMT.zdct filename. This step causes After Effects to ignore the file, but 
preserves this file as a backup.

Go back to the AMT folder and open the folder for en_US. (You can also choose other languages that are unaffected by 
this problem, such as fr_FR for French or es_ES for Spanish.)

Copy the AMT.zdct file from this folder to the target language folder, from step 4. Select the file, choose Edit > Copy, 
navigate back to the target language folder, and choose Edit > Paste.

Launch After Effects. 

Additional information
The AMT.zdct files contain text phrases for menu items that are translated for specific languages. A problem in After 
Effects prevents it from translating special characters used in some languages correctly if the OS language does not 
support those characters.

After Effects was installed in a language that uses a non-Roman Unicode or Cyrillic character set on an OS that doesn't 
match the language. For example, you installed After Effects in Turkish on an English OS.

Affected languages include:

• Arabic

• Chinese, Simplified

• Chinese, Traditional

• Greek
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• Hebrew

• Japanese

• Korean

• Romanian

• Russian

• Turkish

• Ukrainian

After Effects warning: The location you have chosen is a 
removable drive (Mac OS)

Issue
When you attempt to launch Adobe After Effects CS4, you receive the following message:

• After Effects warning: The location you have chosen is a removable drive. Please choose another location.

When you click OK the application continues to launch and function normally. This dialog presents itself on each 
subsequent launch.

Reason
This can occur when you use the Mac OS File Vault's home folder encryption option (System Preferences > Security > 
File Vault).

Solution
Change the location of the After Effects Media Cache Database preferences to another location outside of your home 
folder.

1 In After Effects, choose After Effects > Preferences > Media & Disk Cache.

2 In the Conformed Media Cache: Database section, choose a folder outside of your user account's home folder.

3 Close After Effects and relaunch.

See "The media cache".

After Effects error: "Error parsing properties list"

Issue
When you attempt to start Adobe After Effects CS4, it crashes with the error message "After Effects warning: Error 
parsing properties list."

http://help.adobe.com/en_US/AfterEffects/9.0/WSEF6D619D-DFA4-467f-AD1A-280C81A19D77.html
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Reason
This error can result from corruption in one of the XML preference files for After Effects.

Solution
Update Adobe After Effects to version 9.0.2.

See the Adobe website for details about the After Effects CS4 (9.0.2) update.

After Effects CS5 known issues, bugs (partial list)
Important: Be sure to install the recent updates for After Effects CS5 and Adobe Media Encoder. These updates fix 
many bugs.

If you encounter a problem not mentioned here, submit a detailed bug report. You can also visit the After Effects user-
to-user forum for assistance.

See the After Effects 10.0.2 release notes for other known issues.

Possible hang on start if firewall or other software (such as ZoneAlarm or FileMaker) blocks communication with 
After Effects and related components

See this Technical Support document for more information and solutions.

BMP footage in a CS4 project opens as missing footage

Workaround: Relink footage after opening.

Purged cached frames when a second RAM preview is initialized and multiprocessing is enabled.

When Memory and Multiprocessing is enabled for "Render Multiple Frames Simultaneously," frames cached by 
foreground processes can be purged when you initiate a second RAM preview. (54071 and 53844)

Problems rendering to MPEG4 format when "Short Header" is enabled

When you render to the MPEG4 output module, avoid enabling the "Short Header" parameter under "Format Options," 
if possible. Enabling this option can cause various problems with the rendered media file. (54118)

Some incorrect constrained output media sizes when rendering to MPEG-2 format

Some composition sizes can result in improperly constrained output media sizes. This issue occurs when you use the 
MPEG-2 output module with certain non-default combinations of the "Profile" and "Level" parameters under Format 
Options (54115).

Incorrect pixel aspect ratio when rendering to AVI format using the "None" codec

AVI files rendered with the "None" codec from compositions that don't match the target output file's dimensions can 
be restricted to a square pixel aspect ratio. (2563466)

Possible crash with Turbulent Noise effect when rendering to FLV format

The Turbulent Noise effect can crash After Effects when rendering to the FLV output module with a low value in the 
"Undershoot" parameter (54113).

Redraw issue for Live Photoshop 3D models when modifying the camera

Live Photoshop 3D models do not redraw when modifying camera properties if motion blur is enabled; workaround is 
to purge the image cache (54123).

http://blogs.adobe.com/toddkopriva/2009/05/after-effects-902-update-red-r.html
http://blogs.adobe.com/toddkopriva/2011/04/after-effects-cs5-10-0-2-update-a-few-big-bug-fixes.html
http://www.adobe.com/go/wish
http://forums.adobe.com/community/aftereffects_general_discussion
http://forums.adobe.com/community/aftereffects_general_discussion
http://www.adobe.com/support/documentation/en/aftereffects/releasenotes.html
http://kb2.adobe.com/cps/857/cpsid_85711.html
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Minimized application becomes nonresponsive while Live Photoshop 3D is engaging the ray traced renderer 
(Windows only)

If you minimize After Effects while Live Photoshop 3D is engaging the ray traced renderer, it doesn't come back to the 
foreground until rendering is complete. A workaround is to engage Caps Lock to disable rendering (2579653).

Possible incorrect handling of gamma or color values when opening pre-CS5 projects that use the legacy 
QuickTime gamma adjustment setting

The "MediaCoreQTCodecRulesCS5.xml" file isn't loaded when opening pre-CS5 projects that have the "Match Legacy 
After Effects QuickTime Gamma Adjustments" checkbox enabled. (The MediaCoreQTCodecRulesCS5.xml file 
governs color handling behaviors in some QuickTime codecs.) This issue can cause incorrect handling of gamma or 
color values in QuickTime source files (2572685).

Blocky artifacts in RGB color channels using Canon 5D MKII footage

 

After Effects CS4 crashes on quit (Mac OS)

Issue
When you quit Adobe After Effects CS4, the application crashes.

Reason
You have installed a script that presents a UI panel, and that panel is docked.

Solution
Update Adobe After Effects to version 9.0.2.

See the Adobe website for details about the After Effects CS4 (9.0.2) update.

After Effects CS4 crashes when you use Cycore plugins 
on 8-core Intel Xeon based computer

Issue
When you attempt to use certain Cycore plug-ins that ship with Adobe After Effects CS4 on an 8-core Xeon-based 
(Intel code name Nehalem) machine, After Effects crashes.

http://blogs.adobe.com/toddkopriva/2009/05/after-effects-902-update-red-r.html
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Plug-in affected:

• CC Particle World

Solution
Update Adobe After Effects to version 9.0.2.

See the Adobe website for details about the After Effects CS4 (9.0.2) update.

http://blogs.adobe.com/toddkopriva/2009/05/after-effects-902-update-red-r.html
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