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Troubleshoot OpenGL problems | After Effects CS4-
CS5.5
Note: OpenGL functionality in After Effects CS6 is different from OpenGL functionality in previous versions. This 
document is only for After Effects CS4 through CS5.5. For more information about After Effects CS6 GPU functionality, 
see this video.

This document can help you to resolve problems related to OpenGL that occur while you use After Effects. OpenGL 
problems can manifest in many different ways, including (but not limited to) the following:

• Adobe After Effects crashes or closes without an error while it starts.

• A crash or freeze when you scrub the timeline or preview or render a composition.

• A crash when you change the settings of an effect while OpenGL previews are enabled.

• A crash or freeze when you enable or disable OpenGL previews.

• The composition window takes a long time to redraw.

• Artifacts or blocks of "garbage" pixels are drawn in the composition window.

• The composition window is drawn differently between when OpenGL previews are on and off.

• An error message such as one of the following: " After Effects warning: A problem occurred when processing 
OpenGL commands." "The instruction at '0x00fe1940' referenced memory at '0x000000000' The memory could not 
be 'read'." "AE_OpenGL: failed to generate shadow map (5065::0)" "This composition is too complex for the 
OpenGL hardware." "After Effects error: AE_OpenGL: Create texture error. (5065 :: 0)"

For information about how to configure the preview preferences in After Effects for OpenGL and a list of features in 
After Effects that can be rendered with OpenGL, see Render With OpenGL in After Effects Help.

To benefit most from this document, perform the tasks in order. Record the tasks that you perform and the results of 
each, including errors and other problems. Adobe Technical Support can use this information to better assist you if you 
call.

It's necessary to log on as an administrator to perform some of the procedures in this document.

For Windows, some of these procedures require you to locate hidden files and hidden folders. Some procedures require 
you to locate files by their full filenames, which include extensions (for example, example_filename.ini). By default, 
Windows Explorer doesn't show hidden files, hidden folders, and filename extensions that it recognizes. See the 
following document for details:

• Show hidden files, hidden folders, filename extensions | Windows XP, Vista, Windows 7 (kb402324).

For Windows Vista, the steps in this document that mention the Control Panel are in reference to the Classic view. For 
information on switching the Control Panel to the Classic view and many other common OS procedures, see Common 
Microsoft Windows Vista procedures (kb401275).

http://www.video2brain.com/en/lessons/system-requirements-for-gpu-acceleration-opengl-cuda
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79e8a.html
http://www.adobe.com/go/kb404856
http://www.adobe.com/go/kb401275
http://www.adobe.com/go/kb401275
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These tasks can help you resolve the most common problems with OpenGL. Before performing any of these tasks, back 
up all personal files (for example, After Effects files you created). Always restart the computer after a system error 
occurs to refresh its memory. Continuing to work without restarting the computer can compound the problem.

1. Update to the most recent version of After Effects

To check for updates, choose Help > Updates in After Effects. 

To download updates, see After Effects for Mac OS or After Effects for Windows.

2. Make sure that the computer system meets the minimum requirements for After Effects.

See this page for a list of system requirements for After Effects: Adobe After Effects system requirements

3. Make sure that the video card and drivers meet the OpenGL requirements.

Using OpenGL in After Effects requires an OpenGL card that supports OpenGL 2.0.

To determine what version of OpenGL your card supports, click the OpenGL Info button in the Preview preferences. 
On Mac OS, choose After Effects > Preferences > Previews. On Windows, choose Edit > Preferences > Previews.

For information regarding supported OpenGL hardware, visit the After Effects OpenGL support page on the Adobe 
website.

Newer video card drivers can improve the OpenGL capabilities of your card. See solution 6: Update the video card 
driver.

4. Disable OpenGL to determine whether it is causing the problem.

To disable OpenGL previews:

1 Choose After Effects > Preferences > Previews (Mac OS) or Edit > Preferences > Previews (Windows).

2 Deselect the Enable OpenGL option.

Note: OpenGL does not support some features in After Effects, and the appearance of your composition can change 
between using OpenGL previews and software-rendered previews. For the list features that OpenGL supports, see 
Render With OpenGL in the Rendering and Exporting section of After Effects Help.

5. Remove the OpenGL plug-in from the After Effects plug-ins folder.

To determine if OpenGL caused the problem, remove the OpenGL plug-in and restart After Effects.

To remove the OpenGL plug-in:

1 Quit After Effects.

2 Mac OS: Drag the AE_OpenGL.plugin file from the Applications/Adobe After Effects CS4/Plug-ins/Extensions 
folder to the desktop. Windows: Drag the AE_OpenGL.AEX file from the C:\Program Files\Adobe\Adobe After 
Effects CS4\Support Files\Plug-ins\Extensions folder to the desktop.

3 Restart After Effects.

If the problem recurs, OpenGL didn't cause it. Drag the OpenGL plug-in back to the original location. If the problem 
doesn't recur, the cause of the problem is OpenGL. See solution 6: Update the video card driver.

6. Update the video card driver.

Many OpenGL problems or conflicts are solved by updating the video card driver. Many video card manufacturers 
frequently update their software drivers. If you haven't recently updated the video card driver, contact the video card 
manufacturer for an updated driver, or download one from the manufacturer's website.

7. Restart After Effects and test the behavior that caused the crash. (Windows only)

http://www.adobe.com/support/downloads/product.jsp?product=13&platform=Macintosh
http://www.adobe.com/support/downloads/product.jsp?product=13&platform=Windows
http://www.adobe.com/products/aftereffects/systemreqs/
http://www.adobe.com/go/learn_ae_openglsupport
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103a4f2dff7-79e8a.html
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Following a crash that an OpenGL problem on Windows causes, After Effects CS4 can automatically disable the Prevent 
DLL Address Space Fragmentation preference. This preference allows After Effects to access a larger amount of 
contiguous RAM, but can be incompatible with some OpenGL drivers.

You can enable or disable the Prevent DLL Address Space Fragmentation preference by going to Edit > Preferences > 
Memory & Cache.

Leave this preference enabled unless you are experiencing OpenGL or memory-related crashes. If you disable the 
preference because of an OpenGL problem, and you later update the video card drivers, reenable the preference. Then, 
test the problem again.

8. Optimize the Texture Memory preference.

Crashes or OpenGL errors can occur if After Effects attempts to use too much video texture memory. Texture memory 
is the amount of RAM on the video card (VRAM).

Set the Texture Memory preference in After Effects:

1 Multiply the total installed VRAM by 80% to calculate the optimal Texture Memory setting.

2 In After Effects, choose After Effects > Preferences >Previews (Mac OS) or Edit > Preferences > Previews 
(Windows).

3 Click OpenGL Info.

4 Enter the value you calculated in Step 1, then click OK.

The ideal value for texture memory is 80% of the VRAM on your video card. (If you use multiple video cards, calculate 
80% of the VRAM on the video card that is identified in the OpenGL Information dialog box.) If the Texture Memory 
preference in After Effects is set to more than 80% of the VRAM, it's possible that not enough VRAM is left for the 
video card to handle the user interface or other tasks. (For example, the entire screen can turn white.) If the value is set 
to less than 80%, OpenGL previews in After Effects can take longer to process frames.

See Mac OS Help or Windows Help for information about determining the amount of VRAM on a video card.

9. Purge the image caches and video memory.

If After Effects displays artifacts or "garbage" (blocks of incorrect pixels) in the composition window, the video memory 
(VRAM) could be full, fragmented, or corrupted. Purge the image caches and video memory to empty the VRAM and 
let After Effects rebuild the composition preview.

To purge the image caches, choose Edit > Purge > Image Caches.

To purge the video memory, choose Edit > Purge > Video Memory.

Note: Some screen savers that use OpenGL (or Direct3D on Windows) can corrupt the video memory if they activate 
while After Effects is running. Change or disable the screen saver if you frequently have problems with corrupted 
images in the composition window after turning off the screen saver.

10. Change the color setting for the video card to Highest (32 bit) (Windows) or Millions (Mac OS).

See Mac OS Help or Windows Help for information about changing the video card or display settings.

11. Disable advanced functions of the video card. (Windows only)

Most display card drivers include utilities that allow you to access advanced functions of the card. In particular, anti-
aliasing, and 16-bit mode functions can conflict with OpenGL and cause After Effects to crash. Set the advanced 
functions of the card to their defaults, then disable the anti-aliasing and 16-bit mode options.

If you are using multiple monitors with an Nvidia card, set the Multimonitor setting to "Compatible".
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See the documentation for the video card or to the manufacturer's website for instructions on how to access its 
advanced functions.

12. Use a single monitor.

If you are using multiple monitors and experience problems with OpenGL in After Effects, try the following:

• If you have placed the After Effects application window or the Composition panel on a secondary monitor, move 
the window to the primary monitor.

• Disconnect all but one monitor.

• If you are using multiple display cards, remove all but one display card. For best results with OpenGL, use a single 
dual-head display card.

13. Place the Reduce OpenGL Texture Size script in the Startup scripts folder.

The Reduce OpenGL Texture Size script reduces the amount of texture memory After Effects uses and can provide 
better compatibility with older video cards.

To place the Reduce OpenGL Texture Size script in the Startup scripts folder:

1 Navigate to the After Effects scripts folder. On Mac OS: Applications/Adobe After Effects CS4/Scripts. On Windows: 
C:\Program Files\Adobe\Adobe After Effects CS4\Support Files\Scripts.

2 Move the Reduce OpenGL Texture Size.jsx file from the (support) folder to the Startup folder.

A newer video card can improve the OpenGL capabilities of your computer and make the script unnecessary. After you 
install a new card and its drivers, move the Reduce OpenGL Texture Size script back to the (support) folder. Then reset 
the After Effects preferences.

14. Reset After Effects preferences.

Re-create the After Effects preferences file to eliminate problems that damaged OpenGL preferences can cause.

To re-create the After Effects preferences file, restart After Effects. Hold Ctrl+Alt+Shift (Windows) or 
Command+Option+Shift (Mac OS) while the application is starting.

15. Contact Adobe Technical Support.

If none of the above steps has resolved the error or freeze that you are experiencing with After Effects, then contact 
Adobe Technical Support. You can find the support options at the Support Center.

 

timeToFrames expression method returns string instead 
of number | After Effects CS5.5

Issue
The timeToFrames expression method returns a string, not a number.

Solution
Wrap the call to the timeToFrames expression method in a call to the Number method, like so:

http://www.adobe.com/support/
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Number((timeToFrames())

Additional information
You can encounter this bug without immediately realizing it, because the string that is returned is a string representing 
a number. For example, the returned value could be the string "50" instead of the number 50.

Furthermore, a string representing a numerical value is converted to a number for some arithmetic operations. 
Therefore, some operations can work as expected, such as subtraction with the - operator. However, overloaded 
operators such as + don't behave as expected, because the operation on a string is string concatenation, whereas 
operation on a number is arithmetic addition.

Understanding Stereoscopic 3D in After Effects
This guide helps you understand how to use stereoscopic 3D in After Effects.

Understanding stereopsis and stereoscopy
To understand what stereoscopic 3D is, it's necessary to understand perceived depth. There are many cues that help us 
perceive depth.

Objects in perspective, occlusion, and relative size are good indicators of depth. An object that is farther away is 
interpreted as such by our brains if it is much smaller than another object next to it. Our brain already knows how big 
those objects should be in relationship to one another. If two objects are roughly the same size in our field of view, and 
one is occluded by or is occluding another object, our brain infers that one of those objects is in front of the other. 
(Occlusion mean one object is laid on top of the other and obscures the other.) Paintings or games can appear 3D 
because they obey these rules. After Effects also obeys these rules when you create a 3D composition with a camera.

Another important depth cue is lens blur. If our eyes (or a camera lens) focus on a specific object, and another object 
appears blurred next to it, our brain knows that the other object is either in front of or behind the object. If there is no 
blur, our brain thinks that the two are at a similar distance. One can clearly see this phenomenon as our eyes focus on 
different objects and our retinas blur the out-of-focus objects in the background. Our brain interprets this as a depth 
cue without us realizing it. This phenomenon is subtle as our brain filters it seamlessly into our perception. It is usually 
unnoticed to the average person. However, it is possible to train our eyes and brain to experience and be conscious of 
the depth of field by relaxing the eye muscles and using the following (or similar) technique. Look through a windshield 
with water droplets on it at night. When you focus outside the windshield, the water droplets turn into little halos of 
color called bokeh. Similarly, when you focus on the droplets, the streetlights in the background turn into bokeh. This 
effect can be accomplished with one eye closed. Therefore, it has nothing to do with stereopsis, but instead has to do 
with our eye’s lens focusing, similar to how a camera lenses focus. Understanding how depth of field is related is 
important when attempting to create realistic images and works hand-in-hand with stereoscopic 3D in After Effects. 
Especially with the new and improved Camera Lens Blur effect and related features in After Effects CS5.5.

Finally, arguably the most powerful depth cue is stereopsis. Stereopis is the ability of our brain to take two input images 
from different perspectives and gain an understanding of how far away two different objects are in relationship to each 
other. The key point to understand is that since our eyes are spaced apart on our heads, each eye can view a slightly 
different perspective of the world in front of us. Look at an object nearby and close one eye, then switch eyes back and 
forth several times. Then try this same exercise on an object that is far away. You notice that the object that that is nearby 
jumps from side to side in your field of view a lot more drastically than the object far away. If the close object is in the 
same general direction as the far away object, the close object switches sides of the far away object. This is the basis of 
how stereopsis works. Your brain takes the relative horizontal distance between objects in your field of view and 
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compares them to gain an understanding of where those objects are in relationship to each other in terms of depth. It 
is theorized that pigeons bob their head in order to gain depth perception (since their eyes are on opposite sides of their 
head and they can’t see depth otherwise). If you look through only one eye, you lose your stereopsis depth cue. However 
if you bob your head from side to side with that eye still closed, you can get a sense of depth again. This separation 
between eyes that provides different perspectives is the key to stereopsis.

It is important to keep all these depth cues in mind when constructing a stereoscopic 3D composition in After Effects. 
In the real world, it is possible to give contrary information to the brain and trick it. Optical illusions like the Ames 
Room, the Infinite Staircase, or tilt-shift photography are all examples of how depth cues can be manipulated and our 
brains tricked. (Tilt-shift photographiy is a method in which a post-process depth-of-field blur is added to an image to 
give a broad landscape the feeling of a miniature.) Since After Effects gives you control of all of these depth cues, it's 
important to maintain control over their interaction and make sure that they are not giving our brains too many 
contrary depth cues. In real life, one can mess around with our surroundings in intelligent ways to create optical 
illusions. But more often than not, inconsistencies in the digital realm are considered unnatural and can even cause 
eyestrain or brain pain. Stereopsis, being the most powerful depth cue, is no exception. It's important to make sure that 
it is not painful to look at the stereoscopic result on different screens. Ones viewing experience can change depending 
on how big the screen is and how far away the viewer is from the screen.

Stereoscopy is a digital technique for allowing our brain to see stereopsis by tricking it. This technique is done is by 
presenting each eye with a different image. The left eye is presented a view of a scene from some virtual or real camera 
that shows the left perspective. Similarly, the right eye is presented with an image of the right perspective. In this way, 
each eye is presented with a different image independently and our brain puts them together, and we perceive depth. 
When viewing a stereoscopic 3D scene on a monitor, the elements in the scene have a tendency to pop out or sink into 
the screen. Stereopsis is telling us that the object is closer or farther away from us than how far away the monitor 
actually is.

Many different devices and systems exist for delivering stereopsis to our brains. But in general the principle behind all 
of them is the same; get one eye to see one view, and the other to see a different perspective of the same scene. Anaglyph 
glasses are the oldest method, and by far the cheapest. Different colored lenses color filter each eye’s view differently. 
Red-blue glasses filter out blue on the left eye and red on the right eye. On the display side, the left image is colored red, 
and the right is colored blue. Then the images are overlapped. Each eye sees only the associated image. Because of the 
inherent color distortion, it is difficult to see all the colors accurately using anaglyph. But the setup is very easy and 
works accurately for judging depth and convergence. Polarized glasses work on a simple principle. Two images are 
displayed on a screen, one image emits horizontally polarized light only, and one emits vertically polarized light only. 
The glasses have polarized lens such that each only lets through light polarized in one direction. Active shutter glasses 
work by blocking one eye at a time at a high rate (usually 60fps) and switching the left and right images every frame 
while synchronized with the monitor. Some TVs use no glasses at all, such as those from Alioscopy. Aliscopy uses 
lenticular technology, in which the lens on the monitor itself actually refracts the lights in different directions so that 
each eye gets a different perspective simply by being in a different location in relationship to the TV. There are many 
more methods for stereoscopy. Here is a parody of the topic that shows a very unconventional method used by Jonathan 
Post: http://www.jonathanpost.com/

When dealing with stereopsis in the real world, the only things that can vary are the positions of objects in front of you, 
and the perspective from each eye can only change based on that. The only way to make an object look closer through 
stereopsis is to actually place it closer. You can’t easily change the distance between your eyes, your field of view, or the 
aperture of your eyes (at least not voluntarily) to modify the depth of field you perceive. However, in the digital realm, 
there are many more variables since all of these aforementioned things can be changed. Therefore, there is a high 
likeliness to introduce confusing depth cues that are contradictory and cause pain when viewing.
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3D depth cues in After Effects
Perspective, occlusion, and relative-size depth cues are all handled automatically for you by After Effects, since it places 
objects in a virtual 3D space. Moving an object farther away along the z axis of the camera makes that object smaller 
and place it behind other objects. Changing the camera field of view changes the perspective of the scene. A wide-angle 
lens gives you more perspective depth cue information than a telephoto lens, for example. Turning on Depth Of Field 
in the camera layer and modifying the aperture adds lens blur according to the focus distance. Also, stereopsis can be 
added to any 3D composition in After Effects. In short, the concept is simple: create a left camera view and a right 
camera view of some 3D scene, and render them out. Then use some sort of stereoscopic display to view the 
composition in stereo.

Creating a stereoscopic scene in After Effects
Start out by taking any composition that has some 3D layers positioned along the z axis. Right-click a layer and select 
Camera > Create Stereo 3D Rig. After Effects creates a Left Eye composition and Right Eye composition driven by left 
and right cameras. It also creates an output composition that puts the two views together into a format that is 
recognized by some stereo viewing method. If you applied the command to a camera, that camera is the one to control 
your stereo cameras.

At this point, you canput on red-blue anaglyph glasses and see your composition in stereo. Objects pop out or sink in 
to the screen according to their distance from the camera. At this point, you can go back to your starting composition 
and modify your camera position, depth of field, placement of layers, or anything else about the scene. When you 
switch back to the stereo view, it updates in stereoscopic 3D. Play with your scene. Tt's very easy to see stereoscopic 3D 
in action if you are animating a camera move, animating objects moving closer to the camera, or animating the depth 
of field (camera aperture, focus distance, and zoom).

Controlling stereoscopy in After Effects
Once your scene is complete, you can begin to tweak the stereoscopic 3D controls for your scene. No further changes 
are required in your main composition. Switch to the Stereo 3D composition and find the layer Stereo 3D controls. All 
of the controls necessary for stereoscopic 3D are in two effects on this layer.

Stereo scene depth
This control is the main control for changing the interaxial separation of the cameras. Increasing this control spreads 
the cameras out. This effect is the same as if you moved your eyes farther apart. It is very difficult and unnatural in real 
life, so this controlif used improperlycan have very painful results since our eyes and brain are not used to converging 
much more than allowed by the distance between our eyes. The last thing you want is to get your viewer to go cross-
eyed trying to converge their eyes on an object too close or too far away. Usually, to get the most pleasant results, you 
want your camera separation to match the separation of your eyes. However, it is very difficult to do, because your final 
output could be on a (relatively) small 50’’ 3D TV or a very large IMAX screen. In both cases, the distances between the 
objects on screen could vary drastically and could cause eye strain or cross-eye on one viewing screen, but be fine on 
another. For this reason, the Stereo Scene Depth property is measured in % of composition width. That way, if you 
change the size of your stereo composition, the stereoscopic calculation remains unchanged relative to the new size.

Changing the Stereo Scene Depth value has the result of making the stereoscopic 3D scene appear to pop out or sink 
in to the screen more. Setting it back to 0 gets rid of all stereoscopy, and everything is on the plane of the screen.

To understand what this control is doing, understand that moving the cameras apart has the effect of moving all objects 
in the scene away from one another horizontally, thus increasing the amount of perceived depth separation. In this way, 
you can get around moving an object farther back and closer to the camera to get more depth. Increasing this value 
increases the maximum amount an object can stick out of or sink in to the monitor.
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Understanding convergence
When our eyes converge on an object, if there is a difference in horizontal position of that object between the left eye’s 
image and the right, our mind puts the object together into one and our brain thinks the object is a certain distance 
away (due to parallax).

When two objects appear in the same location horizontally in both the left and right frame, the objects' distance from 
the camera indicates the plane of convergence. Any layer that is at the same distance as that plane from the camera is 
converged upon. Objects that are converged upon appear to reside on the surface of the screen that is being viewed. 
Everything closer to the camera than that object or others along that plane appears to pop out of the screen. Everything 
farther away from the camera than that object appears to be pushed deeper in the screen.

Think of the convergence plane as an anchor point for the stereoscopic 3D space. In this way, you can shift your 3D 
objects back and forth and control directly whether objects are all sinking in to the screen, or only popping out, or a 
mix of in and out. To understand how much those objects will stick out in either direction relative to the plane, see the 
section on Stereo scene depth.

Toe-in or parallel cameras and convergence point
Our eyes angle slightly in toward the object we are looking at. This effect is known as toe-in. After Effects does this 
effect when you select Converge Cameras in the Stereo 3D Controls. Using toe-in can give more control, but there are 
several factors to be aware of when doing this. When cameras converge, you change the perspective of the view, since 
the cameras are rotated and thus distortion is introduced. No longer do the perspectives of the left and right cameras 
line up exactly. When you capture live stereoscopic video, you almost never want your camera rig to have a toe-in. You 
want to correct for the perspective distortion if you need to change the convergence point in post-production. Real 
scenes are almost always shot with parallel cameras. Keep this in mind if you are trying to mix and match live footage 
with digital elements. If your scene consists of only 3D elements in After Effects, then it is probably safe and preferable 
to use converged cameras.

Converged cameras
In After Effects, it is much easier to change the convergence point of your stereoscopic 3D camera rig because you can 
change where the cameras are pointing quite easily. Make sure that Converge Cameras is selected, and change the 
Convergence Z Offset property. Increasing this value pushes the convergence point away from the camera, so all objects 
in the scene pop out toward you when you view it on a 3D monitor. You can set where the cameras converge by 
changing the Converge To property. Usually, it is easiest to have the left and right cameras converge to your master 
camera's point of interest (default). But it is useful to change it to camera position (plus, for example, the focus distance 
as an offset) when trying to match convergence point and depth of field. Likewise, you can tie the convergence point to 
the zoom to automatically keep the convergence the same while doing a perspective shift (changing the field of view of 
the camera while doing a dolly in). See the section on depth of field for more information.

Parallel cameras
You can also use parallel virtual cameras. This technique is useful if you need to match live footage and add digital 
elements to that scene. Keeping the virtual camera orientations consistent with the cameras used in the footage helps 
to keep the perspectives of the digital elements and that of the stereo footage aligned. Changing the convergence plane 
with live footage is as simple as changing the horizontal alignment of the left and right images. Conceptually it makes 
sense; each object in the left and right image has a different horizontal offset depending on their depth due to parallax. 
If you align the left and right images so a specific object in your footage appears in the exact same location when 
overlapped. Your convergence point is now located at the depth that matches how far that object was from the camera 
when you shot your footage (or however far that object is from your virtual cameras).
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You can change the 3D Glasses effect's Scene Convergence property to change the convergence plane of parallel 
cameras. Keep in mind, though, that because it simply offsets the final images, it acts as an additional change to the 
convergence if you have already converged using the Converge Cameras property with an offset. In general, only change 
the 3D Glasses effect's Scene Convergence property when using live footage or when Converge Cameras is turned off.

Increasing the Scene Convergence property moves the convergence plane farther away from the camera. Everything in 
the scene pops out from the screen toward the viewer.

In general, your convergence plane with parallel cameras should ideally be at your camera's zoom distance. However, 
when your cameras are parallel, there is an offset to take into account. The cameras are spaced apart, and the two 
perspectives are also spaced apart. To have the correct convergence plane you must change the scene convergence to 
counteract the separation of the cameras. Subtracting the stereo scene depth (interaxial separation) will do this and 
keep the convergence point from moving when using parallel cameras and virtual 3D elements. However, don't this 
when using converged cameras. Set an expression on the 3D Glasses effect's Scene Convergence property to 
automatically account for this. Also make sure that the Units property in the 3D Glasses effect is set to % Of Source to 
match the units of Stereo Scene Depth in the Stereo 3D Controls effect; otherwise, an additional calculation is 
necessary. After doing this, you can change the Stereo Scene Depth property, and your scene convergence doesn't 
change. As a test, try changing the Stereo Scene Depth property with the 3D View in the 3D Glasses effect set to 
Difference. You should not see the black areas move back and forthonly the separation of the objects in front or behind 
them. With the following expression for parallel cameras, and the value of Scene Convergence set to 0, the convergence 
plane will be at the zoom distance of the camera.

3D Glasses effect Scene Convergence property expression 

try { cameraOffset = effect("Stereo 3D Controls")("Stereo SceneDepth"); if( effect("Stereo 3D Controls")("Converge 
Cameras") == false ) { value - cameraOffset; } else { value; } } catch (e) { value; }

Preview convergence plane with parallel cameras
When working with converged cameras, it is much easier to know how far away your convergence plane is. You have 
direct access to set the convergence point and offset. See the section on converged cameras to see how. When dealing 
with parallel cameras, it is difficult to tell how deep in the scene the convergence plane is. To preview this effect, change 
the 3D View property in the 3D Glasses effect to Difference. Objects that are aligned turn black. Any objects that are 
aligned are on the convergence plane. If you then change the Scene Convergence property by dragging the property 
value, you should see a darker band move through the scene. This band is the convergence plane moving back and forth 
through the scene. If you switch to the 3D view and put on your glasses, objects on this convergence plane appear to be 
on the plane of the TV screen.

Match cameras to Maya
A good thing to remember is that normally our eyes are about 6 to 6.5 cm apart. This fact is useful if you are trying to 
match camera separation from another program, like Maya. If you import cameras (or nulls) from Maya and they are 
not lining up with the stereo rig camera positions, try adding the following expression to the interaxial separation 
(Stereo Scene Depth property) to handle the conversion to After Effects units. In this case, the Maya default units are 
in cm, and they are dealing with absolute units. It's necessary to counteract the composition width percentage 
calculation. However, it possible you have to rework any keyframes if you change your output size. Using this equation 
allows you to drag the property value as you normally would. It takes that value and modifies it as needed.

Stereo Scene Depth (interaxial separation) expression to match Maya cameras:

value * (100.0 * 6.5 / thisComp.width);
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If your cameras are in the wrong location, make sure to verify where the master camera from Maya is in relationship to 
the left and right. Remember that you can change the configuration in your Stereo 3D Controls effect in After Effects 
such that the master camera is centered between the left and right cameras, or in the same location as the left (hero left), 
or the same location as the right (hero right).

Match depth of field to convergence
To get any sort of realistic scene, you usually want to add depth of field, though usually it is subtle unless you are using 
a telephoto or macro lens. Usually, you want your focus to match the convergence plane of the cameras. With parallel 
cameras, it is more difficult, and a little bit of eyeballing is required (See the section on ETLAT and previewing 
convergence plane with parallel cameras for more information).

When working with converged cameras, it is very easy to match your focus distance and convergence planes. Here are 
a few methods.

If you want your focus distance to simply follow your point of interest, use the new command by right-clicking the 
camera layer in the timeline. Choose Camera > Link Focus Distance To Point Of Interest. Then make sure that your 
Stereo 3D Controls effect properties are set to converge to camera point of interest with a 0 offset.

If you have already keyframed your main camera’s focus distance and want your convergence point to match it, make 
your cameras converge to camera position. Set an expression on the Convergence Z Offset property to match the focus 
distance of the camera. Now your convergence point follows your focus distance.

Make sure to replace YourCompName with the correct name for your main composition.

Expression to set on the Convergence Z Depth property:

comp("YourCompName").layer("Master Cam").cameraOption.focusDistance

If you have keyframed your Convergence Z Offset property, you can set an expression on your focus distance to match 
the convergence z offset. Make sure to remember where your convergence point anchor point is. If you are converging 
to camera position, no further work is required beyond linking your focus distance to point of interest as described 
earlier. However, if you are converging to the camera point of interest, add the distance between the camera point of 
interest and the camera position to the z offset for the focus distance expression using the length function. If you are 
converging to the camera zoom, add the cameras zoom value to the z offset for the focus distance expression.

Make sure to replace YourCompName with the correct name for your stereoscopic 3D composition.

Expression to set on the Focus Distance property:

stereo_comp = comp("YourCompName Stereo 3D"); s3d_controls = stereo_comp.layer("Stereo 3D 
Controls").effect("Stereo 3D Controls"); converge_to = s3d_controls("Converge To"); convergence_z_offset = 
s3d_controls(8); converge_to_pos = (converge_to == 1); converge_to_poi = (converge_to == 2); converge_to_zoom = 
(converge_to == 3);if( converge_to_pos ) { convergence_z_offset; } else if (converge_to_poi) { convergence_z_offset + 
length(transform.position, transform.pointOfInterest); } else if ( converge_to_zoom ) { convergence_z_offset + 
cameraOption.zoom; } 

Composite digital 3D elements with stereo footage from real-life cameras
You can work with real footage and integrate 3D elements in After Effects. The workflow currently requires a little bit 
of manual work. In general, use your stereo footage as a background plate, and then composite your 3D elements on 
top of it. The reverse could be the case if for example you are trying to put a stereoscopic video (like a TV screen 
replacement) into a virtual stereoscopic scene and the convergence of the scene needs to be different than the 
convergence of the footage.

For the purpose of simplicity, here is the workflow using stereoscopic footage as a background plate.
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First, start out with your 3D scene and create a stereoscopic 3D rig (Camera > Create Stereo 3D Rig). Import your 
stereoscopic left-eye and right-eye footage items. Drag your left-eye footage item into your Left Eye Comp composition 
and your right-eye footage item into your Right Eye Comp composition at the very bottom of your layer stack and leave 
them as 2D layers. Now, if you switch to your stereo 3D view, you should see your 3D elements composited with your 
stereoscopic 3D footage. Great!

One final thing needs to be done in order to truly control the convergence of the footage. Add a Slider Control 
expression control effect to your Stereo 3D Comp composition and name it Footage Convergence. Set an expression on 
the X position of the left and right footage layers. (You'll need separate dimensions of Position first: Animation > 
Separate Dimensions.) The left layer adds the slider value converted into percentage of composition width, and the 
right layer subtracts it. Make sure to replace YourCompName with the correct name for your stereoscopic 3D 
composition.

Expression to set on the left-eye footage layer's X Position property: transform.xPosition + (comp(“YourCompName 
Stereo 3D").layer("Stereo 3D Controls").effect("Footage Convergence")("Slider") / 100 * width )

Expression to set on the right-eye footage layer's X Position property: transform.xPosition - (comp("YourCompName 
Stereo 3D").layer("Stereo 3D Controls").effect("Footage Convergence")("Slider") / 100 * width )

Now you can drag your footage convergence slider to change the convergence plane of your stereoscopic 3D footage, 
and use the Stereo 3D Controls effect to control the convergence of your 3D elements. 3D glasses change the 
convergence of both together. It is best to try and get the convergence planes to match as close as possible in this 
situation.

You can’t change the stereoscopic scene depth of footage after you've shot it. Doing so would involve changing the 
interaxial separation of the cameras and shooting the footage with new perspectives for each camera. It is very difficult 
to get different perspectives from an image that has already been recorded (though there is research happening in this 
area). Your best option is to set the Stereo Scene Depth property of your 3D elements to match as closely as possible the 
separation of the cameras that were used on the shoot. Matching it might be somewhat difficult. Normally, cameras are 
spaced 6.5 cm apart to be similar to eye separation. But depending on the camera size, it can vary (especially if the body 
of the camera is wider and it is not possible to place the cameras that close together). It's necessary to do some sort of 
calculation to compensate for the dimensions of the footage. Also take into account correct units as mentioned 
previously since After Effects operates in units of pixels, not centimeters. It can be easiest just to manually adjust it in 
this situation.

Remember that to get the convergence point of the footage to match the camera zoom value, it's necessary to subtract 
the cameras' separation amount from your footage convergence. Using the difference mode is probably the easiest and 
fastest way to align the object you want to be on the convergence plane. To have the best composite possible (and least 
painful), make sure to match the convergence plane of your 3D elements with that of your stereo footage.

For a good explanation of different types of camera rigs that can be used and more stereo 3D workflows in Premiere 
Pro, check out this great video by David Helmly:

http://tv.adobe.com/watch/davtechtable/3d-stereoscopic-editing-with-premierepro-cs5-winosx/

ETLAT (edit this, look at that) 
When editing with stereoscopic 3D, it is usually invaluable to be able to see what exactly is happening and how the 
parameters you are changing affects your stereoscopic 3D rig. There is a simple way to get a sense of this in After Effects:

• Open a new composition viewer, and set one to view your initial scene composition, and one to view your final 
stereoscopic 3D composition. Make sure to lock those views so that they do not switch.

• With your Stereo 3D composition selected, click the controls layer and lock the Effect Controls panel so it isn't 
hidden.

http://tv.adobe.com/watch/davtechtable/3d-stereoscopic-editing-with-premierepro-cs5-winosx/
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• Now go back to your initial composition and turn on camera wireframes. Choose View > View Options > Camera 
Wireframes > On. Then switch to a custom view so that you can see your cameras in 3D space.

At this point, you should be able to see three cameras: your master camera, as well as your left and right ones. Changing 
your settings under Stereo 3D Controls should update the cameras in your initial scene. Try changing the Stereo Scene 
Depth property to see the cameras separating or tweak your convergence options to see where the cameras are pointing.

This technique is especially useful when debugging problems, and when trying to match your depth of field to the 
convergence distance. Both the focus distance and the convergence point are shown when the cameras are converging. 
With parallel cameras, you can still see your focus distance or point of interest and you can see how this lines up with 
the perceived convergence point in your final output using the difference mode technique as described earlier.

Hook After Effects up to a 3D TV
It's pretty simple to edit while previewing the stereoscopic 3D effects that you are changing. Anaglyph mode is an 
inexpensive way to do this. If you happen to have a 3D TV accessible, follow these steps to see your composition and 
edit in stereoscopic 3D live.

• Connect your 3D TV to your computer as a second monitor (DVI or HDMI).

• Make sure that your composition dimensions exactly match the resolution of the 3D TV. Check your resolution 
settings for the second monitor.

• Change the 3D View property in the 3D Glasses effect to match one that your 3D TV supports: either Stereo Pair 
(Side By Side), Over Under, or Interlaced Upper L Lower R.

• Create a new composition viewer for your stereoscopic 3D scene, and drag it out of the After Effects frame onto the 
3D TV. Make sure to lock this viewer.

• Make sure that your Magnification Ratio in the viewer is set to 100%. 

• Press Ctrl+\ (Windows) or Command+\ (Mac OS) twice to make the size of the viewer full-screen on the 3D TV.

• Turn on the associated 3D mode on your 3D TV.

• Put on your glasses, and you should be viewing your composition in stereoscopic 3D.

Lights and cameras and the rig
Left Eye Comp composition and Right Eye Comp composition can produce different camera views because they are 
precomposed with Collapse Transformations on. They do not inherit camera or light data from the containing 
composition, but instead use the modified left and right cameras. This is good because the cameras automatically create 
the correct angles for the stereoscopic view without any manual work.

However there are two limitations that this introduces:

You cannot use multiple cameras, since each stereoscopic 3D rig is always linked to only one master camera. If you need 
multiple cameras, you will need to make multiple stereoscopic 3D rigs linked to each individual camera, and then edit 
the stereoscopic 3D scenes together in another composition.

Lights do not transfer into the precompositions with collapsed transformations. If you create a light in your main 
composition, that light isn't used in your Left Eye and Right Eye composition and not in your Stereo 3D composition 
either. If you need lights, manually copy your lights into the Left Eye and Right Eye compositions. Make sure that the 
lights are identical to your original lights in the main composition. Otherwise, you can get different shadows or colors 
in each eye, which can be a cause of visual discomfort. Adobe recommends that if you need to add lights, connect the 
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lights in the left and right compositions via expressions to their counterparts in the master composition. Make sure to 
link all properties in the lights, including positional, directional, and light parameters. You can do this step easily using 
the pickwhip tool. Open up two timelines to simultaneously show your main and either left or right composition. 
Option-click the stopwatch for each property in the light and using the pickwhip tool drag it to the associated light 
property in the main composition. 

Ghosting
When viewing your composition through glasses, you can see areas that appear twice, called ghosting. You can test this 
phenomenon by closing your right eye. If you see any part of the image that only the right eye should be able to see, you 
know you have a problem. This problem is usually an issue with the way the display is showing your content. In general, 
though, suppress areas that are ghosting. Sometimes it happens when there are sharp contrasts of color and the glasses 
are not able to entirely block out that image from the incorrect eye. But most likely it is a display synchronization issue 
or similar problem with the 3D TV or display device.

Avoiding stereoscopic problems
As you can tell, there are many moving parts when working with stereoscopic 3D. As first discussed, you have access 
to so many more variables than in real life. Therefore, there is much more opportunity for them to not be aligned, 
providing contradictory depth cues and causing eyestrain or brain pain. The following are some general principles to 
keep in mind.

• Make sure that your depth cues are not giving contradictory information.

• Check your camera zoom; wide-angle lenses cause more distortion if your cameras are converging (toe-in).

• Match your focus distance of the master camera to the distance to the convergence plane; it could be subtly 
confusing if they are not (it can give you the sense that something is wrong but you can’t tell what).

• If integrating live footage, affirm that your camera angles match that of the cameras from the footage (usually 
parallel), and that your convergence distance also matches that of the footage.

• Avoid introducing an extreme amount of parallax. In difference mode, look at the horizontal spacing of the left and 
right eyes between the closest and farthest object and make sure this is not too extreme.

• If your eyes cannot converge or it is painful to see the image you might try these solutions:

• Move farther away from the viewing screen when looking through your 3D glasses.

• Make sure that your convergence point is somewhere predictable and not far off in the distance or very close to 
the camera where your eyes would go cross-eyed.

• Reduce the Stereo Scene Depth (interaxial separation). If your convergence plane is reasonably located and an 
object that is far away from the convergence point causes you to go cross-eyed, this can be painful. Remember 
that it is the relationship between the objects in the scene that matters; compare the horizontal separation of the 
closest object to the farthest. If the two images overlaid look drastically different, this could cause strain. 

Ghosting can happen from things that are out of your control. Factors that can cause ghosting are hardware 
synchronization between glasses and monitor, battery power of glasses, dynamic range of the monitor, or refresh rate. 
But there are some things you can do to make it better. If you are getting ghosting, try the following:

• reducing the high-contrast areas

• increasing brightness

• reducing scene depth so the separation between elements is reduced

• checking your display's stereoscopic 3D troubleshooting guide
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A final experiment
One interesting thing to try is to reverse the depth cues on purpose, and gain a sense of what happens when things go 
wrong. In this case, you can easily contradict your occlusion and stereoscopic 3D depth cues to give an interesting 
illusion. If you select Swap Left-Right in the 3D Glasses effect, it reverses all the convergences. Therefore, everything 
that was sticking out is now pushed in. This method is unintuitive, but the effect is that an object that is in front of 
another with regard to occlusion, relative size and perspective appears like it is behind the other in the stereo depth cue. 
It looks as if the background layer is cut out and the foreground layer is sinking into it. This effect is strange, but 
experiencing it helps to understand how important these depth cues are and how important it is to make sure that they 
are all in alignment and agree.

 

Error "The font dictionary can't be read" | After Effects

Issue
When After Effects starts, it shows the following warning message:

"After Effects warning: The font dictionary can't be read. Please restart your computer. If this problem persists, please 
go to http://www.adobe.com/go/learn_ae_fonterror ( 83 :: 3 )"

Solutions 

Solution 1
1 Restart your computer.

2 Restart After Effects.

The most common cause of this warning message is a corruption of the font information that is held in memory by the 
operating system. Restarting the computer clears this memory and causes the computer to rebuild and reload the in-
memory font information.

Solution 2
1 Quit After Effects and other Adobe applications.

2 Delete all instances of the Adobe font database files (AdobeFnt.lst, AdobeFnt10.lst, AdobeFnt11.lst, AdobeFnt12.lst, 
AdobeFnt13.lst, and so on).

3 Restart the computer.

4 Restart After Effects.

On Mac OS, the AdobeFnt.lst files can be in several locations, including the following folders:

• /Library/Application Support/Adobe/TypeSupport/CS5/CMAPS
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• /Library/Application Support/Adobe/PDFL/9.9/Fonts

On Windows, the AdobeFnt.lst files can be in several locations, including the following folders:

• C:\Program Files\Common Files\Adobe\TypeSupport\CS5

• C:\Program Files\Common Files\Adobe\PDFL\9.9\Fonts

• C:\Program Files\Common Files\Adobe\PDFL\9.9\CMAPS

To find other occurrences of these files, search your hard disk for 'AdobeFnt'.

This solution is useful if the font cache database on disk has become corrupt. By deleting the font database cache files 
and restarting the computer, you cause the computer to rebuild the font database on disk.

Solution 3
If rebuilding the font cache database doesn't fix the issue, the source of the problem could be a bad or corrupt font. The 
most common instances of bad or corrupt fonts are free bitmap fonts downloaded from the Internet (for example, 
Zebra).

Locating and removing a corrupt font can be done manually, by selectively removing fonts and then performing the 
solutions above. Third-party utilities (such as Font Doctor) exist to manage fonts, identify corrupt fonts, and so on.

After removing a bad or corrupt font, perform Solution 2 to rebuild the font cache database.

More Help topics 
Font problems | Mac OS X

Font problems | Windows

Error "Could not convert Unicode characters" | After 
Effects

Issue
The following error occurs when you start or use After Effects CS3, CS4, or CS5:

"After Effects error: Could not convert Unicode characters. (23::46)"

Solutions

Solution 1: Use single-byte characters for filenames, paths, and hard disks.
Change instances of multibyte characters (such as Chinese, Hebrew, or Japanese characters) to single-byte characters 
(such as English characters). 

Solution 2: Replace the AMT.zdct file for the target language.

http://kb2.adobe.com/cps/327/327791.html
http://kb2.adobe.com/cps/328/328607.html
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Mac OS
1 Open the Applications/Adobe After Effects CS5 (or CS3 or CS4) folder.

Right-click the Adobe After Effects CS4 application icon and choose Show Package Contents.

Open the Content/Resources/AMT Languages folder.

Note the name of the .txt file in this folder, which is the code for the language that After Effects was installed in. This 
language is the target language. For example, US English is en_US, Turkish is tr_TR, Russian is ru_RU, and so on. A list 
of commonly used language codes is available here.

Go back to the Resources folder and open the AMT folder.

Open the folder named with the target language code you identified in step 4.

Place a tilde character (~) at the beginning the AMT.zdct filename. This step causes After Effects to ignore the file, but 
preserves this file as a backup.

Go back to the AMT folder and open the folder for en_US. (You can also choose other languages that are unaffected by 
this problem, such as fr_FR for French or es_ES for Spanish.)

Copy the AMT.zdct file from this folder to the target language folder, from step 6. To copy the file, hold down the 
Option key while dragging it from one folder to the other. Or, select the file and choose File > Duplicate, then move the 
file to the other folder and remove "Copy" from the end of the filename.

Launch After Effects.

Windows
1 Open the Program Files\Adobe\Adobe After Effects CS4 (or CS3)\Support Files\AMT Languages folder.

Note the name of the .txt file in this folder, which is the code for the language that After Effects was installed in. This 
language is the target language. For example, US English is en_US, Turkish is tr_TR, Russian is ru_RU, and so on. A list 
of commonly used language codes is available here. 

Go back to the Support Files folder and then open the AMT folder.

Open the folder named with the target language code you identified in step 2.

Place a tilde character (~) at the beginning the AMT.zdct filename. This step causes After Effects to ignore the file, but 
preserves this file as a backup.

Go back to the AMT folder and open the folder for en_US. (You can also choose other languages that are unaffected by 
this problem, such as fr_FR for French or es_ES for Spanish.)

Copy the AMT.zdct file from this folder to the target language folder, from step 4. Select the file, choose Edit > Copy, 
navigate back to the target language folder, and choose Edit > Paste.

Launch After Effects. 

Additional information
The AMT.zdct files contain text phrases for menu items that are translated for specific languages. A problem in After 
Effects prevents it from translating special characters used in some languages correctly if the OS language does not 
support those characters.

After Effects was installed in a language that uses a non-Roman Unicode or Cyrillic character set on an OS that doesn't 
match the language. For example, you installed After Effects in Turkish on an English OS.
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Affected languages include:

• Arabic

• Chinese, Simplified

• Chinese, Traditional

• Greek

• Hebrew

• Japanese

• Korean

• Romanian

• Russian

• Turkish

• Ukrainian

After Effects FAQ list
Video2Brain provides video versions of many of these frequently asked questions and answers at Adobe After Effects 
Frequently Asked Questions.

Conduct discussions on the general After Effects forum.

After Effects FAQ list
FAQ: What information should I provide when asking a question on the After Effects user forum?

FAQ: How do I reduce or prevent flicker?

FAQ: Where can I get help with downloading and installation?

FAQ: Where can I get information and help regarding pricing, shipping, orders, and activation?

FAQ: How do I find information about After Effects?

FAQ: Why does horizontal motion stutter (judder) in my movies, such as during pans?

FAQ: Why can't I see my changes until I let go of the mouse button?

FAQ: What is the best format for rendering and exporting from After Effects?

FAQ: Why is my output file huge, and why doesn't it play back smoothly in a media player?

FAQ: What are optimum memory settings for best performance in After Effects?

FAQ: Why doesn't AVI appear as an export format in the Render Queue?

FAQ: Why isn't the anchor point centered in shape layers?

FAQ: Why are my vector graphics (for example, from Illustrator) jagged or soft?

FAQ: Why is there no audio (sound) in my output file?

FAQ: How can I play or preview sound (audio)?

https://www.video2brain.com/en/courses/adobe-after-effects-cs5-frequently-asked-questions
https://www.video2brain.com/en/courses/adobe-after-effects-cs5-frequently-asked-questions
https://forums.adobe.com/community/aftereffects_general_discussion
https://forums.adobe.com/thread/961743
https://forums.adobe.com/thread/1038934
https://forums.adobe.com/thread/957945
https://forums.adobe.com/thread/907238
https://forums.adobe.com/thread/688250
https://forums.adobe.com/thread/878948
https://forums.adobe.com/thread/737571
https://forums.adobe.com/thread/729526
https://forums.adobe.com/thread/684381
https://forums.adobe.com/thread/543440
https://forums.adobe.com/thread/478655
https://forums.adobe.com/thread/448601
https://forums.adobe.com/thread/432370
https://forums.adobe.com/thread/426347
https://forums.adobe.com/thread/423108
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FAQ: Why does my layer (camera) move back and forth between keyframes of equal value?

FAQ: Why won't After Effects import my PSD file as a composition but flattens it?

FAQ: How do I make fire, fog, smoke, or explosions?

After Effects CS5 known issues, bugs (partial list)
Important: Be sure to install the recent updates for After Effects CS5 and Adobe Media Encoder. These updates fix 
many bugs.

If you encounter a problem not mentioned here, submit a detailed bug report. You can also visit the After Effects user-
to-user forum for assistance.

See the After Effects 10.0.2 release notes for other known issues.

Possible hang on start if firewall or other software (such as ZoneAlarm or FileMaker) blocks communication with 
After Effects and related components

See this Technical Support document for more information and solutions.

BMP footage in a CS4 project opens as missing footage

Workaround: Relink footage after opening.

Purged cached frames when a second RAM preview is initialized and multiprocessing is enabled.

When Memory and Multiprocessing is enabled for "Render Multiple Frames Simultaneously," frames cached by 
foreground processes can be purged when you initiate a second RAM preview. (54071 and 53844)

Problems rendering to MPEG4 format when "Short Header" is enabled

When you render to the MPEG4 output module, avoid enabling the "Short Header" parameter under "Format Options," 
if possible. Enabling this option can cause various problems with the rendered media file. (54118)

Some incorrect constrained output media sizes when rendering to MPEG-2 format

Some composition sizes can result in improperly constrained output media sizes. This issue occurs when you use the 
MPEG-2 output module with certain non-default combinations of the "Profile" and "Level" parameters under Format 
Options (54115).

Incorrect pixel aspect ratio when rendering to AVI format using the "None" codec

AVI files rendered with the "None" codec from compositions that don't match the target output file's dimensions can 
be restricted to a square pixel aspect ratio. (2563466)

Possible crash with Turbulent Noise effect when rendering to FLV format

The Turbulent Noise effect can crash After Effects when rendering to the FLV output module with a low value in the 
"Undershoot" parameter (54113).

Redraw issue for Live Photoshop 3D models when modifying the camera

Live Photoshop 3D models do not redraw when modifying camera properties if motion blur is enabled; workaround is 
to purge the image cache (54123).

Minimized application becomes nonresponsive while Live Photoshop 3D is engaging the ray traced renderer 
(Windows only)

https://forums.adobe.com/thread/422875
https://forums.adobe.com/thread/415490
https://forums.adobe.com/thread/415182
http://blogs.adobe.com/toddkopriva/2011/04/after-effects-cs5-10-0-2-update-a-few-big-bug-fixes.html
http://www.adobe.com/go/wish
http://forums.adobe.com/community/aftereffects_general_discussion
http://forums.adobe.com/community/aftereffects_general_discussion
http://www.adobe.com/support/documentation/en/aftereffects/releasenotes.html
http://kb2.adobe.com/cps/857/cpsid_85711.html
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If you minimize After Effects while Live Photoshop 3D is engaging the ray traced renderer, it doesn't come back to the 
foreground until rendering is complete. A workaround is to engage Caps Lock to disable rendering (2579653).

Possible incorrect handling of gamma or color values when opening pre-CS5 projects that use the legacy 
QuickTime gamma adjustment setting

The "MediaCoreQTCodecRulesCS5.xml" file isn't loaded when opening pre-CS5 projects that have the "Match Legacy 
After Effects QuickTime Gamma Adjustments" checkbox enabled. (The MediaCoreQTCodecRulesCS5.xml file 
governs color handling behaviors in some QuickTime codecs.) This issue can cause incorrect handling of gamma or 
color values in QuickTime source files (2572685).

Blocky artifacts in RGB color channels using Canon 5D MKII footage

 

Colors from DPX file not correct in After Effects CS5 (Mac 
OS)

Issue
When you import DPX files into Adobe After Effects, the colors are not correct. Colors may appear too saturated or 
too bright.

Solution
Note: This can occur if you have Glue Tools (http://www.gluetools.com/products_dpx.html) installed. Glue Tools 
installs software into QuickTime that makes QuickTime attempt to handle the files, rather than the native After Effects 
DPX importer.

Force After Effects to use the built-in DPX importer rather than the one provided by Glue Tools.

1 Choose File > Import > Import File.

2 Under Enable, choose All Files.

3 From the Format menu, choose DPX/Cineon.

4 Choose the file(s) you want to import, and click Open.

Can't set frame rate for WMV or FLV output from After 
Effects CS5 to custom value 

http://www.gluetools.com/products_dpx.html
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Issue
When you choose to render and export a movie to WMV (Windows Media) or FLV format, a "Settings mismatch" alert 
appears at the bottom of the Output Module Settings dialog box. If you click the yellow triangle icon at the bottom of 
the Output Module Settings dialog box, this message is shown:

"Warning: Frame rate of output file will be adjusted from <n> to <m> fps to meet format constraints. Audio may not 
synchronize."

Solution
Create an output module template (Edit > Templates > Output Module) with your desired settings, and assign that 
template to the render item. (See "Output module templates")

Additional information
When you choose an output module and change settings in the Output Module Settings dialog box, the settings are 
checked against a set of constraints for certain formats. For example, the MPEG-2 DVD format output only allows 
parameters that fit the DVD specification; movies created outside of these constraints may not play in a DVD player 
that conforms to the DVD specification.

Many formats are unconstrained. Many codecs used inside QuickTime and AVI containers are unconstrained, as are 
all of the image-sequence formats.

In After Effects CS5, there is a known issue that causes WMV and FLV output frame rates to be constrained 
unnecessarily.

The frame rate values for WMV should be unconstrained, but After Effects CS5 constrains the frame rate in WMV files 
to a preset group of values: 1, 5, 6, 7.5, 8, 10, 12, 12.5, 15, 24, 25, 29.97, 30, 50, 59.94, 60.

The frame rate values for FLV should be unconstrained, but After Effects CS5 constrains the frame rate in FLV files to 
a preset group of values: 1, 5, 8, 10, 12, 12.5, 15, 24, 25, 29.97, 30.

By creating an output module template and applying this template to a render item, you bypass this bug. Because a 
template isn't associated with a specific composition, there is no associated frame rate for it to check against, so the 
constraint checking doesn't occur.

For more information about frame rate, see "Frame rate".

Alpha channel in ProRes 4444 footage ignored by After 
Effects CS5.

Issue
When you import ProRes 4444 media into Adobe After Effects CS5, the alpha channel information is ignored. 

Solution
On Mac OS:

1 Close all Adobe applications.

http://help.adobe.com/en_US/aftereffects/cs/using/WS3878526689cb91655866c1103a4f2dff7-79dba.html#WS64B35A57-E375-425d-892A-D71497C848F3a
http://help.adobe.com/en_US/aftereffects/cs/using/WS3878526689cb91655866c1103906c6dea-7f3ea.html
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2 Copy the MediaCoreQTCodecRulesCS5.xml file in your Users/[username]/Library/Application 
Support/Adobe/Common folder to your desktop in case you need to revert any changes made in subsequent steps.

3 Open the MediaCoreQTCodecRulesCS5.xml file in your Users/[username]/Library/Application 
Support/Adobe/Common folder in a text editor.

4 Find the codec='ap4h' and platform='mactel' entries for both directions (encode and decode).

5 Change the deepdecodefourcc value for each from 'v210 to 'b64a' to match the following example lines:<QTCodec 
codec='ap4h' vendor='****' platform='mactel' direction='encode' versionlow='0x00000' versionhigh='*' 
gammatag='false' cvbuffertag='0' deepdecodefourcc='b64a' decodefourcc='argb' /> and<QTCodec codec='ap4h' 
vendor='****' platform='mactel' direction='decode' versionlow='0x00000' versionhigh='*' gammatag='false' 
cvbuffertag='0' deepdecodefourcc='b64a' decodefourcc='argb' /> 

6 Restart After Effects CS5 and see if the alpha channel information is seen and interpreted correctly by After Effects. 
If it isn't, let us know by filing a bug report.

On Windows:

The fix is the same, but the .xml file is located in your user AppData\Roaming\Adobe\Common\ directory and the 
entries for codec='ap4h' and platform='windows' need to be modified instead. 

http://blogs.adobe.com/toddkopriva/2010/04/send-feedback-about-after-effe.html
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