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Legal notices

Legal notices
For legal notices, see http://help.adobe.com/en_US/legalnotices/index.html.

A note to our customers
Adobe provides this searchable PDF of archived technical support documents as a service to our 
customers who own and continue to enjoy older, unsupported versions of our software products. The 
information in these documents is not updated, and will become increasingly less accurate as 
hardware, browsers, and operating systems continue to evolve. Please be aware that these archived 
documents reflect historical issues and solutions for products that are no longer supported. Adobe 
does not warrant that the information in this document is accurate.
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Troubleshoot printing problems (InDesign)
What's Covered

• Determine the level of the problem 

• Troubleshoot printing problems at the document level 

• Troubleshoot printing problems at the application level 

• Troubleshoot printing problems at the printer level 

• Resolve problems printing to a PostScript printer 

• Resolve problems printing to a non-PostScript printer 

• Troubleshoot printing problems at the system level 

This document can help you resolve problems that occur when you print from Adobe InDesign. To get the most from 
this document, perform the tasks in order. Keep track of the tasks you perform and the results of each one, including 
errors or other problems. Adobe Technical Support can use this information to better assist you, should you need to 
call.

Known printing problems and solutions to specific errors are documented in the Adobe Support Knowledgebase on 
the Adobe website at www.adobe.com/support/. If you can't find a specific solution to your problem, follow these 
procedures to isolate and resolve the issue.

When you attempt to resolve a printing issue, the first step is to determine the conditions under which the problem 
occurs. For example, was the error a one time problem or can it be reproduced consistently when printing all 
documents, some documents or a specific document. The steps and tests below will help you define how and when your 
printing issue occurs so that a solution can be found.

Determine the level of the problem

You should first verify whether the problem is a recurring issue. If the issue recurs consistently, then you can whether 
it is caused at the document, application, or system level.

1. Restart the computer and try printing again.

If the error doesn't occur, it may have been caused by a temporary communication problem, low system resources, or 
other temporary environmental factors. If you can print without error when you first restart the computer, but the error 
occurs again later, troubleshoot the issue at the system level.

2. Turn off the printer, turn it back on, and then try printing again.

If the error doesn't occur, an issue with the printer's memory may have caused the problem. If the error recurs further 
troubleshooting is required.

3. Create a new document, draw a box on the page using the Rectangle tool, and print the document.

If you can print a new document, but not the original document, troubleshoot the error at the document level.

4. Print from another application.

http://helpx.adobe.com/indesign/kb/#main_h1
http://helpx.adobe.com/indesign/kb/#main_h2
http://helpx.adobe.com/indesign/kb/#main_h3
http://helpx.adobe.com/indesign/kb/#main_h4
http://helpx.adobe.com/indesign/kb/#main_h5
http://helpx.adobe.com/indesign/kb/#main_h6
http://helpx.adobe.com/indesign/kb/#main_h7
http://www.adobe.com/support/
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If you can print from another application (for example, WordPad or TextEdit) but not from InDesign, troubleshoot the 
problem at the application level.

5. Print to another printer.

If another printer is available, then try printing the document to another printer. If you can print to a different printer, 
then check to make sure that the original printer is turned on and is online. Remove and reconnect the printer cables, 
ensure that they are connected properly, and then run a self-test on the printer to check for mechanical failure or 
damaged cables. If none of these steps identify the problem, then troubleshoot the error at the system level.

Troubleshoot printing problems at the document level

If the error doesn't occur when you print a new document, the document's print settings may be invalid, a particular 
object or font used in the document may be damaged, or the structure of the document may be damaged. Do one or 
more of the following tasks to troubleshoot an error that occurs only when you print a particular document.

Note: Problems that occur at the system level may appear to be document-specific if they occur due to the complexity 
of the document.

1. If you print to a PostScript printer, send the PostScript error handler to the printer.

Windows:

1 Choose File > Print.

2 Click the Setup button.

3 Right-click the printer and choose Properties.

4 In the General tab, click Printing Preferences.

5 Click Advanced.

6 Expand Document Options and then expand PostScript Options. If Send PostScript Error Handler is not set to Yes, 
click it and choose Yes from the pop-up menu.

Mac OS X:

1 Choose File > Print.

2 Click the printer.

3 Choose Error Handling from the menu below the Presets menu.

4 Select Print Detailed Report, and then click Print.

5 Click Print.

If a PostScript error is causing the problem, the PostScript error handler prints a page with error information. For help 
interpreting PostScript errors, see document 328515, Troubleshoot PostScript errors."

2. Exclude graphics when you print the document.

To exclude graphics when you print the document:

1 Choose File > Print.

2 Click Graphics, and then choose None from the Send Data menu.

3 Click Print.

If the document prints successfully, one or more of the graphic elements on the page may be damaged. Remove the 
graphics one at a time, and print the document after you remove each graphic to determine whether a damaged graphic 
is causing the print error. Delete and replace any damaged graphics. You may need to re-export a graphic from the 
application in which you created it.
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A successful print job may also indicate inadequate printer memory. Common symptoms of insufficient printer 
memory include fonts being substituted and missing data. Simplify the publication to see if it will print with fewer 
graphics.

Note: If the document contains only graphical elements, then you will receive a blank page when you print only if the 
option to print blank pages is enabled in InDesign (select Print Blank Pages in the General section of the Print dialog 
box).

3. If you print to a PostScript printer, exclude fonts when you print.

If you choose to exclude fonts when you print from InDesign, the printer substitutes printer-resident fonts for fonts that 
are specified in the document instead of downloading the fonts to the printer.

To exclude fonts when you print:

1 In InDesign, choose File > Print.

2 Click Graphics.

3 In the Fonts section, choose None from the Download menu.

If the document prints, the printing problem may be related to one of the fonts used in the document. If the document 
uses a large number of fonts, excluding the fonts makes the document less complex. Test the fonts that are specified in 
the document one at a time in a new document to determine if one or more of the fonts is damaged.

4. Verify that links in the document are valid.

When you place graphic and text elements in a document, InDesign creates a link to the original graphic. InDesign 
relies on the original graphic to obtain information it uses to display and print the file correctly.

To view the status of links, choose Window > Links. Unlink or relink any files where the file name is preceded by a 
question mark or other symbol. For an explanation of the various symbols that may appear in the Links dialog box, see 
"About the Links palette" in InDesign Help. For additional information about links in InDesign, see "Managing links 
and embedded graphics" in InDesign Help.

5. Use the Console utility to identify software conflicts. (Mac OS)

If the problem causes InDesign to freeze, the Console utility can identify software that causes the conflict.

To use the Console utility to identify software conflicts:

1 Choose Go > Applications, open the Utilities folder, and then double-click Console.

2 Choose Console > Preferences 

• For Mac OS 10.4.x and earlier, click the Crashes tab and select Log Crash Information in ~/Library/Logs/, and 
then select Automatically Display Crash Logs.

• For Mac OS 10.5.x and later, select the Bring log window to front option.

3 Restart InDesign, and try to re-create the problem. If the problem recurs, reinstall or update the software identified 
in the crash log.

6. Troubleshoot third-party plug-ins.

Remove third-party plug-ins from the InDesign [version] Plug-ins folder, and then restart InDesign. If the problem 
recurs, move the plug-ins back to the InDesign Plug-ins folder. If the problem doesn't recur, identify conflicting plug-
ins.

To identify conflicting plug-ins:

1 Choose Help > Configure Plug-Ins (Windows) or InDesign > Configure Plug-Ins (Mac OS).
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2 Select All Plug-Ins for the Set and then deselect all the options in the Display section except Third Party. Create a 
list of these Plug-Ins.

3 Quit InDesign and move one third-party plug-in back to the InDesign plug-ins folder:

• Windows: C:\Program Files\Adobe\Adobe InDesign [version]\Plug-Ins

• Mac OS X: [Computer]/[Hard Drive]/Applications/Adobe InDesign [version]/Plug-Ins

4 Restart InDesign and try to re-create the problem: 

• If the problem doesn't occur, repeat steps 3-4.

• If the problem recurs, contact the developer of the plug-in you last moved to inquire about an update.

7. Print from within a new user account.

Occasionally, a user account can become corrupted and prevent the installer from accessing or creating the necessary 
files and folders. Create a new account, log in to the new account, and then try to install or run the Adobe application. 
Do not delete your existing Windows account &acirc;&rdquo; the new account is only for testing purposes, and you 
can revert back to your original Windows account after you finish testing. Once you have the new account setup, login 
to it and see if you can reproduce the problem.

On Windows: On Windows XP, you can create a new user account by going to Start button > Settings> Control Panel 
> User Accounts. For Windows Vista, see the " Create new local administrator account " section of "Common Microsoft 
Windows Vista procedures" (TechNote kb401275 ). 

For more details on creating a new Windows user account, consult with your IT administrator or the Windows 
documentation.

On Mac OS X v10.5.x:

1 From the Apple menu, choose System Preferences.

2 Click Accounts.

3 Click the lock icon in the lower-left corner of the window and enter your administrator password, then click the OK 
button.

4 Click the plus sign toward the bottom of the window on the left.

5 Set the Account type to Administrator.

6 Enter the user name (for example, type test). Make sure to enter a password that you'll remember, such as test,

7 Click the Create Account button, and then close the Accounts window.

8 Choose Log Out from the Apple menu.

9 When the log in screen displays, choose the test user.

On Mac OS X v10.3.x - 10.4.x:

1 From the Apple menu, choose System Preferences.

2 Click Accounts.

3 If the lock icon in the lower-left corner of the window displays as locked, click it and enter your administrator 
password, then click the OK button.

4 Click the plus sign toward the bottom of the window on the left.

5 Enter the user name (for example, type test). Make sure to enter a password that you'll remember, such as test.

6 Click the Security button (OS 10.3.x only)

7 Select the checkbox next to Allow User To Administer This Computer. This makes the test user an administrator.

http://www.adobe.com/go/kb401275#create_local_adminacct
http://www.adobe.com/go/kb401275#create_local_adminacct
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8 Click the Create Account button, and then close the Accounts window.

9 Choose Log Out from the Apple menu.

10 When the log in screen displays, choose the test user.

8. Troubleshoot the document as a damaged document.

Perform the tasks listed in document kb403982, "Troubleshoot damaged InDesign documents (CS3, CS4)".

Troubleshoot printing problems at the application level

If you receive an error when you print any InDesign document, one of the InDesign resource files may be damaged, or 
InDesign may be incompatible with the printer driver, video driver, or another device driver on the system. Do one or 
more of the following tasks to identify the cause of an application-wide problem.

1. Rename or delete the InDesign Defaults and the InDesign SavedData files.

Note: Re-creating the InDesign preference files restores settings to their defaults, so you will lose custom settings 
associated with the old preference files. Make sure to close InDesign before you re-create the preference files or 
InDesign may behave unexpectedly.

To re-create the InDesign preference files automatically:

1 Quit InDesign.

2 Now launch the application and immediately hold down the appropriate keys for your OS: 

• Mac OS X: Control + Option +Command + Shift

• Windows: Control + Alt + Shift

3 A dialog will pop up asking you if you would like to "Delete InDesign Preference Files?" Click Yes.

4 InDesign will now launch with defaults and regenerated Preferences

To re-create the InDesign preferences files manually:

1 Delete or rename the preferences files. 

• On Mac OS X: InDesign SavedData Users/[user]/Library/Caches/Adobe InDesign/Version 5.0/InDesign 
SavedData InDesign Defaults Users/[user]/Library/Preferences/Adobe InDesign/Version 5.0/InDesign Defaults

• On Windows XP: InDesign Defaults C:\Documents and Settings\[user]\Application 
Data\Adobe\InDesign\Version 5.0 InDesign SavedData C:\Documents and Settings\[user]\Local 
Settings\Application Data\Adobe\InDesign\Version 5.0\Caches

• On Windows Vista: InDesign Defaults C:\Users\labuser\AppData\Roaming\Adobe\InDesign\Version 
5.0\InDesign Defaults InDesign SavedData C:\Users\labuser\AppData\Roaming\Adobe\InDesign\Version 
5.0\Caches\InDesign SavedData

2 Restart InDesign. InDesign creates new preference files.

If the problem persists, then you can restore the original preferences by deleting the new files and renaming the old 
preference files back to their original names.

2. Make sure that you have the most recent printer driver installed for the printer to which you're printing. 
(Windows only)

Install the most recent driver for the printer to which you print:

• If you print to a PostScript printer, download the Adobe Universal PostScript Windows Driver Installer from the 
Adobe website at www.adobe.com/support/downloads/ .

http://go.adobe.com/kb/ts_kb403982_en-us
http://www.adobe.com/support/downloads/
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• If you print to a non-PostScript printer, contact the printer manufacturer for the latest version of the driver for the 
printer.

3. If you print to a PostScript printer, optimize PostScript for speed. (Windows only)

1 Choose File > Print.

2 Click Setup, and do one of the following tasks: 

• In Windows Vista or XP, click Setup, select a printer, click Preferences, and then click Advanced.

• In Windows 2000, click the Layout tab, and then click Advanced.

3 Expand Document Options, and then expand PostScript Options.

4 Choose PostScript Output Option.

5 Choose Optimize for Speed from the pop-up menu, and then click OK.

6 Click OK and then click Print.

4. Disable the Page Protection feature.

See the documentation included with the printer for instructions on how to disable this feature.

5. If the problem occurs when you print over a network, connect the computer directly to the printer and try 
printing again.

If you can't connect directly to the printer, then save the document as a PostScript file and then send the file to the 
printer from a command line on a computer that can be connected directly to a printer. For more information about 
creating a PostScript file, see "Creating a device- and driver-dependent PostScript file" in InDesign Help.

6. Make sure the printer to which you're printing supports the current printing operations.

For example, you shouldn't print color separations of EPS graphics to a non-PostScript printer. For more information 
about the printer's capabilities, contact the printer manufacturer.

7. Ensure that you've installed any available updates for the version of InDesign you use.

Adobe posts updates and bug fixes to InDesign periodically on its website at www.adobe.com/support/downloads/.

Troubleshoot printing problems at the printer level

Determine whether you are using a Postscript or a non PostScript printer. Once you have determined which kind of 
printer you are using, follow the appropriate steps below.

To verify that you are using a Postscript printer, check the printer properties (Windows only):

Note: If you are using a Macintosh computer, then check your printer documentation or contact your printer 
manufacturer to determine if your printer is a Postscript device.

1 Open the Printers control panel.

2 Right-click the desired printer and choose Properties.

3 Choose the Device Setting tab.

4 Right-click the driver name at the top of the tree and choose About.

If you are using a PostScript printer, "PostScript Printer Driver" appears at the top of the window along with the driver 
version, the PPD name, and the PPD version.

Resolve problems printing to a PostScript printer

If you have problems printing to a PostScript printer, do one or more of the following tasks, printing after each task:

http://www.adobe.com/support/downloads/
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1. Use an updated printer driver.

Use the Universal Installer (WinInstaller) to automatically install the PostScript printer driver that is compatible with 
your version of Windows. The most recent version of the Universal Installer is available on the Adobe website at 
www.adobe.com/support/downloads/main.html.

Note: If you use a network printer, then the print server may not be set up to run alternate drivers for different operating 
systems on client computers. You may be using a printer driver that is compatible with the print server's operating 
system but not with your computer's operating system. To install a printer driver that is compatible with your operating 
system, reconfigure the network printer using the Add Printer Wizard. For instructions, see task 6 below, "Install a 
printer driver that is compatible with your operating system."

2. Use an updated PPD file.

A PostScript Printer Description (PPD) file describes the capabilities of a PostScript printer for settings such as 
margins, color, and resolution. Incorrect or outdated PPD files can increase print times. Configure your printer in the 
Printers Control Panel with the PPD file recommended by the printer manufacturer.

To obtain a PPD file for your device, contact the printer manufacturer or visit 
www.adobe.com/support/downloads/main.html.

3. Set up the printer driver to output optimized PostScript code. (Windows only)

If you set up the printer driver to output PostScript code that's optimized for portability and in binary format, the 
amount of scaling the driver must do is minimized, thus preventing it from losing portions of images.

1 Choose Start > Settings > Printers.

2 Right-click the printer, and choose Properties.

3 Click the General tab.

4 Click Printing Preferences, and then click Advanced.

5 Expand the Document Options, and then expand the PostScript Options.

6 Set PostScript Output Option to Optimize For Portability.

4. Create more free disk space.

Make sure that plenty of free hard disk space is available: Adobe recommends that free space is equivalent to three to 
five times the size of the file you print. To create more space, search for and delete temporary (.tmp) files on your 
computer, and clear the disk cache that the web browser uses. For instructions about clearing the disk cache, see the 
documentation for the browser. You can also free up disk space bypassing the spool file, which stores temporary files 
to the system disk during printing. For instructions for bypassing the spool file, see the documentation included with 
Windows.

5. Print from a local printer.

If you print to a network printer, try printing the file from a computer that is connected directly to a local printer. If the 
file prints correctly, network-related issues may be the cause. Contact the network administrator for assistance.

6. Install a printer driver that is compatible with your operating system.

If you use a network printer, then install a printer driver that is compatible with your operating system. Print servers 
don't always provide drivers for operating systems running on client computers, so you may be using a printer driver 
that is appropriate for the print server's operating system but not for your computer's operating system.

1 Choose Start > Settings, and then double-click Printers And Faxes (Windows XP) or Start > Control Panel > 
Hardware > Printers (Windows Vista).

http://www.adobe.com/support/downloads/main.html
http://www.adobe.com/support/downloads/main.html
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2 Right-click the network printer, and then choose Delete.

3 Double-click Add Printer, and then click Next.

4 Select Local Printer Attached To This Computer, deselect Automatically Detect And Install My Plug And Play 
Printer, and then click Next.

5 Select Create A New Port.

6 Choose Local Port from the Type of Port menu, and then click Next.

7 In the Port Name dialog box, type the path for the print server and printer (for example, 
\\printservername\printername), and then click OK.

8 Follow the onscreen instructions to install a driver that matches the brand and model of your network printer.

Resolve problems printing to a non-PostScript printer

If you have problems printing to a non-PostScript printer, do one or more of the following tasks, printing after each 
task:

Disclaimer: Some of these solutions require you to change the printer driver properties. The locations for specific 
properties vary by printer and by printer driver. Therefore, Adobe Technical Support cannot provide detailed 
information about the location for each property. Contact the printer manufacturer or refer to the printer 
documentation for more information.

1. Try printing as bitmap

By default, InDesign uses GDI commands to print to non-PostScript printers on Windows, and PostScript to print to 
the Mac OS X CUPS printing architecture, which passes the data as PDF to the printer driver to convert to it's native 
drawing language. Where possible, InDesign offers an option to send each page as bitmap data encapsulated within 
standard non-Postscript printing protocols. To enable this option

1 Choose File > Print.

2 Click the Advanced pane.

3 Check the Print as Bitmap checkbox. Select an appropriate resolution for your printer.

2. Ensure that the printer has enough memory.

Ensure that the printer has enough memory to print all page elements. To print at 300 dpi, the printer should have at 
least 2 MB of available RAM. To print at 600 dpi, the printer should have at least 4 to 6 MB of RAM. For instructions 
on determining available printer memory, see the printer documentation.

3. Use the printer's PostScript mode.

If the printer has a PostScript option, use the PostScript mode. For details, see the printer documentation.

4. Switch to the standard SVGA driver.

Switch to the standard Windows SVGA driver to determine if your third party video driver causes the problem. If the 
error doesn't occur when you use the standard SVGA driver, then contact the video card manufacturer for an updated 
driver. If you already use the current version, then try using a different video resolution (for example, 1024 x 768 rather 
than something higher).

Troubleshoot printing problems at the system level

If nothing prints from any application, then contact Apple Technical Support, Microsoft Technical Support, or the 
printer manufacturer. Always check the physical connection between the printer and the computer before calling, as 
the solution may be as simple as reconnecting a loose cable.
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Also, consider what has changed on the system recently that may be impacting the printing process. For example, have 
you performed any of the following tasks:

• Updated your hardware

• Added new software

• Updated existing software

• Deleted software

• Installed or deleted fonts

• Added or removed hardware components

• Recently connected to a network

• Cleaned up the hard drive, or erased unused files

• Encountered random system errors

• Encountered errors in any other applications

Often, a change to the system directly corresponds to the appearance of a printing problem. You should keep a record 
of changes made to the system as a resource for troubleshooting printing and other problems.

Additional Information
kb403982: Troubleshoot damaged InDesign documents ( CS3,CS4)

http://www.adobe.com/go/kb403982


13

Last updated 11/12/2015

Troubleshoot installation problems with InDesign CS4 
(Windows XP)
What's covered

• Beginning troubleshooting 

• Intermediate troubleshooting 

• Advanced troubleshooting 

This document can help you resolve problems that interrupt the installer for Adobe InDesign CS4 on Windows XP. 
These problems can manifest themselves in many different ways, including (but not limited to) a frozen cursor or 
screen, or an error.

Please note that this document does not address problems related to serial numbers. For these problems, contact Adobe 
Customer Services. To contact Adobe Customer Service in your region for assistance, visit the Adobe website at 
http://www.adobe.com/, select your region from the menu at the top of the page, and then click Contact Us.

Different factors can interrupt the installation of an application, including the AutoPlay feature in Windows, a 
conflicting application, incorrect data in the Windows registry, or hardware problems. Although a system error may 
occur only when you work with Adobe InDesign CS4, Adobe InDesign may not necessarily be the cause--it may be the 
only application that uses enough memory or processor cycles to expose the problem.

To get the most from this document, perform the tasks in order. Keep a log of the tasks you perform and the results of 
each, including errors or problematic behavior. Adobe Technical Support can use this information to better assist you, 
should you need to call.

Note: The procedures in this document are based on the default interface of Windows XP. If the interface is customized, 
some procedures may vary. For example, a commonly encountered difference is the navigation to Control Panel from 
the Start menu: You may navigate Start > Settings > Control Panel instead of Start > Control Panel. Additoinally, the 
procedures in this document assume you are using the Classic View of the Control Panel: To view the Control Panel in 
the Classic View, click Switch To Classic View on the Control Panel navigation bar on the left side of the window.

See "Show hidden files, hidden folders, and all file name extensions in Windows Explorer (Windows XP)" (TechNote 
kb404856) for details.

Beginning troubleshooting

The tasks in this section can help you resolve the most common installation problems. Before performing any of these 
tasks, back up all personal files.

1. Make sure that the system meets the minimum requirements for Adobe InDesign CS4.

http://helpx.adobe.com/indesign/kb/#main_Begin
http://helpx.adobe.com/indesign/kb/#main_Inter
http://helpx.adobe.com/indesign/kb/#main_Advanced
http://www.adobe.com/
http://www.adobe.com/go/kb404856
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Adobe InDesign CS4 may not run correctly on a system that doesn't meet the following requirements:

Windows

• 1.5GHz or faster processor

• Microsoft Windows XP with Service Pack 2 (Service Pack 3 recommended) or Windows Vista Home Premium, 
Business, Ultimate, or Enterprise with Service Pack 1 (certified for 32-bit Windows XP and Windows Vista)

• 512MB of RAM (1GB recommended)

• 1.8GB of available hard-disk space for installation; additional free space required during installation (cannot install 
on flash-based storage devices)

• 1,024x768 display (1,280x800 recommended) with 16-bit video card

• DVD-ROM drive

• QuickTime 7 software required for multimedia features

• Broadband Internet connection required for online services

For updates to system requirements, visit www.adobe.com/products/indesign/systemreqs.

2. Check the DVD and DVD-ROM drive.

Dust or dirt on a DVD can interfere with installation and prevent the DVD-ROM drive from recognizing the DVD. 
Examine the Adobe InDesign DVDs for dirt, dust, or fingerprints. Gently wipe the bottom of each DVD from the 
center outward with a soft, lint-free cloth.

Verify that the DVD-ROM drive can read other DVDs. If it can't, examine the DVD caddy or loading tray for dirt, and 
clean it with a lint-free cloth. If it still can't read other DVDs, contact the DVD-ROM drive manufacturer or the 
computer manufacturer.

Intermediate troubleshooting

If the tasks in the previous section don't solve the problem, then try the following intermediate troubleshooting tasks.

3. Install InDesign CS4 in a simplified mode from the desktop.

Software and services that load automatically with Windows (for example, virus protection utilities) can conflict with 
the InDesign CS4 installer and cause problems in InDesign CS4. To prevent conflict, reinstall InDesign CS4 while 
Windows is in simplified mode doesn't resolve the issue, try installing and running InDesign CS4 on a different 
computer, or on a different hard drive.

To copy the InDesign CS4 install files to the desktop:

1 Insert the InDesign CS4 disc into your DVD-ROM drive.

2 Click the Start button, and then click Computer.

3 Right-click on your DVD-ROM drive, and then click Explore.

4 Copy the Adobe InDesign CS4 folder from the DVD to your desktop. If you are asked to confirm replacing any 
folders with the same name, select "Yes".

5 Click the Start button, and then click Computer.

To start Windows XP in a simplified mode:

1 Choose Start > Run.

2 Type msconfig in the Open text box, and then press Enter.

3 On the Startup tab, click Disable All.

http://www.adobe.com/products/indesign/systemreqs


15

Last updated 11/12/2015

4 On the Services tab, select Hide All Microsoft Services, click Disable All, then reselect FLEXnet Licensing Service, 
and then click OK.

5 In the System Configuration dialog box, click OK then Restart.Note: Upon reboot, you'll be notified that the System 
Configuration Utility has made changes to the way that Windows starts up. Click OK, and when the System 
Configuration Utility appears click Cancel.

6 Start the InDesign CS4 installer "setup.exe" in the Adobe CS4 Install\Adobe CS4 folder, and then follow the on-
screen instructions.

To re-enable startup items and services:

1 Choose Start > Run, type msconfig, and click OK.

2 Choose Normal Startup on the General tab, click OK, and restart the computer.

4. Optimize handling of temporary files by Windows XP.

Windows and applications store working data in temporary (.tmp) files that they create on the hard disk. Excessive or 
outdated temporary files can interfere with performance of Windows or applications.

See "Delete temporary files using the Disk Cleanup utility (Windows XP)" (TechNote kb404871) for details

5. Repair and defragment hard disks.

See "Repair and defragment hard disks (Windows XP)" (TechNote kb404981) for details.

6. Scan the system for viruses.

Use current anti-virus software (for example, Symantec Norton AntiVirus or McAfee VirusScan) to check the system 
for viruses. Virus infections can damage software and cause system errors. For more information, see the 
documentation for the anti-virus software.

Advanced troubleshooting

7. Install Adobe InDesign CS4 on a different computer.

Try to install Adobe InDesign CS4 on a different computer to determine if the problem is unique to your computer. If 
you are able to install Adobe InDesign CS4 on a different computer, contact the computer manufacturer. If the problem 
occurs on multiple computers, contact Adobe Technical Support.

8. Visit the Adobe User to User Forums.

You can see if other Adobe customers have a similar problem by visiting the User to User Forums at 
www.adobeforums.com. If you confirm that other users have experienced the same problem, then Adobe Technical 
Support may be able duplicate and research the problem. Otherwise, refer to the system-related or hardware-related 
help.

Troubleshoot installation problems with InDesign CS4 
(Mac OS)
What's covered

• Beginning troubleshooting 

• Intermediate troubleshooting 

• Advanced troubleshooting 

http://www.adobe.com/go/kb404871
http://www.adobe.com/go/kb404981
http://www.adobeforums.com/
http://helpx.adobe.com/indesign/kb/#main_Begin
http://helpx.adobe.com/indesign/kb/#main_Inter
http://helpx.adobe.com/indesign/kb/#main_Advanced
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This document can help you resolve problems that interrupt the installer for Adobe InDesign CS4 on Mac OS X. These 
problems can manifest themselves in many different ways, including (but not limited to) a frozen cursor or screen, or 
an error.

Different factors can cause system errors, including conflicts among device drivers, software, and hardware, and 
corrupt elements in specific files. Although a system error may occur only when you work with Adobe InDesign CS4, 
Adobe InDesign may not necessarily be the cause--it may be the only application that uses enough memory or 
processor cycles to expose the problem.

Please note that this document does not address problems related to serial numbers. For these problems, contact Adobe 
Customer Services. To contact Adobe Customer Service in your region for assistance, visit the Adobe website at 
http://www.adobe.com/, select your region from the menu at the top of the page, and then click Contact Us.

To get the most from this document, perform the tasks in order. Keep a log of the tasks you perform and the results of 
each, including errors or problematic behavior. Adobe Technical Support can use this information to better assist you, 
should you need to call.

Beginning troubleshooting

The tasks in this section can help you resolve the most common system errors. Before performing any of these tasks, 
back up all personal files (for example, Adobe InDesign files you created). Always restart the computer after a system 
error occurs to refresh its memory. Continuing to work without restarting the computer may compound the problem.

1. Make sure that the system meets the minimum requirements for Adobe InDesign CS4.

Adobe InDesign CS4 may not run correctly on a system that doesn't meet the following requirements:

• PowerPC G5 or multicore Intel processor

• Mac OS X v10.4.1110.5.4

• 512MB of RAM (1GB recommended)

• 1.6GB of available hard-disk space for installation; additional free space required during installation (cannot install 
on a volume that uses a case-sensitive file system or on flash-based storage devices)

• 1,024x768 display (1,280x800 recommended) with 16-bit video card

• DVD-ROM drive

• QuickTime 7 software required for multimedia features

• Broadband Internet connection required for online services For updates to system requirements, visit 
www.adobe.com/products/indesign/systemreqs.

Note: To check how much RAM is installed, choose About This Mac from the Apple menu. The Memory value 
indicates the amount of installed RAM. On board video cards may share system memory. Adobe InDesign CS4 cannot 
be installed if the remaining amount of system memory does not meet system requirements.

2. Delete previously installed application files.

You should perform these steps after each failed installation to avoid further problems that partially installed 
components can cause.

To do so, please refer to the following technical document: http://www.adobe.com/go/kb404925

3. Check the installation discs and disc drive.

Sometimes dust or dirt on a DVD can interfere with an installation and prevent your drive from recognizing the media. 
Examine the Adobe InDesign CS4 installation discs for dirt, dust, or fingerprints. Gently wipe the bottom of the disc 
from the center outward with a soft, lint-free cloth.

http://www.adobe.com/
http://www.adobe.com/products/indesign/systemreqs
http://www.adobe.com/go/kb404925
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Verify that the disc drive can read other discs. If it can't, examine the disc caddy or loading tray for dirt and clean it with 
a lint-free cloth. If it still can't read other discs, contact the drive manufacturer or Apple Computer.

4. Log in as a user with administrator access privileges.

If you lack administrator access privileges, then Adobe InDesign may be unable to access necessary files. To determine 
if limited privileges cause the problem, log in as a user with access privileges, and try to re-create the problem. If the 
problem doesn't recur, then the account you were previously using lacks access privileges. Contact your system 
administrator to grant you access privileges.

To log in as a user with access privileges, please refer to the following technical document: 
http://www.adobe.com/go/kb404926

5. Install current Mac OS X updates.

Updates to the Mac OS X operating system can improve its performance and compatibility with applications. You can 
obtain Mac OS X updates from the Apple website, or choose Software Update from the Apple menu. For assistance 
installing updates, contact Apple technical support.

Important: Before you install a system update, check the system requirements for Adobe InDesign CS4 (and any third-
party software or hardware you may use with Adobe InDesign) to ensure compatibility. If the update isn't listed,then 
contact Adobe or the manufacturer of your third-party software or hardware.

6. Run Adobe InDesign while no other applications are running.

To maximize available RAM and reduce the chance that another application may conflict with Adobe InDesign, quit 
open applications, and then restart Adobe InDesign.

If applications don't quit as expected, then force quit them.

To force quit open applications:

1 Choose Force Quit from the Apple menu.

2 In the Force Quit Applications dialog box, select an application, and then click Force Quit.Note: Don't select the 
Finder, which is the core Mac OS component. 

3 Click Force Quit again when Mac OS returns the alert "Do you want to force Adobe InDesign to quit?"

4 Restart Adobe InDesign, try to re-create the error, and continue as follows: 

• If the error doesn't occur, then the application you selected in step 2 conflicts with Adobe InDesign.

• If the error occurs, then repeat steps 3-4; or, if you've quit all open applications, then proceed to the next task.

7. Install the Adobe InDesign CS4 in Safe Boot.

Starting up in Safe Boot does the following to assist troubleshooting your computer:

• It forces a directory check of the startup volume.

• It loads only required kernel extensions (some of the items in /System/Library/Extensions).

• It disables all fonts other than those in /System/Library/Fonts.

• It moves to the Trash all font caches normally stored in /Library/Caches/com.apple.ATS/(uid)/, where (uid) is a user 
ID number such as 501.

• It disables all startup items and any Login Items.

To restart your system in Safe Boot, please refer to the following technical document: 
http://www.adobe.com/go/kb404936

8. Install the Adobe InDesign CS4 from within a new user account.

http://www.adobe.com/go/kb404926
http://www.apple.com/downloads/macosx
http://www.adobe.com/go/kb404936
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To install or run InDesign CS4 from within a new user account, please refer to the following technical document: 
http://www.adobe.com/go/kb404927

9. Install Adobe InDesign CS4 from within a root user account.

For instructions on enabling and logging into the root account on Mac OS X, see "Enabling the root user" in Macintosh 
online Help.

Intermediate troubleshooting

If the tasks in the previous section don't solve the problem, then try the following intermediate troubleshooting tasks.

10. Install Adobe InDesign CS4 from the desktop.

Some system components--for example, device drivers and virus protection utilities--can conflict with the Adobe 
InDesign CS4 installer and result in an incomplete or failed installation. To prevent these conflicts, install Adobe 
InDesign from the desktop.

To copy the InDesign CS4 install files to the desktop:

1 Insert the InDesign CS4 disc into your disc drive.

2 Copy the 'Adobe InDesign CS4' folder from the DVD to your desktop. If you are asked to confirm replacing any 
folders with the same name, select "Replace".

3 Open the Adobe InDesign CS4 Install folder on the desktop.

4 Double-click the Setup file, and follow the on-screen instructions.

Note: If you are installing Production Premium or Master Collection you should not copy the install files for 
OnLocation CS4 as it uses a separate installer.

11. Repair disk permissions by running Disk Utility.

If you log in to an account with administrator privileges, but are still unable to install or run Adobe InDesign CS4, then 
your disk permissions may be damaged.

To repair your permissions using the Disk Utility, please refer to the following technical document: 
http://www.adobe.com/go/kb404928

12. Troubleshoot fonts.

A system error can occur if Adobe InDesign accesses a damaged font. You can troubleshoot fonts to determine if they 
cause the problem.

To do so, please refer to the following technical document: http://www.adobe.com/go/kb405153

13. Check hard disks for damage.

A damaged hard disk can cause installation errors. Check hard disks using a disk utility, such as Apple Disk Utility, 
Alsoft DiskWarrior, or Micromat Drive 10.

Disclaimer: Adobe doesn't support third-party disk utilities but provides the following instructions as a courtesy. For 
support, contact the developer of the disk utility.

To check for damage by using Apple Disk Utility (included on the system CD):

1 Start the computer from the system CD.

2 Choose Installer > Open Disk Utility.

3 Select the disks to be checked, and then click the First Aid tab.

4 Click Repair to check and, if necessary, repair selected disks.

http://www.adobe.com/go/kb404927
http://www.adobe.com/go/kb404928
http://www.adobe.com/go/kb405153
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14. Temporarily disable any virus scanner.

Virus scan software can interfere with software installation. Temporarily disabling anit-virus software can allow 
software to install successfully. The steps below are common procedures use to disable anti-virus software. If the steps 
below do not allow you to disable the anti-virus software refer to its documentation.

1 Click on the anti-virus icon in the Menu Bar.

2 Select the disable Anti-Virus option.

3 Attempt the installation again.

4 Re-enable the anti-virus software after the installation completes successfully.

Advanced troubleshooting

If the tasks in the previous section don't resolve the problem, then you may be able to resolve the problem by 
reformatting your hard disk or by determining if hardware is conflicting with Adobe InDesign.

Disclaimer: Adobe doesn't support hardware and provides these tasks as a courtesy only. For further assistance, contact 
the hardware manufacturer or an authorized reseller. If you troubleshoot hardware problems yourself, then you may 
void the computer's warranty.

Note: Before you remove or rearrange hardware, turn off and disconnect the power to the computer and any peripheral 
devices.

15. Use the Console utility to identify software conflicts.

1 If the problem causes the installer to freeze, the Console utility can identify software that causes the conflict.

2 Choose Go > Applications, open the Utilities folder, and then double-click Console.

3 Click the Logs tab.

4 Expand ~/Library/Logs, and then expand CrashReporter.

5 Select the Adobe InDesign.crash.log.

6 Restart the installer, and try to re-create the problem. If the problem recurs, remove or update the software identified 
in the crash log.

16. Use the Process Viewer to identify and quit processes that may be using large amounts of system resources.

To identify and quit processes, please refer to the following technical document: http://www.adobe.com/go/kb404933

17. Install to a different hard disk that is designated as the startup disk.

Install the system software on a different hard disk (not a different partition on the same disk) and then specify that 
disk as the startup disk. Then, install Adobe InDesign to the new hard disk.

To specify the startup disk:

1 Choose System Preferences from the Apple menu.

2 Select Startup Disk from the System selections.

3 Select the drive to which you reinstalled the system software.

4 Restart the computer.

18. Check for damaged PCI or PCX cards.

Damaged or incompatible PCI or PCX cards can cause system errors. To check PCI or PCX cards, turn off your 
computer, remove any processor accelerator cards, video cards, or other installed expansion cards, and then restart the 
computer.

http://www.adobe.com/go/kb404933
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19. Disconnect peripheral devices.

Disconnect peripheral devices one at a time. Peripheral devices include devices connected by FireWire, USB, Serial 
ATA, IDE, or SCSI. If an error doesn't occur when an external device is disconnected, then there may be a problem with 
the device, the cable, or the connection. Contact the manufacturer of the device for troubleshooting steps for the device.

20. Check for problems with RAM modules.

To check for problems with RAM modules, please refer to the following technical document: 
http://www.adobe.com/go/kb404980

21. Run Adobe InDesign on a different hard drive or computer.

Install and run Adobe InDesign from a different hard drive installed in the same computer or the same hard drive 
installed in a different computer. If the problem doesn't recur, then the hard drive or the motherboard you were using 
previously may be the cause. For assistance, contact the manufacturer.

Troubleshoot installation problems with InDesign CS4 
(Windows Vista)
What's covered

• Beginning troubleshooting 

• Intermediate troubleshooting 

• Advanced troubleshooting 

This document can help you resolve problems that interrupt the installer for Adobe InDesign CS4 on Windows Vista. 
These problems can manifest themselves in many different ways, including (but not limited to) a frozen cursor or 
screen, or an error.

Please note that this document does not address problems related to serial numbers. For these problems, contact Adobe 
Customer Services. To contact Adobe Customer Service in your region for assistance, visit the Adobe website at 
http://www.adobe.com/, select your region from the menu at the top of the page, and then click Contact Us.

Different factors can interrupt the installation of an application, including the AutoPlay feature in Windows, a 
conflicting application, incorrect data in the Windows registry, or hardware problems. Although a system error may 
occur only when you work with Adobe InDesign CS4, Adobe InDesign may not necessarily be the cause--it may be the 
only application that uses enough memory or processor cycles to expose the problem.

To get the most from this document, perform the tasks in order. Keep a log of the tasks you perform and the results of 
each, including errors or problematic behavior. Adobe Technical Support can use this information to better assist you, 
should you need to call.

Note: The procedures in this document are based on the default interface of Windows Vista. If the interface is 
customized, some procedures may vary. For example, a commonly encountered difference is the navigation to Control 
Panel from the Start menu: You may navigate Start > Settings > Control Panel instead of Start > Control Panel. 
Additionally, the procedures in this document assume you are using the Classic View of the Control Panel: To view the 
Control Panel in the Classic View, click Classic View on the Control Panel navigation bar on the left side of the window.

To show hidden files, hidden folders, and all filename extensions in Windows Explorer, please refer to the following 
technical document: http://www.adobe.com/go/kb404880

Beginning troubleshooting

http://www.adobe.com/go/kb404980
http://helpx.adobe.com/indesign/kb/#main_Begin
http://helpx.adobe.com/indesign/kb/#main_Inter
http://helpx.adobe.com/indesign/kb/#main_Advanced
http://www.adobe.com/
http://www.adobe.com/go/kb404880
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The tasks in this section can help you resolve the most common installation problems. Before performing any of these 
tasks, back up all personal files.

1. Make sure that the system meets the minimum requirements for Adobe InDesign CS4.

Adobe InDesign CS4 may not run correctly on a system that doesn't meet the following requirements:

Windows

• 1.5GHz or faster processor

• Microsoft Windows XP with Service Pack 2 (Service Pack 3 recommended) or Windows Vista Home Premium, 
Business, Ultimate, or Enterprise with Service Pack 1 (certified for 32-bit Windows XP and Windows Vista)

• 512MB of RAM (1GB recommended)

• 1.8GB of available hard-disk space for installation; additional free space required during installation (cannot install 
on flash-based storage devices)

• 1,024x768 display (1,280x800 recommended) with 16-bit video card

• DVD-ROM drive

• QuickTime 7 software required for multimedia features

• Broadband Internet connection required for online services

For updates to system requirements, visit http://helpx.adobe.com/x-productkb/policy-pricing/system-requirements-
indesign.html.

Note: To check basic system information, such as processor speed and how much RAM is installed, choose Start > 
Control Panel > System.

2. Check the DVD and DVD-ROM drive.

Dust or dirt on a DVD can interfere with installation and prevent the DVD-ROM drive from recognizing the DVD. 
Examine the Adobe InDesign DVDs for dirt, dust, or fingerprints. Gently wipe the bottom of each DVD from the 
center outward with a soft, lint-free cloth.

Verify that the DVD-ROM drive can read other DVDs. If it can't, examine the DVD caddy or loading tray for dirt, and 
clean it with a lint-free cloth. If it still can't read other DVDs, contact the DVD-ROM drive manufacturer or the 
computer manufacturer.

Intermediate troubleshooting

If the tasks in the previous section don't solve the problem, then try the following intermediate troubleshooting tasks.

3. Install Adobe InDesign CS4 in a simplified mode from the desktop.

Software and services that load automatically with Windows (for example, virus protection utilities) can conflict with 
InDesign CS4 installer and cause problems in InDesign. To prevent conflict, reinstall InDesign CS4 while Windows is 
in simplified mode doesn't resolve the issue, try installing and running InDesign CS4 on a different computer, or on a 
different hard drive.

To copy the InDesign CS4 install files to the desktop:

1 Insert the first InDesign CS4 disc into your DVD-ROM drive.

2 Click the Start button, and then click Computer.

3 Right-click on your DVD-ROM drive, and then click Explore.

4 Copy the Adobe InDesign CS4 folder from the DVD to your desktop. If you are asked to confirm replacing any 
folders with the same name, select "Yes".

http://helpx.adobe.com/x-productkb/policy-pricing/system-requirements-indesign.html
http://helpx.adobe.com/x-productkb/policy-pricing/system-requirements-indesign.html
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5 Click the Start button, and then click Computer.

To start Windows Vista in a simplified mode:

1 Choose Start, type msconfig in the Search text box, and press Enter.

2 On the Startup tab, click Disable All.

3 On the Services tab, select Hide All Microsoft Services, click Disable All, and then click OK.

4 In the System Configuration dialog box, click OK then Restart.

5 Start the InDesign CS4 installer "setup.exe" in the Adobe CS4 Install\Adobe CS4 folder, and then follow the on-
screen instructions.

To re-enable startup items and services:

1 Choose Start, type msconfig in the Search text box, and press Enter.

2 Choose Normal Startup on the General tab, click OK, and restart the computer.

4. Optimize handling of temporary files by Windows Vista.

Windows and applications store working data in temporary (.tmp) files that they create on the hard disk. Excessive or 
outdated temporary files can interfere with performance of Windows or applications.

To delete temporary files by using the Disk Cleanup utility included with Windows, pleaser refer to the following 
technical document: http://www.adobe.com/go/kb404917

5. Repair and defragment hard disks.

To repair and defragment hard disks, please refer to the following technical document: 
http://www.adobe.com/go/kb405610

6. Scan the system for viruses.

Use current anti-virus software (for example, Symantec Norton AntiVirus or McAfee VirusScan) to check the system 
for viruses. Virus infections can damage software and cause system errors. For more information, see the 
documentation for the anti-virus software.

Advanced troubleshooting

7. Install Adobe InDesign CS4 on a different computer.

Try to install Adobe InDesign CS4 on a different computer to determine if the problem is unique to your computer. If 
you are able to install Adobe InDesign CS4 on a different computer, then contact the computer manufacturer. If the 
problem occurs on multiple computers, then contact Adobe Technical Support.

8. Visit the Adobe User to User Forums.

You can see if other Adobe customers have a similar problem by visiting the User to User Forums at 
www.adobeforums.com. If you confirm that other users have experienced the same problem, Adobe Technical Support 
may be able duplicate and research the problem. Otherwise, refer to the system-related or hardware-related help.

http://www.adobe.com/go/kb404917
http://www.adobe.com/go/kb405610
http://www.adobeforums.com/
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Troubleshoot InDesign third-party plug-ins (InDesign)
This document can help you troubleshoot the following: 

• Problems and errors that may occur after you install a third-party plug-in for Adobe InDesign. 

• Errors when using certain plug-ins included with InDesign 

• Errors referring to plug-ins that are accociated with particular documents. 

• Errors indicating that certain plug-ins are missing. 

• Problems and errors when a particular plugin is referenced in a crash log file 

Please search the Adobe Knowledgebase for possible issues with specific third-party plugins before you contact Adobe 
Technical Support or the manufacturer of the third party plug-in. 

Adobe Technical Support can help you isolate problems related to plug-ins. However, if it has been determined that the 
problem is directly relates to a plug-in created by another company, you will need to contact that company for further 
support. 

Beginning troubleshooting 

If you experience problems after installing a third-party plug-in (for example, a trapping or imposition plug-in), or if a 
third-party plug-in suddenly causes errors in InDesign, then ask yourself the following questions to narrow down the 
source of the problem: 

• Has the plug-in ever worked properly? If so, what has changed on the system? 

• Are other plug-ins and the InDesign application working? 

If, after answering these questions, you are convinced the problem is specifically with the plug-in and not the result of 
broader, system-level issues, then proceed through the steps in this document. 

1. Re-create the InDesign preferences file. 

The steps below are written for InDesign CS5,version 7.x, as an example. Replace the version number with "6" for 
InDesign CS4.

Mac OS: 

1 Quit InDesign. 

2 Drag the "Version 7.0" folder from Users/[user name]/Library/Preferences/Adobe InDesign/ to the desktop.

3 Drag the "Version 7.0" folder from Users/[user name]/Library/Caches/Adobe InDesign/ to the desktop.

4 Restart InDesign.

or: Hold down Command+Option+Control+Shift immediately after launching InDesign again.

WIN OS: 

Quit InDesign 

5 Drag the "Version 7.0" folder from C:\Documents and Settings\[user name]\Application Data\Adobe\InDesign\ to 
the desktop. 

6 Drag the "Caches" folder from C:\Documents and Settings\[user name]\Local Settings\Application 
Data\Adobe\InDesign\Version 7.0 to the desktop. 

7 Restart InDesign.

Or: hold down the Ctrl+Alt+Shift Keys immediately after launching InDesign again.
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InDesign creates new preference files on launch of the application.

The folders you moved to the desktop contain InDesign's old preference files, "InDesign SavedData" file and "InDesign 
Defaults." These can be moved back, if the issue is not resolved by creating new preference files.

 

2. Ensure that your system meets minimum requirements for InDesign and the plug-in. 

In some cases, plug-ins or suites of plug-ins designed for complex tasks may require more memory than InDesign 
requires. 

Memory and other system requirements for InDesign can be found on the outside sleeve of the InDesign box as well as 
in the Introduction chapter of the InDesign user guide. System requirements for the third-party plug-in should be 
included in the plug-in documentation. 

If you used third-party plugins to create an earlier version of a document, then check with the manufacturer to make 
sure that they are installed correctly for and compatible with the version of InDesign you are using before you convert 
the document. 

3. Install the latest version of your plug-in. 

• InDesign CS4 

• InDesign CS5 

Indesign CS4

The text below explains how to display your third-party plug-ins. Alternatively, you can view a video.

 

The latest version of your plug-in may be more compatible with the operating system and drivers. Before you install an 
update or upgrade, make sure that the system meets the requirements. 

To get information on installed third-party plug-ins: 

1 Open the Configure Plug-ins dialog box from the InDesign (Mac OS) or Help (Windows) menu.

2 Select "All Plug-ins" from the Set list and select all but the "Adobe" option in the Display field.

3 Highlight the third-party plugin and click on Show Info.

 InDesign CS5

To get information on installed third-party plug-ins: 

1 Open the Extension Manager dialog box from the InDesign (Mac OS) or Help (Windows) menu.

2 Select InDesign from the Product list.

3 In the Author tab, search for the plug-in authors other than Adobe Systems Incorporated.

4 Highlight the third-party plugin. Click on the Description and Advanced tab to display information and the location 
of the plug-in.

 

Intermediate troubleshooting 

4. Disable or remove third-party plug-ins 

• InDesign CS4 

http://helpx.adobe.com/indesign/kb/#main_ID4 Info
http://helpx.adobe.com/indesign/kb/#main_ID5_info
http://helpx.adobe.com/indesign/kb/
http://kb2.adobe.com/cps/523/cpsid_52354.html
http://kb2.adobe.com/cps/523/cpsid_52354.html
http://helpx.adobe.com/indesign/kb/
http://helpx.adobe.com/indesign/kb/#main_ID4_remove
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• InDesign CS5 

InDesign CS4

 The text below explains how to disable your third-party plug-ins. Alternatively, you can view a video.

Disable or remove third-party plug-ins from the InDesign Plug-ins folder, and then restart InDesign. If the problem 
does not occur after you disable or remove third-party plug-ins, then reinstall the plug-ins to ensure they are correctly 
installed. Otherwise contact the manufacturer of the plug-ins to inquire about updates. 

To identify which third-party plug-ins are installed for InDesign, use the Configure Dialog box. 

1 Open the Configure Plug-ins dialog from the Help (Windows) or InDesign (Mac OS) menu. 

2 Select All Plug-ins from the Set list, and select all but the "Adobe" option in the Display field. 

Note: If you click Show Info, you can also see the path where they are installed. 

To disable the third-party plug-ins: 

1 Create a New Set by following the steps to verify your third-party plug-ins, and then click on the check mark to the 
left of the third-party plug-ins' names. 

2 Click Yes, when InDesign displays the warning message: Cannot modify the "all Plug-ins" set. Create a new set based 
on the "All Plug-ins" set.

3 Enter a name for the set and click OK. 

4 Restart InDesign. 

Note:You can choose the set Adobe Plug-ins, and then restart InDesign to disable third-party plug-ins. When you 
enable or disable plug-ins or choose a different plug-in set, you must restart InDesign so the change can take effect. 

To remove the third-party plug-ins: 

1 Quit InDesign. 

2 Remove any identified third-party plug-ins from Program Files\Adobe\Adobe InDesign [version number]\Plug-Ins 
(Windows), or Application/Adobe InDesign [version number]/Plug-Ins (Mac OS) folder to a backup folder. 

3 Remove the InDesign Preference files. For more information, see solution 1 in the Beginning troubleshooting 
section of this document. 

4 Restart InDesign. 

To reinstall following the instructions from the plug-ins manufacturer. 

Most third-party plug-ins are installed into a subfolder in these locations: 

• Windows: Program Files/Adobe/Adobe InDesign [version number]/Plug-Ins 

• Mac OS X: Applications/Adobe InDesign [version number]/Plug-Ins 

InDesign CS5

To disable the third-party plug-ins: 

1 Open the Extension Manager dialog box from the InDesign (Mac OS) or Help (Windows) menu.

2 Select InDesign from the Product list.

3 In the Author tab and search for the plug-in authors other than Adobe Systems Incorporated

4 Highlight the third-party plugins.

http://helpx.adobe.com/indesign/kb/#main_ID5_remove
http://helpx.adobe.com/indesign/kb/
http://helpx.adobe.com/indesign/kb/
http://kb2.adobe.com/cps/523/cpsid_52354.html
http://kb2.adobe.com/cps/523/cpsid_52354.html
http://helpx.adobe.com/indesign/kb/
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5 Click on the Check mark in the Enabled column to disable the plug-in

6 Restart InDesign. 

To remove the third-party plug-ins: 

1 Open the Extension Manager dialog box from the InDesign (Mac OS) or Help (Windows) menu.

2 Select InDesign from the Product list.

3 In the Author tab and search for the plug-in authors other than Adobe Systems Incorporated

4 Highlight the third-party plug-ins.

5 Click on the Remove button.

6 Restart InDesign.

To reinstall follow the instructions from the plug-in manufacturer. 

Most third-party plug-ins are installed into a subfolder in these locations: 

• Windows: Program Files/Adobe/Adobe InDesign [version number]/Plug-Ins

• Mac OS X: Applications/Adobe InDesign [version number]/Plug-Ins

5. Reinstall missing or damaged plug-ins.

If you receive an error stating a plug-in is no longer available or is damaged, reinstall the plug-in from the original 
source. If you have removed a plug-in on which another plug-in depends, reinstall it. 

Ensure that the plug-in is installed in the proper location and the files required for this plug-in have the correct file size 
and date (contact the plug-in vendor for the appropriate size and date of the plug-in files and their install locations). If 
your plug-in lists an incorrect file size or date, it could be damaged. 

6. Restart in Safe Boot (Mac OS) or with Start up items disabled (Windows).

Mac OS

To restart your system in Safe Boot, please refer to the following technical document: 
http://www.adobe.com/go/kb404936 

Windows XP

To restart your Windows XP with disabled startup items and services, please refer to the following technical document: 
http://go.adobe.com/kb/ts_kb404984_en-us 

Windows Vista

To restart your Windows Vista with disabled startup items and services, please refer to the following technical 
document: http://kb2.adobe.com/cps/404/kb404913.html

7. Check your hard disk for damage and scan for viruses.

A damaged disk sector or virus can prevent a plug-in from launching or from working properly. Make sure you scan 
your disk for errors using a disk utility (for example, Apple Disk Utility, Disk First Aid, or Scandisk) and also scan it 
using a virus-detection utility that uses the latest virus definitions. For more information on these procedures, refer to 
the troubleshooting documents listed at the end of this document. 

What to do if the solutions don't work 

If InDesign functions without the plug-in, and none of preceding steps help, contact the plug-in's developer for further 
assistance. Most plug-in vendors provide either a technical support phone number or e-mail address for support 
questions. 

http://www.adobe.com/go/kb404936
http://go.adobe.com/kb/ts_kb404984_en-us
http://kb2.adobe.com/cps/404/kb404913.html
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If you would like to try further system-level troubleshooting, then please refer to one or more of the following 
documents: 

• Troubleshoot system errors and freezes | Adobe software on Mac OS (cpsid_82414)

• Troubleshoot system errors and freezes | Adobe software on Windows (cpsid_82252)

http://kb2.adobe.com/cps/824/cpsid_82414.html
http://kb2.adobe.com/cps/822/cpsid_82252.html
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Tool and Page panel icons not visible, other panels blank 
or cause crashes | InDesign CS4 | Windows
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Issue
When you start Adobe InDesign CS4, the Tools panel icons are not visible, or various other panels either draw blank 
or partially blank. When you access the Pages panel, and possibly other panels, InDesign CS4 crashes.

Solution

Install the InDesign CS4 6.0.1 update.
Download updates from the Adobe website at http://www.adobe.com/downloads/updates.

• For Mac OS:http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Macintosh

• For Windows:http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Windows

Additional information
This issue occurs when your computer uses a processor that does not support SSE2, for example an AMD Athlon X 
processor.

Thin white, dark lines (stitching) | Export to PDF | 
InDesign CS2 and later

Issue
When you export to Adobe PDF from InDesign, white or dark lines are visible in the PDF file. One or more of the 
following is true:

• White or dark lines appear in areas where process colors and spot colors interact during flattening.

• You have an image file behind objects or text that have transparency applied, including drop shadows.

• You exported with Acrobat 4 (PDF 1.3) compatibility.

Solution
Do one of the following solutions:

Solution 1: Export as PDF 1.4 or later.
In the Export Adobe PDF General settings, select Acrobat 5 (PDF 1.4) or higher from the Compatibility options.

Solution 2: Turn off the Smooth Line Art option in Acrobat.
1 Choose Edit > Preferences (Windows), or Acrobat > Preferences (Mac OS) to open the preference dialog box.

2 In Categories > Page Display deselect the option Smooth Line Art, and then click OK.

Solution 3: Convert spot color to process color.
1 Choose Window > Swatches to open the Swatches palette.

http://www.adobe.com/downloads/updates
http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Macintosh
http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Windows
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2 Double-click the spot color to open the Swatch Options dialog box.

3 Choose Process from the Color Type pop-up menu.

Solution 4: Move the spot color to the top of the layer.
Change the stacking order of the objects, so that the object with the spot color is at the top, before flattening the image.

1 Select the object.

2 Choose Object > Arrange > Bring to Front.

Solution 5: Use layers to arrange the colors.
Place the spot colored object on a different layer, then arrange that layer above the layer that contains the transparent 
objects.

Solution 6: Set the opacity for the spot color to less than 100% and export to PDF again.
If your print shows dark lines on the printout of a created PDF file, then lower the opacity and create the PDF file again.

1 Select the object that contains the spot color.

2 Choose Window > Transparency to open the Transparency palette.

3 In the Opacity field, enter a value like 99.9%.

4 Export or print to PDF again.

Additional Information
White or dark lines can be caused by anti-aliasing of an application where the two regions intersect. Turning off the 
anti-aliasing in Acrobat's display preferences (Smooth Line Art/Smooth Images) eliminates these lines.

Acrobat 4 PDF compatibility (PDF 1.3) does not support transparency. Therefore, InDesign flattens the file during the 
conversion process. Consider changing the settings in the Transparency Flattener presets.

Converting the spot color to a process color allows InDesign to flatten the image without stitching. By moving the spot 
colored object to the top of the stacking order or moving it to a different layer, you can also prevent stitching.

White lines are likely to be only a display issue in Acrobat. They do not appear when you print a file.

Dark lines are likely only to occur when you print a file. Setting the opacity can create white lines when you view a file 
in Acrobat, but these white lines don't print.

Text in placed PDF is incorrect when exported to PDF 
and viewed in Acrobat 8 or earlier, or rendered in PDF-
based RIP (InDesign CS4)

Issue
PDFs, with particular font dictionaries, when placed into Adobe InDesign CS4 and exported to PDF, will result in some 
or all of their text not being drawn correctly when viewed in Acrobat 8.x or earlier versions, or rendered in an imaging 
system which uses the Adobe PDF Library version 8.x or earlier.
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Reason
The fonts in the original PDF are embedded as symbolic fonts. Acrobat and PDF Library 8.x and earlier are not capable 
of correctly rendering symbolic fonts if the font encoding doesn't contain the glyph names for every glyph in the font.

Solution 1: Install the InDesign CS4 6.0.4 update

Download the update from the Adobe website at 
http://www.adobe.com/downloads/updates.
or

Update through the Adobe Update Manager
In Adobe InDesign CS4 do the following: 

1 Help > Updates

2 Select Show Details in the first Adobe Updater window

3 Select Adobe InDesign CS4 6.0.4 update from the list of available updates 

4 Click Download and Install Updates

 

Solution 2: Export with the PDF/X-4 standard enabled.
This standard has a requirement for font encoding which prevents this issue from appearing in the resulting PDF when 
selected.

Note: This does not mean that you need to use the PDF/X-4 PDF Preset. You can use any settings, as long as the PDF/X-
4 standard is also selected. 

1 Choose File > Export and select Adobe PDF as the format.

2 Choose a destination, and click Save.

3 In the Export Adobe PDF dialog box, choose PDF/X-4:2008 from the Standard options.

4 Set any other options that are needed, then click Export.

 

If needed, you can convert the PDF to another standard using Acrobat Professional.

1 In Acrobat and choosing File > Save As, then choose PDF/X as the format.

2 Click on the Settings button to choose which PDF/X-based standard is needed for your use.

3 Choose a color profile to match your viewing/printing condition.

4 Choose to apply corrections as needed, then click OK.

5 Choose a destination, then click Save. 
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Suppress the user interface
This article is for InDesign plug-in developers trying to suppress different user interface components opened by default 
by InDesign application. Using the APIs exposed through InDesign SDK, you can develop your own plug-ins. 
Companies around the world develop plug-ins to provide customized user interfaces to their respective customers as 
per their needs.

Whenever you open an InDesign document that contains fonts or links that are not available, InDesign shows a dialog 
box about the missing fonts or links. Similarly, whenever you reopen InDesign after a crash, InDesign displays a 
recovery dialog box. These behaviors are the default. Here are some other default elements of InDesign and ways that 
developers can suppress them.

1 Document recovery dialog box.

2 Missing font dialog box.

3 Missing links dialog box.

4 Print dialog box.

5 Modal Welcome screen that appears at first launch.

1 Document recovery dialog box: Whenever InDesign crashes, it keeps information about state (valid state) of 
document in its cache. So, when InDesign starts up, it displays a Recovery dialog box. Once user clicks Yes, InDesign 
restores the document. If you remove the contents of InDesign Recovery folder at C:\Documents and Settings\{user 
name}\Local Settings\Application Data\Adobe\InDesign\Version 5.0\Caches\InDesign Recovery\, the dialog box 
doesn't appear. You can also find this address within "Document Recovery Data" frame of the dialog box that opens 
when you choose Edit > Preferences > File Handling.

2 Missing font dialog box: Whenever you open an InDesign document that contains unavailable fonts, InDesign 
displays a Missing Fonts dialog box. You can suppress this dialog box by specifying the "kSuppressUI" flag when 
opening the document. IOpenFileCmdData::Set () and IDocumentCommands::Open() take UIFlags as parameter 
where you can pass kSuppressUI. This enum comes from public/includes/BaseTypes.h. By using kSupporessUI, all 
user interface components are suppressed.

3 Missing links dialog box: Whenever you open an InDesign document containing missing links, you receive a 
missing links dialog box. You can suppress this dialog box by specifying kSuppressUI flag (as above) when opening 
the document.

4 Print dialog box: You can suppress the print user interface that appears when you choose File > Print in InDesign. 
The IPrintCmdData has a PrintUIOptions enum that lets you suppress user interface during print. This option 
works for both print and EPS export. See the following sample code snippet: 
/source/sdksamples/codesnippets/SnpPrintDocument.cpp.

5 Modal Welcome screen that appears at first launch: Whenever you open InDesign, you get a Welcome screen. You 
can suppress this screen by placing an empty file called NoModalStartupUI at the root of your system drive. (It could 
be the drive that contains InDesign.)
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Supported file formats for InDesign CS5
What's Covered

• File > Open formats 

• File > Save As formats 

• File > Export formats 

• File > Place formats (Import in graphics, media, and text files)

• Save for InCopy 

• Other 

These tables list the file formats that Adobe InDesign CS4 supports for various functions.

For more information on settings and option when opening, importing, exporting, and saving files, see Adobe 
InDesign CS4 Online Help.

File > Open

File > New

File > Save As

Extension Filename Version Comments

indd InDesign document CS5 and earlier  

indl InDesign library CS5 and earlier  

indt InDesign template CS5 and earlier  

indb InDesign book CS5 and earlier  

inx InDesign interchange CS4 and earlier  

idml InDesign Markup Language CS5 and earlier  

pmd Adobe PageMaker 6.0 - 7.0  

xqx QuarkXPress Passport 4.1.x save newer versions in Quark to 
these accepted versions

xqx QuarkXPress 3.3 - 4.1.x save newer versions in Quark to 
these accepted versions

Extension Filename Version Comments

indd InDesign document CS5  

indl InDesign Library CS5  

indb InDesign Book CS5  

Extension File name Version Comments

indd InDesign document CS5  

indt InDesign template CS5  

http://helpx.adobe.com/indesign/kb/#main_Open
http://helpx.adobe.com/indesign/kb/#main_SaveAs
http://helpx.adobe.com/indesign/kb/#main_Export
http://helpx.adobe.com/indesign/kb/#main_Place
http://helpx.adobe.com/indesign/kb/#main_SaveforInCopy
http://helpx.adobe.com/indesign/kb/#main_other
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File > Export formats

Note: For backwards compatibility to InDesign CS4 export to InDesign Markup Language (idml). For backwards 
compatibility to InDesign CS3, open the .IDML in CS4 and export as InDesign CS3 Interchange (inx).

File > Place formats (Import in graphics and text files)

Extension Filename Version Comments

pdf Portable Document Format PDF 1.3 - 1.7  

eps Encapsulated PostScript PS level 2 - 3  

fla Flash CS5 Professional CS5  

swf Shockwave Flash 10.x For Flash Player

idml InDesign Markup Language CS5  

jpg JPEG  

xml Extensible Markup Language  

txt Adobe InDesign Tagged Text  

icml Adobe InCopy document CS5  

rtf Rick Text Format  

txt Text only  

Extension Filename Version Comments

tiff Tagged Image File Format  

gif Graphic Interchange Format  

jpg, jpeg Joint Photographic Experts Group  

bmp Bitmap  

eps Encapsulated PostScript  

dcs Desktop Color Separation  

pict Picture file format (Mac)  

wmf MS Windows Metafile  

emf MS Windows Enhanced Metafile  

pcx PC Paintbrush File format  

png Portable Network Graphic  

sct Scitec CT  

ai Adobe Illustrator  

psd Adobe Photoshop  

pdf Portable Document Format  since ID CS3 support of multipage 
PDF files

indd InDesign document  

txt Text documents  
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Save for InCopy

Edit> InCopy> Export, or options from Link or Assignment panels.

Other

 

Supported File Formats for InDesign CS4
What's Covered

• File > Open formats 

• File > Save As formats 

• File > Export formats 

• File > Place formats ( Import in graphics and text files) 

• Save for InCopy 

• Other 

doc, docx Microsoft Word document  

xls, xlsx Microsoft Excel documents  

rtf Rich Text Format  

swf Shockwave File  

flv, f4v Flash Video  

mp4 MPEG-4 Video  H.264 encoding

avi Audio Video Interface  

mov QuickTime Video  H.264 encoding

mp3 MPEG Audio Layer  

Extension Filename Version Comments

icma Assignment file CS5 is .inca in ID CS3

icml Content file, Exported file CS5 is .incx in ID CS3

icap Package for InCopy CS5 is .incp in ID CS3

idap Package for InDesign CS5 is .indp in ID CS3

Extension Filename Version Comments

xml Extensible Markup Language  File > Import XML

N/A Buzzword Document  File > Place from Buzzword

epub Open Publication Structure eBook  File > Export for > EPUB

html Hypertext Markup Language  File > Export for > Dreamweaver

N/A Buzzword document  File > Export for > Buzzword

http://helpx.adobe.com/indesign/kb/#main_Open
http://helpx.adobe.com/indesign/kb/#main_SaveAs
http://helpx.adobe.com/indesign/kb/#main_Export
http://helpx.adobe.com/indesign/kb/#main_Place
http://helpx.adobe.com/indesign/kb/#main_SaveforInCopy
http://helpx.adobe.com/indesign/kb/#main_other
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The tables list the file formats that Adobe InDesign CS4 supports for various functions. 

For more information on settings and option when opening, importing and exporting, and saving files, see Adobe 
InDesign CS4 Online Help. 

File > Open

File > Save As

File > Export formats

 Extention File Name Version Comments 

indd InDesign document all versions 

indl InDesign Library all versions 

indt InDesign Template all versions 

pmd Adobe PageMaker 6.0 - 7.0 

xqx QuarkXPress Passport 4.1.x newer versions need to be save in 
Quark to these accepted versions 

xqx QuarkXPress 3.3 - 4.1.x newer versions need to be save in 
Quark to these accepted versions 

 Extention File Name Version Comments 

indd InDesign document all versions 

indl InDesign Library all versions libraries are save from the Library 
panel 

indt InDesign Template all versions 

 Extention File Name Version Comments 

xlf Adobe Flash CS4 Pro only for Flash CS4 Pro 

txt Adobe InDesign Tagged Text 

pdf Portable Document Format 

eps Encapsulated PostScript 

incx InCopy CS3 Interchange for IC CS3 can also be read by IC CS4 

icml InCopy document CS4 only 

inx InDesign CS3 Interchange for ID CS3 can also be read by ID CS4 

See note below. 

idml InDesign Markup Language CS4 only 

jpg JPEG 

rtf Rich Text Format 

swf Flash all versions 

txt Text only 

xml XML 
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Note: For backwards compatibility export to INX. INX is only supported to be opened by InDesign CS3, however, it 
might open and function correctly in previous versions to ID CS3. 

File > Place formats ( Import in graphics and text files)

Save for InCopy

 Edit> InCopy> Export, or options from Link or Assignment panels. 

Note: Any InCopy CS4 file format will not be openable in versions prior to InCopy CS3, or InDesign CS3. However, 
files from InCopy CS2, for example, can be opened in InDesign and InCopy CS4.

 Extention File Name Version Comments 

tiff Tagged Image File Format 

gif Graphic Interchange Format 

jpg, jpeg Joint Photographic Experts Group 

bmp Bitmap 

eps Encapsulated PostScript 

dcs Desktop Color Separation 

pict Picture file format ( Mac) 

wmf MS Windows Metafile 

emf MS Windows Enhanced Metafile 

pcx PC Paintbrush File format 

png Portable Network Graphic 

sct Scitec CT 

swf Flash 

ai Adobe Illustrator 

psd Adobe Photoshop 

pdf Portable Document Format since ID CS3 support of multipage 
PDFs 

indd InDesign document 

txt Text documents 

doc, docx Microsoft Word document 

xls, xlsx Microsoft Excel documents 

rtf Rich Text Format 

Extention File Name Version Comments 

icma Assignment file CS4 used to be .inca in ID CS3 

icml Content file, Exported file CS4 used to be .incx in ID CS3 

icap Package for InCopy CS4 used to be .incp in ID CS3 

idap Package for InDesign IC CS4 used to be .indp in ID CS3 
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Other

Some TrueType font math symbols and fraction glyphs 
drop out when exporting to PDF from InDesign CS4 (Mac 
OS)

Issue
 When you export to PDF from InDesign CS4 on Mac OS, some mathematical characters such as the multiplication 
symbol, divisor symbol, or fraction symbols, fail to draw correctly in the resulting PDF. This only happens when the 
symbols are sourced from particular True Type fonts. 

Reason
 The reason behind this is still under investigation by Adobe engineering. 

Solution

Use a different font.
 Fonts that use Type 1, or PostScript rendering, do not show this problem; these fontsinclude the Adobe OpenType font 
library. 

Why Are Some OpenType Fonts from Adobe Listed at the 
Bottom of Font Menus in InDesign cs-cs4?
Issue:

Some OpenType fonts from Adobe are listed at the bottom of the font menus in InDesign .

Additional Info:

 Extention File Name Version Comments 

xml Extensible Markup Language File > Import XML 

epub Open Publication Structure eBook File > Export for Digital Edition 

html Hypertext Markup Language File > Export for Dreamweaver 
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InDesign lists the fonts in the menu based on their "main" writing script. The main writing script specifies the base 
language of the font such as Roman (English), Cyrillic and CJK (Chinese, Japanese and Korean). The main writing 
script is determined by a formula which may look at the specific letters in the font. Because OpenType fonts from Adobe 
can contain many many letters and can support multiple languages, the formula used to determine the main writing 
script for a specific font, may determine a font to be mainly a Cyrillic or Asian font rather than Roman as expected. If 
a font is determined to be, for example, Cyrillic, the font will be listed in a section of the menu designated for Cyrillic 
fonts. This section will begin after the Roman section.

Roman, Cyrillic and other language fonts have been separated in InDesign in order to support the user's need to quickly 
find fonts for different languages. Sorting Cyrillic and Japanese fonts in a section separate from Roman fonts enables 
the user to more quickly and efficiently find and switch from one font that supports a particular language to another 
that supports a different language.

Some faces of Type 1 fonts, such as Helvetica Neue, 
aren't available in InDesign on Mac 10.6

Issue
Some Type 1 (PostScript) fonts don't appear in the InDesign fonts lists on Mac OS 10.6 and later. For example, when 
you look at the font Helvetica Neue in the Font submenu of the Type menu, you see Medium Italic, but no Medium. 
The missing faces do appear under the TrueType version of the font.

Faces listed under Type 1 Helvetica Neue

Faces listed under TrueType Helvetica Neue

 

Solution 1: Update to InDesign CS5 7.0.2
Install the InDesign CS5 7.0.2 update. This can be found by choosing Help > Updates from any CS5 application, or by 
downloading from http://www.adobe.com/downloads/updates/.

Solution 2: Use the InDesign Font Folder
Put the affected Type 1 font files into the Adobe InDesign application font folder, for example:

• CS3: /Applications/Adobe InDesign CS3/Fonts

• CS4: /Applications/Adobe InDesign CS4/Fonts

• CS5: /Applications/Adobe InDesign CS5/Fonts

http://www.adobe.com/downloads/updates/
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Additional information
InDesign has an order of preference for dealing with font conflicts. For fonts with the same PostScript name (as with 
Helvetica Neue), the /System/Library/Fonts folder is preferred over the /Library/Fonts folder. Additionally, a preference 
is made in favor of other fonts when conflicts include a .dfont type font. In earlier versions of Mac OS, 
/System/Library/Fonts was always populated with .dfont type fonts. Now with other types of fonts included, the 
preference is to suppress the Type 1 face when it conflicts with the System TrueType version.

Small caps ignored | Adobe OpenType fonts older than 
version 2.0 | InDesign CS5

Issue
No small caps effect appears when you apply the small caps attribute to text assigned with an Adobe OpenType font 
older than version 2.0. Additionally, opening an InDesign CS4 or earlier document in InDesign CS5 causes the 
previously applied small caps effects to disappear.

Solution
Contact Adobe Technical Support or your font vendor to receive upgrades of the affected fonts to the most recent 
version available. When contacting Adobe Technical Support, reference this Knowledgebase article number.

 

Silent PDF export failure or "Internal Error" | Place, print, 
export PSD | InDesign

Issue
When you place a PSD file or print or export a file that contains a link to a PSD, InDesign returns the error, "Internal 
Error." Or, if you export a document with a PSD file from InDesign CS5 to PDF, the export fails without an error. The 
PSD file has a spot channel defined with a color book that is not installed in your instance of InDesign

Solution
Work with the file creator to determine which color books were used in the definition of spot channels, and install those 
color books on your system. Alternatively, the file creator can edit the image as described below, using a color book that 
you both have in common.file

1 Open the PSD in an instance of Photoshop that contains the necessary color books.

2 Open the Channels panel and double click the Spot channel.

3 Click the Color swatch in the Spot Channel Options dialog box.

http://www.adobe.com/support/contact/
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4 Write down the LAB values then choose a common color book from the Books pop-up menu.

5 Click the Picker button and adjust the LAB values if necessary.

6 Click OK twice to exit from the Spot Channel Options dialog box.

7 Save As and save a version of the file, or replace the existing file. 

Additional information
One of the most common causes of this issue is the use of the new PANTONE PLUS Digital Libraries for Adobe CS. 
Make sure that when you define spot channels with these libraries that other users who work with the files also 
install them. For more information, see New PANTONE PLUS Digital Libraries available | Creative Suite 
(cpsid_85803).

More Help topics 

New PANTONE&reg; PLUS Digital Libraries available | Creative Suite

Pantone color books dont' toggle between CMYK, RGB | Illustrator CS5 | Dutch

Error "The file is not readable" placing PSD or opening file with linked PSD | Illustrator

Error, "Could not complete your request because the specified color book cannot be found." | Photoshop

 

Last updated 11/12/2015

http://go.adobe.com/kb/ts_cpsid_85803_en-us
http://go.adobe.com/kb/ts_cpsid_85803_en-us
http://go.adobe.com/kb/ts_cpsid_88972_en-us
http://go.adobe.com/kb/ts_cpsid_89260_en-us
http://go.adobe.com/kb/ts_cpsid_89262_en-us
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The ''Remove blank lines when empty'' Data Merge 
option does not work consistently (InDesign CS4)

Issue
When you merge documents the 'Remove blank lines when empty' option is sometimes ignored.

Delete empty lines manually in the merged InDesign document.
1 Choose Edit > Find/Change > Text.

2 In the Find What field enter : ^p^p ; or two times: End Of Paragraph

3 In the Change To field enter : ^p ; or once: End of Paragraph

4 Click Done.

Printing tints of black with Color Management enabled 
to "Composite Gray" PostScript produce different tint 
values
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Issue
 Tints of the "[Black]" swatch, or CMYK color definitions in which only black contributes (for example, C=0, M=0, Y=0, 
K=60) will print with slightly different tint values in Composite Gray PostScript output from InDesign if Color 
Management is enabled in the Color Settings. 

Example
 Print an InDesign document that contains a rectangle filled with an 80% tint of the swatch "[Black]" to the Adobe PDF 
printer with "Composite Gray" as the Color option in the Output panel of the Print dialog box. 

Place the resulting PDF file back into InDesign and view with the Separations Preview enabled (Window > Output > 
Separations Preview). Hover over the rectangle in the placed PDF and you'll see that it contains approximately a 73% 
tint of black, depending on your Color Management setup.

Reason
You have Color Management enabled. InDesign is converting your source color numbers to the active document profile 
space prior to the conversion to grayscale.

Solution
 Do one of the following: 

Solution 1: Disable color management.
1 Choose Edit > Color Settings

2 Change the Settings selection to "Emulate Adobe InDesign 2.0 CMS Off "

3 Click OK

4 Print the document with "Composite Gray" Color option in the Output pane

Solution 2: Print with "Composite Leave Unchanged".
Note: This will produce DeviceCMYK colorspace for your black objects, which could produce different numbers based 
on down-stream processes in your workflow. Also, this doesn't convert any non-black colors to grayscale so you'll need 
to set your printer or other RIP to convert the colors to grayscale. 

1 In the Print dialog box, set the Color setting to "Composite Leave Unchanged"

2 Ensure the Print dialog box's Color Management setting is set to "No Color Management"

Solution 3: Convert to Grayscale in Acrobat.
1 Print with "Composite Leave Unchanged"

2 Distill with "Leave Unchanged" in the Acrobat Distiller color settings

3 Use the Advanced > Print Production > Convert Colors command to bring up the Convert Colors command

4 Set all colors to be converted to the destination space

5 Set the destination space to a grayscale profile.Note: Most grayscale profiles will cause a shift in the values of CMYK 
blacks. To avoid this, you'll need to use a custom profile that meets your needs.
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PMString Constructor fails in CS6 with right quote 
present
Issue

The right quote (\u2019) appears causes an issue in its 8-bit representation in WideString (0x92).

For example, the following code works in CS4, but fails in CS6 in Adobe Owl.

WideString w(L"Paul\2019s issue");&nbsp;

PMString sorig = w;&nbsp; PMString x = sorig.GetPlatformString().c_str();//Failure - GetPlatformString() turns 2019 
into 0x92 in the generated std::string - PMString constructor appears to choke on the 0x92

Solution
This behavior while using WideString in PMString constructors is not a bug and is due to the changes made in the 
respective constructors across the versions. These errors are due to the changes in the assignment operator 
implementation of PMString in CS6 to make handling of UTF16 characters better. To use them correctly, PMString can 
be used in the following way:

WideString w(L"Paul\2019s issue"); PMString sorig = PMString(w); PMString x = 
PMString(sorig.GetPlatformString().c_str());

Therefore, using PMString's Copy constructor, give correct results. 

SetXString() can also be used to handle them correctly.

 

After you place a digital photograph into InDesign, the 
Actual ppi value is higher than the expected image 
resolution

Issue
 When you place a digital image into Adobe InDesign, the info palette displays a much higher actual ppi value (for 
example, 288) than the expected 72ppi resolution. 

Reason
• Your image was captured at high resolution and with low compression. For example, Large format or high pixel 

values and fine quality. 

• Your image was not edited and/or saved from Adobe Photoshop. 

• Your image was saved at a resolution of 72ppi. 
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Solution
 Do one or more of the following solutions: 

Solution 1: Use photo editing software to save the image at the desired size and resolution 
before placing the image into InDesign
1 Prior to placing your image into InDesign determine the appropriate physical dimensions (for example, 5x7").

2 Open your image in an image editing application such as Adobe Photoshop and resample the image to the correct 
ppi resolution at the correct physical dimensions (for example, 5x7" and 72ppi).

3 Place the image into InDesign.

Solution 2: Open and resave the image from Adobe Photoshop
1 Open your image in Photoshop.

2 Choose File > SaveAs and save your file to a new name or the same name.Note: If the image is not resampled before 
being saved it will be quite large when placed into InDesign.

Additional Information
 Some digital cameras omit data that applications use to generate a preview for the image. In some cases, ommission of 
the preview data results in a preview that is saved at a ppi resolution of 72ppi. High resolution images typically contain 
millions of pixels. When those pixels are mapped to a low pixels-per-inch ratio, such as 72ppi, the physical dimensions 
of the image preview are quite large. 

For example, if your image was captured at a pixel depth of 2560 wide by 1920 high and then those pixels are mapped 
to a ppi resolution of 72ppi, the physical dimensions of the image become 35.5556" wide by 26.6667" high. 

When a high resolution image mapped to a low ppi resolution is placed into InDesign it will usually need to be resized. 
Resizing an image in InDesign does not resample the image. This means that no pixels are lost when the image is 
decreased in size after placement into InDesign. Since the image contains the same total number of pixels (eg: 2560 X 
1920) when you reduce the size of the image each inch of image will contain more pixels. 

For example, if you reduce your 35.5556x26.6667" image in InDesign by 50% so that it is 17.7778x13.333", the number 
of pixels per inch doubles to 144ppi. If you reduce your orignal image to 25% of its original size the image dimensions 
will be 8.8889 X 6.6667 and the ppi resolution will be 288ppi. 

Objects in placed InDesign files disappear when printed 
or exported to PDF (InDesign CS4)

Issue
 Objects in placed InDesign files disappear when printed or exported to PDF from InDesign CS4. These itemsare left 
hand master page items inlinked InDesign file(s). 

Here is a typical example of a workflow that replicates this issue: 
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1. Create a 4 page document. 2. On both A-Master pages, create an object (filled with color). 3. On all document pages, 
create a rectangle and fill with color. 4. Save doc as 'doc1.indd'. 5. Create a new 4 page document. 6. Place all pages of 
doc1.indd into the new document. 7. Print or export to PDF. 

The resulting output will display but all left master page items are missing. 

Reason
 This is due to an error in calculating the coordinates for the page items. The items may actually be included in the 
resulting print or PDF data streams, but are positioned outside of the page boundaries. 

Solution

Solution 1: Install the InDesign CS4 6.0.1 update.
 Download updates from the Adobe website at http://www.adobe.com/downloads/updates. 

• For Mac OS:http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Macintosh

•  For Windows:http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Windows

Solution 2: Use the 'Override all master page items' command.
1 Open the original linked InDesign document.

2 In the Pages panel, select all pages that contain page items sourced from left handed master pages.

3 From the Pages panel fly-out menu, choose Override All Master Page Items.

4 Save the InDesign document.

5 Open the "host" InDesign document and update the link(s) to the .indd file(s) modified with the steps above.

Solution 3: Disable the Facing Pages option
1 Open the original linked InDesign document.

2 Choose File > Document Setup and disable the Facing Pages option.

3 Save the InDesign document.

4 Open the "host" InDesign document and update the link(s) to the .indd file(s) modified with the steps above.

Missing plug-ins
This article is for plug-in developers who store persistent data within an InDesign document. It discusses strategies for 
handling situations when you open a document containing that data, but the plug-in isn't present. Plug-ins you create 
can add data to the document. When your plug-in is present and loaded, it can open and interpret the data. However, 
if you remove the plug-in, or give the document to someone who doesn't have it, the plug-in isn't available to interpret 
the data.

http://www.adobe.com/downloads/updates
http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Macintosh
http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Windows
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You can control what warning is shown when the document is opened without the plug-in. The application can warn 
when a document that contains data created by a plug-in that isn't available. There are three warning levels: critical, 
default, and ignore. By setting the warning level, the plug-in can specify the relative importance of its data. Data created 
by the plug-in has the “default” warning level. However, you can override the setting and identify the data as more 
important (critical) or less important (ignored). You can modify this important setting by adding resources to the plug-
in’s boss definition file:

• CriticalTags — A “critical” warning tells the user that the document contains data from missing plug-ins and advises 
the user not to open the document. If the user opens the document, the application opens an untitled copy, to 
preserve the original document. Use this level when the data is visible in the document or contributes objects owned 
by another object in the database. (For example, use it when the document has text attributes, owned by the text 
model.)

• DefaultTags — A “default” warning tells the user that the document contains data from missing plug-ins. It asks 
whether to continue the open operation. If the user continues the open operation, the application opens the original 
document. Use this level when the data is self-contained and invisible to the user, but the user could encounter 
missing function that would have been provided by the plug-in.

• IgnoreTags — An “ignore” warning provides no warning message at all. The application proceeds with the open 
operation as if there were no missing plug-ins. Use this level when the data is invisible to the user and self-contained. 
In this case, it's unnecessary to know the plug-in was involved in the construction of this document. If the plug-in 
stored data in the document, but that data is used only by this plug-in and does not reference objects supplied by 
other plug-ins, the user sees no difference in the document when the plug-in is missing. For example, the plug-in 
could store preferences information in every document for its own use.

You can set these warnings to use ClassID (when the plug-in creates new bosses) or ImplementationID (when the plug-
in adds interfaces to existing bosses) values as triggers. Use kImplementationIDSpace to specify a list of 
ImplementationID values, and kClassIDSpace for ClassID values. You can put any number of IDs in the list, but all the 
IDs must be of the same type. Use a second resource to mark IDs of another type. The following examples set the 
warning level to ignore data stored by the PersistentList plug-in in the SDK by adding two resources to PstLst.fr:

This example marks implementation IDs as ignored:

 

resource IgnoreTags(1) { 
   kImplementationIDSpace, { 
       kPstLstDataPersistImpl, 
       kPstLstUIDListImpl, 
       } 
}; 
This example marks boss classes as ignored: 
resource IgnoreTags(2) { 
   kClassIDSpace, { 
       kPstLstDataBoss, 
       } 
}; 

It's unnecessary to mark any IDs that do not appear in the document (for example, data that was written out to saved 
data). It's also unnecessary to mark implementations that are not persistent. You do not need to mark IDs if you want 
the default behavior.
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“Missing plug-in alert” is activated when a document is opened and contains data from one or more missing plug-ins 
that cannot be ignored. The document contains a list of the plug-ins that added data to it. Each piece of data added has 
an importance attached to it. This importance can be critical, default, or ignorable. Data marked as ignorable does not 
cause the alert to activate. Data marked as critical or default causes the alert to activate. With critical data, the alert 
works more strongly. The alert is the only difference between critical and default data. The alert tells the user that data 
is missing, presents a list of missing plug-ins, and allows the user to continue or cancel the open operation. Each missing 
plug-in has the chance to add a string to the alert that specifies additional useful information (for example, a URL for 
purchasing or downloading the plug-in). The alert is modeled on the missing-font alert. The “Don’t Warn Again For 
These Plug-ins” option is deselected by default. If this option is selected, the alert is not activated the next time a 
document is opened and any subset of the listed plug-ins is missing (and no other plug-ins are missing). This option 
allows users accustomed to seeing (and ignoring) alerts concerning specific plug-ins to automatically bypass the alert, 
while still getting warned about data from any plug-ins newly found to be missing. The alert is activated again if a 
document is opened that uses other missing plug-ins. The alert is activated again if the “Don’t Warn Again For These 
Plug-ins” option is deselected.

For more help, see the programming guides in the docs\guide folder of the InDesign SDK.

Manual kerning incorrect | TrueType, Type 1 fonts | 
InDesign, InCopy | CS5

Issue
When you apply manual kerning to fonts that have built-in kerning values, InDesign or InCopy CS5 incorrectly 
positions the glyphs. Documents from CS4 show a shift of these glyphs when opened in CS5 and recomposed.

Solution
Install the InDesign/InCopy CS5 7.0.3 update by choosing Help > Updates, or by visiting the Adobe product updates 
page: http://www.adobe.com/downloads/updates

Additional information
In the failure mode, InDesign and InCopy concatenate the manual kerning values onto the automatic kerning values 
obtained from inside the font.

Linked graphics stored on AFP volumes drop out or lose 
their clipping paths when printed or exported (InDesign 
on Mac OS 10.5.x)

http://www.adobe.com/downloads/updates
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Issue
When you print documents from Adobe InDesign on Mac OS X v.10.5.x, some graphics do not appear in the resulting 
output.

Details:
• You are printing documents that contain links to graphic files on network volumes mounted via AFP (Apple File 

Protocol).

• The graphics that do not appear are primarily EPS or PDF formats.

• The EPS images might appear in the output, but clipping paths are not applied as expected.

Reason
Adobe is working with Apple to investigate the cause of this issue.

Solution
Do one of the following solutions:

Solution 1: Install the Apple Mac OS X 10.5.7 update
Adobe's Quality Assurance team has confirmed that this problem no longer occurs when printing or exporting from 
machines that have the OS X 10.5.7 update installed. This can be updated via the Apple Software Update tool, or from 
apple's website:http://support.apple.com/kb/DL826

Solution 2: Access the linked files via the SMB protocol.
Note: This solution requires your remote volume to support this protocol. If it does not, then contact your IT 
department and ask if it can be enabled.

1 From the Finder, choose Go > Connect to Server.

2 In the Server Address field, type "smb://" followed by the IP address or name of your server. This may require you 
to type the server name, including domain extensions, such as [server.domain.com].

3 Click Connect.

4 Reopen your InDesign document, and relink as needed. If you are using InDesign CS4, then use the Relink to Folder 
command from the Links panel fly-out menu.

Solution 3: Move the linked files to a local drive prior to output.
1 Mount your AFP volume, and copy the files to a disk local to the machine from which you are printing or exporting.

2 Reopen your InDesign document, and relink as needed. If you are using InDesign CS4, then use the Relink to Folder 
command from the Links panel fly-out menu.

Solution 4: Use a different file format.
For cases of lost clipping paths from EPS, use of TIFF or PSD appears to avoid the issue.

Solution 5: Print/Export from a non Mac OS 10.5.x system.
Either downgrade the client to Mac OS 10.4.x, or print/export from a PC running Windows. This later option will 
require relinking. If you are using InDesign CS4, then use the Relink to Folder command from the Links panel fly-out 
menu.

http://support.apple.com/kb/DL826
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Limitations of the trial versions of InDesign CS4 and 
InCopy CS4
 The only limitations of the Adobe InDesign CS4 and Adobe InCopy CS4 trial versions is that they will only run for 30 
days after they are first launched. This is true for the trial versions of InDesign CS4 and InCopy CS4 on both Mac OS 
and Windows. 

Layout format isn't maintained when using InDesign's 
Export for Dreamweaver or EPUB
The page layout of InDesign documents exported as Dreamweaver (.html) or .epub files isn't accurately represented 
when you view the files in a web browser or epub reader. For example, text on top of an image in the InDesign document 
isn't on top of the image in the resulting output. Instead, the text appears following the image. In other cases, stylistic 
text formatting is removed.

This behavior is expected for these formats. Both of these export options are designed to export the content of the 
document so that it can be repurposed in other publishing workflows. The Export for Dreamweaver option reformats 
content so that it's more appropriate for display from within a web browser. The Export to EPUB option exports content 
that is free of formatting. EPUB content is intended for display on various devices in which the screen size, orientation, 
and text size varies. The EPUB reader determines the format.

For information about controlling the reading order of content for accessibility, see Adobe InDesign CS5 read order. 
(This information is also applicable to Export for Dreamweaver and EPUB.)

 For more about the options associated with these two export formats, see the following InDesign Help topics:

• Export content to Dreamweaver

• Export content for Digital Editions (EPUB)

 For more information about the EPUB format, see the following resources:

• eBooks: Exporting EPUB files from Adobe® InDesign® white paper

• International Digital Publishing Forum

• EPUB WIkipedia Entry

 

Known issues with Microsoft Office 2007/2008 (InDesign 
CS4 and CS5)
There are some known issues when importing Microsoft Office 2007/2008 files into Adobe InDesign CS4 and InDesign 
CS5. If you encounter an issue while importing Microsoft office 2007/2008 documents, then try saving back to a 
previous version or to another file format within the Microsoft Office product, and then import the new file.

 

Known Issues InDesign CS4 

http://www.adobe.com/accessibility/products/indesign/readorder.html
http://help.adobe.com/en_US/indesign/cs/using/WS82C401A9-E844-40d5-B9B4-540CA374B0C6a.html
http://help.adobe.com/en_US/indesign/cs/using/WS032BF3B3-6DF2-4544-9017-3AD3160F6C65a.html
http://helpx.adobe.com/indesign/using/export-content-epub-cs6.html
http://www.idpf.org/
http://en.wikipedia.org/wiki/EPUB
http://helpx.adobe.com/indesign/kb/#main_CS4
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Known Issues InDesign CS5 

Known Issues InDesign CS4

1. Footnotes are not imported from .docx, .doc, or .rtf files when a graphic is present in the text. The footnote 
reference displays as a missing glyph, and the footnote text is not present.

Workaround: Deselect the Import Inline Graphics option in the Microsoft Word Import Options dialog box while 
importing the Microsoft Office document.

2. In the Excel Import Options dialog box, the user defined cell range is not populated while you import an .xlsx 
file.

Workaround: Type the range manually in the cell range box, and then import the desired cell data.

3. InDesign does not display "-1" value for an imported Microsoft Excel 2007 spreadsheet that contains the value 
"-1".

Workaround: In Microsoft Excel, save the .xlsx document in the .xls file format, and then reimport the document in 
InDesign CS4.

4. InDesign CS4 does not apply the correct font when importing a .docx file for some font types.

Workaround: In Microsoft Word, resave the document in the .doc file format, and then reimport the document.

5. When a Microsoft Office Word 2007/2008 text document (.docx) with black only fill is imported into InDesign 
CS4, it displays as rich black in the Separations dialogue box.

Workaround: Resave the document in the .doc file format, and then reimport the new file.

6. InDesign may quit unexpectedly when importing a .docx file that contains cross-references of type Footnote & 
Endnote.

Workaround: No valid workaround.

7. InDesign displays the error message "Failed to open PDF file" when a chart is copied from Microsoft Excel 
2007/2008 to InDesign CS4.

Workaround: Save the Excel document in the .xls file format, and then copy and paste the chart into inDesign CS4.

8. Text does not display as text when you copy from Microsoft Excel 2007/2008 and paste into InDesign CS4. When 
you paste the text, it appears as a bitmap graphic rather than as text.

Workaround: Save the document in the .xls file format, and then copy the desired text and paste it into InDesign CS4.

9. InDesign may quit unexpectedly while importing a .docx file with different cross-references.

Workaround: Resave the document in the .doc file format, and then reimport the new file.

10. InDesign may freeze or quit unexpectedly while importing a Microsoft Excel file that contains blank cells with 
formatting applied. InDesign attempts to import blank cells with formatting applied.

Workaround: Remove all formatting from blank cells in the Microsoft Excel document.

11. InDesign may quit unexpectedly when importing .docx files that contain nested tables.

Workaround: Save the file in the .doc file format, and reimport into InDesign CS4.

12. Some straight quotation marks are not converted to typographic quotation marks when imported.

Workaround: No valid workaround

http://helpx.adobe.com/indesign/kb/#main_CS5
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13. When cross-references of type Footnote & Endnote are present in either footnotes or endnotes in a Microsoft 
Office Word document, and the document is imported into InDesign, the cross-references aren't imported. This 
occurs with several file formats from Microsoft Office documents.

Workaround: No valid workaround

14. Hyperlinks defined in Microsoft Office documents are not preserved when that document is imported to InDesign.

Workaround: InDesign's import filters are not capable of converting these to it's native hyperlink objects. The 
hyperlinks must be recreated in InDesign via the Cross References/Hyperlinks panel.

 

Known Issues InDesign CS5
 

1. Paragraph rules imported from word 2007 files are not shown in InDesign.
This is likely to happen with use of drop cap characters.

Workaround: Save as a 2003 Word (doc) document.

 

2. Footnote text is incorrectly shown under Endnotes on import.
Workaround: Save as a 2003 Word (doc) document, or Rich Text Format (RTF)

 

3. Importing an Excel (.xls) file containing GB18030 characters fails to display the characters.
When importing an Excel document, InDesign displays GB18030 Chinese characters as squares.

Workaround: Apply a different font before importing the document. For example, use Arial Unicode MS or SimSun-
18030.

 

4. InDesign does not display "-1" value for an imported Microsoft Excel 2007 spreadsheet 
that contains the value "-1".
Workaround: In Microsoft Excel, save the .xlsx document in the .xls file format, and then reimport the document in 
InDesign CS5.

 

5. Some straight quotation marks are not converted to typographic quotation marks when 
imported.
Workaround: No valid workaround.
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6. When cross-references of type Footnote & Endnote are present in either footnotes or 
endnotes in a Microsoft Office Word document, and the document is imported into InDesign, 
the cross-references aren't imported. This occurs with several file formats from Microsoft 
Office documents.
Workaround: No valid workaround.

 

Known Issues with Flash Export from InDesign CS5

Issue
This document lists behaviors and known issues that occur when export an InDesign CS5 document to Flash Player 
(SWF) and Flash Pro (FLA)

• Known behaviors 

• Known issues 

Known Behaviors

Document setup issues
How InDesign pages are convertedWhen you export to SWF or FLA, InDesign spreads become separate clips in a 
timeline, like slides in a slideshow. Each spread is mapped to a new keyframe. In Flash Player, you advance through the 
spreads of the exported document by pressing arrow keys or clicking interactive buttons.

Page size

When you create a document, you can choose a specific resolution, such as 800 x 600, from the Page Size menu in the 
New Document dialog box. During export, you can also adjust the scale or resolution of the exported SWF or FLA file.

Note: When creating a document intended for the web, choose Web from the Intent menu in the New Document dialog 
box.

Interactivity features
Buttons, page transitions, hyperlinks, animation, and media files can be included in exported SWF and FLA files.

Buttons

For buttons in an exported SWF or FLA file, the Next Page and Previous Page actions are especially useful controls for 
playback in Flash Player. However, some actions that work in interactive PDF files have no effect in Flash Player. When 
you choose an action in the Buttons panel, do not select an option from the PDF Only section.

HyperlinksCreate links to websites or to other pages in the document. Hyperlinks are broken in FLA files.

http://helpx.adobe.com/indesign/kb/#main_behaviors
http://helpx.adobe.com/indesign/kb/#main_issues
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Movies and sound clips
• Movies and sound clips are included in an exported SWF file if they’re in a supported format, such as SWF, FLV, 

F4V, and MP4 for movies and MP3 for sound clips.

• When you export to FLA, only the poster image is included in the FLA file. Supported media files appear in a 
resources folder saved in the same location as the exported FLA file.

Conversion issues
Color

• SWF and FLA files use RGB color.

• When a document is exported to SWF or FLA, InDesign converts all color spaces (such as CMYK and LAB) to 
sRGB. InDesign converts spot colors to equivalent RGB process colors. 

• To avoid unwanted color changes in artwork with text with transparency, choose Edit > Transparency Blend 
Space > Document RGB.

• To avoid unwanted color changes in images with transparency, avoid using a lossy compression during export.

TextWhen exporting to SWF or FLA, you can determine whether text is output as Flash text or converted to outlines 
or pixels. Text exported as Flash Classic Text remains fully editable when the FLA file is opened in Adobe Flash CS5 
Professional and can be searched in web browsers when saved as SWF files.

Images

• When you export images to SWF or FLA, you can change image compression, JPEG quality, and resolution settings 
during export.

• When you export images to FLA, an image placed multiple times in your InDesign document is saved as a single 
image asset with a shared location.

• A large number of vector images in the InDesign document may cause performance problems in the exported file.To 
reduce file size, place repeating images on master pages, and avoid copying and pasting images. If the same image 
is placed multiple times in the document and not transformed or cropped, only one copy of the file is exported in 
the FLA file.

• Images that are copied and pasted are treated as separate objects.

• By default, a placed Illustrator file is treated as a single image in the FLA file, whereas an Illustrator file that’s copied 
and pasted generates many individual objects. For best results, place the Illustrator image as a PDF file instead of 
copying and pasting from Illustrator. Copying and pasting results in multiple editable paths. You can change 
preference options to make sure that Illustrator objects are pasted as one object instead of a collection of small 
vectors. In Illustrator File Handling & Clipboard preferences, select PDF and deselect AICB (No Transparency 
Support). In InDesign Clipboard Handling preferences, select both Prefer PDF When Pasting and Copy PDF To 
Clipboard.

Transparency

• Before exporting to SWF, make sure that transparent objects do not overlap any interactive element, such as a button 
or hyperlink. If an object with transparency overlaps an interactive element, the interactivity may be lost during 
export. You may want to flatten transparency before exporting to FLA.

• In some instances, choosing a lossy compression reduces the quality of images with transparency. When exporting, 
choose PNG (Lossless) to improve the quality.

3D attributes3D attributes are not supported in the exported SWF and FLA files.
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Known issues
Issue 1: Objects appear to drop out in unflattened FLA when both the contents of a group and the group have the 
same transparency effects applied. (2537818)

Workaround:

• Remove the drop shadow on the group or the individual objects.

• Change the blending space on the group to Normal.

• Export to SWF

• Apply a different transparency effect to the group 

Issue 2: Multi State Objects (MSO) continuously cycles through states in exported SWF movie (2496987)

Workaround: Add a stop in Flash Pro.

Note: This is consistent with how InDesign treats the FLA as a whole. InDesign does not include a 'stop' and thus the 
default behavior is to flip through all the pages.

Issue 3: Some document installed fonts are shifting vertically in Flash text (2497723)

• Note workaround.

• InDesign uses CoolType, not platform APIs. 

• Flash text relies on the platform API to get ascent/descent to adjust the text position. The platfrom dependent API 
call can only get legitimate values if font is installed on the system foler. If the font is installed in our app folder or 
the document installed font folder, the return value may not be legitimate. 

Issue 4: Middel Eastern (Hebrew, Arabic) drop caps are shifting horizontally in SWF files with Flash text (2486484, 
2499126)

Workaround: Use the ME version of InDesign 

Issue 5: Animations on the master page will drop in SWF if one spread contains mutliple pages. ( for example 4 
page spread) (2475343)

Now workaround. This workflow is not supported in the current architecture. 

Issue 6: Transparency effects applied to the contents of a placed graphic frame do not output to FLA/SWF 
flattened or native. (2375074)

Workaround: Apply transparency to the frame itself.

Issue 7: Error message occur when exporting bitmap type, Courier (Courier system font in MS Word,) to SWF 
(2295686)

No workaround: Indesign does not support bitmap font on Windows. Bitmap fonts are filtered in the font menu. 

Japanese specific: 
J: Text shifts up in TLF text (2523394)

Workaround:

• Set it as lineHeight in Flash Authoring or manually set it as a number that matches or apply underline to the original 
text in InDesign.

• This behavior is by design due to the fact that TLF does not have the same first baseline offset supports as InDesign. 
For J document, InDesign always uses auto for the first baseline even though the setting for InDesign is 
EmboxHeight. The workaround for user is to 
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Additional Information
For Information regards InDesign CS4 and Flash publishing functionality, please refer to Background information on 
InDesign CS4 Flash publishing functionality(SWF/XFL)

 

Known issues with cross-references in InDesign CS4
Overview

 If you are writing a manual or reference document, then you might want to include a cross-reference to refer the reader 
from one part of your document to another. Example: "For more information, see 'Field mice' on page 249." You can 
specify whether a cross-reference derives from a paragraph style, such as a heading style, or from a text anchor you 
created. You can also determine the cross-reference format, such as Page Number Only or Full Paragraph & Page 
Number. 

Known Issues

 The following are some known issues with the InDesign CS4 Cross-References functionality. 

Issue: The Hyperlinks pane or Cross-References pane of the Hyperlinks panel may not appear if the horizontal line 
dividing them is moved to the very top or bottom of the panel. When in this state, double-clicking on either a hyperlink 
or a cross-reference will not bring up the Hyperlink Options or Cross-Reference Options dialog box as expected. 
[1888869]Solution 1: Drag the horizontal separator bar from the topmost or bottommost position in the panel to 
expose both panes.Solution 2: To modify the Hyperlink or Cross-Reference Options while in this state, select the 
hyperlink or cross-reference and choose the appropriate Options... command from the panel's fly out menu. 

Issue: Cross-Reference name field is blank when the cross-reference is targeting an unnumbered paragraph and using 
only paragraph number as the cross-reference format. [1888812]Solution 1: Use a cross-reference format that includes 
something other than the paragraph number.Solution 2: Number the paragraph(s) via Type > Bulleted and Numbered 
Lists > Apply Numbers 

Issue: When opening InDesign book composed of multi InDesign documents with one document in the book with 
missing plug-ins the following alert message: "<file_name.innd> uses one or more plug-ins that are not currently 
available on your system. Book operations will be disabled until you replace or delete this document, or install the 
missing plug-ins" is displayed for all other document in the book when updating all cross references from the book 
panel menu. [1874459]Solution: Cancel the updating process, check the documents for missing plug-ins and resolve 
them, then open the InDesign book. 

Issue: Pressing Ctrl+A to select all format definition in Cross-Reference Formats dialog box is not supported. 
[1864143]Solution: Hold the shift key down while selecting the first item in the list, then the last item in the list. 

Issue: When performing Relink Cross-Reference between two InDesign documents from the Cross-Reference palette 
menu and selecting the wrong file type (example .jpeg) the following error message is displayed: "Some hyperlinks 
couldn't be updated because the documents they point to are not open. Please open the documents or hold down 
Option/Alt while choosing Update Hyperlinks." [1857472]Solution: Be sure to select correct file type for relinking. 

Issue: InCopy stories that aren't checked out to an InDesign user aren't in the paragraph list for cross references in the 
New Cross-Reference dialog box. [1853543]Solution: Change the assignment of the InCopy stories to the author of the 
cross-references for the time needed to make the cross-references. 

http://kb2.adobe.com/cps/406/kb406846.html
http://kb2.adobe.com/cps/406/kb406846.html
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Issue: After Edit > Undo of an action that deleted a cross-reference destination, the cross-reference still shows with the 
status Missing in the Hyperlinks panel. [1841410]Solution 1: Save both documents and open the document with the 
cross-reference source(s).Solution 2: Select the cross-reference in the Hyperlinks panel, choose Relink Cross-
Reference... from the panel fly out menu, select the document with the cross-reference destinations, and click OK. 

Issue: Page number listed as missing for a multiple document cross-reference when you copy/paste the text frame 
containing the cross-reference. [1799765]Solution: Open the document with the cross-reference destination. Double-
click on the cross-reference to bring up the Cross-Reference Options dialog box. Choose the document that contains 
the destination and reselect the destination paragraph. 

Issue: When no documents are open, the Define Cross-Reference Formats menu option is disable from Hyperlinks fly 
out menu. Application-wide defaults are not supported for cross-reference formats. [1761034]Solution: Define default 
cross-reference formats as part of your document template(s). These can then be loaded via the Load Cross-Reference 
Formats... command from the Hyperlinks panel's fly out menu. 

Issue: New Cross-Reference or Hyperlink dialog remembers any modified values if canceled. [1750640]Solution: Reset 
to your preferred values before canceling, or when you next create a new cross-reference or hyperlink. 

Issue: The paragraph styles list in a New Cross-Reference dialog box is showing styles that are not used in the selected 
document. [1735304]Solution: None available at this time. Check regularly for available updates. 

Issue: Deleting cross-reference destinations that are part of tagged text frames causes the cross-reference to display 
Overset Text status rather than Missing. The Got to Destination command is still available, though it does nothing. 
[1845473]Solution: Untag the text frame(s) before deleting. 

InDesign tools and panels don't respond to mouse clicks 
(Windows 7/Vista)

Issue
When you try to access a tool or panel item in Adobe InDesign by clicking on it, nothing happens.

Reason
The DPI setting for fonts is set too high or there is a conflict with Aero being enabled on your Microsoft Windows 
7/Vista system.

Solutions:
Solution 1: Change the DPI scale back to the default.

Windows Vista

1 Open Personalization by clicking the Start button Picture of the Start button, clicking Control Panel, clicking 
Appearance and Personalization, and then clicking Personalization.

2 In the left pane, click Adjust font size (DPI). Administrator permission required If you are prompted for an 
administrator password or confirmation, type the password or provide confirmation.

3 In the DPI Scaling dialog box decrease the size of text and other items on the screen, click Default scale (96 DPI)–
fit more information, and then click OK.
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4 To see the changes, close all of your programs, and then restart Windows.

Windows 7

1 Click on the Start button, click on Control Panel, click on Appearance and Personalization, and then, under Display, 
click on Make text and other items larger or smaller.

2 Choose Smaller - 100% (default).

3 Click Apply.

4 To see the change, close all of your programs and then log off of Windows. This change will take effect the next time 
you log on.

Solution 2: Disable Windows Aero

Windows 7

1 Choose Start > Control Panel.

2 Double-click Personalization.

3 Scroll down to the Basic and High Contrast Themes.

4 Select one of the Basic or High Contrast themes, then wait for that theme to take effect.

5 Re-create the problem behavior, and then do one of the following:

• If the problem doesn't recur, then Aero is the cause. Choose a Color Scheme other than Windows Aero to set up 
your Appearance of your desktop.

• If the problem recurs, then Aero isn't the cause. Re-enable Aero.

To re-enable Aero:

1 Choose Start > Control Panel.

2 Double click Personalization

3 Choose one of the Windows Aero themes and close the Personalization control panel.

Windows Vista

1 Choose Start > Control Panel.

2 Double-click Personalization .

3 Select Window Color and Appearance.

4 Click Open Classic Appearance Properties For More Color Options.

5 Select a color scheme other than Windows Aero and click OK.

6 Re-create the problem behavior, and then do one of the following: 

• If the problem doesn't recur, then Aero is the cause. Choose a Color Scheme other than Windows Aero to set up 
your Appearance of your desktop.

• If the problem recurs, then Aero isn't the cause. Re-enable Aero.

To re-enable Aero:

1 Choose Start > Control Panel.

2 Double click Personalization 

3 Select Windows Color And Appearance. 

4 Choose Windows Aero from the Color Scheme menu and click OK.
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Additional information 
A larger DPI is often used to help make the text on the screen easier to read. Yet altering this setting beyond the defaults 
can cause issues with program functionality.

Aero is a new hardware-based graphical user interface in Windows 7/Vista. It is intended to offer more advanced 
features than are available in the standard interface, including new transparencies and animations.

InDesign support for World-Ready Composer | CS4, CS5
Adobe InDesign CS4 and CS5 don't support World-Ready Composer. World-Ready Composer is the GUI-less, 
scriptable method that enables support for “complex script" languages, such as Arabic and Hebrew.

While the World-Ready Composer exists in InDesign CS5, it has never been marketed as an official feature. Although 
there are references to it in the InDesign code, there is no InDesign documentation that covers World-Ready 
Composer.

If you want to report issues with World-Ready Composer and InDesign, use the bug report form on Adobe.com: 
Feature Request/Bug Report Form.

 

InDesign starts with missing workspaces, keyboard 
shortcut sets, and/or other presets and resources 
(Windows)

Issue
When you start Adobe InDesign CS4, your customized workspaces are missing, keyboard shortcuts do not work and 
other presets are not working.

Reason
User permissions, or some other cause, are preventing resource files from being loaded into the application.

Solution

Solution 1: Set permissions for all users to have full control on the InDesign registry key.
NOTE: Adobe does not provide support for making edits to registry keys. This information is provided as is. For 
support in making modifications to your system registry, please consult Microsoft Technical Support.

1 Choose Start > Run (XP only), then type regedit and press return.

https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform
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2 Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Adobe\InDesign

3 Right-click on the InDesign element and choose Permissions.

4 Select the group "Users" then select the checkbox for Allow under the permission Full Control

5 Click OK.

Solution 2: Log in with Administrator rights or created a new local Administrator account
Create a new local administrator account on Windows XP

1 Right click My Computer and select Manage.

2 Expand Local Users and Groups, right click Users, and choose New User

3 Fill in User name and full name.

4 Deselect User Must Change Password At Next Logon and select Password Never Expires.

5 Choose create and click Close.

6 Right click on the user account name and choose Properties.

7 Choose Add on the Members Of tab.

8 Type Administrators and click OK.Note: If the user is currently logged into a domain, then you might need to 
change the location to the local computer using the Locations... button.

9 Click Start > Shut Down, select Log Off, and click Ok.

10 Log in as the newly created user.

For instructions on creating a new user account, see "To add a new user to the computer" in Windows Help or contact 
your system adminstrator or the manufacturer of your computer.

On Windows Vista, see "Create new local administrator account (Windows Vista)" (TechNote kb404912) for details.

Solution 2: Set the access rights for the InDesign Presets folder to Full Access.
1 Choose Start > Run.

2 Type cmd in the Open box, and click OK.

3 Type the following CACLS commands for your operating system exactly, include quotation marks, and press Enter 
at the end of each command line: 

Important: Enter spaces before and after /T, /E, /C, and /G in each line.

• On Windows XP: cacls "C:\Program Files\Adobe\Adobe InDesign CS4\Presets" /T /C /E /G Administrators:F 
cacls "C:\Program Files\Adobe\Adobe InDesign CS4\Presets" /T /C /E /G SYSTEM:F cacls "C:\Program 
Files\Adobe\Adobe InDesign CS4\Presets" /T /C /E /G All Users:F

• On Windows Vista: icacls "C:\Program Files\Adobe\Adobe InDesign CS4\Presets" /T /C /Grant 
Administrators:F icacls "C:\Program Files\Adobe\Adobe InDesign CS4\Presets" /T /C /Grant SYSTEM:F icacls 
"C:\Program Files\Adobe\Adobe InDesign CS4\Presets" /T /C /Grant All Users:F

Solution 3: Run the application as administrator (Windows Vista)
Please see kb404918, "Run a program as an administrator (Windows Vista)".

Solution 4: Rename the locale folders in the preset locations
1 If InDesign is running, choose File > Quit.

http://www.adobe.com/go/kb404912
http://www.adobe.com/go/kb404918
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2 Navigate to the folder \Program files\Adobe\Adobe InDesign CS4\Presets\InDesign Shortcut Sets\

3 Rename if the folder contained within is something other than "en_US", for example, "en_GB", rename it to 
"en_US".

4 Repeat for the following additional folders:

• \Program files\Adobe\Adobe InDesign CS4\Presets\InDesign Workspaces\

• \Program files\Adobe\Adobe InDesign CS4\Presets\Page Sizes\

• \Program files\Adobe\Adobe InDesign CS4\Presets\Start Page\

Solution 5: Disable User Access Control (Windows Vista)
Important: This procedure involves disabling User Access Control. This feature is intended to prevent administrative 
accounts from performing undesired actions that may affect the system. Disabling UAC removes these notifications. 
You must restart your system after you disable or re-enable UAC.

For more information on UAC, see the Microsoft Windows Vista support site.

1 Choose Start > Control Panel.

2 Double click User Accounts.

3 Select Turn User Account Control On Or Off.

4 Deselect Use User Account Control (UAC) To Help Protect Your Computer and click OK.

5 Click Restart Now. 

Additional Information
Corrupt Preference files could cause the nessessary files for the Presets and Shortcuts not to load. After you delete the 
preference files, InDesign recreates them on startup.

For the Preset files to be accessed and saved you need the correct access rights. Not having the correct assess rights 
prevents InDesign from saving the files correctly or loading them after the application is launched.

 

InDesign Server CS5 known issues and bugs

Adobe InDesign CS5 Server known issues and bugs
Welcome to Adobe InDesign CS5 Server. This document contains known issues and troubleshooting tips not covered 
in the InDesign Server documentation. 

Please refer to Adobe Support for late-breaking information and known issues for InDesign CS5 Server.

• InDesign CS5 Server is certified to operate on Mac OS X 10.5.x. Please refer to Adobe Support for late-breaking 
information on this specific issue. (2389388)

• The Layout Adjustment feature is once again supported in InDesign CS5 Server. The Layout Adjustment feature was 
omitted in InDesign CS4 Server due to challenges in porting to 64-bit.

http://www.adobe.com/go/support/


63

Last updated 11/12/2015

• Arabic and Hebrew languages are now officially supported with InDesign CS5 Server.

• InDesign CS5 Server does not include the InDesign desktop application features for CS Live or Acrobat.com, or any 
related features including CS Review, Share My Screen, Buzzword import, Access CS Live, CS News and Resources, 
and kuler.

• InDesign CS5 Server does not support placing URL-based movies.

• Placing InDesign files into InDesign files results in an inflated file size. Perform a Save As in order to reduce the file 
size. (#2536202)

• Importing an .xls file containing GB18030 characters results in missing glyphs. As a workaround, change the font of 
the file to Arial Unicode MS or SimSun-18030 before importing to InDesign Server. (#1840859)

FLA/SWF Export Issues

• Some document installed fonts shift vertically when the file is exported to FLA and then opened in Flash Authoring. 
The workaround is to install the needed font into the system font folder and then replace that font in the document. 
(#2487723)

• Text position in a FLA file exported from InDesign Server with TLF Text option selected is higher on the page when 
opened in Flash. As a workaround, set it as lineHeight or manually set it as a number that matches in Flash 
Authoring. (#2523394)

• Some Transparency Effects (Outer Bevel, Outer Glow, Emboss, and Pillow Emboss) applied to text that is over 
another transparent object render incorrectly to SWF Preview and FLA export. For example, the background is 
lighter in color. As a workaround, change the screen mode applied to the highlight to normal, or remove the opacity 
on the background element and replace it with a 33% tint. (#2536205)

• Multi-state objects in an InDesign document exported to FLA and then exported to SWF from Flash Authoring 
continuously cycle through states in the exported movie. This is expected behavior, and ActionScript can be added 
in Flash Authoring to stop the animation. (#2496987)

• Some document installed fonts shift vertically when the file is exported to FLA and then opened in Flash Authoring. 
The workaround is to install the needed font into the system font folder and then replace that font in the document. 
(#2487723)

 © 2010 Adobe Systems Incorporated. All rights reserved. 

InDesign preferences and support file locations

InDesign preferences and support files
The preference and support files for InDesign have similar locations. These files are primarily grouped into three 
locations, though there is data in additional locations as noted below.

• The Application folder: At the location of the application, or executable, are subfolders for presets and other support 
files. These subfolders are typically where the "canned" presets are located.

• The application "roaming data folder." This folder is intended for "normal" preference data that you would want to 
roam from machine to machine in a roaming profile environment.

• The application "local cached data folder." This folder is designed for large data caches that you don't want to roam 
from machine to machine in a roaming profiles environment on Windows. It is also for data that can easily be 
regenerated if deleted.
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Mac OS X

Application "Roaming Data Folder"
• /Users/[User Name]/Library/Preferences/Adobe InDesign/Version #

Preference files saved into this location include the following:

• Color Settings

• Composite Fonts

• Find-Change Queries

• InDesign Defaults

• Scripts

• Workspaces

Preference files saved into this location include the following:

• Color Settings

• Composite Fonts

• Find-Change Queries

• InDesign Defaults

• Scripts

• Workspaces

Preference files saved into this location include the following:

• Color Settings

• Composite Fonts

• Find-Change Queries

• InDesign Defaults

• Scripts

• Workspaces

Preference files saved into this location include the following:

• Color Settings

• Composite Fonts

• Find-Change Queries

• InDesign Defaults

• Scripts

• Workspaces

Preference files saved into this location include the following:

• Color Settings

• Composite Fonts

• Find-Change Queries
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• InDesign Defaults

• Scripts

• Workspaces

Application "local cached data folder"
• /Users/[User Name]/Library/Caches/Adobe InDesign/Version [#]

Windows
Windows XP

Roaming Data Folder:

• C:\Documents and Settings\[User Name]\Application Data\Adobe\InDesign\Version [#]

Local Cached Data Folder:

• C:\Documents and Settings\[User Name]\Local Settings\Application Data\Adobe\InDesign\Version [#]

Windows 8/Windows 7/Windows Vista

Roaming Data Folder:

• C:\Users\[User Name]\AppData\Roaming\Adobe\InDesign\Version [#]

Local Cached Data Folder:

• C:\Users\[User Name]\AppData\Local\Adobe\InDesign\Version [#]\en_US\Cache

Reset preferences in Creative Cloud
To clear the preferences store in the Cloud, follow the steps below:

1 Go to creative.adobe.com and Sign in with your adobe ID.

2 Click the icon in the upper-right corner of the page.

3 Click My Application Settings to see a list of Applications who's preferences are stored in the cloud.

4 Click Clear Settings next to the application name to remove the preferences stored in the Cloud. 

https://creative.adobe.com
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Learn more about Preferences in Creative Cloud.

Delete InDesign preferences with shortcuts
You can delete the replaceable InDesign SaveData and InDesign Defaults files by holding down the following keys while 
InDesign is launching:

• Windows: Shift+Ctrl+Alt

• Mac OS: Shift+Control+Option+Command

InDesign version and preferences version number
• InDesign CS3 Version 5.0

• InDesign CS4 Version 6.0

• InDesign CS5 Version 7.0

• InDesign CS5.5 Version 7.5

• InDesign CS6 Version 8.0

• InDesign CC Version 9.x

Additional information
Here is a brief Description of what is stored in different locations:

Local Cached Data folder

• InDesign Recovery folder (+data)

• Scripting Support folder

• FindChangeData

• FindChangeDataTmp

• FontMask

• Cacheidletask log

• InDesign ClipboardScrap

• InDesign DragDropScrap

• InDesign SavedData

Roaming Data folder

• Color Settings

• Composite Fonts

• Find-Change Queries

• InDesign Defaults

• InDesign Scripts folder

• Workspaces folder

• Menu Sets folder

http://helpx.adobe.com/indesign/using/sync-settings.html


67

Last updated 11/12/2015

Also attached is a PDF document that contains further information of a range of preferences and their functions. This 
document was written for InDesign and was posted on indesignsecrets.com.

Adobe believes that the information in this document is correct. However, Adobe cannot give support on the accuracy 
of the content.

ID Preferences PDF 

InDesign or InCopy freezes or quits when you start on 
Mac OS

Issue
When you start Adobe InDesign or Adobe InCopy on Mac OS, the application crashes, freezes, or quits with one of the 
following error messages:

• "The application Adobe InDesign has unexpectedly quit."

• "The application Adobe InCopy has unexpectedly quit."

Solution
Do one or more of the following solutions:

Solution 1: Delete all Adobefnt10.lst files.

Search for and delete all copies of the AdobeFnt10.lst file that you find on the hard disk:

1 In the Finder, choose File > Find (Command + F).

2 Type Adobefnt10.lst, select the system drive, and then click the Search icon.

3 Click within the search results. Choose Edit > Select All, and then drag the selected files to the Trash.

4 Choose Finder > Empty Trash.

5 Restart InDesign.

Solution 2: Troubleshoot fonts by disabling a few at a time.

1 Deactivate all font management utilities, such as Adobe Type Manager or Extensis Suitcase.

2 Start Font Book from the Applications folder.

3 In the Collection column, select Computer.

4 Choose Edit > Disable Computer. Click Disable, when asked to confirm.

5 Run the application installer. Then do one of the following:

• If the problem recurs, repeat steps 4-5 to disable the User and Classic collections.

• If the problem doesn't recur, the problem font is in the collection you disabled. In Font Book, enable one font at a 
time in the collection and try to reproduce problem until you find the problem font.Note: If you identify problem 
fonts, Adobe requests that you complete a bug report at www.adobe.com/misc/bugreport.html. Be sure to include 
the font name, the font creation date, and the font type (for example, OpenType fonts from Adobe, TrueType, dfont, 
or Type 1).

http://helpx.adobe.com/indesign/kb//content/dam/kb/en/407/kb407987/attachments/ID_Presets___Prefs.pdf
http://www.adobe.com/misc/bugreport.html
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Solution 3: Remove third-party plug-ins from the Plug-ins folder.

Identify third-party plug-ins and then remove the plug-in files for each of those plug-ins.To identify third-party plug-
ins in CS4 and earlier, choose choose Help > Configure Plug-ins (Windows) or InDesign > Configure Plug-ins (Mac 
OS).To identify third-party plug-ins/extensions in CS5 and later, choose Help > Manage Extensions (Windows) or 
InDesign > Manage Extensions (Mac OS).

To remove third-party plug-ins: Move the plug-in file for each plug-in from the Adobe InDesign [version]/Plug-ins 
folder to a backup folder and restart InDesign/InCopy.

If you identify problems with third-party plug-ins, then please complete a bug report, available on the Adobe website 
at www.adobe.com/misc/bugreport.html. Be sure to include the plug-in name, version and manufacturer.

Solution 4: Disable the Font Agent plug-in.

If you've installed Extensis Suitcase on the system, disable the FontAgent plug-in that comes with the application. You 
may also want to check the Extensis website (www.extensis.com) for updates to Suitcase.

Solution 5: Start the application in Safe mode and disable Font Preview.

1 Restart the computer, and then hold down the Shift key immediately after you hear the startup tone.

2 Release the Shift key when the Apple logo appears. "Safe Boot" appears on the Mac OS X startup screen.

3 Start the application.

4 Choose InDesign > Preferences > Type (for InDesign), or InCopy > Preferences > Type (for InCopy).

5 In Type Options, deselect Font Preview Size.

Additional Information
If an Adobefnt10.lst file becomes damaged, it can cause InDesign or InCopy to crash, freeze, or quit when you try to 
start it. Adobefnt.lst files (for example, Adobefnt10.list) are font cache files that Adobe applications use to quickly 
gather and store information about available fonts. If you delete or rename an Adobefnt.lst file, the application will re-
create it the next time you start the application.

 

InDesign missing link relocation method, for workflow 
design and troubleshooting missing links (CS4 and 
later)
InDesign Missing Link Relocation Method

 This document explainshow InDesign attempts to resolve links when the absolute path stored in the document does 
not enable it to locate the link from the current Application environment. This information can be used to help design, 
and troubleshoot, your workflow relative to organizing, packaging, transferring, and archiving your linked assets 
relative to your InDesign documents. This information is current as of version CS4. 

If the link cannot be found at its original path, then the missing link location rules in this document begin. InDesign 
first looks for the link in the current document folder. Next, InDesign next starts looking for the link around the 
document's location by appending portions of the link's path to the document path, starting with the lowest folder level 
and proceeding to the highest. If still not found, InDesign goes up one level in the document's current path, and tries 
the same process again. This repeats for any additional folder levels that exist in the document's current path. 

http://www.adobe.com/misc/bugreport.html
http://www.extensis.com
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Example

 For example, assume that the original path to the linked graphic was here:C:\Original Root Folder\Original Sub-
Folder\Image.psd and the the InDesign document's current location is here:/Current Folder/Current Sub-
Folder/Current Document Folder/Doc.indd If the link cannot be found at its original path, then the following missing 
link location rules begin. InDesign first looks for the link in the current document folder:/Current Folder/Current Sub-
Folder/Current Document Folder/Image.psd Next, InDesign next starts looking for the link around the document's 
location by appending portions of the link's path to the document path, starting with the lowest folder level and 
proceeding to the highest:/Current Folder/Current Sub-Folder/Current Document Folder/Original Sub-
Folder/Image.psd /Current Folder/Current Sub-Folder/Current Document Folder/Original Root Folder/Original Sub-
Folder/Image.psd If still not found, InDesign goes up one level in the document's current path, and tries the same 
process again:/Current Folder/Current Sub-Folder/Image.psd /Current Folder/Current Sub-Folder/Original Sub-
Folder/Image.psd /Current Folder/Current Sub-Folder/Original Root Folder/Original Sub-Folder/Image.psd This 
repeats for any additional folder levels that exist in the document's current path:/Current Folder/Image.psd /Current 
Folder/Original Sub-Folder/Image.psd /Current Folder/Original Root Folder/Original Sub-Folder/Image.psd Finally, 
InDesign looks for the link in any of the folders that have been explicitly pointed to by the user when relinking any 
object during the current app session. This is a full history of all folders where a relink command was executed on an 
object since InDesign last launched. For example,/Image.psd /Current Folder/Other Sub-Folder/Image.psd /Other 
Folder/Other Sub-Folder/ Image.psd Etc..

InDesign Links panel fails to show actual/effective ppi 
for Photoshop EPS files (CS3 and later)

Issue
InDesign Links panel fails to report actual, or effective, ppi for Photoshop EPS files.

Solution
Use the InDesign CS4 Preflight panel to create a Preflight profile that checks for resolutions within your needed range. 
Observe for errors that indicate an image's effective resolution is out of that range.

1 Choose Window > Output > Preflight.Note: If you don't see these menu commands, choose "Show All Menu Items" 
from the bottom of each menu and submenu.

2 From the Preflight panel menu in the upper right, choose Define Profiles.

3 Click the "plus" button at the bottom of the list of existing profiles.

4 Give your profile a name.

5 Expand the Images and Objects section.

6 Select Image Resolution.

7 Expand the Image Resolution section.

8 Enable the Color Image Maximum Resolution and give it a value.

9 Enable the Color Image Minimum Resolution and give it a value.

10 Repeat Steps 8 and 9 for Grayscale images and 1-bit images.
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11 Click Save.

12 Click OK to exit the Preflight Profiles dialog box.

13 Turn on the Preflight feature, and choose your custom profile in the Preflight panel.

Note: The Preflight feature only reports on the effective resolution of an image. For example, for an image with 72 ppi, 
scaled down to 25% of its original size, Preflight reports its effective resolution of 288 ppi (4 x 72).

Additional Information
For other file formats, InDesign reads the image resolution while importing for the firs time, or when updating an 
existing link. It then caches the information in the document for quick reference later. The Photoshop EPS import 
function does not have methods for caching the resolution information.

Currently this issue is a designed limitation for InDesign.

Resolution information may also be missing for PDF files that contain multiple images with different resolutions, or 
that contain no images.

Adobe InDesign and InCopy CS4 for Citrix Presentation 
Server 4.0
What's Covered

• Product names 

• Document overview 

• Product overview 

• Installing InDesign & InCopy CS4 products 

• Basic acceptance tests for InDesign & InCopy CS4 

• Removing InDesign & InCopy CS4 

• Troubleshooting 

• Known Issues 

• Support Statement for Windows Terminal Services 

1. Product names

 Adobe InDesign & InCopy CS4 and Citrix Presentation Server 4.0. 

2. Document overview

 This document explains how an IT manager can reliably install and host Adobe InDesign & InCopy CS4 on a Citrix 
Presentation Server 4.0 server and have the applications published to a Macintosh, Windows and/or Linux clients using 
the Citrix client software. This document assumes that you have a basic understanding of the Windows Server/Client 
operating system, CitrixÂ Presentation Server software, and Adobe InDesign & InCopy CS4 installer software. A list 
of the Known Issues documented by Technical Support can be accessed by using the Citrix keyword via the Adobe 
Technical Support Knowledge Base. 

Here is the URL for the Citrix home pagehttp://www.citrix.com

3. Product overview

http://helpx.adobe.com/indesign/kb/#main_ProductNames
http://helpx.adobe.com/indesign/kb/#main_DocumentOverview
http://helpx.adobe.com/indesign/kb/#main_ProductOverview
http://helpx.adobe.com/indesign/kb/#main_Installing
http://helpx.adobe.com/indesign/kb/#main_AcceptanceTests
http://helpx.adobe.com/indesign/kb/#main_Removing
http://helpx.adobe.com/indesign/kb/#main_Troubleshooting
http://helpx.adobe.com/indesign/kb/#main_KnownIssues
http://helpx.adobe.com/indesign/kb/#main_SupportStatement
http://www.citrix.com
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 Adobe has validated the installation procedures and the remote application launching and running of Adobe InDesign 
& InCopy CS4 using Citrix Presentation Server 4.0 Server. 

Important: We do recommend you refer to the Adobe InDesign and/or InCopy CS4 Installer documentation in the 
User Guide as well as the Citrix document--"MetaFrame Presentation Server 4.0 Administrator's Guide." 

System requirements

You can ï¬nd the system requirements for InDesign & InCopy CS4 products at the following locations:

• InDesign CS4http://www.adobe.com/products/indesign/systemreqs.html

• InCopy CS4 Standardhttp://www.adobe.com/products/incopy/systemreqs.html

The environments used for validation were set up in the following ways:

 Host--An English Windows Server 2003 SP1 (Standard Edition) with Windows Terminal Server that is a member of 
an Active Directory domain. Citrix--Citrix Presentation Server 4.0 

• System Partition and Application partition moved from c: and d: to m: and o: respectively using the Citrix 
driveremap.exe utility. 

• Applications were deployed via the Citrix Web Interface. 

Important: Our validation environment did not include other Languages like Japanese or other Citrix technologies like 
Metaframe Server, Presentation Server 3.0 or Program Neighborhood, etc. 

End-User Licensing Guidelines

 You must have a valid license to the desktop version to respective InDesign or InCopy software (âœSoftwareâ) for all 
users who have access to the Software on a Citrix Presentation Server 4.0 terminal server -- not for the number 
concurrent users. All use is limited to users on your Internal Network, as defined in the Software End User License 
Agreement. This section is intended to provide some clarity of the terms of the EULA, but does not supercede the terms 
of the EULA. In the event of any conflict between the terms of this User Document and the EULA, the terms of the 
EULA shall control. (See Section 2.3 of the EULA) 

4. Installing InDesign and InCopy

Install InDesign CS4 or InCopy CS4 on a Citrix Presentation Server 4.0 Server:

Important: If your Activated InDesign and InCopy CS4 licenses are not purchased through volume licensed program, 
then you must use a non-Activating versions of InDesign and InCopy CS4 for use in a Citrix environment. To learn 
more about Adobe's volume licensing program, please contact an Adobe reseller or Adobe sales representative. 

These installations steps are based upon the specific environment indicated in the Environment section of this 
document. 

Running the application installers

1 Double click the Installer setup file which is named â˜ADBEIDSNCS4_LS1.exeâ.

2 Choose a location to extract the Installer and hit Next.

3 Leave the âœLaunch Install Adobe InDesign CS4â option checked and click Finish

4 The installer will launch

5 Youâll get a minimum system Requirements warning since you are using a server OS. Click Continue.

6 Enter your serial number.

7 Click Next

8 Click Install

http://helpx.adobe.com/x-productkb/policy-pricing/system-requirements-indesign.html
http://helpx.adobe.com/x-productkb/policy-pricing/system-requirements-incopy.html
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9 Once the install is done, click Exit

Publish the Application(s) via Citrix

1 Start the Management Console for Presentation Server 4.0 -- To start from the Citrix toolbar, click the button that 
has a personâs head, an app, and a server icon on it. -- To start if you donât have the toolbar, double-click ctxload.exe 
in Program Files\Citrix\Administration. (replacing c: with the drive letter of your system drive if 
necessary)Important Note: Once you start the Management console, youâll see a list of your farms on the left hand 
side. If needed, type your user ID and password, to authenticate to the farm.

2 Click + (plus) next to the farm to which you want to install the InDesign CS4 or InCopy CS4 applications.

3 Right click the Applications folder icon that is within the farm you just expanded and choose Publish Application. 
The Citrix Application Publishing Wizard will start. All of the following steps take place within the Citrix 
Application Publishing Wizard.

4 Enter a Display Name for the application. If youâre not sure what to enter then use the name of the application 
(InDesign CS4 or InCopy CS4). The Application Description text field is optional.

5 Click âœNextâ.

6 Click Browse under the Command Line text field.

7 Navigate to where the InDesign CS4 or InCopy CS4 Application is installed and select the InDesign.exe or 
InCopy.exe file. If you performed a standard install of InDesign this path will be c:\Program Files\Adobe\Adobe 
InDesign CS4\InDesign.exe. [The standard install path for InCopy is the same, only with InCopy CS\InCopy.exe at 
the of the path.]

8 Click âœOKâ.

9 Leave the default values for the Working Directory text fields, and click Next.

10 Leave the default values on the Program Neighborhood Settings screen, and click Next.

11 Set the Specify Application Appearance values so they meet the minimum requirements for InDesign or InCopy. If 
you are unsure what values to set, select Fullscreen for Session Window Size, and True Color for Colors.

12 Click âœNextâ

13 Choose settings on the Specify The ICA Client Requirements screen based on your security and deployment 
requirements. If you are unsure what settings to choose, leave everything at the default setting, and click Next.

14 Specify the servers to which you will publish the application. Choose a server on the left and click Add to list it on 
the right hand side; this indicates the application will run on that server.

15 Click Next.

16 Specify the Users who can use the published application. You can use any of the following scenarios: --If there is a 
specific group that you wish to give usage privileges to, you can drill down through the domain tree and locate that 
group. To add the group, click Add and it will be listed in the box on the bottom of the window. --If you want to let 
anyone on your network use the application, select Allow Anonymous Connections.

17 Click Finish to publish the application and make it available for network use via Citrix.

18 If you need to install another application (InDesign CS4 or InCopy CS4) then return to step 2.Important Note: After 
you install InDesign or InCopy, the application installer may prompt you to restart the server. If you receive this 
prompt, Adobe strongly recommendeds that you restart the system.

Access InDesign & InCopy CS4 from a client compatible computer
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Important: These access instructions are specific to the environment as documented in section 3.2 

1 Start your Web browser and enter the URL specified by the IT Manager for Web Access to the Citrix Presentation 
Server 4.0 Server

2 Enter your specified Username & Password when the Citrix Presentation Server 4.0 Login main window displays 
and then click Log-in.Note: IT Managers can set up the server to allow users to select the option, âœDesktop 
Credential Pass-throughâ or they may require users to select the option, âœExplicit User.â

3 Double-click the icon to start InDesign or InCopy in the Citrix Presentation Server 4.0 Applications window. 
Important Note: The IT Manager may grant application access rights on a user-by-user basis

5. Basic acceptance tests for InDesign and InCopy

 After you complete the installation of InDesign or InCopy, test the application on a target computer. This section 
details tests you can perform to ensure that you installed InDesign & InCopy CS4 successfully. 

To verify that InDesign and InCopy plug-ins installed: 

1 Start InDesign or InCopy, and then verify that no error messages appear on the startup screen.

2 Choose Help > Configure Plug-ins and in the Sets Popup Menu select the option All Plug-ins.

3 In the Display section, deselct Enabled and make sure that Disabled is selected. Verify that there are no Disabled 
plug-ins listed in the Scrollable Window.Important Note: You can also select plug-ins individually in the window, 
and then click Show Info to get more information about the plug-in, including confirmation that the plug-in is 
loaded and enabled.

Check that basic file acctions and commands work correctly

 To check that basic file actions and command work correctly, do the following basic file actions and commands on the 
target computer after you successfully start the applications and verify all plug-ins are loaded and properly enabled: 

1 Choose File > New > Document and click OK with the application defaults

2 Choose File >Save As (InDesign) or File > Save Content As (InCopy) and choose a local or server directory and 
name the file, and then click OK.

3 Choose File > Open and navigate to a directory that contains either an existing InDesign document (INDD) or an 
existing InCopy document (INCD or INCX), select the document, and then click Open.

4 Make some modifications to the document, select File > Save a Copy (InDesign) or File > Save Content Copy 
(InCopy), and then click OK.

5 Perform InDesign specific acceptance testing:

a Choose File > Place and navigate to a directory containing file types that InDesign uses and confirm that you can 
place all of the following file types successfully: JPG, PSD, TIFF, EPS, AI, PDF, DOC, RTF, XLS, and XML.

b Confirm that you can edit the text files in both Layout and Story views

c Confirm that you can apply all transformations supported by InDesign to the Placed graphic files in step 5.

d Confirm you can Print and Export a PDF file.

6 Perform InCopy specific acceptance testing:

a In a new InCopy document, choose Type > Fill with Placeholder Text.

b Switch to Story or Galley View and choose Changes > Track Changes in Current Story.

c Select the first paragraph and press Delete.

d Select a sentence in the second paragraph and choose Notes > Convert to Note.

e Choose Notes > Expand/Collapse Notes In Story.
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f In the second paragraph, type a new sentence.

g Switch to Layout View. place a text insertion point in the beginning of the third paragraph, press F8 to display up 
the Notes palette, and then enter a note and press F8 again.

h Choose File > Save Content As, and then close the document.

i Choose File > Open, select the document saved in step h, and then verify that all edits were preserved..

6. Removing InDesign and InCopy

 Removing InDesign or InCopy from a Citrix Server consists of deleting the published application from the Citrix 
Management Console, then removing the application using the standard Add/Remove Programs Control Panel. 

Delete the published application from the Citrix Management Console

1 Start the Management Console For Presentation Server 4.0 in one of the following ways: --Click the button on the 
Citrix tool bar which has a personâs head, an app, and a server icon on it. --Run it from Program 
Files\Citrix\Administration\ctxload.exe. Important Note: Once the Management console has launched, youâll see a 
list of your farms on the left hand side.

2 Expand the farm object where the InDesign/InCopy application is installed.

3 Click on the Applications folder to display your InDesign and InCopy applications should be shown in the main 
pane of the window.

4 Right click on InDesign CS4 or InCopy CS4, and choose Delete Published Application.

5 Click Yes on the confirming dialog.

6 Repeat step 4 if necessary to remove the other InDesign CS4 or InCopy CS4 application.

7 Close the âœManagement Console for Presentation Server 4.0â

Remove the application using Add/Remove Programs

1 Choose Start > Settings > Control Panel > Add/Remove Programs

2 Select either InDesign CS4 or InCopy CS4 by clicking on itâs name in the list of currently installed programs.

3 Click Change/Remove beside the application you want to remove to start the Adobeâs Installer, then click Next.

4 Select Remove, and then click Next.

5 Click Uninstall

6 Click Exit on the verification screen to leave the uninstaller.

7 Repeat steps 2-6 to remove the other application.

7. Troubleshooting

Contacting Adobe Technical Support

 If you need to contact Adobe Technical Support, please prepare answers to the following questions so that we can better 
assist you: 

1 Which Server Operating system and version number is the Citrix Presentation Server 4.0-based server running? 
Which Service Pack (if any) has been applied to the server operating system?

2 Which version of the Windows client operating system is the client computer? Which Service Pack (if any) has been 
applied to the client operating system? Do these programs meet the environment requirements listed in 
Environments section in this document?

3 Which version of the Citrix Presentation Server 4.0 Server software are you currently running? Which Citrix 
Hotfixes and Service Packs have you installed?
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4 What is the problem statement (for example, âœWhen I do X with Y, Z happensâ)? If the problem produces an error 
message, what is the exact wording of the message?

5 Which user proï¬le is logged into the server (for example, Administrator or Power User)? Does the problem occur 
when an Administrator proï¬le is logged into the server?

6 Which user proï¬le is logged into the client computer (for example, Administrator or Power User)? Does the 
problem occur when an Administrator proï¬le is logged into the client computer?

7 Can you reproduce the problem when you test the problem on the server? If so, what steps reproduce the problem?

8 What goal are you trying to achieve? Have you been able to achieve this goal in the past? If so, did anything change 
recently in your environment that might be related to the problem?

8. Known Issues

 As of October 2008, there are no known issues with installation procedures and the remote application execution of 
Adobe InDesign CS4 and InCopy CS4 using Citrix Presentation Server 4.0 Server 

9. Support Statement for Windows Terminal Services

 Adobe InDesign and InCopy CS4 supports Windows Terminal Services and Citrix Server/Client configurations. Citrix 
Presentation Server 4.0 Server implementations leverage core Microsoft Windows Terminal Services. Adobe has 
performed limited testing with standard Microsft Windows Terminal Services for Windows 2003 Server. Our testing 
coverage focused on basic file actions consisting of the following: 

1 Remote Launching of the applications

2 Creating and Saving new documents

3 Opening existing documents

 Copyright 2008 Adobe Systems Incorporated. All rights reserved. 

Adobe, the Adobe logo, InCopy and InDesign are either trademarks or registered trademarks of Adobe Systems 
Incorporated in the United States and/or other countries. Windows is a trademark or registered trademark of Microsoft 
Corporation in the United States and/or other countries. Macintosh is a trademark of Apple, Inc., registered in the U.S 
and other countries. Linux is the registered trademark of Linus Torvalds in the U.S. and other countries. All other 
trademarks are the property of their respective owner.

InDesign fails to respond to show or hide commands or 
disappears while its process continues (Mac OS X 10.5-
10.5.5)

Issue
 Adobe InDesign CS3 or CS4 fails to respond to the show or hide commands when you use the Cmd+H keyboard 
shortcut or the "Hide InDesign" or "Show All" commands on the Application menu on Mac OS X10.5.x. 

InDesign may enter into a hidden state and cannot be made visible again. This can occur when switching context from 
or to InDesign. For example, clicking on the desktop to switch to the finder, or using the Command+Tab keys to switch 
between InDesign and another application.

 You might also have problems maximizing or minimizing the application. 
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Reason
Adobe Engineering is working with Apple to address this issue.

Solution
 Do one of the following solutions: 

Solution 1: Update your Mac operating system to 10.5.6.
 For more information on how to upgrade your operating system, please refer to http://www.apple.com/downloads. 

Solution 2: Quit and Restart InDesign before the issue appears.
 When you first start InDesign, before this issue appears, quit and restart InDesign. Many customers have found this 
prevents the issue from occurring later in their application session. 

Solution 3: Restart InDesign after the issue appears.
 If InDesign is still visible, but not responding to the Hide command (Command+H), then quit InDesign and restart 
the application. 

If InDesign has become hidden, and cannot be made active again, then do one of the following: 

Quit using the Dock

1 Control+Click the InDesign icon in the Dock and choose Quit.Note: If there are open unsaved documents, this will 
not work as the save confirmation dialog will be invoked and cannot be dismissed because the user interface (UI) is 
hidden.

2 Relaunch InDesign.

Force quit

1 Press Command+Option+Escape to invoke the Mac OS X Force Quit Applications dialog box.

2 Select InDesign and click the Force Quit button.

3 In the next dialog box, click the Force Quit button again to confirm your selection.

4 Restart InDesign and use the Document Recovery feature to recover any unsaved changes to documents which were 
open when you forced quit.

http://www.apple.com/downloads
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InDesign CS4 Sample Buttons Library has limited 
functionality

Issue
 In some circumstances on Mac OS or Windows platforms you cannot add custom created buttons or modified existing 
buttons to/from InDesign CS4 Sample Buttons Library. 

Reason
InDesign CS4 Sample Buttons Library is locked for non-administrator users on the Mac OS and on Windows XP and 
Vista.

Solution

Unlock the InDesign CS4 Sample buttons Library.
To unlock InDesign CS4 Sample Buttons Library do the following: 

• On Mac OS: login to account with administrator permissions and start InDesign. 

• On Windows XP: login to account with administrator permissions and start InDesign. 

• On Windows Vista: 

1 Highlight InDesign.exe - left mouse click. 
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2 Run in InDesign as administrator - right mouse click and select "Run as Administrator". 

InDesign CS4 or earlier crashes when opening 
documents when FontExplorer X Pro is enabled (Mac OS 
X)

Issue
When opening a document on Mac OS X, Adobe InDesign CS4, CS3, or CS2 crashes, hangs, or freezes.

Note: Typically this problem occurs if you have the FontExplorer X Pro InDesign Plug-in 3.0.5 or earlier installed, and 
if the document you are opening contains an EPS or PDF graphic that has references to non-embedded fonts.

Solution
Download and install the InDesign CS2/CS3/CS4 Plug-in Version 3.0.6 for FontExplorer X Pro. Be sure to download 
the file that matches your version of InDesign:

For InDesign CS4: http://fex.linotype.com/download/mac/plugins/FEX_InDesign_CS4_6503.zipFor InDesign CS3: 
http://fex.linotype.com/download/mac/plugins/FEX_InDesign_CS3_6357.zipFor InDesign CS2: 
http://fex.linotype.com/download/mac/plugins/FEX_InDesign_CS2_6370.zip

The new plug-in fixes the problem of InDesign crashing when opening a document that contains graphic elements such 
as EPS and PDF with non-embedded fonts.

To install the plug-in:

1 Quit FontExplorer X Pro.

2 Remove the FontExplorer X Pro InDesign Plug-in 3.0.5 from the InDesign CS2/CS3/CS4 Plug-in folder 
(/Applications/Adobe InDesign CSx/Plug-Ins/).

3 Quit InDesign.

4 Copy the downloaded file into /Applications/Adobe InDesign CSx/Plug-Ins/.

5 Double-click the .zip file to unpack the plug-in (optionally delete the .zip file afterward or remove it from the Plug-
in folder and store elsewhere).

6 Restart FontExplorer X Pro.

7 Open the Plug-in Manager from the Tools menu and check that the Plug-in Version 3.0.6 is installed Note: Do not 
press the Downgrade button; clicking Downgrade installs Plug-in Version 3.0.5 again.

Additional Information
If this solution doesn't solve your problem, contact the FontExplorer X Pro team via their web contact form:

http://www.fontexplorerx.com/support/

 

http://fex.linotype.com/download/mac/plugins/FEX_InDesign_CS4_6503.zip
http://fex.linotype.com/download/mac/plugins/FEX_InDesign_CS3_6357.zip
http://fex.linotype.com/download/mac/plugins/FEX_InDesign_CS2_6370.zip
http://www.fontexplorerx.com/support/
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InDesign CS4 becomes unresponsive when Dynamic 
Spelling is enabled (Mac OS X)

Issue
InDesign CS4 slows or appears to freeze. Dynamic spelling is enabled and the text is being composed with custom 
document dictionary entries that use more than one language.

Solution
Do one of the following:

1 Remove any words from the document dictionary and add them back with the target set to User Dictionary.

2 Remove words from the document dictionary and re-add them with the same Language setting for all.

3 Turn off the Dynamic Spelling feature.

Additional Information
The Language selection "All Languages" counts as a language of it's own. If you have dictionary entries under the Target 
of your document, with the Language "All Languages" along with other entries in the document that use any other 
language, you can encounter this issue.

Adobe InDesign CS4 6.02 update fails to install on 
Windows if 6.0.1 was previously installed.

Issue
When installing the Adobe InDesign CS4 6.0.2 update on top of the earlier 6.0.1 update, the installation fails with the 
error message, "Adobe InDesign CS4 6.0.2:Failed to install." The Installer log file will typically show the following near 
the end of the log:

 

[ 4168] Mon May 04 09:39:04 2009 ERRORThe following payload errors were found during install:- Adobe InDesign 
CS4: Install failed

Earlier in the log, you'll typically see this, which is the secondary cause of the failure. Note that the checksum value will 
vary based on which file is being evaluated:

Original file has invalid checksum "2dfb6affbe5697940bdf9a86e6311083"[ 5912] Mon May 04 09:39:02 2009 ERROR
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Reason
When the 6.0.2 update identifies that the installed version of InDesign CS4 has already been updated, it should revert 
the updated files back to their original versions. This ensures that the files to be patched will be the same regardless of 
whether previous updates have been installed, or not. For some unknown reason, for a subset of Windows users, the 
roll-back to the original 6.0.0 files is not happening, and so the checksum test fails, and the installer gives up and 
attempts to 

Solution
Currently, the only solution is to uninstall InDesign CS4, then reinstall, and then run the 6.0.2 update directly. This 
should ensure that the files are all the original 6.0.0 versions, which the updater knows how to patch.

InDesign CS3 or CS4 documents with placed InDesign 
files fail to update links to placed InDesign files

Issue
 When you work with InDesign CS3 or InDesign CS4 documents that contain large numbers of placed native .indd files, 
some links to those native files may fail to update. 

Details
 Printed output for the affected artwork might image as a low resolution proxy when you print or export to PDF. 

Reason
 This issue is caused by a limitation in the number of InDesign documents that can be open at one time (150). When 
InDesign opens a book or document that contains links to placed .indd files, it needs to open those .indd files in the 
background in order to have high resolution data to draw to the screen, or to print, or toexport. The solution involves 
opening some of the files, reading the necessary data, closing them, then repeating the process. This avoids the 150 
open document limit. 

Solution

Install the InDesign CS4 6.0.1 update.
 Download updates from the Adobe website at http://www.adobe.com/downloads/updates. 

• For Mac OS:http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Macintosh

•  For Windows:http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Windows

http://www.adobe.com/downloads/updates
http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Macintosh
http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Windows
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InDesign CS3 documents reflow unexpectedly when 
opened in InDesign CS4

Issue
When you open documents created in InDesign CS3 or earlier in InDesign CS4, the document's text reflows 
unexpectedly. This is likely to affect text with Eastern European languages applied, such as Russian, Polish, and 
Ukrainian.

Reason
The Hyphenation Limit is getting incorrectly set to zero.

Solution

Install the InDesign CS4 6.0.1 update.
 Download updates from the Adobe website at http://www.adobe.com/downloads/updates. 

• For Mac OS:http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Macintosh

•  For Windows:http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Windows

InDesign crashes upon launch while attempting to 
recover a damaged document

Issue
InDesign continues to crash each time you try to re-start.

Reason
Documents can become damaged while working on them in InDesign, or they can contain damaged information, for 
example, due to hard drive or other disk read/write errors. The situation can occur when InDesign opens the file 
initially, but then cause a crash because InDesign tries to read or write from or to a damaged portion of the file.

The InDesign document recovery feature tries to automatically open InDesign documents which were open during the 
time of an application crash. If the document it is trying to open is damaged, then it can cause InDesign to crash each 
time you restart InDesign.

Solution

http://www.adobe.com/downloads/updates
http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Macintosh
http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Windows
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Remove the file or files from the document recovery folder.
Move these files to your desktop, and attempt to recover them using the methods described in, "Troubleshoot damaged 
InDesign documents" (TechNote kb403982).

You can change the document recovery folder in the user preferences. The default path is listed below, but check the 
location in Preferences > File Handling > Document Recovery Data to be certain.

• On Mac OS: /[Hard Drive]/Users/[User Name]/Library/Caches/Adobe InDesign/Version [#.0]/InDesign Recovery

• On Windows XP: C:\Documents and Settings\[User Name]\Local Settings\Application 
Data\Adobe\InDesign\Version [#.0]\en_US\Caches\InDesign Recovery

• On Windows Vista and Windows 7: C:\Users\[User Name]\AppData\Local\Adobe\InDesign\Version 
[#.0]\en_US\Caches\InDesign Recovery

Crash, blank dialog boxes | Mac OS X Lion 10.7.4

Issue
When you use InDesign or InCopy CS4 or later on a 2012 Mac OS X Lion system, you receive a blank warning dialog 
box. The application crashes when you perform certain functions.

Solutions

Solution 1
• InDesign CS4 and later: Update Mac OS X 10.7 to Mac OS X 10.8.

• InDesign CS6 only: Install the latest updates for InDesign CS6 by going to Help > Updates within the application.

Solution 2
1 Download and run the following script.

IDIcons_1074_Script.app.zip

2 The script asks you to choose a copy of InDesign/InCopy to update. Direct the script to your current installation.

Solution 3
The following steps are the same solution as Solution 1, but the files are copied manually. Do them if Solution 2 is not 
successful.

1 Close InDesign and download the zip archive containing three InDesign icons.

IDIcons_1074_Fix.zip

Note: Placing these files should continue to allow additional updates. But be aware that you are modifying the existing 
application file. Moving or changing the contents of the application can make it necessary to reinstall the 
application.Adobe recommends installing all official updates before placing these files within the application. You can 
access these updates through Help > Updates or on the Adobe website.

http://www.adobe.com/go/kb403982
http://helpx.adobe.com/indesign/kb/indesign-crashes-blank-dialog-boxes/_jcr_content/main-pars/procedure_0/proc_par/step/step_par/download/file.res/IDIcons_1074_Script.app.zip
http://helpx.adobe.com/indesign/kb/indesign-crashes-blank-dialog-boxes/_jcr_content/main-pars/procedure/proc_par/step/step_par/download/file.res/IDIcons_1074_Fix.zip
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2 Extract the icons from the zip file to an easy to find location, such as your desktop.

3 Navigate to: /Applications/Adobe InDesign CS6/ or where the application is installed on your system.

4 Right click or CTRL+Click the InDesign application file and choose "Show Package Contents."

5 Within the InDesign application file, navigate to: /Contents/MacOS/Required/ and locate the file "Application 
UI.InDesignPlugin" and again "Show Package Contents."

6 Within the plug-in, navigate to the Resources folder and then into the folder "idrc_PNGA."

7 Copy the three icon files from the extracted zip file to the folder "idrc_PNGA."

8 Relaunch InDesign.

Solution 4
Do not install the Mac OS X (Mid 2012) Software Update to 10.7.4. Or, uninstall it if possible, by using the recovery 
function of Mac OS X Lion.

Additional information
The latest update for Mac OS X Lion has removed an API file that InDesign uses to work with system icons. By placing 
the files directly within the applications, you are working around the function the API served.

Adobe has been able to work with Apple to help make sure these APIs are present within their latest release of Mac OS 
10.8.

At this time, the only working solution for CS4 is to install the more recent Mac OS 10.8.

InCopy assignment links are missing or cannot be edited 
when working in cross-platform workflow (InCopy CS3 - 
CS5)

Issue
When you open an .indd file in InDesign, links to *.icml files are shown as missing, and cannot be checked in.

Or...

When opening an *.icma or other file with links to *.icml files in InCopy, the assignments are shown as missing and 
cannot be checked out.

Solution

Solution 1: Upgrade to InDesign/InCopy CS5
This issue has been addressed in the CS5 release of InDesign and InCopy.
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Solution 2: Rename *.icml files and edit links in the *.icma file
Note: At some point, the *.icml files moved from one type of file system to another where the font encodings were 
different. This move caused remapping of a character in the *.icml filename. Due to this change in the filename, the 
link from the InCopy Assignment file cannot find the *.icml content file. Remapping of one or more filename 
characters occurs in workflows where some users are on Mac OS X and others on Windows systems, or when files were 
moved via a remote file server, e-mail server, FTP server, or other. Characters affected by this issue are usually extended 
or Upper ASCII characters, like Umlauts or accented characters.

Perform both of the following procedures:

Finder (Mac) or Windows Explorer
1 Edit the *.icml files in the so that they contain no extended characters, like Umlauts or accented characters.

2 Remove all spaces.

3 Note the filename for use when modifying the content of the .icma files in the next part of this solution.

Note: Removing all spaces and other non-alphanumeric characters makes it easier to write a matching name in the 
*.icma file.

Text Editor
1 Open the *.icma file in a text editor and search for all instances of "<link".

2 Locate the portion of the path that is the filename. Replace it with the new name you created in the first part of this 
solution.

3 Save the file.

4 Open the .indd file that contains links to the .icml files.

5 Choose > WIndows > Links to display the Links panel.

6 Selelct the affected .icml file, and click the Relink button and select the renamed file.

Solution 3: Recreate your assignment content so that it does not contain non-lower ASCII 
characters
1 Unlink the *.icml.

2 Resave the *.indd so that it has more than 26 characters that are all lower ASCII.

3 Re-export the assignments.

Solution 4: Compress your files before moving them through another file system
Compress the files, for example, as a *.zip, before sharing it on a different operating system, uploading it to an FTP 
server, e-mailing it, or distributing it in any other way. 

Example: If all users are on Mac, but the files are distributed via Windows file server, keep the files compressed during 
this transfer. Unzip them when they reach the destination workstation that uses the same character encoding as the 
others workstations involved with the files.

Additional Information
InDesign CS3-CS4 automatically names *.icml files that it creates in the Contents folder while generating InCopy 
Assignment files (.icma), using this formula:

Trim to 26 characters ([.indd file name] + [story text]) + .icma
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If the INDD filename is 26 characters or greater, then the story text never contributes to the names of the .icma, and 
the subsequent .icma files in the same Assignment file are clipped and incremented, for 
example:123456789a123456789b123456.icml123456789a123456789b1234-2.icml...123456789a123456789b123-
10.icmlEtc...

If your InDesign filename is less than 26 characters, and if the algorithm takes text from your story content and the 
story content has non-lower ASCII characters, you run the risk that cross-platform workflow modifies the filenames 
due to platform font encoding differences. Thus the link object in the *.icml points to something like:

LinkResourceURI="file:/Users/joe/Desktop/InCopyTest%20Assignments/content/InCopyTest-
Upp%C3%A9r%20ASCII.icml"

But the string %C3%A9, which resolves to an accented e (&eacute;), makes the file not found because the file on disk 
has gone from:InCopyTest-Upp&eacute;r ASCII.icmlto:InCopyTest-Upper ASCII.icml or...InCopyTest-Uppr 
ASCII.icml or...InCopyTest-Upp[notdef char]r ASCII.icml

 

Identify and deactivate third-party plug-ins in InDesign 
CS4 (TechNote Video)

Issue
This document demonstrates how to identify and deactivate third-party plug-ins in InDesign CS4.

Solution 
Play the video below to learn how to identify and deactivate third-party plug-ins in InDesign CS4.

If you prefer text instruction, you can read the HTML version.

 

Hyperlinks do not work in SWF files exported from 
InDesign (InDesign CS4, CS5)

http://kb2.adobe.com/cps/508/cpsid_50846.html
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Issue
When testing the link in the SWF file locally, hyperlinks do not work in Flash SWF files that have been exported from 
InDesign CS4 or InDesign CS5.

Solution

Solution 1: Upload the Flash SWF file to a web server
 

Solution 2: Set the Flash Player Security Settings to allow access to the file on the Hard Drive 
When you click the hyperlink in the SWF running in a web browser (or the standalone Flash Player) from your local 
disk, you are presented with an "Adobe Flash Player Security" dialog.

1 Click the Settings button.

2 In the web page set the Flash Player to approve access the folder on the local drive.

Note: If you have no intention of uploading the SWF to a web server, you can declare the top-level directory of the hard 
drive as “Safe” to the Flash Player. Thus you don’t have to set the access permission for every SWF file you want to run 
locally.

Solution 3: Use the Preview Panel (InDesign CS5 only)
To open the Preview Panel do one of the following:

• Click the Preview icon in your Motion, or Animation Panel.

• Use the keyboard shortcut: Cmd+Option+Return ( Mac), or Ctrl+Alt+Enter ( Windows).

Additional information
For hyperlinks in SWF files not to work locally is expected behavior. 

By default, you cannot mix local and network references (URLs) in the same SWF when running the SWF locally. If 
you deploy the SWF to a web server, the hyperlinks should work as expected. In order to preview this correctly when 
running the SWF locally, you have to declare your local directory as "safe" to the Flash Player.

 

"Failed to Export PDF" when you downsample large 
images while exporting to PDF (InDesign)
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Issue
 When you export an InDesign documnent to PDF with downsampling enabled, large images can require large amounts 
of memory. If the memory needs exceed the amount of system and virtual memory available, then the export might fail 
withthe message, "PDF Export Failed." 

Reason
 This is typically caused by placing images, or graphics that contain images, and scaling them down significantly. This 
causes their effective resolution to increase. For example, a 600 dpi image scaled to 50% has an effective resolution of 
1200dpi. But placing a large, high resolution image without scaling could also require more than the available memory, 
depending on your system configuration and state, and the downsampling settings. 

Solution

Solution 1: Install the InDesign CS4 6.0.1 update.
 Download updates from the Adobe website at http://www.adobe.com/downloads/updates. 

• For Mac OS:http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Macintosh

•  For Windows:http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Windows

Solution 2: Downsample the images after export using Acrobat.
1 Choose File > Export and select PDF as your format, choose a location and click Save.

2 In the Export PDF dialog box, disable the image downsampling options.

3 Open the resulting PDF in Acrobat.

4 Choose Advanced > PDF Optimizer.

5 Set the downsampling options you desire in the Image Settings pane.

6 Disable any other options that are not needed.

7 Click OK and choose the name and location to save the file.

Solution 3: Downsample the images prior to export using Photoshop (or another photo 
editing tool).
1 Context-click on the image in the layout, or the links panel, and choose Edit Original.

2 Once the image has opened in Photoshop, choose Image > Image size.

3 Ensure that Resample Image, and Constrain Proportions are enable.

4 Adjust the document size values to the needs of your layout.

5 If the image resolution is larger than what is required by your final output, adjust the value here.

6 Save and close the image.

7 Return to InDesign.

8 Update the link if necessary.

http://www.adobe.com/downloads/updates
http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Macintosh
http://www.adobe.com/support/downloads/product.jsp?product=31&platform=Windows
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Error "The PageMaker document is damaged..." when 
you open a PageMaker document in InDesign CS2 on 
Windows Vista

Issue
When you attempt to open an Adobe PageMaker 7.x or 6.5 document in Adobe InDesign CS2 on Windows Vista, you 
receive the error message, "The PageMaker document is damaged and cannot be recovered."

Reason
Microsoft has changed the behavior of some of the APIs on Windows Vista, preventing InDesign from properly reading 
the PageMaker document information.

Solution
Do one of the following solutions:

Solution 1: Install InDesign CS3 or CS4.

• To purchase an upgrade from Adobe, visit the Adobe Store at http://store.adobe.com/store/, click Print Publishing, 
and choose either InDesign CS3 or Adobe Creative Suite 3 Premium or Standard.

• To locate an authorized reseller, visit the Adobe website at 
www.adobe.com/store/customerregistration/other_places.jhtml.

Solution 2: Open and save your PageMaker documents in InDesign CS2 or InDesign CS on either Windows XP or 
2000, and then open the newly updated documents in InDesign on Windows Vista.

Additional Information
InDesign CS2 was released before Windows Vista became publicly available and was not designed for or fully tested on 
this new operating system. For more information about InDesign on Windows Vista, see "How Adobe Products 
Support Windows Vista" at www.adobe.com/support/products/pdfs/adobe_products_and_windows_vista.pdf.

Error "The Package Operation Failed" | Return package 
for InDesign | InCopy CS5

Issue
When you choose Package > Return To InDesign in InCopy CS5 to create a return package, you receive the following 
error message: 

"The package operation failed."

The workflow started with an InDesign CS4 assignment.

http://store.adobe.com/store/
http://www.adobe.com/store/customerregistration/other_places.jhtml
http://www.adobe.com/support/products/pdfs/adobe_products_and_windows_vista.pdf
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Solution
Update to InCopy CS5 7.0.3 or later. To obtain the latest InCopy updates, choose Help > Updates in InCopy, or visit 
http://www.adobe.com/downloads/updates. Select InCopy for your platform and find the latest update for InCopy CS5.

 

Error "Critical Errors were found in Setup" when you 
install InDesign CS3

Issue
When you install Adobe InDesign CS3, you receive the error message, "Critical Errors were found in Setup."

Reason
A pre-release version of InDesign CS3 is currently, or was previously, installed on your computer.

Solution
Do one or more of the following solutions:

Solution 1: Remove previous versions of InDesign CS3.

1 Remove the application by starting the installer located in /Applications/Utilities/Adobe Installers (Mac OS) or 
Add/Remove Programs Control Panel (Windows).

2 Follow the on-screen instructions to remove InDesign CS3.

Solution 2: Run the Adobe CS5 Cleaner Tool before you install InDesign CS3.

The CS5 Cleaner Tool helps resolve installation problems for C5, CS4, and CS3 products. For information on 
downloading and running it, see Resolve installation problems with CS5 Cleaner Tool (cpsid_82947). Follow the 
onscreen instructions to remove InDesign CS3.

Additional Information
If the prerelease version of InDesign CS3 was not fully removed or is still installed, the retail version cannot install. 
Running the Adobe CS3Clean script removes the previous version and enables installation of the retail version.

http://www.adobe.com/downloads/updates
http://kb2.adobe.com/cps/829/cpsid_82947.html


90

Last updated 11/12/2015

Disable access to CS4 service extensions | System 
administrator
Adobe Creative Suite 4 offers a number of services that connect to the Internet to provide enhanced functionality. These 
services can also download updates automatically. In certain circumstances, system administrators want to disable 
these connections and updated downloads. The document lists the changes required in the registry (Windows XP, 
Vista) or preference files (Mac OS X) to disable these network activities. This document applies to the following 
Creative Suite 4 services:

• Kuler (Extensions > Kuler)

• Adobe ConnectNow (File > Share my Screen)

• Service Manager (Extensions > Connections)

• Search for Help (Search field in the app bar)

• Help > [Product Name] Help

Deactivate the Adobe Online Services and Service Update preferences at a 
system level
Set the following data values to deactivate the Adobe Online Services and Service Update preferences at a system level. 
When these connections are disabled at the system level, it overrides the users' ability to enable connections or updates 
through the user interface. When online access for Help search is disabled, this feature and the Help > [Product] Help 
command searches .html Help files on the local hard disk.

Windows XP, Vista, or Windows 7 32-bit systems
• HKEY_LOCAL_MACHINE\SOFTWARE\Adobe\ AdobeOnlineDefault; Controls online connections for Search 

for Help and Help > [Product Name] Help

• HKEY_LOCAL_MACHINE\SOFTWARE\Adobe\CSXSPreferences\ AdobeOnlineDefault; Controls online 
connections for the other services UpdatesAllowed; Controls download of updates to these service extensions

Windows XP, Vista, or Windows 7 64-bit systems
• HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Adobe\AdobeOnlineDefault; Controls online 

connections for Search for Help and Help > [Product Name] Help

• HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Adobe\CSXSPreferences\ AdobeOnlineDefault; 
Controls online connections for the other services UpdatesAllowed; Controls download of updates to these service 
extensions

Do the following:

1 Choose Start > Run and type regedit to open the registry editor.

2 Navigate to the locations listed above.

3 If the string value AdobeOnlineDefault does not exist, create one (right-click the container object, and choose New 
> String Value).

4 Double-click this string value and set its Value Data to "0" to disable it. Click OK.
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Mac OS X
On Mac OS, you can find these keys in a file in the following Property List (.plist) files:

• /Library/Preferences/com.adobe.AdobeOnlineHelp.plist AdobeOnlineDefault; controls online connects for Search 
for Help and Help > [Product Name] Help

• /Library/Preferences/com.adobe.CSXSPreferences.plist AdobeOnlineDefault; controls online connections for the 
other services UpdatesAllowed; controls download of updates to these service extensions

Do the following:

1 Open the Apple Property List Editor (supplied with the Apple SKD) or other property list editor application.

2 Open /Library/Preferences/com.adobe.CSXSPreferences.plist.

3 Select Root to see the subentries.

4 Change the value of the key AdobeOnlineDefault to "0" to disable it.

5 Change the value of the key UpdatesAllowed to "0" to disable it.

6 Open /Library/Preferences/com.adobe.AdobeOnlineHelp.plist.

7 Select Root to see the subentries.

8 Change the value of the key AdobeOnlineDefault to "0" to disable it.

9 Save the plist file.

10 Restart the Adobe application.

If any of these keys does not exist, then complete the following steps:

1 Select the Root object in the applicable plist file and click the triangle to display its contents.

2 Click the New Child button and name it "AdobeOnlineDefault" or "UpdatesAllowed" as appropriate.

3 For Class, select String.

4 Set the value to "0" to disable it.

5 Save the plist file.

6 Restart the Adobe application.

Sample plist files and registry keys
Attached below are sample plist files and registry keys that you can use as reference, or in place of manually performing 
the steps above. To add the plist files, navigate to the locations indicated in the steps above. Replace the files with those 
files supplied in the attached .zip file. To add the registry keys, double-click the registry files in the provided .zip file, 
authenticate with an administrative password, and click Yes to add the entries.

• PlistFiles.zip (Mac OS)

• RegEntries.zip (Windows)

Note: For information about disabling the CS3 or CS4 Adobe Update Manager (Help > Product Updates), see Disable 
Adobe Update Manager for CS3 or CS4 applications, for system administrators (kb408711).

Additional Information
• User Settings are controlled through the application Interface. For example, the Connections panel has the 

commands "Check for Updates," "Update Preferences" and "Offline Options" in its pop-up menu. These options 
don't appear if the system-level registry entries or plist keys have disabled the functions.

http://www.adobe.com/support/creativesuite/ts/documents/kb404813/PlistFiles.zip
http://www.adobe.com/support/creativesuite/ts/documents/kb404813/RegEntries.zip
http://kb2.adobe.com/cps/408/kb408711.html
http://kb2.adobe.com/cps/408/kb408711.html
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• If the Administrator disables AdobeOnlineDefault in the CSXS preferences, the Connections panel displays the 
following: "This feature is disabled. Please contact your internal IT for more information."

• If the User preference is set through the application interface, it affects the application immediately. If an 
Administrator changes it in the registry, it affects the application immediately. If an administrator changes it in a 
plist file, it doesn't have an affect until the application is relaunched.

• Setting only the UpdatesAllowed key doesn't restrict the services from accessing the Internet.

• These settings do not affect other online connections from features such as: 

• Resource Central

• Help > Online Registration

• Help > Product Updates

• Help > Adobe Product Improvement

 

More Help topics 
Disable CS Live internet access from CS5 applications for system administrators

Cannot open PDF file in Acrobat created from InDesign 
or Illustrator (Mac, InDesign and Illustrator)

Issue
When trying to open a PDF generated from InDesign or Illustrator, Acrobat displays the following error message:

"Acrobat could not open '[name of file]' because it is either not a supported file type or because the file has been 
damaged (for example, it was sent as an email attachment and wasn't correctly decoded).

To create an Adobe PDF document, go to the source application. Then print the document to Adobe PDF."

Using Apple Preview, the error is, "Couldn't open the file. It may be corrupt or a file format that Preview doesn't 
recognize."

http://kb2.adobe.com/cps/846/cpsid_84665.html
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Reason
The file was created by selecting the option "Save as PDF" from the Mac OS Print dialog.

This workflow is not supported.

Solution

Solution 1:Use the Export PDF (InDesign) or Save As > Adobe PDF (Illustrator) methods
InDesign

1 Choose File > Export and select Adobe PDF as the Format.

2 Select the desired PDF options.

3 Click Export.

Illustrator

1 Choose File Save and select Adobe PDF as the Format.

2 Select the desired PDF options.

3 Click Save PDF.

Solution 2: Print to Adobe PDF
InDesign and Illustrator

1 Choose File > Print.

2 Select Adobe PDF [version] from the Printer list.

3 Select the desired printer options.

4 Click Print.

 

Bleed settings are incorrect when you export to PDF ( 
InDesign CS3, CS4)
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Issue
When you export an InDesign document with bleed settings as a spread to PDF, the bleed appears incorrectly in the 
PDF.

For example, the PDF does not show the outside bleed of a spread, or the last page has a bleed incorrectly added.

Reason
The Use Document Bleed And Slug Settings option in the InDesign PDF Export settings is unreliable when you export 
as Reader Spreads.

Solution

Solution 1: Specify the Bleed and Slug settings manually
1 In the PDF Export dialog box, go to Marks And Bleeds.

2 In the Bleeds And Slug section, deselect Use Document Bleed And Slug Settings.

3 Enter values for Bleed and Slug.

4 Specify other export settings as desired.

5 Click Export.

Solution 2: Export to PDF with single pages
1 In the PDF Export dialog box, go to General.

2 In the Pages section, deselect Spreads.

3 Finish the other export settings as desired.

4 Click Export.

 

Background information on InDesign CS4 Flash 
publishing functionality (SWF/XFL)
What's Covered

• Overview 

• Flattening and Interactivity 

• Comparison of Flash's Imaging Model and the Adobe Imaging Model 

• Representing AIM in Flash 

• Paths 

• Raster Images in XFL Export 

• Raster Images in SWF Export 

• Color Conversion 

http://helpx.adobe.com/indesign/kb/#main_Overview
http://helpx.adobe.com/indesign/kb/#main_Flattening
http://helpx.adobe.com/indesign/kb/#main_Comparison
http://helpx.adobe.com/indesign/kb/#main_Representing
http://helpx.adobe.com/indesign/kb/#main_Paths
http://helpx.adobe.com/indesign/kb/#main_Raster
http://helpx.adobe.com/indesign/kb/#main_RasterSWF
http://helpx.adobe.com/indesign/kb/#main_Color
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• Strokes and Fills 

• Placed Vector Art 

• Text 

• Text Representation in XFL 

• Text Representation in SWF 

• Buttons and Interactivity 

• Movies and Sounds 

• XFL Packaging 

• Spreads as Symbols in XFL 

• Representing Entire Spread as Raster 

Overview

Overview

InDesign CS4 supports two Flash publishing workflows; one, a direct-to-SWF export, the other, an XFL export for 
transitioning InDesign authored content into Flash CS4 for further authoring. Both export formats aim to represent 
static InDesign content as accurately as possible, with emphasis placed on preserving the visual appearance of the 
source document. Because of the differences between Flash's imaging model and the Adobe Imaging Model (AIM) 
that's the foundation of PostScript and PDF, there are challenges in how to represent particular kinds of content when 
converting from one representation to the other. When facing these challenges, its typical to choose the option that 
gives the best visual fidelity, even if that means the structure of the underlying content is destroyed. For instance, text 
may in some cases be converting to outlines or rasterized, and dashed lines, which have no native Flash representation, 
may be converted to compound paths that are then filled. One important difference between the two formats is that 
SWF is a final form content, similar is some respects to PDF, that is not intended for further editing in a downstream 
tool, whereas XFL is, by its very nature, an editable format. This has two main consequences. First, it means that 
interactivity for SWF must be added in InDesign, whereas with XFL it will likely be added within Flash. Second, it is 
much less important to attempt to preserve the original structure of the document for SWF. This led two key decisions 
about how InDesign CS4 exports the two formats. First, when exporting to XFL,InDesign CS4 does not include 
buttons, page transitions, or other interactivity features, or movies and sounds. The assumption behind this is that 
customers will most likely want to add interactivity like this in the Flash environment given the much better toolset 
available there - InDesign's interactivity tools are limited to simple buttons, page transitions and placed sounds and 
movies, whereas Flash offers ActionScript scripting, an extensive set of components, and more, on top of what InDesign 
offers. Support for such features in XFL export may come in future versions of the software. Second, InDesign CS4 
flattens all transparency when exporting to SWF. The assumption is that the SWF content will not have later edits that 
would benefit from the preservation of transparency. Like with PDF 1.3, PostScript/print, and SVG exports, flattening 
only occurs on spreads that have transparency, and makes use of the existing Flattener Presets to control the flattening 
options.

Flattening and Interactivity

Flattening and Interactivity

Note that the use of flattening with interactivity may in some cases cause interactivity to drop out when exporting to 
SWF. The flattener works by dividing content it sees into two categories: bits that interact with transparency and those 
that don't. Bits that don't interact are passed through unchanged. However, bits that do interact are typically converted 
into a much different form to preserve the visual appearance of the transparency (e.g., rasterized, broken into distinct 
opaque regions). When this occurs with an interactive item, the interactivity will lost. This is unavoidable and already 
a fact of life for InDesign users publishing to PDF version 1.3.

http://helpx.adobe.com/indesign/kb/#main_Strokes
http://helpx.adobe.com/indesign/kb/#main_Placed
http://helpx.adobe.com/indesign/kb/#main_Text
http://helpx.adobe.com/indesign/kb/#main_TextXFL
http://helpx.adobe.com/indesign/kb/#main_TextSWF
http://helpx.adobe.com/indesign/kb/#main_Buttons
http://helpx.adobe.com/indesign/kb/#main_MoviesSounds
http://helpx.adobe.com/indesign/kb/#main_XFLPackaging
http://helpx.adobe.com/indesign/kb/#main_Spreads
http://helpx.adobe.com/indesign/kb/#main_PagesAsRaster
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Comparison of Flash's Imaging Model and the Adobe Imaging Model

Comparison of Flash's Imaging Model and the Adobe Imaging Model

Flash's imaging model is superficially similar to the Adobe Imaging Model (AIM): Both are vector-based and support 
the notion of paths that are filled/stroked with various kinds of paint. Both support affine transformations 
(transformations which, like scaling, translation, and rotation, preserve the parallel-ness of an objects lines). Both 
support raster images, including alpha channel. Both support vector text. Both support simple opacity and the notion 
of blend modes that dictate how content is composited with content it overlaps. The takeaway is that experience with 
AIM representation of things will largely transfer to Flash. However, the two imaging models differ in a number of 
important ways. The complete list of differences is too large to include here, but some of the more important differences 
are:

• Flash uses device RGB color only. No other color spaces are supported and all color is uncalibrated.

• Flash uses quadratic curves, whereas AIM uses cubics. This requires that an authoring tool approximate its native 
cubic curves with quadratic curves.

• Flash paths implicitly use a non-zero winding rule. AIM paths may use either non-zero or even-odd winding.

• Flash supports a limited set of paint types: solid color, gradients, and raster paint are supported; more complex 
paints, such as general smooth shades, and patterns, are not.

• Flash gradients allow a smaller number of stops than their AIM equivalents.

• Flash supports limited clipping and masking. Flash allows objects in its display list to be clipped and/or masked by 
other objects in the display list, but this is a simple one-to-one relationship and limited compared to the graphic state 
based clipping and masking supported by AIM.

• Flash does not natively support dashed or dotted lines. These simulated in Flash by drawing each dash as an 
individual line segment.

• Flash supports a limited subset of the blending modes available in AIM.

• Flash does not support transparency groups.

Representing AIM in Flash

Representing AIM in Flash

The general rule InDesign CS4 uses for representing AIM constructs in Flash is to attempt to use native Flash 
constructs wherever possible, and to fall back on a Flash construct that maintains the visual appearance when this 
cannot be done. This is conceptually similar to flattening. In the below content, if no explicit reference is made to a 
particular format, the assumption should be that the item refers to both SWF and XFL.

Paths

Paths

Paths are implicitly simplified so that they can be represented using either winding rule. Paths are implicitly intersected 
with the current clipping path. For instance, if a rectangular path is filled with solid color and the current clip is an 
ellipse that fits exactly within the rectangle, the result will be a fill of the elliptical path. We will not represent this as it 
would typically be represented in PostScript, PDF or SVG, as a clip on the elliptical path followed by a fill on the 
rectangular path. Dashed and dotted paths are implicitly converted to fills. The resulting path is compound and will be 
filled with a single call and not as a separate fill for each dash. Raster Images Raster images in the Flash imaging model 
fall into two main categories: lossy (such as JPEG compressed) or lossless (such as Zip or Flate compressed). In addition 
to these main categories, indexed can be considered a subcategory of lossless. This distinction is muddied somewhat 
when authoring in Flash, which allows a number of raster formats to be imported to the library. Internally, however, 
Flash will ultimately treat the images as falling into one of the two main categories.
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Raster Images in XFL Export

Raster Images in XFL Export

InDesign exports a raster image to XFL as a path with a BitmapFill applied. This allows us to clip the image to the path 
boundaries. This differs from what happens when a raster image is placed on the stage while authoring in Flash. In that 
case, you get a Bitmap object. It is necessary to select the placed image, context click on it, and choose Break apart... to 
convert a Bitmap object to a path with a BitmapFill. We use BitmapFill instead of Bitmap objects in order to ensure 
clipping works in all cases of images transitioning from InDesign CS4 to XFL. We use this heuristic when determining 
what format to use when encoding a raster image as part of exporting to XFL: * If the image source is a JPEG that does 
not require any modifications, such as color conversion or re-sampling, it is used as is. Note that this implies that the 
image has no alpha channel. * For all other cases, we use PNG. Note that these heuristics are also used when exporting 
to SWF, with a handful of exceptions (see below).

Raster Images in SWF Export

Raster Images in SWF Export

The raster heuristics used when exporting to SWF are similar to that for XFL, except that it must choose between full 
color lossless, indexed lossless and lossy (JPEG) encoding. When exporting to SWF, InDesign CS4 uses the following 
heuristic to determine whether lossless or lossy encoding is used: Lossless encoding is used if one or more of the 
following is true:

• The raster is a 1-bit bitmap

• The raster's width times its height is less than 4096 (this matches SWF publishing from Flash)

• The raster has a chroma key*

• The raster is not considered smooth

 Alpha channel does not automatically require lossless compression as it does for XFL. Flash Player supports the notion 
of JPEG + alpha, in which the color pixels are JPEG compressed and the alpha channel is stored as a separate, Flate 
compressed block. If an image with alpha can be represented as JPEG, aside from its alpha channel, it will be stored in 
the SWF as JPEG + alpha. If the raster uses 256 or fewer colors, it is implicitly converted to indexed. In all other cases, 
lossy compression is chosen. *Chroma key is a way to selectively mask pixels based on a particular pixel value (compare 
to the transparent pixel in GIF). These are not expected in an InDesign CS4 workflow where we'll be rasterizing the 
placed vector content that would be the only way to get such content into ID.

Color Conversion

Color Conversion

All content is converted to sRGB. This includes spot colors, DeviceN and NChannel color. I need to go back and 
determine exactly how the conversions are done. I believe that this is done using Newell blending for separation and 
DeviceN/NChannel color (rather than OPP) and that it is not a preserve numbers conversion for RGB content but I'm 
not positive about any of that. [Not sure if this is important for the sake of this document]

Strokes and Fills

Strokes and Fills

Fills using solid color and raster images, both rendered without an alpha server, are preserved as is (aside from 
conversion to RGB). Other types of fill, such as gradients, will be rasterized. All content with an alpha server will be 
rasterized, effectively merging the alpha into the rasterized contents. Simple opacity will be preserved. Blending modes 
common to AIM and Flash are currently preserved in XFL export, assuming that the flattener is not invoked. However, 
there are outstanding issues around the use of transparency groups with blend modes that may result in incorrect 



98

Last updated 11/12/2015

appearance when imported into Flash Authoring.[Did these issues get resolved? Do they need to be noted here?] 
Strokes with non-solid color, such as gradients, are converted to fills. Note that gap color handling naturally follows 
these same rules. In InDesign, gap color is rendered by stroking the path with a solid stroke prior to stroking with the 
dashed (or other non-solid) stroke. Each follows the rules abovelikewise for striped and other stroke styles (e.g., slanted, 
diamond, wavy, etc.). These are rendered as multiple stroked paths, each following the above rules.

Placed Vector Art

Placed Vector Art

Placed PDF, EPS, WMF, EMF, INDD, and Vector PICT graphics will be rasterized. This will occur for both SWF and 
XFL output. This is currently done by rasterizing the content in device space that is, we determine the bounds of the 
content in device space, and then bake any transforms on the content, rotation or skew, for instance, into the resulting 
raster. Rasterized content will follow the resolution specified in the export settings.

Text

Text

Three export options are provided to control how native text is represented in the export:

• InDesign Text to Flash Text: Text will be represented as DOMTextObject when exporting to XFL so that it can be 
edited in Flash, or represented by DefineText tags when exporting directly to SWF.

• InDesign Text to Vector Paths: Text will be represented as path shape in XFL, or using DefineShape tags in SWF.

• InDesign Text to Raster Image: Text will be represented as raster images in XFL, or using Image tags in SWF.

 When exporting XFL or SWF with the InDesign CS4 Text to Flash Text option enabled, all text in will be represented 
as static text objectsdynamic text is not supported. All fonts are embeddeddevice fonts are not supported.

Text Representation in XFL

Text Representation in XFL

Since XFL is XML-based format, raw text has to be represented as Unicode which involves the process of converting 
glyphID values to the Unicode values. InDesign CS4 leverages the code used for PDF export to construct the Unicode 
table, and then extracts the Unicode value from that table to make the XML representation. Ideally each InDesign CS4 
text run would be represented as a DOMTextObject in XFL, however, in some cases, the original text run must be 
subdivided so that each subrun can be represented uniquely. For example, if composite font has applied to a text run, 
we have to do this subdivision since XFL face attribute tag does not have the notation of composite font. Another case 
is that if text run has been applied tracking or kerning attribute, then we may have to subdivide the text run too if the 
letter space of each characters in the original text run is different. Since XFL does not current support all text attributes 
that can be set in InDesign CS4, some text has to be converted to vector paths or rasterized to preserve the visual fidelity 
of the text. Below are some of the instances where this will occur, even when the option for InDesign Text to Flash Text 
is selected Cases in which the text will be rasterized:

• Text has gradient applied

 Cases in which the text will be converted to vector paths:

• Ruby text

• Kenten text

• Warichu

• Text with Small Cap applied

• Text on the path

• Text has stroke applied (both fill and stroke will be vectorized)
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• Text has Gaiji/Sing font applied

• GlyphID and Unicode values do not match

• Many glyphs map to the same Unicode value

• Glyph cannot be represented by Unicode value

Text Representation in SWF

Text Representation in SWF

Although SWF has the notion of static text, dynamic text and an input text, in InDesign CS4, our text in SWF will 
always be represented as static text. In addition, we decide to always embed fonts in SWF which means that character 
shapes will always be in the SWF file, so it's not necessary to convert glyphID to Unicode for rendering text in SWF 
because DefineText tag has reference to the glyphID in the DefineFont tag. Therefore the visual look of SWF should be 
the same across platforms.

Buttons and Interactivity

Buttons and Interactivity

As noted above, buttons and itneractivity features are not preserved in XFL exported from InDesign CS4. For that 
workflow, use Adobe Flash CS4 to add buttons and interactivity to your XFL project. SWF export from InDesign CS4 
supports a subset of buttons actions, page transitions, and other interactivity features. Button actions include a subset 
of those supported by PDF export. Some, like 'Quit,' 'Close,' and 'Open file' have no real meaning in Flash, and thus are 
not supported when exporting to SWF. See note above for issues with transparency flattening and interactivity.

 

Movies and Sounds

Movies and Sounds

Currently, movies and sounds are not supported in either XFL or SWF export from InDesign CS4. For this workflow, 
export to XFL and use Flash CS4 to add movies and sounds to the project.

 

XFL Packaging

XFL Packaging

XFL is packaged as a single file that is ZIP compressed and contains an XML-based manifest file and a LIBRARY folder 
that contains XML-based representation of each page (or spread, if Spreads are enabled in the Export XFL dialog box) 
and all images produced as part of the export.

Spreads as Symbols in XFL

Spreads as Symbols in XFL

When exporting to XFL, each page (or spread, if Spreads are enabled in the Export XFL dialog box) in the source 
document are mapped to a keyframe in Flash. Also, the contents for each page or spread are wrapped in a symbol that 
is then placed on its corresponding frame.

Representing Pages as Raster

Representing Pages as Raster

To absolutely guarantee visual fidelity, InDesign CS4 offers an export option to Rasterize Pages. The images this 
generates follow the resolution specified in the export settings. When exporting with this option to SWF, buttons and 
hyperlinks are not preserved. However, page transitions, including Page Curls, are preserved.
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Applied clipping paths on placed Photoshop EPS files 
are not retained after relinking/updating (InDesign CS4)

Issue
After you place a Photoshop EPS into your InDesign document, and apply a Photoshop path in the Clipping Path 
Options dialog box, manually relinking that image to the same source, or another copy, or using the Edit Original 
command and modifying the image, causes the clipping path's masking to fail to appear in the page display. Other file 
formats which are treated as Photoshop EPS files, such as certain EPS based OPI proxy files, will demonstrate the same 
issue.

Reason
Adobe is currently investigating this issue, and hope to address it in a future release.

Solution: Install the InDesign CS4 6.0.4 update
Download the update from the Adobe website at http://www.adobe.com/downloads/updates.

or

Update through the Adobe Update Manager

In Adobe InDesign CS4 do the following: 

1 Help > Updates

2 Select Show Details in the first Adobe Updater window

3 Select Adobe InDesign CS4 6.0.4 update from the list of available updates 

4 Click Download and Install Updates

Anchored objects lose corner options | InDesign CS5

Issue
 When you open documents authored in CS4 or earlier in InDesign CS5, corner options applied to anchored rectangles 
are lost on all but the upper-left corner. 
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Solution
Apply the corner effect to all corners.

1 Select the anchored object.

2 Choose Object > Corner Options.

3 Click the "Make all settings the same" icon (chain links).

4 Click OK.

Additional information
 InDesign CS5 introduced the ability to set different corner effects for each corner of a rectangle. For this specific case, 
the conversion process doesn't populate all corners with the value from the original object. Adobe hopes to address this 
issue in a future version of InDesign.
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