Erwecke einen mit Adobe Illustrator gezeichneten Stadtplan zum Leben, indem du in Adobe After Effects Pfade animierst und Icons einblenden lässt.
Ein Mann berührt einen Computer-Bildschirm mit einem Stadtplan um die New Yorker Börse herum.

Was du benötigst

Die Beispieldatei enthält Adobe Stock-Elemente, mit denen du die Schritte dieses Tutorials nachvollziehen kannst. Wenn du die Beispieldatei anderweitig verwenden möchtest, kannst du sie bei Adobe Stock lizenzieren. In der ReadMe-Datei in diesem Ordner findest du die Bedingungen für die Verwendung dieser Beispieldateien.

Auf einem animierten Stadtplan lässt sich eine Route von A nach B besser verfolgen. Dieser Stadtplan wurde in Illustrator erstellt. In After Effects wurde anschließend eine Taxiroute eingezeichnet und animiert. Du kannst entweder mit diesem Stadtplan von Lower Manhattan experimentieren oder ein eigenes Karten-Design verwenden. Das Illustrator-Dokument sollte idealerweise doppelt so groß sein wie die After Effects-Komposition. 

Den Pfad animieren.

Die Linie, die die zu animierende Route darstellt, muss im Illustrator-Dokument auf einer separaten Ebene gespeichert sein. Bei einer durchgezogenen Linie kannst du mit dem nächsten Abschnitt fortfahren. Wenn die Linie jedoch ein Muster aufweist, z. B. ein Schachbrett-Muster wie in unserem Beispieldokument, musst du die Ebene erst kopieren und als Maske verwenden. Wähle die Ebene mit der gemusterten Linie aus. Wähle im Bedienfeldmenü „Ebenen“ den Befehl zum Duplizieren dieser Ebene. Doppelklicke auf die Kopie. Füge dem Namen die Endung „mask“ (Maske) hinzu. Drücke Umschalt+F6, um das Bedienfeld „Aussehen“ zu öffnen. Wähle die duplizierte Linie in der Grafik aus. Lösche den Musterstil, indem du unten im Bedienfeld auf „Aussehen löschen“ klickst. Weise der Linie stattdessen (vorübergehend) eine kräftige Farbe zu. Wähle für die Größe (Kontur) am besten mehr als 5 Punkte, damit sie deutlich zu sehen ist. Speichere die Datei – lasse sie jedoch geöffnet –, und wechsle zu After Effects. 

Der Stadtplan ist in Adobe Illustrator geöffnet. Unter „Ebenen“ wird die Route auf einer eigenen Ebene angezeigt.

Wähle „Datei > Importieren > Datei“. Navigiere zur Illustrator-Datei. Wähle im Exportdialog „Importieren als > Komposition – Ebenengrößen beibehalten“. Mache einen Rechtsklick bzw. Ctrl-Klick auf die Ebene mit der Linienmaske. Wähle „Erstellen > Formen aus Vektorebene erstellen“. Blende auf der Zeitleiste alle Optionen für die neu hinzugefügte Ebene ein. Der Name dieser neuen Ebene enthält das Wort „Konturen“. Klicke neben „Inhalt“ auf „Hinzufügen“. Wähle „Pfade trimmen“ aus. Setze den Abspielkopf an den Anfang der Komposition. Blende die Optionen für „Pfade trimmen 1“ ein. Setze einen Keyframe für „Ende“ mit dem Wert „0 %“. Verschiebe jetzt den Abspielkopf an das Ende der Komposition. Setze einen Keyframe für „Ende“ mit „100 %“. Lösche die ursprüngliche Ebene mit der Linienmaske. Ändere auf der Linienebene die Einstellung in der Spalte „Bewegte Maske“ von „Ohne“ in „Alpha-Maske ‚[Ebene mit Konturen]‘“. (Klicke auf „Schalter/Modi“, falls die Optionen für bewegte Masken nicht angezeigt werden.) Die zuvor erstellte Linie mit kräftiger Farbe wird durch die gemusterte Linie ersetzt. 

Die Stadtplan-Datei wird in After Effects importiert. „Pfade trimmen 1“ ist ausgewählt. Ein Keyframe für „Ende“ wird gesetzt.

Die Taxifahrt simulieren.

Wähle zum Animieren eines Objekts (in unserem Beispiel ein Taxi) die entsprechende Ebene aus und dann im Hauptmenü „Ebene > Transformieren > Automatische Ausrichtung“. Wähle im Dialogfeld „Automatische Ausrichtung“ die Option „Ausrichtung entlang Pfad“. Klicke auf „OK“. Wechsle zu Illustrator. Markiere die Ebene mit der gemusterten Linie. Wähle „Bearbeiten > Kopieren“. Kehre zurück zu After Effects. Setze den Abspielkopf an den Anfang der Komposition. Wähle die Ebene mit dem Taxi aus. Drücke die P-Taste, um den Parameter „Position“ einzublenden. Wähle den Parameter „Position“ aus und anschließend „Bearbeiten > Einfügen“, um die Pfadpunkte als Keyframes einzufügen. Ziehe bei gedrückter Alt- bzw. Wahltaste den letzten Keyframe der Serie an das Ende der Komposition – alle Keyframes müssen dabei ausgewählt sein (blau). Die relativen Positionen bleiben erhalten, sodass sich das Taxi in derselben Geschwindigkeit wie die gemusterte Linie bewegt. Wähle jetzt im Kompositionsfenster einen Punkt auf der Kontur des eingefügten Pfads aus. Positioniere ihn an der richtigen Stelle auf dem Stadtplan. Möglicherweise musst du hierzu den Zoom-Faktor erhöhen. Spiele die Komposition ab. Das Taxi bewegt sich entlang des definierten Pfads. Hinter ihm wird die gemusterte Linie eingeblendet. Drücke ggf. bei aktivierter Taxi-Ebene die R-Taste, und ändere den Wert für „Drehung“, damit das Fahrzeug nach vorne gerichtet ist. 

Ein Taxi ist zur Animation ausgewählt. „Ausrichtung entlang Pfad“ ist aktiviert. Der Pfad aus Illustrator wird eingefügt.

Sehenswürdigkeiten hervorheben.

Als Nächstes sollen die Namen von Sehenswürdigkeiten eingeblendet werden, wenn das Taxi daran vorbeifährt. Blende die Transformieren-Optionen für jede Ebene mit dem Namen einer Sehenswürdigkeit ein. Setze für den Parameter „Skalierung“ Keyframes für eine kurze Zeitspanne, z. B. 12 Frames. Wenn du außerdem eine Drehung wünscht, bewege zunächst den Ankerpunkt von der jeweiligen Form weg. Wenn du nun für „Drehung“ Keyframes festlegst, wird der Name der jeweiligen Sehenswürdigkeit mit einer Schwenkbewegung eingeblendet, anstatt sich lediglich an derselben Stelle zu drehen. Trimme den linken Rand der Namens-Ebene auf der Zeitleiste. Positioniere ihn, sodass der Name der Sehenswürdigkeit genau dann eingeblendet wird, wenn sich das Taxi nähert. Wähle als Letztes alle Ebenen aus. Klicke, falls erforderlich, auf „Schalter/Modi“. Klicke auf der Zeitleiste für eine beliebige Ebene auf „Optimieren“ (neben „Verbergen“), um diesen Modus zu aktivieren.

Keyframes für 12 Frames und für „Drehung“ bewirken, dass der Name der Sehenswürdigkeit mit Schwenkbewegung eingeblendet wird.

Die Animation filmen.

Erstelle ein Video, in dem der Stadtplan herangezoomt und das Taxi (bzw. das von dir verwendete Objekt) verfolgt wird. Erstelle eine neue Komposition, indem du im Projektfenster die aktuelle Komposition auf „Eine neue Komposition erstellen“ ziehst. Aktiviere den Modus „Optimieren“ für das neue Element. Setze Keyframes für „Position“ und „Skalierung“, um einen Kamera-Zoom auf den animierten Stadtplan sowie die Verfolgung des Fahrzeugs bzw. der Route zu simulieren. Wähle die Keyframes aus. Drücke die F9-Taste, um für eine nahtlose Animation die Option „Easy Ease“ anzuwenden.  

Mit Keyframes für „Position“ und „Skalierung“ werden ein Kamera-Zoom und die Verfolgung des Taxis simuliert.

Experimentiere mit dieser Technik. Wähle für das Taxi eine andere Route. Oder füge neue Sehenswürdigkeiten hinzu, um deinen animierten Stadtplan aus der Vogelperspektive auszugestalten. 

Bei Adobe Stock stehen mehr als 100 Millionen hochwertige, lizenzfreie Fotos, Grafiken, Videos und Templates zu deiner Verfügung. Teste Adobe Stock. Zehn Bilder sind für dich kostenlos.

09/27/2021
War diese Seite hilfreich?