Hotfixes für Adobe Experience Manager 6.0 vor dem Service Pack 3

Diese Seite ist die alte Version der empfohlenen Hotfixes-Seite, vor der Veröffentlichung von AEM 6.0 Service Pack 3.

Sie enthält die Liste von empfohlenen Hotfixes, die Sie auf AEM 6.0 installieren, *sofern Sie das SP3 noch nicht aufgespielt haben.*

Adobe empfiehlt die Installation von Service Pack 3, bitte besuchen Sie diese Seite, auf der Sie Installationen für Hotfixes finden, die für das SP3 gedacht sind.

Einführung

Die folgenden Hotfixes sind derzeit für Adobe Experience Manager 6.0 verfügbar, denken Sie daran, die empfohlenen Hotfixes (fettgedruckt) zu installieren, wenn sie Ihnen noch fehlen.

Hinweis:

Sie finden alle markierten Hotfixes (fett mit einem *) im öffentlichen Abschnitt der Paketfreigabe. Sie können über einen registrierten Benutzer wie hier beschrieben auf die Paketfreigabe zugreifen.

  • Fordern Sie die anderen Hotfixes über ein AEM-Support-Ticket an.
  • Die meisten Hotfixe sind eigenständig, sofern es nicht angegeben ist, und sie können in beliebiger Reihenfolge installiert werden. Über das „Abhängigkeiten“-Element auf der „Details“-Registerkarte in der Paketfreigabe kann eine Selbstverifizierung durchgeführt werden.  
  • Die Versionshinweise der öffentlichen Hotfixes sind derzeit nur per Antrag über das AEM Support Portal verfügbar. Package Share wird sie in Kürze direkt führen.

Adobe Experience Manager 6,0 Service Pack 2 wurde am 3. Februar 2015 veröffentlicht

Hinweis:

Installieren Sie alle Hotfixes, die Sie hier finden, nachdem Sie das Service Pack 2 installiert haben.

Die Installation des aktuellsten Service Packs ist empfohlen, da er Fehlerbehebungen und Verbesserungen in Sachen Sicherheit, Leistung, Stabilität und wesentlicher Kundenerfahrung enthält, die seit der allgemeinen Verfügbarkeit des Adobe Experience Manager 6.0 freigegeben wurden. 

Der direkte Link für das neueste Service Pack (SP 2) auf der Paketfreigabe ist https://www.adobeaemcloud.com/content/marketplace/marketplaceProxy.html?packagePath=/content/companies/public/adobe/packages/cq600/servicepack/AEM-6.0-Service-Pack-2.

Hier finden Sie weitere Informationen: http://docs.adobe.com/docs/en/aem/6-0/release-notes-sp2.html.

Core

Sicherheitslücken

Die folgenden Hotfixes beheben mehrere kritische Schwachstellen. Adobe empfiehlt dringend, dass Sie dieses Sicherheitsupdate sofort auf allen Adobe Experience Manager 6.0 mit SP2-Instanzen installieren.

Zum Schutz unserer Kunden gibt Adobe keine Einzelheiten zu Sicherheitslücken bekannt. 

Datum

Name

Korrekturen

22. April 2015.

Der Security-Fix-Container für AEM6 SP2 enthält auch Lösungen für mehr Leistung und Stabilität aus den Hotfixes 5918 und 6109

Hinweis: Wenn Sie Formulare von AEM verwenden, müssen Sie das aktuellste Erweiterungspaket für Formulare neu installieren, nachdem Sie den Hotfix aufgespielt haben.

22. Mai 2015

Webday-Sicherungs-Lösung

4. Juni 2015

Sicherheitslücke bei Apache Sling Servlets Post 2.3.6

Oak

Die aktuell empfohlene Oak-Version ist 1.0.23.

Datum

Name

Korrekturen

10. November 2015

Siehe Versionshinweise

Herunterladen

Das Oak-Run-Werkzeug ist in der Maven-Zentral-Repository erhältlich. Nutzen Sie die gleiche Oak-Run-Version wie bei der Verwendung des Oak-Core-Bundles.

Das CRX2-Oak-Repository-Migrations-Werkzeug ist erhältlich unter http://docs.adobe.com/content/docs/en/aem/6-0/deploy/upgrade.html#Migrating%20the%20repository%20to%20OAK

Hinweis:

Um unser aktuelles Oak-Repository am effektivsten zu nutzen, lesen Sie die Oak-Sektion auf unserer 6.0 Leistungsoptimierungs-Seite aufmerksam durch, die die neuesten Tipps über Index-Optimierung und effektive Repository-Kompaktierung enthält.

Leistung

Installieren Sie das erste Hotfix 6167, das nachfolgend aufgelistet wird, da es einige Verbesserungen der Leistung bietet.

Datum

Name

Beschreibung der Bugfixes

10. Juni 2015

Leistungssteigerung im Tag-Management.  Das Hotfix enthält eine Systemvariable, cqTaggingLikeEnabled.  Details siehe Tags verwalten: Tag-Abfrage-Probleme.

27. August 2015

Während dem Öffnen einer Seite zeigt Google Chrome die Fehlermeldung "synchrone Ajax-Abfragen sollten vermieden werden, insbesondere beim Laden der Seite". Sie finden weitere Informationen unter Liesmich.

Hinweis: Wenn Sie AEM-Formulare verwenden, installieren Sie das neueste AEM-Formulare-Add-On-Paket. Wenden Sie sich an den Adobe-Support, um das neueste Paket zu erhalten.

18. September 2015.

Versionen im Hintergrund-Thread bereinigen.

Arbeitsablauf

Datum

Name

Beschreibung der Bugfixes

6. August

Verschiedene Bugfixes für Workflow-Engine

Replikation

Datum

Name

Beschreibung der Bugfixes

21. August

Batch-Replikationsregression

Diverses

Datum

Name

Korrekturen

31. August

Hotfix 7394

Fehlerbehebung SLING-4635 - Topologiebezogene Jobs sollten nicht eingeplant werden, wenn die Topologie unklar/nicht verfügbar ist

8. August 2014

FeaturePack 4137

S3 Datastore Connector auf AEM 6.0 OAK.

Version 1.8 verfügbar seit dem 10. Juli 2015.

17. Februar 2015

Hotfix 5916

Fehlerbehebung SLING-4307 - Vermeidet das Caching von JCR-Eigenschaftswerten, wenn die TarMK-Online-Verdichtung aktiviert ist, abhängig vom Hotfix 5918

Sites

Bearbeitung/Benutzeroberfläche

Das Touch-Benutzeroberflächen-Verbesserungspaket ist in SP2 enthalten.

Lesen Sie sorgfältig unsere Empfehlungen und die besten Vorgehensweisen für die Benutzeroberfläche in Adobe Experience Manager 6.0 unter http://docs.adobe.com/docs/en/aem/6-0/deploy/best-practices/ui-recommendations.html.

Sie finden Versionshinweise zum oben genannten Update-Paket, sowie Touch-optimierte spezifische Fehlerkorrekturen in unseren Service Packs, auf derselben Seite in Abschnitt Touch-optimierte Benutzeroberflächen-Verbesserungen.

MSM

Keine empfohlenen Hotfixes bisher auf SP2.

Entwicklung

Datum

Name

Beschreibung des Pakets.

5. Juni 2015.

Sightly FP 1.1 - AEM 6.1 Sightly Skript-Engine für AEM 6.0.

Elemente

Dynamische Medien

Datum

Name

Korrekturen

4. Juni 2015

Sicherheit, Stabilität, wichtige Fehlerkorrekturen und Verbesserungen des reaktionsfähigen Designs und Video-Workflow für AEM 6.0 dynamischer Medien-Kunde. Anforderungen: AEM 6.0 und Service Pack 2

Communities

Datum

Name

Korrekturen

6. November 2014

Dieses Fehlerbehebungspaket enthält den neuesten Satz Fixes für Version 6.0 von AEM Social Communities. Für Details zur Veröffentlichung sehen Sie sich die 6.0 Dokumentation an.

Formulare

Adaptive Formulare

Datum

Name

Korrekturen

3. September 2015

  • Die Daten in der Dropdownliste werden beim Hinzufügen einer neuen zweiten Zeile neu angeordnet. (Ref# CQ-52098)
  • Zusammengeführte Daten für ein wiederholbares Fenster sind nicht für die Initialisierung von Skripten verfügbar. (Ref# CQ-52054)
  • Die Skriptausführung beim Hinzufügen oder Entfernen von Instanzen eines wiederholbaren Panel oder einer Zeile wurde optimiert. (Ref# CQ-52057)
  • Post-Aufruf an guideContainer.analyticsconfigparser.json beim Rendern eines adaptiven Formulars, auch wenn die Analyse nicht aktiviert ist, wurde optimiert. (Ref# CQ-51164)
  • Post-Aufruf an guideContainer.fd.tempstorageprovider.jsp beim Rendern eines adaptiven Formulars, auch wenn die Daten nicht eingegeben werden, wird optimiert. (Ref# CQ-51169)

24. Juli 2015

HTML5-Formulare

  • Seiten in einem bestimmten Dokument werden nicht gerendert. (Ref# CQ-49461)
  • Die Eigenschaften prevText und newText funktionieren nicht ordnungsgemäß. (Ref# CQ-49382)

Adaptive Formulare

  • Die Lokalisierung der aus mehreren Werten bestehenden benutzerdefinierten Dialogkomponenten funktioniert nicht. (Ref# CQ-47890)
  • Dropdown-Komponentenliste aus der Adaptive-Formulargruppe wird im Vorschaumodus nicht ausgefüllt. (Ref# CQ-46318)

13. März 2015

  • Wörterbucheinträge werden für benutzerdefinierte Dialogelement nicht erstellt. (Ref# LC-3913647)
  • Validierungsfehlermeldungen werden für von Benutzern hinzugefügte Sprachen nicht übersetzt (Ref# LC-3913524)
  • Wenn das adaptive Formular im Internet Explorer 9 Browser gerendert wird, tritt ein
    JavaScript-Fehler im Zusammenhang mit guidelib.js auf. Der Fehler verursacht
    Rendering-/Anzeigeprobleme. (Ref# LC-3913538)

3. Juni 2015

  • Das Accordian-Layout in Internet Explorer 9 funktioniert nicht richtig. (Ref# LC-3912099)
  • Das numerische Feld nimmt 0 nicht als Wert an. (Ref# LC-3912103, LC-3912460)
  • AEM-Overlays funktionieren nicht ordnungsgemäß für die Komponenten und Layouts in einem adaptiven Formular (Ref# LC-3912864)
  • Adaptive Formulare unterstützen nicht das Änderungsereignis für die Dropdown-Komponenten. (Ref# LC-3912785)
  • In adaptiven Formularen werden die Eigenschaften von prevText und newText für die Felder „Text“, „Numerisch“, „Datum“ und „Dropdown-Liste“ ignoriert. (Ref# LC-3912457)

17. Juni 2015

  • Wörterbucheinträge werden für benutzerdefinierte Dialogelement nicht erstellt. (Ref# LC-3913647)
  • Validierungsfehlermeldungen werden für von Benutzern hinzugefügte Sprachen nicht übersetzt (Ref# LC-3913524)
  • Wenn das adaptive Formular im Internet Explorer 9 Browser gerendert wird, tritt ein
    JavaScript-Fehler im Zusammenhang mit guidelib.js auf. Der Fehler verursacht
    Rendering-/Anzeigeprobleme. (Ref# LC-3913538)

Assembler

Datum

Name

Korrekturen

27. April 2015

  • In der LiveCycle-Verwaltungskonsole wurde eine neue Option hinzugefügt, um die
    XML-Kodierung für den Assembler-Dienst festzulegen.  (Ref# LC-3910022)

Core

Datum

Name

Korrekturen

2. April 2015

  • Das Laden von CRX-Knoten im Dialog zum Hinzufügen von CRX-Assets als Anhang zu einem Endpunkt dauert länger als erwartet. (Ref# LC-3911835)

25. Mai 2015

  • Kategorien können nicht in der Admin-Benutzeroberfläche gelöscht werden. (Ref# LC-3912139)
  • Festgelegte HTML5-Formularfähigkeit ist nun in AEM 6.0 FP1-Formularen aktiviert. (Ref# LC-3909935)
  • Der Aufruf an invokestartpoint-API mit deaktiviertem Zwischenspeicher durch die mobile Workspace-App schlägt fehl. (Ref# LC-3911926)
  • Das Client-SDK wurde verbessert, um seine Nutzung innerhalb eines
    Livecycle-Servers zum Aufrufen eines anderen Livecycle-Servers zuzulassen, wenn der Zieldienst
    nicht auf dem Quellserver installiert ist.

HTML5-Formulare

Datum

Name

Korrekturen

24. Juli 2015.

HTML5-Formulare

  • Seiten in einem bestimmten Dokument werden nicht gerendert. (Ref# CQ-49461)
  • Die prevText und newText-Eigenschaften funktionieren nicht ordnungsgemäß. (Ref# CQ-49382)

Adaptive Formulare

  • Planen der aus mehreren Werten bestehenden benutzerdefinierten Dialogkomponenten funktioniert nicht. (Ref# CQ-47890)
  • Dropdown-Komponentenliste aus der Adaptive-Formulargruppe wird im Vorschaumodus nicht ausgefüllt. (Ref# CQ-46318)

2. Februar 2015

  • Einige Floating-Felder werden beim Einfügen in wiederholbare Unterformulare nicht gerendert. (Ref# LC-9868)
  • Einige Seiten werden nicht wiedergegeben, wenn verschachtelte und wiederholbare Unterformulare auf mehrere Seiten aufgeteilt sind. (Ref# LC-9878)

2. Juni 2015

  • Die RemoveInstance-Methode entfernt keine verknüpften Daten beim Senden des Formulars. (Ref# LC-3910543)
  • Das Exit-Event wird beim ersten Verlassen von einem Textfeld oder einer Dropdown-Liste nicht aufgerufen. (Ref# LC-10153, LC-10152)
  • Die Border-Eigenschaft eines Objekts verhält sich inkonsistent für unterschiedliche Ereignisse. (Ref# LC-3910380)
  • Die AddInstance-Methode funktioniert nicht ordnungsgemäß beim Anwenden auf ein übergeordnetes Unterformular mit mehreren untergeordneten Unterformularen. (Ref# LC-3910098)

Berechtigungsverwaltung

Datum

Name

Korrekturen

7. Mai 2015

Die folgenden APIs werden im Rights Management Policy Manager eingeführt:

  • getPolicySet()
  • createPolicySet()
  • updatePolicySet()
  • getPolicySetIdByPolicySetName()
  • deletePolicySets()
  • managePolicySetPublishers()
  • managePolicySetVisibleUsersGroups()
  • managePolicySetCoordinators()
  • updateCoordinatorPermission()

29. Mai 2015

  • Ein Fehler wird auf dem AEM-Formularserver angezeigt, wenn eine benutzerdefinierte Komponente mit SDK-JAR-Dateien mit einem anderen AEM-Formular-Rechteverwaltungsserver
    kommuniziert. (Ref# LC-3913205)
  • Beim Aktivieren oder Aktualisieren einer Richtlinie mit Validierungszeitraum für Benutzerdaten wird ein interner Serverfehler ausgegeben. (LC-3913076)

Veraltete Hotfixes

Die Hotfixes in diesem letzten Abschnitt waren oben bereits vorhanden, wurden jedoch durch neuere Pakete ersetzt, die auf dieser Seite aufgeführt sind.

Name

Beschreibung der Bugfixes

Ersetzt durch / enthalten in

Hotfix 5918 *

Leistungs- und Stabilitätskorrekturen für AEM SP2.

HF 6167.

Hotfix 6109 *.

Die Rundlauf-Verfahren-Warteschlange wird als geordnete Warteschlange behandelt.

HF 6167.

Adobe-Logo

Bei Ihrem Konto anmelden

[Feedback V2 Badge]