Bekanntes Problem bei Upgrades von AEM 6.4.2 bis AEM 6.5

Problem

Die Aktualisierung von 6.4.2 und höher auf 6.5 kann fehlschlagen und eine Fehlernachricht wegen fehlender Anforderungen wird angezeigt, wenn zuvor eine Aktualisierung von AEM 6.1 oder AEM 6.2 durchgeführt wurde.

04.12.2019 15:14:33.439 *ERROR* [FelixStartLevel] ERROR: Bundle '827' Error starting/stopping bundle. (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.scripting.javascript [827](R 827.0): missing requirement [org.apache.sling.scripting.javascript [827](R 827.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=2.0.0)) Unresolved requirements: [[org.apache.sling.scripting.javascript [827](R 827.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=2.0.0))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.scripting.javascript [827](R 827.0): missing requirement [org.apache.sling.scripting.javascript [827](R 827.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=2.0.0)) Unresolved requirements: [[org.apache.sling.scripting.javascript [827](R 827.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=2.0.0))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1727)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:338)
at java.lang.Thread.run(Unknown Source)
04.12.2019 15:14:33.440 *ERROR* [FelixStartLevel] ERROR: Bundle '828' Error starting/stopping bundle. (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.scripting.jst [828](R 828.0): missing requirement [org.apache.sling.scripting.jst [828](R 828.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=1.0.0)(!(version>=3.0.0))) Unresolved requirements: [[org.apache.sling.scripting.jst [828](R 828.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=1.0.0)(!(version>=3.0.0)))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.scripting.jst [828](R 828.0): missing requirement [org.apache.sling.scripting.jst [828](R 828.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=1.0.0)(!(version>=3.0.0))) Unresolved requirements: [[org.apache.sling.scripting.jst [828](R 828.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=1.0.0)(!(version>=3.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1727)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:338)
at java.lang.Thread.run(Unknown Source)

Oder dieser Fehler:

11.12.2019 10:26:32.102 *ERROR* [FelixDispatchQueue] com.adobe.granite.crypto FrameworkEvent ERROR (org.osgi.framework.BundleException: Unable to resolve com.adobe.granite.crypto [158](R 158.3): missing requirement [com.adobe.granite.crypto [158](R 158.3)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.commons.io)(version>=2.0.1)(!(version>=3.0.0))) Unresolved requirements: [[com.adobe.granite.crypto [158](R 158.3)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.commons.io)(version>=2.0.1)(! (version>=3.0.0)))])
org.osgi.framework.BundleException: Unable to resolve com.adobe.granite.crypto [158](R 158.3): missing requirement [com.adobe.granite.crypto [158](R 158.3)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.commons.io)(version>=2.0.1)(!(version>=3.0.0))) Unresolved requirements: [[com.adobe.granite.crypto [158](R 158.3)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.commons.io)(version>=2.0.1)(! (version>=3.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix$RefreshHelper.restart(Felix.java:5349)
at org.apache.felix.framework.Felix.refreshPackages(Felix.java:4516)
at org.apache.felix.framework.FrameworkWiringImpl.run(FrameworkWiringImpl.java:188)
at java.lang.Thread.run(Thread.java:748)

Lösung

  1. Nach dem Upgrade auf 6.5 (oder vor dem Ausführen des letzten Aktualisierungsbefehls) stoppen Sie bitte die Instanz.
  2. Laden Sie diese Common-io-JAR auf den Server herunter und legen Sie sie unter crx-quickstart/install ab.
  3. Starten Sie die Instanz mit dem folgenden Befehl neu:
    java -server -Xmx1024m -XX:MaxPermSize=256M -Djava.awt.headless=true -Dsling.run.modes=author,crx3,crx3tar -jar cq-quickstart-6.5.0.jar -p 4502 -Dsling.properties=conf/sling.properties -Dorg.apache.sling.launchpad.startupmode=UPDATE &
  4. Überprüfen Sie /system/console/bundles, sobald alle Pakete aktiv sind und das System vollständig aktualisiert wurde, und stoppen Sie dann die Instanz erneut.
  5. Starten Sie die Instanz mit dem folgenden Befehl neu:
    java -server -Xmx1024m -XX:MaxPermSize=256M -Djava.awt.headless=true -Dsling.run.modes=author,crx3,crx3tar -jar cq-quickstart-6.5.0.jar -p 4502 -Dsling.properties=conf/sling.properties &
  6. Die Aktualisierung sollte erfolgreich abgeschlossen werden.

Weitere Informationen

Dieses Problem tritt auf, wenn Sie eine Instanz mit AEM 6.4.2 oder höher aktualisieren, die zuvor von AEM 6.1 oder AEM 6.2 aktualisiert wurde.

Adobe-Logo

Bei Ihrem Konto anmelden