AEM beenden
Problem
Diese Warnung wird in Ihren AEM-Protokolldateien wiederholt angezeigt:
23.03.2017 07:49:59.379 *WARN* [pool-8-thread-3] org.apache.jackrabbit.oak.spi.query.Cursors$TraversingCursor Traversed 2993000 nodes with filter Filter(query=select [jcr:path], [jcr:score], * from [dam:Asset] as a where [jcr :content/metadata/prism:expirationDate] > cast('2017-03-22T07:00:00.000Z' as date) and [jcr:content/metadata/prism:expirationDate] < cast('2017-03-23T07:00:00.001Z' as date) and isdescendantnode(a, '/content/dam') /* xpath: / jcr:root/content/dam//element(*, dam:Asset)[(jcr:content/metadata/@prism:expirationDate > xs:dateTime('2017-03-22T07:00:00.000Z') and jcr:content/metadata/@prism:expirationDate < xs:dateTime('2017-03-23T07:00:00.001Z'))] */, path=/content/dam//*, property=[jcr:content/metadata/prism:expirationDate=[(2017-03-22T07:00:00.000Z.., ..2017-03-23T07:00:00.001Z)]]); consider creating an index or changing the query
Diese Warnungsmeldung bedeutet, dass in der AEM-Instanz etwas nicht funktioniert, wo der /oak:index/damAssetLucene-Index nicht funktioniert. Dies führt dazu, dass die obige Abfrage ein Traversal ausführt, anstatt den damAssetLucene-Index zu verwenden.
Umgebung
Ursache
Beim /oak:index/damAssetLucene-Index tritt ein Fehler auf. Sie müssten die Protokolldateien untersuchen und nach „damAssetLucene“ suchen, um die genaue zugrundeliegende Ursache zu finden.
Lösung
A. Untersuchen der zugrundeliegenden Ursache
Im Fehlerprotokoll und anderen konfigurierten Indizierungsprotokollen nach „damAssetLucene“ suchen. Eventuelle Fehler- oder Warnmeldungen untersuchen, um zu sehen, ob sie der Grund des Problems sind.
Im Falle eines Kunden war beispielsweise dies der Grund für das Problem:
22.03.2017 12:46:45.205 *ERROR* [Thread-44] org.apache.jackrabbit.oak.plugins.index.lucene.IndexTracker Could not access the Lucene index at /oak:index/damAssetLucene java.io.FileNotFoundException: [/oak:index/damAssetLucene] segments_8o28
B. Versuchen Sie, die lokale Indexkopie neu zu erstellen
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crx-quickstart/repository/index löschen
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Starten Sie AEM
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Erneut testen
C. Entscheiden, ob neu indiziert werden soll oder nicht
Wenn das Problem durch Neuerstellen der lokalen Indexkopie nicht gelöst wurde, wenden Sie sich an die Kundenbetreuung von AEM für die weitere Fehlersuche und um zu entscheiden, ob Sie den /de/oak:index/damAssetLucene-Index neu indizieren müssen.
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