Wie Masken mit Alphakanälen in Photoshop verknüpft sind.

Wenn Sie einen Bildbereich auswählen, wird der nicht ausgewählte Bereich „maskiert“, d. h. vor der Bearbeitung geschützt. Zum Erstellen einer Maske, müssen Sie Bereiche eines Bildes isolieren, während Sie Farbänderungen, Filter oder andere Effekte auf den Rest des Bildes anwenden. Sie können Masken auch für komplizierte Bildbearbeitungen verwenden, z. B. für das schrittweise Anwenden von Farb- oder Filtereffekten.

Sie können einer Ebene eine Maske hinzufügen und diese Maske dazu verwenden, Teile der Ebene auszublenden und die darunter liegenden Ebenen sichtbar zu machen. Standardmäßig ist die Ebenenmaske mit der Ebene verknüpft, der sie zugewiesen ist.

Soll eine Auswahl dauerhafter gespeichert werden, speichern Sie sie als Alphakanal. Als Alphakanal wird die Auswahl als bearbeitbare Graustufenmaske im Kanälebedienfeld gespeichert. Ist die Auswahl als Alphakanal gespeichert, können Sie sie jederzeit neu laden oder sie sogar in ein anderes Bild laden. Masken werden in Alphakanälen gespeichert. Masken und Kanäle sind Graustufenbilder, weshalb sie ganz normal mit Mal- und Bearbeitungswerkzeugen sowie mit Filtern bearbeitet werden können. Schwarz bemalte Bereiche auf einer Maske sind geschützt, weiß bemalte Bereiche können bearbeitet werden.

Falls Sie die Transparenz der Ebene direkt bearbeiten möchten, erstellen Sie eine Maske für diese Daten.

  1. Wählen Sie im Ebenenbedienfeld die Ebene aus.
  2. Wählen Sie „Ebene“ > „Ebenenmaske“ > „Aus Transparenz“.

Sie können bei gedrückter Umschalttaste auf die Miniatur klicken, um sie zu deaktivieren und das Bild und dessen Kanäle deckend zu machen.

Photoshop konvertiert Transparenz in eine deckende Farbe, die von der neu erstellten Maske verdeckt wird. Die deckende Farbe kann sehr unterschiedlich ausfallen, je nachdem, welche Filter und andere Verarbeitungsschritte zuvor auf die Ebene angewendet wurden.

Photoshop-Kanäle.

Kanäle sind Graustufenbilder, die verschiedene Informationen enthalten:

  • Farbinformationskanäle werden beim Öffnen eines neuen Bildes automatisch erstellt. Die Anzahl der erstellten Farbkanäle hängt vom Farbmodus des Bildes ab. Ein RGB-Bild hat beispielsweise für jede Farbe (Rot, Grün und Blau) einen Kanal und verfügt außerdem über einen unseparierten Kanal zum Bearbeiten des Bildes.
  • In Alphakanälen wird die Auswahl jeweils als Graustufenbild gespeichert. Sie können Alphakanäle zum Erstellen und Speichern von Masken hinzufügen, mit denen sich bestimmte Teile eines Bildes bearbeiten oder schützen lassen. (Siehe Masken und Alphakanäle.)
  • Durch Volltonfarbkanäle werden zusätzliche Platten zum Drucken mit Volltonfarben angegeben. (Siehe Volltonfarben.)

Ein Bild kann über bis zu 56 Kanäle verfügen. Alle neuen Kanäle haben dieselben Maße und dieselbe Pixelanzahl wie das Originalbild. Mit einem RGB-Bild, das über drei Farbkanäle (rot, grün und blau) und einen zusammengesetzten (RGB) Kanal verfügt, können Sie bis zu 20 zusätzliche Alphakanäle hinzufügen.

Die für einen Kanal erforderliche Dateigröße hängt von den Pixelinformationen im Kanal ab. Bestimmte Dateiformate, z. B. TIFF und Photoshop, komprimieren Kanalinformationen und sparen Speicherplatz. Die Größe einer unkomprimierten Datei, einschließlich Alphakanälen und Ebenen, wird als der am weitesten rechts stehende Wert in der Statusleiste am unteren Rand des Fensters angezeigt, wenn Sie im Popup-Menü Dokument-Größen auswählen.

Hinweis: Solange Sie eine Datei in einem Format speichern, das den Farbmodus des Bildes unterstützt, bleiben die Farbkanäle erhalten. Alphakanäle bleiben nur erhalten, wenn Sie eine Datei im Format Photoshop, PDF, TIFF, PSB oder Raw speichern. Im Format DCS 2.0 bleiben nur Volltonfarbkanäle erhalten. Das Speichern in andere Formate kann Kanalinformationen verwerfen.

Transparenz und Alphakanäle und PNG

PNG unterstützt keine beliebigen Alphakanäle wie andere Formate, wie zum Beispiel TIFF. PNG gibt an, dass der vierte Kanal in einer Datei Transparenz ist und nur Transparenz ist. Wenn Sie in Photoshop eine PNG-Datei mit Transparenz öffnen, wird diese als ein Einzelebenenbild betrachtet. Es ist kein flaches Hintergrundbild. Alphakanäle können alles enthalten, während Transparenz eine bestimmte Kanalbeziehung ist. Sie können mehrere Alphakanäle pro Dokument haben, aber nur einen Transparenzkanal verwenden. Photoshop behandelt Transparenz und Alphakanäle getrennt voneinander. Transparenz von einem vorhandenen PNG kann in Photoshop bearbeitet werden, indem eine Ebenenmaske aus den Transparenzdaten erstellt wird (sehen Sie die Schritte unten).

Gehen Sie folgendermaßen vor, wenn Sie die Deckkraft eines bestimmten Punkts in einer Bilddatei anzeigen möchten:

  1. Öffnen Sie die Palette „Info“.
  2. Klicken Sie auf die Optionen der Palette oben rechts, und wählen Sie „Bedienfeldoptionen“.
  3. Wählen Sie für „Zweite Farbwerteanzeige“ den Modus „Deckkraft“.
  4. Klicken Sie auf „OK“.
  5. Die Infopalette stellt den Deckungsgrad an der Position des Mauszeigers bereit.
  6. Falls Sie die Ebenentransparenz direkt bearbeiten möchten, können Sie eine Ebenenmaske erstellen, die auf Ebenentransparenz basiert.
  7. Wählen Sie im Ebenenbedienfeld die Ebene aus.
  8. Wählen Sie „Ebene“ > „Ebenenmaske“ > „Aus Transparenz“.
  9. Es wird eine Miniatur der Ebenenmaske angezeigt, die mit der Ebene verknüpft ist. Sie können bei gedrückter Umschalttaste auf die Miniatur klicken, um sie zu deaktivieren und das Bild und dessen Kanäle deckend zu machen. Durch erneutes Klicken auf das Miniaturbild wird es erneut aktiviert.

Masken werden in Alphakanälen gespeichert. Im Kanalfenster sollten Sie eine Ebene-0-Maske sehen. Blenden Sie die Farbkanäle aus und machen Sie die Ebene-0-Maske sichtbar, indem Sie auf das Augensymbol klicken, um die Maske zu sehen. Masken und Kanäle sind Graustufenbilder, weshalb sie ganz normal mit Mal- und Bearbeitungswerkzeugen sowie mit Filtern bearbeitet werden können. Schwarz bemalte Bereiche auf einer Maske sind geschützt, weiß bemalte Bereiche können bearbeitet werden.

Wenn Sie die Datei als PNG speichern und dann das PNG in Photoshop erneut öffnen, ist die Transparenz implizit. Sie sehen keine Ebenenmaskenminiatur oder eine in einem Alphakanal gespeicherte Maske.

Wählen Sie in nichttransparenten Bereichen eine Ebene in Photoshop

Sie können alle nicht transparenten Bereiche in einer Ebene oder – wenn eine Ebenenmaske vorhanden ist – alle nicht maskierten Bereiche auswählen. Die Auswahl dieser Bereiche ist nützlich, wenn Sie Bildinhalte auswählen möchten, die von transparenten Bereichen umgeben sind oder diese enthalten oder wenn Sie eine Auswahl erstellen möchten, die maskierte Bereiche auf einer Ebene ausschließt.

1. Führen Sie einen der folgenden Schritte aus:

  • Um nur die undurchsichtigen Bereiche auf einer nicht maskierten Ebene auszuwählen, klicken Sie mit Strg (Windows) oder Befehl (Mac OS X) auf die Ebenen-Miniaturansicht im Ebenenbereich.
  • Um die unmaskierten Bereiche auf einer Ebene mit Ebenenmaske auszuwählen, klicken Sie mit der Strg-Taste (Windows) oder der Befehlstaste (Mac OS X) auf die Miniaturansicht der Ebenenmaske im Ebenenbereich.
  • 2. Wenn eine Auswahl vorhanden ist, können Sie eine der folgenden Aktionen durchführen:
  • Um die Pixel zu einer bestehenden Auswahl hinzuzufügen, drücken Sie Strg+Umschalt (Windows) oder Befehl+Umschalt (Mac OS), und klicken Sie auf das Ebenen-Miniaturbild oder die Ebenenmaske im Ebenenbereich.
  • Um die Pixel von einer vorhandenen Auswahl zu entfernen, drücken Sie Strg+Alt (Windows) oder Befehl+Option (Mac OS) und klicken Sie auf das Ebenen-Miniaturbild oder die Ebenenmaske im Ebenenbereich.
  • Um den Schnittpunkt der Pixel mit einer vorhandenen Auswahl zu laden, drücken Sie Strg+Alt+Shift (Windows) oder Befehl+Option+Shift (Mac OS) und klicken auf das Ebenen-Miniaturbild oder die Ebenenmaske im Ebenenbereich.

Erstellen eines Alphakanals aus einer Auswahl

  1. Wählen Sie mit einem Auswahlwerkzeug die zu isolierenden Bildbereiche aus.
  2. Wählen Sie „Auswählen“ > „Auswahl speichern“.
  3. Geben Sie im Dialogfeld „Auswahl speichern“ Folgendes an und klicken Sie auf OK:
    1. Dokument
      Wählen Sie ein Zielbild für die Auswahl aus. Standardmäßig wird die Auswahl in einem Kanal des aktiven Bildes platziert. Sie können die Auswahl in einem Kanal eines anderen geöffneten Bildes mit denselben Pixelmaßen oder in einem neuen Bild speichern.
    2. Kanal
      Wählen Sie einen Zielkanal für die Auswahl. Standardmäßig wird die Auswahl in einem neuen Kanal gespeichert. Sie können die Auswahl in einem beliebigen vorhandenen Kanal im ausgewählten Bild oder, sofern das Bild Ebenen enthält, in einer Ebenenmaske speichern.
  4. Wenn Sie die Auswahl als neuen Kanal speichern, geben Sie unter „Name“ einen Namen für den Kanal ein.
  5. Wählen Sie zum Speichern in einem vorhandenen Kanal eine Option für die Auswahlkombination aus:
    1. Kanal ersetzen
      Ersetzt die aktuelle Auswahl im Kanal.
    2. Dem Kanal hinzufügen
      Fügt die Auswahl dem aktuellen Kanalinhalt hinzu.
    3. Von Kanal subtrahieren
      Löscht die Auswahl aus dem Kanalinhalt.
    4. Kanalschnittmenge bilden
      Behält die Bereiche der neuen Auswahl bei, die sich mit dem Kanalinhalt überschneiden.

Sie können den Kanal im Kanälebedienfeld auswählen, um die gespeicherte Auswahl in Graustufen anzuzeigen.

Einen Alphakanal in Photoshop erkennen

Doppelklicken Sie auf den Kanal, um das Dialogfeld „Kanälebedienfeld“ zu öffnen. Das Dialogfeld zeigt an, ob die Farbe „Maskierte Bereiche“, „Ausgewählte Bereiche“ oder „Volltonfarbe“ anzeigt.

Erstellen eines Alphakanals aus einer Auswahl

  1. Wählen Sie mit einem Auswahlwerkzeug die zu isolierenden Bildbereiche aus.
  2. 2. Wählen Sie „Auswahl“ > „Auswahl speichern“.
  3. 3. Legen Sie im Dialogfeld „Auswahl speichern“ folgende Optionen fest und klicken Sie auf „OK“:
    1. Dokument
      Wählen Sie ein Zielbild für die Auswahl aus. Standardmäßig wird die Auswahl in einem Kanal des aktiven Bildes platziert. Sie können die Auswahl in einem Kanal eines anderen geöffneten Bildes mit denselben Pixelmaßen oder in einem neuen Bild speichern.
    2. Kanal
      Wählen Sie einen Zielkanal für die Auswahl. Standardmäßig wird die Auswahl in einem neuen Kanal gespeichert. Sie können die Auswahl in einem beliebigen vorhandenen Kanal im ausgewählten Bild oder, sofern das Bild Ebenen enthält, in einer Ebenenmaske speichern.
  4. Wenn Sie die Auswahl als neuen Kanal speichern, geben Sie unter „Name“ einen Namen für den Kanal ein.
  5. Wählen Sie zum Speichern in einem vorhandenen Kanal eine Option für die Auswahlkombination aus:
    1. Kanal ersetzen
      Ersetzt die aktuelle Auswahl im Kanal.
    2. Dem Kanal hinzufügen
      Fügt die Auswahl dem aktuellen Kanalinhalt hinzu.
    3. Von Kanal subtrahieren
      Löscht die Auswahl aus dem Kanalinhalt.
    4. Kanalschnittmenge bilden
      Behält die Bereiche der neuen Auswahl bei, die sich mit dem Kanalinhalt überschneiden.
  6. Sie können den Kanal im Kanälebedienfeld auswählen, um die gespeicherte Auswahl in Graustufen anzuzeigen.

Anzeige der Transparenzeigenschaften von Bildern in Photoshop

Wenn ein Bild einen Beschneidungspfad enthält, wird dieser im Fenster „Pfade“ mit seinem Name in Fettschrift angezeigt.

Wenn ein Bild einen Alpha- oder Maskenkanal enthält, wird der zusätzliche Kanal im Fenster „Kanäle“ angezeigt. Jeder Kanal im Fenster „Kanäle“ hat ein Symbol des aktuellen Bildes. Wenn Sie auf dieses Symbol doppelklicken, ändert sich nichts bei den Prozessfarben, aber das Fenster „Kanäleoptionen“ für Masken-, Alpha- und Volltonfarbkanäle wird geöffnet. In diesem Fenster werden Eigenschaften von zusätzlichen Kanälen angezeigt.

Wenn ein Bild einen Transparenzkanal enthält, wird dieser NICHT im Fenster „Kanäle“ angezeigt. Stattdessen zeigt das Fenster "Ebenen" eine Ebene (nicht-kursive Schrift) an, welche nicht die Hintergrundebene ist (kursive Schrift).

Enthält ein Bild mehrere Ebenen, werden diese alle im Fenster „Ebenen“ aufgelistet.

Transparenzen in Rasterbildern

Um Transparenzen in Rasterbildern zu erzeugen, stehen verschiedene Techniken zur Verfügung:

  • Beschneidungspfade
  • Alpha- oder Maskenkanäle
  • Transparenzkanäle
  • Mehrere Ebenen

Beschneidungspfade

Die am weitesten verbreitete Technik zur Erzeugung von Transparenzen in der Druckvorstufe ist die Verwendung von Beschneidungspfaden. Beschneidungspfade stellen Objekte im Vordergrund frei und lassen deren Hintergrund transparent. Beschneidungsspfade sind vektorbasierte Linienstrukturen, die scharfe Ränder zwischen dem Objekt im Vordergrund und dem transparenten Hintergrund erzeugen.

Alpha- oder Maskenkanäle

Einige Bildformate unterstützen Alpha- oder Maskenkanäle.

Bei allen Rasterbildern wird jedes Pixel durch nummerische Werte für alle Farbkanäle des Bildes, in Abhängigkeit vom Farbraum, dargestellt. Enthält ein Bild einen Alphakanal, wird jedes Bildpixel zusätzlich von einem nummerischen Wert dargestellt, der die Durchsichtigkeit dieses Pixels angibt. In Alphakanälen definiert ein Wert von 100 % ein undurchsichtiges Pixel, während 0% ein durchsichtiges Pixel angibt. Maskenkanäle entsprechen Alphakanälen, mit dem Unterschied, dass sie eine entgegengesetzte Polarität haben. Bei Maskenkanälen definiert der Wert 100% ein durchsichtiges Pixel und 0% ein undurchsichtiges Pixel. Mit Alpha- und Maskenkanälen lassen sich mehrstufige Transparenzen für Schlagschatten und unscharfe Ränder von Objekten, auch "Weiche Auswahlkanten" genannt, realisieren. Unterstützt ein Bildformat Alpha- und Maskenkanäle, kann jedes Bild dieses Formats keinen, einen oder mehrere Alpha- oder Maskenkanäle enthalten. Die zusätzlichen Kanäle können anhand ihres eindeutigen Namens identifiziert werden. Enthält ein Bild ein oder mehrere Alpha- oder Maskenkanäle, kann der Benutzer entscheiden, ob er keinen oder genau einen dieser zusätzlichen Kanäle anwendet.

Transparenzkanäle

Transparenzkanäle ähneln Alphakanälen. Rasterbildformate, die Transparenzkanäle unterstützen, können genau einen oder keinen Transparenzkanal enthalten. Der Benutzer hat in der Regel keine Wahl, ob er einen Transparenzkanal anwendet oder nicht. Die Anwendung eines Transparenzkanals ist obligatorisch. Jedes einzelne Bildpixel wird durch nummerische Werte für die sichtbaren Farben sowie einen zusätzlichen nummerischen Wert dargestellt, der die Information zur Durchsichtigkeit enthält. Der Wert 100 % definiert ein undurchsichtiges, 0 % ein durchsichtiges Pixel. Über Transparenzkanäle lässt sich auch mehrstufige Transparenz realisieren. Ein bekanntes Beispiel für ein Bildformat, das Transparenzkanäle unterstützt, ist PNG mit RGBA-Farbkanälen.

Mehrere Ebenen

Eine sehr aufwändige Art und Weise Transparenzen zu erzeugen, ist mehrere Adobe Photoshop Ebenen miteinander zu kombinieren. Nur TIFF- und native Photoshop-Dokumente unterstützen mehrere Ebenen. TIFF-Bilder enthalten immer ein Hauptbild, das sich aus allen Photoshop Ebenen zusammensetzt. Native Photoshop Bilder enthalten hingegen ein Hauptbild, welches nicht zwingend die Kombination aller Photoshop Ebenen ist.

Glossar

Ebenenmaske

Eine Ebenenmaske ist eine Transparenzmaske, die mit der Ebene verbunden ist. Sie wird nur im Alphakanal angezeigt, wenn die Ebene aktiv ist.

Nicht zugeordneter Alphakanal

RGB-Bilder mit Alpha-Transparenz können auf zwei verschiedene Arten gespeichert werden. Eine Möglichkeit besteht darin, Roh-RGB-Werte und Alpha-Werte als getrennte und unabhängige Kanäle zu speichern; dies wird „nicht zugeordnetes Alpha“ genannt. PNG ist standardisiert auf „nicht zugeordnetes“ („nicht-multipliziertes“) Alpha, so dass Bilder mit separaten Transparenzmasken verlustfrei gespeichert werden können. Die meisten Bildbearbeitungsprogramme speichern Bilder in nicht zugeordnete Alphakanäle, um die RGB- und Alphakanäle unabhängig voneinander zu ändern und dabei keine RGB-Daten beim Nullieren der Alphakanäle zu verlieren.

Vormultiplizierter Alphakanal

Eine andere Möglichkeit besteht darin, RGB-Werte nicht als Rohwerte zu speichern, sondern vorab mit entsprechenden Alpha-Werten zu multiplizieren, die dann als „zugeordnetes Alpha“ bezeichnet werden.
Wenn ein Alpha-Kanal in einem Bild verwendet wird, ist es üblich, die Farbe auch mit dem Alpha-Wert zu multiplizieren. Dies wird in der Regel als vor-multipliziertes Alpha bezeichnet. „Vor-multipliziertes Alpha“ speichert Pixelwerte, die durch die Alpha-Fraktion vormultipliziert sind. Die Alpha-Informationen eines Pixels werden nicht nur im Alphakanal selbst gespeichert, sondern sind bereits im roten, grünen und blauen Kanal „multipliziert“. Die Rendering-Software bevorzugt zugeordnetes Alpha, da mit RGB-Werten, die bereits mit Alpha multipliziert wurden, weniger Arbeit in Echtzeit erledigt werden muss, wenn Alpha-Blending durchgeführt wird. TIFF-Dateien unterstützen beide Arten von Alphakanälen, sind aber häufig falsch markiert.

 

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie