Adobe Acrobat PDFMaker (bouton Convertir au format Adobe PDF de la barre d'outils/de l'onglet PDFMaker) est un module externe qui permet de créer des fichiers PDF à partir d'applications Microsoft Office. Cette fonction est installée avec Acrobat Professional et Standard.

  • Dans MS Office 2003 et versions antérieures, PDFMaker utilise l'imprimante Adobe PDF pour créer un fichier PostScript. Puis, l'imprimante Adobe PDF établit une interface avec l'application Adobe Acrobat Distiller pour créer un fichier PDF.
  • Dans MS Office 2007, 2010, 2016 et 365, PDFMaker utilise la bibliothèque Adobe PDF pour convertir un document Microsoft Office en PDF.
  • Acrobat Distiller ou l'imprimante Adobe PDF peut également être utilisé indépendamment pour créer des fichiers PDF.

Ce document peut vous aider à résoudre les problèmes qui se produisent lorsque vous essayez de créer des fichiers PDF depuis des applications Office avec Acrobat PDFMaker. Bien que ce document concerne Microsoft Word, la plupart des procédures de dépannage s’appliquent également à Microsoft PowerPoint et Microsoft Excel.

 

Le ruban Acrobat Ribbon n’est pas disponible dans les applications Office 2016 ou Office 365 sur Windows

Applicable aux versions Office 2016 ou Office 365 de Word, Excel et PowerPoint

Essayez les étapes suivantes pour résoudre ce problème :  

  1. Cliquez sur l’icône Word à l’aide du bouton droit de la souris et sélectionnez Exécuter en tant qu’administrateur.

    Si l’invite Contrôle de compte d’utilisateur s’affiche, cliquez sur Oui.

  2. Ouvrez un document vierge et sélectionnez le modèle Document vierge. Vous pouvez également ouvrir un document Word existant.

  3. Dans le menu Fichier, sélectionnez Options. La boîte de dialogue Options Word s’affiche.

  4. Sélectionnez Compléments dans la liste d’options. Dans le menu déroulant Gérer, sélectionnez Compléments COM, puis cliquez sur OK.

    Compléments Word
  5. Dans la boîte de dialogue Compléments COM, cochez la case du complément COM Acrobat PDFMaker Office si elle n’est pas déjà cochée, puis cliquez sur OK.

    Complément COM PDFMaker Office

PDFMaker se bloque avec Office 2016 et Office 365 sous Windows

Acrobat PDFMaker se bloque avec Office 2016 et Office 365 sous Windows après la mise à jour de février d'Office 2016.

Adobe étudie ce problème et travaille avec Microsoft pour le résoudre dès que possible. En attendant, pour créer un fichier PDF, voir la solution ici.

Vérification de la compatibilité d'Acrobat avec Microsoft Office

Avant de commencer le dépannage, assurez-vous que la version d'Acrobat que vous utilisez est compatible avec la version d'Office que vous utilisez. Pour plus de détails, consultez Navigateurs Web et applications PDFMaker compatibles | Acrobat Reader.

Dépannage Acrobat Distiller et imprimante Adobe PDF (uniquement applicable à PDFMaker pour MS Office 2003 et versions antérieures)

Acrobat PDFMaker (pour MS Office 2003 et versions antérieures) utilise l'imprimante Adobe PDF, qui à son tour utilise l'application Acrobat Distiller, pour convertir des documents Word. Par conséquent, la première étape du processus de dépannage consiste à déterminer si Acrobat Distiller fonctionne correctement :

Essayez de créer un fichier PDF à partir de Word à l'aide de l'imprimante Adobe PDF 

  1. Ouvrez un document dans Word et sélectionnez Fichier > Imprimer.
  2. Choisissez Adobe PDF dans le menu Nom de l'imprimante, puis cliquez sur OK.

Tentative de création d'un fichier PDF avec l'application Acrobat Distiller

Remarque : Cette méthode ne prend pas en charge les fonctions avancées de PDFMaker, telles que le maintien des liens et de la structure du document.

  1. Ouvrez un document Word et sélectionnez Fichier > Imprimer.
  2. Dans la boîte de dialogue d'impression, choisissez une imprimante PostScript (par exemple, l'imprimante Adobe PDF), sélectionnez Imprimer dans un fichier, puis cliquez sur OK.

    Un fichier PostScript (.ps ou.prn) est créé.

    Remarque : Si vous ne disposez d'aucune imprimante PostScript, vous pouvez télécharger un pilote d'imprimante PostScript à partir du site web d'Adobe. Une fois que vous avez installé le pilote, exécutez l'étape 2. Si vous choisissez l'imprimante Adobe PDF, ne sélectionnez pas « Ne pas envoyer les polices à “Adobe PDF” » pour créer un fichier PostScript.

  3. Dans Acrobat, sélectionnez Options avancées > Acrobat Distiller.
  4. Sélectionnez un paramètre dans la liste Paramètres par défaut (ou gardez le paramètre par défaut).
  5. Sélectionnez Fichier > Ouvrir, sélectionnez Tous les fichiers dans le menu Fichiers de type, sélectionnez le fichier PS ou PRN que vous avez créé, puis cliquez sur Ouvrir.
  6. Spécifiez un nom et un emplacement pour le fichier PDF, puis cliquez sur Enregistrer.
  7. Ouvrez le fichier messages.log dans le dossier suivant pour Windows (NT, 2000, XP, vista, 7) : %AppData%\Adobe\Acrobat\Distiller [numéro de version]

  8. Consultez le fichier messages.log pour obtenir des informations de dépannage :

    • Si le fichier indique pourquoi Acrobat Distiller n'a pas pu créer le fichier PDF, utilisez la zone de texte de recherche dans Aide et services d'Acrobat pour rechercher des documents associés. Par exemple, si le fichier indique une erreur PostScript, dépannez l'erreur en respectant les recommandations sous Dépannage des erreurs PostScript.
    • Si le fichier n'indique pas pourquoi Acrobat Distiller ne peut pas créer le fichier PDF, créez un document Word contenant seulement quelques mots. Essayez ensuite de créer un fichier PDF à partir de ce document à l'aide de l'imprimante Adobe PDF et de l'application Acrobat Distiller :
    • Si vous pouvez créer un fichier PDF à partir du nouveau document, PDFMaker peut être à l'origine du problème. Passez à Résolution des problèmes d'Acrobat PDFMaker.
    • Si vous ne parvenez pas à créer un fichier PDF à partir du nouveau document, utilisez un fichier d'une autre application. Essayez ensuite de créer un fichier PDF avec Acrobat Distiller. Si le problème se produit avec le fichier d'une autre application, réinstallez Acrobat Distiller. Si le problème ne se reproduit pas avec le fichier d'une autre application, dépannez le comportement spécifique à l'aide des documents sous Contenu associé. Ou, recherchez Aide d’Acrobat. Si vous avez besoin d'une aide supplémentaire, contactez le support technique d'Acrobat.

Résolution des problèmes d'Acrobat PDFMaker

Si vous pouvez créer un fichier PDF avec l'imprimante Adobe PDF ou Acrobat Distiller, mais pas avec Acrobat PDFMaker, le problème peut être dû aux fonctions d'Acrobat PDFMaker. Pour déterminer si l'une de ces fonctions est la cause de votre problème, désactivez-les. Ensuite, essayez de créer un fichier PDF :

  1. Dans Word, sélectionnez Adobe PDF > Modifier les paramètres de conversion.
  2. Sélectionnez Taille de fichier minimale dans le menu Paramètres de conversion.
  3. Cliquez sur l'onglet Word et désélectionnez toutes les options.
  4. Cliquez sur l'onglet Signets et désélectionnez toutes les options de signets.
  5. Cliquez sur l'onglet Sécurité et désélectionnez toutes les options de sécurité.
  6. Cliquez sur OK.
  7. Essayez de créer un fichier PDF :
  • Si vous ne parvenez pas à créer un fichier PDF, passez à Dépannage des problèmes spécifiques au document.
  • Si vous parvenez à créer un fichier PDF, déterminez les fonctions à l'origine du problème : Activez une fonction et tentez de créer un fichier PDF. Répétez ce processus jusqu'à ce que le problème se reproduise. Créez ensuite un document Word contenant seulement quelques mots. Essayez de créer un fichier PDF à partir de ce document en utilisant les mêmes paramètres Acrobat PDFMaker :
  • Si vous parvenez à créer un fichier PDF à partir du nouveau document, le problème est spécifique au document. Passez à Dépannage des problèmes spécifiques au document.
  • Si vous ne parvenez pas à créer un fichier PDF à partir du nouveau document, la dernière fonction activée continue de causer des problèmes. Réinstallez Acrobat PDFMaker. Si le problème persiste, contactez le Support d'Acrobat

Dépannage des problèmes spécifiques au document

Si vous déterminez que le problème est propre au document, dépannez-le comme suit.

Activer uniquement les fonctions Acrobat PDFMaker que le document utilise

Par exemple, si le document contient uniquement des styles de titre en-tête 1 et en-tête 2, désactivez les autres styles de titre dans la boîte de dialogue Acrobat PDFMaker.

Basculez vers la vue de document normale dans Word, puis créez le fichier PDF à l'aide d'Acrobat PDFMaker

Recréer le document Word pour éliminer tout dommage

Procédez au moins de l’une des façons suivantes :

  • Copiez et collez le contenu du document Word dans un nouveau document, puis créez le fichier PDF.
  • Sélectionnez tout le texte dans un document, modifiez sa police, puis enregistrez le document sous un nouveau nom. Word réécrit le document, ce qui peut éliminer les éléments qui entrent en conflit avec Acrobat PDFMaker. Après avoir enregistré le document, vous pouvez le reformater avec la police souhaitée.
  • Si le document a été conçu dans une version de Word autre que celle que vous utilisez pour créer le fichier PDF, apportez une petite modification au document. Puis, enregistrez-le sous un nouveau nom. Cette procédure force Word à réécrire le document, pouvant ainsi éliminer tous les éléments qui entrent en conflit avec Acrobat PDFMaker.

Recréez tous les styles d'en-tête personnalisés dans le document, puis créez le fichier PDF.

Identifier les éléments conflictuels dans le document

  1. Créez un document Word.
  2. Copiez la moitié du document Word d'origine dans le nouveau document Word.
  3. Convertissez le nouveau document Word au format PDF à l'aide d'Acrobat PDFMaker.
  • Si le problème se reproduit, un élément conflictuel existe dans le nouveau document Word. Pour isoler davantage l'élément, répétez les étapes 1 à 3 et copiez la moitié du deuxième document Word dans un nouveau document Word.
  • Si le problème ne se reproduit pas, un élément conflictuel se trouve dans le document Word d'origine. Pour isoler le problème, répétez les étapes 1 à 3 et copiez l'autre moitié du document Word d'origine dans un nouveau document Word. Si les deux moitiés du document sont converties correctement, fermez les autres programmes en cours d'exécution, y compris l'application Office. Supprimez les fichiers .tmp (souvent situés dans le dossier Windows/Temp).

Réinstallez les programmes

Supprimez Acrobat et Office ou l'application Office spécifique (Word, PowerPoint ou Excel). Réinstallez Office ou l'application Office spécifique, puis réinstallez Acrobat.

Pour supprimer Acrobat, accédez à Programmes et fonctionnalités dans le Panneau de configuration. Pour obtenir des instructions sur la procédure de suppression d'Office, voir la documentation d'Office ou contactez Microsoft.

Si le document Word est protégé, supprimer la protection

Pour obtenir des instructions sur la manière de désactiver la protection, voir la documentation Word ou contactez Microsoft. 

Résoudre les conflits avec d'autres macros dans Microsoft Word

PDFMaker peut être en conflit avec d'autres macros, tels que les antivirus ou les logiciels de télécopie. Si d'autres tâches de résolution des incidents échouent ou si PDFMaker a des problèmes après l'installation d'une macro tiers, résolvez les conflits avec d'autres macros. Les macros connues pour causer des incompatibilités incluent Duden Korrektor Plus 2.0, ViaVoice 10 et versions antérieures, Personal Translator 2002 Office Plus, OfficeReady Stuffit, Leuchter Informatic AG WordPlus et GoldMine Link to Word.

Pour déterminer si PDFMaker est en conflit avec une autre macro, supprimez ou désactivez les autres macros une par une (voir lien applicable ci-dessous). Réessayez de convertir un document au format PDF à l'aide de PDFMaker. Si le problème ne se reproduit pas, contactez le fabricant de cette macro.

Dépannage des problèmes dans Microsoft Word

Les étapes ci-dessous s'appuient sur les articles de la base de connaissances Microsoft :

Pour plus d'informations sur le dépannage de Microsoft Word, consultez le site Web Microsoft et recherchez l'article approprié.

Démarrer Word à l'aide du commutateur /a et ajouter PDFMaker manuellement

Le commutateur/a démarre Word et empêche le chargement automatique de modèles et de compléments globaux (y compris le modèle Normal).Le commutateur /a verrouille également les fichiers de paramètres ; en d'autres termes, les fichiers des paramètres ne peuvent pas être lus ou modifiés si vous utilisez ce commutateur.

Remarque : Les modifications des préférences, personnalisations ou macros au cours d'une session de commutateur /a dans Word sont perdues lorsque vous quittez Word.

Pour lancer Word à l'aide du commutateur /a :

  1. Quittez tous les programmes.
  2. Sélectionnez Démarrer > Exécuter.
  3. Dans la boîte de dialogue Exécuter, tapez winword.exe /a.
  4. Cliquez sur OK. La boîte de dialogue Exécuter se ferme et Word démarre.

Pour charger PDFMaker manuellement (Acrobat 6.x uniquement) :

  1. Quittez tous les programmes.
  2. Sélectionnez Outils > Modèles et compléments.
  3. Sélectionnez PDFMaker.dot (pas PDFMakerA.dot) et cliquez sur OK.

    Les icônes PDFMaker apparaissent.

Pour Acrobat 7.x, 8.x, 9.x, X (selon le cas) 

Pour charger PDFMaker manuellement (MS Word 2003 ou version antérieure) :

  1. Quittez tous les programmes.
  2. Sélectionnez Outils > Personnaliser, puis cliquez sur l'onglet Commandes.
  3. Cliquez sur Outils dans le panneau Catégories.
  4. Faites glisser Compléments COM du panneau Commandes dans le menu Outils tout en maintenant le bouton de la souris enfoncé. Lorsque le menu Outils affiche les commandes de menu, faites glisser Compléments COM juste en dessous de l'option Personnaliser, puis relâchez le bouton de la souris.
  5. Cliquez sur Fermer.
  6. Cliquez sur Compléments COM dans le menu Outils.
  7. Cliquez sur Ajouter, localisez le module externe (le module externe PDFMaker se trouve sous [chemin d'installation d'Acrobat]\PDFMaker\Office\PDFMOfficeAddIn.dll) et cliquez sur OK.

  8. Appuyez sur les touches Alt + F11 pour lancer Visual Basic Editor.
  9. Appuyez sur Ctrl + G pour lancer Immediate Window de Visual Basic Editor.
  10. Pour démarrer PDFMaker dans Word, tapez Application.COMAddIns("PDFMaker.OfficeAddin").Connect = True. Fermez Visual Basic Editor.
  11. Vérifiez que le menu Adobe PDF s'affiche à droite de l'aide dans la barre de menus de Microsoft Word.

Charger PDFMaker manuellement (MS Word 2007 et 2010) :

  1. Quittez tous les programmes.
  2. Cliquez sur le Bouton Office, puis cliquez sur Options Word.

  3. Cliquez sur Compléments.

  4. Dans la liste déroulante Gérer, sélectionnez Compléments COM, puis cliquez sur Atteindre.

  5. Si le complément COM Acrobat PDFMaker se trouve dans la liste et est sélectionné dans la boîte de dialogue Compléments COM, procédez comme suit. Dans le cas contraire, passez à l'étape 6.

  6. Cliquez pour désélectionner la case du complément COM Acrobat PDFMaker.

  7. Cliquez sur OK pour fermer la boîte de dialogue Compléments COM.

  8. Répétez les étapes 1 à 3, puis cochez la case du complément COM Acrobat PDFMaker dans la boîte de dialogue Compléments COM.

  9. Vérifiez que l'onglet Acrobat s'affiche dans le ruban de Microsoft Word.

  10. Si le complément COM Acrobat PDFMaker ne figure PAS dans la boîte de dialogue Compléments COM, suivez les étapes 7 à 10 dans la section Pour charger PDFMaker manuellement (MS Word 2003 ou version antérieure)

Créez un document Word et démarrez PDFMaker : 

  1. Saisissez du texte dans le document Word.
  2. Sélectionnez Fichier > Enregistrer, puis enregistrez le document test sur le bureau.
  3. Cliquez sur Convertir au format Adobe PDF.

Si vous résolvez le problème lorsque vous utilisez le commutateur /a pour lancer Word, supprimez chacun des composants qui chargent au démarrage de Word. Supprimez ces composants un par un dans l'ordre dans lequel ils apparaissent dans Word. Les composants suivants chargent au démarrage de Word :

  • Macros automatiques Word
  • Modèle global (Normal.dot)
  • Compléments (WLLs)
  • Modèles dans le dossier Démarrage Word et les dossiers Démarrage d'Office
  • Compléments COM
  • Clé de données Word dans le registre Windows
  • Clé d'options Word dans le registre Windows
  • Macros automatiques Word

Remarque : Consultez les services de support produit Microsoft suivants pour un dépannage supplémentaire du démarrage de Word :

Renommer le fichier modèle Normal.dot

Pour des instructions sur la façon de renommer le fichier modèle global, voir « Modèle global (Normal.dotm ou Normal.dot) » dans l'article du support Microsoft, Comment réinitialiser les options d'utilisateur et les paramètres de registre dans Word. Faites défiler la page vers le bas pour accéder à l'article.

Important : N'utilisez pas le commutateur /a pour redémarrer Word après avoir accompli les étapes.

Si le problème est résolu lorsque vous renommez le modèle global, il provient d’un modèle Normal.dot endommagé. Il est parfois nécessaire de modifier plusieurs paramètres pour restaurer les options. Si le fichier Normal.dot que vous avez renommé contient des personnalisations, telles que les styles, des macros ou des entrées AutoText qui ne peuvent pas être facilement recréées, vous pouvez utiliser Organizer pour copier ces personnalisations de l'ancien fichier Normal.dot vers le nouveau fichier Normal.dot.

Pour plus d'informations sur la façon d'utiliser Organizer, procédez comme suit :

  1. Démarrez Word.
  2. Sélectionnez Aide > Aide de Microsoft Word.
  3. Dans l'assistant d'Office ou l'assistant Answer, saisissez Organizer.

  4. Cliquez sur Rechercher pour afficher les rubriques correspondantes.

Si vous ne parvenez pas à résoudre le problème, il est préférable de recourir à votre ancien modèle global (Normal.dot) au lieu du nouveau modèle global. Pour utiliser votre ancien modèle Normal.dot, renommez le modèle Normal.dot à Normal.dot. Si vous continuez à rencontrer des problèmes avec PDFMaker après utilisation de ce document, contactez le Support d’Acrobat.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne