Problème : erreur « La licence de ce produit ne fonctionne plus »

Remarque :

Cet article s’applique à Creative Suite 5.5 et versions antérieures.

Quand vous essayez de lancer une application Adobe, recevez-vous un message d’erreur « La licence de ce produit ne fonctionne plus » ? Si tel est le cas, essayez les solutions sur cette page pour résoudre le problème.

Solutions

Important : appliquez les solutions suivantes dans l’ordre. Ne passez pas à la solution suivante si une solution précédente corrige le problème. Après avoir appliqué certaines de ces solutions, vous devrez peut-être saisir de nouveau les données d’attribution de licence ou activer votre produit. De plus, le lancement des éditions d’évaluation du logiciel Adobe peut être bloqué.

Solution 1 : appliquez la mise à jour du service de licences.

  1. Fermez toutes les applications Adobe.
  2. Exécutez la mise à jour du service de licences:

    1. Extrayez le fichier LicenseRecovery109.zip.

      Important : utilisez un utilitaire tel que Winzip pour extraire le contenu du fichier .zip.
    2. Cliquez deux fois sur LicenseRecover.exe.
  3. Suivez les instructions qui s’affichent à l’écran.
  4. Démarrez l’application Adobe.

    Important : le correctif s’applique aux produits Creative Suite 3 ou 4, Acrobat 8 ou 9, Photoshop Elements 6, 7 ou 8, Director et Adobe Technical Communication Suite. Si votre problème n’a pas été résolu à la première tentative, exécutez de nouveau le correctif et entrez l’option 0 lorsque vous êtes invité à le faire. Si le problème persiste après avoir exécuté le correctif une seconde fois, passez à la solution 2.

Solution 2 : configurez FLEXnet Licensing Service sur Manuel et lancez-le.

  1. Sélectionnez Démarrer > Panneau de configuration.
  2. Cliquez deux fois sur Outils d’administration.
  3. Cliquez deux fois sur Services.
  4. Cliquez deux fois sur FLEXnet Licensing Service pour ouvrir la boîte de dialogue Propriétés.
  5. Cliquez sur le menu Type de démarrage, puis sélectionnez Manuel.
  6. Cliquez sur Appliquer.
  7. Dans la section Etat des services, cliquez sur Démarrer pour lancer le service.
  8. Cliquez sur Appliquer, puis sur OK.
  9. Fermez toutes les boîtes de dialogue ouvertes.
  10. Lancez votre application Adobe.
 

Remarque : si vous recevez le message d’erreur « Erreur 5, accès refusé » lorsque vous essayez de démarrer le service FLEXnet Licensing Service, procédez comme suit :

  1. Sélectionnez Démarrer > Exécuter et saisissez services.msc.
  2. Cliquez deux fois sur FLEXnet Licensing Service.
  3. Cliquez sur l’onglet de connexion et sélectionnez Connexion en tant que : ce compte et spécifiez votre compte.
  4. Cliquez sur OK, puis fermez la fenêtre Services.
  5. Redémarrez le système, puis répétez la solution 2.

Solution 3 : renommez le dossier FLEXnet.

Renommez le dossier FLEXnet en FLEXnetold à l’emplacement suivant :

  • Sous Windows XP :
    C:\Documents and Settings\All Users\Application Data\FLEXnet
  • Sous Windows Vista ou Windows 7 :
    C:\ProgramData\dossier FLEXnet

Important : la suppression de ce fichier met fin à toute version d’évaluation d’Adobe et vous perdrez les jours restants.

 

Solution 4 : Réinitialisez vos autorisations concernant le dossier FLEXnet.

Fermez toutes les applications Adobe. Le dossier FLEXnet contient les données d’attribution de licence pour les applications Adobe installées. La modification des autorisations de fichier dans le dossier FLEXnet peut permettre l’écriture correcte des informations de licence. Suivez les instructions ci-dessous pour votre système d’exploitation afin de modifier les autorisations pour le dossier FLEXnet (contenant les données de service des informations de licence).

Remarque : cette solution nécessite des droits d’administrateur sur votre ordinateur. Sous Windows XP, connectez-vous à l’aide d’un compte administratif. Sous Windows 7 et Vista, fournissez des informations d’identification administratives.

Sous Windows XP Professionnel

  1. Sélectionnez Démarrer > Panneau de configuration.
  2. Cliquez deux fois sur Options des dossiers, puis cliquez sur l’onglet Affichage.
  3. Faites défiler la section Paramètres avancés jusqu’à la fin, puis désélectionnez l’option Utiliser le partage de fichiers simple (recommandé).
  4. Cliquez sur OK.
  5. Dans la fenêtre d’exploration du Panneau de configuration, cliquez sur la barre d’adresse, tapez %ALLUSERSPROFILE%\Application Data, puis appuyez sur la touche Entrée.
  6. Avec le bouton droit de la souris, cliquez sur le dossier FLEXnet et sélectionnez Propriétés.
  7. Dans la section Attributs, désactivez l’option Lecture seule.
  8. Cliquez sur Appliquer, puis cliquez sur OK pour fermer la boîte de dialogue Confirmation des modifications d’attributs.
  9. Cliquez sur l’onglet Sécurité.
  10. Veillez à ce qu’Administrateurs et System apparaissent dans la liste et à ce que les autorisations de sécurité soient configurées sur Contrôle total.
  11. Cliquez sur Avancé.
  12. Sélectionnez l’option Remplacer les entrées d’autorisations de tous les objets enfants par les entrées affichées ici et qui s’appliquent aux objets enfants.
  13. Cliquez sur l’onglet Propriétaire.
  14. Sélectionnez Administrateurs.
  15. Sélectionnez l’option Remplacer le propriétaire des sous-conteneurs et des objets.
  16. Cliquez sur OK, puis cliquez sur Oui dans la boîte de dialogue Sécurité.
  17. Cliquez sur OK pour fermer la boîte de dialogue Propriétés de FLEXnet.
  18. Lancez votre application Adobe.
 

Sous Windows XP Edition familiale

  1. Redémarrez en mode sans échec.
    1. Redémarrez Windows.
    2. Avant que Windows démarre, appuyez sur la touche F8 (lorsque vous voyez un message du type Pour options de démarrage avancées).
    3. Sélectionnez Mode sans échec dans la liste des options de démarrage.

      • Si Mode sans échec n’apparaît pas à chaque angle du Bureau, répétez les étapes 1.1 à 1.3.
      • Si Mode sans échec apparaît à chaque angle du Bureau, connectez-vous en tant qu’administrateur sur le poste local.
    4. Si une boîte de dialogue indique que Windows fonctionne en mode sans échec, cliquez sur OK.
  2. Sélectionnez Démarrer > Panneau de configuration.
  3. Cliquez deux fois sur Options des dossiers, puis cliquez sur l’onglet Affichage.
  4. Faites défiler la section Paramètres avancés jusqu’à la fin, puis désélectionnez l’option Utiliser le partage de fichiers simple (recommandé).
  5. Cliquez sur OK.
  6. Dans la fenêtre d’exploration du Panneau de configuration, cliquez sur la barre d’adresse, tapez %ALLUSERSPROFILE%\Application Data, puis appuyez sur la touche Entrée.
  7. Avec le bouton droit de la souris, cliquez sur le dossier FLEXnet et sélectionnez Propriétés.
  8. Dans la section Attributs, désactivez l’option Lecture seule.
  9. Cliquez sur Appliquer, puis cliquez sur OK pour fermer la boîte de dialogue Confirmation des modifications d’attributs.
  10. Cliquez sur l’onglet Sécurité.
  11. Veillez à ce qu’Administrateurs et System apparaissent dans la liste et à ce que les autorisations de sécurité soient configurées sur Contrôle total.
  12. Cliquez sur Avancé.
  13. Cliquez sur l’onglet Propriétaire.
  14. Sélectionnez Administrateurs.
  15. Sélectionnez l’option Remplacer le propriétaire des sous-conteneurs et des objets.
  16. Cliquez sur Appliquer et sélectionnez l’onglet Autorisations.
  17. Sélectionnez l’option Remplacer les entrées d’autorisations de tous les objets enfants par les entrées affichées ici et qui s’appliquent aux objets enfants.
  18. Cliquez sur OK, puis cliquez sur Oui dans la boîte de dialogue Sécurité.
  19. Cliquez sur OK pour fermer la boîte de dialogue Propriétés de FLEXnet.
  20. Lancez votre application Adobe.
 

Sous Windows 7 ou Windows Vista

  1. Cliquez sur Démarrer > Poste de travail.
  2. Sélectionnez Organiser > Options des dossiers et de recherche, puis cliquez sur l’onglet Affichage.
  3. Faites défiler la section Paramètres avancés jusqu’à la fin, puis désactivez l’option Utiliser l’assistant de partage (recommandé).
  4. Cliquez sur OK.
  5. Dans la fenêtre Explorateur de l’ordinateur, cliquez sur la barre d’adresse, tapez %ALLUSERSPROFILE%, puis appuyez sur la touche Entrée.
  6. Avec le bouton droit de la souris, cliquez sur le dossier FLEXnet et sélectionnez Propriétés.
  7. Dans la section Attributs, désactivez l’option Lecture seule.
  8. Cliquez sur Appliquer, puis cliquez sur OK pour fermer la boîte de dialogue Confirmation des modifications d’attributs.
  9. Cliquez sur l’onglet Sécurité.
  10. Veillez à ce qu’Administrateurs et System apparaissent dans la liste et à ce que les autorisations de sécurité soient configurées sur Contrôle total. Si tel n’est pas le cas, procédez comme suit :
    1. Cliquez sur Modifier.
    2. Si l’invite d’élévation du contrôle d’accès utilisateur s’affiche, suivez les instructions pour l’accepter.
    3. Apportez les modifications nécessaires.
  11. Cliquez sur Avancé.
  12. Cliquez sur l’onglet Propriétaire.
  13. Cliquez sur Modifier, puis acceptez l’invite du contrôle d’accès utilisateur si elle apparaît.
  14. Dans la section Modifier les propriétaires, cliquez sur Administrateurs.
  15. Sélectionnez l’option Remplacer le propriétaire des sous-conteneurs et des objets.
  16. Cliquez sur Appliquer et sélectionnez l’onglet Autorisations.
  17. Cliquez sur Modifier, puis acceptez l’invite du contrôle d’accès utilisateur si elle apparaît.
  18. Sélectionnez l’option Remplacer les entrées d’autorisations de tous les objets enfants par les entrées affichées ici et qui s’appliquent aux objets enfants.
  19. Cliquez sur OK, puis sur Oui.
  20. Cliquez sur OK, puis cliquez sur OK dans la boîte de dialogue Sécurité de Windows.
  21. Cliquez sur OK pour fermer la boîte de dialogue Paramètres de sécurité avancés de FLEXnet.
  22. Cliquez sur OK pour fermer la boîte de dialogue Propriétés de FLEXnet.
  23. Lancez votre application Adobe.
 

Solution 5 : réinitialisez vos autorisations sur le dossier Adobe PCD. 

Suivez les instructions de la Solution 4, mais appliquez-les au dossier suivant :

C:/Program Files/Common Files/Adobe PCD

Solution 6 : supprimez le fichier de journalisation SQLite.

Le fichier de journalisation n’existe que dans des cas spécifiques où un client accède au fichier de base de données avec certaines options activées. Si le fichier n’existe pas, passez à la solution suivante.

  1. Avec l’Explorateur, accédez à \Program Files\Common Files\Adobe\Adobe PCD\cache.
  2. S’il est présent, supprimez cache.db-journal.
  3. Lancez votre application Adobe.

Solution 7 : (sous Vista uniquement) synchronisez les fichiers PCD et caps virtualisés et non virtualisés.

Si vous possédez à la fois des applications compatibles et non compatibles avec Vista, cela peut entraîner la désynchronisation des fichiers dans C:\Program Files et dans l’emplacement du magasin virtuel. Pour synchroniser les dossiers, procédez comme suit :

  1. Fermez toutes les applications Adobe.
  2. Copiez le dossier Adobe PCD situé dans le répertoire C:\Program Files (x86)\Common Files\Adobe.
  3. Collez ce dossier dans C:\Users\[nom_utilisateur]\AppData\Local\VirtualStore\Program Files (x86)\Common Files\Adobe.
  4. Sélectionnez Oui pour confirmer l’invite proposant de remplacer/fusionner les fichiers existants. Dans la boîte de dialogue suivante, sélectionnez Copier et remplacer pour tous les fichiers.
  5. Redémarrez l’application.
  6. Si le problème persiste, procédez de la même manière avec le dossier « caps » (situé au même emplacement et copié dans le même emplacement).

Remarque : il est possible dans ce cas que l’application ainsi que d’autres applications Adobe vous invitent à ressaisir le numéro de série.

Vous pouvez également renommer ou supprimer les dossiers du magasin virtuel et redémarrer l’application :

  1. Fermez toutes les applications Adobe.
  2. Accédez à C:\Users\[nom_utilisateur]\AppData\Local\VirtualStore\Program Files (x86)\Common Files\Adobe.
  3. Renommez le dossier Adobe PCD (par exemple en AdobeoldPCD) ou supprimez-le.
  4. Démarrez l’application.
  5. Si le problème persiste, procédez de la même manière avec le dossier caps.

En cas d’échec des tentatives proposées ci-dessus, supprimez la clé de registre du magasin virtuel/Adobe :

  1. Fermez toutes les applications Adobe.
  2. Connectez-vous à Windows en tant qu’administrateur.
  3. Cliquez sur Démarrer > Tous les programmes > Accessoires > Exécuter et saisissez regedit.
  4. Cliquez sur le bouton Continuer dans la boîte de dialogue Contrôle de compte d’utilisateur.
  5. Effectuez une copie de sauvegarde du registre en sélectionnant Fichier > Exporter. Nommez la sauvegarde et enregistrez-la à un emplacement dont vous vous souviendrez.
  6. Cliquez avec le bouton droit de la souris sur HKEY_LOCAL_MACHINE > SOFTWARE > Classes > VirtualStore > MACHINE > SOFTWARE > Adobe.
  7. Sélectionnez Supprimer. Quittez le Registre.
  8. Démarrez l’application.

Remarque : il est possible dans ce cas que l’application ainsi que d’autres applications Adobe vous invitent à ressaisir le numéro de série.

Solution 8 : procédez à une réinstallation.

AVERTISSEMENT ! Ce processus implique que vous désinstalliez et réinstalliez entièrement tous les logiciels Adobe CS3 et CS4, ainsi qu’Acrobat 8 et 9. Des droits d’administrateur sont requis pour l’installation du logiciel Adobe. Connectez-vous à un compte d’administrateur pour effectuer les étapes ci-dessous. Reportez-vous à la documentation de votre système d’exploitation pour plus d’informations.

  1. Sélectionnez Démarrer > Panneau de configuration.
  2. Cliquez deux fois sur Programmes et fonctionnalités (Windows 7/Vista) ou sur Ajout/Suppression de programmes (XP).
  3. Sélectionnez votre produit Adobe et cliquez sur Modifier/Supprimer.
  4. Suivez les instructions à l’écran pour supprimer l’application.
  5. Répétez les étapes 3 et 4 pour les autres produits Adobe CS3/CS4 et Acrobat 8/9.
  6. Supprimez les dossiers suivants :
    C:\Program Files\Common Files\Adobe\Adobe PCD
    C:\Program Files\Common Files\Adobe\caps
    C:\Program Files\Common Files\Adobe\backup

  7. Cliquez sur Démarrer > Arrêter, sélectionnez Redémarrer, puis cliquez sur OK.
  8. Installez les produits Adobe à partir du support d’origine.
  9. Lancez les produits Adobe.

Solution 9 : contactez le support technique d’Adobe.

Le support technique d’Adobe peut obtenir des journaux de votre ordinateur pour obtenir des informations supplémentaires sur le problème. Contactez le support technique d’Adobe si les informations fournies ne vous ont pas aidé à résoudre votre problème.

Informations supplémentaires

Divers problèmes peuvent être à l’origine de cette erreur, dont les suivants :

  • Si l’erreur se produit immédiatement après l’installation, un composant doit parfois être mis à jour pour être compatible avec votre système d’exploitation. Le composant peut également nécessiter une configuration légèrement différente pour votre système.
  • Si l’application a précédemment démarré correctement au moins une fois ou a été utilisée de façon intensive, le problème est probablement lié à une ressource système.  (La cause peut être un manque de mémoire ou d’espace disque, ou encore le lancement simultané de plusieurs programmes.) Cela peut résulter en une panne temporaire dans le système d’attribution de licence ou en la corruption des données de licence permanentes.
  • Si une interruption s’est produite pendant le processus d’installation, il se peut qu’elle empêche le fonctionnement correct du système d’attribution de licence.
  • Si vous avez précédemment participé à un programme de test de version préliminaire, vous disposez éventuellement d’un numéro de série temporaire destiné à expirer. Dans ce cas, voir Erreur « L’obtention de licence pour ce produit a expiré » | CS4, CS5.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne