Vous consultez actuellement l'aide de la version:

Adobe évalue constamment les fonctionnalités du produit et prévoit au fil du temps de remplacer certaines d’entre elles par des versions plus puissantes, ou décide de mettre à nouveau en œuvre certaines parties pour mieux se préparer aux attentes ou aux extensions futures.

La compatibilité descendante est essentielle lors du remplacement de fonctionnalités, car elle permet de garantir que l’investissement de nos clients dans nos technologies est protégé.

En général, les fonctionnalités sont d’abord annoncées comme obsolètes, puis supprimées dans la version suivante. Cela laisse au moins un cycle de mise à jour aux clients pour adapter leur mise en œuvre à la nouvelle version de la fonctionnalité avant que celle-ci ne soit supprimée.

Modifications touchant les clients qui procèdent à la mise à jour

La liste suivante répertorie les modifications qui ont une incidence directe sur les clients après la mise à jour vers AEM 6.3. Il s’agit de comportements modifiés qui peuvent nécessiter des changements dans la mise en œuvre du projet.

Zone Fonctionnalité
Modification

Fonctionnalités obsolètes

Cette section répertorie les fonctionnalités qui ont été signalées comme obsolètes dans AEM 6.3. En général, les fonctionnalités qui seront supprimées dans une prochaine version sont d’abord annoncées comme obsolètes, et une alternative est fournie.

Il est conseillé aux clients de réfléchir à leur utilisation de la fonctionnalité dans leur déploiement actuel et de prévoir la modification de leur mise en œuvre de façon à utiliser l’alternative proposée.

Zone Fonctionnalité Remplacement
Foundation Composants UI Shell 2.0 Composants UI Shell 3.0 introduits avec AEM 6.2
Foundation Composants obsolètes des formulaires de l’UI renderReadOnly on Granite UI Shell 3.0 n’utilise plus cette option
Foundation Coral 3 coralui-component-badge obsolète Utilisez coral-tag à la place
Foundation Explorateur de chemins d’accès Coral 3 obsolète Utilisez foundation-picker à la place
Foundation Sélectionneur de balises Coral 3 obsolète
/libs/cq/gui/components/common/tagspicker
Utilisez /libs/cq/gui/components/common/coral/form/tagfield
Foundation Sélectionneur d’utilisateurs Coral 3 obsolète
/libs/granite/ui/components/coral/foundation/form/userpicker
Utilisez /libs/granite/ui/components/coral/foundation/authorizable/autocomplete
Foundation granite.ui.quickactions clientlib obsolète Utilisez coral-quickactions
Foundation granite.ui.notifications clientlib obsolète Utilisez foundation-ui
Foundation Pont d’événements Sling obsolète Adobe recommande vivement d’utiliser à la place le tableau blanc ResourceChangeListener optimisé en termes de performances.
Processus IU de notification utilisée entre 5.6-6.2
(/libs/cq/workflow/content/notifications.html)
Boîte de réception des processus /aem/inbox
Processus Liste des tâches du projet utilisée entre 6.0 et 6.2
(/libs/cq/core/content/projects/showtasks.html)
Boîte de réception des processus /aem/inbox
IU classique Boîte de réception des notifications relatives aux événements JCR dans l’IU classique
(/libs/wcm/core/content/inbox.html)
Recently changed/visited rail.
Sites Redirection côté serveur obsolète en fonction des fonctionnalités du dispositif en utilisant WURFL com.day.cq.wcm.mobile.core.impl.redirect.RedirectFilter  
Sites Composants obsolètes Foundation /libs/foundation/components/mobile* Utilisez les composants principaux
Sites IU Gestion des campagnes marketing dans l’IU classique obsolète Utilisez l’IU Bibliothèque d’offres
Sites Composants obsolètes /libs/mcm/components/cta* Utilisez les composants principaux
Sites Composants obsolètes /libs/mcm/components/newsletter Remplacés par /libs/mcm/campaign/components
Sites Importateur hors ligne hérité obsolète dans l’IU classique Aucun remplacement
Assets API héritée obsolète permettant de gérer la migration des ressources de /var/dam vers /content/dam utilisée dans CQ 5.4 Aucun remplacement requis
Commerce Importateur de produits obsolète de l’IU classique Utilisez la nouvelle IU
Commerce Importateur de catalogues obsolète de l’IU classique Utilisez la nouvelle IU
Applications mobiles Cessez d’utiliser /content/phonegap Utilisez /content/mobileapps à la place
Applications mobiles Cessez d’utiliser /etc/clientlibs/mobile/content-sync Utilisez /etc/clientlibs/mobile/content-sync-2 introduit dans AEM 6.2 à la place
Applications mobiles Cessez d’utiliser les services de notifications Pushwoosh et Amazon SNS Utilisez le SDK AEM Mobile et sa prise en charge des notifications
Communities Composant Connexion sociale obsolète.  

Fonctionnalités supprimées

Cette section répertorie les fonctionnalités qui ont été supprimées d’AEM 6.3. Ces fonctionnalités ont été marquées comme obsolètes dans les versions antérieures.

Zone Fonctionnalité Remplacement
Intégrations à Marketing Cloud

Intégration héritée supprimée avec Adobe Audience Manager

  • Balisage intégré de page d’AAM JS
  • Règles côté client via des segments AAM synchronisés

Adobe recommande d’utiliser l’intégration de nouvelle génération qui utilise le service d’identification de l’utilisateur :

  • Balisage de pages par le biais de la gestion dynamique des balises (fonctionne depuis la version 6.0)
  • Règles côté client : remplacées par l’intégration côté serveur entre Adobe Target et AAM.
Intégrations à Marketing Cloud Suppression du composant Mbox globale Il est recommandé de passer à la diffusion basée sur la gestion dynamique des balises d’Adobe Target et d’utiliser at.js
Intégrations à Marketing Cloud Suppression de la fonction Publier l’offre Adobe Target héritée utilisée dans l’intégration de 1ère génération Il est recommandé d’utiliser l’intégration d’Adobe Target telle qu’introduite avec AEM 6.2
Intégrations à Marketing Cloud Suppression de l’importateur d’impressions Adobe Analytics hérité et de l’intégration à SAINT

Le remplacement de ImpressionsImporter est ReportImporter

L’intégration à SAINT utilise ClassificationsService/ClassificationsTransformer

Foundation

Lors de la mise à jour vers la version 6.3, plusieurs index de recherche ne seront plus utilisés :

  • profils
  • slingResource
  • damResolvedPath
  • utilisateurs
  • groupes
 
Foundation Suppression du servlet Sling Background (org.apache.sling.bgservlets) Utilisez le mécanisme de tâches Sling à la place. Voir les documents Apache Sling
Foundation Suppression du gestionnaire de bibliothèques HTML hérité  
Foundation Suppression du com.day.cq.theme hérité  
Foundation Suppression de granite.ui.utils.clientlib inutilisé et de Coral.Colorpicker de granite.u.coralui3  
Foundation Suppression des pages de connexion CQ héritées.  Elles ont été mises hors service dans la version 5.5 de CQ. Adobe recommande d’utiliser les composants et les pages de connexion Granite.
Foundation Suppression des API de sécurité héritées L’API com.day.cq.security.* a été mise hors service dans la version 5.5 de CQ, car elle a été attribuée à Apache Foundation. Adobe recommande de restructurer le code personnalisé et de passer à org.apache.jackrabbit.api.security.*
Foundation Suppression de com.adobe.sightly.engine L’API com.adobe.sightly.engine a été mise hors service dans la version 6.1 d’AEM, car elle a été donnée à la Fondation Apache. Elle a été remplacée à l’identique par org.apache.sling.scripting.sightly
Foundation Suppression de com.adobe.cq.sightly.WCMUse 
Restructurez le code pour passer de WCMUse à com.adobe.cq.sightly.WCMUsePojo
Foundation Suppression des prédicats de recherche hérités utilisés dans l’interface utilisateur tactile des versions 5.6 et 6.0. De plus, la logique de mise à niveau des versions utilisée pour les réécrire au nouveau format dans la version 6.1 a été supprimée.  
Sites Suppression du service de statistiques CQ hérité. Il s’agit du servlet effectuant le suivi des impressions de page qui s’affichent dans l’IU d’administration de site classique. Il est recommandé d’utiliser la version intégrée d’Adobe Analytics pour mesurer l’efficacité du contenu. Contactez votre gestionnaire de compte Adobe pour découvrir si vous pouvez bénéficier d’Adobe Analytics Essentials.
Sites Suppression du com.day.cq.wcm.api.msm hérité A été mis hors service en 2010.
Sites Suppression de l’IU Éditeur de manuscrits AEM 6.2 a introduit les fragments de contenu qui remplacent les manuscrits. 
Sites Suppression de l’IU Importateur de sites de l’IU classique. Cette fonctionnalité a été développée à l’origine pour créer un POC rapide afin d’obtenir un modèle à partir de sites hébergés en externe.  
Assets Suppression de l’API et des processus hérités de l’intégration de Scene 7 à partir de la version 5.6.1. N’est plus utilisée depuis la version 6.1  
Intégration à DPS Classic Suppression de l’IU de publication permettant de gérer le contenu des applications DPS Classic. Les clients qui ont encore besoin de l’intégration d’AEM à DPS Classic peuvent tirer parti de l’interface utilisateur classique d’AEM.
Échantillon Les sites Geometrixx ont été entièrement supprimés d’AEM 6.3 AEM 6.3 est livré avec un nouvel ensemble d’exemples de sites, représentant les moyens de pointe permettant de tirer parti d’AEM pour Sites, Communities, Assets et Mobile.

Annonce préalable à la prochaine version

Cette section vise à annoncer les modifications à venir dans la prochaine version, qui ne sont pas obsolètes, mais qui auront une incidence sur les clients. Elles sont fournies à des fins de planification.

Zone
Fonctionnalité
Annonce
Langage Java
Java VM AEM 6.3 est la dernière version prenant en charge Java 7. La version 2018 de Java 8 est la machine virtuelle Java minimale prise en charge
Serveurs d’applications Servlet API AEM 6.3 est la dernière version qui prend en charge Servlet API 3.0. La version 2018 d’AEM exigera au minimum Servlet API 3.1. En outre, l’ancienne version des serveurs d’applications web devra être mise à niveau vers une version prenant en charge l’API Servlet 3.1 ou version ultérieure
Serveur web du répartiteur
Oracle iPlanet D’ici la fin de l’année 2017, Adobe ne prendra plus en charge Oracle iPlanet Web Server 7.
Serveur web du répartiteur Apache 2.2 Adobe supprimera la prise en charge d’Apache httpd 2.2 après décembre 2017 et recommande de passer à Apache httpd 2.4. Si vous restez sur la version Apache 2.2 après décembre 2017, il est recommandé d’utiliser une distribution Linux qui prend en charge les mises à jour de sécurité d’Apache 2.2. La dernière version 2017 du répartiteur pour Apache 2.2 restera disponible en téléchargement jusqu’à la fin de l’année 2018.
Foundation Structure de l’IU Adobe prévoit de mettre hors service l’interface utilisateur classique en 2018. Adobe recommande à ses clients de planifier une mise à jour vers AEM 6.3, puis de passer à l’utilisation de la nouvelle interface utilisateur. En 2017, Adobe a fourni un outil pour aider à convertir les boîtes de dialogue de composants de l’interface utilisateur classique en Coral 3.
Foundation Structure de l’IU Adobe prévoit de mettre hors service les composants de l’UI Coral 2 en 2018. L’UI Coral 3 a été introduite avec AEM 6.2, et AEM 6.3 est entièrement basé sur Coral 3. Adobe recommande à ses clients et partenaires qui ont créé des interfaces utilisateur personnalisées avec Coral 2 de les restructurer avec Coral 3. En 2017, Adobe a fourni un outil pour aider à convertir les boîtes de dialogue de composants de l’interface utilisateur classique de Coral 2 à Coral 3.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne