La redirection SAML à la page d’origine ne fonctionne pas | AEM 6.x

Problème

Dès qu’un utilisateur est connecté au fournisseur de données pour la connexion SSO SAML, l’utilisateur n’est pas redirigé vers la page d’origine. Le chemin saml_sollicité n’est pas respecté lors de la connexion.

Environnement

AEM 6.x

Cause

Si SSL est arrêté à l’équilibreur de charge, un problème connu empêche la redirection SAML de la page d’origine.

Résolution

En supposant que la connexion HTTPS (SSL) se termine au niveau de l’équilibreur de charge, les étapes suivantes permettent de garantir que le paramètre saml_request_path n’est pas perdu.

  1. Accédez à http://aem-host:port/system/console/configMgr/org.apache.felix.http.sslfilter.SslFilter et connectez-vous en tant qu’administrateur.

  2. Configurez les valeurs dans la Configuration du filtre SSL du service Apache Felix, avec les en-têtes que l’équilibreur de charge utilise pour indiquer aux systèmes finaux que la demande était une demande SSL. Par exemple, les équilibreur de charge Amazon ELB utilisent ces valeurs :

    SSL forward header : X-Forwarded-Proto

    Valeur en avant SSL : https

    Pour plus d’informations sur la terminaison SSL au niveau des CDN, des proxies et des équilibreurs de charges, voir l’article sur la solution.

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