Accédez à l'URL suivante et connectez-vous en tant qu'administrateur : http://aem-host:port/system/console/configMgr/com.day.crx.security.token.impl.impl.TokenAuthenticationHandler
Problème
Dans AEM, lorsque Token Refresh est activé sur la configuration Apache Jackrabbit Oak Token Configuration OSGi [1], le jeton de connexion n'est pas actualisé. Ce problème concerne à la fois LDAP et SAML 2, l'authentification par jeton par défaut.
[1]
http://aem-host:port/system/console/configMgr/org.apache.jackrabbit.oak.security.authentication.token.TokenConfigurationImpl
Cause
L'actualisation du jeton de connexion échoue en raison d'une fausse idée du fonctionnement de l'actualisation du jeton ou de si le jeton encapsulé est activé.
Résolution
Vérifiez si la prise en charge des jetons encapsulés est activée. Au moment de la rédaction de cet article (AEM v6.0-6.3), le mécanisme de connexion au jeton encapsulé ne prenait pas en charge l'actualisation des jetons.
-
-
Voir si Activer le support de jeton encapsulé est activé.
Si la prise en charge des jetons encapsulés n'est pas activée, il est probable que l'actualisation des jetons fonctionne, mais elle ne fonctionne pas comme prévu. Lorsque les utilisateurs se connectent, le jeton ne s'actualise pas à moins que les utilisateurs n'accèdent au système après la moitié de la durée d'expiration du jeton configurée dans Oak Token Configuration [1]
Par exemple, si l'expiration est définie sur deux heures, l'utilisateur peut utiliser le système pendant toute la première heure. Cependant, s'ils n'accèdent pas au système après une heure, le jeton ne s'actualisera pas. Ensuite, ils doivent se connecter à nouveau après deux heures de connexion. Toutefois, s’ils se connectent, attendent une heure et accèdent à nouveau au système, leur jeton s’actualise pour que la session soit étendue.
Adobe
Recevez de l’aide plus rapidement et plus facilement
Nouvel utilisateur ?