Context

Gold Standard 11 has been released on December 22, 2020. It comes with major fixes which impact both services and security. Learn more in Gold Standard 11 release notes.

All Campaign Gold Standard hosted instances will be upgraded to this new build by Adobe. For on-premise and hybrid customers, Adobe highly recommends customers to upgrade their environments.  You will find below guidance for this procedure and useful links.

Let op:

As a non-Gold Standard user, it is mandatory to upgrade to one of the latest versions below, which include the latest security fix and the new authentication protocol for connecting through IMS:

Frequently Asked Questions

Gold Standard 11 is a mandatory upgrade. All the customers who are on Gold Standard 10 and earlier versions must upgrade to Gold Standard 11.

Gold Standard 11 comes with a security fix which is mandatory for all Adobe Campaign Classic customers to fix certain identified vulnerabilities

Moreover, Gold Standard 11 ensures the continuity of certain Campaign services: Experience Cloud Triggers integration, APNs authentication and the new connection protocol which impacts Adobe Identity Management Service (IMS) authentication mechanism. For details, please refer to Gold Standard 11 release notes.

As for every Campaign upgrade, maximum interruption of service is of 2 hours. Though, for most of the customers we expect it to be around one hour.  Learn more in this page.

Implementation steps depend on the hosting model:

  • For hosted customers, Adobe will upgrade the instances to Gold Standard 11. 
    No specific action required for the customers.

  • For hybrid customers, Adobe will upgrade the mid-sourcing instance to Gold Standard 11 and customers are highly recommended to upgrade their marketing instance to Gold Standard 11.
    The new build is compatible with at least Campaign Classic 17.9 release, but to prevent any security gap, Adobe strongly recommends to upgrade all instances to Gold Standard 11.  

  • On-premise customers are requested to upgrade marketing and mid-sourcing instances to Gold Standard 11. 

Let op:

As an on-premise or hybrid customer, if you are already running on a 9032 build, you need to force postupgrade. To perform this, use the following command:

nlserver config -postupgrade -instance:<instance_name> -force

Triggers integration authentication, originally based on oAUTH authentication setup to access pipeline, has moved to Adobe I/O. Learn more

Once the instances are upgraded, all customers need to follow the steps listed hereto move to the new authentication mode. - This requires to generate the new Adobe I/O token and use it in the implementation.    

In addition, for hybrid environments, customers need to ensure that pipeline is configured on mid-sourcing instance. Learn more.

This release comes with a new connection protocol: upgrade is mandatory for both Campaign server and client console to be able to connect to Campaign after June 30, 2021.

Once all instances are upgraded, the client console needs to be upgraded to this version as well.

> Learn how to access Adobe Software Distribution.

> Learn how to install Campaign Client console.

The Apple Push Notification service (APNs) will no longer support the legacy binary protocol as of March 31st, 2021. Campaign Classic push notification deliveries based on this protocol will then stop working after this date.

The HTTP/2-based APNs provider API is the new default protocol. Once all instances are upgraded to Gold Standard 11, push notification external account settings for iOS are automatically updated to the new protocol with no additional actions. Learn more.

Learn more