Issue

Some OSGi configurations and bundles uploaded to /apps under an install folder or config folder are not applied.

Environment

AEM 6.x

Cause

Following few causes are responsible for the issue.

  1. The install or config folder is deeper in the folder tree than four levels of depth. Files at a level deeper than this level are not installed.
  2. The configuration or bundle is malformed or corrupted.
  3. The install or config folder has a runmode in the name that does not apply to the instance. For example, config.publishqa or install.publishstage.

The OSGi installer is in an inconsistent state.

Resolution

  1. If the install or config folder is at a level of depth greater than four. For example /apps/sites/siteA/jars/install/foo-1.0.0.jar would not get installed, but /apps/siteA/install/foo-1.0.0.jar would get installed.
  2. To see if there are errors and to validate that your configuration or bundle is not malformed, review the error.log.
  3. If there is a runmode in the folder name, go to http://host:port/system/console/status-slingsettings on the AEM instance and validate that the correct runmode is applied.
  4. If you suspect the OSGi installer is malfunctioning, then see this article for steps to fix the issue.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid