Gebruikers van het Linux-besturingssysteem 10.x en 11.x krijgen soms een leeg of zwart scherm te zien met Flash Player 11 wanneer ze beveiligde video-inhoud afspelen. (Dit probleem doet zich bijvoorbeeld voor bij services zoals Amazon Instant Video.) Dit gedrag wordt veroorzaakt door een ontbrekende Ubuntu HAL-module (Hardware Abstraction Layer). Deze module is niet standaard geïnstalleerd. Als de leverancier een foutbericht ontdekt, krijgen gebruikers DRM-fout 3323 of 3322 te zien.

Voorwaarden voor het afspelen van beveiligde inhoud

Zorg voor Ubuntu 10.04 of later dat de HAL-module eerst is geïnstalleerd aan de hand van apt-get.
(Vermijd HAL-installatiefouten, want een beschadigde installatie van het pakket kan het afspelen van video's blijven beïnvloeden.)

sudo apt-get install hal

Zodra de “libhal” (HAL)-bibliotheek is geïnstalleerd, sluit u de browser en maakt u de Adobe Access-mappen leeg door de volgende shell-opdrachten uit te voeren:

cd ~/.adobe/Flash_Player
rm -rf NativeCache AssetCache APSPrivateData2

Opmerking:

Als de HAL-module ontbreekt, werkt Flash Player nog steeds. Het kan echter geen beveiligde inhoud die de Adobe Flash Access DRM-module (Digital Rights Management) vereist, afspelen.

Ondersteuning voor 64-bits doelversies van Linux

Adobe publiceert ondersteuning voor het 32-bits en 64-bits Linux-platform in de sectie met systeemvereisten van de Flash Player 11-site. De distributies (32-bits en 64-bits) die momenteel ondersteund worden, zijn Redhat Enterprise Linux 5.6 of later en Ubuntu 10.04 of later.

openSUSE wordt ook ondersteund.

Installeer de juiste 32-bits of 64-bits plug-in van Flash Player.

Surf naar http://www.adobe.com/go/flashplayer om de nieuwste Flash Player voor uw platform en architectuur te installeren.

Als u niet zeker weet welk Linux-pakket u moet installeren, klikt u op Hebt u een ander besturingssysteem of andere browser? voor meer besturingssystemen.

openSUSE en andere Linux-versies

In sommige Linux-distributies, met name openSUSE, worden pakketten op een aparte manier beheerd. openSUSE gebruikt RPM als een systeemeigen pakketindeling. Het maakt echter gebruik van een eigen geavanceerd hulpprogramma om de installatie van de systeemsoftware te beheren.
.rpm-installaties op openSUSE (32-bits en 64-bits) zijn onvoorspelbaar. Soms geven ze de volgende fout weer: “Bericht heeft geen antwoord ontvangen (time-out door Message Bus)”.

In dergelijke gevallen downloadt u het archief .tar.gz en verplaatst u Flash Player (libflashplayer.so) naar deze locatie:

/usr/lib/adobe-flashplugin/libflashplayer.so

Beveiligde video-inhoud proberen afspelen met de demospeler

  1. Open de container van de Adobe-demovideospeler: http://drmtest2.adobe.com:8080/SVP/SampleVideoPlayer_FP.html
     
      Let op de Adobe Flash Player-versie in de onderste helft van de demovideo-shell. Zorg ervoor dat versie 11.2 of hoger wordt vermeld
       
  2. Speel de beveiligde voorbeeldinhoud af.
     
      Voer de volgende URL in in het veld 'Voer de video-URL in: (hoofdlettergevoelig)'
      http://drmtest2.adobe.com:8080/Content/anonymous.f4v
       
  3. Klik op de knop [Afspelen] onder aan de videocontainer.

De beveiligde inhoud anonymous.f4v wordt nu afgespeeld. (Deze video wordt de Getty “train”-video genoemd.)

 

Van toepassing op de volgende producten

Adobe Flash Player 11, Flash Access (FAXS), Ubuntu 10.x & 11.x Linux

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid