Потребителите на операционни системи Ubuntu 10.x и 11.x Linux понякога виждат празен или черен екран с Flash Player 11, когато възпроизвеждат защитено видео съдържание. (Например този проблем възниква при услуги като Amazon Instant Video.) Това поведение е причинено от липсващ модул HAL (Слой за хардуерна абстракция) на Ubuntu, който не се инсталира по подразбиране. Ако доставчикът показва съобщения за грешка, потребителите виждат DRM грешка 3323 или 3322.

Предварителни условия за възпроизвеждане на защитено съдържание

При Ubuntu 10.04 или по-нова версия първо се уверете, че модулът Слой за хардуерна абстракция е инсталиран, с помощта на apt-get.
(Наблюдавайте внимателно за грешки при инсталирането от тип „hal”, тъй като инсталирането на повреден пакет може да продължи да пречи на възпроизвеждането на видео.)

sudo apt-get install hal

След завършване на инсталирането на библиотеката „libhal” (HAL), затворете браузъра и изчистете директориите на Adobe Access, като изпълните следните Shell команди:

cd ~/.adobe/Flash_Player
rm -rf NativeCache AssetCache APSPrivateData2

Бележка:

Ако модулът Слой за хардуерна абстракция липсва, Flash Player все още работи. Въпреки това, той не може да възпроизвежда защитено съдържание, изискващо модул DRM (Управление на правата за достъп) на Adobe Flash Access.

Поддръжка за целеви 64-битови версии на Linux

Adobe публикува поддръжка за платформи за 32-битов и 64-битов Linux в раздела за системни изисквания в сайта на Flash Player 11. Текущо поддържаните дистрибуции (32 бита и 64 бита) са Redhat Enterprise Linux 5.6 или по-нова и 10.04 или по-нова.

Поддържа се и openSuse.

Инсталиране на подходящата 32-битова или 64-битова корекция за Flash Player

Отидете до http://www.adobe.com/go/flashplayer_bg, за да инсталирате най-новата версия на Flash Player за вашата платформа и архитектура.

Ако не сте сигурни кой пакет на Linux да инсталирате, щракнете върху Имате ли различна операционна система или браузър? за повече варианти на операционни системи.

openSuse и други версии на Linux

Някои дистрибуции на Linux имат свой собствен начин за управление на пакети, особено openSUSE. openSUSE използва RPM като свой основен формат на пакет. Въпреки това, той има свой собствен инструмент от високо ниво за управление на инсталирането на системен софтуер. 
.rpm инсталациите в openSuse (32 бита и 64 бита) са неустойчиви. Те понякога причиняват обща грешка „Съобщението не получи отговор (време на изчакване от шина на съобщения)”.

В тези случай изтеглете архива .tar.gz и поставете Flash Player (libflashplayer.so) на следното място:

/usr/lib/adobe-flashplugin/libflashplayer.so

Тестване на възпроизвеждането на защитено видео съдържание с помощта на демо плейъра

  1. Стартирайте контейнера на демо видео плейъра на Adobe: http://drmtest2.adobe.com:8080/SVP/SampleVideoPlayer_FP.html
     
      Отбележете версията на Adobe Flash Player в долния ляв ъгъл на обвивката на демо видеото. Уверете се, че е посочена версия 11.2 или по-нова
  2. Възпроизведете просто защитено съдържание.
     
      Въведете следния URL в полето „Въвеждане на URL на видео: (чувствителност към малки и главни букви)
      http://drmtest2.adobe.com:8080/Content/anonymous.f4v
       
  3. Натиснете бутона [Play] (Възпроизвеждане) в долната част на видео контейнера.

Защитеното съдържание anonymous.f4v се възпроизвежда. (Това видео се нарича „Видео от влак на Гети”.)

 

Засегнати продукти

Adobe Flash Player 11, Flash Access (FAXS), Ubuntu 10.x & 11.x Linux

Този материал е лицензиран под лиценз Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  Публикациите в Twitter™ и Facebook не попадат под клаузите на Creative Commons.

Правни бележки   |   Правила за онлайн поверителност