Sintomas
Ao criar um usuário (via CQ ou LDAP), ele não consegue acessar sua Caixa de entrada de notificação, a menos que seja membro do grupo de administradores de usuários (ou administradores privilegiados). Qual permissão é necessária para que o usuário veja sua Caixa de entrada de notificação sem ter privilégios de administração de usuário?
Além disso, ocorre o seguinte erro no log quando o usuário tenta acessar a Caixa de entrada de notificações:
26.10.2009 15:42:41.833 *ERRO* [127.0.0.1 [1256586161833] GET /bin/wcm/notification/inbox/messages.json HTTP/1.1] com.day.cq.wcm.notification.inbox.impl.InboxServlet Não é possível consultar a caixa de entrada do usuário xxxxxx javax.jcr.AccessDeniedException: xxxxxx não pode acessar o UserManager
Causa
Por padrão, um usuário tem permissão total para acessar sua pasta inicial no espaço de trabalho crx.default. Usuários padrão não têm acesso ao espaço de trabalho crx.system
. Ao acessar a Caixa de entrada de notificações, há uma verificação adicional no código que lança uma AccessDeniedException se o usuário não tem acesso ao espaço de trabalho crx.system
.
Portanto, somente usuários que são membros dos grupos (1) administradores, (2) administradores privilegiados ou (2) administradores de usuários não poderão alterar sua Caixa de entrada de notificações.
Solução
A solução alternativa atual é criar um novo grupo e conceder acesso ao espaço de trabalho crx.system. O usuário deve ser adicionado a este grupo.
- Acesso ao espaço de trabalho
crx.system
com a conta de administrador - Abra o Explorador de conteúdo
- Navegue até "
/rep:workspaces/crx.system
" - Use o botão "Segurança" para permitir que o novo grupo acesse este repositório
Aplica-se a
CQ 5.2.1
Fazer logon em sua conta