InvalidFileStoreVersionException migrando da versão antiga para 6.3 usando o CRX2Oak

Problema

Ao migrar conteúdo do AEM 6.0, 6.1 ou 6.2 para o AEM 6.3 usando o utilitário CRX2Oak, o erro abaixo é observado:

22.08.2017 11:25:16.256 ERRO c.a.g.c.c.MigrationSpecGenerator: erro de E/S durante o processamento da especificação de migração: org.apache.jackrabbit.oak.segment.file.InvalidFileStoreVersionException: usando oak-segment-tar, mas o segmento do aok deve ser usado

Ambiente

O CRX2Oak-1.6.x é usado para migrar do AEM6.0-6.2 para o 6.3 ou versão futura.

Causa

Parâmetro ausente no comando CRX2Oak.

Resolução

Adicione "segment-old:" antes do caminho de origem no comando CRX2Oak como este (consulte o texto destacado abaixo):

java -Xmx1g -jar crx2oak-1.6.8-all-in-one.jar --include-paths=/content/geometrixx segment-old:/opt/old-aem/repository /opt/aem63/crx-quickstart/repository

Logotipo da Adobe

Fazer logon em sua conta