O AsyncIndexUpdate está falhando

Causa

Há muitas causas para os índices assíncronos não serem atualizados no AEM.

Algumas causas possíveis são:

  • Um arquivo de índice de lucene está corrompido
  • A corrupção do repositório Oak, causando erros durante a indexação

Resolução

O primeiro passo para resolver esse problema é depurar a causa principal.  Depois de conhecer a causa principal, é possível decidir se a reindexação é necessária ou não.

Nas versões do AEM anteriores ao 6.2, todos os índices usavam uma faixa "async".  O status dessa faixa de índice pode ser visualizado no IndexStats MBean:

http://aem-host:port/system/console/jmx/org.apache.jackrabbit.oak%3Aname%3Dasync%2Ctype%3DIndexStats

Na AEM6.2, existem duas faixas de índice:

  • "fulltext-async" usado por /oak:index/lucene index - http://aem-host:port/system/console/jmx/org.apache.jackrabbit.oak%3Aname%3Dfulltext-async%2Ctype%3DIndexStats
  • "async" usado por todos os outros índices de lucene - http://aem-host:port/system/console/jmx/org.apache.jackrabbit.oak%3Aname%3Dasync%2Ctype%3DIndexStats

É possível visualizar os IndexStats MBeans para ver o status de indexação e identificar se falhou ou se está demorando muito tempo.

Os campos-chave que devem ser referenciados são:

  • LatestError - se estiver falhando, este é o erro que está causando o problema na indexação.
  • LatestErrorTime - o horário em que o erro ocorreu.
  • LastIndexedTime - a última vez em que um ciclo de indexação foi bem-sucedido.


Se um erro listado no LatestError for identificado, é necessário corrigir isso para que a indexação funcione novamente.  Se houver dúvidas com relação aos próximos passos para resolver o problema, entre em contato com o Atendimento ao Cliente da AEM.

Logotipo da Adobe

Fazer logon em sua conta