As traduções do i18n não estão mais funcionando

Causa

Pode haver várias causas para esse problema.  Neste artigo, nos concentraremos em uma causa conhecida, na qual as ACLs do usuário do serviço sling-i18n são excluídas. Isso geralmente acontece quando um pacote do ACL é instalado a partir de outro ambiente.

Resolução

Verifique se o usuário do serviço sling-i18n tem acesso de leitura no nó raiz /

  1. Vá para http://host:port/crx/explorer/index.jsp
  2. Faça o logon como admin
  3. Abra o Explorador de Conteúdo
  4. Clique no nó raiz - /
  5. Na navegação superior, selecione Segurança => Editor de Controle de Acesso (o botão de Segurança é uma imagem de um cofre)
  6. Verifique se o usuário do sling-i18n tem acesso de leitura concedido.  Caso contrário, siga os passos abaixo.

Corrigir os ACLs do usuário do serviço:

  1. Instale o ACS Commons caso ele ainda não esteja instalado. Você precisará usar o ACS Commons ACL Packager.
  2. Use o ACL Packager para criar um pacote de backup de todos os ACLs de um ambiente corrompido.  Antes de criar o pacote, edite sua configuração, vá para a guia Avançado e defina Manuseio de AC para o modo Mesclar.
  3. Instale uma nova instância do AEM com todos os mesmos patches (pacotes de serviço, hotfixes, etc.).
  4. Crie um pacote com o modo de mesclagem dos ACLs a partir das novas instâncias.
  5. Construa o pacote com modo de mesclagem também.
  6. Baixe o pacote.
  7. Instale em um ambiente corrompido. Reinstale o pacote ACL da etapa 1.  
  8. A reinstalação do pacote reordena os ACLs personalizados para o final da lista, garantindo que os ACLs personalizados não sejam substituídos pelos ACLs prontos para uso.

Depois que o ACL for solucionado, uma etapa final será necessária.

  • Vá para /system/console/bundles e reinicie o pacote "Apache Sling Internationalization Support"
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