Pare o AEM
Problema
Esse aviso se repete nos arquivos de log do AEM:
23.03.2017 07:49:59.379 *WARN* [pool-8-thread-3] org.apache.jackrabbit.oak.spi.query.Cursors$TraversingCursor Traversed 2993000 nodes with filter Filter(query=select [jcr:path], [jcr:score], * from [dam:Asset] as a where [jcr :content/metadata/prism:expirationDate] > cast('2017-03-22T07:00:00.000Z' as date) and [jcr:content/metadata/prism:expirationDate] < cast('2017-03-23T07:00:00.001Z' as date) and isdescendantnode(a, '/content/dam') /* xpath: / jcr:root/content/dam//element(*, dam:Asset)[(jcr:content/metadata/@prism:expirationDate > xs:dateTime('2017-03-22T07:00:00.000Z') and jcr:content/metadata/@prism:expirationDate < xs:dateTime('2017-03-23T07:00:00.001Z'))] */, path=/content/dam//*, property=[jcr:content/metadata/prism:expirationDate=[(2017-03-22T07:00:00.000Z.., ..2017-03-23T07:00:00.001Z)]]); consider creating an index or changing the query
Essa mensagem de aviso significa que algo está errado na instância do AEM em que o índice /oak:index/damAssetLucene não está funcionando. Isso faz com que a consulta acima faça uma passagem em vez de usar o índice damAssetLucene.
Ambiente
Causa
Algo está errado com o índice /oak:index/damAssetLucene. Você precisaria investigar os arquivos de log e procurar por "damAssetLucene" para descobrir a causa raiz exata.
Resolução
A. Investigue a causa raiz
Pesquise no error.log e em quaisquer outros logs de indexação configurados para "damAssetLucene". Investigue em qualquer mensagem de nível ERROR ou WARN para ver se elas são a causa do problema.
Por exemplo, no caso de um cliente, essa foi a causa do problema:
22.03.2017 12:46:45.205 *ERROR* [Thread-44] org.apache.jackrabbit.oak.plugins.index.lucene.IndexTracker Could not access the Lucene index at /oak:index/damAssetLucene java.io.FileNotFoundException: [/oak:index/damAssetLucene] segments_8o28
B. Tente reconstruir a cópia do índice local
-
-
Exclua crx-quickstart/repository/index
-
Iniciar o AEM
-
Teste novamente
C. Decida se deve ou não reindexar
Se a recriação da cópia do índice local não resolver o problema, entre em contato com o Atendimento ao Cliente do AEM para depurar mais e decidir se você precisa reindexar o índice /oak:index/damAssetLucene.