Atualize a barra de lançamento para as versões oficiais mais recentes

Problema: como posso atualizar a barra de lançamento?

Existem algumas correções no mais recente Apache Felix Framework, como posso atualizá-lo no Adobe Experience Manager?

Solução

Siga estas etapas:

  1. Baixe o novo jar base do repositório oficial do Maven em http://search.maven.org/#search%7Cga%7C1%7Corg.apache.sling.launchpad.base. Você pode escolher a versão. Quando este artigo foi escrito, 5.0.1-2.6.2 é recomendado (ele ainda usa javax.servlet.api 2.5). Mas, você pode usar 5.2.0-2.6.4 se não tiver dependências na versão anterior da API do servlet.
  2. Desligue a instância.
  3. Substitua o jarro base na instalação (padrão em crx-quickstart / launchpad).
  4. Reinicie a instância com -Dorg.apache.sling.launchpad.startupmode=RESTART.

Valide-o ao seu lado se isso ajudar a resolver esse problema e observe o aviso geral de uso em produção

AVISO LEGAL: A BIBLIOTECA DE TERCEIROS É FORNECIDA “COMO ESTÁ” E SEM GARANTIA DE QUALQUER TIPO, INCLUINDO GARANTIAS OU CONDIÇÕES DE COMERCIALIZAÇÃO, ADEQUAÇÃO A UM DETERMINADO FIM, QUALIDADE SATISFATÓRIA, FALTA DE VÍRUS, TITULARIDADE, NÃO VIOLAÇÃO, PRECISÃO OU INTEGRIDADE DAS RESPOSTAS, RESULTADOS, FALTA DE NEGLIGÊNCIA E / OU AUSÊNCIA DE ESFORÇO DE TRABALHO. A ADOBE NÃO GARANTE CONTRA NENHUM BUG, ERRO, OMISSÃO, DEFEITO, DEFICIÊNCIA OU NÃO CONFORMIDADE NA BIBLIOTECA TERCEIRA. BIBLIOTECAS DE TERCEIROS NÃO SÃO TESTADAS PELO QA. USE-O POR SUA PRÓPRIA CONTA E RISCO. A ADOBE RECOMENDA QUE ESTE BIBLIOTECA DE TERCEIROS SEJA UTILIZADA PARA FINS DE DESENVOLVIMENTO. SE VOCÊ DEVE APLICAR ESTA BIBLIOTECA DE TERCEIROS A UM SISTEMA DE PRODUÇÃO, VOCÊ DEVERÁ TESTAR O SEU APLICATIVO. A ADOBE NÃO PODE SER RESPONSÁVEL POR QUAISQUER DANOS QUE PODEM SER CAUSADOS POR ESTA BIBLIOTECA DE TERCEIROS.

Aplica-se a: CQ 5.x / AEM 6.x qualquer versão que esteja usando este jar base da barra de ativação

Sobre as dependências da API do Servlet: A API de servlet é fornecida pelo mecanismo de servlet CQSE, Felble / Jetty HTTP bunble ou outro (Websphere, Weblogic, Tomcat, JBoss e assim por diante). Verifique se ele funciona com a base da barra de ativação disponível no repositório Maven (você pode verificar o pom.xml para obter informações sobre a dependência na API do servlet).

 Adobe

Receba ajuda com mais rapidez e facilidade

Novo usuário?