Este documento descreve como instalar e usar o plug-in OpenEXR Alpha complementar.

O plug-in OpenEXR Alpha complementar oferece um método alternativo para a manipulação de dados do canal 'A' ao abrir um arquivo OpenEXR. Em vez de converter diretamente os dados do canal 'A' para a transparência (como fazia o antigo plug-in OpenEXR), o OpenEXR Alpha abre os dados do canal 'A' como um canal alfa.

Plano de fundo

O Photoshop CS2 não suportava normalmente a transparência no modo de 32 bits. Naquela versão, foi implementada uma solução alternativa que permitia ler os dados de transparência para um canal alfa. No Photoshop CS3, o suporte à transparência foi implementado para o modo de 32 bits, assegurando a conformidade com a especificação OpenEXR. A transparência, portanto, não era mais lida em um canal alfa durante a composição de canal direto.

Antes de começar

A instalação do plug-in OpenEXR Alpha requer direitos locais de administração. Se usar Mac OS, Windows Vista ou Windows 7, o sistema operacional solicitará que insira o nome e a senha de uma conta de usuário de administrador. Se usar o Windows XP, efetue login em seu computador usando uma conta de administrador local antes de iniciar.

Usuários do Windows: algumas das etapas nesta TechNote lista os arquivos pelo nome de arquivo completo, incluindo as extensões de arquivo (p. ex., OpenEXR Alpha.8bi). No Windows, as extensões de arquivo dos tipos de arquivo conhecidos não estarão visíveis por padrão. Para tornar as extensões de arquivo visíveis, faça o seguinte:

  1. No Windows Explorer, escolha Ferramentas > Opções da pasta (Windows XP) ou Organizar > Pasta e opções de pesquisa (Windows 7 ou Vista).
  2. Selecione a guia Visualizar perto da parte superior da janela Opções de pasta.
  3. Na área Configurações avançadas da guia Visualizar, desmarque a opção Ocultar extensões dos tipos de arquivo conhecidos.
  4. Clique em OK.

Usuários do Windows: algumas das etapas neste documento requerem que você determine se está usando uma versão de 32 bits ou de 64 bits do Windows. Para determinar o tipo de sistema que você tem, consulte Determinar se seu computador está executando uma versão de 32 bits ou de 64 bits do Windows.

Compatibilidade

No Windows, o plug-in OpenEXR Alpha não é compatível com as versões do Photoshop anteriores ao Photoshop CS5. Ele não é carregado no Photoshop CS3 ou CS4.

No Mac OS, o plug-in OpenEXR Alpha não é carregado em máquinas PPC.

Instalar o plug-in OpenEXR Alpha para Photoshop CS5 no Mac ou no Windows (download da atualização no site da Adobe)

Para instalar o plug-in OpenEXR Alpha fazendo download de uma atualização do site da Adobe:

  1. Faça download do plug-in compactado:

  2. Saia do Photoshop CS5.
  3. Descompacte o arquivo baixado.
  4. Arraste o plug-in para a pasta de plug-ins do Photoshop.
    • Windows de 32 bits: arraste OpenEXR Alpha.8bi da pasta Win32 para /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Windows de 64 bits/Photoshop de 64bits: arraste OpenEXR Alpha.8bi da pasta Win64 para /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Windows de 64 bits/Photoshop de 32bits: arraste OpenEXR Alpha.8bi da pasta Win32 para /Program Files (x86)/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Mac OS: arraste OpenEXR.plugin para a pasta /Applications/Adobe Photoshop CS5/Plug-ins/File Formats.
  5. Inicie o Photoshop CS5.

Usar o plug-in OpenEXR Alpha

Para abrir um arquivo EXR:

  1. Inicie o Photoshop CS5.
  2. Escolha Arquivo > Abrir.
  3. Navegue até o arquivo EXR que deseja abrir. Na lista de formatos de arquivo, escolha OpenEXR Alpha. O Photoshop trata os dados do canal 'A' como um canal alfa em vez de transparência.

Para exportar um arquivo EXR:

  1. Escolha Arquivo > Salvar como.
  2. Na lista de formatos de arquivo, escolha OpenEXR Alpha.

  3. Selecione a opção Salvar: Canais alfa. Essa configuração preserva os dados dos canais alfa.

Observação: a transparência adicionada após o arquivo ter sido aberto será simplificada.

Observação: mesmo após a instalação do plug-in OpenEXR Alpha, você ainda terá a opção de escolher o OpenEXR antigo na lista de formatos de arquivo. Este plug-in ainda trata os dados no canal 'A' como transparência. Este comportamento era o padrão no Photoshop desde o Photoshop CS3 (versão 10.0).

Notas adicionais

Qualquer outro comportamento válido ao usar o plug-in complementar:

  • A composição pré-multiplicada não é suportada.
  • Se clicar duas vezes em um arquivo para abri-lo, o Photoshop CS5 sempre usa a OpenEXR Alpha em vez do OpenEXR.
  • Se abrir um arquivo com dois ou mais canais alfa, o OpenEXR Alpha não preserva nenhum dos canais alfa. Eles são completamente eliminados.
  • (Mac OS): na caixa de diálogo Salvar, o OpenEXR Alpha é o item superior. Ele não é exibido em ordem alfabética junto a Open EXR.
  • (Windows): para obter o comportamento do OpenEXR antigo, escolha Arquivo > Abrir como e, a seguir, selecione OpenEXR.
     

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online