Atualização de segurança disponível para o Adobe Acrobat e Reader | APSB19-55
ID do boletim Data de publicação Prioridade
APSB19-55 10 de dezembro de 2019 2

Resumo

A Adobe lançou atualizações de segurança para o Adobe Acrobat e Reader para Windows e macOS. As atualizações eliminam vulnerabilidades críticas e importantes.  A exploração bem-sucedida pode levar à execução de código arbitrário no contexto do usuário atual.    

Versões afetadas

Produto Track Versões afetadas Plataforma
Acrobat DC  Continuous 

2019.021.20056 e versões anteriores  Windows e macOS
Acrobat Reader DC Continuous   2019.021.20056 e versões anteriores  Windows e macOS
       
Acrobat 2017 Classic 2017 2017.011.30152 e versões anteriores Windows 
Acrobat 2017 Classic 2017 2017.011.30155 e versões anteriores macOS
Acrobat Reader 2017 Classic 2017 2017.011.30152 e versões anteriores Windows e macOS
       
Acrobat 2015  Classic 2015 2015.006.30505 e versões anteriores Windows e macOS
Acrobat Reader 2015 Classic 2015 2015.006.30505 e versões anteriores Windows e macOS

Solução

A Adobe recomenda que os usuários atualizem suas instalações do software para as versões mais recentes seguindo as instruções abaixo.    

As versões de produto mais recentes estão disponíveis para os usuários finais através de um dos seguintes métodos:    

  • Os usuários podem atualizar suas instalações de produtos manualmente ao selecionar Ajuda > Verificar atualizações.     

  • Os produtos serão atualizados automaticamente, sem exigir a intervenção do usuário, quando as atualizações forem detectadas.      

  • O instalador completo do Acrobat Reader pode ser baixado no Centro de download do Acrobat Reader.     

Para administradores de TI (ambientes gerenciados):     

  • Baixe os instaladores Enterprise em ftp://ftp.adobe.com/pub/adobe/, ou consulte a versão específica da nota de versão para links para instaladores.     

  • Instale as atualizações por meio da metodologia desejada, tal como AIP-GPO, bootstrapper, SCUP/SCCM para o Windows ou, no macOS, Apple Remote Desktop e SSH.     

   

A Adobe categoriza essas atualizações com as seguintes classificações de prioridade e recomenda aos usuários que atualizem as suas instalações para a versão mais recente:    

Produto Track Versões atualizadas Plataforma Classificação de prioridade Disponibilidade
Acrobat DC Continuous 2019.021.20058 Windows e macOS 2

Windows    

macOS  

Acrobat Reader DC Continuous 2019.021.20058
Windows e macOS 2

Windows


macOS

           
Acrobat 2017 Classic 2017 2017.011.30156 Windows e macOS 2

Windows

macOS

Acrobat Reader 2017 Classic 2017 2017.011.30156 Windows e macOS 2

Windows

macOS

           
Acrobat 2015 Classic 2015 2015.006.30508 Windows e macOS 2

Windows

macOS

Acrobat Reader 2015 Classic 2015 2015.006.30508 Windows e macOS 2

Windows

macOS

Detalhes da vulnerabilidade

Categoria da vulnerabilidade Impacto da vulnerabilidade Severidade Número CVE
Out-of-Bounds Read   Divulgação de informações   Importante   

CVE-2019-16449

CVE-2019-16456

CVE-2019-16457

CVE-2019-16458

CVE-2019-16461

CVE-2019-16465

Gravação fora dos limites  Execução de código arbitrário    Crítico

CVE-2019-16450

CVE-2019-16454

Uso após período gratuito    Execução de código arbitrário      Crítico

CVE-2019-16445

CVE-2019-16448

CVE-2019-16452

CVE-2019-16459

CVE-2019-16464

Heap Overflow  Execução de código arbitrário      Crítico CVE-2019-16451
Erro de buffer Execução de código arbitrário      Crítico CVE-2019-16462
Desreferência de ponteiro não confiável Execução de código arbitrário  Crítico

CVE-2019-16446

CVE-2019-16455

CVE-2019-16460

CVE-2019-16463

Inserção de binário (escalonamento de privilégios de pasta padrão)  Escalonamento de privilégio Importante  CVE-2019-16444
Bypass de segurança Execução de código arbitrário Crítico CVE-2019-16453

Agradecimentos

A Adobe gostaria de agradecer às seguintes pessoas e organizações por relatar problemas relevantes e por trabalhar com a Adobe para ajudar a proteger nossos clientes:    

  • Mateusz Jurczyk do Google Project Zero & Anonymous trabalhando com a Zero Day Initiative da Trend Micro (CVE-2019-16451)

  • Honc (章 哲 瑜) (CVE-2019-16444) 

  • Ke Liu do Tencent Security Xuanwu Lab. (CVE-2019-16445, CVE-2019-16449, CVE-2019-16450, CVE-2019-16454)

  • Sung Ta (@Mipu94) do SEFCOM Lab, Universidade Estadual do Arizona (CVE-2019-16446, CVE-2019-16448) 

  • Aleksandar Nikolic da Cisco Talos (CVE-2019-16463)

  • Equipe de suporte técnico da HTBLA Leonding (CVE-2019-16453)

  • Haikuo Xie do Baidu Security Lab (CVE-2019-16461)

  • Bit do STAR Labs (CVE-2019-16452)

  • Xinyu Wan e Yiwei Zhang da Universidade Renmin da China (CVE-2019-16455, CVE-2019-16460, CVE-2019-16462)

  • Bo Qu da Palo Alto Networks e Heige da Knownsec 404 Security Team (CVE-2019-16456) 

  • Zhibin Zhang da Palo Alto Networks (CVE-2019-16457)

  • Qi Deng, Ken Hsu da Palo Alto Networks (CVE-2019-16458) 

  • Lexuan Sun, Hao Cai da Palo Alto Networks (CVE-2019-16459)

  • Yue Guan, Haozhe Zhang da Palo Alto Networks (CVE-2019-16464) 

  • Hui Gao da Palo Alto networks (CVE-2019-16465)

  • Zhibin Zhang, Yue Guan da Palo Alto Networks (CVE-2019-16465)