Learn about new features and enhancements in the October 2020 release of Animate (version 21.0).
Assets panel

Use Assets panel to create cool animation with preloaded assets and customize them.

Social share

Share your animations on YouTube channel within Animate.

publish

Publish your animation to video, animated GIF, or HTML5 canvas formats, seamlessly.

Improvised Timeline

Customize your timeline tools and explore the new symbol options to make the most out of it.

Advanced rigging

Character rigging is made easier with auto and manual mapping.

Assets panel

The revamped Assets panel allows you to find, organize, and manage assets within the new Default and Custom tabs.

Default tab comes with set of pre-loaded assets under Animated, Static, and Sound clips sections. You can quickly create cool animations by combining various assets. You can also download more assets within the Default tab. 

All the reusable components that you save or export are available in Custom tab. The imported assets are categorized as Animated or Static assets.

You can filter, search, rename, and delete assets within Default and Custom tabs.

You can also save or export scenes, symbols, and bitmaps as assets. The assets are saved in the form of objects, rigs, or rigged objects.

Assets panel

For more details, see Work with Assets panel.

Social share

Apart from Twitter, post animations to your YouTube channel within Animate using the Social share option. Add title, description, hashtags, and click Share to generate and upload the video on YouTube.

Quick publish

For more details, see Social share and publish animations.

Quick publish

Publish your animations to video, Animated GIF, or HTML5 canvas formats with the new Quick publish option. Quick publish uses the settings defined in File> Export (video and animated GIF) or File > Publish settings (HTML canvas file).

Publish

For more details, see Social share and publish animations.

Timeline and symbol enhancements

  • Customize Timeline Tools: Add or remove options on the timeline panel with the Customize Timeline Tools option. From the hamburger menu, select Customize Timeline Tools to personalize your timeline. 
  • Convert Layers to Symbol: Convert your layers in the timeline to symbol with just two clicks. Select the layers and right-click to choose Convert Layers to Symbol option. You can also specify the symbol type and registration point, accordingly.
  • Break Apart Symbol to Layers: The new option lets you break any symbol instances on stage along with its layer structure.
  • Reverse play and loop support for Graphic Symbols: Now, play your graphic symbol on loop in reverse. Similarly, you can also play the Graphic symbol in reverse. You can specify the starting frame for these two options. 
  • Copy paste Tween Settings: Reuse your tween settings with the new tween options. Copy, paste, or reset the tween settings using the Frame tab of Properties panel.
Extended Timeline

For more details, see the Timeline.

Advanced Rigging (Beta)

Rigging feature allows you to quickly connect various body parts of your character. This feature helps in controlling the motion of each body part in relation to one another. You can drag-and-drop rigs from Assets panel to compatible characters on stage. 
Use the new Rig Mapping panel to manually map rigs with the corresponding body parts of the character. Once mapped, click Apply skeleton to apply the rig along with its motion if present.

advanced rigging

For more details, see Advanced rigging in Animate.

Other enhancements

  • Windows Ink support: With the improved Windows Ink tablet mode, experience the natural drawing strokes and pressure sensitivity in Surface Pro and other drawing tablets.
  • Bone tool enhancements: Now control the motion of the object at the end of a leaf node by adding constraints. Use the Object tab of Properties panel, to apply constraints. Also, you can split an armature span into multiple spans or join the armature span if the character has the same number of nodes.