i18n translations are no longer working

Cause

There could be multiple causes for this problem.  In this article, we focus on one known cause, where the sling-i18n service user's  ACLs are deleted. This usually happens when an ACL package is installed from another environment.

Resolution

Check if the service user sling-i18n has read access on the root node /

  1. Go to http://host:port/crx/explorer/index.jsp
  2. Log in as admin
  3. Open Content Explorer
  4. Click on the root node - /
  5. In the top navigation, select Security => Access Control Editor (the Security button is a picture of a safe)
  6. Check if the sling-i18n user has read access granted.  If not then follow the steps below.

Fix the service user ACLs:

  1. Install ACS Commons if it isn't already installed. You will need to use the ACS Commons ACL Packager.
  2. Use the ACL Packager to create a back up package of all ACL's from corrupted environment.  Before building the package, edit it's configuration, go to the Advanced tab and set AC Handling to Merge mode.
  3. Install a fresh AEM instance with all the same patches (service packs, hotfixes, etc.).
  4. Create a package with merge mode of the ACL's from the fresh instance.
  5. Build the package with merge mode as well.
  6. Download the package.
  7. Install it to broken environment.Reinstall the ACL package from step 1.  
  8. Reinstalling the package reorders the custom ACLs to the end of the list ensuring that custom ACLs aren't overridden by out of the box ones.

Once The ACL has been resolved, one final step is required.

  • Go to /system/console/bundles, and restart the "Apache Sling Internationalization Support" bundle

 Adobe

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