Masking and tracking

Use Premiere Pro's masking tools to apply effects to a specific part of a frame in your video. Learn to apply a mask, and then track it as it moves across the frame.

Masking in Premiere Pro

Masks let you define a specific area in a clip that you want to blur, cover, highlight, apply effects, or color-correct. You can create and modify different shaped masks, like an Ellipse or a Rectangle. Or, you can draw free-form Bezier shapes using the Pen tool.

Create masks using shapes

You can use the Ellipse shape tool to create a circular or ellipse-shaped mask, or a Rectangle shape tool to create a four-sided polygon.

Before masking
Before masking
After masking
After masking
  1. In the Timeline panel, select the clip you want to mask.

  2. From the Effects panel, select the effect that you want to apply to the clip.

    For example, if you want to apply the Mosaic effect, select Video Effects > Stylize > Mosaic.

  3. Apply the selected effect to a clip by dragging the effect from the Effects panel to the clip in the Timeline panel. Alternatively, select the clip and double-click an effect in the Effects panel to apply it.

    For more information on applying an effect, see Apply effects to clips.

    Add mosaic effect to a clip
    Add mosaic effect to a clip

       

  4. Open the Effect Controls panel to see the effect properties. Click the drop-down arrow to reveal the controls.

    You can create an ellipse or rectangle. Use the Pen tool to create free form shapes

    You can specify values to adjust a mask using the Effect Controls panel. The controls change depending on your choice. For more information, see Adjust mask settings.

    Ellipse, rectangle, pen tool
    Ellipse, rectangle, pen tool
  5. Click the Ellipse shape tool to create an Ellipse-shaped mask or click the Rectangle shape tool to create a rectangle-shaped mask.

    The shape mask appears in the clip displayed in the Program Monitor, and the effect is constrained within the masked area.

    Ellipse
    Ellipse
  6. You can now customize the size and shape of the mask using the Effect Controls panel. For more information on editing your mask, see Adjust mask settings.

    Create a mask using the Ellipse tool
    Create a mask using the Ellipse tool

Note:

You can apply the same effect multiple times by using different settings each time.

Important notes

  • Premiere Pro does not save masks as effects presets.
  • Masking is disabled for the Warp Stabilizer effect. The mask shape controls do not appear for the Warp Stabilizer effect in the Effect Controls Panel.

Create free-form shapes

You can create free-form shapes using the Pen tool. The Pen Tool lets you freely draw complex mask shapes around objects.

Select the Pen tool from the Effect Controls panel. Draw directly on the clip in the Program Monitor.

Create a free form shape using the Pen tool
Create a free form shape using the Pen tool

You can create different shapes by drawing straight lines and curved segments. To draw smooth curves, you can draw Bezier path segments that provide you greater control over the shape of the mask.  

Draw straight path segments with the Pen tool

The simplest path that you can draw with the Pen tool is a straight line with two vertex points. By continuing to click, you create a path made of straight-line segments connected by vertex points. This is a linear mask.

A linear mask is always a polygon with joined by hard angles. Linear control points are also known as corner points.

Use the Pen tool to create a linear mask
Use the Pen tool to create a linear mask
  1. Select the Pen tool.

  2. Position the Pen tool where you want the straight segment to begin, and click to define the first vertex point (do not drag).

    Note:

    The first segment you draw is not visible until you click a second vertex point.

  3. Click again where you want the segment to end (Shift-click to constrain the angle of the segment to a multiple of 45°).

  4. Continue clicking to set vertex points for additional straight segments.

  5. To close the path with a linear mask, Alt+click (Windows) or Option+click (macOS) over the first vertex point. 

Draw curved Bezier path segments with the Pen tool

bezier lines
A. Two-directional Bezier handles to control the shape of the curve  B. Bezier mask points  

You create a curved path segment by dragging direction lines using the Pen tool. The length and direction of the direction lines determine the shape of the curve.

To create Bezier shapes, you convert a vertex point on a mask to a Bezier point by pressing the Alt key while placing the cursor over the vertex point. The cursor becomes an inverted "V" shape . Then, click and release the pointer.

Bezier handles provide two-directional controls that allow you to change the curve of the line segment between the handle and the next point on either side.

  1. Place the Pen tool where you want the curve to begin, and hold the mouse button down. A vertex appears, and the Pen tool pointer changes to an arrowhead.

  2. Drag to modify the length and direction of both direction lines for a vertex, and then release the mouse button.

    A. Placing the Pen tool
    B. Starting to drag (mouse button pressed)
    C. Dragging to extend direction lines

    Drawing the first vertex in a curved path
    Drawing the first vertex in a curved path
  3. Place the Pen tool where you want the curved segment to end, and do one of the following:

    • To create a C-shaped curve, drag in the direction opposite from the direction that you dragged the previous direction line, and then release the mouse button.

    A. Starting to drag
    B. Dragging away from previous direction line, creating a C curve
    C. Result after releasing mouse button

    Drawing the second vertex in a curved path
    Drawing the second vertex in a curved path
    • To create an S-shaped curve, drag in the same direction as the previous direction line, and then release the mouse button.

    A. Starting to drag
    B. Dragging in same direction as previous direction line, creating an S curve
    C. Result after releasing mouse button

    Drawing an S curve
    Drawing an S curve
  4. Continue dragging the Pen tool from different locations to create a series of smooth curves.

Modifying and moving masks

The vertex points on a mask let you easily manage the shape, size, and rotation of a mask.

Modify the shape, size, and rotation of a mask

masking3-31

To change the shape of a mask, drag a mask handle.

masking3-32

To change the shape of an ellipse mask to a polygon, press Alt and click any of the vertices of the ellipse.

masking3-33

To resize a mask, place your cursor just outside a vertex and press Shift (cursor becomes a double-sided arrow ), then drag the cursor.

masking3-34

To rotate the mask, place your cursor just outside a vertex (cursor becomes a curved double-sided arrow ), and then drag. 

Move, add, or remove a vertex

masking3-35

To move a vertex, drag the vertex with the Selection tool. Note that while dragging an ellipse-shaped mask, the ellipse shape is not maintained.

masking3-36

To add a vertex, place your cursor over a mask edge while pressing Ctrl (Windows) or Cmd (macOS). The cursor changes to a pen shape with a "+" sign 

masking3-37

To remove a vertex, place your cursor over the point while pressing Ctrl (Windows) or Cmd (macOS). The cursor changes to a pen shape with a minus sign 

Other important commands and keyboard shortcuts

  • Use the arrow keys on your keyboard to nudge a selected control point by a distance of one unit.
  • Press Shift and use the arrow keys to nudge a selected control point by a distance of five units.
  • To deselect all the selected control points, click outside a currently active mask.
  • To disable direct manipulation of a mask, click outside the mask. Or deselect the clip in the sequence.
  • To delete a mask, select the mask in the Effect Controls Panel and press Delete on your keyboard.

Adjust mask settings

You can specify values to adjust a mask using the Effect Controls panel. You can feather the mask, expand the mask, change the opacity, or invert the mask to stylise your video.

Adjust mask settings
Adjust mask settings

Apply mask feathering

feather mask

To feather a mask, specify a Mask Feather value. The feathering guide appears around the mask as a dashed line. Drag the handle away from the feathering guide to increase the feathering, or toward the feathering guide to decrease the feathering.

The mask feather handle lets you control the amount of feathering directly on the mask outline in the Program Monitor. 

Adjust mask opacity

opacity

When opacity is applied to a mask it will change the opacity of the footage you have cropped out.

To adjust the opacity of a mask, specify a Mask Opacity value. The slider controls the mask opacity. At  a value of 100, the mask is opaque and blocks out any underlying area of the layer. As you lower the opacity, more of the area under the mask becomes visible.

Adjust mask expansion

expand

To expand a mask, specify a Mask Expansion value. Positive values move the borders outward, and negative values move it inward. You can also drag the handle away from the expansion guide to expand the mask area, or toward the expansion guide to contract the mask area.   

Invert mask selection

invert mask

Select the Inverted check box to reverse the masked and unmasked areas.

You can protect areas that you want to leave as-is by masking it, and select the Inverted check box to apply effects to the unmasked areas.

Copy and paste masks

You can easily copy and paste masks between clips or between effects.

Copy and paste effects with masks between clips

When you copy and paste an effect containing masks, the pasted effect has the same masks applied.

  1. In the Timeline panel, select the clip containing the effect with masks.
  2. In the Effect Controls panel, select the effect to copy.
  3. Select Edit > Copy. Or use the keyboard shortcut Ctrl+C (Windows) or Cmd+C (Mac OS).
  4. Select another clip in the Timeline to which you want to paste the mask.
  5. Select Edit > Paste. Or use the keyboard shortcut Ctrl+V (Windows) or Cmd+V (Mac OS).

 

Copy and paste masks between effects

  1. In the Effect Controls panel, click the triangle to expand the effect to reveal the applied masks.
  2. Select the mask to copy.
  3. Select Edit > Copy. Or use the keyboard shortcut Ctrl+C (Windows) or Cmd+C (Mac OS).
  4. Select another effect in the Effect Controls panel to which you want to paste the mask.
  5. Choose Edit > Paste. Or use the keyboard shortcut Ctrl+V (Windows) or Cmd+V (Mac OS).

Note:

You can copy and paste only one mask at a time.

Mask tracking in Premiere Pro

When you apply a mask to an object, Premiere Pro can let the mask automatically follow the object as it moves from one frame to another. For example, after blurring a face using a shape mask, Premiere Pro can automatically track the movements of the masked face from frame to frame as the person moves.

When a mask is selected, the Effect Controls panel displays controls for tracking the mask forward or backward. You can choose to track the mask either one frame at a time or until the end of the sequence.

Click the wrench icon  to modify how masks are tracked. You can select from a few choices to provide the most effective tracking:

Position

Tracks just the mask position from frame to frame

Position And Rotation

Tracks the mask position while changing the rotation as required per frame

Position, Scale, And Rotation

Tracks the mask position while automatically scaling and rotating as the frame moves

Note:

You can find the option that works best for your clip by trial. Select one of these options, and if it doesn't work well, undo, and try another one.

To use the more advanced tracking features available in After Effects, send your sequence to After Effects using the Dynamic Link feature. For more information, see Mask Tracking in After Effects.

Speed up mask tracking

Mask tracking in Premiere Pro is faster when Live Preview is disabled (the default option). If for some reason, Live Preview is enabled, you can disable it using the following procedure.

  1. In the Timeline panel, select the clip containing the effect with masks.

  2. To preview the changes in the track, click the mask wrench icon  and select preview from the drop-down list.

    Mask preview
    Mask preview
  3. To disable live preview, click the mask wrench icon  and deselect preview from the drop-down list.

    Disable live preview
    Disable live preview

In addition, Premiere Pro has in-built features that optimize mask tracking:  

For clips with a height greater than 1080, Premiere Pro scales the frame to 1080 before calculating the track. Also, Premiere Pro uses Low Quality renders to speed up the process of mask tracking.

Video tutorial

How to blur a moving face with masking and tracking

In this 5-min video tutorial, learn how to apply a feathered mask to protect a person's identity and then track that mask as it moves across the frame in a scene.

The tutorial provides you sample files to try out the feature for yourself.