Correctifs d’Adobe Experience Manager 6.0 à installer avant le Service Pack 3

Cette page est l'ancienne version de la page recommandée des correctifs, avant la sortie de la version AEM 6.0 des Service Pack 3.

Voici la liste des correctifs recommandés à installer après AEM 6.0, * sauf si vous avez installé SP3. *

Adobe recommande l'installation du Service Pack 3. Consultez cette page pour les correctifs à installer après SP3.

Introduction

Les correctifs suivants sont actuellement disponibles pour Adobe Experience Manager 6.0. Installez les correctifs recommandés (en gras) s'ils ne sont pas présents ici.

Remarque :

Vous pouvez trouver tous les correctifs (en gras avec une *) dans la section publique de partage de packages. Vous pouvez accéder à Package Share avec un utilisateur enregistré comme indiqué ici.

  • Demandez les autres correctifs via un ticket de support AEM.
  • La plupart des correctifs sont autonomes, sauf spécification contraire et peuvent être installés dans n’importe quel ordre. Ils peuvent être vérifiés de manière autonome en vérifiant les dépendances de l’onglet Details (Détails) dans Package Share.  
  • À l'heure actuelle, les notes de mise à jour des correctifs publics sont uniquement disponibles par demande via le portail de support AEM. Le partage de package les contiendra bientôt directement.

Le module de services Adobe Experience Manager 6,0 Service Pack 2 a été publié le 3 février 2015

Remarque :

Installer les correctifs rapides ci-présents sur le dernier Service Pack 2 disponible.

L'installation de la version la plus récente du module de service est recommandée. Celle-ci inclut les correctifs et les améliorations clés apportés à la sécurité, aux performances ainsi qu'à la stabilité parus depuis la mise en circulation générale de Adobe Experience Manager 6.0. 

Le lien d'accès direct au plus récent module de service (SP 2) est https://www.adobeaemcloud.com/content/marketplace/marketplaceProxy.html?packagePath=/content/companies/public/adobe/packages/cq600/servicepack/AEM-6.0-Service-Pack-2.

Des informations supplémentaires sur les mises à jour sont disponibles à l'adresse http://docs.adobe.com/docs/en/aem/6-0/release-notes-sp2.html.

Composants de base

Vulnérabilités de sécurité

Les correctifs ci-dessous permettent de résoudre plusieurs vulnérabilités critiques. Adobe vous recommande vivement d'installer immédiatement cette mise à jour de sécurité en plus de la version complète d’Adobe Experience Manager 6.0 avec les instances SP2.

Afin de protéger nos clients, Adobe ne divulgue aucune information de vulnérabilité. 

Date

Nom

Correctifs

April 22 2015

Conteneur de correctif de sécurité pour AEM6 SP2, contenant également des correctifs de performance et de stabilité des correctifs 5918 et 6109.

Remarque : Si vous utilisez des formulaires AEM, installez les modules complémentaires de formulaires AEM les plus récents après l'installation du correctif.

22 mai 2015

Correctif de sécurité Webdav

4 juin 2015

Vulnérabilité affectant Apache Sling Servlets Post 2.3.6

Oak

La version actuellement recommandée est 1.0.23.

Date

Nom

Correctifs

10 novembre 2015

Voir les notes de mise à jour

Telechargement

L'outil géré par Oak est disponible sur le référentiel central Maven. Tirez parti de la même version gérée par Oak que le regroupement Oak-Core utilisé.

L'outil de migration de référentiel crx2oak est disponible sur http://docs.adobe.com/content/docs/en/aem/6-0/deploy/upgrade.html#Migrating%20the%20repository%20to%20OAK

Remarque :

Pour tirer le meilleur parti de votre référentiel Oak actualisé, vérifier attentivement la section Oak du réglage des performances de page 6.0, qui contient les derniers conseils autour de l'optimisation des index et du compactage efficace de référentiel.

Performances

Installez le premier correctif 6167 répertorié ci-dessus, car il contient aussi plusieurs améliorations des performances.

Date

Nom

Description des correctifs

10 juin 2015

Amélioration des performances dans la gestion des balises.  Le correctif comprend une variable système, cqTaggingLikeEnabled  Pour plus de détails, voir Gérer les balises : problèmes de requête de balise.

27 août 2015

Lors de l'ouverture d'une page, Google Chrome renvoie l'avertissement « Synchronous Ajax requests should be avoided, especially while loading the page ». Pour de plus amples informations, consultez le fichier Readme

Remarque : En cas d'utilisation de formulaires AEM, installer la dernière extension de module de formulaires AEM. Contacter l'assistance technique d'Adobe pour obtenir le dernier module.

18 septembre 2015

Purge des versions dans le thread d'arrière-plan

Processus

Date

Nom

Description des correctifs

6 août

Divers correctifs du moteur de flux de travail

Réplication

Date

Nom

Description des correctifs

21 août

Régression de la réplication par lots

Divers

Date

Nom

Correctifs

31 août

Correctif 7394

Corrige SLING-4635 - Les tâches liées à la topologie ne doivent pas être planifiées si la topologie n'est pas suffisamment claire ou disponible.

8 août 2014

FeaturePack 4137

Connecteur S3 Datastore sur AEM 6.0 Oak.

Version 1.8 disponible depuis le 10 juillet 2015.

17 février 2015.

Correctif 5916

Corrige SLING-4307 - Évite la mise en cache des valeurs de propriétés JCR si le compactage en ligne TarMK est activé - Dépend du correctif 5918.

Sites

Création / Interface utilisateur

Le pack d'amélioration de l'interface utilisateur Touch est inclus dans SP2.

Prenez connaissances de nos recommandations et bonnes pratiques en matière d'interface utilisateur dans Adobe Experience Manager 6.0 à l'adresse http://docs.adobe.com/docs/en/aem/6-0/deploy/best-practices/ui-recommendations.html.

Les notes de version du Update Pack ci-dessus, ainsi que les correctifs spécifiques Touch-Optimized dans nos Service Packs, se trouvent sur la même page dans la section Améliorations de l'interface utilisateur Touch-Optimized.

MSM

Aucun correctif logiciel recommandé pour le moment sur le SP2.

Développement.

Date

Nom

Description du package

5 juin 2015

Sightly FP 1.1 - AEM 6.1 Moteur de scripting Sightly pour AEM 6.0.

Actifs

Média dynamique

Date

Nom

Correctifs

4 juin 2015

Sécurité, stabilité, corrections de bogues clés et améliorations pour prendre en charge la conception et le flux de production vidéo adaptés aux clients AEM 6.0 Dynamic Media. Exigences : AEM 6.0 et Service Pack 2.

Communautés.

Date

Nom

Correctifs

6 novembre 2014

Ce groupe de correctifs contient le dernier ensemble de correctifs pour la version 6.0 d'AEM Social Communities. Voir la documentation6.0 pour plus de détails sur cette version.

Formulaires

Formulaires adaptatifs.

Date

Nom

Correctifs

3 septembre 2015

  • Les données de la liste déroulante sont réorganisées lors de l’ajout d’une nouvelle rangée. (N° de référence : CQ-52098)
  • Les données fusionnées pour un panneau répétitif ne sont pas disponibles pour les scripts d’initialisation. (N° de référence : CQ-52054)
  • L’exécution de scripts, lors de l’ajout ou de la suppression d’instances de panneaux ou de rangées reproductibles, est désormais optimisée. (N° de référence : CQ-52057)
  • L'appel à guideContainer.analyticsconfigparser.json lors du rendu d'un formulaire adaptatif, même lorsque l'analyse n'est pas activée, est maintenant optimisé. (N° de référence : CQ-51164)
  • L'appel à guideContainer.fd.tempstorageprovider.jsp sur le rendu d'un formulaire adaptatif, même lorsque les données ne sont pas entrées, est optimisé. (N° de référence : CQ-51169)

24 juillet 2015

Formulaires HTML5

  • Les pages d’un document particulier ne sont pas affichées. (N° de référence : CQ-49461)
  • Les propriétés prevText et newText ne fonctionnent pas correctement. (N° de référence : CQ-49382)

Formulaires adaptatifs

  • La localisation des composants de boîte de dialogue personnalisés à plusieurs valeurs ne fonctionne pas. (N° de référence : CQ-47890)
  • Le composant de liste déroulante du groupe de formulaires adaptatifs ne s'affiche pas en mode Aperçu. (N° de référence : CQ-46318)

13 mars 2015

  • Les entrées de dictionnaire ne sont pas créées pour les éléments de dialogue personnalisés. (N° de référence : LC-3913647)
  • Les messages d'erreur de validation ne sont pas traduits pour les langues ajoutées par l'utilisateur (N° de référence : LC-3913524).
  • Lorsque le formulaire adaptatif s'affiche dans le navigateur Internet Explorer 9, une erreur JavaScript
    liée à guidelib.js se produit. L'erreur provoque
    des problèmes de rendu ou d’affichage. (N° de référence : LC-3913538)

3 juin 2015

  • Dans Internet Explorer 9, la mise en page en accordéon ne fonctionne pas correctement. (N° de référence : LC-3912099)
  • Le champ numérique n'accepte pas la valeur 0. (N° de référence : LC-3912103, LC-3912460)
  • Les incrustations de AEM ne fonctionnent pas correctement pour les composants et les mises en page répertoriés sous un formulaire adaptatif (N° de référence : LC-3912864)
  • Les formulaires adaptatifs ne prennent pas en charge le changement d’événement pour les composants déroulants. (N° de référence : LC-3912785)
  • Dans les formulaires adaptatifs, les propriétés prevText et newText sont ignorées pour les champs de liste Texte, Numérique, Date et Liste déroulante. (N° de référence : LC-3912457)

17 juin 2015

  • Les entrées de dictionnaire ne sont pas créées pour les éléments de boîte de dialogue personnalisés. (N° de référence : LC-3913647)
  • Les messages d'erreur de validation ne sont pas traduits pour les langues ajoutées par l'utilisateur (N° de référence : LC-3913524).
  • Lorsque le formulaire adaptatif s'affiche dans le navigateur Internet Explorer 9, une erreur JavaScript
    liée à guidelib.js se produit. L'erreur provoque
    des problèmes de rendu ou d’affichage. (N° de référence : LC-3913538)

Assembler

Date

Nom

Correctifs

27 avril 2015

  • Ajout d'une nouvelle option dans la console d'administration LiveCycle pour spécifier le codage XML
    pour le service Assembler.  (N° de référence : LC-3910022)

Composants de base

Date

Nom

Correctifs

2 avril 2015

  • Les nœuds CRX sont plus longs que prévu dans la boîte de dialogue pour ajouter des actifs CRX en pièce jointe à un point final. (N° de référence : LC-3911835)

25 mai 2015

  • Impossible de supprimer les catégories dans l'interface utilisateur d'administrateur. (N° de référence : LC-3912139)
  • L'ensemble des formulaires HTML5 sont dorénavant activés dans les formulaires FP1 de AEM 6.0. (N° de référence : LC-3909935)
  • L’appel à l’API invokestartpoint avec la mise en cache échoue en cas d’échec de l’application mobile Workspace. (N° de référence : LC-3911926)
  • Le SDK client a été amélioré pour permettre son utilisation dans un serveur Livecycle
    , pour appeler un autre serveur Livecycle lorsque le service cible
    n'est pas installé sur le serveur source.

Formulaires HTML5.

Date

Nom

Correctifs

24 juillet 2015

Formulaires HTML5

  • Les pages d’un document particulier ne sont pas affichées. (N° de référence : CQ-49461)
  • Les propriétés prevText et newText ne fonctionnent pas correctement. (N° de référence : CQ-49382)

Formulaires adaptatifs

  • La localisation des composants de boîte de dialogue personnalisés à plusieurs valeurs ne fonctionne pas. (N° de référence : CQ-47890)
  • Le composant de liste déroulante du groupe de formulaires adaptatifs ne s'affiche pas en mode Aperçu. (N° de référence : CQ-46318)

2 Février 2015

  • Certains champs flottants ne sont pas rendus lorsqu’ils sont placés dans des sous-formulaires répétables. (N° de référence : LC-9868)
  • Certaines pages ne sont pas rendues lorsque les sous-formulaires imbriqués et répétables sont séparés sur plusieurs pages. (N° de référence : LC-9878)

2 juin 2015.

  • La méthode Suppression d'Instance ne supprime pas les données associées lors de l’envoi du formulaire. (N° de référence : LC-3910543)
  • L'événement Exit ne s'applique pas à la première sortie d'un champ de texte ou d'une liste déroulante. (N° de référence : LC-10153, LC-10152)
  • La propriété border d'un objet se comporte de manière incohérente pour de multiples événements. (N° de référence : LC-3910380)
  • La méthode AddInstance ne fonctionne pas correctement lorsqu'elle est appliquée sur un sous-formulaire parent avec plusieurs sous-formulaires enfants. (N° de référence : LC-3910098)

Gestion des droits

Date

Nom

Correctifs

7 mai 2015

Les API suivantes sont introduites dans le Gestionnaire Rights Management Policy Manager :

  • getPolicySet()
  • createPolicySet()
  • updatePolicySet()
  • getPolicySetIdByPolicySetName()
  • deletePolicySets()
  • managePolicySetPublishers()
  • managePolicySetVisibleUsersGroups()
  • managePolicySetCoordinators()
  • updateCoordinatorPermission()

29 mai 2015

  • Une erreur est affichée sur le serveur AEM Forms lorsqu'un composant personnalisé avec des fichiers JAR SDK communique avec un autre serveur AEM forms Rights Management
    . (N° de référence : LC-3913205)
  • L’erreur interne du serveur est renvoyée lors de l’activation ou de la mise à jour d’une stratégie avec une période de validation de la date utilisateur. (LC-3913076)

Correctifs obsolètes

Les correctifs présents dans cette dernière section étaient présents dans le passé, mais ont été remplacés par des packages plus récents répertoriés dans cette page.

Nom

Description des correctifs

Remplacé par / Inclus dans

Correctif 5918*

Correctifs de performances et de stabilité pour AEM SP2.

HF 6167

Correctif 6109*

La file d'attente Round Robin est traitée comme une file d'attente ordonnée.

HF 6167

 Adobe

Recevez de l’aide plus rapidement et plus facilement

Nouvel utilisateur ?

Adobe MAX 2024

Adobe MAX
La conférence sur la créativité

Du 14 au 16 octobre à Miami Beach et en ligne

Adobe MAX

La conférence sur la créativité

Du 14 au 16 octobre à Miami Beach et en ligne

Adobe MAX 2024

Adobe MAX
La conférence sur la créativité

Du 14 au 16 octobre à Miami Beach et en ligne

Adobe MAX

La conférence sur la créativité

Du 14 au 16 octobre à Miami Beach et en ligne