Mises à jour de sécurité disponibles pour Adobe Reader et Acrobat

Date de publication : 13 mai 2014

Identifiant de vulnérabilité : APSB14-15

Priorité : Voir le tableau ci-dessous

Références CVE : CVE-2014-0511, CVE-2014-0512, CVE-2014-0521, CVE-2014-0522, CVE-2014-0523, CVE-2014-0524, CVE-2014-0525, CVE-2014-0526, CVE-2014-0527, CVE-2014-0528, CVE-2014-0529

Plates-formes : Windows et Macintosh

Synthèse

Adobe a publié des mises à niveau de sécurité pour Adobe Reader et Acrobat XI (11.0.06) et leurs versions antérieures pour Windows et Macintosh. Ces mises à niveau corrigent des vulnérabilités susceptibles de provoquer un dysfonctionnement de l’application et de permettre à un pirate de prendre le contrôle du système concerné.

Adobe recommande aux utilisateurs de mettre à niveau leurs installations vers la dernière version :

  • Les utilisateurs de la version 11.0.06 d’Adobe Reader XI pour Windows et Macintosh doivent installer la version d’Adobe Reader XI 11.0.07.
  • Pour les utilisateurs d’Adobe Reader X versions 10.1.9 et antérieures pour Windows et Macintosh qui ne peuvent pas effectuer la mise à niveau vers Adobe Reader XI (11.0.07), une autre mise à niveau est disponible : Adobe Reader X (10.1.10).
  • Les utilisateurs de la version 11.0.06 d’Adobe Acrobat XI pour Windows et Macintosh doivent installer la version d’Adobe Acrobat XI 11.0.07.
  • Pour les utilisateurs d’Adobe Acrobat X versions 10.1.9 et antérieures pour Windows et Macintosh qui ne peuvent pas effectuer la mise à niveau vers Adobe Acrobat XI (11.0.07), une autre mise à niveau est disponible : Adobe Acrobat X (10.1.10).

Versions logicielles concernées

  • Adobe Reader XI versions 11.0.06 et 11.x antérieures pour Windows et Macintosh
  • Adobe Reader X versions 10.1.9 et 10.x antérieures pour Windows et Macintosh
  • Adobe Acrobat XI versions 11.0.06 et 11.x antérieures pour Windows et Macintosh
  • Adobe Acrobat X versions 10.1.9 et 10.x antérieures pour Windows et Macintosh

Solution

Adobe recommande aux utilisateurs d’effectuer la mise à niveau de leurs installations en procédant comme suit :

Adobe Reader

Les utilisateurs de systèmes Windows et Macintosh peuvent utiliser la fonction de mise à niveau automatique. Dans le cas d’une installation par défaut, des mises à niveau automatiques sont exécutées régulièrement ; il est possible de les activer manuellement en choisissant Aide > Rechercher les mises à jour.

Les utilisateurs d’Acrobat Reader pour Windows peuvent trouver la mise à jour désirée en se rendant sur : http://www.adobe.com/support/downloads/product.jsp?product=10&platform=Windows

Les mises à niveau destinées aux utilisateurs d'Adobe Reader pour Macintosh sont également disponibles à l'adresse suivante : http://www.adobe.com/support/downloads/product.jsp?product=10&platform=Macintosh

Adobe Acrobat

Les utilisateurs peuvent utiliser la fonction de mise à niveau automatique. Dans le cas d'une installation par défaut, des mises à niveau automatiques sont exécutées régulièrement ; il est possible de les activer manuellement en choisissant Aide > Rechercher les mises à jour.

Les utilisateurs d’Adobe Acrobat Standard et Pro pour Windows peuvent trouver la mise à jour désirée en se rendant sur :
http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Windows

Les mises à niveau destinées aux utilisateurs d'Acrobat Pro Extended pour Windows sont également disponibles à l'adresse suivante : http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Windows

Les utilisateurs d’Acrobat Pro pour Macintosh peuvent trouver la mise à jour désirée en se rendant sur : http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Macintosh

Degrés de priorité et de gravité

Adobe attribue à ces mises à jour les priorités suivantes et recommande aux utilisateurs concernés de mettre à jour leurs installations avec les dernières versions des logiciels :

Produit Version mise à jour Plate-forme Priorité
Adobe Reader XI (11.0.07)
Windows et Macintosh
1
Adobe Reader X (10.1.10)
Windows et Macintosh 1
Adobe Acrobat XI (11.0.07)
Windows et Macintosh
1
Adobe Acrobat
X (10.1.10)
Windows et Macintosh
1

Ces mises à niveau corrigent des vulnérabilités critiques du logiciel.

Détails

Adobe a publié des mises à niveau de sécurité pour Adobe Reader et Acrobat XI (11.0.06) et leurs versions antérieures pour Windows et Macintosh. Ces mises à niveau corrigent des vulnérabilités susceptibles de provoquer un dysfonctionnement de l’application et de permettre à un pirate de prendre le contrôle du système concerné.

Adobe recommande aux utilisateurs de mettre à niveau leurs installations vers la dernière version :

  • Les utilisateurs de la version 11.0.06 d’Adobe Reader XI pour Windows et Macintosh doivent installer la version d’Adobe Reader XI 11.0.07.
  • Pour les utilisateurs d’Adobe Reader X versions 10.1.9 et antérieures pour Windows et Macintosh qui ne peuvent pas effectuer la mise à niveau vers Adobe Reader XI (11.0.07), une autre mise à niveau est disponible : Adobe Reader X (10.1.10).
  • Les utilisateurs de la version 11.0.06 d’Adobe Acrobat XI pour Windows et Macintosh doivent installer la version d’Adobe Acrobat XI 11.0.07.
  • Pour les utilisateurs d’Adobe Acrobat X versions 10.1.9 et antérieures pour Windows et Macintosh qui ne peuvent pas effectuer la mise à niveau vers Adobe Acrobat XI (11.0.07), une autre mise à niveau est disponible : Adobe Acrobat X (10.1.10).

Ces mises à niveau corrigent une vulnérabilité de type « débordement de tas » susceptible d’entraîner l’exécution de code (CVE-2014-0511).

Ces mises à niveau corrigent une erreur de validation en entrée susceptible d’entraîner un contournement de sécurité (CVE-2014-0512).

Ces mises à niveau corrigent une vulnérabilité lors de la mise en œuvre des API JavaScript susceptible d’entraîner une divulgation d’informations (CVE-2014-0521).

Ces mises à niveau corrigent des vulnérabilités de type corruption de mémoire susceptibles d’entraîner l’exécution de code (CVE-2014-0522, CVE-2014-0523, CVE-2014-0524, CVE-2014-0526).

Ces mises à niveau corrigent une vulnérabilité liée à la manière dont Reader traite certains appels d’API vers la mémoire non mappée, qui est susceptible d’entraîner l’exécution de code (CVE-2014-0525).

Ces mises à jour corrigent une vulnérabilité de type « utilisation de zone désallouée » susceptible d’entraîner l’exécution de code (CVE-2014-0527).

Ces mises à jour corrigent une vulnérabilité de type « double-free » susceptible d’entraîner l’exécution de code (CVE-2014-0528).

Ces mises à jour corrigent une vulnérabilité de type débordement de mémoire tampon susceptible d’entraîner l’exécution de code (CVE-2014-0529).

Remerciements

Adobe tient à remercier les personnes et sociétés suivantes pour avoir signalé ces problèmes et joint leurs efforts aux nôtres pour protéger nos clients :