Issue:
Maximum number of connections reached in Adobe campaign classic.
Cause:
The number of opened connections in the Database has reached the configured limit.
Note: For On-premise deployments, you can check and modify the above mentioned values in serverConf.xml, and for Hosted deployments raise a request to Adobe Campaign Support.
Resolution:
For heavily loaded servers, the connection threshold might be exceeded. In any event, it is useful to find out why.
1. The Adobe Campaign connection threshold, available in two places:
a) Tomcat side: all queries actually arriving on the Adobe Campaign Tomcat client. This threshold is configured in the nl6/tomcat-8/conf/serverConf.xml file. The maxThreads attribute lets you increase the threshold of the number of queries processed at a time. It can be changed to 250, for instance.
<Connector protocol="HTTP/1.1" port="8080"
maxThreads="75"
minSpareThreads="5"
enableLookups="true" redirectPort="8443"
acceptCount="100" connectionTimeout="20000"
disableUploadTimeout="true" />
<Engine name="Tomcat-Standalone" defaultHost="localhost">
<Host name="localhost" appBase="./" unpackWARs="true" autoDeploy="true">
b) Database: set of all connections open at the same time on the database by a process.This threshold is configured in the file nl6/conf/serverConf.xml. The maxCnx attribute located in datasource pool lets you increase the threshold of queries processed simultaneously.
<!-- Data source-->
<dataSource name="default">
<dbcnx NChar="" bulkCopyUtility="" dbSchema="" encrypted="" login="" password="" provider="" server="" timezone="" unicodeData="" useTimestampTZ=""/>
<sqlParams funcPrefix="">
<postConnectSQL/>
</sqlParams>
<pool aliveTestDelaySec="600" freeCnx="0" maxCnx="90" maxIdleDelaySec="1200"/>
</dataSource>
2. If the issue is faced even after increasing the maximum connections, please reach out to Adobe Campaign Support for further investigation.
Need More Help?
Please contact Adobe Campaign Support