AWS will stop supporting PostgreSQL 9.4 at the end of Jun, 2020. All Adobe Campaign Classic instances that are running on PostgreSQL 9.4 will need to be upgraded to PostgreSQL 9.5 or PostgreSQL 9.6 before that date. You will find below common questions about this upgrade and its impact.

Context

AWS RDS PostgreSQL requires upgrade from time to time as it gets into End Of Life (EOL) and AWS stops supporting such versions. The PostgreSQL (v9.4.x) is running under EOL and AWS is going to stop its support by end of Jun, 2020. All Adobe Campaign Classic instances that are running PostgreSQL 9.4 will need to be upgraded to PostgreSQL 9.5 or PostgreSQL 9.6 before end of Jun, 2020.

Common questions

AWS will stop supporting PostgreSQL 9.4 beyond Jun, 2020. Not upgrading PostgreSQL before its End Of Life will have an impact and your instance will go down.

Downtime will be communicated to each impacted Customer in advance. Typically, the window for downtime will be 4 hrs but in some cases it can go up to ~6-8 hrs where RDS size is very large [more than 300 GB]. Your instances may be down during the downtime window. You can check your DB size in Control Panel following instructions here.

There are 2 options -

1. Customer upgrades to Gold Standard before the date mentioned in the email (which will upgrade the DB as well within a single maintenance window)

2. If above is not acceptable, the only option is to upgrade just the PostgreSQL in the window mentioned in email.

Adobe strongly recommends Option 1 as it saves customers another downtime for Gold standard upgrade which has to be done this year anyway.

There should be no change to any existing feature. Post PostgreSQL 9.4 upgrade, Customers will just need to login and perform basic sanity.

Yes, we are upgrading Stage instance first and then Prod, typically after ~1-3 weeks.

Please reach out to Customer Care if there is an issue post PostgreSQL9.4 upgrade