Einige js- und css-Dateien werden nicht auf der Seite geladen

Problem

Einige .js- und .css-Dateien fehlen auf Ihren AEM-Seiten oder auf der AEM-Benutzeroberfläche.

Ursache

Dies kann durch einige Dinge verursacht werden:

  • Die vom AEM-Clientbibliotheksmanager (HTMLLibraryManager) verwendete xpath-Abfrage [1] verwendet einen anderen Index als den Index /oak:index/nodetype.
  • Der Index nodeltype wird nicht aktualisiert oder ist beschädigt.
  • Die Berechtigungen des Clientlibs-Service fehlen.

[1]

/jcr:root//element(*, cq:ClientLibraryFolder)

Lösung

I. Überprüfen Sie die Service-Benutzerrechte

Lesen Sie diesen Artikel für den Fall, dass die Benutzerberechtigungen für den Clientlibs-Service fehlen.

II. Überprüfen Sie, ob die Abfrage korrekte Ergebnisse erhält

  1. Gehen Sie auf http://aem-host: port/crx/de/index.jsp und melden Sie sich als Admin an.

  2. Wählen Sie „Tools“ => „Abfrage“.

  3. Geben Sie im unteren Abfragefeld diese Abfrage ein:

    /jcr:root//element(*, cq:ClientLibraryFolder)
  4. Überprüfen Sie, ob Ihre fehlende Clientbibliothek in den Ergebnissen enthalten ist.  Wenn es dazu kommt, kontaktieren Sie AEM-Kundenbetreuung, um Hilfe bei weiteren Untersuchungen zu erhalten.  Fahren Sie andernfalls mit dem nächsten Schritt fort.

  5. Wenn Sie feststellen, dass die Ergebnisse die fehlende Clientbibliothek ausgeschlossen haben, gehen Sie auf http://aem-host:port/libs/granite/operations/content/diagnosis/tool.html/granite:queryperformance.

  6. Geben Sie die Abfrage erneut ein und klicken Sie auf „Erklären“.

  7. Die Ausgabe zeigt, welcher Index für die Ausführung der Abfrage verwendet wird.  Wenn der angegebene Index nicht der nodetype-Index ist, stimmt etwas nicht.

  8. Sie müssten debuggen, was einen anderen Index verursacht, um eine niedrigere Kostenschätzung für die Abfrage zurückzugeben.  Lesen Sie in diesen Artikel, wie Sie die Debug-Protokollierung für die Abfrageanalyse aktivieren können.

  9. Wenn der richtige Index ausgewählt wird, aber nicht das korrekte Ergebnis zurückgibt, ist er beschädigt.  Sie müssen den Knotentyp-Index neu indizieren.

  10. Befolgen Sie die Schritte in diesem Artikel, um den Index asynchron neu zu indizieren.

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