Problem
Nach der Anwendung von AEM 6.3 SP1 und CFP1 oder einem späteren Patch auf Systemen, auf denen „SSL am Load Balancer (oder Webserver) beendet ist" [1], können sich Benutzer nicht mehr bei AEM einloggen.
[1] Die Beendigung von SSL am Load Balancer oder Dispatcher bedeutet, dass auf AEM über http:// zugegriffen wird, aber beim Zugriff über den Load Balancer verwenden Sie https://.
Umgebung
AEM 6.3 oder neuere Versionen
Ursache
Es ist ein bekanntes Problem, dass nach der Anwendung des CFP der SslFilter von Apache Felix vor der Authentifizierung nicht mehr funktioniert.
Apache Felix bietet nun einen anderen Mechanismus der Konfiguration über Jetty-Servlet-Engine, zu technischen Details siehe FELIX-5207.
Lösung
Nach der Installation von AEM 6.3 SP1 + CFP1 oder einem späteren Service-Pack / CFP nehmen Sie die folgenden Konfigurationsänderungen vor:
- Melden Sie sich bei http://aem-host:port/system/console/configMgr an.
- Suchen Sie nach Apache Felix Jetty Based Http Service und öffnen Sie die Konfiguration.
- Aktivieren Sie die Einstellung Proxy-/Load Balancer-Verbindung aktivieren und speichern Sie diese.
- Suchen Sie nach Sling-Authentifizierungsdienst und öffnen Sie die Konfiguration.
- Deaktivieren Sie Anonymen Zugriff erlauben und speichern Sie die Konfiguration.
Diese Einstellung funktioniert nur für den Header X-Forwarded-Proto: https. Vergewissern Sie sich, dass Ihr Load Balancer oder Webserver dies an AEM übermittelt, wenn Benutzer eine Verbindung über HTTPS herstellen.
Benutzer sollten sich nach Änderung dieser Einstellungen über den Load Balancer / Dispatcher anmelden können.