Symptômes

Vous avez une page qui contient des caractères spéciaux (par exemple des trémas). Lorsque vous demandez la page au répartiteur, vous ne pouvez pas voir les caractères. Cependant, si vous demandez directement la même page à l’instance Communiquer, vous pouvez voir les caractères.

Cause

Les en-têtes http ne sont pas mis en cache dans le répartiteur et vous stockez probablement le codage dans l’en-tête.

Résolution

Il y a 2 solutions :

1. Si vous utilisez un seul encodage, assurez-vous que l’encodage que vous utilisez sur le serveur Web est le même que l’encodage par défaut de l’instance Communique.

2. Utilisez une balise <META> dans l’en-tête HTML pour définir l’encodage, par exemple :

<META http-equiv="Content-Type" content="text/html; charset=EUC-JP">

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne