1) HtmltoPDF (WebKit Route) NON funziona su AIX per AEM 6.2.
2) HtmltoPDF (WebKit Route) è deprecato su AIX, AEM 6.2 e successivi.
3) HtmltoPDF (WebKit Route) su Linux e Solaris ha una doppia dipendenza da openssl-0.9.x e openssl-1.0.x. Questo è un problema noto che sarà affrontato da una patch ufficiale, ma per il momento può essere fatto funzionare con un workaround che richiede alcune impostazioni aggiuntive come indicato di seguito.

RHEL 6.x e 7.x
Sono necessarie le seguenti librerie aggiuntive a 32 bit (i686) sul sistema:
a. /usr/lib/libcurl.so.3
b. /usr/lib/libssl.so.0.9.6
c. /usr/lib/libcrypto.so.0.9.6
d. /usr/lib/libssl.so.1.0.0
e. /usr/lib/libcrypto.so.1.0.0

I file [a,b,c] sono forniti da compat-libcurl3, che se installato via yum incorpora una dipendenza transitiva da openssl-0.9.6
I file [d,e] sono forniti da openssl-1.0.x. Se non li installa in /usr/lib, puoi creare collegamenti simbolici con questi nomi usando il percorso delle librerie.

Assicurati che siano disponibili le librerie a 32 bit (libicudata.so.42) per la conversione HtmlToPdf basata su Webkit, e le librerie a 64-bit libicudata.so.42 libs per la conversione HtmlToPdf basata su PhantomJS.

L'esistenza di /usr/lib/X11/fonts è obbligatoria. Nelle recenti distribuzioni RHEL, la directory /usr/lib/X11 è stata eliminata, quindi dobbiamo crearla manualmente.
  a) Crea un collegamento simbolico /usr/lib/X11/fonts -> /usr/share/X11/fonts b
  b) Disponibilità di font courier IBM type1. Decomprimere questi font in /usr/share/X11/fonts (all'interno della cartella 'font-ibm-type1-1.0.3')
  c) /usr/share/fonts deve essere presente
  d) Crea un link simbolico /usr/share/fonts/X11_fonts collegato a /usr/share/X11/fonts

Solaris 11
Sono necessarie le seguenti librerie a 32 bit aggiuntive (i686) sul sistema:
a. /usr/lib/libssl.so.0.9.6
b. /usr/lib/libcrypto.so.0.9.6

Se queste librerie non sono presenti in /usr/lib, creare collegamenti simbolici con questi nomi che puntano alle librerie vere e proprie.
libssl.so.0.9.6 -> libssl.so.1.0.0
libcrypto.so.0.9.6 -> libcrypto.so.1.0.0