Nota:

La funzionalità OpenGL in After Effects CS6 è diversa da quella nelle versioni precedenti. Questo documento si applica solo alle versioni di After Effects comprese fra CS4 e CS5.5. Per ulteriori informazioni sulla funzionalità GPU in After Effects CS6, guardate questo video.

Questo documento può aiutarvi a risolvere i problemi relativi a OpenGL che si verificano durante l’utilizzo di After Effects. I problemi di OpenGL possono manifestarsi in diversi modi, tra cui, a titolo di esempio, quelli riportati di seguito:

  • Arresto anomalo o chiusura di Adobe After Effects senza errori durante l’avvio.
  • Arresto anomalo o blocco quando si scorre la timeline o l’anteprima o si esegue il rendering di una composizione.
  • Arresto anomalo quando si modificano le impostazioni di un effetto mentre le anteprime di OpenGL sono attivate.
  • Arresto anomalo o blocco quando si attivano o disattivano le anteprime di OpenGL.
  • La finestra delle composizioni impiega molto tempo a ridisegnare.
  • Artefatti o blocchi di pixel indesiderati vengono disegnati nella finestra di composizione.
  • La finestra di composizione viene disegnata in modo diverso a seconda dell’attivazione o della disattivazione delle anteprime OpenGL.
  • Un messaggio di errore come quelli riportati di seguito:

    "Avvertimento After Effects: si è verificato un problema durante l’elaborazione dei comandi di OpenGL."

    L’istruzione a ’0x00fe1940’ fa riferimento alla memoria a ’0x000000000’ Impossibile leggere la memoria."

    "AE_OpenGL: impossibile generare mappa ombre (5065::0)"

    "La composizione è troppo complessa per l’hardware OpenGL."

    "Errore After Effects: AE_OpenGL: errore creazione texture. (5065 :: 0)"

Per informazioni su come configurare le preferenze di anteprima in After Effects per OpenGL e un elenco di funzioni in After Effects che possono essere sottoposte a rendering con OpenGL, consultate "Eseguire il rendering con OpenGL" nella guida di After Effects.

Per sfruttare al meglio il presente documento, eseguite le operazioni in ordine sequenziale. Prendete nota delle operazioni effettuate e dei relativi risultati, inclusi errori e altri problemi. Ciò consente al supporto tecnico di Adobe di utilizzare queste informazioni per fornire una migliore assistenza in caso di necessità.

Alcune procedure descritte in questo documento richiedono l’accesso come amministratore.

Per Windows, alcune di queste procedure richiedono l’individuazione di cartelle e file nascosti. Altre procedure richiedono la ricerca dei file mediante il nome completo, comprensivo di estensione (ad esempio nomefile_esempio.ini). Per impostazione predefinita, in Esplora risorse non vengono visualizzati file e cartelle nascosti né le estensioni dei file riconosciuti dal sistema. Consultate Visualizzazione di cartelle e file nascosti in Windows per dettagli.

In Windows Vista, le procedure riguardanti il Pannello di controllo in questo documento si riferiscono alla visualizzazione Classica. Per informazioni su come impostare la visualizzazione Classica del Pannello di controllo e su altre procedure comuni nel sistema operativo, consultate Procedure comuni nel sistema operativo.

Queste operazioni possono aiutarvi a risolvere la maggior parte di problemi riscontrati in OpenGL. Prima di effettuare tali operazioni, eseguite il backup di tutti i file personali (ad esempio, i file PSD creati con After Effects). Quando si verifica un errore di sistema, riavviate sempre il computer per aggiornare la memoria. Proseguire nell’utilizzo senza riavviare il computer potrebbe comportare ulteriori problemi.

1. Eseguite l’aggiornamento alla versione più recente di After Effects.

Per verificare la presenza di aggiornamenti, scegliete Aiuto > Aggiornamenti in After Effects.

2. Verificate che il sistema possieda i requisiti minimi richiesti per After Effects.

Per visualizzare l’elenco di requisiti di sistema per After Effects, consultate questa pagina: Requisiti di sistema per Adobe After Effects.

3. Verificate che la scheda video e i driver siano conformi ai requisiti OpenGL.

L’utilizzo di OpenGL in After Effects richiede una scheda OpenGL che supporti OpenGL 2.0.

Per determinare la versione di OpenGL supportata dalla vostra scheda, fate clic sul pulsante Informazioni su OpenGL in Preferenze anteprima. In Mac OS, scegliete After Effects > Preferenze > Anteprime. In Windows, scegliete Modifica > Preferenze > Anteprime.

Per informazioni sull’hardware OpenGL supportato, consultate Funzionalità GPU (CUDA, OpenGL).

I driver della scheda video più recenti possono migliorare le capacità OpenGL della vostra scheda. Consultate Aggiornamento del driver della scheda video di seguito.

4. Disattivate OpenGL per determinare se è la fonte del problema.

Per disattivare le anteprime di OpenGL:

  1. Scegliete After Effects > Preferenze > Anteprime (Mac OS) o Modifica > Preferenze > Anteprima (Windows).
  2. Deselezionate l’opzione Attiva OpenGL.

Nota: OpenGL non supporta alcune funzioni in After Effects e la visualizzazione della composizione può variare se si utilizzano anteprime OpenGL o anteprime di cui è stato eseguito il rendering con software. Per visualizzare le funzioni supportate da OpenGL, consultate Eseguire il rendering con OpenGL nella sezione relativa all’esecuzione di rendering e all’esportazione dell’aiuto di After Effects.

5. Rimuovete il plug-in OpenGL dalla cartella dei plug-in di After Effects.

Per stabilire se il problema è causato da OpenGL, rimuovete il plug-in OpenGL e riavviate After Effects.

Per rimuovere il plug-in OpenGL:

  1. Uscite da After Effects.
  2. Mac OS: trascinate sul desktop il file AE_OpenGL.plugin da Applicazioni/Adobe After Effects CS4/Plug-in/Estensioni.

    Windows: trascinate sul desktop il file AE_OpenGL.AEX da C:\Programmi\Adobe\Adobe After Effects CS4\Support Files\Plug-ins\Extensions.
  3. Riavviate After Effects.

Se il problema persiste, OpenGL non ha causato il problema. Trascinate di nuovo il plug-in OpenGL nella posizione originale. Se il problema non si manifesta significa che OpenGL ne è la causa. Consultate Aggiornamento del driver della scheda video di seguito.

6. Aggiornate il driver della scheda video.

Molti problemi o conflitti di OpenGL vengono risolti aggiornando il driver della scheda video. Numerosi produttori di schede video aggiornano frequentemente il software dei driver. Se il driver della scheda video non è stato aggiornato di recente, contattate il produttore della scheda per richiedere driver aggiornati o scaricate i driver direttamente dal sito Web del produttore.

7. Riavviate After Effects e individuate il comportamento che ha causato l’arresto anomalo. (Solo per Windows)

In seguito a un arresto anomalo causato da un problema di OpenGL in Windows, After Effects CS4 potrebbe disattivare automaticamente la preferenza "Impedisci frammentazione spazio indirizzo DLL". Questa preferenza consente ad After Effects di accedere a una quantità maggiore di RAM contigua, ma potrebbe non essere compatibile con alcuni driver OpenGL.

È possibile attivare o disattivare la preferenza "Impedisci frammentazione spazio indirizzo DLL" in Modifica > Preferenze > Memoria e Cache.

Lasciate disattivata questa preferenza solo se si verificano arresti anomali causati dalla memoria o da OpenGL. Se disattivate la preferenza a causa di un problema di OpenGL e in seguito aggiornate i driver della scheda video, riattivate la preferenza. Quindi, controllate nuovamente se il problema persiste.

8. Ottimizzate la preferenza Memoria texture.

Possono verificarsi arresti anomali o errori di OpenGL se After Effects tenta di utilizzare troppa memoria texture video. La memoria texture corrisponde alla quantità di RAM nella scheda video (VRAM).

Impostate la preferenza Memoria texture in After Effects:

  1. Moltiplicate per l’80% la VRAM installata totale per calcolare l’impostazione ottimale di Memoria texture Memory.
  2. In After Effects, scegliete After Effects > Preferenze > Anteprime (Mac OS) o Modifica > Preferenze > Anteprime (Windows).
  3. Fate clic su Informazioni su OpenGL.
  4. Inserite il valore calcolato nel primo passaggio e fate clic su OK.

Il valore ideale per la memoria texture corrisponde all’80% della VRAM della scheda video. Se utilizzate più schede video, calcolate l’80% della VRAM della scheda video identificata nella finestra di dialogo Informazioni su OpenGL. Se la preferenza Memoria texture in After Effects è impostata su un livello superiore all’80% della VRAM, è possibile che non rimanga abbastanza VRAM per consentire alla scheda video di gestire l’interfaccia utente o altre operazioni. Ad esempio, l’intero schermo può diventare bianco. Se il valore impostato è inferiore all’80%, le anteprime OpenGL in After Effects possono impiegare più tempo per elaborare i fotogrammi.

Consultate l’Aiuto di Mac OS o la Guida di Windows per ulteriori informazioni su come stabilire la quantità di VRAM su una scheda video.

9. Svuotate le cache immagini e la memoria video.

Se After Effects visualizza artefatti o elementi indesiderati (blocchi di pixel errati) nella finestra di composizione, la memoria video (VRAM) potrebbe essere piena, frammentata o corrotta. Svuotate le cache immagini e la memoria video per liberare la VRAM e consentire a After Effects di ricostruire l’anteprima della composizione.

Per svuotare le cache immagini, scegliete Modifica > Svuota > Cache immagini.

Per svuotare la memoria video, scegliete Modifica > Svuota > Memoria video.

Nota: alcuni screen saver che utilizzano OpenGL (o Direct3D in Windows) possono danneggiare la memoria video se si attivano mentre After Effects è in esecuzione. Modificate o disattivate lo screen saver se si verificano di frequente problemi con immagini corrotte nella finestra di composizione dopo aver disabilitato lo screen saver.

10. Regolate l’impostazione dei colori per la scheda video su Massima (a 32 bit) (Windows) o Milioni (Mac OS).

Consultate l’Aiuto di Mac OS o la Guida di Windows per ulteriori informazioni su come modificare o visualizzare le impostazioni della scheda video.

11. Disattivate le funzioni avanzate della scheda video. (Solo per Windows)

La maggior parte dei driver della scheda grafica include utility che consentono di accedere alle funzioni avanzate della scheda. In particolare, le funzioni Antialiasing e modalità a 16 bit possono entrare in conflitto con OpenGL e causare un arresto anomalo di After Effects. Impostate le funzioni avanzate della scheda sui valori predefiniti, quindi disattivate le opzioni Antialiasing e modalità a 16 bit.

Se state utilizzando più schermi con una scheda Nvidia, regolate l’impostazione Multimonitor su "Compatibile".

Consultate la documentazione relativa alla scheda video o il sito Web del produttore per istruzioni su come accedere alle funzioni avanzate della scheda video.

12. Utilizzate un solo monitor.

Se state utilizzando più monitor e si verificano problemi con OpenGL in After Effects, provate le seguenti soluzioni:

  • Se avete spostato la finestra dell’applicazione di After Effects o il pannello Composizione sul secondo monitor, portatela sul monitor principale.
  • Lasciate collegato solo un monitor.
  • Se state utilizzando più schede grafiche, lasciate collegata solo una scheda. Per ottenere risultati migliori con OpenGL, utilizzate una scheda grafica singola per due monitor.

13. Inserite lo script relativo alla riduzione delle dimensioni texture OpenGL nella cartella degli script di avvio.

Questo script riduce la quantità della memoria texture utilizzata da After Effects e può migliorare la compatibilità con schede video meno recenti.

Per posizionare lo script nella cartella degli script di avvio:

  1. Andate alla cartella degli script di After Effects.

    In Mac OS: Applicazioni/Adobe After Effects CS4/Script.

    In Windows: C:\Programmi\Adobe\Adobe After Effects CS4\Support Files\Scripts.
  2. Spostate il file Reduce OpenGL Texture Size.jsx dalla cartella (supporto) alla cartella Avvio.

Una scheda video più recente può migliorare le capacità di OpenGL del vostro computer e rendere così superfluo lo script. Dopo aver installato una nuova scheda e i relativi driver, spostate nuovamente lo script nella cartella (supporto), quindi reimpostate le preferenze di After Effects.

14. Ripristinate le preferenze di After Effects.

Create nuovamente il file delle preferenze di After Effects per eliminare i problemi che possono essere causati dalle preferenze di OpenGL.

Per ricreare il file delle preferenze di After Effects, riavviate After Effects. Premete Ctrl+Alt+Maiusc (Windows) o Comando+Opzione+Maiusc (Mac OS) durante l’avvio dell’applicazione.

15. Contattate il supporto tecnico di Adobe.

Se nessuna delle soluzioni indicate in precedenza consente di risolvere l’errore o il blocco di After Effects, contattate il supporto tecnico di Adobe. Le opzioni di supporto disponibili sono reperibili nel supporto tecnico Adobe.

 

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online