Scopri le nuove funzioni e i miglioramenti inclusi nella versione di aprile 2019 di After Effects (versione 16.1).
1_content

Correggere video rimuovendo oggetti indesiderati dal video con lo strumento Riempimento in base al contenuto

Rimuovi dal metraggio oggetti indesiderati, come persone, microfoni con asta e cartelli che distolgono l’attenzione. Basata su Adobe Sensei, la funzione Riempimento in base al contenuto facilita la rimozione degli elementi indesiderati, con un notevole risparmio di tempo rispetto agli interventi tradizionali che richiedevano diverse ore per cancellare o sostituire oggetti, agendo talvolta fotogramma per fotogramma.

2_expression

Miglioramenti apportati all’editor espressioni

Il campo dell’editor espressioni nel pannello Timeline fornisce ora un’interfaccia completa dell’editor di codice. Esplora le espressioni in modo visivo, utilizzando i numeri di riga, l’evidenziazione delle parentesi graffe corrispondenti e la riduzione del codice. Personalizza l’ambiente di scrittura del codice con temi di evidenziazione della sintassi. Identifica e risolvi i problemi relativi ai messaggi di errore in linea e l’evidenziazione delle parentesi graffe corrispondenti.


3_performance_improvementcopy

Miglioramenti relativi alle prestazioni

Visualizza rapidamente l’anteprima del lavoro con anteprime con accelerazione hardware utilizzando Metal, OpenCL e CUDA. Velocizza il rendering durante l’applicazione di effetti basati sulla GPU come Bordi ruvidi. Se utilizzi Progetti team, velocizza il lavoro quando condividi più risorse tra i membri del team.

4_guides_copy

Salvare righelli e guide da condividere con esperti di editing

Ora puoi caricare e salvare le impostazioni delle guide per riutilizzarle in nuovi progetti e condividerle con gli esperti di editing di Premiere Pro che le usano per impostare i parametri della sequenza.



5_font_1_

Sincronizzazione automatica dei font Adobe

Quando apri in After Effects un progetto che contiene un font mancante, Creative Cloud sincronizzerà automaticamente il font se disponibile in Adobe Fonts, un servizio incluso nell’abbonamento Creative Cloud.

6_video_audio

After Effects introduce miglioramenti relativi al supporto del formato raw delle videocamere RED e Sony, nonché miglioramenti relativi alla decodifica HEVC con accelerazione hardware per migliorare le prestazioni audio e video.


7_pref

After Effects introduce nuove preferenze per la schermata e il pulsante Home. Le preferenze esistenti relative agli script e alle espressioni sono state spostate dal riquadro Preferenze generali al nuovo riquadro Script ed espressioni.

8_update_legacy

Con After Effects viene installato il nuovo script Update Legacy Expressions.jsx che analizza tutta la sintassi di versioni precedenti nelle espressioni e la aggiorna per renderla compatibile con il nuovo motore JavaScript per espressioni.



9_frame_blending1

Quando attivi o disattivi le opzioni Fusione fotogrammi o Effetto movimento per un livello, After Effects li attiva o li disattiva automaticamente nel pannello Timeline.

10_scripting_changes

In After Effects sono state aggiunte più funzionalità di script alle seguenti funzioni:

  • Nomi e conteggio degli elementi nel pannello Grafica essenziale
  • Guide e righelli

11_team_project

Grazie a funzionalità migliorate per gli spostamenti nelle ricerche e alla stessa interfaccia utente di Progetti team presente sia in After Effects che in Premiere Pro, puoi risparmiare tempo e semplificare i flussi di lavoro in Progetti team.

12_more

Informazioni su altri miglioramenti aggiunti in questa versione, come il comando Modifica originale aggiunto al sottomenu Apri del menu di scelta rapida del livello.



Rimuovere oggetti indesiderati dai video con lo strumento Riempimento in base al contenuto

Lo strumento Riempimento in base al contenuto in After Effects consente di riempire le parti vuote nei video che si sono create in seguito alla rimozione di oggetti o aree indesiderate. After Effects analizza i fotogrammi in un dato arco di tempo e sostituisce i pixel mancanti copiandoli da altri fotogrammi.

Per rimuovere gli oggetti indesiderati da una clip video, crea una maschera o ritaglia un oggetto e fai clic su Genera livello di riempimento. Utilizzando una tecnologia di flusso ottico, After Effects fa riferimento ai fotogrammi prima, accanto o dopo l’oggetto e riempie la maschera con i pixel vicini o dati immagine provenienti da altre aree del video, cancellando di fatto ogni traccia dell’oggetto.

Per altre informazioni, consulta Rimuovere oggetti dai video con Riempimento in base al contenuto.

Miglioramenti apportati all’editor espressioni

Hai ora a disposizione un modo più semplice e veloce per scrivere espressioni. L’editor espressioni è un editor di codice completo, che include evidenziazione della sintassi, numeri di riga e altre funzioni che consentono di cambiare il colore del testo per segnalare effetti, numeri o la modifica della dimensione del font per facilitare la lettura. Inoltre, identifica in modo immediato e automatico gli errori nel codice ed evita quindi di doverli cercare manualmente. Popola anche automaticamente le espressioni più comunemente usate. Con questo nuovo editor non è più necessario utilizzare un editor di terze parti per scrivere codice.

Per altre informazioni, consulta Miglioramenti apportati all’editor espressioni.

Miglioramenti relativi alle prestazioni

Questa versione include i seguenti miglioramenti relativi alle prestazioni:

After Effects ora utilizza Metal, OpenCL o CUDA anziché OpenGL quando in Preferenze > Visualizzazione è attivata l’opzione Accelerazione hardware per pannelli Composizione, Livello e Metraggio. Questa preferenza è attivata per impostazione predefinita.

Durante la riproduzione delle anteprime, le aree dell’interfaccia utente nei pannelli Composizione, Livello, Metraggio e Timeline vengono aggiornate meno frequentemente. Questo migliora le prestazioni complessive di riproduzione e risolve problemi specifici legati all’impossibilità di eseguire la riproduzione in tempo reale in determinate situazioni.

Per il rendering dei seguenti effetti, viene ora utilizzata la GPU del computer quando l’opzione Impostazioni > Rendering video ed effetti > Utilizzo è impostata su Accelerazione GPU Mercury:

  • Modifica colore
  • Bordi ruvidi

Salvare righelli e guide da condividere con esperti di editing

Le guide nei pannelli visualizzatore Composizione, Livello e Metraggio possono ora essere importate ed esportate utilizzando i nuovi comandi Importa guide ed Esporta guide, disponibili nel menu Visualizza.

Durante l’esportazione delle guide, viene creato un file modello (.guides) che può essere condiviso o importato in altri progetti, oppure in un’altra visualizzazione Composizione, Livello o Metraggio. Un file modello di guide contiene i dati JSON che registrano gli attributi delle guide. Durante l’esportazione, vengono esportate tutte le guide presenti nella visualizzazione corrente.

Puoi anche importare file di guide creati da After Effects in Premiere Pro 13.1 e viceversa.

Sincronizzazione automatica dei font Adobe

Gli abbonamenti a Creative Cloud includono l’accesso alla libreria completa di Adobe Fonts. Con gli abbonamenti di prova a Creative Cloud viene fornita la libreria di base, che include una selezione di font utilizzabili in ambiente Web e desktop. I font di terze parti acquistati da Adobe Fonts non vengono sincronizzati automaticamente.

Miglioramenti relativi al supporto dei formati di importazione audio e video

Miglioramenti relativi al supporto del formato raw delle videocamere RED e Sony

In After Effects è ora disponibile il supporto migliorato per l’importazione di file video nei seguenti formati raw nativi delle videocamere:

  • È ora possibile eseguire la rimozione Bayer dei filmati RED (.r3d) sulla GPU quando il progetto è impostato per l’uso dell’accelerazione GPU Mercury (Metal) in macOS. In precedenza, la rimozione Bayer del formato RED funzionava solo per OpenCL e CUDA.
  • È possibile importare metraggio Sony VENICE X-OCN (.mxf) registrato da videocamere VENICE che includono l’aggiornamento del firmware dell’inizio del 2019.

Miglioramenti relativi alla decodifica HEVC con accelerazione hardware

After Effects decodifica ora più velocemente il metraggio video HEVC in Windows. Con la decodifica con accelerazione hardware del montaggio video HEVC sia in macOS che in Windows viene ora accelerata anche la decodifica dei file HEVC a 10 bit per canale. Come per il precedente supporto per le riprese H.264 o HEVC a 8 bit per canale, anche per la decodifica con accelerazione hardware è richiesto Windows 10 o macOS 10.13 e superiore e un processore Intel con Quick Sync Video.

La decodifica con accelerazione hardware del metraggio video HEVC e H.264 è attivata per impostazione predefinita. Per disattivarla, apri Preferenze > Importa e disattiva l’opzione Abilita decodifica con accelerazione hardware.

Modifiche apportate alle preferenze

Preferenza per la schermata e il pulsante Home

L’opzione nel pannello Preferenze generali che consente di visualizzare la schermata Home all’avvio di After Effects è stata rinominata Attiva schermata Home. Tale opzione rimane attivata per impostazione predefinita. Se si disattiva questa opzione, viene nascosto anche il pulsante Home nel pannello Strumenti. Entrambe le modifiche diventano effettive al successivo avvio di After Effects.

Script ed espressioni

Le seguenti preferenze esistenti relative agli script e alle espressioni sono state spostate dal pannello Preferenze generali al nuovo riquadro Script ed espressioni:

  • Consenti agli script di scrivere i file e accedere alla rete
  • Attiva debugger JavaScript
  • Il selettore espressioni usa inglese compatto
  • Mostra banner di avvertenza se il progetto contiene errori di espressione

Il pannello Script ed espressioni contiene anche le opzioni correlate al nuovo editor espressioni. Per altre informazioni, consulta Miglioramenti apportati all’editor espressioni.

Script di aggiornamento delle espressioni di versioni precedenti

Con After Effects viene installato il nuovo script Update Legacy Expressions.jsx, disponibile dal menu File > Script. Questo script analizza tutta la sintassi di versioni precedenti nelle espressioni e la aggiorna per renderla compatibile con il motore JavaScript per espressioni.

In particolare, questo script analizza composizioni, livelli o proprietà alla ricerca di espressioni contenenti una sintassi che funzionava con il precedente motore ExtendScript, ma che non è compatibile con il motore JavaScript e la modifica per renderla compatibile:

  • Le istruzioni if...else su un’unica riga vengono modificate in modo da includere un’interruzione di riga prima dell’istruzione else.

  • I blocchi delle funzioni vengono spostati all’inizio dell’espressione (corrispondenza tramite regex).

  • I riferimenti abbreviati al livello this vengono modificati in thisLayer.
  • Ai riferimenti degli indici di matrice del testo sorgente, ad esempio sourceText[n], viene aggiunto .value.
  • Metodi e proprietà di tipo snake_case vengono sostituiti con gli equivalenti di tipo camelCase (corrispondenza tramite coppie chiave:valore).

Attivazione e disattivazione automatica degli switch di composizione Fusione fotogrammi ed Effetto movimento

Quando attivi Fusione fotogrammi ed Effetto movimento per un livello, gli switch di composizione corrispondenti nel pannello Timeline vengono ora attivati automaticamente (se erano disattivati). Con questa funzione, non devi più fare clic su un secondo switch per eseguire il rendering delle anteprime di Fusione fotogrammi o Effetto movimento. È comunque possibile attivare o disattivare manualmente lo switch di composizione.

Allo stesso modo, quando disattivi Fusione fotogrammi o Effetto movimento in tutti i livelli, gli switch di composizione corrispondenti vengono disattivati automaticamente (se erano attivati).

Per ripristinare il comportamento precedente (attivazione o disattivazione manuale degli switch di composizione), disattiva la nuova opzione Attiva automaticamente fusione fotogrammi e rendering dell’effetto movimento, in Preferenze > Anteprime.

Modifiche apportate alla funzione di script

In questa versione di After Effects è stato aggiunto il supporto per gli script alle seguenti funzioni:

  • Conteggio ed elementi del pannello Grafica essenziale: ora puoi contare il numero di elementi per una data composizione nel pannello Grafica essenziale, ottenere o impostare i nomi degli elementi oppure impostare il nome di un elemento mentre viene aggiunto.
  • Guide e righelli: ora puoi impostare la visibilità di guide e righelli oppure attivare o disattivare il blocco e l’aggancio delle guide nei pannelli visualizzatore. Puoi anche aggiungere, rimuovere o modificare il valore delle guide.

Miglioramenti relativi a Progetti team

  • La finestra di dialogo Gestisci progetti team include ora un campo di ricerca in ognuna delle tre schede.
  • In Premiere Pro, il comando Modifica originale ora consente di aprire una composizione in After Effects.
  • In Premiere Pro, il comando File > Adobe Dynamic Link > Nuova composizione After Effects consente ora di creare una composizione in After Effects.

Altre funzioni

  • Al menu Livelli è stato aggiunto il sottomenu Rivela. Questo menu è identico al sottomenu Rivela nel menu di scelta rapida del livello, accessibile facendo clic con il pulsante destro del mouse su un livello nel menu Timeline. Ora è anche possibile assegnare scelte rapide da tastiera ai comandi del sottomenu Rivela, tra cui Rivela sorgente livello nel progetto.
  • Il comando Modifica originale è stato aggiunto al sottomenu Apri del menu di scelta rapida del livello, accessibile facendo clic con il pulsante destro del mouse su un livello nel menu Timeline. Si tratta dello comando presente nel menu Modifica > Modifica originale.
  • Nell’effetto Curve, la curva alfa viene ora disegnata con una linea tratteggiata anziché una linea nera continua, in modo da renderla più visibile rispetto al colore di sfondo dell’interfaccia utente.
  • Diversi comandi del menu di scelta rapida del livello di testo nel menu Composizione (accessibile, ad esempio, quando si fa clic con il pulsante destro del mouse su un livello di testo con lo strumento Testo) ora funzionano quando sono selezionati più livelli di testo: Converti in testo paragrafo, Converti in testo indipendente, Orientamento orizzontale, Orientamento verticale (l’orientamento deve essere lo stesso per tutti i livelli di testo selezionati) e Rivela testo sorgente nella timeline.
  • Ora è possibile selezionare contemporaneamente file JSX e JSXBIN nelle finestre di dialogo File > Script > Installazione file script in corso e Installazione pannello ScriptUI in corso.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online