Visualizzazione del contenuto dell'aiuto per la versione :

Nella sezione seguente vengono descritti alcuni problemi che potreste riscontrare durante l’utilizzo di AEM e vengono proposte possibili soluzioni.

Nota:

Quando si verificano problemi, è anche utile controllare la lista dei Problemi noti per l'istanza (release e service pack).

Nota:

Gli utenti con diritti di amministratore possono seguire i metodi di risoluzione di problemi descritti in Troubleshooting AEM (for Administrators) (Risoluzione di problemi in AEM - Per amministratori). Se non disponete delle autorizzazioni necessarie, rivolgetevi al vostro amministratore di sistema.

La vecchia versione della pagina è ancora nel sito pubblicato

  • Problema:
    • Avete apportato delle modifiche a una pagina e l’avete replicata sul sito pubblicato, ma nel sito pubblicato viene ancora visualizzata la vecchia versione della pagina.
  • Motivo:
    • Questo può dipendere da diverse cause. In genere si tratta di un problema di cache (del browser locale o del Dispatcher), ma a volte può dipendere da un problema relativo alla coda di replica.
  • Soluzioni:
    • Sono disponibili diverse possibilità:
    • Verificate che la pagina sia stata replicata correttamente. Controllate lo stato della pagina e, se necessario, lo stato della coda di replica.
    • Cancellate la cache del browser locale e accedete di nuovo alla pagina.
    • Aggiungete ? alla fine dell’URL della pagina. Esempio:
          http://localhost:4502/sites.html/content?
      Questo fa sì che la pagina venga richiesta direttamente da AEM senza passare dal Dispatcher. Se viene visualizzata la pagina aggiornata, significa che è necessario cancellare la cache del Dispatcher.
    • In caso di problemi relativi alla coda di replica, rivolgetevi al vostro amministratore di sistema.

Azioni per componenti non visibili sulla barra degli strumenti (interfaccia touch)

  • Problema:
    • Non tutte le azioni disponibili per i componenti sono visibili quando si modifica il contenuto di una pagina nell’ambiente di authoring.
  • Motivo:
    • In rari casi, un’azione precedente potrebbe pregiudicare il funzionamento della barra degli strumenti.
  • Soluzione:
    • Aggiornate la pagina.

Barra laterale non visibile (interfaccia classica)

  • Problema:
    • La barra laterale non è visibile quando si modifica il contenuto di una pagina nell’ambiente di authoring.
  • Motivo:
    • In alcuni rari casi è possibile che l’intestazione della barra laterale sia stata posizionata oltre l’ambito della finestra corrente e non potete quindi riposizionarla.
  • Soluzione:
    • Disconnettetevi dalla sessione corrente ed effettuate di nuovo l’accesso. La barra laterale torna nella sua posizione predefinita.

Trova e sostituisci - Non vengono sostituite tutte le istanze (interfaccia cassica)

  • Problema:
    • Quando si utilizza l’opzione Trova e sostituisci è possibile che non vengano sostituite tutte le istanze del termine da trovare presenti sulla pagina.
  • Motivo:
    • La funzione Trova e sostituisci dipende da come è stato salvato il contenuto e se supporta la funzione di ricerca. Ad esempio il testo di un blog è archiviato nella proprietà jcr:text che non è configurato per la ricerca. L’ambito predefinito del servlet di ricerca e sostituzione include le seguenti proprietà:
      • jcr:title
      • jcr:description
      • jcr:text
      • text
  • Soluzione:
    • Le definizioni possono essere modificate con la configurazione per Day CQ WCM Find Replace Servlet tramite la console Web; ad esempio in
         http://localhost:4502/system/console/configMgr

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online