L'istanza AEM si arresta con OutOfMemoryError a causa di Jetty Sessions

Problema

AEM si arresta con o senza OutOfMemoryError. La segnalazione di perdite sospette da Eclipse Memory Analyzer Tool (MAT) mostra org.eclissi.jetty.server.session.HashedSession che consuma la maggior parte del heap.

Esempio di uscita da Eclipse MAT

1.650.055 istanze di “org.eclipse.jetty.jetty.server.session.HashedSession”, caricate da “org.apache.felix.framework.BundleWiringImpl$BundleClassLoaderJava5 @ 0x6c279ad00” occupano 2.292.147.984 (51,04%) byte. Queste istanze sono riferite da un'istanza di “java.util.concurrent.concurrent.ConcurrentHashMap$Node[]”, caricata da “”

Parole chiave
java.util.concurrent.concurrentHashMap$Node[]
org.eclipse.jetty.server.session.hashedSession
org.apache.felix.framework.BundleWiringImpl$BundleClassLoaderJava5 @ 0x6c279ad00

Ambiente

AEM 6.0, 6.1

Causa

Si tratta di un fisso problema noto in AEM 6.2.  Le sessioni Jetty non avevano un time out predefinito configurato in AEM 6.0 e 6.1.

Risoluzione

  1. Vai su http://host:port/system/console/configMgr/org.apache.felix.http

  2. Impostare un valore ragionevole nella Sessione Timeout

  3. Salva

Logo Adobe

Accedi al tuo account